Иллюстрированный самоучитель AutoCAD 2004

  • Предисловие
  • Глава 1. Общие сведения
  • Глава 2. Примитивы
  • Глава 3. Редактирование геометрии
  • Глава 4. Свойства
  • Глава 5. Стили и стандарты
  • Глава 6. Печать
  • Глава 7. Блоки и внешние ссылки
  • Глава 8. Операции над объектами других форматов
  • Глава 9. Трехмерные построения
  • Глава 10. Пространство листа
  • Глава 11. Повышение эффективности работы
  • Приложение 1. Перечень команд AutoCAD
  • Приложение 2. Перечень системных переменных
  • Приложение 3. Операции с сетью Интернет
  • Приложение 4. Сопутствующие программные продукты


Глава 1. Общие сведения

    • 1.1. Назначение системы
    • 1.2. Требования к компьютеру
    • 1.3. Пользовательский интерфейс
    • 1.4. Способы ввода команд
    • 1.5. Операции с файлами рисунков
    • 1.6. Текстовое окно
    • 1.7. Единицы измерения


1.1. Назначение системы

Первые версии системы AutoCAD, разрабатываемой американской фирмой Autodesk, появились еще в начале 80-х годов двадцатого века, и сразу же привлекли к себе внимание своим оригинальным оформлением и удобством для пользователя. Постоянное развитие системы, учет замечаний, интеграция с новыми продуктами других ведущих фирм (в первую очередь, Microsoft), сделали AutoCAD мировым лидером на рынке программного обеспечения.
Широкое распространение системы в России началось с десятой версии, которая работала в операционной системе MS DOS. В такой же операционной системе могли работать одиннадцатая, двенадцатая и тринадцатая версии, однако появились и аналоги, которые могли работать в среде операционной системы Windows (Windows 3.1 или Windows 95). Четырнадцатая версия системы AutoCAD вышла уже только в Windows-варианте, и была рассчитана на операционные системы Windows 95 и Windows NT.
В 1999 году началось внедрение 15-й версии, которая известна как AutoCAD 2000. Вслед за ней, с интервалом в один год, выходили AutoCAD 2000i и AutoCAD 2002. Все они связаны между собой единым форматом хранения данных.
Рассматриваемая в данной книге версия AutoCAD 2004 (внутренний номер — 16) появилась в марте 2003 года. Работоспособность этой версии в средах Windows 95 и Windows 98 уже не гарантируется. Для установки версии рекомендуется одна из следующих операционных систем:

  • Windows 2000;
  • Windows XP (Professional Edition);
  • Windows XP (Home Edition);
  • Windows NT 4.0 (с обновлением Service Pack 6a или более поздним).

Система AutoCAD 2004 может использоваться в локальном или сетевом варианте. Для ее нормального функционирования требуется получить специальный код авторизации от фирмы Autodesk.
Первые версии AutoCAD содержали в основном инструменты для простого двумерного рисования, которые постепенно дополнялись и развивались. В результате система стала очень удобным "электронным кульманом". На рис. 1.1 приведен пример двумерного чертежа, сделанного сравнительно простыми средствами AutoCAD. Для формирования такого чертежа не требуется работа с трехмерной моделью изделия.

Рис. 1.1. Двумерный чертеж

Большим преимуществом системы AutoCAD, как средства рисования, является возможность последующего формирования электронного архива чертежей. Каждый из созданных таким образом файлов рисунков легко редактируется, что позволяет быстро получать чертежи-аналоги по чертежам-прототипам. В качестве средств защиты от несанкционированного доступа в файлах рисунков, созданных системой AutoCAD 2004, предусмотрены пароли и электронные цифровые подписи.
Для облегчения процесса выпуска проектной документации можно разрабатывать "библиотеки стандартных элементов". В качестве стандартных элементов могут выступать как целые файлы, так и их отдельные части. Эта идея стала хорошим стимулом для создания на базе системы AutoCAD локальных рабочих мест по различным конструкторским, архитектурным и другим направлениям, а также для разработки новых специализированных систем. Мощным дополнением к этому является возможность использования языков программирования.
Начиная с AutoCAD 2002, в систему включены специальные средства для контролирования стандартов предприятий, позволяющих управлять слоями, стилями и т. п. Подробнее о стандартах см. гл. 4.
Уже десятая версия AutoCAD позволяла выполнить достаточно сложные трехмерные построения в любой плоскости пространства и отобразить их на разных видовых экранах с различных точек зрения. Поэтому она стала также инструментом и трехмерного моделирования. Механизм пространства листа и видовых экранов дал возможность разрабатывать чертежи с проекциями трехмерных объектов или сооружений. В системе AutoCAD по одной модели можно получить несколько листов чертежного документа. На рис. 1.2 приведен пример чертежа, сформированного как отображение проекций и сечений трехмерного объекта.

Рис. 1.2. Чертеж части устройства дверного замка

На рис. 1.3 показана модель корпуса судна, являющаяся основой для последующего формирования чертежа и построения контуров деталей. Степень проработанности, а также сложность и насыщенность такой модели могут быть разными и определяются тем, как она будет в дальнейшем использована.

Рис. 1.3. Трехмерная модель платформы


1.2. Требования к компьютеру

Персональный компьютер, на котором может быть установлена система AutoCAD 2004, должен удовлетворять определенным минимальным требованиям. Этим требованиям соответствует компьютер не ниже Pentium III с процессором 500 МГц, оперативной памятью 256 Мбайт, винчестером (жестким диском) 2 Гбайта — на винчестере надо иметь свободными 350 Мбайт под программное обеспечение, и не менее 250 Мбайт для временных файлов, которые система образует во время сеансов работы. И конечно, на винчестере должно оставаться место для хранения создаваемых файлов чертежей. На компьютере должна быть установлена одна из операционных систем, перечисленных в разд. 1. 1.
Основные особенности системы AutoCAD 2004 — это отсутствие Windows 98 в списке допустимых операционных систем, поддержка многопроцессорных компьютеров, работа в сетевом и локальном вариантах. Нет точных данных о совместимости этой версии AutoCAD с Windows ME.


1.3. Пользовательский интерфейс

Итак, вы установили систему AutoCAD 2004 и готовы начать работу. Запуск системы осуществляется с помощью двойного щелчка левой кнопки мыши по ярлыку [image] , расположенному на рабочем столе. Другой способ запуска — использование меню Пуск (Start) рабочего стола Windows (Пуск | Программы | Autodesk | AutoCAD 2004 | AutoCAD 2004).
Сразу после старта системы открывается стандартное диалоговое окно Startup (Начало работы) (рис. 1.4), в котором необходимо выбрать режим работы. В системах AutoCAD 2000i и AutoCAD 2002 был другой вариант начала — диалоговое окно AutoCAD Today (Проектный центр), который был доступен помимо стандартного. В рассматриваемую версию системы AutoCAD этот вариант не включен.

Рис. 1.4. Диалоговое окно Startup (режим Start from Scratch)

В диалоговом окне Startup (Начало работы) пользователю необходимо подвести указатель мыши к одной из больших кнопок с режимами начала работы, изображенных в верхней части окна:

  • Open a Drawing (Открытие рисунка);
  • Start from Scratch (Простейший шаблон);
  • Use a Template (По шаблону);
  • Use a Wizard (Вызов мастера).

Затем следует щелкнуть левой кнопкой мыши. После этого выбранная вами большая кнопка изменит свое состояние на "нажатая", а содержимое текста надписи, расположенной в правой верхней части окна, модифицируется на название кнопки. Для завершения работы с диалоговым окном остается только щелкнуть левой кнопкой мыши по кнопке ОК.
Если вам необходимо создать новый пустой рисунок, то в окне Startup (Начало работы) нужно воспользоваться кнопкой Start from Scratch (Простейший шаблон) (см. рис. 1.4). Этот режим предлагается по умолчанию. В нем создается новый пустой чертеж с минимумом установок. Пользователю только нужно отметить, в каких единицах измерения он будет работать: Imperial (feet and inches) (Английские (футы и дюймы)) или Metric (Метрические). Второй вариант, конечно, в этом случае для нас предпочтительнее.
При выборе режима Use a Template (По шаблону) пользователь имеет возможность начать работу не с нуля, а с каким-то наполнением нового рисунка (это могут быть рамки, штампы и какие-то другие линии или установки). Подробнее работа с шаблонами разбирается в гл. 10.
Режим Use a Wizard (Вызов мастера) дает возможность вызвать одну из программ-мастеров настройки нового рисунка. Работа мастеров разобрана в разд. 1.7 на примере мастера детальной подготовки нового чертежа.
Будем считать, что читатель для первого раза воспользуется режимом по умолчанию Start from Scratch. В открывшемся окне (рис. 1.5) разберем элементы оформления рабочего окна AutoCAD.
Центральная часть экрана — это основная рабочая зона, в которой находится видимая часть рисунка (остальные его части могут находиться выше, правее, ниже и левее). При движении курсора по этой части, которую мы будем называть далее графическим экраном, он (курсор) имеет вид перекрестия с квадратной мишенью в точке пересечения (на рис. 1.5 — обозначен номером 12). Длина линий перекрестия настраивается с помощью системной переменной CURSORSIZE (см. разд. 11.1).
В левом нижнем углу графического экрана находится знак осей системы координат (обозначенный цифрой 4). При необходимости знак может быть настроен или приведен к виду, который он имел в AutoCAD 2000 (см. гл. 9).

Рис. 1.5. Элементы пользовательского интерфейса: 1 —строка меню, 2 — панели инструментов, 3 — панель Tool Palettes, 4 — пиктограмма осей координат, 5 — кнопки показа списка вкладок, 6 — вкладка пространства модели, 7 — вкладки листов, 8 — строка состояния со счетчиком координат, 9 — кнопки режимов, 10 — Communication Center, 11 — зона командных строк, 12 — курсор, 13 — линейки прокрутки, 14 — кнопки управления окном документа

Верхнюю строку экрана (1), состоящую из надписей: File (Файл), Edit (Правка), View (Вид), Insert (Вставка), Format (Формат), Tools (Сервис), Draw (Рисование), Dimension (Размеры), Modify (Редакт), Express (Экспресс), Window (Окно), Help (Справка) — будем называть строкой меню. Эта строка содержит наименования падающих меню, раскрыть любое из которых можно, выбрав с помощью мыши соответствующее имя меню.
Графический экран снизу обрамляют кнопки вкладок Model (Модель) (элемент 6), Layout 1 (Лист!) и Layout 2 (Лист2) (элементы 7). Вкладки используются при переключении между пространствами модели и листа (см. гл. 10). По умолчанию активной является вкладка Model (Модель). Треугольные кнопки (5) слева от имен вкладок позволяют передвигаться по списку вкладок в обоих направлениях (аналогично движению по списку листов в книге Microsoft Excel).
Справа от вкладок расположена горизонтальная линейка прокрутки для графического экрана (в случае ее отсутствия у вас изменена настройка AutoCAD — см. гл. 11). Вертикальная линейка прокрутки расположена по правой границе графического экрана. Обе линейки прокрутки на рис. 1.5 обозначены номером 13.
Нижняя часть экрана (11), в которой вы на рис. 1.5 видите приглашение в форме Command: (Команда:) — это область, через которую в основном происходит диалог пользователя с системой, здесь отображаются вводимые вами команды и ответы (или вопросы) AutoCAD. Эту часть будем называть зоной командных строк. Последняя строка, содержащая приглашение Command: (Команда:), называется командной строкой.
Ниже от зоны командных строк находится строка состояния (8), в которой расположены счетчик координат и прямоугольные кнопки режимов (9): SNAP (ШАГ), GRID (СЕТКА), ORTHO (OPTO), POLAR (OTC-ПОЛЯР), OSNAP (ПРИВЯЗКА), OTRACK (ОТС-ПРИВ), LWT (ВЕС), MODEL (МОДЕЛЬ). Счетчик координат служит для ориентировки на поле чертежа — он изменяет свое трехкоординатное значение при движении указателя мыши по графическому экрану. Счетчик может быть отключен с помощью функциональной клавиши <F6>. Нажатием на ту же клавишу счетчик можно снова включить. Другой способ включения и выключения счетчика — щелчок левой кнопкой мыши по строке счетчика. Описание режимов, кнопки которых показаны в строке состояния, приведено в разд. 2.4.
Кнопка [image] (10), появившаяся только в версии AutoCAD 2004, предназначена для вызова диалогового окна Communication Center (Центр связи), которое дает возможность при наличии соединения с Интернетом оперативно получать сведения об обновлениях, выпущенных фирмой Autodesk. Работа с этим окном рассматривается в приложении 3.
Основным элементом пользовательского интерфейса являются кнопки панелей инструментов. Четыре горизонтальные панели на рис. 1.5 находятся ниже строки меню. Еще две вертикальные панели находятся слева от графического экрана.
Все панели инструментов в системе AutoCAD 2004 оформлены в стиле Windows XP (с использованием серо-голубой гаммы цветов). Если вы подведете курсор к какой-нибудь пиктограмме любой панели, то пиктограмма сразу примет форму прямоугольной кнопки, а через несколько мгновений под указателем появится всплывающая подсказка с наименованием команды или функции AutoCAD, выполняемой с помощью этой кнопки. На рис. 1.6 показана подсказка, появляющаяся при положении верхней точки указателя мыши над кнопкой команды LINE (ОТРЕЗОК).

Рис. 1.6. Всплывающая подсказка

Одновременно в строку состояния выводится справочная информация к команде (рис. 1.7):
Creates straight line segments: LINE (Создает прямолинейные отрезки: ОТРЕЗОК)

Рис. 1.7. Справка в строке состояния

Шесть панелей, которые показаны на рис. 1.5, находятся в фиксированном положении. При желании можно перенести их внутрь графического экрана, где они займут "плавающее" положение, принимая одновременно форму окон Windows (рис. 1.8). Для этого нужно аккуратно подвести указатель мыши к краю панели (но не задевая кнопок инструментов!), нажать левую кнопку мыши и, не отпуская ее, перетащить панель на свободное место экрана, после чего отпустить левую кнопку.
В плавающем положении панели могут принимать разную форму, которую можно изменять, растягивая их за углы. Для перемещения панели на новое место следует перетащить ее с помощью мыши за синюю область с наименованием. Перемещение панели на один из четырех краев графического экрана позволяет вернуть ее к фиксированному положению. Таким образом, пользователь может сам найти для себя наиболее удобный способ расположения и формы панелей.
Все панели имеют имена. Если курсор находится на выпуклых полосках [image] в начале панели, то в строку состояния выводится имя панели.
На рис. 1.5, 1.8 под строкой меню видны четыре горизонтальные панели с наименованиями: Standard (Стандартная) (в первом ряду сверху), Layers (Слои) и Styles (Стили) (во втором ряду сверху) и Properties (Свойства) (в третьем ряду сверху). Эти панели желательно не трогать, не удалять и не перемещать, поскольку они постоянно нужны для работы. По сравнению с предыдущими версиями в системе AutoCAD 2004 появилась новая панель Styles (Стили), а панель Object Properties (Свойства объектов) разделилась на панели Layers (Слои) и Properties (Свойства).

Рис. 1.8. Плавающее положение панели инструментов Modify

Две панели, вертикально расположенные на рис. 1.5, называются Draw (Рисование) и Modify (Редактирование).
Для вызова панелей на экран и удаления их с экрана имеются специальные средства. Подведите курсор к имени падающего меню View (Вид) и нажмите левую кнопку мыши. Выбранное падающее меню откроется (выпадет) внутрь графического экрана (рис. 1.9). Затем опустите указатель мыши на нижнюю строку Toolbars (Панели) и нажмите левую кнопку мыши (в дальнейшем выбор любых элементов экрана будем делать только с помощью щелчка левой кнопки мыши, правая же кнопка обычно вызывает какое-нибудь контекстное меню, о которых речь пойдет дальше). Многоточие после наименования пункта Toolbars (Панели) означает, что после выбора этого пункта меню будет вызвано диалоговое окно, в котором следует ввести какие-то параметры и ответить на предложенные вопросы.
Появившееся диалоговое окно Customize (Адаптация) (рис. 1.10) при выборе вкладки Toolbars (Панели) показывает в левом вертикальном списке все имена панелей, которые доступны в данной версии системы AutoCAD. Пролистывание всего списка осуществляется с помощью вертикальной линейки прокрутки. При установленном флажке в квадрате перед именем панели, панель будет находиться на экране, при отсутствии этого флажка панели на экране не будет.

Рис. 1.9. Вызов падающего меню View

Рис. 1.10. Диалоговое окно Customize (вкладка Toolbars)

Установите с помощью левой кнопки мыши флажок возле панели Dimension (Размеры) и снимите его около панели Draw (Рисование). После этого вертикально расположенная панель Draw (Рисование) исчезнет, а панель Dimension (Размеры) появится на экране (рис. 1.11).

Рис. 1.11. Добавленная панель Dimension

Закройте диалоговое окно Customize (Адаптация) с помощью кнопки Close (Закрыть). Далее новую панель можно известным нам способом перетащить на удобное место экрана. Аналогично добавляются любые другие панели инструментов. Работа с другими вкладками диалогового окна Customize (Адаптация) рассмотрена в гл. 11.
Если нужно вызвать на экран только одну панель или только одну панель убрать с экрана, то следует воспользоваться контекстным меню. Контекстные меню вызываются по щелчку правой кнопки мыши. Содержание контекстного меню зависит от двух условий: работает ли в данный момент какая-нибудь команда системы AutoCAD и где в данный момент находится курсор мыши. Подведите указатель мыши к какой-нибудь из находящихся на экране панелей инструментов, например, к расположенной горизонтально панели Standard (Стандартная), и щелкните правой кнопкой мыши. В том месте, где находится курсор, у вас должно появиться контекстное меню работы с панелями (рис. 1.12).
Появившееся контекстное меню содержит перечень всех панелей, а также пункт Customize (Адаптация) для вызова диалогового окна, приведенного на рис. 1.10. Если слева от имени панели стоит символ "галочка", то эта панель уже находится на экране. Щелчок левой кнопки мыши по наименованию панели изменяет ее состояние на противоположное (т. е. убирает, если она была на экране, или выводит на экран, если ее там не было).
Удалить панель с экрана можно также щелчком по кнопке [image] (эта кнопка видна, когда панель находится в плавающем положении).
Новым элементом пользовательского интерфейса в системе AutoCAD 2004 является панель Tool Palettes (Палитры инструментов), которая на рис. 1.5 обозначена цифрой 3. Вызов этой панели на экран и убирание ее с экрана осуществляется щелчком левой кнопки мыши по кнопке [image] панели инструментов Standard (Стандартная), а также с помощью комбинации клавиш <Ctrl>+<3> (т. е. при нажатой клавише <Ctrl> нажать клавишу с цифрой 3 и затем обе клавиши отпустить). Панель Tool Palettes (Палитры инструментов) предназначена для быстрого вызова таких наиболее употребительных элементов оформления чертежа, как штриховки и блоки. Работа с панелью обсуждается в разд. 2.15 и 7.1.
На рис. 1.5 номером 14 обозначены кнопки управления окнами документов. Для системы AutoCAD каждый рисунок является графическим документом. Каждый документ имеет собственное окно, которое размещается внутри графического экрана. Упомянутые кнопки позволяют выполнять с активным документом такие операции, как сворачивание, восстановление и закрытие.

Рис. 1.12.Контекстное меню работы с панелями

Еще одним новым интересным инструментом управления пользовательским интерфейсом является пункт Clean Screen (Очистка экрана) падающего меню View (Вид) (см. рис. 1.9). С помощью этого пункта можно увеличить рабочую зону графического экрана за счет временного удаления панелей, заголовка окна AutoCAD и лотка рабочего стола Windows (рис. 1.13). В таком состоянии пользователю остаются доступными падающие меню.

Рис. 1.13. Расширение графического экрана

Повторный выбор пункта Clean Screen (Очистка экрана) возвращает окно системы AutoCAD к обычному виду (с панелями). Для быстрого переключения между этими состояниями графического экрана можно пользоваться комбинацией клавиш <Ctrl>+<0>.
Операциям расширения и восстановления экрана соответствуют новые команды CLEANSCREENON и CLEANSCREENOFF (в момент написания данной книги русские аналоги этих команд были не известны). О командах см. разд. 1.4.


1.4. Способы ввода команд

Система AutoCAD создана для интерактивной работы пользователя. Весь диалог с системой идет на языке команд. Самый простой способ ввода команд — это набор их на клавиатуре в командной строке в ответ на приглашение Command: (Команда:). Наименования команд в англоязычной версии вы можете вводить в латинском регистре (верхнем или нижнем). Если же вы работаете в русскоязычной версии, то можно пользоваться русскими именами команд или английскими, но предваренными знаком подчеркивания (так, например, в русскоязычной версии команду ОТРЕЗОК можно заменить командой _LINE).
Команда LINE (ОТРЕЗОК) для рисования отрезков может быть введена в английской версии AutoCAD с клавиатуры любым из следующих способов.

  • LINE
  • Line
  • line
  • liNE

Кроме того, в английской версии обычно допускается и форма команды с символом подчеркивания (_LINE, _line). После набора команды на клавиатуре не забудьте нажать клавишу <Enter>, поскольку она является для системы AutoCAD указанием начать обработку команды. Пока клавиша <Enter> не нажата, вы можете отредактировать набранный в командной строке текст, используя клавиши <->>, <<->, <Del> (удаляет символ справа от курсора), <Backspace> (удаляет символ слева от курсора).
Другим способом ввода команд является выбор соответствующих пунктов меню или кнопок панелей инструментов.
Если в ответ на запрос Command: (Команда:) нажать клавишу <Enter>, то AutoCAD повторит вызов предыдущей команды.
Прервать выполнение любой команды, уже начавшую свою работу, можно, нажав клавишу <Esc>.


1.5. Операции с файлами рисунков

Чертежи (рисунки) системы AutoCAD хранятся в файлах с расширением dwg (формат, в котором записывается графическая информация в этих файлах, называется DWG-форматом). Имена файлов могут содержать русские и латинские буквы, цифры, специальные знаки (@, #, $, &, _, -), а также пробелы. Остальные символы (точки, запятые и т. п.), как правило, не допускаются, поскольку являются служебными и могут быть неправильно интерпретированы операционной системой Windows. Для удобства работы желательно пользовательские чертежи хранить в отдельных папках и ни в коем случае не записывать их в основные и вспомогательные папки AutoCAD, иначе такие файлы будут не только засорять программное обеспечение, но и при смене версии или при переинсталляции системы AutoCAD могут быть потеряны.
Операции над файлами и некоторые другие собраны в падающем меню File (Файл) (рис. 1.14).

  • New (Новый)
  • Open (Открыть)
  • Close (Закрыть)
  • Partial Load (Частичная загрузка)
  • Save (Сохранить)
  • Save As (Сохранить как)
  • eTransmit (Сформировать комплект)
  • Publish to Web (Публикация в Интернете)
  • Export (Экспорт)
  • Page Setup (Параметры листа)
  • Plotter Manager (Диспетчер плоттеров)
  • Plot Style Manager (Диспетчер стилей печати)
  • Plot Preview (Предварительный просмотр)
  • Plot (Печать)
  • Publish (Публикация)
  • Drawing Utilities (Утилиты)
  • Send (Переслать)
  • Drawing Properties (Свойства рисунка)
  • Exit (Выход)

Пункт New (Новый) падающего меню выполняет команду AutoCAD NEW (НОВЫЙ), которая создает в рабочей области новый рисунок по простейшему шаблону или по специальному шаблону — согласно выбору пользователя. При этом вызывается диалоговое окно Create New Drawing (Создание нового рисунка) (рис. 1.15), которое похоже на окно Startup (Начало работы), но в нем недоступна кнопка открытия существующего файла. Следует заметить, что можно настроить AutoCAD таким образом, что это окно вызываться не будет, а система сразу же создаст новый рисунок с простейшими установками.
Такую же операцию создания нового рисунка выполняет кнопка [image] панели инструментов Standard (Стандартная), которая соответствует команде QNEW (БНОВЫЙ).

Рис. 1.14. Падающее меню File

Рис. 1.15. Диалоговое окно Create New Drawing

С помощью пункта меню Open (Открыть) можно выполнить команду OPEN (ОТКРЫТЬ), вызывающую диалоговое окно Select File (Выбор файла) для указания открываемого файла чертежа (рис. 1.16).

Рис. 1.16. Диалоговое окно Select File

Все файлы рисунков в этом окне имеют расширение dwg и слева от имени каждого файла стоит значок [image] . Когда вы в диалоговом окне Select File (Выбор файла) отметите какой-то DWG-файл, то его имя появится в поле раскрывающегося списка File name (Имя файла), а в области просмотра Preview (Просмотр) вы увидите его растровый образец, дающий представление о содержимом файла. После выбора нужного чертежа следует щелкнуть по кнопке Open (Открыть).
В левой части окна приводится перечень стандартных папок, расположенных на локальном диске или на сайте в Интернете.

  • History (История)
  • DATA (D:) (Диск DATA (D:))
  • Favorites (Избранное)
  • FTP (FTP-сервер)
  • Desktop (Рабочий стол)
  • Buzzsaw.com (URL-адрес www.buzzsaw.com)

К этим папкам у вас тоже есть доступ из диалогового окна Select File (Выбор файла). Папка History (История) — это папка с именами последних открытых файлов. Папки Favorites (Избранное) и Desktop (Рабочий стол) — это папки, знакомые вам по работе с Windows. Папка FTP (FTP-сервер) — это папка с адресами FTP-серверов, с которыми вы постоянно работаете. Последняя папка в перечне стандартных является адресом сайта www.buzzsaw.com, предоставляющего различные услуги (от хранения файлов до чтения специальных графических библиотек). Для настройки папок и средств доступа к ним (паролей и т. п.) можно воспользоваться кнопкой [image] , расположенной в правой верхней части диалогового окна Select File (Выбор файла).
Активным, т. е. доступным для операций редактирования, является тот рисунок, окно которого также активно (наименование этого окна выделено более ярким цветом). Если вы максимизируете активный рисунок, он займет всю зону графического экрана (остальные окажутся под ним).
В окне Select File (Выбор файла) (см. рис. 1.16) имеются средства, облегчающие поиск рисунков. Если щелкнуть по кнопке [image] , то откроется небольшое меню, в котором есть пункты Find (Найти) и Locate (Обнаружить). Справа от кнопки Open (Открыть) есть значок [image] , который позволяет выбрать режимы открытия файла:

  • Open (Открытие с максимальными возможностями редактирования);
  • Open Read-Only (Открытие в режиме только для чтения);
  • Partial Open (Частичное открытие);
  • Partial Open Read-Only (Частичное открытие в режиме только для чтения).

Если в диалоговом окне Select File (Выбор файла) установить флажок Select Initial View (С выбором начального вида), то система AutoCAD запросит, какой вид, имеющийся в файле рисунка, нужно открыть (о видах см. гл. 9).
Режим частичного открытия позволяет открыть не весь рисунок, а его часть, что удобно в случае больших файлов. Если вы выбрали этот режим в окне Select File (Выбор файла), то вам будет предложено диалоговое окно Partial Open (Частичное открытие) (рис. 1.17), в котором можно указать объем частичной загрузки. Выбор может быть осуществлен по слоям (в списке области Layer geometry to load (Загрузка объектов по слоям)) и по видам (в списке области View geometry to load (Загрузка объектов по видам)). О слоях и видах см. гл. 4 и 9. Частичное открытие может быть выполнено также с помощью команды PARTIALOPEN (ОТКРЧАСТЬ).

Рис. 1.17. Выбор элементов в диалоговом окне Partial Open для частичного открытия файла рисунка

Это же окно, но с названием Partial Load (Частичная загрузка), вызывается и с помощью пункта Partial Load (Частичная загрузка) падающего меню File (Файл) или команды PARTIALOAD (ЗАГРЧАСТЬ). Однако данный пункт будет доступен только после того, как вы сначала откроете часть рисунка, а затем захотите еще что-то добавить.
Раскрывающийся список Files of type (Тип файлов) диалогового окна Select File (Выбор файла) (см. рис. 1.16) позволяет задавать открытие не только обычных файлов рисунков (с расширением dwg), но и файлов с расширениями dws, dxf и dwt, о которых будет сказано далее.

Замечание Вместе с системой поставляются интересные примеры, которые можно найти в папке Sample, расположенной внутри папки с программным обеспечением AutoCAD (например, если система установлена в папку d:\AutoCAD 2004, то файлы примеров находятся в папке d:\AutoCAD 2004\Sample).

Система AutoCAD 2004 поддерживает многодокументный режим, поэтому в одном сеансе работы с AutoCAD можно иметь открытыми сразу несколько рисунков. Каждый из них оформляется как отдельное окно Windows.
Используя кнопки сворачивания и восстановления окон (элемент, обозначенный номером 14 на рис. 1.5), которые находятся в правой верхней части, вы можете расположить рисунки так, как вам будет удобно. В этом вам помогут также команды операций над окнами, включенные в падающее меню Window (Окно) (рис. 1.18):

Рис. 1.18. Падающее меню Window

  • Close (Закрыть);
  • Close All (Закрыть все);
  • Cascade (Каскадом);
  • Tile Horizontally (Слева направо);
  • Tile Vertically (Сверху вниз);
  • Arrange Icons (Упорядочить значки).

Первый пункт меню позволяет закрыть активный рисунок, а второй — закрыть все рисунки. Этим двум пунктам соответствуют команды CLOSE (ЗАКРЫТЬ) и CLOSEALL (ЗАКРЫТЬВСЕ). Для закрытия текущего (активного) рисунка можно использовать также пункт Close (Закрыть) падающего меню File (Файл). При закрытии рисунка система AutoCAD обычно запрашивает о необходимости сохранения сделанных изменений или отказе от них (рис. 1.19).

Рис. 1.19. Окно с запросом о сохранении изменений

Необходимо щелкнуть по кнопке Yes (Да), если изменения требуется сохранить, или по кнопке No (Нет), если изменения не нужны. Выбор кнопки Cancel (Отмена) отменяет команду CLOSE (ЗАКРЫТЬ).
Следующие четыре пункта падающего меню Window (Окно) дают различные варианты расположения окон рисунков. Нижняя строка меню показывает имя открытого рисунка (количество таких строк в меню равно количеству открытых DWG-файлов). На рис. 1.20 показаны четыре одновременно открытых рисунка, размещенные согласно пункту Arrange Icons (Упорядочить значки) меню Window (Окно).

Рис. 1.20. Пример четырех одновременно открытых рисунков

Пункт Save (Сохранить) падающего меню File (Файл) (см. рис. 1.14) (или соответствующая этому пункту команда QSAVE (БСОХРАНИТЬ)) позволит вам быстро сохранить изменения открытого рисунка в файле с тем же именем. Если вы хотите сделать запись в другой файл, воспользуйтесь пунктом меню Save As (Сохранить как) или командой SAVEAS (СОХРАНИТЬКАК). При этом вам будет предложено окно, в котором нужно для сохранения выбрать папку и ввести имя файла (расширение dwg можно не указывать, т. к. оно будет добавлено автоматически).

Замечание AutoCAD 2004 имеет DWG-формат, отличный от формата систем AutoCAD 2000, 20001 и 2002. Поэтому файлы, созданные системой AutoCAD 2004, не могут открываться предыдущими версиями системы.

В данном окне есть также возможность с помощью раскрывающегося списка Files of type (Тип файла) задать режим сохранения рисунка либо в DWG-формате AutoCAD 2004, либо в DWG-формате AutoCAD 2000, либо в DWT-формате, используемом шаблонами системы AutoCAD (о применении шаблонов см. гл. 10), либо в формате DWS, применяемом в файлах стандартов (о стандартах см. гл. 5), либо в DXF-формате, используемом при передаче графических файлов между разными системами автоматизированного проектирования (САПР).
При создании новых рисунков система AutoCAD дает им условные имена: Drawingl, Drawing2 и т. д. Пользователь в дальнейшем может сохранить рисунки с этими именами или назначить свои.
Пункт Export (Экспорт) меню File (Файл) и команда EXPORT (ЭКСПОРТ) позволяют преобразовывать графическую информацию рисунка AutoCAD в специальные форматы других графических пакетов. На рис. 1.21 приведено диалоговое окно Export Data (Экспорт данных) операции экспорта.

Рис. 1.21. Окно Export Data

В рассматриваемой нами версии возможен экспорт в следующие форматы: WMF, SAT, STL, EPS, DXX, BMP, 3DS.
Пункт eTransmit (Сформировать комплект) меню File (Файл) предназначен для передачи группы рисунков и связанных с ними вспомогательных файлов (шрифтов, типов линий и т. п.) в другие организации и фирмы, а пункт Publish to Web (Публикация в Интернете) — для размещения их на страницах сайтов (см. приложение 3). Для передачи рисунка в качестве вложения при использовании электронной почты можно воспользоваться пунктом Send (Переслать).
Пункты Page Setup (Настройка страницы), Plotter Manager (Диспетчер плоттеров), Plot Style Manager (Диспетчер стилей печати), Plot Preview (Просмотр) и Plot (Печать) предназначены для настройки, а также выполнения печати и рассмотрены в гл. 6.
Пункт Publish (Публикация) позволяет экспортировать рисунки в файлы еще одного формата — DWF, который разработан фирмой Autodesk и тоже предназначен для размещения рисунков в Интернете. Этому пункту соответствует также кнопка [image] панели инструментов Standard (Стандартная).
На рис. 1.14 видно, что пункт Drawing Utilities (Утилиты) имеет подпункты, которые располагаются в следующем порядке: Audit (Проверить), Recover (Восстановить), Update Block Icons (Обновить образцы блоков), Purge (Очистить). Они предназначены для опытных пользователей и позволяют выполнять особые операции с рисунками, особенно при возникновении сбоев.
Как и Microsoft Office, AutoCAD дает возможность сохранить вместе с рисунком некоторую авторскую информацию. Для этого выберите пункт Drawing Properties (Свойства рисунка) падающего меню File (Файл), который открывает одноименное диалоговое окно (рис. 1.22). Эту операцию можно выполнить также с помощью команды DWGPROPS (СВОЙСТВАРИС).
В этом окне имеются четыре вкладки, которые выбираются щелчком левой кнопки мыши. Вкладки General (Общие) и Statistics (Статистика) содержат данные, заносимые системой AutoCAD, а вкладки Summary (Документ) и Custom (Прочие) заполняются непосредственно автором чертежа. Все эти данные сохраняются вместе с чертежом.
Для выхода из сеанса редактирования следует воспользоваться пунктом Exit (Выход) падающего меню File (Файл) или кнопкой [image] |, расположенной в правом верхнем углу окна AutoCAD. Система анализирует, сохранены ли изменения во всех открытых рисунках, и если нет, то по каждому несохраненному файлу выдает запрос о сохранении или игнорировании изменений.

Рис. 1.22. Окно Drawing Properties, вкладка Summary


1.6. Текстовое окно

Если вы, находясь в графическом экране (см. рис. 1.5), нажмете на клавиатуре функциональную клавишу <F2>, то на экране дисплея появится окно AutoCAD Text Window (Текстовое окно AutoCAD), которое выводится поверх рабочей зоны (рис. 1.23).
Содержимое этого окна начнется протоколом всего сеанса работы с текущим рисунком, а для его просмотра (прокрутки) используются вертикальная и горизонтальная линейки (вертикальная линейка на рис. 1.23 отсутствует, т. к. при небольшом количестве строк линейка прокрутки не нужна; по мере роста объема информации в текстовом окне вертикальная линейка появится автоматически). Обратите внимание: область командных строк повторяет последние строки (как правило, три строки) текстового окна.
Убрать текстовое окно можно, нажав еще раз клавишу <F2> или воспользовавшись стандартной кнопкой [image] , размещенной в верхнем правом углу окна. Текстовое окно выводится системой AutoCAD также в случаях, когда нужно выдать пользователю большую порцию текстовой информации (например, при работе команды LIST — см. разд. 2.19}.

Рис. 1.23. Окно AutoCAD Text Window

Замечание В версиях, работающих под управлением MS DOS, для вызова текстового окна служит клавиша <F1>, которая для Windows имеет совсем другой смысл: вызов справочной системы.


1.7. Единицы измерения

AutoCAD может работать в двух линейных единицах измерения: в миллиметрах и дюймах и различных угловых единицах, причем единицы в процессе работы могут меняться. В разделе Default Settings (Единицы по умолчанию) окна Startup (Начало работы) (см. рис. 1.4) включение переключателя Metric (Метрические) означает, что в качестве единиц измерения при создании рисунка выбраны миллиметры. Переход к подробной установке единиц осуществляется в окне Startup (Начало работы) (см. рис.1.4) или в окне Create New Drawing (Создание нового рисунка) (см. рис. 1.15) с помощью кнопки [image] , которая переводит начальное окно в режим вызова программы-мастера создания нового чертежа (рис. 1.24).
Мастер начальных установок может работать в одном из двух вариантов дальнейшей работы:

  • Quick Setup (Быстрая подготовка);
  • Advanced Setup (Детальная подготовка).

Рис. 1.24. Диалоговое окно Startup (режим Use a Wizard)

В режиме быстрой подготовки будут запрошены только тип линейных единиц и размеры зоны рисования. Более подробная настройка выполняется в режиме детальной подготовки, которым мы и продолжаем дальнейшее освоение системы AutoCAD. Выберите мышью режим Advanced Setup (Детальная подготовка) и нажмите кнопку ОК. У вас откроется первая страница окна Advanced Setup (Детальная подготовка) (рис. 1.25).

Рис. 1.25. Страница Units окна Advanced Setup

Выберите десятичные единицы (включите переключатель Decimal (Десятичные)). Рисунок справа иллюстрирует те единицы, которые вы выбрали. Затем с помощью раскрывающегося списка Precision (Точность) установите точность, с которой вы будете оперировать с вещественными числами (щелкните левой кнопкой мыши, поместив ее указатель на треугольнике раскрывающегося списка, и отметьте подходящий для вас вариант; по умолчанию это четыре знака после десятичной точки), и нажмите на кнопку Далее (Next).

Замечание На рис. 1.25 и других рисунках некоторые стандартные кнопки имеют русские названия, поскольку эти названия зависят от языка операционной системы, а не от языка системы AutoCAD. Поэтому, например, на рис. 1.25 кнопки Back, Next и Cancel приведены с наименованиями Назад, Далее и Отмена.

Появится очередная страница для задания единиц и точности углов (рис. 1.26).

Рис. 1.26. Страница Angle окна Advanced Setup

Выберите Decimal Degrees (Десятичные градусы). Рисунок справа опять покажет иллюстрацию к избранному вами способу. Установите точность измерения углов (обычно это округление до целого) и нажмите кнопку Далее (Next). Переходим к следующей странице (рис. 1.27).
В этом окне надо выбрать то направление, которое будет соответствовать нулевому углу (обычно это East (Восток)), и снова нажать кнопку Далее (Next). Откроется очередная страница настройки, задающая ориентацию отсчета углов (рис. 1.28).

Рис. 1.27. Страница Angle Measure окна Advanced Setup

Рис. 1.28. Страница Angle Direction окна Advanced Setup

Здесь нужно определиться с направлением отсчета углов, т. е. отсчета по часовой стрелке или против нее. Обычный вариант — это Counter-Clockwise (Против часовой стрелки). Нажмите кнопку Далее (Next), в результате чего откроется заключительная страница, устанавливающая размеры области рисования (рис. 1.29).

Рис. 1.29. Страница Area окна Advanced Setup

В новом окне вам надо определить начальные размеры зоны рисования, которая называется зоной лимитов. Как правило, левый нижний угол этой прямоугольной зоны имеет нулевые координаты как по горизонтальной, так и по вертикальной осям, а верхний правый угол определяется пользователем. По умолчанию это зона формата A3 (420 мм х 297 мм), но пользователь может выбрать и другие размеры, пользуясь двумя специальными полями: Width (Ширина) и Length (Длина) (для активизации поля нужно щелкнуть левой кнопкой мыши по этому полю, в котором после этого появится мерцающий вертикальный курсор, и ввести или отредактировать значение размера). После установки размеров остается нажать на кнопку Готово (Finish). Ваш чертеж после этого будет настроен в соответствии с выбранными вами линейными и угловыми единицами измерения.
В левом нижнем углу графического экрана обычно изображается пиктограмма осей координат. Ось X экрана направлена вдоль горизонтальной кромки экрана, ось Y— вдоль вертикальной кромки. Основная система координат, в которой вы по умолчанию начинаете работу, называется мировой. Ось Z системы AutoCAD направлена от плоскости экрана к вам (конечно, это важно, только если вы работаете не на плоскости, а в пространстве). При движении указателя мыши по графическому экрану счетчик координат, если он не отключен функциональной клавишей <F6>, считывает текущие координаты и выводит их в левом нижнем углу в статусной строке.
Хотя заданы размеры зоны лимитов, вы не обязаны строго придерживаться этих ограничений. Выход за пределы лимитов допустим (а когда вы с помощью AutoCAD создаете двумерную или трехмерную модель большого объекта, то тогда вам обязательно придется выйти за границы лимитов). Часть построенных вами линий может вполне оказаться за пределами видимой части экрана. Об управлении просмотром различных частей рисунка см. в разд. 2.4.


Глава 10. Пространство листа

    • Пространство листа
    • 10.1. Переключение между пространствами модели и листа
    • 10.2. Создание видовых экранов в листе
    • 10.3. Оформление видовых экранов
    • 10.4. Управление масштабом
    • 10.5. Редактирование формы видового экрана
    • 10.6. Создание нового рисунка с использованием шаблона
    • 10.7. Специальные средства оформления листа чертежа
    • 10.8. Добавление нового листа


В предыдущей главе были рассмотрены разнообразные средства создания трехмерных моделей изделий, сооружений и зданий: расположение в различных плоскостях пространства, выдавливание двумерных объектов, каркасное (сетевое) представление и твердотельное проектирование. Все это создавалось в пространстве, которое называется пространством модели. Пространству модели соответствует вкладка графического экрана с названием Model (Модель).
В данной главе мы рассмотрим вопросы представления созданных моделей на бумаге с помощью технологии видов. Для такого представления в системе AutoCAD предусмотрено еще одно пространство — пространство листа. В версиях системы, предшествовавших AutoCAD 2000, в рисунке было пространство только для одного листа. В последних версиях системы AutoCAD (в том числе и в AutoCAD 2004) пространству листа соответствуют все остальные вкладки (Layoutl (Лист1), Layout2 (Лист2) и т. д.), кроме вкладки Model (Модель). Поскольку таких вкладок может быть много, а каждая вкладка соответствует одному листу чертежа, то можно называть это пространство пространством листов.


10.1. Переключение между пространствами модели и листа

При создании нового рисунка даже с простейшим шаблоном в нижней части графического экрана рисунка появляются имена двух вкладок пространства листа — Layoutl (Лист!) и Layout2 (Лист2). Если в первый раз щелкнуть с помощью левой кнопки мыши по вкладке Layoutl (Лист1), то система AutoCAD начинает инициализацию (установку начальных параметров) этой вкладки графического экрана и открывает диалоговое окно Page Setup (Параметры листа). В этом окне возможны две вкладки (как мы уже знаем, у диалоговых окон могут быть вкладки, позволяющие на одно и то же место выводить разные порции информации окна) — открывается вкладка Layout Settings (Компоновка) (рис. 10.1).

Рис. 10.1. Диалоговое окно Page Setup, вкладка Layout Settings

Данное окно практически полностью совпадает с диалоговым окном Plot (Печать), открытым на вкладке Plot Settings (Параметры печати) (см. рис. 6.14). И это не случайно. Когда мы создаем или инициализируем вкладку листа, то мы должны описать все, что связано с этим листом: устройство печати (на которое лист будет выводиться), размеры листа, поля, масштаб и т. д. Вся указанная информация далее будет храниться вместе с вкладкой в текущем рисунке.
В открывшемся диалоговом окне предлагаются параметры листа по умолчанию, зависящие в основном от принтера, установленного в операционной системе компьютера. После необходимой корректировки закройте окно кнопкой ОК. Теперь параметры листа сформированы, и AutoCAD открывает вкладку Layoutl (Лист1) (рис. 10.2).
Оформление графического экрана в пространстве листа отличается от оформления в пространстве модели. В левом углу виден знак ПСК пространства листа в форме треугольника. Белое поле — это лист бумаги. Пунктирная линия — зона, доступная для печати. Сплошной линией обозначен создаваемый по умолчанию один видовой экран.

Рис. 10.2. Пространство листа, вкладка Layout 1

VIEWPORT (видовой экран) — это примитив системы AutoCAD, который существует только в пространстве листа и имеет, в основном, прямоугольную форму (может быть подрезан линией другой геометрии). Внутри видового экрана устанавливается вид на объекты, построенные в пространстве модели.
В пространстве модели тоже могут быть видовые экраны. Но там они являются не примитивами, а элементами деления на части графического экрана (см. разд. 9.2). Видовые экраны пространства модели еще называют неперекрывающимися видовыми экранами, а пространства листа — плавающими видовыми экранами.
На рис. 10.3 показан внешний вид листа с плавающим видовым экраном, имеющим размеры по умолчанию, на примере файла твердотельной модели, приведенной на рис. 9.87.
В пространстве листа могут быть не только видовые экраны — в нем можно строить любые примитивы (линии, надписи и т. д.), но они будут принадлежать только пространству листа и не будут отображаться в пространстве модели.
Плавающий видовой экран доступен редактированию, как и другие примитивы системы AutoCAD. Для того чтобы высветить ручки у видового экрана, нужно щелкнуть обязательно по его границе. За появляющиеся ручки можно экран растягивать и сжимать. Сам экран можно перемещать, стирать, копировать и т. д.

Рис. 10.3. Лист, имеющий один видовой экран с видом модели изделия

Если щелкнуть правой кнопкой мыши по имени вкладки, то появится контекстное меню работы с вкладкой (рис. 10.4).

Рис. 10.4. Контекстное меню операций с вкладками

По сравнению с предыдущей версией системы AutoCAD в этом меню появились два новых пункта:

  • Activate Previous Layout (Вернуться к предыдущему листу) — активизирует тот лист, который был активным до перехода на текущий лист;
  • Activate Model Tab (Перейти на вкладку Модель) — активизирует вкладку пространства модели.

Пункт Page Setup (Параметры листа) контекстного меню позволяет вызвать диалоговое окно Page Setup (Параметры листа) (см. рис. 10.1), чтобы посмотреть установки, сделанные для листа, и изменить их, если в этом есть необходимость. Данный пункт недоступен (погашен), если вкладка еще не инициализировалась (т. е. у нее еще нет параметров). Как уже было сказано, при первом же щелчке при помощи левой кнопкой мыши по имени вкладки выполняется инициализация этой вкладки.
Вернуться из пространства листа в пространство модели можно щелчком по имени вкладки Model (Модель) или выбором пункта Activate Model Tab (Перейти на вкладку Модель) из контекстного меню вкладок.
Переключением между пространствами модели и листа управляет системная переменная TILEMODE: при TILEMODE = 1 вы находитесь в пространстве модели, при TILEMODE = 0 — в пространстве листа (о системных переменных см. разд. 11.1).


10.2. Создание видовых экранов в листе

Откройте файл с изображением, показанным на рис. 9.87. Если в нем сохранилось изображение, оставшееся от скрытия невидимых линий, то войдите в падающее меню View (Вид) и в подменю Shade (Раскрашивание) выберите пункт 2D Wireframe (2M каркас). Это режим обычного представления объектов и он проще для вычислений системы AutoCAD, чем режим скрытых линий.
Щелкните по вкладке Layoutl (Лист1) и закройте кнопкой ОК появившееся диалоговое окно Page Setup (Параметры листа). Кнопка MODEL (МОДЕЛЬ) в строке режимов изменит свое состояние на PAPER (ЛИСТ).
Рисунок перейдет в пространство листа, в котором должен быть только один видовой экран, создаваемый по умолчанию системой AutoCAD на новом листе (см. рис. 10.3). В данном видовом экране появится вид, идентичный виду, установленному в активном видовом экране пространства модели (если в пространстве модели не было деления графического экрана на видовые, то активным является целый графический экран).
Удалите этот видовой экран (щелкните по кромке видового экрана и после появления у него ручек нажмите, например, клавишу <Delete>). Изображение на вашем компьютере должен стать похожим на рис. 10.2 (только не будет контура видового экрана). Теперь мы создадим на листе свои собственные видовые экраны.
Вызовите панель инструментов Viewports (Видовые экраны) (рис. 10.5).

Рис. 10.5.Панель инструментов Viewports

На этой панели инструментов находятся пять кнопок и один раскрывающийся список. Перечислим функции кнопок:

  • —выводит диалоговое окно Viewports (Видовые экраны) (см. рис. 9.22 и 9.24);
  • — в пространстве модели: переходит к одноэкранной конфигурации видовых экранов; в пространстве листа: или создает один новый плавающий прямоугольный видовой экран, или делит прямоугольную зону листа, создавая группу из двух, трех или четырех новых смежных плавающих видовых экранов;
  • — в пространстве листа создает видовой экран с границей в форме многоугольника;
  • — в пространстве листа преобразует замкнутый примитив в границу создаваемого видового экрана нестандартной формы;
  • — в пространстве листа подрезает существующий видовой экран многоугольной линией.

Воспользуемся кнопкой [image] панели Viewports (Видовые экраны) для создания видового экрана в листе. Щелчок по этой кнопке равносилен вызову команды MVIEW (СВИД) или команды -VPORTS (-ВЭКРАН) (минус перед именем команды заставляет команду работать без диалогового окна, в режиме командной строки). Система AutoCAD выдаст запрос о расположении новых видовых экранов:
Specify corner of viewport or [ON/OFF/Fit/Shadeplot/Lock/Object/Polygonal/Restore/2/3/4] <Fit>:
(Угловая точка видового экрана или [ Вы/Откл/В Писать/Раскрасить/ Блокировать/ОБъект/Многоугольный/ВОсстановитъ/2/3/4] <ВПисать>:)
Для указания границ нового видового экрана нужно указать две его угловые точки, расположенные по диагонали будущего прямоугольного контура. Укажите сначала одну точку недалеко от левого верхнего угла прямоугольника с пунктирной линией (это край рабочего поля листа бумаги). Появится следующий запрос:
Specify opposite corner: (Противоположный угол:)
Укажите противоположный угол так, чтобы создаваемый видовой экран занял примерно левую верхнюю четверть листа (рис. 10.6).

Рис. 10.6. Создание плавающего видового экрана

Повторите операцию по созданию видовых экранов разных размеров на свободном поле листа еще несколько раз. Пример создания нескольких экранов на листе приведен на рис. 10.7.
Видовые экраны могут располагаться в любом месте графического экрана, даже за пределами рабочего поля (хотя это не имеет большого смысла — разве что только для какой-то дополнительной информации разработчику рисунка, т. к. часть пространства листа, находящаяся вне рабочего поля, обычно не попадает на печать). Видовые экраны могут пересекаться, но не стоит создавать видовые экраны, целиком лежащие внутри других видовых экранов — это затруднит выбор такого экрана и осложнит с ним дальнейшие операции.
Другие опции команды MVIEW (СВИД):
  • ON (Вкл) — включает видимость объектов модели внутри видового экрана, если она ранее была выключена с помощью опции OFF (Откл);
  • OFF (Откл) — отключает видимость объектов модели внутри видового экрана;
  • Fit (ВПисать) — создает видовой экран с размерами рабочего поля листа;
  • Shadeplot (Раскрасить) — задает возможную дополнительную обработку видового экрана при выводе на плоттер (удаление невидимых линий, раскраску или тонирование, режим каркаса);
  • Lock (Блокировать) — включает или выключает блокировку дальнейшего изменения масштаба видового экрана;
  • Object (ОБъект) — создает видовой экран с границей, идентичной указанному замкнутому объекту (полилинии, эллипсу, сплайну, области или окружности);
  • Polygonal (Многоугольный) — создает видовой экран с многоугольной границей (стороны многоугольника могут быть и дуговыми сегментами);
  • Restore (Восстановить) — создает группу плавающих видовых экранов, расположенных аналогично именованной конфигурации видовых экранов пространства модели;
  • 2 —- делит прямоугольную зону на 2 видовых экрана;
  • 3 — делит прямоугольную зону на 3 видовых экрана;
  • 4 — делит прямоугольную зону на 4 видовых экрана.

Рис. 10.7. Создание нескольких плавающих видовых экранов

Дальнейшая работа с листом должна заключаться в следующем: в каждом видовом экране необходимо установить свой вид и масштаб, сделать рамки видовых экранов невидимыми или непечатаемыми, добавить в пространстве листа элементы оформления (наименования видов и сечений, надписи, рамку, штамп и т. д.) и только после этого лист можно печатать для получения твердой копии. Об управлении масштабами видового экрана, масштабировании надписей см. разд. /ft5.
Если теперь щелкнуть по расположенной внизу кнопке режима PAPER (ЛИСТ), то надпись на ней изменится на MODEL (МОДЕЛЬ). Кроме того, один видовой экран будет обведен жирной линией, а устройство указания внутри него будет иметь форму перекрестия, как в пространстве модели (рис. 10.8). Аналогичного эффекта можно добиться, если в режиме PAPER (ЛИСТ) дважды щелкнуть левой кнопкой мыши внутри одного видового экрана.

Рис. 10.8. Переход в режим MODEL с активизацией одного видового экрана

Если передвинуть курсор в любое другое место пространства листа, то там курсор будет иметь форму стрелки, а не перекрестия. Это означает, что в данный момент вам доступна для работы только область активного видового экрана. Вы можете работать с ней так же, как и с пространством модели, только зона построений графического экрана стала несколько меньше. В данном режиме вы имеете доступ только к пространству модели, в котором вы можете редактировать, стирать существующие в модели объекты и строить новые примитивы. В то же время вы теперь не можете работать с объектами пространства листа (например, создавать новые видовые экраны).
В любой момент в листе в режиме MODEL (МОДЕЛЬ) активным может быть только один видовой экран. Чтобы активизировать другой видовой экран, просто щелкните в его зоне левой кнопкой мыши.
Внутри активного видового экрана вам доступны команды панорамирования, зумирования, установки вида, направления взгляда и любые другие команды работы с трехмерной моделью.
Щелчок по кнопке режима MODEL/PAPER (МОДЕЛЬ/ЛИСТ) меняет ее состояние на противоположное (MODEL на PAPER и наоборот). Можно использовать для переключения между режимами еще один способ: двойной щелчок левой кнопкой мыши в зоне любого видового экрана включает режим MODEL (МОДЕЛЬ), а двойной щелчок в зоне вне видовых экранов включает режим PAPER (ЛИСТ).
Переключение между режимами MODEL (МОДЕЛЬ) и PAPER (ЛИСТ) пространства листа может выполняться также с помощью команд MSPACE (МОДЕЛЬ) и PSPACE (ЛИСТ).


10.3. Оформление видовых экранов

Установим теперь различные виды в разных видовых экранах. Сохраним в одном экране изометрический вид, а в трех других установим, например, виды сверху, спереди и справа. Для этого в режиме MODEL (МОДЕЛЬ) (следите за режимом!) щелчком мыши активизируйте нужный видовой экран и с помощью пункта 3D Views (3M виды) падающего меню View (Вид) или посредством панели инструментов View (Вид) установите требуемый вид. Повторите операцию во всех видовых экранах. Подкорректируйте установленные виды с помощью операций панорамирования и зумирования. Возможный вариант результата работы приведен на рис. 10.9.
О согласовании проекций между видовыми экранами см. разд. 10.7.
Часто возникает необходимость на виде или сечении чертежа (для нас — это в видовом экране файла рисунка) показывать не все элементы модели. Как же сделать так, чтобы в видовом экране не были видны лишние элементы?
Для этого воспользуемся такой операцией, как замораживание слоя в конкретном видовом экране. Она была опущена в гл. 4, поскольку в пространстве модели у слоев такого свойства нет (есть только общее замораживание, когда объекты слоя становятся невидимыми везде).

Рис. 10.9. Установки видов в режиме MODEL

Находясь в режиме МОДЕЛЬ (MODEL) пространства листа, щелкните по кнопке [image] панели инструментов Layers (Слои) (напомним, что в системе AutoCAD 2002 данная кнопка находилась на панели Object Properties (Свойства объектов)). После этого откроется диалоговое окно Layer Properties Manager (Диспетчер свойств слоев) (см. рис. 4.14). В центральной части окна находятся характеристики слоев, выводимые в столбцы с заголовками. Наименования не всех столбцов видны полностью, но можно, устанавливая указатель мыши на разделитель между столбцами, буксировать его до такого положения, чтобы нужные наименования развернулись (при необходимости границы этого окна по ширине можно менять). После характеристики Plot (Печать) у вас должны появиться два новых столбца (рис. 10.10) с характеристиками, которые были опущены в гл. 4.
Новые характеристики слоев следующие:

  • Current VP Freeze (Замороженный на текущем ВЭ) — указывает состояние замораживания относительно текущего видового экрана (заморожен или разморожен);
  • New VP Freeze (Замороженный на новых ВЭ) — указывает состояние замораживания относительно будущих новых видовых экранов (будет заморожен или разморожен).

Рис. 10.10. Диалоговое окно Layer Properties Manager со свойствами, относящимися к видовым экранам

Для каждого слоя в столбце Current VP Freeze (Замороженный на текущем ВЭ) может находиться одна из двух пиктограмм: — разморожен в активном видовом экране и [image] — заморожен в активном видовом экране.
Первая из этих пиктограмм означает, что объекты данного слоя будут видимыми в текущем видовом экране, а вторая — что невидимы. Поэтому для каждого слоя нужно решить, в каких видовых экранах он будет виден, а в каких нет. Щелчок по пиктограмме меняет состояние слоя на противоположное.
Если внимательнее посмотреть на раскрывающийся список слоев в панели Layers (Слои) (см. рис. 10.9), то можно увидеть, что значок [image] присутствует и в списке со значками других свойств. Поэтому список панели Layers (Слои) используется для ускорения процесса замораживания или размораживания слоя в активном видовом экране.
Аналогичное свойство замораживания можно зарезервировать слою для всех новых видовых экранов пространства листа, которые будут создаваться. В столбце New VP Freeze (Замороженный на новых ВЭ) тоже может находиться одна из двух пиктограмм: — разморожен в новых видовых экранах и [image] — заморожен в новых видовых экранах.
Таким образом, если вам нужно, чтобы какой-то объект был виден только в данном видовом экране и не виден в других экранах, то перенесите этот объект в пространстве модели на свой персональный слой, который в пространстве листа разморозьте только в одном видовом экране и заморозьте во всех остальных. На рис. 10.11 приведен пример модели, у которой изображение дополнительного цилиндра видно только на виде спереди (верхний левый видовой экран) и на изометрическом виде (экран в правой части листа). В то же время цилиндр не виден на расположенном внизу виде сверху.
Однако если вы заморозили слой в целом с помощью значка [image] или выключили его с помощью значка [image] , то объекты слоя будут невидимыми и в пространстве модели, и во всех видовых экранах пространства листа, независимо от состояния размороженное™ слоя относительно активного видового экрана.

Рис. 10.11. Замораживание слоя модели в выбранных видовых экранах

Описанный только что способ раньше был единственным методом, позволявшим показывать размер только на одном виде. Чтобы пользоваться функциями объектной привязки, приходилось проставлять размеры в пространстве модели, а это приводило к проблеме появления размерных примитивов во всех видовых экранах. Тогда размер переносился на свой слой, а слой замораживался в лишних видовых экранах.
В данной версии системы AutoCAD указанная проблема простановки размеров не существует. Вы можете, находясь в пространстве листа в режиме PAPER (ЛИСТ), наносить размеры и при этом пользоваться объектной привязкой к примитивам модели. На рис. 10.12 показан пример простановки размеров в пространстве листа, но с применением объектной привязки к объекту пространства модели.

Рис. 10.12. Простановка размеров в пространстве листа с привязкой к объектам модели

Замечание Проставлять размеры следует уже после того, как установлен масштаб вида. Если изменить масштаб вида, то произойдет отрыв размеров от объекта. Кроме того, в размерных текстах следует учитывать масштаб видового экрана. Об управлении масштабом см. разд. 10.4. В предыдущей версии системы AutoCAD приходилось выполнять специальную операцию учета масштаба видового экрана в значениях проставляемых размеров. На рис. 10.12 видно, что в данной версии эта проблема снята.

Для того чтобы рамки видовых экранов были не видны, их нужно перенести на отключенный слой, при этом внутренность видовых экранов останется видимой (рис. 10.13).

Рис. 10.13. Замораживание границ видовых экранов

Еще один прием для удаления рамок видовых экранов из печатного документа — перед выводом сделать слой рамок экранов непечатаемым, изменив значение характеристики слоя Plot (Печать) на [image] .
Подробнее об управлении видимостью границы подрезанного видового экрана см. в разд. 10.5.


10.4. Управление масштабом

Установка масштаба внутри видового экрана пространства листа выполняется с помощью команды ZOOM (ПОКАЗАТЬ) с опцией Scale (Масштаб). Как уже было сказано в разд. 2.4, если при указании масштаба ввести число с окончанием ХР (ХЛ) (здесь буквы X латинские и в английской, и в русской версиях, буква Р латинская, буква Л русская), то масштаб будет установлен относительно пространства листа. Поэтому если в каком-то видовом экране нужно установить масштаб 1:10, то перейдите в пространстве листа в режим MODEL (МОДЕЛЬ), активизируйте щелчком мыши экран и введите команду ZOOM (ПОКАЗАТЬ) с опцией Scale (Масштаб). Система AutoCAD выдаст запрос:
Enter a scale factor (nX or nXP): (Масштабный коэффициент (nХ или nХЛ):) В ответ введите 0.1ХР или 0.lxp.
Удобным способом установки масштаба в видовом экране является раскрывающийся список масштабов в панели инструментов Viewports (Видовые экраны) (рис. 10.14).

Рис. 10.14. Раскрывающийся список масштабов панели инструментов Viewports

Если нужный вам масштаб является одним из стандартных, то вы можете прямо выбрать его из раскрывающегося списка. К стандартным в данной версии AutoCAD отнесены такие значения: Scale to fit (Вписать), 1:1, 1:2, 1:4, 1:8, 1:10, 1:16, 1:20, 1:30, 1:40, 1:50, 1:100, 2:1, 4:1, 8:1, 10:1, 100:1. Вы можете посредством этого списка ввести и свои значения масштабов. Например, если вам нужен масштаб 1:5, то вы можете в поле списка набрать 1:5 или 0.2 и затем нажать клавишу <Enter>, после чего активный экран изменит свой масштаб на новый. Если щелкнуть по другому видовому экрану, то поле списка в панели инструментов Viewports (Видовые экраны) отразит его текущий масштаб (см., например, рис. 10.8).
Команда SPACETRANS (ЕДПРОСТ), появившаяся в версии AutoCAD 2002, позволяет рассчитать, с какими длинами объекты, построенные в пространстве модели, будут отображаться в видовых экранах пространства листа и наоборот. Команда не применима во вкладке Model (Модель).
Если команда SPACETRANS (ЕДПРОСТ) вызвана во вкладке пространства листа в режиме PAPER (ЛИСТ), то выводится запрос:
Select a viewport: (Укажите видовой экран:)
Нужно выбрать тот видовой экран, относительно которого будут пересчитываться длины. При пересчете будет использован масштаб видового экрана. После указания экрана система запрашивает:
Specify model space distance <1>: (Расстояние в пространстве модели <1>:)
Нужно задать длину объекта (или, например, высоту букв надписи) в пространстве модели, после чего AutoCAD вычислит, как эта длина (или высота) будет отражена в выбранном видовом экране. Например, если масштаб видового экрана равен 5, а вы введете в качестве длины 12,5 мм, то получите ответ: 2.5. Данная операция позволяет вам управлять длиной объекта в модели, если вы хотите получить нужную вам длину в видовом экране.
Если команда SPACETRANS (ЕДПРОСТ) выполняется в режиме MODEL (МОДЕЛЬ), то запрос выглядит несколько иначе:
Specify paper space distance <1>: (Расстояние в пространстве листа < 1 >:)
Вам необходимо ввести длину (расстояние) в пространстве листа. AutoCAD вернет соответствующее значение длины в пространстве модели с учетом масштаба активного видового экрана.


10.5. Редактирование формы видового экрана

Видовой экран в пространстве листа не обязан иметь только прямоугольную форму. В системе AutoCAD, начиная с версии AutoCAD 2000, можно придать видовому экрану форму многоугольника, окружности, эллипса и т. п.
Рассмотрим еще три кнопки панели инструментов Viewports (Видовые экраны) (рис. 10.5). Щелкните по кнопке [image] , которая предназначена для создания видовых экранов в форме многоугольника (точнее, в виде полилинии, в которую могут входить прямолинейные и дуговые сегменты). Кнопка соответствует опции Polygonal (Многоугольный) команды -VPORTS (-ВЭКРАНЫ), рассмотренной в разд. 10.2.
Система AutoCAD выдаст первый запрос: Specify start point: (Начальная точка:)
Укажите первую точку будущей многоугольной границы видового экрана. Следующий запрос:
Specify next point or [Arc/Close/Length/Undo]: (Следующая точка или [Дуга/Замкнуть/длИна/Отменить]:)
Последний запрос повторяется, пока не будут заданы все точки контура (завершение ввода после нажатия клавиши <Enter>). Из формы запросов видно, что создается полилиния, в которой могут быть и дуговые сегменты, но должно быть не менее трех точек. Такой контур можно редактировать с помощью команды PEDIT (ПОЛРЕД) или с помощью ручек.
Теперь щелкните по кнопке [image] панели инструментов Viewports (Видовые экраны). Эта кнопка предназначена для преобразования замкнутого объекта в видовой экран и соответствует опции Object (Объект) команды -VPORTS (-ВЭКРАНЫ).
Система AutoCAD запрашивает: Select object to clip viewport: (Выберите объект для подрезки видового экрана:)
В ответ выберите существующий замкнутый объект, который должен стать границей будущего видового экрана. Этот объект должен быть построен на поле листа в режиме PAPER (ЛИСТ), иначе он не будет доступен в данной операции. В качестве такого объекта могут выступать полилиния, окружность, эллипс и сплайн.
После указания объекта образуется видовой экран требуемой формы. На рис. 10.15 показаны экраны в форме полилинии и в форме окружности.
Кнопка [image] панели инструментов Viewports (Видовые экраны) в пространстве листа подрезает существующий видовой экран многоугольной линией. Данная операция аналогична подрезке блоков и внешних ссылок, рассмотренной в разд. 7.3.
Таким образом, лишние элементы можно удалять из видового экрана не только замораживанием слоя объекта на данном видовом экране, но и подрезкой экрана.
При отключении видимости границ видовых экранов, имеющих подрезку, следует иметь в виду следующее. Замораживание слоя, на котором находится подрезанный видовой экран, приводит к отключению подрезки (восстановится та форма экрана, которая была до подрезки). Правильным выходом является не замораживание, а отключение слоя, на котором находится подрезанный видовой экран, что обеспечит невидимость его границы (подрезка при этом сохранится).

Рис. 10.15. Видовые экраны непрямоугольной формы


10.6. Создание нового рисунка с использованием шаблона

В гл. ] рассматривался вопрос создания рисунка с помощью простейшего шаблона. Однако в AutoCAD есть возможность создать рисунок с помощью шаблонов, поставляемых вместе с версией системы AutoCAD.
Щелкните на панели инструментов Standard (Стандартная) по кнопке [image] соответствующей новой команде QNEW (БНОВЫЙ). Если в настройке системы у вас было задано имя шаблона для быстрого создания нового рисунка (см. гл. 11), то AutoCAD сразу же создаст рисунок по такому шаблону. Если в настройке имя шаблона не было указано, то откроется диалоговое окно Create New Drawing (Создание нового рисунка) или диалоговое окно Select Template (Выбор шаблона).

Замечание Старая команда NEW (НОВЫЙ) и соответствующий ей пункт New (Новый) падающего меню File (Файл) открывают окно Create New Drawing (Создание нового рисунка) независимо от настроек.

В диалоговом окне Create New Drawing (Создание нового рисунка) щелкните по кнопке Use a Template (По шаблону). После этого окно примет вид, изображенный на рис. 10.16.

Рис. 10.16. Диалоговое окно Create New Drawing (режим Use a Template)

В данном окне вам предлагается выбрать нужный шаблон из списка шаблонов стандартов: ANSI, DIN, ISO и JIS, содержащих рамки различных форматов с основными надписями. Надо иметь в виду, что рамки ANSI имеют размеры в дюймах, остальные — в миллиметрах. Поэтому рамка ANSI может оказаться не того размера, которого вам бы хотелось иметь.
Аналогичный выбор вам необходимо сделать в том случае, если открылось окно Select Template (Выбор шаблона).
Выберите для примера шаблон ISO A3 -Color Dependent Plot Styles.dwt. При этом откроется новый рисунок, но в нем уже будут элементы оформления (рис. 10.17).
Прежде всего, обратите внимание, что рисунок открылся сразу в пространстве листа (вкладка ISO A3 Title Block) с одним видовым экраном (его прямоугольная граница нарисована сплошной линией). В зависимости от свойств вашего плоттера границы видового экрана и рамка формата могут выйти за пределы рабочего поля, что вам далее придется подкорректировать.
Проверьте с помощью команды LIST (СПИСОК), какими примитивами представлены рамка и штамп. Это позволит вам в дальнейшем правильно ими воспользоваться. В данном случае рамка и штамп являются блоком с атрибутами. При заполнении штампа вам нужно будет отредактировать значения атрибутов (см. разд. 7.1.6). В крайнем случае, блок можно будет расчленить и подработать его элементы под свой стиль.

Рис. 10.17. Новый рисунок, открытый с шаблоном ISO A3

В шаблоны могут входить любые элементы чертежа — не только рамки и штампы, но и узлы, секции и другие заготовки, а также настройки единиц, углов и др. Такие шаблоны могут создавать сами пользователи.
Если вы уже создали и открыли файл, который хотели бы дальше использовать как шаблон, выберите в падающем меню File (Файл) операцию Save As (Сохранить как) или воспользуйтесь командой SAVEAS (СОХРАНИТЬ-КАК). Появится диалоговое окно Save Drawing As (Сохранение). Файлы шаблонов имеют расширение dwt. поэтому в раскрывающемся списке Files of type (Тип файлов) выберите AutoCAD Drawing Template (*.dwt) (Шаблон рисунка AutoCAD (*.dwt)). Система AutoCAD откроет папку Template, в которой хранит файлы своих шаблонов (рис. 10.18).
Введите имя вашего шаблона в поле File name (Имя файла) и нажмите кнопку Save (Сохранить). После этого откроется диалоговое окно Template Description (Описание шаблона) (рис. 10.19).
В этом окне в поле Measurement (Единицы) с помощью раскрывающегося списка нужно выбрать единицы измерения и в поле Description (Описание) ввести описание шаблона. Закройте окно Template Description (Описание шаблона), и ваш шаблон готов. Этот шаблон пока будет доступен только на вашей машине, но его можно записать в папку Template тех пользователей, которым вы хотите этот шаблон передать.

Рис. 10.18. Диалоговое окно Save Drawing As

Рис. 10.19. Диалоговое окно Template Description


10.7. Специальные средства оформления листа чертежа

В панели инструментов Solids (Тела) (см. рис. 9.80) есть две кнопки, предназначенные для подготовки согласованных видовых экранов с видами трехмерных тел. Следует заметить, что создаваемые и обрабатываемые командами этих кнопок видовые экраны имеют специальную организацию. Видовые экраны получают имена и с этими видовыми экранами связываются специально создаваемые слои рисунка.
Команда SOLVIEW (Т-ВИД), которой соответствуют кнопка [image] панели инструментов Solids (Тела) и пункт падающего меню Draw | Solids | Setup | View (Рисование Тела Подготовка | Вид), позволяет создать согласованные виды.
Рассмотрим эту команду на примере, изображенном на рис. 9.87. В пространстве модели построен объект, для которого в пространстве листа нужно создать видовые экраны согласованных проекций. Перейдем на вкладку Layoutl (Лист1), в которой, будем считать, пока еще нет видовых экранов (если есть, то их можно удалить). Первый запрос команды SOLVIEW (Т-ВИД):
Enter an option [Ucs/Ortho/'Auxiliary/Section]: (Задайте опцию [Пск/Орто/Дополнительный/Сечение]:)
Нажатие клавиши <Enter> завершает команду. Возможные опции команды:

  • Ucs (Пек) — создание видового экрана с видом по заданной ПСК;
  • Ortho (Орто) — создание видового экрана с видом, ортогональным к виду указанного видового экрана;
  • Auxiliary (Дополнительный) — создание видового экрана с видом по линии дополнительного сечения;
  • Section (Сечение) — создание видового экрана с сечением. Выберем опцию Ucs (Пек).

Следующий запрос: Enter an option [Named/World/?/Current] <current>: (Задайте опцию [Имя/Мск/?/Текущая] <Текущая>:)
Выберем опцию World (Мск) для вида сверху, т. к. МСК соответствует плоскости нижнего основания моделируемого объекта. Далее:
Enter view scale <1.0>: (Масштаб вида < 1.0>:)
Задайте масштаб, равный 0.2 (т. е. 1:5). Система AutoCAD начинает строить первую проекцию и запрашивает положение центра вида:
Specify view center: (Центр вида:)
Укажите точку центра вида в левой нижней четверти листа. Система создаст видовой экран с условной кромкой по границе рабочего поля листа и сделает первое приближение по размещению вида (рис. 10.20).
С первого раза вид может расположиться неудачно (например, слишком близко к нижней границе рабочего поля). Поэтому следующий запрос позволяет либо уточнить положение точки центра вида, либо нажатием клавиши <Enter> зафиксировать положение центра и перейти к заданию границ видового экрана:
Specify view center <specify viewport>: (Центр вида <видовой экран>:)

Рис. 10.20. Размещение центра первого вида

Запрос повторяется до тех пор, пока вы не нажмете клавишу <Enter>. Поэтому можно сколько угодно раз уточнять положение центра вида. После нажатия <Enter> появляется запрос о положении границ прямоугольного видового экрана:
Specify the first corner of viewport: (Первый угол видового экрана:)
Далее:
Specify the other corner of viewport: (Противоположный угол видового экрана:)
После задания границ видового экрана нужно ввести его имя:
Enter view name: (Имя вида:)
Введите имя (например. Сверху). Система AutoCAD завершает построение первого видового экрана и выдает сообщение о сохранении ПСК вместе с видом (рис. 10.21).

Рис. 10.21. Размещение первого видового экрана

Затем снова повторяется запрос:
Enter an option [Ucs/Ortho/'Auxiliary/Section]: (Задайте опцию [Пек/'Орто/'Дополнительный/'Сечение']:)
Для того чтобы построить вид спереди, связанный с видом сверху, и расположить его в листе выше построенного, выберите опцию Ortho (Орто). Появляется запрос:
Specify side of viewport to project: (Укажите сторону видового экрана для проекции:)
Укажите нижнюю сторону первого видового экрана (в этом вам помогает автоматически появляющаяся объектная привязка Midpoint (Середина)) (рис. 10.22). Нельзя указывать верхнюю сторону видового экрана, т. к. в этом случае новый вид получится перевернутым (вместо вида спереди получится вид сзади).
После этого выдается запрос о центре второго вида, но, когда вы пытаетесь показать центр нового вида, появляющаяся резиновая нить режима ортогональности позволит вам разместить новый вид только строго вертикально от вида сверху. Укажите точку центра вида и затем по следующим запросам — границы видового экрана. Зададим второму виду имя Спереди. После этого в листе будут уже два видовых экрана с согласованными проекциями (рис. 10.23).

Рис. 10.22. Указание направления взгляда для связанного вида

Далее с помощью опции Ortho (Орто) команды SOLVIEW (Т-ВИД) в правой верхней четверти листа построим третий видовой экран, задав имя вида Справа. Для полноты картины с помощью команд —VPORTS (—ВЭКРАНЫ) или MVIEW (СВИД) можно в правом нижнем углу построить еще один видовой экран и установить в нем изометрический вид. Получим чертеж с четырьмя проекциями, три из которых полностью согласованы между собой (рис. 10.24).
Созданные командой SOLVIEW (Т-ВИД) видовые экраны обладают особыми свойствами. Имена расположенных в них видов связаны с именами автоматически сгенерированных слоев, которые можно увидеть, вызвав окно Layer Properties Manager (Диспетчер свойств слоев) (рис. 10.25).
На рис. 10.25 видно, что создан слой VPORTS. На этом слое размещены контуры видовых экранов (его можно отключить, если контуры должны стать невидимыми). По имени каждого из трех видов (Сверху, Спереди, Справа), которые мы задавали, образовалась тройка слоев с окончаниями: DIM, HID и VIS. Эти слои имеют специальное предназначение: слои с окончанием DIM должны хранить размерные примитивы соответствующего вида, слои с окончанием VIS — видимые линии вида, а слои с окончанием HID — невидимые линии вида. Управление видимыми и невидимыми линиями осуществляется с помощью рассматриваемой далее команды SOLDRAW (Т-РИСОВАНИЕ).

Рис. 10.23. Построение видового экрана с сохранением проекционной связи

Рис. 10.24. Построение нескольких видовых экранов с сохранением проекционной связи

Рис. 10.25. Слои, создаваемые командой SOLVIEW

Опция Auxiliary (Дополнительный) команды SOLVIEW (Т-ВИД) позволяет создать видовой экран с неортогональным видом, для чего нужно двумя точками указать положение его плоскости (она перпендикулярна плоскости уже имеющегося вида). При выборе этой опции система просит указать на основном виде первую из двух точек, которыми будет задана плоскость дополнительного вида:
Specify first point of inclined plane: (Первая точка наклонной плоскости:)
Затем следует аналогичный запрос о второй точке:
Specify second point of inclined plane: (Вторая точка наклонной плоскости:)
На рис. 10.26 пунктиром показан отрезок, концы которого являются точками наклонной плоскости дополнительного вида. Система AutoCAD выдает запрос о точке, из которой мы смотрим на введенную плоскость:
Specify side to view from: (Сторона просмотра:)
В нашем примере точка, определяющая сторону просмотра, была указана снизу слева. После этого следует знакомый нам запрос о положении центра нового вида и границах видового экрана. На рис. 10.26 видно, что при выборе положения центра вида система AutoCAD генерирует резиновую нить, которая держит направление, перпендикулярное к отрезку, использованному для указания положения плоскости дополнительного вида.

Рис. 10.26. Выбор дополнительного вида

На рис. 10.27 видно, как сформировался новый дополнительный вид.
По окончании построения нового видового экрана вы можете с помощью команды MOVE (ПЕРЕНЕСТИ) сместить его в листе в новое место. Кроме того, если в этом есть необходимость, вы можете внутри видовою экрана повернуть вид.
Опция Section (Сечение) команды SOLVIEW (Т-ВИД) дает возможность создать сечение тела и вывести его в свой видовой экран. Плоскость сечения задается двумя точками, как в опции Auxiliary (Дополнительный). При этом образуется специальный слой с еще одним окончанием HAT, а на слое будут располагаться линии штриховки сечения.
Команда SOLDRAW (Т-РИСОВАНИЕ), которой соответствуют кнопка [image] панели инструментов Solids (Тела) и пункт падающего меню Draw | Solids | Setup | Drawing (Рисование | Тела | Подготовка | Построение), предназначена для работы с видовыми экранами, созданными командой SOLVIEW (Т-ВИД).

Рис. 10.27. Построение дополнительного вида

Команда SOLDRAW (Т-РИСОВАНИЕ) просит выбрать видовые экраны, которые нужно обработать:
Select viewports to draw... Select objects: (Выберите видовые экраны для построений... Выберите объекты:)
Нужно указать те видовые экраны, в которых необходимо рассчитать и разделить видимые и невидимые линии модели.
После этого система AutoCAD на указанных экранах вместо существующих линий объектов модели создает видимые и невидимые линии, которые являются копиями существующих линий объектов и которые разносятся по слоям, соответствующим именам видов, сформированных командой SOLV1EW (Т-ВИД) (например, на слой Сверху-VIS помещаются видимые линии вида Сверху, на слой Сверху-HID — невидимые линии вида Сверху). При этом сечения штрихуются. По умолчанию слои невидимых линий замораживаются. На рис. 10.28 показан результат обработки трех видовых экранов, изображенных на рис. 10.24, с помощью команды SOLDRAW (Т-РИСОВАНИЕ).

Рис. 10.28. Результат обработки трех видовых экранов командой SOLDRAW

На трех видах, созданных командой SOLVIEW (Т-ВИД), рассчитаны невидимые линии и удалены лишние образующие на лекальных участках поверхностей тела. Для правильного отображения невидимых линий необходимо либо заморозить слои, заканчивающиеся на HID, либо этим слоям дать по умолчанию тип линии DASHED. На рис. 10.28 на виде сверху невидимые линии показаны штриховой линией.
Четвертый вид (изометрический) не создавался командой SOLVIEW (Т-ВИД), поэтому не мог обрабатываться командой SOLDRAW (T-РИСОВАНИЕ).
Для обработки последнего вида можно воспользоваться командой SOLPROF1LE (Т-ПРОФИЛЬ), которой соответствуют кнопка [image] панели инструментов Solids (Тела) и пункт падающего меню Draw | Solids | Setup | Profile (Рисование Тела Подготовка | Контуры).
Команда SOLPROFILE (Т-ПРОФИЛЬ) работает с любыми видовыми экранами (в том числе и с построенными командой SOLVIEW (Т-ВИД)). Она предназначена для создания профилей трехмерных тел и разделения линий вида на видимые и невидимые. Для выполнения команды нужно в пространстве листа перейти в режим MODEL (МОДЕЛЬ) и активизировать нужный видовой экран. Сначала команда запрашивает объекты модели, которые нужно обработать, а затем выдается запрос:
Display hidden profile lines on separate layer? [Yes/No] <Y>: (Изображать скрытые линии профиля на отдельном слое? [Да/Нет/ <Д>:)
При ответе Yes (Да) создаются отдельные слои для видимых и невидимых линий (например, PV-7A для видимых линий и РН-7А для невидимых, где 7А — это метка, или внутренний номер, объекта, которую можно узнать с помощью команды LIST (СПИСОК)). Обычный ответ — Yes (Да). Далее:
Project profile lines onto a plane? [Yes/No] <Y>: (Проецировать линии профиля на плоскость?[Да/Нет] <Д>:)
В этот момент разница между ответами Yes (Да) и No (Нет) заключается в том, что в первом случае создается двумерная проекция профиля объекта на плоскость вида, а во втором — линии профиля остаются трехмерными (оба случая дадут в видовом экране чертежа аналогичное изображение). Следующий запрос:
Delete tangential edges? [Yes/No] < Y>: (Удалить касательные ребра'.'[Да/'Нет/ <Д>:)
При ответе Yes (Да) удаляются лишние касательные ребра, образующиеся на криволинейных участках.
На рис. 10.29 приведен результат работы команды SOLPROFILE (Т-ПРОФИЛЬ). Для наглядности заморожены слои с невидимыми линиями и отключен слой границ видовых экранов.
Упомянем еще одну команду — MVSETUP (ФОРМАТЛ), вводимую только с клавиатуры. Эта команда тоже позволяет создавать в листе видовые экраны с выравниванием. Аналогичные операции выполняет мастер создания новых листов, рассмотренный в следующем разд.

Рис. 10.29. Удаление скрытых линий и касательных ребер с помощью команды SOLPROFILE


10.8. Добавление нового листа

Для операций с листами (вкладками пространства листа) предусмотрена панель инструментов Layouts (Листы) (рис. 10.30).

Рис. 10.30. Панель инструментов Layouts

В панель входят следующие кнопки:

  • — создание нового листа без применения шаблона (команда LAYOUT (РЛИСТ));
  • — создание нового листа по шаблону (команда LAYOUT (РЛИСТ));
  • — изменение параметров листа (команда PAGESETUP (ПАРАМ-ЛИСТ));
  • — вызов диалогового окна видовых экранов (команда VPORTS (ВЭКРАНЫ)).

Основные операции с листами (копирование, удаление, переименование и создание нового листа) выполняет команда LAYOUT (РЛИСТ). При создании или переименовании вкладок листов вы можете использовать удобные для вас названия, в том числе состоящие из нескольких слов (например, "Схема водоснабжения района").
Для работы с листами также можно воспользоваться контекстным меню (см. рис. 10.4) или подменю Layout (Лист) падающего меню Insert (Вставка).
Это подменю имеет следующие пункты:

  • New Layout (Новый лист);
  • Layout from Template (Лист по шаблону);
  • Layout Wizard (Мастер компоновки).

Последний пункт (он соответствует команде LAYOUTWIZARD (МАСТЕР-ЛИСТ)) вызывает специальную программу — мастер создания листов. Аналогичную возможность предоставляет пункт падающего меню Tools | Wizards | Create Layout (Сервис Мастера Создания листа).
Рассмотрим, как работает мастер создания листов. После запуска мастера появляется первая страница (рис. 10.31).

Рис. 10.31. Страница Create Layout — Begin

В этом окне введите имя вкладки (например, Основной элемент) и для продолжения нажмите кнопку Далее (Next). Следующая страница (рис. 10.32) предлагает выбрать принтер, на котором будет распечатываться лист.

Рис. 10.32. Страница Create Layout — Printer

На очередной странице (рис. 10.33) нужно в области Drawing units (Единицы рисунка) установить единицы измерения и с помощью раскрывающегося списка выбрать формат листа бумаги (из числа форматов, доступных установленному принтеру).

Рис. 10.33. Страница Create Layout — Paper Size

Далее на странице Orientation (Ориентация) (рис. 10.34) с помощью одного из двух переключателей (Portrait (Книжная) и Landscape (Альбомная)) необходимо выбрать ориентацию чертежа на листе.

Рис. 10.34. Страница Create Layout — Orientation

Следующая страница (рис. 10.35) предлагает выбрать основную надпись из тех шаблонов, которые доступны в данной версии AutoCAD.

Рис. 10.35. Страница Create Layout — Title Block

Если вы выбираете какую-нибудь из основных надписей, то в области Туре (Тип) с помощью двух переключателей нужно еще указать, будет ли она вставлена блоком или внешней ссылкой. Далее появляется страница для видовых экранов (рис. 10.36).

Рис. 10.36. Страница Create Layout - Define Viewports

Здесь вы можете с помощью группы из четырех переключателей Viewport setup (Способ расположения) указать способ расположения видовых экранов:

  • None (Нет) — отказ от создания видовых экранов;
  • Single (Один экран) — создание одного видового экрана;
  • Std. 3D Engineering Views (Конструкторский набор) — построение четырех видовых экранов с основными проекциями;
  • Array (Массив) — построение массива видовых экранов.

В случае выбора одного из двух последних переключателей группы Viewport setup (Способ расположения) необходимо еще дополнительно указывать расстояние между видовыми экранами по горизонтали и вертикали. Кроме того, при выборе положения Array (Массив) с помощью соответствующих полей Rows (Ряды) и Columns (Столбцы) надо указать количество видовых экранов. Если же построение видовых экранов задано, то необходимо в раскрывающемся списке Viewport scale (Масштаб видовых экранов) также указать устанавливаемый в них масштаб.
Следующая страница (рис. 10.37) предлагает задать положение зоны видовых экранов. Для задания нужно щелкнуть по кнопке Select location (Положение). Система AutoCAD тогда закрывает страницу, генерирует новый лист и просит на нем указать точки положения экрана или группы экранов.

Рис. 10.37. Страница Create Layout— Pick Location

Далее выводится заключительное окно мастера создания листа (рис. 10.38).

Рис. 10.38. Страница Create Layout — Finish

В этом окне сообщается о завершении операции и о том, как можно изменить параметры листа в дальнейшем. На рис. 10.39 приведен результат создания листа Основной элемент с конструкторским набором видовых экранов и без основной надписи.

Рис. 10.39. Конструкторский набор видовых экранов


Глава 11. Повышение эффективности работы

    • Повышение эффективности работы
    • 11.1. Системные переменные
    • 11.2. Настройка AutoCAD
    • 11.2.1. Настройка путей доступа
    • 11.2.2. Настройка экрана
    • 11.2.3. Настройка открытия и сохранения
    • 11.2.4. Настройка печати
    • 11.2.5. Настройка общесистемных характеристик
    • 11.2.6. Дополнительные настройки пользователя
    • 11.2.7. Настройка привязки и отслеживания
    • 11.2.8. Настройка режимов выбора
    • 11.2.9. Настройка профилей
    • 11.2.10. Адаптация элементов интерфейса
    • 11.3. Программные средства адаптации
    • 11.4. Коллективная работа
    • 11.4.1. Одновременный доступ
    • 11.4.2. Формирование комплекта документов
    • 11.4.3. Диспетчер ссылок
    • 11.4.4. Защита паролем и цифровая подпись
    • 11.4.5. DWF-формат
    • 11.5. Express Tools 2004
    • 11.5.1. Подменю Layers
    • 11.5.2. Подменю Blocks
    • 11.5.3. Подменю Text
    • 11.5.4. Подменю Layout tools
    • 11.5.5. Подменю Dimension
    • 11.5.6. Подменю Selection tools
    • 11.5.7. Подменю Modify
    • 11.5.8. Подменю Draw
    • 11.5.9. Подменю File tools
    • 11.5.10. Подменю Web tools
    • 11.5.11. Подменю Tools
    • 11.5.12. Другие подменю и пункты меню Express


AutoCAD является гибкой системой, легко встраиваемой в вычислительные системы предприятий. Она не только адаптируется к особенностям информационных потоков, но и позволяет конструкторам и архитекторам разрабатывать свои графические базы и программные продукты и интегрировать их в среду AutoCAD.
В данной главе рассматриваются проблемы настройки системы и элементов пользовательского интерфейса, а также некоторые другие вопросы: коллективная работа, передача файлов проекта, дополнительное меню Express (Экспресс).


11.1. Системные переменные

Во время работы с рисунком AutoCAD оперирует так называемыми системными переменными, в которые заносится определенная информация: о текущих установках рисования (установках слоя, цвета, типа линий и т. п.), о последнем выполненном действии (имя последней команды, последняя точка, последний радиус и т. п.), о настройках некоторых команд (длина фаски, радиус сопряжения и т. п.) и многое другое. Пользователь может вывести на экран перечень и значения системных переменных и большую часть из них изменить. Остальные изменяются самой системой в процессе работы.
Значения почти всех системных переменных сохраняются в текущем рисунке, однако значения некоторых из них записываются в файл конфигурации, реестр Windows, папку Documents and Settings и др.
Для работы с системными переменными предназначена команда SETVAR (УСТПЕРЕМ). Этой же команде соответствует пункт падающего меню Tools | Inquiry | Set Variable (Сервис Сведения | Переменная).
Первый запрос, который выдает команда после начата своего выполнения:
Enter variable name or [?]: (Имя переменной или /?/:)
В этот момент можно ввести или имя системной переменной, которую вы хотите изменить, или знак вопроса ? для получения справки. Введите знак вопроса. Далее:
Enter variable(s) to list < *>: (Список переменных для вывода < *>:)
Система AutoCAD готова в этот момент вывести в текстовое окно значения тех переменных, имена которых вы укажете. Возможен ввод имен с использованием групповых символов * и ?. Например, можно указать А* — чтобы вывести значения переменных, начинающихся с символа А, или DIM*T — для вывода переменных, имена которых начинаются с DIM и заканчиваются на Т. После указания только символа * система AutoCAD выводит в текстовое окно первую часть всех системных переменных (рис. 11.1).

Рис. 11.1. Вывод значений системных переменных

В текстовом окне значения системных переменных оформляются в виде трех столбцов. Первый столбец — имя переменной, второй — значение и третий — примечание (оно может либо отсутствовать, либо в скобках может быть написано read only (только чтение)). В именах переменных не используются символы других алфавитов, кроме латинского. Выводимый командой SETVAR (УС-ТПЕРЕМ) список переменных упорядочен по латинскому алфавиту.
На рис. 11.1 видно, что в данном файле переменная ACADLSPASDOC имеет значение 0, переменная APERTURE — 5, CECOLOR — "BYLAYER" и т. д.
В случае если в записи значения той или иной переменной присутствует многоточие, то это означает, что значение переменной при выводе сокращено.
Общее количество системных переменных — более 300. Полный перечень переменных приведен в приложении 2.
С помощью команды SETVAR (УСТПЕРЕМ) можно изменить значение любой системной переменной, кроме тех, которые имеют примечание "только чтение". Для изменения надо вызвать команду SETVAR (УСТПЕРЕМ). Система выдаст запрос:
Enter variable name or [?]: (Имя переменной или [?]:)
В ответ на него необходимо ввести имя переменной, например, LUPREC (в верхнем или нижнем регистре). Переменная LUPREC указывает, сколько знаков после десятичной точки нужно выводить в координатах точек в счетчике координат в левом нижнем углу экрана системы AutoCAD, а также в справочной информации, отображаемой некоторыми командами в текстовом окне. Следующий запрос:
New value for LUPREC <4>: (Новое значение LUPREC <4>:)
В ответ на запрос введите 0, если вы хотите, чтобы при движении устройства указания по экрану счетчик координат показывал значения, округленные до целых чисел. На рис. 11.2 показан левый нижний угол окна AutoCAD с целыми значениями счетчика координат.

Рис. 11.2. Установка точности счетчика координат с помощью системной переменной LUPREC

Есть еще один способ — более быстрый — изменение значения системной переменной (он упоминался в разд. 9.7 при работе с переменной ISOLINES). Для этого нужно в ответ на запрос Command: (Команда:) ввести в командной строке значение системной переменной, например, CURSORSIZE. Система AutoCAD запросит:
New value for CURSORSIZE <5>: (Новое значение CURSORSIZE <5>:)
В ответ на это введите 50. Результат выполненного изменения отражен на рис. 11.3.
Возможность такого изменения была упомянута в разд. 1.3.

Рис. 11.3. Изменение размера перекрестия устройства указания с помощью системной переменной CURSORSIZE

Удобное средство работы с системными переменными — пункт падающего меню Express | Tools | System Variable Editor (Экспресс | Сервис | Редактор системных переменных), рассматриваемого в разд. 11.5.


11.2. Настройка AutoCAD

Система AutoCAD позволяет настраивать многие элементы пользовательского интерфейса (строку меню, панели инструментов, экранное меню и т. п.). Параметры настройки формируются уже на стадии установки AutoCAD на ваш компьютер — большая часть по умолчанию, а что-то (например, размещение папок для программного обеспечения) задает пользователь.
Редактирование настроек выполняется либо с помощью команды OPTIONS (НАСТРОЙКА), либо с помощью пункта Options (Настройка) падающего меню Tools (Сервис), либо с помощью пункта Options (Настройка) контекстного меню, вызываемого щелчком правой кнопки мыши в зоне командных строк (рис. 11.4). Последнее меню идентично падающему меню Edit (Средства) текстового окна AutoCAD.

Рис. 11.4. Контекстное меню, вызываемое из зоны командных строк

Изменение установок, сделанных в настройке, требует опыта работы с системой AutoCAD, поэтому делать их начинающим пользователям не рекомендуется.
Команда OPTIONS (НАСТРОЙКА) вызывает диалоговое окно Options (Настройка), которое имеет девять вкладок (рис. 11.5):

  • Files (Файлы);
  • Display (Экран);
  • Open and Save (Открытие/Сохранение);
  • Plotting (Печать);
  • System (Система);
  • User Preferences (Пользовательские);
  • Drafting (Построения);
  • Selection (Выбор);
  • Profiles (Профили).

Рис. 11.5. Диалоговое окно Options, вкладка Files Порядок работы с каждой из этих вкладок описан в разд. 11.2.1—11.2.9.


11.2.1. Настройка путей доступа

Вкладка Files (Файлы) (см. рис. 11.5) задает пути для поиска файлов различных типов, элементов программного обеспечения (шрифтов, текстовых редакторов и т. п.), пользовательских проектов, пользовательских приложений и т. д. Находящиеся справа кнопки Browse (Обзор), Add (Добавить), Remove (Удалить), Move Up (Вверх), Move Down (Вниз) и Set Current (Установить) позволяют корректировать ранее установленные пути, удалять, добавлять и менять местами пути поиска. Кнопки отключаются и включаются в зависимости от действий пользователя.
Настройки путей оформлены в виде дерева, в котором есть разделы (строки), параметры и значения параметров. Так, например, раздел Drawing Template Settings (Настройки шаблонов) имеет два параметра: Drawing Template File Location (Папка для шаблона рисунка) и Drawing Template File Name for QNEW (Имя файла шаблона для команды БНОВЫЙ) (рис. 11.6).

Рис. 11.6. Пункт Drawing Template Settings

В разд. 10.6 рассматривался вопрос о работе команды QNEW (БНОВЫЙ) и было сказано, что команда использует имя файла шаблона, заданного в настройке. Эта настройка хранится в параметре Drawing Template File Name for QNEW (Имя файла шаблона для команды БНОВЫЙ). Если значение параметра не задано (на рис. 11.6 это отображается значением None (Нет)), то команда QNEW (БНОВЫЙ) при быстром создании нового рисунка обычно открывает диалоговое окно Create New Drawing (Создание нового рисунка) (см. рис. 10.16). Если значение параметра задано, то новый рисунок создается без обращения к диалоговому окну.
Для того чтобы изменить значение параметра Drawing Template File Name for QNEW (Имя файла шаблона для команды БНОВЫЙ), необходимо сначала щелкнуть по значку [image] слева от наименования раздела Drawing Template Settings (Настройки шаблонов) и открыть строки раздела с названиями параметров. Затем следует щелкнуть по значку [image] в строке параметра Drawing Template JHie rsame tor yrNtw (Имя файла шаблона для команды БНО-ВЫЙ), чтобы вывести на экран значение этого параметра (как показано на рис. 10.6).
После этого нужно щелкнуть по строке значения параметра, чтобы выделить его, а затем щелкнуть по кнопке Browse (Обзор). В открывшемся диалоговом окне, показывающем файлы и папки вашего компьютера, требуется найти и выбрать тот DWT-файл, имя которого необходимо занести в качестве значения параметра. После закрытия диалогового окна выбора файла замена в строке значения параметра будет выполнена. Нажатие кнопок Apply (Применить) и ОК зафиксирует сделанное в окне Options (Настройка) изменение.


11.2.2. Настройка экрана

Вкладка Display (Экран) (рис. 11.7) выполняет настройку экрана AutoCAD в пространствах модели и листа. Чаще всего пользователи вносят изменения в область Window Elements (Элементы окна), в котором находятся два флажка:

  • Display scroll bars in drawing window (Полосы прокрутки) — отображать полосы прокрутки графического экрана;
  • Display screen menu (Экранное меню) — отображать экранное меню.

В области Window Elements (Элементы окна) расположены также две кнопки управления цветом и шрифтами:

  • Colors (Цвета) — вызывает диалоговое окно цветовой настройки элементов всех рабочих зон экрана AutoCAD;
  • Fonts (Шрифты) — вызывает окно настройки шрифтов.

При установленном флажке Display screen menu (Экранное меню) в правой части графического экрана выводится экранное меню (рис. 11.8).
Экранное меню — это еще один вид меню, который был основным в первых версиях AutoCAD, работающих под управлением MS DOS. Экранное меню имеет иерархическую структуру (верхний уровень, первый, второй и т. д.).
Зона экранного меню разделена на боксы (ячейки). В каждом из них находится наименование пункта, который либо вызывает команду AutoCAD, либо вызывает экранное меню другого уровня. На рис. 11.8 показано экранное меню верхнего уровня, в котором видны наименования экранных меню первого уровня: FILE (ФАЙЛ), EDIT (ПРАВКА), VIEW1 (ВИД1), VIEW2 (ВИД2) и т. д. Наименования почти полностью повторяют имена падающих меню. Щелчок левой кнопки мыши по боксу с именем меню меняет экранное меню верхнего уровня на соответствующее меню первого уровня.

Рис. 11.7. Диалоговое окно Options, вкладка Display

Рис.11.8. Экранное меню верхнего уровня

В каждом боксе этого меню видны наименования пунктов, которые практически идентичны именам команд, вызываемых щелчком по этому пункту. Два нижних пункта - ASSIST (СРЕДСТВА) "и LAST (ПРЕДМЕНЮ) (условное имя предыдущего экранного меню) — вызывают другие экранные меню (на рис. П.8 они не показаны).
В экранном меню любого уровня щелчок по верхней строке, в которой написано AutoCAD, вызывает экранное меню верхнего уровня. Экранные меню являются несколько устаревшим элементом пользовательского интерфейса и поддерживаются разработчиками системы AutoCAD для тех пользователей, которые до этого работали со всеми предыдущими версиями.
Кнопка Colors (Цвета) вкладки Display (Экран) диалогового окна Options (Настройка) (см. рис. 11.7) вызывает диалоговое окно Color Options (Установка цветов) (рис. 11.9) цветовой настройки элементов всех рабочих зон экрана AutoCAD.

Рис. 11.9. Диалоговое окно Color Options

В верхней части этого окна в области Model tab (Вкладка Модель) иллюстрируется текущее оформление вкладки Model (Модель), а в области Layout tabs (Вкладки листов) — вкладок пространства листа, показанное справа. В раскрывающемся списке Window Element (Элемент окна) можно выбрать настраиваемый элемент:

  • Model tab background (Фон на вкладке Модель);
  • Model tab pointer (Указатель на вкладке Модель);
  • Layout tabs background (paper) (Фон на вкладках листов);
  • Layout tabs pointer (Указатель на вкладках листов);
  • AutoTrack vector color (Цвет вектора автоотслеживания);
  • Command line background (Фон командной строки);
  • Command line text (Текст командной строки);
  • Plot preview background (Фон окна предварительного просмотра чертежа).

Кнопки Default All (Вернуть все) и Default one element (Вернуть один) устанавливают стандартные цвета для всех элементов оформления или только для одного выбранного элемента.


11.2.3. Настройка открытия и сохранения

Следующая вкладка диалогового окна Options (Настройка) — Open and Save (Открытие/Сохранение) (рис. 11.10)— устанавливает основной формат сохранения рисунков, характеристики автосохранения, средства зашиты рисунка от несанкционированного доступа, а также особенности загрузки внешних ссылок и пользовательских приложений.

Рис. 11.10. Диалоговое окно Options, вкладка Open and Save

Обращаем внимание читателя на три области этой вкладки. В области File Save (Сохранение файлов) в раскрывающемся списке Save as (Сохранять в формате) можно установить, в каком формате по умолчанию будут сохраняться рисунки (например, в формате AutoCAD 2000/LT2000 Drawing (Рисунок AutoCAD 2000/LT2000)). По умолчанию действует установка сохранения в формате AutoCAD 2004 Drawing (Рисунок AutoCAD 2004).
В области File Safety Precautions (Меры предосторожности при сохранении) рекомендуем установить флажок Automatic save (Автосохранение). В поле Minutes between saves (Интервал, мин) лучше установить значение в районе 10—30 минут, чтобы какие-либо случайности или сбои компьютера не приводили к значительной потере выполненной работы. Системные переменные SAVEFILEPATH и SAVEFILE хранят, соответственно,
путь и имя файла автосохранения. Переменная SAVEFILEPATH доступна пользователю для установки своего собственного значения пути. Переменная SAVEFILE доступна только для чтения (примерная форма значения, формируемого системой — Drawingl_l_l_8467.sv$, где Drawing! — имя текущего рисунка).
Кнопка Security Options (Параметры безопасности) вызывает диалоговое окно для работы с паролем и электронной цифровой подписью (см. разд. 11.4.4).
В области File Open (Последние файлы) можно задать параметр Number of recently-used files to list (Количество последних открытых файлов). Это количество файлов, имена которых система запоминает и отображает в нижней части падающего меню File (Файл). По умолчанию оно равно четырем. Допускаются значения от 0 до 9.


11.2.4. Настройка печати

Вкладка Plotting (Печать) диалогового окна Options (Настройка) (см. рис. 6.2) задает параметры вывода на плоттер и рассмотрена в разд. 6.1.


11.2.5. Настройка общесистемных характеристик

Следующая вкладка диалогового окна Options (Настройка) — System (Система) (рис. 11.11) — задает различные общесистемные характеристики.
В области General Options (Общие параметры) следует обратить внимание на раскрывающийся список Startup (Начало работы), в котором может быть выбрано одно из следующих значений:

  • Show Startup dialog box (Показывать окно начата работы);
  • Do not show a startup dialog (He показывать окно начала работы).

При первом значении открывается окно начала работы (см. рис. 1.15). Второе значение позволяет начинать работу без диалогового окна, создавая новый рисунок с простейшими установками (при этом система запрашивает в командной строке имя файла шаблона). По сравнению с предыдущей версией системы из этого списка удален вариант, соответствующий началу работы с окном AutoCAD 2002 Today (Проектный центр).
Рассмотренные в данном разделе настройки влияют на работу команды QNEW (БНОВЫЙ). Эта команда открывает диалоговое окно Create New Drawing (Создание нового рисунка), когда в качестве имени шаблона на вкладке Files (Файлы) (см. разд. 11.2.1) задано None (Нет) и если в раскрывающемся списке Startup (Начало работы) выбрано первое значение, и диалоговое окно Select Template (Выбор шаблона), если выбрано второе значение.

Рис. 11.11. Диалоговое окно Options, вкладка System


11.2.6. Дополнительные настройки пользователя

Дополнительные системные настройки можно задать на вкладке User Preferences (Пользовательские) диалогового окна Options (Настройка) (рис. 11. 12).
На этой вкладке в области Windows Standard Behavior (Соответствие стандартам Windows) следует обратить внимание на кнопку с названием Right-click Customization (Правая кнопка мыши), которая позволяет вызвать окно Right-Click Customization (Правая кнопка мыши) (рис. 11.13). Установки этого окна задают варианты использования правой кнопки мыши (как инструмента вызова контекстного меню или аналога нажатия клавиши <Enter>) в разных ситуациях.
Если в верхней части окна флажок Turn on time-sensitive right-click (Выполнять обработку правого щелчка по его длительности) сброшен, то используются те же настройки, которые можно было задать в предыдущей версии системы AutoCAD.

Рис. 11.12. Диалоговое окно Options, вкладка User Preferences

Рис. 11.13. Диалоговое окно Right-Click Customization

Пользователь (особенно привыкший к работе с AutoCAD R14) может задать удобные ему функции правой кнопки устройства указания в трех областях диалогового окна. В области Default Mode (Обычный режим), установки которого применяются, когда нет выполняемой команды и нет выбранных примитивов, располагается группа из двух переключателей:

  • Repeat Last Command (Повтор последней команды);
  • Shortcut Menu (Контекстное меню).

Такие же переключатели есть и в области Edit Mode (Режим редактирования), установки которого используются, когда в рисунке выбран один или большее количество объектов.
В области Command Mode (Командный режим) возможно одно из трех положений переключателя:

  • ENTER — имитация нажатия клавиши <Enter>;
  • Shortcut Menu: always enabled (Контекстное меню: всегда доступно);
  • Shortcut Menu: enabled when command options are present (Контекстное меню: доступно, если команда имеет опции).

При выборе верхних положений переключателей во всех трех областях пользователь получит вариант работы с правой кнопкой мыши, идентичный варианту системы AutoCAD версии 14.
Однако при установке флажка Turn on time-sensitive right-click (Выполнять обработку правого щелчка по его длительности) пользователь системы AutoCAD 2004 получает совершенно новую возможность, при которой способ интерпретации программой щелчка правой кнопкой мыши ставится в зависимость от длительности этого щелчка. В поле Longer click duration (Время длинного щелчка) необходимо задать контрольное время, которое будет минимальной продолжительностью длинного щелчка (например, 250 миллисекунд, как на рис. 11.13). Все щелчки с меньшей длительностью будут считаться короткими. В таком режиме короткие щелчки интерпретируются как нажатие клавиши <Enter>, а длинные — как вызов контекстного меню.
На вкладке User Preferences (Пользовательские) диалогового окна Options (Настройка) (см. рис. 11.12) появилась новая кнопка Hidden Line Settings (Параметры скрытых линий), которая позволяет вызвать окно настройки параметров отображения невидимых линий.


11.2.7. Настройка привязки и отслеживания

Вкладка Drafting (Построения) диалогового окна Options (Настройка) (рис. 11.14) содержит различные параметры привязки и отслеживания, величину прицела перекрестия курсора и значков автоматической привязки.


11.2.8. Настройка режимов выбора

Вкладка Selection (Выбор) (рис. 11.15) задает режимы выбора и параметры ручек.

Рис. 11.14. Диалоговое окно Options, вкладка Drafting

Рис. 11.15. Диалоговое окно Options, вкладка Selection


11.2.9. Настройка профилей

Последняя вкладка— Profiles (Профили) (рис. 11.16)— позволяет присвоить имя профилю, т. е. набору параметров всех вкладок диалогового окна Options (Настройка), и при необходимости экспортировать параметры в файл с расширением arg.

Рис. 11.16. Диалоговое окно Options, вкладка Profiles

В левой части окна в списке Available profiles (Имеющиеся профили) перечисляются имена профилей, доступных в текущем рисунке. Вкладка имеет следующие кнопки:

  • Set Current (Установить) — устанавливает текущим профиль с отмеченным именем;
  • Add to List (Добавить) — сохраняет текущие установки в качестве нового профиля;
  • Rename (Переименовать) — переименовывает профиль;
  • Delete (Удалить) — удаляет профиль (это возможно только в том случае, если профиль не является текущим);
  • Export (Экспорт) — осуществляет экспорт профиля в файл с расширением arg;
  • Import (Импорт) — осуществляет импорт профиля из файла с расширением arg;
  • Reset (Сброс) — восстанавливает установки, действующие в системе AutoCAD по умолчанию.


11.2.10. Адаптация элементов интерфейса

Подменю Customize (Адаптация), входящее в падающее меню Tools (Сервис) (рис. 11.17), имеет следующие пункты настройки интерфейса системы:

  • Menus (Меню) — загрузка и выгрузка MNU-файлов фрагментных меню (дополнительных меню пользователя);
  • Toolbars (Панели) — подключение, удаление и адаптация панелей инструментов;
  • Keyboard (Клавиатура) — адаптация клавиш быстрого вызова;
  • Tool Palettes (Палитры) — адаптация панели Tool Palettes (Палитры инструментов);
  • Edit Custom Files (Редактирование файлов пользователя) — подменю редактирования системных файлов, содержит два пункта:
    • Current Menu (Текущее меню) — открывает для редактирования файл acad.mns;
    • Program Parameters (acad.pgp) (Параметры программ (acad.pgp)) — открывает для редактирования файл acad.pgp настройки параметров вызова внешних программ.

Рис. 11.17. Подменю Customize

Система AutoCAD позволяет создавать пользовательские меню, которые могут загружаться либо заменяя полностью все меню AutoCAD, либо дополняя меню AutoCAD новыми пунктами, подменю и т. п. Это вызвано тем, что все меню (падающие, экранные и контекстные), а также панели инструментов объединены в системе AutoCAD в один файл, который можно редактировать как обычный текстовый файл.


11.3. Программные средства адаптации

Система AutoCAD может использоваться как основа для разработки приложений, в которых AutoCAD играет роль графического процессора. Фирма Autodesk и ее партнеры уже создали много специализированных программных продуктов, работающих в среде AutoCAD (о них пойдет речь в приложении 4).
Перечислим средства адаптации AutoCAD: пользовательские меню, средства связи с базами данных, язык программирования Visual LISP, язык программирования Visual Basic и пакет ObjectARX (предназначен для программирования на языке С). Все эти средства представляют собой тему для отдельного разговора и в данной книге рассматриваются очень коротко.
Средства связи с базами данных в AutoCAD подключаются с помощью команды DBCONNECT (БДСВЯЗЬ), которой соответствует пункт Dbconnect (Связь с БД) падающего меню Tools (Сервис).
Команда DBCONNECT (БДСВЯЗЬ) вызывает окно DBCONNECT MANAGER (Диспетчер подключения к БД) (рис. 11.18) и добавляет в строку меню новое падающее меню dbConnect (Базы данных).

Рис. 11.18. Окно DBCONNECT MANAGER

Это окно имеет ту же организацию, как окна таких специальных панелей, как Properties (Свойства), Tool Palettes (Палитры инструментов). Окно может перемещаться, сворачиваться до вертикальной черты, закрепляться у края графического экрана.
Система AutoCAD предоставляет возможность связывать с примитивами рисунка информацию из таблиц баз данных разных версий приложений Microsoft Access, dBASE, Microsoft Excel, Oracle, Paradox, Microsoft Visual FoxPro и SQL Server. Для работы с этими средствами AutoCAD желательно иметь опыт работы с базами данных.
Для выхода из режима связи с базами данных нужно воспользоваться командой DBCCLOSE (ДСОЗАКРЫТЬ) или закрыть окно DBCONNECT MANAGER (Диспетчер подключения к БД) щелчком по кнопке [image] расположенной в левом верхнем углу окна.
Язык программирования AutoLISP является редакцией языка LISP, адаптированной для работы в среде AutoCAD. В данную версию AutoCAD входит модификация языка, называемая Visual LISP, обращение к которой осуществляется с помощью пункта падающего меню Tools | AutoLISP | Visual LISP Editor (Сервис AutoLISP Редактор Visual LISP) или команды VLISP, которые вызывают диалоговое окно Visual LISP for AutoCAD (Visual LISP для AutoCAD) (рис. 11.19).

Рис. 11.19. Диалоговое окно Visual LISP for AutoCAD

С помощью средств данного диалогового окна пользователь может писать, компилировать, тестировать и выполнять программы на языке Visual LISP.
Другим средством адаптации системы AutoCAD являются среда VBA (Visual Basic for Applications) и язык программирования Visual Basic. Команда VBAIDE и пункт падающего меню Tools | Macro | Visual Basic Editor (Сервис | Макрос | Редактор Visual Basic) вызывают диалоговое окно Microsoft Visual Basic (рис. 11.20), которое позволяет разрабатывать приложения, работающие в среде системы AutoCAD.

Рис. 11.20. Диалоговое окно Microsoft Visual Basic

Существует еше один пакет разработки приложений — ObjectARX 2004. Он не поставляется вместе с системой AutoCAD и позволяет разрабатывать на языке С в среде Visual Studio .NET приложения, работающие в среде AutoCAD.


11.4. Коллективная работа

В связи с тем, что AutoCAD во многих фирмах стал основным инструментом разработки проектной документации, в самой системе предусмотрены специальные средства коллективной работы, обмена файлами и зашиты документов.


11.4.1. Одновременный доступ

В системе AutoCAD 2002 была предусмотрена команда MEETNOW (ДОСТУП), предназначенная для коллективной работы группы пользователей в сети. Из системы AutoCAD 2004 эта команда исключена. Теперь следует применять программу Windows NetMeeting, вызываемую как стандартную программу из группы Связь.


11.4.2. Формирование комплекта документов

Для организации архивов, передачи файлов проекта заказчикам и соисполнителям предназначены команда ETRANSMIT (ФОРМКОМПЛЕКТ) и соответствующий ей пункт eTransmit (Сформировать комплект) падающего меню File (Файл).
Команда ETRANSMIT (ФОРМКОМПЛЕКТ) открывает диалоговое окно Create Transmittal (Формирование комплекта файлов) (рис. 11.21).

Рис. 11.21. Диалоговое окно Create Transmittal, вкладка General

Диалоговое окно имеет три вкладки. Вкладка General (Общие) предназначена для задания типа и особенностей формируемого архива. Текстовое поле Notes (Примечания) позволяет ввести примечания, включаемые в комплект. Если по путям доступа системы AutoCAD обнаруживается файл etransmit.txt, то текст из него автоматически вставляется в поле Notes (Примечания).
В раскрывающемся списке Туре (Тип) можно выбрать одно из трех значений, задающее тип комплекта файлов:

  • Self-extracting executable (*.exe) (Самораспаковывающийся ехе-файл);
  • Zip (*.zip) (Zip-файл);
  • Folder (set of files) (Папка с файлами).

В раскрывающийся список Location (Расположение) пользователь должен ввести путь и имя формируемого файла (папки). Путь можно выбрать и с помощью стандартной кнопки Browse (Обзор).
Кнопка Password (Пароль) дает возможность задать пароль для последующего чтения архива.
Установка флажка Convert drawings to (Преобразовать файлы в) позволяет перед архивацией выбрать формат (AutoCAD 2000 или AutoCAD 2004).
Во вкладке General (Общие) расположены еще четыре флажка:

  • Preserve directory structure (Сохранить структуру папок);
  • Remove paths from xrefs and images (Удалить пути из ссылок и изображений);
  • Send e-mail with transmittal (Отправить электронное уведомление);
  • Make web page files (Создать Web-страницу).

С помощью этих флажков можно задать такой тип комплекта, который максимально облегчит получателю восстановление структуры проекта и его папок.
Вкладка Files (Файлы) (рис. 11.22) дает возможность выбрать те файлы, которые должны войти в комплект.
В данной вкладке с помощью кнопки Add File (Добавить файл) можно указать те файлы (любых типов), которые должны быть включены в комплект. При установке флажка Include fonts (Включая шрифты) в массив автоматически добавляются файлы шрифтов с расширениями txt и shx (шрифты типа True Type не включаются). На рис. 11.22 структура формируемого массива показана в виде дерева. С помощью кнопки [image] можно показать ее в виде списка, а с помощью кнопки [image] — вернуть к форме дерева.
Третья вкладка— Report (Отчет) (рис. 11.23)— показывает текст отчета, который автоматически присоединяется к комплекту файлов.

Рис. 11.22. Диалоговое окно Create Transmittal, вкладка Files

Рис. 11.23. Диалоговое окно Create Transmittal, вкладка Report

С помощью расположенной в этой вкладке кнопки Save As (Сохранить как) отправитель может сохранить копию отчета в виде файла у себя.


11.4.3. Диспетчер ссылок

При работе со сложными проектами, использующими большое количество вспомогательных файлов (особенно файлов внешних ссылок), значительную помощь может оказать новая программа, появившаяся в системе AutoCAD 2004, — Reference Manager (Диспетчер ссылок). Эту программу можно запустить, войдя в системное меню Пуск | Программы (Start | Programs) и найдя в группе Autodesk | AutoCAD 2004 пункт [image] .
Программа работает независимо от того, запущен в данный момент AutoCAD или нет.
После выбора этого пункта открывается окно Reference Manager (Диспетчер ссылок) (рис. 11.24).

Рис. 11.24. Окно Reference Manager

В левой верхней части окна можно щелкнуть по кнопке [image] (Добавить рисунки) и выбрать те файлы рисунков, по которым необходимо вывести дерево ссылок. На рис. 11.24 на примере файла 8th floor.dwg, поставляемого в папке Sample системы AutoCAD 2004, показаны типы ссылок, которые отслеживаются программой Reference Manager (Диспетчер ссылок):

  • Fonts (Шрифты):
  • Plot Configurations (Конфигурации печати);
  • Plot Styles (Стили печати);
  • Shapes (Формы);
  • Standards (Стандарты);
  • Xrefs (Внешние ссылки).

В правой части окна перечисляются имеющиеся ссылки по всем типам. В данном окне можно изменять пути к файлам, на которые у рассматриваемого рисунка имеются ссылки. Для этого необходимо отметить те ссылки, которые будут изменяться, и щелкнуть по кнопке [image] (Изменить выбранные пути). В открывшемся диалоговом окне Edit Selected Paths (Изменить выбранные пути) (рис. 11.25) следует ввести новый путь к файлам изменяемых ссылок.

Рис. 11.25. Диалоговое окно Edit Selected Paths

Измененные ссылки помечаются в колонке Status (Статус) значком [image] , как на рис. 11.24. Для внесения сделанных изменений в сами рисунки следует в окне Reference Manager (Диспетчер ссылок) (см. рис. 11.24) щелкнуть по кнопке [image] (Применить изменения).

Замечание 1. Программа Reference Manager (Диспетчер ссылок) в настоящее время не поддерживает следующие типы ссылок: шрифты, на которые нет ссылок в текстовых стилях; OLE-связи; гиперссылки; связи с базами данных; РМР-файлы (файлы параметров калибровки принтера), внешние ссылки на адреса сети Интернет. 2. Пути к шрифтам типа True Type не сохраняются.


11.4.4. Защита паролем и цифровая подпись

В системе AutoCAD 2004 появилась возможность добавлять в рисунок пароль и электронную цифровую подпись. Файл, защищенный паролем, откроется только в том случае, когда пользователь введет правильный пароль. Открытый файл, даже если он имеет пароль, может редактироваться средствами AutoCAD.
Для того чтобы задать пароль для текущего рисунка, необходимо открыть диалоговое окно Options (Настройка) на вкладке Open and Save (Открытие/Сохранение) (см. рис. 11.10) и щелкнуть по кнопке Security Options (Параметры безопасности). Откроется диалоговое окно Security Options (Параметры безопасности) (рис. 11.26).

Рис. 11.26. Диалоговое окно Security Options, вкладка Password

Это окно имеет две внутренние вкладки. На вкладке Password (Пароль) в поле Password or phrase to open this drawing (Пароль или фраза для открытия этого рисунка) необходимо ввести ваш пароль. Если установить флажок Encrypt drawing properties (Шифровать свойства рисунка), то данные окна Drawing Properties (Свойства рисунка) (см. рис. 1.22) будут заноситься в шифрованном виде. Тип ключа шифрования выводится ниже поля Password or phrase to open this drawing (Пароль или фраза для открытия этого рисунка) (на рис. 11.26 — Microsoft Base Cryptographic Provider vl.0). Тип шифрования можно изменить в диалоговом окне Advanced Options (Дополнительные параметры) (рис. 11.27), которое открывается щелчком по одноименной кнопке в окне Security Options (Параметры безопасности).

Рис. 11.27. Диалоговое окно Advanced Options

Если вы имеете сертификат цифровой подписи, то вам в диалоговом окне Security Options (Параметры безопасности) будет доступна вкладка Digital Signature (Цифровая подпись), на которой вы можете установить флажок Attach signature after saving drawing (Добавить подпись после сохранения рисунка). После этого ваша цифровая подпись будет присоединяться к файлу рисунка, что станет подтверждением вашего авторства.
По закрытии окна Security Options (Параметры безопасности) вам будет предложено окно Confirm Password (Подтверждение пароля) (рис. 11.28), в котором установленный пароль необходимо будет ввести еще раз, для подтверждения.

Рис. 11.28. Диалоговое окно Confirm Password

Если вы открываете рисунок, имеющий пароль, то от вас потребуется ввод этого пароля (см. рис. 11.29).
При неправильном вводе пароля система AutoCAD не откроет этот рисунок. При вставке защищенного рисунка с помощью команд INSERT (ВСТАВИТЬ) или XREF (ССЫЛКА) также потребуется знание пароля.
Если файл рисунка имеет цифровую подпись, то его значок в окнах выбора файлов будет иметь вид [image] , а не [image] , как у обычных рисунков.

Рис. 11.29. Запрос пароля при открытии защищенного рисунка


11.4.5. DWF-формат

Для передачи файлов сторонним организациям (а иногда и заказчику) предусмотрен еще один формат сохранения — DWF. В этом формате файлы нельзя уже редактировать, а для просмотра следует использовать другую программу — Autodesk Express Viewer, которая автоматически устанавливается на компьютере одновременно с системой AutoCAD 2004.
Для вывода текущего чертежа в формат DWF следует пользоваться или командой PUBLISH (русский вариант команды на момент написания книги не известен), или пунктом Publish (Публикация) падающего меню File (Файл), или кнопкой [image] панели Standard (Стандартная). Команда открывает диалоговое окно Publish Drawing Sheets (Публикация листов чертежа) (рис. 11.30).
Каждая вкладка внутри DWF-файла имеет свое изображение. Вкладка Model (Модель) обычно не включается, но при необходимости тоже добавляется. При просмотре DWF-файла с помощью программы Autodesk Express Viewer (рис. 11.31) можно его сразу направить на устройство печати.


11.5. Express Tools 2004

Если вы при инсталляции системы AutoCAD выбрали и установку Express Tools 2004, то в строке меню у вас должно появиться падающее меню Express (Экспресс), которое дает доступ к дополнительным возможностям. После установки AutoCAD вы можете доустановить Express Tools, запустив повторную инсталляцию с диска и выбрав Step5. Install Supplemental Tools. AutoCAD Express Tools (Шаг 5. Установка дополнительных средств. AutoCAD Express Tools). Если меню Express (Экспресс) у вас не появилось, то попробуйте применить команды EXPRESSTOOLS и EXPRESSMENU.
На рис. П.32 приведен внешний вид падающего меню Express (Экспресс). Фирма Autodesk периодически на своем сайте обновляет Express Tools для разных версий AutoCAD. Следует отметить, что Express Tools 2004 не могут быть установлены в AutoCAD 2002 и в более ранних версиях системы.

Рис. 11.30. Диалоговое окно Publish Drawing Sheets

Рис. 11.31.Окно просмотра DWF-файла с помощью Autodesk Express Viewer

Рис. 11.32. Падающее меню Express

Кроме падающего меню, при установке Express Tools (сокращенно ЕТ) в системе появляются четыре панели, показанные на рис. 11.33.

Рис. 11.33. Панели инструментов Express Tools

Перечислим функции Express Tools в том порядке, в каком они расположены в виде двенадцати подменю в падающем меню Express (Экспресс) (см. рис. 11.32).


11.5.1. Подменю Layers

Подменю Layers (Слои) имеет следующие пункты (для тех операций, которым соответствуют кнопки панели инструментов ЕТ: Layers (ET: Слои), рядом с переводом приведены пиктограммы этих кнопок):

  • Layer Manager (Диспетчер слоев, [image] ) — позволяет сохранять и восстанавливать свойства слоев;
  • Layer Walk (Просмотр слоев, [image] ) — показывает объекты только тех слоев, которые отмечены в диалоговом окне;
  • Layer Match (Слой по образцу, [image] ) — переносит объекты на слой указанного примитива;
  • Change to Current Layer (На текущий слой, [image] ) — переносит объекты на текущий слой;
  • Copy Objects to New Layer (На новый слой, [image] ) — переносит объекты на другой слой, с возможностью создания этого слоя;
  • Layer Isolate (Изоляция слоя, [image] ) — выключение всех слоев, кроме слоев выбранных объектов;
  • Isolate Layer to Current Viewport (Изоляция слоя в видовом экране) — замораживание в текущем видовом экране пространства листа;
  • Layer Off (Выключение слоя, [image] ) — выключение слоев выбранных объектов;
  • Turn All Layers On (Включение всех слоев) — включает все слои;
  • Layer Freeze (Замораживание слоя, [image] ) — замораживает слои выбранных объектов;
  • Thaw All Layers (Размораживание всех слоев) — размораживает все слои;
  • Layer Lock (Блокировка слоя, [image] ) — блокирует слой выбранного объекта;
  • Layer Unlock (Разблокировка слоя, [image] ) — разблокирует слой выбранного объекта;
  • Layer Merge (Перенос со слоя на слой) — переносит все объекты с одного слоя на другой, с удалением первого слоя;
  • Layer Delete (Удаление слоя) — стирает все объекты на выбранном слое и удаляет слой.


11.5.2. Подменю Blocks

Подменю Blocks (Блоки) имеет такие пункты (для тех операций, которым соответствуют кнопки панели инструментов ЕТ: Blocks (ET: Блоки), рядом с переводом приведены пиктограммы этих кнопок):

  • List Xref/Block Properties (Свойства объекта из вхождения, [image] ) — показывает свойства примитива, входящего в состав блока или внешней ссылки;
  • Copy Nested Objects (Копирование объектов из вхождения, [image] ) — копирует примитивы, входящие в состав блоков или внешних ссылок;
  • Trim to Nested Objects (Обрезка объектами из вхождения, [image] ) — выполняет обрезку, используя в качестве режущих объектов примитивы, входящих в состав блоков или внешних ссылок;
  • Extend to Nested Objects (Продление до объекта из вхождения, [image] ) - выполняет продление, используя в качестве граничного объекта примитив, входящий в состав блока или внешней ссылки;
  • Explode Attributes to Text (Расчленение с преобразованием атрибутов в текст. ) — - расчленяет вхождения блоков или внешних ссылок, заменяя атрибуты на их значения, преобразованные в текстовые примитивы;
  • Convert Shape to Block (Преобразование формы в блок) — заменяет вставленную в рисунок форму на вхождение блока, для которого создается описание;
  • Export Attribute Information (Экспорт атрибутов) —- выполняет экспорт значении атрибутов в текстовый файл, в котором значения разделяются с и м вол о м табуляции;
  • Import Attribute Information (Импорт атрибутов) — выполняет замену значений атрибутов вхождений блоков, импортируя их из текстового файла, в котором значения разделяются символом табуляции;
  • Convert block to xref (Преобразование блока во внешнюю ссылку) — заменяет вхождения блока на внешнюю ссылку на указываемый файл;
  • Replace block with another block (Замена одного блока другим) — заменяет все вхождения одного блока на вхождения другого блока.


11.5.3. Подменю Text

Следующее подменю — Text (Текст). Оно имеет такие пункты (приведены соответствующие пиктограммы кнопок панели ЕТ: Text (ET: Текст)):

  • Remote Text (Внешний текст) — вставляет текст из внешнего ТХТ-файла, с возможностью использования выражений языка DIESEL, применяемого в макросах меню;
  • Text Fit (Сжатие текста, [image] ) — сжатие текста за счет изменения ширины букв;
  • Text Mask (Маскирование текста. ) — создание маски в виде прямоугольного объекта вокруг текстового примитива, для того чтобы под текстом не были видны другие примитивы рисунка;
  • Unmask Text (Демаскирование текста) — отказ от ранее созданной маски текстового примитива;
  • Explode Text (Расчленение текста, [image] ) — преобразование текстового примитива в полилинии;
  • Convert Text to Mtext (Преобразование текста в мультитекст) — заменяет выбранный однострочный текст из одной или нескольких строк на многострочный текст;
  • Arc-Aligned Text (Размещение текста по дуге, [image] ) — позволяет создать или отредактировать специальный текстовый примитив, выровненный вдоль дуги окружности;
  • Justify Text (Выравнивание текста) — изменяет способ выравнивания текста, или мультитекста, или описания атрибута, с сохранением внешнего вида примитива;
  • Rotate Text (Поворот текста) — изменяет наклон текста, или мультитекста, или описания атрибута, с целью преобразования к наиболее читаемому виду;
  • Enclose Text with Object (Обводка текста) — строит дополнительный объект (круг, полилинию в форме овала или полилинию в форме прямоугольника) вокруг текста, мультитекста или описания атрибута;
  • Automatic Text Numbering (Автоматическая нумерация текста) — изменяет текстовые примитивы, дополняя их номерами;
  • Change Text Case (Изменение регистра текста) — изменяет текстовые примитивы, преобразуя текст к нужному регистру.


11.5.4. Подменю Layout tools

Четвертое подменю Layout tools (Сервис листов) имеет следующие пункты:

  • Change Space (Смена пространства) — копирует в листе объект из одного пространства в другое, с сохранением внешнего вида;
  • Align Space (Выравнивание в пространстве) — изменяет вид и масштаб видового экрана в листе так, чтобы две точки, указанные в пространстве модели, преобразовались в две точки, указанные в пространстве листа;
  • Synchronize Viewports (Сихронизация видовых экранов) — изменяет масштаб видовых экранов на масштаб основного видового экрана;
  • List Viewport Size (Масштаб видового экрана) — выводит знаменатель масштаба видового экрана;
  • Merge Layout (Слияние листов) — перенос видовых экранов из нескольких листов в один.


11.5.5. Подменю Dimension

Пятое подменю Dimension (Размеры) имеет следующие пункты:

  • Leader Tools (Сервис выносок) — имеет три подпункта:
    • Attach Leader to Annotation (Присоединение выноски к надписи) — создает связь выноски с объектом (мультитекстом, допуском или блоком); при перемещении объекта конец выноски будет следовать за ним;
    • Detach Leader from Annotation (Отсоединение выноски от надписи) — разрывает связь между выноской и объектом надписи;
    • Global Attach Leader to Annotation (Глобальное присоединение выноски к надписи) — создает связи между выбранными выносками и указанными объектами надписей (мультитекстами, допусками и блоками);

  • Dimstyle Export (Экспорт размерных стилей) — сохраняет настройки размерных стилей в текстовом файле с расширением dim;
  • Dimstyle Import (Импорт размерных стилей) — импортирует настройки размерных стилей из файла с расширением dim;
  • Reset Dim Text Value (Восстановление размерного текста) — восстанавливает размерный текст, который был переопределен.


11.5.6. Подменю Selection tools

Следующее подменю падающего меню Express (Экспресс) — Selection tools (Сервис выбора). Это подменю имеет два пункта:

  • Get Selection Set (Создание набора) — создает текущий набор выбора, запрашивая имя слоя и тип объектов;
  • Fast Select (Быстрый выбор, кнопка [image] панели ЕТ: Standard (ЕТ: Стандартная)) — создает набор из примитивов, пересекающих данный объект.


11.5.7. Подменю Modify

Следующее подменю — Modify (Редактирование). Оно имеет такие пункты (там где имеются, после перевода приведены пиктограммы кнопок и названия панелей, на которых эти кнопки расположены):

  • Multiple Object Stretch (Множественное растягивание объектов, кнопка [image] панели ЕТ: Standard (ЕТ: Стандартная)) — выполняет операцию одновременного растягивания объектов;
  • Move/Copy/Rotate (Перенос/Копирование/Поворот, кнопка [image] панели ЕТ: Standard (ЕТ: Стандартная)) — выполняет операции переноса, копирования, поворота и масштабирования объектов в рамках одной команды;
  • Extended Clip (Расширенная подрезка, кнопка [image] панели ЕТ: Blocks (ЕТ: Блоки)) — выполняет подрезку вхождений блоков, внешних ссылок, пятен и растровых изображений границами, полученными аппроксимацией окружностей, дуг, эллипсов, полилиний, текстов, мультитекстов или описаний атрибутов;
  • Convert Shape to Block (Преобразование формы в блок) — заменяет вставленную в рисунок форму на вхождение блока, для которого создается описание (повтор одноименного пункта подменю Blocks (Блоки));
  • Multiple Copy (Множественное копирование, кнопка [image] панели ЕТ: Standard (ЕТ: Стандартная)) — копирует объекты, предлагая дополнительные возможности вставки копий аналогично работе команд DIVIDE (РАЗДЕЛИТЬ) и MEASURE (РАЗМЕТИТЬ);
  • Extended Offset (Расширенное подобие) — создает подобные (параллельные) объекты, предлагая дополнительные возможности: множественное построение, удаление исходного примитива, задание слоя нового объекта.


11.5.8. Подменю Draw

Восьмое подменю падающего меню Express (Экспресс) — Draw (Рисование). Оно имеет два пункта (в скобках после перевода приведены пиктограммы соответствующих кнопок панели инструментов ЕТ: Standard (ЕТ: Стандартная)):

  • Break-line Symbol (Обозначение разрыва, [image] ) — построение линии разрыва со вставкой знака разрыва из стандартного или пользовательского DWG-файла;
  • Suoer Hatch (Суперштриховка, [image] ) — создание суперштриховки из растровых изображений, внешних ссылок, блоков и пятен.


11.5.9. Подменю File tools

Девятое подменю — File tools (Сервис операций над файлами). Оно имеет следующие пункты:

  • Move Backup Files (Перемещение ВАК-файлов) — изменяет путь для размещения ВАК-файлов;
  • Convert PLT to DWG (Преобразование PLT в DWG) — вставляет в текущий рисунок содержимое PLT-файлов, сформированных в формате HPGL;
  • Edit Image (Редактирование изображения) — вызывает внешнюю программу редактирования растровых изображений;
  • Redefine Path (Переопределение путей) — модифицирует пути для вставленных растровых изображений, внешних ссылок, шрифтов, форм и примитивов RTEXT (внешних текстов);
  • Update Drawing Property Data (Обновление свойств рисунка) — изменяет данные, отображаемые в окне свойств рисунка, по шаблону;
  • Save All Drawings (Сохранение всех рисунков) — сохранение всех открытых рисунков без их закрытия; для неименованных рисунков запрашивается имя;
  • Close All Drawings (Закрытие всех рисунков) — закрывает все рисунки и предлагает сохранение для измененных рисунков;
  • Quick Exit (Быстрый выход) — закрывает все рисунки, предлагая сохранение для измененных рисунков, и выходит из AutoCAD;
  • Revert to Original (Переоткрытие) — закрывает текущий рисунок, предлагая сохранение при наличии изменений, и снова открывает его.


11.5.10. Подменю Web tools

В десятом подменю (Web tools (Сервис Web)) три пункта:

  • Show URLs (Показ URL, кнопка [image] панели инструментов ЕТ: Standard (Ы: Стандартная)) — показывает список использованных в рисунке адресов сети Интернет в формате URL (Universal Resource Locator);
  • Change URLs (Изменение URL) — редактирование URL-адресов;
  • Find and Replace URLs (Поиск и замена URL) — ищет и заменяет в рисунке одни URL-адреса на другие.


11.5.11. Подменю Tools

Следующее подменю падающего меню Express (Экспресс) — Tools (Сервис). Это подменю содержит следующие пункты:

  • Command Alias Editor (Редактор псевдоимен команд) — позволяет, не выходя из системы AutoCAD, редактировать псевдоимена команд, хранящиеся в файле acad.pgp;
  • System Variable Editor (Редактор системных переменных) — вызывает диалоговое окно, в котором можно просматривать и редактировать значения системных переменных;
  • Make Linetype (Создание типа линии) — создает новый тип линии по образцу и сохраняет его описание в файле с расширением Нп;
  • Make Shape (Создание формы) — создает новую форму по образцу и сохраняет ее описание в файле с расширением slip;
  • Real-Time UCS (ПСК реального времени) — врашает ПСК с заданным шагом угла в режиме реального времени относительно одной из осей;
  • Attach Xdata (Добавление расширенных данных) — присоединяет расширенные данные указанного приложения к примитиву:
  • List Object Xdata (Чтение расширенных данных) — выводит в текстовое окно расширенные данные приложения, сохраненные с прими швом:
  • Full-Screen AutoCAD (Полноэкранный режим) — распахивает окно AutoCAD на весь экран, сохраняя, в отличие от команды CLEANSCREEN, панели инструментов;
  • Extended Plan (Расширенный план) — формирует границы окна по указанному объекту после установки вида в плане (расширение команды PLAN (ПЛАН)).


11.5.12. Другие подменю и пункты меню Express

В состав падающего меню Express (Экспресс) входит вспомогательное подменю Web Links (Web-ссылки) со следующими пунктами:

  • Express Tools Web site (Сайт Express Tools) — запускает программу-браузер и устанавливает соединение с сайтом www.autodesk.com/ expresstools, посвященным Express Tools;
  • Express Tools Newsgroup (Группа новостей Express Tools) — запускает программу-браузер и устанавливает соединение с группой новостей news://discussion.autodesk.com/autodesk.expresstools, посвященной Express Tools;
  • Autodesk Products and Support Website (Продукты Autodesk и сайты поддержки) — запускает программу-браузер и устанавливает соединение с сайтом www.autodesk.com/products, на котором находятся сведения о программных продуктах фирмы Autodesk.

Два последних пункта меню Express (Экспресс) не являются названиями подменю:

  • Express Tools FAQ (Часто задаваемые вопросы по Express Tools) — открывает окно с разделом справочной системы с ответами на часто задаваемые вопросы по Express Tools;
  • Help (Справка) — открывает окно с оглавлением справочной системы Express Tools.


Глава 2. Примитивы

    • Примитивы
    • 2.1. Типы примитивов
    • 2.2. Отрезки
    • 2.3. Способы ввода координат точек
    • 2.4. Режимы
    • 2.5. Точки
    • 2.6. Лучи
    • 2.7. Прямые
    • 2.8. Окружности
    • 2.9. Дуги
    • 2.10. Полилинии
    • 2.11. Полилинии специального вида
    • 2.12. Мультилинии
    • 2.13. Надписи
    • 2.14. Размеры
    • 2.15. Штриховки и заливки
    • 2.16. Эллипсы
    • 2.17. Сплайны
    • 2.18. Другие примитивы
    • 2.19. Получение справок


Отрезки, дуги, окружности и другие графические объекты являются элементами, из которых состоит любой чертежный файл. В системе AutoCAD они носят название примитивов.


2.1. Типы примитивов

Примитивы могут быть простыми и сложными. К простым примитивам относятся следующие объекты: точка, отрезок, круг (окружность), дуга, прямая, луч, эллипс, сплайн, однострочный текст.
К сложным примитивам относятся: полилиния, мультилиния, мультитекст (многострочный текст), размер, выноска, допуск, штриховка, вхождение блока или внешней ссылки, атрибут, растровое изображение. Кроме того, есть пространственные примитивы, которые рассматриваются в гл. 9, видовые экраны, изучаемые в гл. 10, и редкие примитивы, приведенные в разд. 2.18.
Работа с большей частью примитивов рассматривается в данной главе, работа с блоками, внешними ссылками и растровыми изображениями — в гл. 7 и 8.
Операции построения большей части примитивов могут быть выполнены с помощью кнопок панели инструментов Draw (Рисование) (рис. 2.1).

Рис. 2.1. Панель инструментов Draw (Рисование)

По сравнению с предыдущими версиями в AutoCAD 2004 в панели Draw (Рисование) появилась новая кнопка [image] , соответствующая команде REVCLOUD (к моменту написания данной книги русской версии системы AutoCAD 2004 еще нет, поэтому русский аналог этой команды не известен).
Создавать примитивы можно также с помощью пунктов падающего меню Draw (Рисование) (рис. 2.2).

Рис. 2.2. Падающее меню Draw(Рисование)

По сравнению с предыдущими версиями в системе AutoCAD 2004 в падающем меню Draw (Рисование) появились новые пункты: Wipeout (Пятно), соответствующий команде WIPEOUT (русское наименование этой команды пока не известно), и Revision Cloud (Облако правки), соответствующий упомянутой ранее команде REVCLOUD.


2.2. Отрезки

Начнем с рисования отрезков. Панель Tool Palettes (Палитры инструментов) пока нам не нужна, поэтому уберите ее с экрана щелчком по кнопке [image] , расположенной в правом верхнем углу панели. Введите на клавиатуре LINE и нажмите клавишу <Enter> (любой ввод с клавиатуры должен завершаться этой клавишей). Тем самым будет вызвана команда LINE (ОТРЕЗОК). Данную команду можно вызвать также, воспользовавшись мышью, либо из падающего меню Draw (Рисование) с помощью пункта Line (Отрезок), либо из панели инструментов Draw (Рисование), применив кнопку [image] , которая является первой кнопкой панели.
Начальный вопрос, который задает система AutoCAD в командной строке (в дальнейшем приводятся два варианта запроса; верхняя строка — это форма запроса в англоязычной версии, нижняя строка — перевод или форма запроса в русскоязычной версии):
Specify first point: (Первая точка:)

Замечание AutoCAD ждет ответа только на тот вопрос, который им задан в командной строке. Если вы хотите перейти к другой команде, прервите действующую, нажав клавишу <Esc>.

Самый простой способ задания первой точки отрезка — указать ее с помощью мыши на видимой части графического экрана, а затем зафиксировать нажатием левой кнопки мыши. При выборе точки можно ориентироваться на счетчик координат в левом нижнем углу. После указания первой точки AutoCAD выводит очередной запрос:
Specify next point or [Undo]: (Следующая точка или [Отменить]:)
Часть запроса заключена в квадратные скобки. Это означает, что нужно либо указать на экране следующую точку (конечную точку отрезка) или выбрать опцию (т. е. вариант следующего шага команды). В качестве опции AutoCAD предлагает Undo (Отменить). Она отменяет ранее введенную начальную точку отрезка. Чтобы воспользоваться опцией, необходимо ее набрать в командной строке с помощью клавиатуры в верхнем или нижнем регистре и нажать <Enter>. Если в наименовании опции какая-то часть выделена прописными буквами (в данном случае это буква U (О)), то достаточно на клавиатуре ввести только эту часть имени опции, причем можно сделать это в верхнем или нижнем регистре (т. е. U (О) или u (о)) и опять-таки нажать клавишу <Enter>. В дальнейшем будем считать, что пользователь уже привык любой ввод с клавиатуры завершать клавишей <Enter>.
Если вы выберете опцию Undo (Отменить), то AutoCAD отменит предыдущую точку и опять попросит ввести первую.
Если вы укажете на экране с помощью мыши следующую точку, то на экране появится отрезок (рис. 2.3), проведенный из первой точки во вторую. Команда LINE (ОТРЕЗОК) на этом не закончится и будет выдан запрос:
Specify next point or [Undo]: (Следующая точка или [Отменить}:)
Появление данного запроса означает, что одной командой можно нарисовать поочередно несколько отрезков, образующих на экране одну ломаную линию. Укажите на экране третью точку. На этот раз очередной запрос будет выглядеть так:
Specify next point or [Close/Undo]: (Следующая точка или [Замкнуть/Отменить]:)
Здесь, помимо опции Undo (Отменить), появилась опция Close (Замкнуть). Если имеется выбор из нескольких опций, то они разделяются символом "/". После ввода на клавиатуре С (3), в верхнем или нижнем регистре, и нажатия клавиши <Enter> AutoCAD нарисует еще один отрезок, идущий из конца предыдущего отрезка в начало первого (рис. 2.4).
Если вы не хотите строить замыкания отрезков, а хотите просто завершить команду LINE (ОТРЕЗОК), то нажмите клавишу <Enter>, которая всегда является признаком конца циклических операций. Разумеется, можно было нажать <Enter> после ввода второй точки. Тогда третий отрезок не был бы построен и команда LINE (ОТРЕЗОК) завершилась бы, а в командной строке появилось бы приглашение Command: (Команда: ) (что всегда означает правильное завершение любой команды в системе AutoCAD.

Рис. 2.3. Построение одного отрезка

Рис. 2.4. Построение замкнутой ломаной линии из отрезков

Есть еще один вариант завершения команды LINE (ОТРЕЗОК). Вместо <Enter> можно поместить указатель мыши внутрь графического экрана и нажать правую кнопку мыши. При этом на месте, где находился конец указателя, появится контекстное меню (рис. 2.5). Контекстное меню — это удобный инструмент, помогающий выбрать следующий шаг работы. Оно вызывается при нажатии правой кнопки мыши практически в любой момент.

Замечание В системе AutoCAD 2004 можно выполнить такую настройку (см. гл. 11), при которой краткий щелчок правой кнопки мыши будет работать как нажатие клавиши <Enter>, а долгий щелчок— вызывать контекстное меню.

Рис. 2.5. .Контекстное меню команды LINE

Содержание контекстного меню зависит от выполняемой в данный момент команды. В меню на рис. 2.5 приводятся варианты продолжения работы команды LINE (ОТРЕЗОК): Enter, Cancel (Прервать), Close (Замкнуть), Undo (Отменить), Pan (Панорамирование), Zoom (Зумирование). Выбор пункта в этом меню осуществляется устройством указания обычным образом (нажатием левой кнопки мыши). Пункт меню Enter заканчивает команду, пункт Cancel (Прервать) прерывает работу команды (в данный момент это равносильно пункту Enter). Действие пунктов Close (Замкнуть) и Undo (Отменить) аналогично действию одноименных опций, описанных ранее. Пункты Pan (Панорамирование) и Zoom (Зумирование) вызывают прозрачные команды (т. е. временно прерывающие действие работающей команды) PAN (ПАН) и ZOOM (ПОКАЗАТЬ). Эти команды позволяют изменить масштаб, а также размер отображения на экране необходимой зоны рисунка и рассматриваются в разд. 2.4.
Если нажать клавишу <Enter> вместо указания второй точки, то команда LINE (ОТРЕЗОК) также завершится, не построив никакого объекта. А вот если нажать <Enter> уже вместо задания первой точки, то вместо нее будет взята конечная точка последнего построенного объекта (отрезка, полилинии или дуги), а если рисунок пуст и предыдущего объекта нет, то будет выдано сообщение об ошибке:
No line or arc to continue. Specify first point: (Нет ни дуги, ни отрезка, которые можно продолжить. Первая точка:)

Замечание Дуга и полилиния являются новыми для нас примитивами. О них рассказывается в разд. 2.9 и 2.10.

В случае, если последним построенным объектом был примитив, у которого нет конечной точки (например, текст), то AutoCAD ищет предпоследний и т. д., пока не найдет отрезок, полилинию или дугу. Если последним подходящим объектом был отрезок или полилиния, у которой только что введенный участок является прямолинейным сегментом, то дальше система запрашивает следующую точку. Однако если последним найденным объектом оказалась дуга или полилиния, у которой только что введенный участок является дуговым, то AutoCAD дальше строит отрезок, который является продолжением найденной дуги по касательной, и выдает запрос:
Length of line: (Длина отрезка:)
На этот вопрос вам нужно либо ввести при помощи клавиатуры число, либо задать на экране временную точку, до которой AutoCAD вычислит расстояние от предыдущей точки. Полученное одним из двух способов число станет длиной в миллиметрах будущего отрезка, являющегося продолжением дуги по касательной.
Таким образом, одной командой LINE (ОТРЕЗОК) можно нарисовать один или несколько последовательно расположенных отрезков. Признаком окончания команды является нажатие клавиши <Enter> или ввод опции замыкания — символа С (3). Прерывание команды с помощью клавиши <Esc> или пункта Cancel (Отмена) контекстного меню тоже завершит команду LINE (ОТРЕЗОК).
По любому из построенных отрезков можно с помощью команды LIST (СПИСОК) получить справочную информацию: координаты концов, угол наклона и т. п. — см. разд. 2.19.


2.3. Способы ввода координат точек

В предыдущем разделе вы задавали конечные точки отрезка с помощью мыши. Но этот способ ввода (указания) точек не является единственным. Больше распространен второй способ — ввод координат точки с клавиатуры, например: 65,113.24
В данном примере введена точка с двумя координатами: X = 65 мм, Y= 113,24 мм. При вводе координат с клавиатуры запятая является разделителем между абсциссой и ординатой, а точка используется как разделитель между целой и дробной частью числа. Вводимые координаты могут быть целыми или вещественными. При вводе координат следует учитывать, где вы выбрали точку с координатами 0.0. Чаше всего это точка левого утла графического экрана (хотя в процессе работы вы перемещаетесь по рисунку, и точка 0,0 может оказаться в любом месте, даже уйти в невидимую часть чертежа).
Третий способ ввода точек — это относительный ввод в декартовых координатах с клавиатуры, например: @50,25
Данная запись означает, что новая точка задается относительно предыдущей (что определяет символ "@") со сдвигом по оси X на +50 мм (т. е. вправо на 50 мм) и сдвигом по оси Y на +25 мм (т. е. вверх на 25 мм). Здесь запятая также является разделителем координат. Вводимые числа могут быть целыми и вещественными, положительными, нулевыми и отрицательными.
Четвертый способ ввода точек — это относительный ввод в полярных координатах с клавиатуры, например: @33.5<45
В этой форме записи уже нет запятых, зато появился символ "<", который интерпретируется как знак угла. В данном примере новая точка задается относительно предыдущей, причем расстояние между ними в плоскости равно 33,5 мм (т. е. числу влево от символа угла), а вектор из предыдущей точки в новую образует угол 45° с положительным направлением оси абсцисс (угол измеряется в тех угловых единицах, которые были заданы в настройке единиц измерения в разд. 1.7}. Расстояние должно обязательно быть положительным, а угол может быть числом с любым знаком.
Пятый способ ввода точек — это указание с помощью функций объектной привязки. Доступ к функциям объектной привязки осуществляется либо через панель Object Snap (Объектная привязка), либо через контекстное меню, которое рассматривается далее в данном разделе.
В разд. 1.3 рассказано, как вывести панель инструментов, если она отсутствует на экране. Вызовите панель Object Snap (Объектная привязка) (рис. 2.6).

Рис. 2.6. Панель Object Snap

В этой панели собраны следующие кнопки (более подробное их рассмотрение будет ниже, по ходу изложения соответствующих функций):

  • — использование отслеживания с помощью промежуточной точки;
  • — смещение от другой (вспомогательной) точки;
  • — конечная точка;
  • — средняя точка;
  • — точка пересечения двух объектов или их продолжений;
  • — точка мнимого пересечения двух объектов или их продолжений (т. е. пересекаются только проекции объектов на текущую плоскость построений);
  • — точка продолжения;
  • — центр дуги, окружности или эллипса;
  • — точка квадранта дуги, окружности или эллипса (это точки, расположенные на 0°, 90°, 180° и 270°);
  • — точка касания;
  • — перпендикулярно объекту;
  • — параллельно объекту;
  • — точка вставки текста, блока, внешней ссылки;
  • — узловая точка;
  • — ближайшая к объекту точка;
  • — без использования объектной привязки;
  • — настройка постоянных режимов привязки.

Рассмотрим использование кнопок объектной привязки и соответствующих им функций на следующем примере. Предположим, на экране есть два отрезка и необходимо построить третий, который идет от конца одного до конца другого. Для этого надо вызвать команду LINE (ОТРЕЗОК) и в ответ на запрос Specify first point: (Первая точка:) с помощью левой кнопки мыши выбрать в панели инструментов Object Snap (Объектная привязка) кнопку [image] соответствующую функции Endpoint (Конточка).
Тогда при подведении указателя мыши к концу первого отрезка, от которого нужно взять конечную точку, появляется желтый (при изменении настройки он может быть другого цвета) квадрат работы функции Endpoint (Конточка) (рис. 2.7).

Рис. 2.7. Выбор первой точки нового отрезка с помощью функции Endpoint

Если вы считаете, что конечная точка выбрана правильно, то вам остается нажать на левую кнопку мыши. Если AutoCAD выбрал не ту точку (а это может оказаться конечная точка другого близлежащего объекта), то необходимо переместить указатель мыши ближе к той точке, которая вам нужна. Аналогично в ответ на запрос Specify next point or [Undo]: (Следующая точка или [Отменить]:) необходимо с помощью левой кнопки мыши снова щелкнуть по кнопке [image] панели Object Snap (Объектная привязка), а затем подвести указатель к концу второго отрезка и нажать на левую кнопку мыши. В ответ на очередной запрос Specify next point or [Undo]: (Следующая точка или [Отменить]:) можно нажать клавишу <Enter>, чтобы завершить команду LINE (ОТРЕЗОК).
В рассмотренной нами ситуации использование функции объектной привязки к концу объекта было обязательным, поскольку рисование "на глаз" (т. е. без применения тех или иных функций) всегда приводит к погрешности построений и заметно ухудшает эстетические свойства чертежа. Данный пример предполагал, что кнопка режима OSNAP (ПРИВЯЗКА) выключена. Несколько иное использование функций объектной привязки будет при включенном режиме OSNAP (ПРИВЯЗКА). Об этом см. разд. 2.4. Другой пример. Предположим, нужно построить отрезок, идущий от середины одного отрезка к середине другого. Выполняется это аналогично предыдущему примеру, но при задании обоих концов отрезка следует пользоваться не функцией Endpoint (Конточка), а функцией Midpoint (Середина), которой соответствует кнопка [image] Еще одна возможность обращения к функциям объектной привязки — это вызов контекстного меню привязки с помощью нажатой клавиши <Shift> и одновременного нажатия на правую кнопку мыши (рис. 2.8) (при этом курсор должен обязательно находиться внутри графического экрана и не попадать ни на какую панель инструментов).

Рис. 2.8. Контекстное меню объектной привязки

Это меню по своим функциям очень похоже на панель инструментов Object Snap (Объектная привязка). Дополнением является лишь пункт Point Filters (Координатные фильтры), который позволяет воспользоваться одним из шести вариантов координатных фильтров: .X, .Y, .Z, .XY, .XZ, .YZ. Функция координатного фильтра чаще всего используется в трехмерных построениях. Она позволяет взять одну или две координаты из какой-нибудь точки рисунка и затем задать остальные координаты. Например, если для следующей точки (скажем, конца отрезка) нужно взять абсциссу от другой точки, то следует в ответ на запрос точки ввести на клавиатуре .X (или выбрать одноименный пункт контекстного меню). Дальше системе AutoCAD необходимо указать точку любым из известных вам способов, у которой будет вычислена абсцисса, а затем по следующему запросу системы (need YZ): ((требуется YZ):) ввести на клавиатуре оставшуюся координату (или оставшиеся координаты, если речь идет о трехмерной точке).


2.4. Режимы

Как вы уже знаете из разд. 1.3, под зоной командных строк находится строка с прямоугольными кнопками режимов: SNAP (ШАГ), GRID (СЕТКА), ORTHO (OPTO), POLAR (ОТС-ПОЛЯР), OSNAP (ПРИВЯЗКА), OTRACK (ОТС-ПРИВ), LWT (ВЕС), MODEL (МОДЕЛЬ). Режим считается включенным, если включена (нажата) соответствующая ему кнопка. Включение и выключение кнопки режима осуществляется щелчком левой кнопки мыши. Если подвести указатель мыши к кнопке режима, то над кнопкой через мгновение появится соответствующая подсказка: Snap Mode (Шаговая привязка), Grid Display (Отображение сетки), Ortho Mode (Режим "Орто"), Polar Tracking (Полярное отслеживание), Object Snap (Объектная привязка), Object Snap Tracking (Объектное отслеживание), Show/Hide Lineweight (Отображение линий в соответствии с весами), Model or Paper Space (Пространство модели или листа).
Кнопка SNAP (ШАГ) позволяет включать или выключать режим привязки к точкам сетки с определенным настраиваемым шагом (перемещения тогда осуществляются по прямолинейным сегментам с заданным шагом) или к угловой привязке (вблизи определенных углов перемещения осуществляются только по сегментам с заданным шагом). Роль кнопки SNAP (ШАГ) выполняет также функциональная клавиша <F9> клавиатуры.
Кнопка GRID (СЕТКА) позволяет включать или выключать отображаемую в зоне лимитов сетку из точек с настраиваемым шагом (рис. 2.9). Эта сетка может отличаться от сетки, используемой в режиме SNAP (ШАГ). Аналогом кнопки является функциональная клавиша <F7>.

Рис. 2.9. Отображение сетки

Кнопка ORTHO (ОРТО) включает или выключает режим ортогональности. Если этот режим включен, то AutoCAD начинает корректировать вновь строящиеся прямолинейные сегменты отрезков и полилиний до вертикальности или до горизонтальности. Для включения или выключения режима можно также использовать клавишу <F8>.
Кнопка POLAR (ОТС-ПОЛЯР) является расширением режима ORTHO (ОРТО) на углы с некоторым настраиваемым шагом (в зависимости от того, что ближе к данным пользователя). Кнопка включает или выключает режим полярного отслеживания. Аналогом кнопки является функциональная клавиша <F10>. На рис. 2.10 показано, как система отслеживает угол 45° (если указатель мыши оказывается вблизи заданного угла, то система сама округляет данные до этого угла). О настройке режима полярного отслеживания см. далее.

Рис. 2.10. Режим полярного отслеживания (POLAR)

При включении режима POLAR (ОТС-ПОЛЯР) автоматически выключается режим ORTHO (ОРТО), если он был включен. Аналогично режим ORTHO (ОРТО) отключает режим POLAR (ОТС-ПОЛЯР).
Кнопка OSNAP (ПРИВЯЗКА) позволяет включать или выключать режим постоянного действия заданных функций объектной привязки (перечень одновременно действующих привязок настраивается). При указании точки на объекте система AutoCAD вычисляет соответствующую функцию объектной привязки к этому объекту (т. е. конечную точку или среднюю точку и т. п.). Аналогом кнопки является функциональная клавиша <F3>.
При включении с помощью кнопки OTRACK (ОТС-ОБЪЕКТ) режима объектного отслеживания система AutoCAD позволяет использовать полярное отслеживание от промежуточной точки, указываемой с применением объектной привязки. Аналогом кнопки является функциональная клавиша <F11>. На рис. 2.11 показан пример использования режима объектного отслеживания.

Рис. 2.11. Использование режима объектного отслеживания (OTRACK)

В этом примере строится отрезок, у которого начальная точка взята в правом нижнем углу рисунка, а конечную нужно расположить на прямой, проходящей через середину правой стороны прямоугольника и образующей угол 45° с горизонталью (положительным направлением оси X). Для этого необходимо включить режимы OSNAP (ПРИВЯЗКА) и OTRACK (ОТС-ОБЪЕКТ), причем в настройке объектной привязки должна быть включена функция привязки к середине, в настройке полярного отслеживания должен быть задан угол 45°, а в настройке объектного отслеживания должна быть задана возможность отслеживания всех полярных углов (о настройке см. далее). В команде LINE (ОТРЕЗОК) при указании второй точки следует подвести указатель мыши к середине правой стороны прямоугольника, подождав, пока AutoCAD обнаружит середину, о чем просигнализирует значком треугольника в этой точке, и затем, не нажимая клавиш мыши, отвести устройство указания вправо вверх под углом 45°. Поймав нужный угол, система просигнализирует об этом пунктирной линией и подсказкой угла (на рис. 2.11 — Midpoint: 144.5404 < 45°).
Кнопка LWT (ВЕС) включает или выключает режим отображения весов элементов чертежа. Вес линии — это ширина, с которой линия будет выводиться на внешнее устройство. Подробнее о весах см. разд. 4.4.
Кнопка MODEL (МОДЕЛЬ) позволяет переключаться между пространствами модели и листа (см. гл. 10).
Настройка режимов может быть осуществлена с помощью команды DSETTINGS (РЕЖИМРИС), открывающей диалоговое окно Drafting Settings (Режимы рисования). Команда может быть введена с клавиатуры или выполнена с помощью пункта Drafting Settings (Режимы рисования) падающего меню Tools (Сервис), а также с помощью пункта Settings (Настройка) контекстного меню, вызываемого с помощью щелчка правой кнопкой мыши, если вы ставите ее указатель на одну из кнопок режимов (кроме кнопок ORTHO (OPTO), LWT (ВЕС), MODEL (МОДЕЛЬ)), как показано на рис. 2.12.

Рис. 2.12. Вызов контекстного меню настройки режимов

Диалоговое окно Drafting Settings (Режимы рисования), как видно на рис. 2.13, имеет три вкладки: Snap and Grid (Шаг и сетка), Polar Tracking (Отслеживание) и Object Snap (Объектная привязка). Активизация нужной вкладки выполняется щелчком левой кнопки мыши, когда курсор находится на имени соответствующей вкладки.
Вкладка Snap and Grid (Шаг и сетка) позволяет задать установки шага привязки к узлам сетки и параметры сетки, отображаемой в зоне лимитов. В верхней части находятся два флажка, которые отображают состояние режимов Snap On (F9) (Шаг Вкл) и Grid On (F7) (Сетка Вкл) (при включенном режиме соответствующий флажок должен быть установлен).
Оставшаяся часть вкладки имеет четыре области. В области Snap (Шаговая привязка) задаются параметры узлов сетки для шагов мыши. Это расстояние по обеим осям (Snap X spacing (Шаг привязки по X) и Snap Y spacing (Шаг привязки по Y)), угол наклона сетки относительно горизонтали (Angle (Поворот)) и база отсчета координат сетки (X base (База по X) и Y base (База по Y)). В области Grid (Сетка) задаются параметры отображаемой сетки (Grid X spacing (Шаг сетки по X) и Grid Y spacing (Шаг сетки по Y)). В правом нижнем углу выбирается вариант привязки: Grid snap (Шаговая привязка) — привязка к узлам прямоугольной (Rectangular snap (Ортогональная)) или изометрической (Isometric snap (Изометрическая)) сетки — или угловая (Polar snap (Полярная привязка)). В левой нижней части вкладки приведен параметр шага угловой привязки (Polar Distance (Шаг полярной привязки)). Причем параметры шаговой или угловой привязки доступны, только если в разделе Snap type & style (Тип и стиль привязки) включен переключатель Polar snap (Полярная привязка).

Рис. 2.13. Диалоговое окно Drafting Settings, вкладка Snap and Grid

В нижней части диалогового окна находятся кнопка Options (Настройка), которая позволяет вызвать диалоговое окно настройки системы AutoCAD (оно будет рассмотрено в гл. 11), и кнопки OK, Cancel (Отмена) и Help (Справка).
Вкладка Polar Tracking (Отслеживание) (рис. 2.14) позволяет задать отслеживание углов с определенным шагом. Для указания шага в раскрывающемся списке Increment angle (Шаг углов) доступны следующие значения: 5, 10, 15, 18, 22.5, 30, 45, 90. Если вы хотите отслеживать еще какие-то углы, нужно установить флажок Additional angles (Дополнительные углы) и нажать кнопку New (Новый), которая даст возможность ввести значение нового угла. Кнопка Delete (Удалить) позволяет вам удалить лишние значения из списка дополнительных углов. Область Object Snap Tracking Settings (Отслеживание при объектной привязке) предоставляет возможности настройки отслеживания при привязке: только ортогональных (Track othogonally only (Только ортогонально)) или всех полярных углов (Track using all polar angle settings (По всем полярным углам)). В области Polar Angle measurement (Отсчет полярных углов) задается способ измерения полярных углов: Absolute (Абсолютно) или Relative to last segment (От последнего сегмента).

Рис. 2.14. Диалоговое окно Drafting Settings, вкладка Polar Tracking

Вкладка Object Snap (Объектная привязка) (рис. 2.15) управляет заданием режимов объектной привязки и объектного отслеживания.

Рис. 2.15.Диалоговое окно Drafting Settings, вкладка Object Snap

Новинка AutoCAD 2004 — меню настройки строки режимов (рис. 2.16).

Рис. 2.16. Меню настройки строки режимов

Это меню можно вызвать либо с помощью значка [image] , расположенного в правой части строки состояния, либо щелчком правой кнопки мыши при положении курсора между кнопками режимов и значком [image] . В меню пункт Cursor coordinate values (Координаты курсора) показывает, отображаются ли в данный момент координаты курсора при движении по графическому экрану (если да, то флажок установлен).
Следующие восемь пунктов описывают состояние восьми режимов. Если режим включен, то флажок в соответствующей строке будет установлен.
Последний пункт меню настройки режимов — Tray Settings (Параметры лотка). При щелчке по данному пункту меню вызывается диалоговое окно Tray Settings (Параметры лотка) (рис. 2.17), которое управляет настройками получения через Интернет уведомлений об обновлениях системы.

Рис. 2.17. Диалоговое окно Tray Settings

Если сбросить флажок Display icons from services (Показывать значки служб), то значок [image] с лотка исчезнет.
При работе с рисунком постоянно приходится изменять окно просмотра, для того чтобы рассмотреть необходимые элементы. Этой цели служат вертикальная и горизонтальная линейки прокрутки графического экрана, а также расположенные в панели инструментов Standard (Стандартная) кнопка [image] (Pan Realtime (Панорамирование в реальном времени)) и правее нее — кнопка [image] (Zoom Realtime (Зумирование в реальном времени)).
Кнопка [image] вызывает команду PAN (ПАН), которая выполняет операцию панорамирования и работает следующим образом. После того как вы нажали на кнопку и отпустили ее, а затем переместили указатель мыши в зону графического экрана, форма указателя изменяется на значок панорамирования в виде ладони. Теперь нужно нажать левую кнопку мыши и, не отпуская, перемещать указатель в другое место. Вместе с указателем будет двигаться весь рисунок. Сместив таким образом изображение на новое место, можно отпустить левую кнопку мыши. Масштаб изображения в новом окне сохраняется, а отображаемая зона смещается (при этом что-то может оказаться за пределами нового окна и стать невидимым, а что-то ранее невидимое может появиться). Затем, при необходимости, можно перенести указатель мыши к новому месту начала операции панорамирования и выполнить операцию еще раз. Когда панорамирование закончено, следует воспользоваться подсказкой, выдаваемой системой AutoCAD:
Press ESC or ENTER to exit, or right-click to display shortcut menu. (Нажмите ESC или ENTER для выхода или правую кнопку мыши для вывода контекстного меню.)
Клавиши <Esc> и <Enter> позволяют завершить команду панорамирования. Если нажать правую кнопку мыши, то появится контекстное меню со следующими пунктами: Exit (Выход), Pan (Панорамирование), Zoom (Зумирование), 3D Orbit (3M орбита), Zoom Window (Показать Рамка), Zoom Original (Показать Исходный), Zoom Extents (Показать Границы), причем строка Pan (Панорамирование) будет помечена галочкой. Используя соответствующие пункты этого меню, вы можете либо закончить действие команды, либо остаться в команде PAN (ПАН), либо перейти к командам зумирования, позволяющим менять размер и масштаб области, отображаемой на экране (о команде 3DORBIT (3-ОРБИТА), соответствующей пункту 3D Orbit (3M орбита) падающего меню View (Вид), см. гл. 9).
Кнопка [image] выполняет зумирование (изменение масштаба отображения рисунка с сохранением центра изображения). После того как вы нажали на кнопку зумирования (на ней изображена лупа со знаком "±") и отпустили левую кнопку мыши, вы перемещаете указатель мыши в зону графического экрана. Указатель принимает форму лупы с плюсом и минусом. Вам необходимо нажать левую кнопку мыши и, не отпуская, буксировать вверх или вниз. Если вы буксируете вверх, то изображение на экране увеличивается, если вниз — уменьшается. Окончание команды зумирования такое же, как и у команды панорамирования, т. е. нажатие клавиши <Esc>, <Enter> или правой кнопки мыши.
Правее кнопки зумирования в реальном времени находится групповая (т. е. с треугольником в правом нижнем углу) кнопка [image] с вариантами команды ZOOM (ПОКАЗАТЬ). Если щелкнуть по групповой кнопке и не отпускать левую кнопку мыши, то вызовется панель инструментов Zoom (Зумирование), которая оформлена как подменю (рис. 2.18).

Рис. 2.18. Панель с опциями команды ZOOM

Эта панель содержит следующие кнопки:

  • — Zoom Window (Показать Рамка);
  • — Zoom Dynamic (Показать Динамика);
  • — Zoom Scale (Показать Масштаб);
  • — Zoom Center (Показать Центр);
  • — Zoom In (Увеличить);
  • — Zoom Out (Уменьшить);
  • — Zoom All (Показать Все);
  • — Zoom Extents (Показать Границы).

Команду ZOOM (ПОКАЗАТЬ), управляющую границами и масштабом отображаемой части рисунка, можно вызвать также из падающего меню View (Вид). Мы ее рассмотрим в самом общем варианте, когда она вводится с клавиатуры. После ввода команды система AutoCAD выдает запрос:
Specify corner of window, enter a scale factor (nX or nXP), or [All/Center/Dynamic/Extents/Previous/Scale/Window] <real time >: (Укажите угол рамки, введите масштаб (nХ или nХЛ), или [Все/Центр/Динамика/Границы/Предыдущий/Масштаб/Рамка] <реальное время >:)
В ответ на этот запрос пользователь может выбрать один из вариантов:

  • ввести букву А (В), соответствующую опции All (Все);
  • ввести букву С (Ц), соответствующую опции Center (Центр);
  • ввести букву D (Д), соответствующую опции Dynamic (Динамика);
  • ввести букву Е (Г), соответствующую опции Extents (Границы);
  • ввести букву Р (П), соответствующую опции Previous (Предыдущий);
  • ввести букву S (М), соответствующую опции Scale (Масштаб);
  • ввести положительное число масштаба, без окончания или с окончанием X или ХР (имейте в виду, что буквы X и Р латинские (!), например: 2.5Х, 1.67ХР);
  • ввести букву W (Р), соответствующую опции Window (Рамка);
  • указать мышью точку (первый угол будущей рамки, подразумевается опция Window (Рамка));
  • нажать клавишу <Enter> (это выбор опции по умолчанию, которая предлагается системой AutoCAD в угловых скобках), переходя в режим зумирования в реальном времени;
  • нажать правую кнопку мыши (если курсор находится внутри графического экрана) и выбрать необходимую опцию из контекстного меню.

При выборе опции Window (Рамка) система AutoCAD запрашивает два угла (две угловых точки) для задания прямоугольной зоны в видимой части рисунка, которая будет увеличена до размеров всего графического экрана. Сначала выдается запрос:
Specify first corner: (Первый угол:)
Затем запрашивается второй угол (рис. 2.19):

Рис. 2.19. Выбор рамки в команде ZOOM

Specify opposite corner: (Противоположный угол:)
После этого в новом окне отмеченная на предыдущем шаге зона рисунка займет весь графический экран, как это видно на рис. 2.20 (по краям отмеченная зона может быть расширена до пропорций графического экрана).

Рис. 2.20. Результат выполнения команды ZOOM с опцией Window

Указание точки мышью (вместо выбора опций) рассматривается командой ZOOM (ПОКАЗАТЬ) как выбор опции Window (Рамка), а введенная точка становится первым углом рамки. Поэтому после этого AutoCAD сразу запрашивает противоположный угол рамки.
Опция Extents (Границы) позволяет выбрать самое меньшее прямоугольное окно, в котором видны (находятся) все ранее построенные объекты рисунка (обратите внимание на эту опцию!).
Опция All (Все) аналогична опции Extents (Границы), но при этом минимальное окно выбирается так, чтобы в него целиком вошла еще и зона лимитов. Это может привести к такой ситуации, когда зона лимитов заполнена мало и новое окно получится полупустым.
В опции Center (Центр) AutoCAD запрашивает сначала точку центра будущего окна, а затем его вертикальный размер.
Опция Dynamic (Динамика) дает возможность выбрать новое окно в динамическом режиме. При этом, как показано на рис. 2.21, сначала система выполняет опцию All (Все), демонстрируя границы предыдущего окна (зеленый пунктирный прямоугольник, на рис. 2.21 — в правой части графического экрана) и границы зоны лимитов (на рисунке — синий пунктирный прямоугольник, занимающий большую часть графического экрана в центре), и переходит в режим панорамирования. Можно перемещением указателя и щелчком левой кнопки мыши выбрать левую границу будущего окна (граница будет проходить по левой стороне сплошного прямоугольника, центр которого показан символом "х"). Затем, перемещая курсор вправо или влево (рис. 2.22), можно установить размер окна по горизонтали и нажать клавишу <Enter> (или правую кнопку мыши).

Рис. 2.21. Выбор левой границы динамического окна

Опция Previous (Предыдущий) команды ZOOM (ПОКАЗАТЬ) возвращает к предыдущему окну, если оно было в данном сеансе работы AutoCAD. Возврат к предыдущему окну может быть выполнен не более десяти раз, т. к. более ранняя информация утрачивается. Опция Previous (Предыдущий) вынесена на кнопку Zoom Previous (Показать Предыдущий) [image] панели Standard (Стандартная).
Опция Scale (Масштаб) команды ZOOM (ПОКАЗАТЬ) запрашивает ввод масштаба в виде числа с возможным окончанием X или ХР. Опция аналогична опции Center (Центр), но размер нового окна выбирается исходя из множителя (масштаба), введенного пользователем. Масштаб больше единицы увеличивает отображение объектов (приближает объекты), меньше единицы — уменьшает (отдаляет объекты). Если масштаб вводится без окончаний X или ХР, то размеры нового окна вычисляются относительно размеров лимитов. Если с окончанием X — размеры окна вычисляются относительно предыдущего вида. Если окончание имеет вид ХР, то масштаб задается относительно пространства листа (см. гл. 10).

Рис. 2.22. Выбор размера динамического окна

Если вместо выбора опции команды ZOOM (ПОКАЗАТЬ) сразу ввести число (с окончаниями X, ХР или без них), то AutoCAD рассматривает его как число опции Scale (Масштаб).
Кнопки [image] и [image] (см. рис. 2.18) выполняют, соответственно, действия, аналогичные действиям команды ZOOM (ПОКАЗАТЬ) с опцией Scale (Масштаб) и последующим ответом 2Х и действиям команды ZOOM (ПОКАЗАТЬ) с опцией Scale (Масштаб) и последующим ответом 0.5Х, т. е. увеличивают или уменьшают изображение в два раза относительно текущего.


2.5. Точки

Интересным примитивом системы AutoCAD является точка. Для его построения используется команда POINT (ТОЧКА), которая, помимо набора на клавиатуре, может быть вызвана из панели Draw (Рисование) с помощью кнопки [image] или из падающего меню, если применить команду Draw | Point | Single Point (Рисование | Точка Одиночная). Построенные заранее точки могут затем быть использованы другими командами.
Команда POINT (ТОЧКА) при вызове ее из панели инструментов Draw (Рисование) работает в цикле, выдавая вопрос:
Current point modes: PDMODE = 0 PDSIZE = 0.0000 Specify a point: (Текущиережимы точек: PDMODE = 0 PDSIZE = 0.0000 Укажите точку:)
Укажите с помощью мыши точку на экране. В указанном вами месте образуется точка, изображаемая в соответствии с теми установками, которые вам выдала система AutoCAD (это значения системных переменных PDMODE и PDSIZE; подробнее о работе с системными переменными см. в разд. 11.1). Дальше AutoCAD снова выдает вышеприведенный запрос об указании точки, и вы можете задать следующую точку и т. д. Когда вам нужно прервать команду POINT (ТОЧКА), то следует воспользоваться клавишей <Esc>.
Если системные переменные PDMODE = 0 и PDSIZE = 0, то точка отображается в виде одного пиксела (т. е. одной точки экрана), что чаще всего неудобно. Поэтому в падающем меню Format (Формат) есть пункт Point Style (Отображение точек), который вызывает диалоговое окно Point Style (Отображение точек) (рис. 2.23).

Рис. 2.23. Диалоговое окно Point Style

Необходимо с помощью левой кнопки мыши отметить ту форму точки, которую вы хотите получить. Рекомендуем выбрать форму в виде символа "х".
В том же окне можно задать и размеры символа точки (поле Point Size (Размер точки)), которые могут быть либо в процентах от размера экрана, если включен переключатель Set Size Relative to Screen (Установка размера относительно экрана), либо в абсолютных единицах, если включен переключатель Set Size in Absolute Units (Установка размера в абсолютных единицах). Предпочтительнее сохранить те установки, которые показаны на рис. 2.23: 5% от размера экрана. Завершив установки, закройте окно. Система AutoCAD автоматически перерисует ранее заданные точки в новой форме.
Представленные таким образом точки могут быть использованы для построений новых объектов с помощью функции объектной привязки Node (Узел). А сами точки поэтому очень часто называются узловыми точками.
Рассмотрим такую задачу: пусть необходимо построить отрезок, у которого концы являются ранее созданными узловыми точками. Для этого вызовем команду LINE (ОТРЕЗОК) и на запрос Specify first point: (Первая точка:) с помощью левой кнопки мыши выберем кнопку [image] (Snap to Node (Привязать к узлу)) панели Object Snap (Объектная привязка).
Затем устанавливаем указатель мыши на первую узловую точку (обнаружив ее, AutoCAD обводит точку кружочком). После этого опять обращаемся к функции объектной привязки Node (Узел) и указываем вторую узловую точку (рис. 2.24).

Рис. 2.24. Построение отрезка по двум узловым точкам

Для рассмотрения других команд очистите экран следующим способом. Если в командной строке стоит приглашение Command: (Команда:), означающее, что предыдущая команда полностью закончена, установите указатель мыши в правом нижнем углу графического экрана и нажмите (и отпустите) ее левую кнопку. Это действие система AutoCAD воспринимает как начало операции выбора объектов с помощью рамки, поэтому выдает запрос Specify opposite corner: (Противоположный угол:). С помощью мыши укажите второй угол рамки таким образом, чтобы все ранее нарисованные точки и отрезки оказались внутри этой рамки. После этого у всех выбранных объектов появятся ручки, т. е. небольшие синие квадраты в характерных точках тех или иных объектов (рис. 2.25). У отрезков характерными точками являются конечные и средние точки.

Рис. 2.25. Ручки выбранных объектов

Объекты можно выбирать не только рамкой, но и непосредственным указанием, когда мишень указателя мыши ставится прямо на объект и нажимается левая кнопка. Рамка, которой выбираются объекты, может идти из левого угла в правый или из правого угла в левый. В первом случае рамка называется простой рамкой, а во втором случае секущей рамкой. Простая рамка показывается сплошной линей и выбирает только те объекты, которые попадают целиком внутрь рамки. Секущая рамка показывается пунктирной линией и выбирает те объекты, которые лежат внутри рамки, а также пересекают рамку. Ручки демонстрируют, какие объекты рисунка выбраны для следующей команды (обычно это одна из команд редактирования).
В нашем примере (рис. 2.25) мы выбрали объекты для удаления. Нажмите на клавиатуре клавишу <Delete> (иногда она называется <Del>), и отмеченные объекты будут удалены.
Может быть ситуация, когда ручки высветились случайно или ошибочно. Сброс ручек выполняется нажатием клавиши <Esc> (в системе AutoCAD 2000 требовалось двукратное нажатие <Esc>).
Есть еще две интересные команды, которые строят точки. Первая команда — DIVIDE (ПОДЕЛИТЬ), которая делит отрезок (или другой объект) на равные части. Команда может быть введена с клавиатуры или вызвана из падающего меню Draw | Point | Divide (Рисование | Точка | Поделить).
Постройте отрезок и введите команду DIVIDE (ПОДЕЛИТЬ). Первый вопрос этой команды:
Select object to divide: (Выберите объект для деления:)
Отметьте построенный отрезок (делить можно и другие объекты — например, дуги и полилинии, рассматриваемые далее в данной главе). Следующий вопрос:
Enter the number of segments or [Block]: (Число сегментов или [Блок]:)
Опция Block (Блок) активизирует вопрос об имени блока, который будет вставлен в точках деления (о блоках см. гл. 7). Мы же введем число — например, 8. В результате выполнения команды DIVIDE (ПОДЕЛИТЬ) отмеченный отрезок будет разделен на 8 равных частей, и в точках деления будут расставлены 7 узловых точек (в той форме, которую мы задали в диалоговом окне Point Style (Отображение точек)) (рис. 2.26).
Другая команда, которая расставляет точки от начала объекта с заданными расстояниями, это команда MEASURE (РАЗМЕТИТЬ). Она, помимо ввода с клавиатуры, может быть вызвана из падающего меню командой Draw | Point | Measure (Рисование | Точка Разметить). Первый вопрос команды:
Select object to measure: (Выберите объект для разметки:)
Выберите объект, который надо разметить. Второй вопрос:
Specify length of segment or [Block]: (Длина сегмента или [Блок]:)
После ввода числа система AutoCAD расставляет точки, начиная от того конца объекта, ближе к которому он (т. е. объект) был указан.
Построенные таким образом лучи можно затем при необходимости обрезать с помощью команд редактирования (см. гл. 3).

Рис. 2.26. Деление отрезка на части с помощью команды DIVIDE


2.6. Лучи

Луч — это примитив, бесконечный в одну сторону и начинающийся в некоторой точке. Для его построения служит команда RAY (ЛУЧ). Команда может быть введена с клавиатуры или вызвана с помощью пункта Ray (Луч) падающего меню Draw (Рисование). Первый запрос команды:
Specify start point: (Начальная точка:)
После задания первой точки AutoCAD циклически запрашивает другие точки и строит лучи, проходящие из первой точки через остальные (рис. 2.27):
Specify through point: (Через точку:)
Окончание команды — нажатие клавиши <Enter> или правой кнопки мыши.

Рис. 2.27. Построение лучей


2.7. Прямые

Прямые, в отличие от отрезков и лучей, — это бесконечные в обе стороны линии. Для их построения используется команда XLINE (ПРЯМАЯ), которая может быть введена с клавиатуры, из падающего меню Draw (Рисование) пунктом Construction Line (Прямая) или кнопкой [image] из панели инструментов Draw (Рисование).
Первый запрос команды:
Specify a point or [Hor/Ver/Ang/Bisect/Offset]: (Укажите точку или [Гор/Вер/Угол/Биссект/Смещение]:) Если в этот момент вы укажете точку (мышью или любым другим из рассмотренных выше способов), то AutoCAD будет строить пучок прямых, проходящих через первую точку. Для фиксации положения прямой на плоскости достаточно двух точек, через которые она проходит, поэтому следующий запрос таков:
Specify through point: (Через точку:)
Можно задать несколько точек, через которые пройдет пучок прямых (рис. 2.28).

Рис. 2.28. Построение пучка прямых

Для окончания команды используйте клавишу <Enter> или правую кнопку мыши.
Следующие пять опций, которые вам доступны в начале работы команды, позволяют рисовать специальным образом расположенные прямые: горизонтальные (Ноr (Гор)); вертикальные (Ver (Вер)); под определенным углом (Ang (Угол)); образующие биссектрису некоторого угла, для которого нужно указать вершину и стороны (Bisect (Биссект)); параллельные к другой линейному объекту, т. е. отрезку, лучу или прямой (Offset (Смещение)). Каждая из перечисленных опций вводится с помощью тех букв, которые в наименовании опции выделены в верхнем регистре.
Опция Ноr (Гор) выдает запрос: Specify through point: (Через точку:)
Необходимо задать точки, через которые пройдут горизонтальные прямые.
Аналогично работает и опция Ver (Вер) (рис. 2.29).

Рис. 2.29. Построение горизонтальных и вертикальных прямых

При использовании опции Ang (Угол) выдается запрос: Enter angle ofxline (0) or [Reference]: (Угол прямой (0) или [Базовая линия]:)
В этот момент нужно задать угол наклона, измеряемый относительно горизонтали (положительного направления оси X). Если нажать клавишу <Enter>, то углом наклона будет нулевой. Угол можно задать числом (в действующих угловых единицах, обычно в градусах) или указав мышью одну точку. Система выдаст запрос:
Specify second point: (Вторая точка:)
На это необходимо задать другую точку, между которыми система AutoCAD построит невидимый отрезок и измерит его угол наклона относительно положительного направления оси X.
Если использовать опцию Reference (Базовая линия), то тогда AutoCAD выдаст следующий запрос:
Select a line object: (Выберите линейный объект:)
Нужно указать линейный объект (отрезок, луч или прямую), относительно которого будет взят угол наклона.
После задания угла появляется знакомый нам вопрос Specify through point: (Через точку:), и вам необходимо будет указать точки (или точку), через которые пройдут прямые с заданным углом наклона.
Опция Bisect (Биссект) строит прямую, являющуюся биссектрисой угла, для которого нужно указать точку вершины, точку на первой стороне угла и точки (точку) на второй стороне угла. Поэтому первый запрос системы такой:
Specify angle vertex point: (Укажите вершину угла:)
Следующий запрос о точке на первой стороне угла:
Specify angle start point: (Точка на первом луче угла:)
Затем выдается повторяющийся запрос о точке на второй стороне угла (рис. 2.30):
Specify angle end point: (Точка на втором луче угла:)

Рис. 2.30. Построение биссектрисы

Если вы зададите несколько точек (и закончите ввод нажатием клавиши <Enter> или правой кнопки мыши), то будут построены биссектрисы углов, у которых одинаковые вершина и первая сторона угла, а вторые стороны угла будут меняться. На рис. 2.30 приведен пример построения биссектрисы одного угла. Точки указания оформлены как узловые точки.
Опция Offset (Смещение) строит прямые линии, параллельные отрезкам, лучам и другим прямым. При этом система выдает такой запрос:
Specify offset distance or [Through] <Through>: (Величина смещения или [Точка] < Точка >:)
Здесь необходимо либо ввести число, которое станет расстоянием между параллельными линейными объектами, либо нажать клавишу <Enter>, если вы соглашаетесь с предлагаемой по умолчанию опцией Through (Точка) (или величиной смещения, если система в угловых скобках предлагает число), либо ввести букву Т (Т).
Если вы указали величину смещения, то следующий запрос системы таков:
Select a line object: (Выберите линейный объект:)
Нужно указать отрезок, луч или прямую. Далее:
Specify side to offset: (Укажите сторону смещения:)
Поскольку к линейному объекту на плоскости могут быть построены две параллельные линии, то необходимо указать любую точку, расположенную по ту же сторону от базового линейного объекта, как и строящаяся параллельная. После построения одной параллельной прямой система AutoCAD готова построить параллельную прямую к другому линейному объекту с тем же смещением, поэтому далее повторяются вопросы о линейном объекте и стороне смещения. На это вы можете или указать другой объект и его сторону смещения, или нажать клавишу <Enter> (или правую кнопку мыши), чтобы выйти из команды XLINE (ПРЯМАЯ).
Если в опции Offset (Смещение) в ответ на запрос Specify offset distance or [Through]: (Величина смещения или [Точка]:) вы выбираете опцию Т (Т), то тогда AutoCAD запрашивает:
Select a line object: (Выберите линейный объект:)
А затем просит точку, через которую нужно провести параллельную линию:
Specify through point: (Через точку:)
Вам нужно указать соответствующую точку. Система построит параллельную линию и затем опять повторит запрос Select a line object: (Выберите линейный объект:), в ответ на который можно указать новый объект для параллельности или закончить команду (с помощью клавиши <Enter> или правой кнопки мыши).


2.8. Окружности

Рисование окружностей (кругов) выполняется командой CIRCLE (КРУГ). Команду можно вызвать из панели Draw (Рисование) кнопкой [image] или из падающего меню Draw (Рисование), в котором подменю Circle (Круг) имеет шесть пунктов (рис. 2.31).

Рис. 2.31. Варианты команды CIRCLE в падающем меню Draw

При вызове команды CIRCLE (КРУГ) AutoCAD выдает запрос:
Specify center point for circle or [3P/2P/Ttr (tan tan radius)]: (Центр круга или [3T/2T/KKP (кос кос радиус)]:)
Если вы в ответ на этот запрос указываете точку, то она становится центром будущей окружности, и выдается следующий запрос (см. рис. 2.32):
Specify radius of circle or [Diameter]: (Радиус круга или [Диаметр]:)

Рис. 2.32. Построение окружности по центру и радиусу

В этот момент можно ввести число, которое станет величиной радиуса окружности. Радиус можно задать и точкой (AutoCAD измерит расстояние от центра окружности до новой точки и возьмет его в качестве радиуса). Если ввести символ D (Д), то это означает, что вы выбираете опцию Diameter (Диаметр). Тогда выдается запрос на ввод. диаметра:
Specify diameter of circle: (Диаметр круга:)
Диаметр можно задать числом или указанием точки (AutoCAD в этом случае измеряет расстояние от ранее указанного центра до новой точки и берет это расстояние в качестве величины диаметра). После задания радиуса или диаметра построение окружности заканчивается.
Если вместо центра окружности выбрать опцию ЗР (ЗТ), то AutoCAD будет строить окружность по трем точкам плоскости. Поочередно задаются запросы на первую, вторую и третью точки и после правильного их указания (а они не должны лежать на одной прямой) окружность появляется на экране.
Если выбрана опция 2Р (2Т), то тогда запрашиваются всего две точки, но считается, что обе точки принадлежат диаметру будущей окружности (расстояние между ними равно диаметру). Система AutoCAD выдает такие запросы:
Specify first end point of circle's diameter: (Первая конечная точка диаметра круга:)
и
Specify second end point of circle's diameter: (Вторая конечная точка диаметра круга:)
Интересна опция Ttr (KKP), которая позволяет построить окружность, касающуюся двух других объектов и имеющую заданный радиус. Соответственно изменяются опции и запросы системы. Первый запрос:
Specify point on object for first tangent of circle: (Укажите точку на объекте, задающую первую касательную:)
В тот момент, когда вы подводите указатель мыши к выбранному объекту, система AutoCAD показывает его обнаружение подсказкой Deferred Tangent (Отложенная касательная). Это означает, что точка касания к объекту будет вычислена позднее (она зависит от не известного пока второго объекта, которого строящаяся окружность должна тоже коснуться).
Второй запрос:
Specify point on object for second tangent of circle: (Укажите точку на объекте, задающую вторую касательную:)
Третий запрос:
Specify radius of circle: (Радиус круга:)
Радиус можно задать числом или двумя точками, расстояние между которыми и станет его величиной. Если построение с указанными данными невозможно, то система выдает соответствующее сообщение (обычно это бывает, когда радиус слишком мал или слишком велик). Пример результата построения приведен на рис. 2.33.

Рис. 2.33. Построение окружности, имеющей заданный радиус и касающейся двух объектов

Чаще всего существует несколько вариантов решения задачи построения окружности, касающейся двух объектов и имеющей заданный радиус (например, для двух пересекающихся отрезков). В таком случае из всех возможных решений AutoCAD выбирает такое, которое ближе всего к тем точкам, в которых вы помечали объекты для касания. Поэтому к указанию точек при выборе объектов следует подходить достаточно внимательно.
В падающем меню Draw. (Рисование) пункт Circle (Круг) имеет подпункт Tan, Tan, Tan (3 точки касания). Однако это не новая самостоятельная опция команды CIRCLE (КРУГ), а частный случай опции ЗР (ЗТ), когда все три точки указываются с помощью функции объектной привязки Tangent (Касательная) (этой функции соответствует кнопка [image] панели инструментов Object Snap (Объектная привязка)).
Функция Tangent (Касательная) — это еще одна очень удобная функция, позволяющая облегчить ряд построений.
Рассмотрим следующий пример. На рисунке изображена окружность, и нужно построить отрезок, который начинается вне окружности и касается ее.
Вызовем команду LINE (ОТРЕЗОК). Укажем первую точку на свободном месте рисунка. После запроса о второй точке нажмем сначала мышью на кнопку с функцией объектной привязки Tangent (Касательная), а затем укажем окружность (рис. 2.34). Точка касания вычисляется системой AutoCAD как ближайшая к тому месту, в котором мы показали окружность (из двух решений выбирается наиболее подходящее).

Рис. 2.34. Построение отрезка, касающегося окружности

Еще один пример. Есть две окружности и надо построить отрезок, который касается обеих.
Вызовем команду LINE (ОТРЕЗОК). И первую, и вторую точки отрезка укажем на окружностях, используя функцию Tangent (Касательная). AutoCAD вычислит обе точки касания (ближе к тем местам, в которых мы указали окружности) и построит отрезок.
У окружностей можно привязываться к точкам центров. Этой цели служит функция объектной привязки Center (Центр), которой соответствует кнопка [image] панели Object Snap (Объектная привязка).
С помощью двукратного применения функции Center (Центр) решается задача построения отрезка, соединяющего точки центров двух окружностей (рис. 2.35). Обращаем внимание читателей, что, когда вы хотите с помощью функции Center (Центр) получить точку, вы должны ставить мишень указателя мыши на линию окружности, а не внутрь нее (линия окружности должна пересечься с мишенью, иначе окружность может быть не обнаружена!).

Рис. 2.35. Построение отрезка, соединяющего центры окружностей

У окружности есть еще четыре особых точки — это крайняя верхняя, крайняя нижняя, крайняя левая и крайняя правая, которые называются квадрантами. Для привязки к ним используется функция Quadrant (Квадрант) (ей соответствует кнопка [image] панели Object Snap (Объектная привязка)).
В заключение раздела напомним, что в любой момент, когда вы стоите перед необходимостью выбора опции, вы можете сделать это, пользуясь не только клавиатурой, но и правой кнопкой мыши и соответственно появляющимся при этом контекстным меню.


2.9. Дуги

Дуга — это примитив, являющийся частью окружности. Для его построения используется команда ARC (ДУГА). Команда может быть введена с клавиатуры, вызвана из панели инструментов Draw (Рисование) с помощью кнопки [image] или из падающего меню Draw (Рисование), в котором подменю Arc (Дуга) имеет одиннадцать пунктов (рис. 2.36).

Рис. 2.36. Подменю Arc падающего меню Draw

Рассмотрим самый общий вариант команды (такой вариант работает при клавиатурном вводе команды или при использовании панели Draw (Рисование)). Первый запрос команды ARC (ДУГА):
Specify start point of arc or [CEnter]: (Начальная точка дуги или [Центр]:)
В ответ можно задать начальную точку дуги или выбрать опцию CEnter (Центр).
Если вы просто нажмете клавишу <Enter>, тогда в качестве начальной точки принимается конечная точка последнего объекта рисунка (но только последнего среди отрезков и дуг) и AutoCAD строит дугу, касательную к этому объекту. Запрашивается конечная точка (центр и радиус дуги вычисляются по конечной точке и условию касания к объекту):
Specify end point of arc: (Конечная точка дуги:)
После указания точки строится дуга, являющаяся продолжением предыдущего объекта (рис. 2.37).

Рис. 2.37. Построение дуги, являющейся продолжением отрезка

Если в ответ на запрос Specify start point of arc or [Center]: (Начальная точка дуги или [Центр]:) вы вводите начальную точку, система AutoCAD запрашивает:
Specify second point of arc or [Center/End]: (Вторая точка дуги или [Центр/Конец]:)
Если указать вторую точку, то система далее запрашивает:
Specify end point of arc: (Конечная точка дуги:)
В результате получается дуга, построенная по трем точкам. Вместо второй точки можно было выбрать опцию Center (Центр), на что система AutoCAD запрашивает:
Specify center point of arc: (Центр дуги:)
После указания точки центра следующий запрос:
Specify end point of arc or [Angle/chord Length]: (Конечная точка дуги или [Угол/Длина хорды]:)
Если указать конечную точку дуги, то AutoCAD ее подправляет, вычислив радиус дуги по первой точке и центру (на рис. 2.38 точка центра обозначена знаком х; видно, что указываемая пользователем точка отличается от реально строящейся конечной точки дуги).

Рис. 2.38. Построение дуги (начало, центр, конец)

В последнем случае есть еще два варианта завершения процесса построения дуги: Angle (Угол) и chord Length (Длина хорды). При выборе опции Angle (Угол) выдается запрос:
Specify included angle: (Центральный угол:)
Угол может быть введен со знаком при помощи клавиатуры или указан мышью.
Если вместо опции выбрать опцию chord Length (Длина хорды), то выдается запрос:
Specify length of chord: (Длина хорды:)
Длина хорды может быть задана либо числом со знаком, либо точкой (в этом случае в качестве длины будет взято расстояние от начальной точки дуги до новой точки). Знак длины (а длина при вводе числа с клавиатуры может быть и отрицательной) влияет на направление обхода дуги.
Сейчас мы не будем рассматривать все остальные варианты построения дуги и оставляем их читателю для самостоятельной проработки. Перечень вариантов виден из подменю Arc (Дуга) падающего меню Draw (Рисование) (см. рис. 2.36).


2.10. Полилинии

Полилиния — это сложный примитив, состоящий из одного или нескольких связанных между собой прямолинейных и дуговых сегментов (рис. 2.39). Полилиния обрабатывается как единое целое (например, при редактировании или удалении).
Для рисования полилинии служит команда PLINE (ПЛИНИЯ), которая, помимо ввода с клавиатуры, может быть вызвана с помощью кнопки [image] панели инструментов Draw (Рисование) или пункта Polyline (Полилиния) падающего меню Draw (Рисование).
Первый запрос системы при выполнении команды:
Specify start point: (Начальная точка:)
Нужно указать начальную точку полилинии. Следующий запрос более сложный:
Current line-width is 0.0000 Specify next point or [Arc/Halfividth/Length/Undo/Width]: (Текущая ширина полилинии равна 0.0000 Следующая точка или [Дуга/Полуширина/длИна/Отменить/'Ширина]:)

Рис. 2.39. Примеры открытой и замкнутой полилинии

Полилиния — один из немногих объектов, которые могут иметь ненулевую ширину. Ширина, заданная для предыдущей полилинии, запоминается и предлагается в качестве ширины по умолчанию для следующей полилинии. Поэтому AutoCAD информирует вас сообщением Current line-width is (Текущая ширина полилинии ) о том, с какой шириной, если вы ее не поменяете, система будет строить новую полилинию.
Если в этот момент указать точку, то эта точка станет второй точкой линии. Система AutoCAD снова повторяет предыдущий запрос, но к нему добавляется опция Close (Замкнуть):
Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]: (Следующая точка или [Дуга/Замкнутъ/Полуширина/длИна/Отменить/ Ширина]:)
Таким образом, можно последовательно указать несколько точек, которые станут вершинами ломаной линии или полилинии, состоящей из одних прямолинейных сегментов. Кроме указания точек, можно выбрать следующие опции:

  • Arc (Дуга) — переход в режим рисования дуговых сегментов полилинии;
  • Close (Замкнуть) — добавление еще одного прямолинейного участка, замыкающего полилинию (одновременно команда PLINE (ПЛИНИЯ) завершается);
  • Halfwidth (Полуширина) — задание ширины, но в терминах полуширины (т. е. если требуемая полная ширина линии равна 10, то получить ее можно, задавая полуширину, равную 5);
  • Length (длИна) — построение сегмента, являющегося продолжением предыдущего участка с заданной длиной, при этом длину можно задать числом или точкой;
  • Undo (Отменить) — отмена последней операции в команде PLINE (ПЛИНИЯ);
  • Width (Ширина) — задание ширины для очередного участка полилинии (у каждого сегмента полилинии может быть своя ширина, причем ширина в начале участка может не совпадать с шириной в конце участка); ширина распределяется поровну по обе стороны от оси полилинии, на которой лежат вершины (точки) полилинии.

В случае перехода в режим рисования дуг (опция Arc (Дуга)) AutoCAD предлагает следующий выбор:
Specify endpoint of arc or [Angle/CEnter/CLose/Direction/Halfwidth/
Llne/Radius/Secondpt/Undo/Width]:
(Конечная точка дуги или [Угол/Центр/Замкнуть/Направление/Полуширина/
Линейный/Радиус/Вторая/Отменить/Ширина]:)
В этот момент после указания конечной точки дуги система AutoCAD строит дуговой сегмент, касающийся предыдущего участка полилинии. Другие опции:

  • Angle (Угол) — задание величины центрального угла для дугового сегмента;
  • CEnter (Центр) — задание центра для дугового сегмента;
  • CLose (Замкнуть) — замыкание полилинии с помощью дугового сегмента;
  • Direction (Направление) — задание направления касательной для построения дугового сегмента;
  • Halfwidth (Полуширина) — задание полуширины для следующего сегмента;
  • Line (Линейный) — переход в режим рисования прямолинейных сегментов;
  • Radius (Радиус) — задание радиуса для дугового сегмента;
  • Second pt (Вторая) — задание второй точки для построения дугового сегмента по трем точкам;
  • Undo (Отменить) — отмена последнего действия внутри команды PLINE (ПЛИНИЯ);
  • Width (Ширина) — задание ширины для следующего сегмента.

Способы построения дуговых сегментов аналогичны способам построения дуг команды ARC (ДУГА). В любой момент можно от режима рисования прямолинейных сегментов перейти к режиму рисования дуговых сегментов и наоборот. Также в любой момент можно задать новую ширину или полуширину для следующего сегмента полилинии. Пример полилинии с переменной шириной сегментов приведен на рис. 2.40.

Рис. 2.40. Пример полилинии с переменной шириной сегментов

Можно отметить следующие особенности полилинии по сравнению с простыми примитивами:

  • полилиния является единым объектом, что удобно для операций удаления или редактирования (например, построения параллельной линии);
  • полилиния удобна для рисования жирных линий чертежа;
  • переменная ширина сегментов полилинии может быть использована для графических эффектов (построения стрелок и т. п.).

Полилиния является сложным объектом. Однако она в любое время может быть преобразована в группу отрезков и дуг, из которых она составлена. Это выполняет команда EXPLODE (РАСЧЛЕНИТЬ), которую можно вызвать кнопкой [image] в панели Modify (Редактирование) или пунктом Explode (Расчленить) в падающем меню Modify (Редакт).
При расчленении теряется информация о ширине, т. к. получающиеся отрезки и дуги не могут иметь ненулевую ширину (на рис. 2.41 приведены две одинаковых полилинии, из которых правая была расчленена).

Рис. 2.41. Потеря информации о ширине после команды EXPLODE

В системе имеется возможность объединения в полилинию ранее нарисованных последовательно связанных отрезков и дуг. Например, если отрезки нарисованы одной командой LINE (ОТРЕЗОК), то они удовлетворяют условию связанности и их можно преобразовать в полилинию.
Для этого используется команда PEDIT (ПОЛРЕД), которой соответствуют кнопка [image] панели инструментов Modify II (Редактирование-2) и пункт падающего меню Modify | Object | Polyline (Редакт | Объект | Полилиния).
Первый запрос команды PEDIT (ПОЛРЕД):
Select polyline or [Multiple]: (Укажите полилинию или [Несколько]:)
Укажите первый из отрезков, которые будут объединены. Система AutoCAD обнаруживает, что отмеченный объект не является полилинией, и выдает следующий запрос:
Object selected is not a polyline Do you want to turn it into one? <Y>: (Выбранный объект не полигиния. Сделать его полилинией? <Д>:)
Нажмите на клавишу <Enter> или введите Y (Д), тогда выбранный отрезок преобразуется в полилинию из одного сегмента и будет готов присоединить к себе другие отрезки. Далее последует запрос:
Enter an option [Close/Join/Width/Edit vertex/ 'Fit/'Spline/'Decurve/Ltype gen/Undo]:
(Задайте опцию {Замкнуть/Добавить/Ширина/Вершина/С'Гладить/С'Плайн/ Убрать сглаживание/Типлин/Отменить]:)
Если необходимо добавить отрезок, введите Y (Д). Следующий запрос будет циклически повторяться:
Select objects: (Выберите объекты:)
Укажите присоединяемые отрезки (рис. 2.42) и завершите выбор объектов нажатием клавиши <Enter>. Система AutoCAD присоединит к полилинии сегменты и выдаст сообщение об этом:
4 segments added to polyline (4 сегмента добавлены к полилинии)
Далее AutoCAD повторяет запрос Enter an option [Close/Join/Width/Edit vertex/ Fit/Spline/Decurve/Ltype gen/Undo]:
(Задайте опцию [Замкнуть/Добавить/Ширина/Вершина/СГладить/СПлайн/ Убрать сглаживние/Типлин Отменить]:), на что нужно ответить нажатием клавиши <Enter>, завершая команду PEDIT (ПОЛРЕД).

Замечание В системе AutoCAD 2004 появилась новая системная переменная — PEDITACCEPT, обычное значение которой 0. Если изменить значение на 1, то система не будет в команде PEDIT (ПОЛРЕД) выдавать сообщение о том, что выбранный объект не является полилинией. О работе с системными переменными см. гл. 11.

Рис. 2.42. Преобразование последовательно нарисованных отрезков в полилинию


2.11. Полилинии специального вида

В системе AutoCAD есть несколько команд рисования таких объектов, как прямоугольники, правильные многоугольники, кольца и линии правки, каждый из которых на самом деле является полилинией.
Вычерчивание прямоугольников осуществляет команда RECTANG (ПРЯМО-УГ). Команда может быть введена с клавиатуры или вызвана с помощью кнопки [image] панели Draw (Рисование) или с помощью пункта Rectangle (Прямоугольник) падающего меню Draw (Рисование). Начальный запрос команды: Specify first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]: (Первый угол или [Фаска/Уровень/Сопряжение/Высота/Ширина]:)
Если указать точку, она станет первым углом будущего прямоугольника, для которого AutoCAD запросит противоположный угол или размеры:
Specify other corner point or [Dimensions]: (Другой угол или [Размеры]:)
Если указать вторую точку, то обе введенные точки становятся точками одной из диагоналей прямоугольника (рис. 2.43). Если выбрать опцию Dimensions (Размеры), то последуют запросы двух размеров прямоугольника:
Specify length for rectangles <0.0000>: (Длина прямоугольников <0.0000>:)
и
Specify width for rectangles <0.0000>: (Ширина прямоугольников <0.0000>:)

Рис. 2.43. Варианты прямоугольников, создаваемых командой RECTANG

После ввода обоих размеров система AutoCAD снова запрашивает вторую точку прямоугольника, указание которой является только заданием ориентации прямоугольника, поскольку первая точка и размеры уже известны.
Возможные опции запроса команды RECTANG (ПРЯМОУГ):

  • Chamfer (Фаска) — задание длин фаски, снимаемых в каждом углу прямоугольника;
  • Fillet (Сопряжение) — задание радиуса сопряжения углов прямоугольника;
  • Elevation (Уровень) — задание уровня для построения прямоугольника, смещенного по оси Z трехмерного пространства (о положении объектов в пространстве см. гл. 9);
  • Thickness (Высота) — задание высоты для построения прямоугольника, выдавленного вдоль оси Z трехмерного пространства (о построении трехмерных объектов см. гл. 9);
  • Width (Ширина) — задание ширины полилинии, которой является строящийся прямоугольник.

Если пользователь при работе с данным рисунком задавал какие-то опции, то они выдаются на экран при новом обращении к команде RECTANG (ПРЯМОУГ), например:
Current rectangle modes: Chamfer = 15.0000 x 10.0000 Elevation = 100.0000 Thickness = 45.0000 (Текущиережимы: Фаска = 15.0000x 10.0000 Уровень = 100.0000 Высота = 45.0000)
или
Current rectangle modes: Fillet — 22.0000 (Текущие режимы: Сопряжение =22.0000)
Если установленные ранее параметры устраивают пользователя, то он может прямо указывать точки противоположных углов прямоугольника. Если какие-то установки необходимо сменить, нужно ввести их значения с помощью соответствующих опций (при отказе от какого-то режима отвечающая ему опция должна быть вызвана с установкой нулевых значений).
Команда POLYGON (МН-УГОЛ) рисует правильный многоугольник либо по конечным точкам одной стороны, либо по точке центра и радиусу вписанной или описанной окружности. Команда может быть вызвана с помощью кнопки [image] панели Draw (Рисование) или с помощью пункта Polygon (Многоугольник) падающего меню Draw (Рисование). Первый вопрос команды POLYGON (МН-УГОЛ):
Enter number of sides <4>: (Число сторон <4>:)
Здесь вам нужно задать число сторон многоугольника (в скобках в качестве подсказки выдается число сторон, использованное в предыдущем вызове команды POLYGON (МН-УГОЛ); в первый раз в качестве подсказки выводится 4). Следующий вопрос:
Specify center of polygon or [Edge]: Укажите центр многоугольника или [Сторона]:
Если выбрать опцию Е (С), то система AutoCAD запрашивает две конечные точки стороны многоугольника и по ним строит многоугольник. Если вы вместо опции указываете точку, то система запрашивает, каким образом будет задан размер многоугольника:
Enter an option [Inscribed in circle/Circumscribed about circle] </>; (Задайте опцию размещения [Вписанный в окружность/Описанный вокруг окружности] <В>:)
При ответе I (В) прямоугольник вписывается в некоторую окружность, при ответе С (О) — описывается вокруг окружности. Остается запрос о величине радиуса окружности, в которую вписывается или около которой описывается многоугольник:
Specify radius of circle: (Радиус окружности:)
На рис. 2.44 приведены примеры правильных многоугольников, построенных с помощью команды POLYGON (МН-УГОЛ).

Рис. 2.44. Построение правильных многоугольников

Кольцо рисуется командой DONUT (КОЛЬЦО) и представляется полилинией с шириной, подобранной по внутреннему и внешнему диаметрам кольца.
Команда, помимо ввода с клавиатуры, может быть вызвана с помощью пункта Donut (Кольцо) падающего меню Draw (Рисование). Первый запрос:
Specify inside diameter of donut <0.5000>: (Внутренний диаметр кольца <0.5000>:)
Внутренний (как и внешний) диаметр может быть задан числом или двумя точками, расстояние между которыми становится величиной диаметра. Второй запрос:
Specify outside diameter of donut <1.0000>: (Внешний диаметр кольца < 1.0000>:)
После задания обоих диаметров размеры кольца уже могут быть вычислены, и AutoCAD в цикле задает вопрос о точке центра для группы колец одного размера:
Specify center of donut or <exit>: (Центр кольца или <выход>:)
После указания очередного центра кольца система AutoCAD рисует очередной экземпляр требуемой фигуры (рис. 2.45). Закончить команду можно с помощью клавиши <Enter> или правой кнопки мыши.

Рис. 2.45. Построение колец

Новая команда, появившаяся в системе AutoCAD 2004, — REVCLOUD (русский аналог команды в момент написания книги еще не известен). Эта команда рисует замкнутую полилинию в форме облака (см. рис. 2.46).

Рис. 2.46. Построение облака

Этой команде соответствуют кнопка [image] панели инструментов Draw (Рисование) и пункт Revision Cloud (Облако правки) падающего меню Draw (Рисование). Команда выдает запрос:
Minimum arc length: 15 Maximum arc length: 15 Specify start point or [Arc length/Object] <Object>:
(Минимальная длина дуги: 15 Максимальная длина дуги: 15 Начальная тонка или [Длина дуги/Объект] <0бъект>:)
В первой строке запроса сообщаются действующие установки команды (минимальная и максимальная длина дуг). Вы можете с помощью опции Arc length (Длина дуги) изменить их. Опция Object (Объект) позволяет придать существующему объекту форму облака.
В случае указания точек строится ломаная линия, которая сразу же принимает форму облака. Причем все точки, кроме первой, указывать щелчком мыши не надо — достаточно провести курсор по нужному маршруту. Как только система обнаружит замкнутый контур, команда завершится.
Если вы выбрали опцию Object (Объект), то система запрашивает объект. После указания объекта выводится запрос по поводу смены направления дуг:
Reverse direction [Yes/No] <No>: (Изменить направление [Да/Нет] <Нет>:)
На рис. 2.46 у левого объекта направление дуг изменено на внутреннее.


2.12. Мультилинии

Мультилиния — это объект, состоящий из пучка ломаных, параллельных друг другу линий. Количество линий, входящих в мультилинию, составляет от 2 до 16. Мультилиния может обладать дополнительными свойствами, к которым относятся: промежуточные стыки, торцы, скругления и заливка.
Построение мультилиний выполняется командой MLINE (МЛИНИЯ). Команда может быть введена с клавиатуры или вызвана с помощью пункта Multiline (Мультилиния) падающего меню Draw (Рисование).
В предыдущих версиях системы AutoCAD в панель Draw (Рисование) входила кнопка, соответствующая команде MLINE (МЛИНИЯ).
При рисовании мультилиний один из стилей мультилиний является текущим (действующим). В самом стиле (о стилях см. разд. 5.3) описаны эталонные размеры, однако в конкретной мультилиний их можно масштабировать. Кроме того, можно управлять расположением мультилиний относительно осевой линии, которую вы задаете, указывая точки. Установки последнего построения мультилиний система AutoCAD запоминает и предлагает в следующий раз в качестве значений по умолчанию:
Current settings: Justification = Top, Scale = 20.00, Style = STANDARD (Текущие настройки: Расположение = Верх, Масштаб = 20.00, Стиль = STANDARD)
Вслед за этим предлагается выбор:
Specify start point or [Justification/Scale/STyle]: (Начальная точка или [Расположение/'Масштаб/Стиль]:)
Если указать начальную точку, то выдается запрос на следующую (вторую), затем на следующую за ней и т. д. На третьей точке система AutoCAD делает доступной опцию Undo (Отменить), а на четвертой появляется еще и опция Close (Замкнуть). Окончанием команды является либо выбор опции Close (Замкнуть), либо нажатие клавиши <Enter> или правой кнопки мыши (рис. 2.47).

Рис. 2.47. Построение мультилинии

До указания первой точки можно установить значения для каждой из опций. Так опция Justification (Расположение) может принимать значения Тор (Верх), Bottom (Низ) и Zero (Центр). Значение опции Scale (Масштаб), равное 1, соответствует эталонному размеру, описанному в действующем стиле; при задании другого положительного числа размеры будут соответствующим образом масштабироваться. При выборе опции STyle (Стиль) можно поменять имя текущего стиля (на имя стиля из числа стилей, созданных в данном рисунке).
В новом рисунке пользователь может рисовать мультилинии только одного стиля (этот стиль называется STANDARD) — из двух параллельных линий. Другие стили могут быть созданы с помощью специальных средств, рассмотренных в разд. 5.3, wiu импортированы из специального файла с расширением т In.


2.13. Надписи

Надписи могут быть созданы с помощью команд TEXT (ТЕКСТ) или МТЕХТ (МТЕКСТ). В первом случае создается однострочный текст, во втором — мультитекст (многострочный текст). У команды TEXT (ТЕКСТ) есть синоним — команда DTEXT (ДТЕКСТ) (действия обеих команд идентичны).
Команда ТЕКСТ (TEXT), создающая простые надписи, помимо клавиатуры, может быть вызвана кнопкой [image] панели инструментов Text (Текст) (рис. 2.48), а также из падающего меню Draw (Рисование), где в подменю Text (Текст) есть пункт Single Line Text (Однострочный).

Рис. 2.48. Панель инструментов Text

После запуска команды сначала выдается сообщение о текущем стиле, в котором предлагается написать текст:
Current text style: "Standard" Text height: 2.5000 (Текущий текстовый стиль: "Standard" Высота текста: 2.5000)
Понятие стиля включает в себя имя шрифта и ряд особенностей его использования (наклон букв относительно вертикали, наличие эффекта переворачивания и др.). О создании и изменении стилей см. разд. 5.1. В начале сеанса работы с рисунком обычно доступен (и является текущим) только один стиль с наименованием STANDARD. Кроме того, система AutoCAD запоминает высоту предыдущей надписи и предлагает ее в качестве значения по умолчанию (в нашем примере — это 2.5 мм). Построение надписи начинается с ответа на запрос:
Specify start point of text or [Justify/Style]: (Начальная точка текста или [Выравнивание/Стиль]:)
Вы можете указать начальную точку текста (это левая точка базовой линии надписи) или выбрать одну из опций: Justify (Выравнивание) или Style (Стиль). Последняя опция позволяет вам поменять имя текущего стиля, если в вашем рисунке есть другие стили (пока будем считать, что их нет). Опция Justify (Выравнивание) дает вам возможность выбрать другой вариант привязки надписи к чертежу, кроме левой нижней точки. Эту опцию рассмотрим далее. Поэтому укажите точку, которая станет начальной точкой базовой линии надписи. Базовая линия — это отрезок, на котором располагаются буквы надписи без учета нижних выступов (таких как, например, у букв g, щ, у, р и т. п.).
Следующий запрос: Specify height <2.5000>: (Высота <2.5000>.)
Нужно ввести высоту (применительно к заглавным буквам) текста или указать эту высоту второй точкой, до которой AutoCAD вычислит расстояние от начальной точки надписи и возьмет его в качестве высоты. Далее появится следующий запрос:
Specify rotation angle of text <0>: (Угод поворота текста <0>:)
Введите число, задающее угол поворота нижнего основания надписи относительно положительного направления оси X (при горизонтальном положении это 0). Можно указать угол поворота второй точкой (например, с помощью мыши). Заключительный запрос:
Enter text: (Введите текст:)
В том месте, где вы определили начало надписи, появился курсор в форме буквы I. Наберите на клавиатуре любой текст (например, Белеет парус одинокий) и закончите его ввод нажатием клавиши <Enter> (до нажатия <Enter>, естественно, вы можете текст еще отредактировать). В результате чего на экране появится надпись (рис. 2.49) и AutoCAD снова повторит запрос Enter text: (Введите текст:). При этом текстовый курсор переместится на строку ниже (расстояние между строками заложено в описании шрифта) и будет готов к вводу следующей надписи. Вы можете или ввести новый текст, или указать точку начала новой надписи, или. если хотите закончить команду TEXT (ТЕКСТ), нажать клавишу <Enter>.

Рис. 2.49. Построение однострочных текстов

На рис. 2.49 узловой точкой помечена точка начала текста, а отрезком — базовая линия, которая указывает заданный угол наклона надписи.
Если в текст нужно вставить специальные знаки (например, диаметр) или получить подчеркнутые или надчеркнутые символы, то при вводе текста можно использовать следующие управляющие коды, начинающиеся с двух символов процента:

  • %%nnn — вставка символа с номером nnn (nnn заменяет три цифры) в текущей таблице кодировки символов ср!251, используемой как основной в графических приложениях для Windows (например, %%193 — это символ с номером 193, т. е. "Б");
  • %%о — включение/отключение надчеркивания;
  • %%u — включение/отключение подчеркивания;
  • %%d — вставка символа градуса "°";
  • %%р — вставка символа плюс-минус "±";
  • %%с — вставка символа диаметра;
  • %%% — вставка символа процента "%".

Режимы надчеркивания и подчеркивания могут действовать в надписи одновременно. Оба режима по достижении конца строки автоматически отключаются. Пример использования специальных символов приведен на рис. 2.50.

Рис. 2.50. Примеры специального оформления текста

Интересны опции выравнивания, которые становятся доступными, если вместо начальной точки выбрать опцию Justify (Выравнивание):
Enter an option [Align/Fit/Center/Middle/ Right/TL/TC/TR/ML/MC/MR/BL/BC/BR]: (Задайте опцию [впИсанный/Поширине/ Центр/сЕредина/впРаво/ ВЛ/ВЦ/ВП/СЛ/СЦ/СП/НЛ/НЦ/НП]:)
Если вы выбираете опцию Right (впРаво), то выдается запрос:
Specify right endpoint of text baseline: (Правая конечная точка базовой линии текста:)
Нужно указать точку, которая будет правым концом базовой линии надписи.
Если вы выбираете опцию Middle (сЕредина), то выдается запрос:
Specify middle point of text: (Средняя точка текста:)
Указанная вами точка будет средней точкой надписи.
Результат для трех случаев (начальная точка, Right (впРаво) и Middle (сЕредина)) проиллюстрирован на рис. 2.51.

Рис. 2.51. Примеры выравнивания по левой, правой и средней точкам

Двухбуквенные наименования опций (BL (НЛ), ВС (НЦ), MR (СП), TR (ВП) и т. п.) образованы из первых букв слов Bottom (Низ), Middle (Середина), Тор (Верх), Left (Левый), Center (Центр), Right (Правый).
На рис. 2.52 приведен пример текста "Недра", который может быть написан разными вариантами выравнивания (с помощью верхней правой точки, нижней центральной точки и т. п.). Отрезки, соответствующие верхней и нижней кромкам надписи, обрамляют надпись сверху и снизу, причем верхняя кромка выбирается по размеру заглавных букв. Между этими отрезками показаны отрезки, соответствующие базовой и средней линиям.

Рис. 2.52. Примеры выравнивания с использованием опций TL, ТС, TR, ML, MC, MR, BL, ВС, BR, Right, Center

Верхний ряд узловых точек соответствует опциям TL (ВЛ), ТС (ВЦ), TR (ВП), средний ряд точек — ML (СЛ), МС (СЦ), MR (СП), нижний ряд точек - BL (НЛ), ВС (НЦ), BR (НП).
Интересны опции Align (впИсанный) и Fit (По ширине), которые позволяют подгонять размеры букв надписи к конкретному местоположению (рис. 2.53). При использовании опции Align (впИсанный) AutoCAD запрашивает две точки, которые берутся как конечные точки базовой линии — они определяют и угол наклона надписи, и размер текста по ширине, а размер букв по высоте вычисляется пропорционально ширине букв. В случае же опции Fit (По ширине) также нужно задать две точки, определяющие положение и длину базовой линии, однако AutoCAD запрашивает еще и высоту букв, после чего текст сжимается или расширяется.

Рис. 2.53. Примеры выравнивания с использованием опций Align и Fit

Команда МТЕХТ (МТЕКСТ) позволяет нанести на чертеж целые абзацы достаточно длинного текста (образующийся при этом примитив называется мулыпитекстом, или многострочным текстом), с возможностями выравнивания и редактирования, приближающимися к возможностям таких текстовых процессоров, как Microsoft Word. Команде соответствуют кнопка [image] в панелях Draw (Рисование) и Text (Текст), а также пункт падающего меню Draw | Text | Multiline Text (Рисование | Текст | Многострочный).
Команда МТЕХТ (МТЕКСТ) при старте информирует об имени действующего текстового стиля и просит указать первую из двух точек, определяющих границы зоны мультитекста по ширине (рис. 2.54). Нижний предел по высоте при этом не фиксируется и сдвигается автоматически по мере ввода текста. Итак, сначала:
Current text style: "Standard" Text height: 2.5 Specify first corner: (Текущий текстовый стиль: "Standard". Высота текста: 2.5 Первый угол:)
Затем:
Specify opposite corner or [Height/Justify/Line spacing/Rotation/Style/Width]: (Противоположный угол или [ВЫСота/ВЫРавнивание/ Межстрочный интервал/Поворот/Стиль/Ширина]:)

Рис. 2.54. Задание границ мультитекста

После указания точек раскрывается окно редактора мультитекста (рис. 2.55), внешний вид которого существенно изменился по сравнению с предыдущими версиями системы AutoCAD. В верхней части появилась линейка разметки. Вертикальный курсор в окне показывает текущую позицию для ввода или редактирования текста.
Через окно редактора в прозрачном режиме видны находящиеся под ним другие примитивы рисунка.

Рис. 2.55. Окно редактора мультитекста

Размеры окна можно менять так же, как и размеры других окон приложений под Windows. Если введенный текст не помещается в текущем окне, то система создает линейки прокрутки (рис. 2.56).

Рис. 2.56. Изменение размеров окна редактора мультитекста

Выше окна мультитекста автоматически выводится специальная панель Text Formatting (Форматирование текста) (рис. 2.57), которая содержит инструменты управления окном редактора.

Рис. 2.57. Панель Text Formatting

По окончании набора текста нужно будет нажать кнопку [image] панели Text Formatting (Форматирование текста) или ввести комбинацию клавиш <Ctrl>+<Enter>, после чего система AutoCAD создаст в графическом экране мультитекст, который является единым сложным примитивом (рис. 2.58).

Рис. 2.58. Создание мультитекста

Помимо кнопки [image] , панель Text Formatting (Форматирование текста) содержит следующие элементы:

  • — раскрывающийся список для установки имени текущего текстового стиля; применяется для форматирования всего текста в окне;
  • — раскрывающийся список для установки имени текущего шрифта; применяется для внестилевого оформления;
  • — раскрывающийся список для установки высоты букв при использовании текущего шрифта; допускает как выбор из списка, так и задание новых значений;
  • - кнопка установки полужирного начертания (доступна только для шрифтов типа True Type);
  • кнопка установки курсивного начертания (доступна только для шрифтов типа True Type);
  • — кнопка установки режима подчеркивания текста;
  • — кнопка отмены последнего действия в окне редактора мультитекста;
  • — кнопка восстановления отмененного действия;
  • — кнопка форматирования дробей, верхнего и нижнего индексов;
  • — раскрывающийся список для установки цвета букв.

Перед вводом текста необходимо установить нужный стиль или задать внестилевое оформление с помощью имени шрифта и размера букв, а также выбрать цвет букв. Если в процессе ввода понадобится сменить настройки (имя шрифта, цвет и т. д.), то можно выделить левой кнопкой мыши участок текста и изменить его форматирование.
Имена шрифтов имеют слева пометки в виде значка [image] ;это стандартные SHX-шрифты AutoCAD) или [image] (шрифты Windows типа True Type). Не все шрифты могут воспроизводить русские буквы, поэтому требуется предварительный анализ шрифтов перед их практическим использованием. Шрифты, имена которых заканчиваются на Суr, всегда подходят для русского текста.
Кнопка [image] позволяет управлять написанием дробей и индексов. Числитель и знаменатель дроби могут либо разделяться горизонтальной чертой, либо ничем не разделяться (по типу допуска), либо разделяться наклонной чертой. Перед тем как воспользоваться кнопкой дробей, нужно выделить мышью участок текста, в котором будущие числитель и знаменатель разделены одним из символов: /, ^ или #. Затем нужно щелкнуть по указанной кнопке. На рис. 2.59 в левой части окна редактора мультитекста показаны пять выделенных участков текста с дробями и индексами до форматирования, а в правой части — результат применения к ним кнопки

Рис. 2.59. Управление дробями

Применение кнопки [image] к выделенному участку текста, уже имеющему вид дроби, возвращает этот участок к неформатированному виду.
Для получения верхнего или нижнего индекса можно воспользоваться средством форматирования дроби с помощью специального символа А (при отсутствии числителя или знаменателя).
Редактор мультитекста настроен так, что при обнаружении символов управления дробями система сама открывает диалоговое окно AutoStack Properties (Свойства автопреобразования) (рис. 2.60).

Рис. 2.60. Диалоговое окно AutoStack Properties

В верхней части этого окна находится вопрос:
Do you want to automatically stack the text expressions x/y, x#y and xy as you type? (Хотите ли вы автоматически преобразовывать выражения вида х/у, х#у и хУ в процессе ввода?)
В окне находятся следующие флажки и переключатели, отвечающие на заданный вопрос:

  • Enable AutoStacking (Разрешить автопреобразование);
  • Remove leading blank (Удалять ведущий пробел, между целой частью и дробью);
  • Convert it to diagonal fraction (Преобразовывать в дробь с наклонной чертой);
  • Convert it to horizontal fraction (Преобразовывать в дробь с горизонтальной чертой);
  • Don't show this dialog again, use these settings (He показывать этот диалог снова, использовать сделанные установки).

Третий и четвертый пункты из перечисленных относятся к интерпретации выражения вида х/у (преобразовывать его в дробь с наклонной или с горизонтальной чертой). Остальные пункты задают соответствующие настройки, причем пятый пункт при установке флажка заставляет систему далее не открывать диалоговое окно AutoStack Properties (Свойства автопреобразования).
Линейка разметки окна редактора (см. рис. 2.56) может использоваться для настройки параметров мультитекста в целом или параметров отдельного абзаца. На рис. 2.61 показано, что при перемещении значка [image] изменяется настройка первой строки абзаца текста.

Рис. 2.61. Настройка первой строки абзаца

Аналогично значок [image] можно использовать для настройки общего отступа абзаца.
Если щелкнуть левой кнопкой мыши внутри линейки, то система ставит на ней значок табуляции [image] . Этот значок используется редактором как граница табуляции, когда пользователь при вводе текста нажал клавишу <Таb> (аналогично редактору Microsoft Word).
Удобным дополнительным средством при работе с редактором мультитекста являются контекстные меню, вызываемые по щелчку правой кнопки мыши. При положении курсора в зоне линейки разметки вызывается контекстное меню, приведенное на рис. 2.62.

Рис. 2.62. Контекстное меню линейки разметки

Пункт Indents and Tabs (Отступы и позиции табуляции) этого меню вызывает одноименное окно (рис. 2.63), в котором можно настроить отступы для первой строки и абзаца в целом, а также указать позиции, в которых будут расположены границы табуляции.
В этом окне расположены две области. В области Indentation (Отступы) в поле First line (Первая строка) задается отступ для первой строки абзаца, а в поле Paragraph (Абзац) — отступ для всего абзаца.
Область Tab stop position (Позиции табуляции) используется для указания позиций табуляции. Каждая новая позиция сначала вводится в текущих единицах измерения в верхнем поле и затем добавляется с помощью кнопки Set (Установить). Кнопка Clear (Очистить) очищает весь список табуляций.

Рис. 2.63. Диалоговое окно Indents and Tabs

Пункт Set Mtext Width (Задание ширины мультитекста) контекстного меню линейки разметки (см. рис. 2.62) дает возможность изменить размер мультитекста по ширине. При этом вызывается окно Set Mtext Width (Задание ширины мультитекста) (рис. 2.64), в котором можно изменить текущую ширину мультитекста, введя новое значение в поле Width (Ширина).

Рис. 2.64. Диалоговое окно Set Mtext Width

При положении курсора внутри окна редактора мультитекста щелчок правой кнопкой мыши вызывает контекстное меню, показанное на рис. 2.65.
Контекстное меню имеет следующие элементы:

  • Undo (Отменить) — отменяет последнее действие в окне редактора;
  • Redo (Повторить) — ликвидирует действие последней отмены;
  • Cut (Вырезать) — вырезает выделенную часть текста и заносит в буфер обмена;
  • Сору (Копировать) — копирует выделенную часть текста в буфер обмена;
  • Paste (Вставить) — вставляет текст из буфера обмена;
  • Indents and Tabs (Отступы и позиции табуляции) — вызывает одноименное диалоговое окно (см. рис. 2.63);
  • Justification (Выравнивание) — переход в подменю операций выравнивания (см. далее);
  • Find and Replace (Найти и заменить) — вызов диалогового окна Замена (Replace) для поиска вхождений текста и замены его на другой текст;
  • Select All (Выбрать все) — выделяет весь текст, находящийся в окне редактора;
  • Change Case (Изменить регистр) — переход в подменю смены регистра в выделенном участке на верхний (UPPERCASE) или нижний (lowercase);
  • AutoCAPS (Авто-CAPS) — автоматически переводит новый текст в верхний регистр (пункт работает в режиме установки и сброса флажка);
  • Remove Formatting (Убрать форматирование) — убирает дополнительное форматирование (курсив, жирность, подчеркивание) выделенного участка текста;
  • Combine Paragraphs (Объединить абзацы) — объединяет абзацы в один;
  • Symbol (Символ) — переход в подменю вставки специальных символов;
  • Import Text (Импорт текста) — импортирует текст из файлов с расширением txt и rtf.

Рис. 2.65. Контекстное меню зоны текста

Подменю Justification (Выравнивание) (рис. 2.66) позволяет задать форматирование выделенного абзаца текста. Доступные при этом опции аналогичны таким же опциям форматирования, применяемым для однострочного текста (см. рис. 2.52).

Рис. 2.66. Подменю Justification

Подменю Symbol (Символ) (рис. 2.67) имеет следующие пункты:

  • Degrees (Градусы) — вставляет в текст символ градуса;
  • Plus/Minus (Плюс/минус) — вставляет в текст символ ±;
  • Diameter (Диаметр) — вставляет в текст символы %%с, которые после закрытия окна редактора преобразуются в знак диаметра;
  • Non-breaking Space (Неразрывный пробел) — вставляет неразрывный пробел;
  • Other (Другие) — вызывает системное окно Windows (рис. 2.68) вставки любых символов (для вставки следует выбрать символ, затем нажать кнопку Копировать; после этого можно закрыть окно Таблица символов, а в окне редактора мультитекста вставить символ из буфера обмена Windows).

Рис. 2.67. Подменю Symbol

Для настройки свойств мультитекста в целом можно использовать две опции, выводимые в начале работы команды МТЕХТ (МТЕКСТ) (см. рис. 2.54):

  • Rotation (Поворот) — задает дополнительный поворот мультитекста относительно оси X;
  • Line spacing (Межстрочный интервал) — управляет величиной межстрочного интервала.

Рис. 2.68. Диалоговое окно Таблица символов

При выборе последней из этих опций система запрашивает:
Enter line spacing type [At least/Exactly] <At least>: (Межстрочный интервал [Минимум/Точно] <Минимум>:)
Опция At least (Минимум) соответствует варианту, при котором программа сама рассчитывает интервал, сохраняя минимальное расстояние между строками. В случае выбора опции Exactly (Точно) расстояние между строками фиксируется, независимо от особенностей текста (при наличии отдельных букв большой высоты может возникнуть наложение высоких символов одной строки на символы другой строки).
Следующий запрос:
Enter line spacing factor or distance <1x>: (Значение межстрочного интервала <1х>:)
Межстрочный интервал может быть задан либо фиксированным численным значением, либо в долях от одинарного интервала.
Величина одинарного межстрочного интервала обозначается буквой х и равна высоте символов, умноженной на 1,66. Поэтому значение межстрочного интервала можно ввести как число с суффиксом х (например, 1.5.x, что соответствует полуторному интервалу) или просто как число (например, 2.25, что соответствует 2,25 от высоты символов). Значения должны находиться в диапазоне от 0.0833 (0.25х) до 1.3333 (4х).
Сочетание правильно подобранного межстрочного интервала и позиций табуляции позволяет эффективно использовать мультитекст для заполнения таблиц (например, таблицы спецификации, располагающейся на чертеже).


2.14. Размеры

Операции установки размеров, допусков и выносных линий (выносок) выполняются с помощью команд, которым соответствуют пункты падающего меню Dimension (Размеры) и кнопки панели инструментов Dimension (Размеры). Рассмотрим эти операции в том порядке, в котором они расположены в панели Dimension (Размеры) (рис. 2.69).

Рис. 2.69. Панель инструментов Dimension

Замечание По умолчанию AutoCAD 2004 и AutoCAD 2002, в отличие от предыдущих версий, все размеры создают ассоциативными, т. е. зависимыми от объектов, к которым данные размеры привязаны. Это означает, что при редактировании основного объекта будут автоматически изменяться и все связанные с ним размеры.

Первая команда — DIMLINEAR (РЗМЛИНЕЙНЫЙ) — предназначена для установки линейных размеров. Ей соответствуют кнопка [image] панели Dimension (Размеры) и пункт Linear (Линейный) падающего меню Dimension (Размеры).
Проставим размеры полилинии, представленной в виде прямоугольника, начиная с верхнего горизонтального отрезка. Первый запрос команды DIMLINEAR (РЗМЛИНЕЙНЫЙ):
Specify first extension line origin or <select object>: (Начало первой выносной линии или <выбрать объект>.)
Имеется два варианта выполнения работы. Первый — указать с помощью временной или постоянной объектной привязки точку верхнего левого угла прямоугольника и в ответ на запрос системы AutoCAD:
Specify second extension line origin: (Начало второй выносной линии:)
следует указать с помощью объектной привязки верхнюю правую точку. Система AutoCAD в свою очередь запрашивает, куда поместить размерную линию:
Specify dimension line location or [Mtext/Text/Angle/Horizontal/Vertical/Rotated]: Положение размерной линии или [Мтекст/Текст/Угол/ Горизонтальный/Вертикальный/Повёрнутый]:)
По указанным на объекте точкам AutoCAD определяет, какой тип размера (горизонтальный, вертикальный) вы хотите построить. Если вы с этим согласны, то остается лишь с помощью мыши указать точку, определяющую уровень, на котором будет расположен размер (рис. 2.70), и нажать левую кнопку мыши. Построенный размер является единым объектом (примитивом размер). В случае выбора его мышью он высвечивается весь целиком. При необходимости можно разложить размер на более простые составляющие с помощью команды EXPLODE (РАСЧЛЕНИТЬ).

Рис. 2.70. Указание положения размерной линии

Замечание Если внешний вид размера вас не устраивает (например, высота букв и величины других элементов слишком малы), воспользуйтесь установкой глобального масштаба для размерных элементов во вкладке Размещение (Fit) размерного стиля (см. разд. 3.6) или установкой большего значения системной переменной DIMSCALE (о системных переменных см. гл. 11). Аналогично выполняется установка вертикального размера прямоугольника (рис. 2.71). Система AutoCAD сама пытается определить по указанным точкам, какой из двух основных вариантов линейного размера — горизонтальный или вертикальный — предпочтительнее.

Рис. 2.71. Линейные размеры

Вы можете сами поменять тип линейного размера, если вместо указания точки положения размерной линии выберите одну из опций:

  • Mtext (Мтекст) — ввести более сложный размерный текст, использующий возможности мультитекста;
  • Text (Текст) — ввести размерный текст, отличный от текста, предлагаемого по умолчанию;
  • Angle (Угол) — задать угол поворота размерного текста относительно размерной линии;
  • Horizontal (Горизонтальный) — проставить горизонтальный размер;
  • Vertical (Вертикальный) — проставить вертикальный размер;
  • Rotated (Повернутый) — проставить повернутый (наклонный) размер; AutoCAD запросит: Specify angle of dimension line: (Угол поворота размерной линии:), на что угол можно будет задать числом на клавиатуре или снова указать две точки по концам измеряемого объекта, и система вычислит требуемый угол поворота.

Кроме указания двух точек, между которыми нужно проставить размер, возможен другой вариант работы — воспользоваться опцией <select object> (<выбрать объект>), которая вступает в силу, если вместо начала первой выносной линии нажать клавишу <Enter>. Следует запрос:
Select object to dimension: (Выберите объект для нанесения размера:)
Нужно указать отрезок или прямолинейный сегмент полилинии. Система AutoCAD по объекту сама вычисляет конечные точки и дальше выдает обычный запрос о положении размерной линии и сопутствующих опциях.
Команда DIMALIGNED (РЗМПАРАЛ), которой соответствуют кнопка [image] панели Dimension (Размеры) и пункт Aligned (Параллельный) падающего меню Dimension (Размеры), позволяет проставить линейный размер параллельно выбранному отрезку или двум указанным точкам.
Результат работы команды приведен на рис. 2.72.

Рис. 2.72. Параллельный размер

Команда DIMORDINATE (РЗМОРДИHATА) позволяет строить выноску с установкой значения абсциссы или ординаты указываемой точки. Данной команде соответствуют кнопка [image] панели Dimension (Размеры) и пункт Ordinate (Ординатный) падающего меню Dimension (Размеры). Первый запрос команды:
Specify feature location: (Укажите положение элемента:)
Необходимо указать точку, в которой будет измерена выносимая координата и начнется будущая выносная линия. Следующий запрос:
Specify leader endpoint or fXdatum/Ydatum/Mtext/Text/AngleJ: (Конечная тонка выноски или [Хзначение/Узначение/Мтекст/Текст/Угол]:)
Нужно указать точку, в которой закончится выносная линия. При этом система сама пытается, используя наклон выносной линии, определить, какую из двух координат (абсциссу или ординату) нужно вынести на поле чертежа. Результат работы команды приведен на рис. 2.73.

Рис. 2.73. Ординатный размер

Другие опции команды:

  • Xdatum (Хзначение) — задать выноску абсциссы, независимо от местоположения конца выносной линии;
  • Ydatum (Узначение) — задать выноску ординаты, независимо от местоположения конца выносной линии;
  • Mtext (Мтекст) — ввести новый текст выноски с использованием возможностей мультитекста;
  • Text (Текст) — ввести новый текст выноски;
  • Angle (Угол) — задать угол наклона выносной надписи.

Команде DIMRADIUS (РЗМРАДИУС) соответствуют кнопка [image] панели инструментов Dimension (Размеры) и пункт Radius (Радиус) падающего меню Dimension (Размеры).
Команда предназначена для простановки радиуса и в начале выдает следующий запрос:
Select arc or circle: (Выберите дугу или круг:)
Затем следует запрос:
Specify dimension line location or [Mtext/Text/Angle]: (Положение размерной линии или [Мтекст/Текст/Угол]:)
Точка указания местоположения размерной линии определяет, где и как будет расположен размер, внутри или снаружи (рис. 2.74).
Команда DIMDIAMETER (РЗМДИАМЕТР) предназначена для нанесения диаметра. Ей соответствуют кнопка [image] панели инструментов Dimension (Размеры) и пункт Diameter (Диаметр) падающего меню Dimension (Размеры).
Примеры работы команды приведены на рис. 2.75.
Команда DIMANGULAR (РЗМУГЛОВОЙ) предназначена для простановки угловых размеров между отрезками или углового размера дуги (или части окружности). Ей соответствуют кнопка [image] панели инструментов Dimension (Размеры) и пункт Angular (Угловой) падающего меню Dimension (Размеры). Команда запрашивает:
Select arc, circle, line, or <specify vertex>: (Выберите дугу, круг, отрезок или <указать вершину >:)
Для того чтобы проставить размер, можно указать либо дугу, либо окружность (на ней устанавливается размер дуги, заключенной между двумя указанными точками), либо отрезок (дальше запрашивается еще один отрезок и измеряется между ними угол). Если нажать клавишу <Enter>, то AutoCAD запросит три точки — вершину угла, первую и вторую конечные точки угла.
Этот угол и будет измерен. Все варианты угловых размеров показаны на рис. 2.76.

Рис. 2.74. Простановка радиуса

Рис. 2.75. Простановка диаметра

Рис. 2.76. Простановка углового размера

Команда QDIM (БРАЗМЕР) предназначена для быстрого создания группы однотипных размеров или для быстрого построения базовых размеров и размерных цепей (о базовых размерах и размерных цепях см. ниже — команды DIMBASELINE (РЗМБАЗОВЫЙ) и DIMCONTINUE (РЗМЦЕПЬ)). Команде QD1M (БРАЗМЕР) соответствуют кнопка [image] панели инструментов Dimension (Размеры) и пункт Quick Dimension (Быстрый размер) падающего меню Dimension (Размеры).
Первый запрос команды:
Associative dimension priority = Endpoint Select geometry to dimension: (Приоритет ассоциативного размера = Конточка Выберите объекты для нанесения размеров:)
Нужно отметить объекты, для которых необходимо проставить однотипные размеры. Система сообщает, что при нанесении размеров, которые являются ассоциативными, приоритет будет отдан объектной привязке Endpoint (Конточка). Изменить эту установку можно с помощью новой опции seTtings (Установки). Далее:
Specify dimension line position, or [Continuom/Staggered/Baseline/Ordinate/ Radius/Dlameter/datumPoint/Edit/seTtings] <Continuous>:
(Положение размерной линии или /Цепь/Ступенчатый/Ъазовый/Ординатный/ Радиус/Диаметр/Точка/Изменить/ Установки] <Цепь>:)
Помимо указания местоположения размерной линии, вы можете воспользоваться опциями:

  • Continuous (Цепь) — задание размерной цепи;
  • Staggered (Ступенчатый) — задание ступенчатых размеров (аналог цепи, но размеры выстраиваются в виде ступеньки) (см. рис. 2.77);
  • Baseline (Базовый) — задание базовых размеров;
  • Ordinate (Ординатный) — задание ординатных размеров;
  • Radius (Радиус) — простановка радиусов;
  • Diameter (Диаметр) — простановка диаметров;
  • Datum Point (Точка) — выбор новой базовой точки для базового или ординатного размеров;
  • Edit (Изменить) — изменение нескольких размеров (AutoCAD запрашивает, добавить или удалить точки имеющихся размеров);
  • seTtings (Установки) — выбор другой функции объектной привязки, которой будет отдан приоритет.

Рис. 2.77. Ступенчатые размеры

Команда DIMBASELINE (РЗМБАЗОВЫЙ) позволяет от одной и той же базовой точки построить несколько линейных размеров (рис. 2.78).

Рис. 2.78. Базовые размеры

Команда DIMBASELINE (РЗМБАЗОВЫЙ), помимо ввода с клавиатуры, может быть вызвана с помощью кнопки [image] панели инструментов Dimension (Размеры) или пункта Baseline (Базовый) падающего меню Dimension (Размеры).
Команда не запрашивает положения первой выносной линии, а сразу начинает с запроса второй:
Specify a second extension line origin or [Undo/Select] < Select >: (Начало второй выносной линии или [Отменить/Выбрать] <Выбрать>:)
В качестве базы группы базовых размеров обычно служит предыдущий линейный размер, и его первая точка становится первой точкой для следующих линейных (базовых) размеров. Если вы согласны взять этот размер в качестве базы, то можете сразу указать точку начала второй выносной линии следующего размера с той же базой. Затем можно в цикле указать очередные точки и закончить их выбор нажатием клавиши <Esc>.
При таком выборе отсчет размера может пойти не от той базовой точки.
Если при работе команды система не может определить последний размер, который можно было бы взять за базу, то она выдает дополнительный запрос:
Select base dimension: Linear, Ordinate, or Angular Associative Dimension Required (Выберите исходный размер: Выбрать линейный, ординатный или угловой размер)
Опция Undo (Отменить) отменяет предыдущий шаг команды DIMBASELINE (РЗМБАЗОВЫЙ), а опция Select (Выбрать) позволяет выбрать другой линейный размер в качестве базы.
Команда DIMCONTINUE (РЗМЦЕПЪ) позволяет построить группу продолжающих друг друга линейных размеров (рис. 2.79).

Рис. 2.79. Размерная цепь

Команда DIMCONTINUE (РЗМЦЕПЬ), помимо ввода с клавиатуры, может быть вызвана с помощью кнопки [image] панели инструментов Dimension (Размеры) или пункта Continue (Цепь) падающего меню Dimension (Размеры).
Команда DIMCONTINUE (РЗМЦЕПЬ) тоже начинает сразу с запроса положения второй выносной линии. Эти выносные линии можно поочередно указать в цикле. Опция Undo (Отменить) отменяет предыдущий шаг команды DIMCONTINUE (РЗМЦЕПЬ), а опция Select (Выбрать) позволяет выбрать другой линейный размер в качестве базы для построения размерной цепи.
Команда QLEADER (БВЫНОСКА) строит одноименный примитив выноска, который состоит из ломаной либо гладкой выносной линии или из нескольких сегментов, начинающихся стрелкой (или другим настраиваемым символом) и заканчивающихся одной либо несколькими строками текста или мультитекста. Команда вызывается также кнопкой [image] панели меню Dimension (Размеры) или пунктом Leader (Выноска) падающего меню Dimension (Размеры).
Первый запрос команды:
Specify first leader point, or [Settings] <Settings>: (Первая точка выноски или [Параметры] <Параметры>:)
Если в ответ на этот вопрос задать точку и на повторяющийся вопрос указать еще одну точку, то следующий запрос будет:
Specify text width <0>: (Ширина текста <0>:)
Необходимо задать ширину полки текста (если выноска строится над линией полки, то полная ширина полки получается как сумма введенного значения и ширины текста). Далее:
Enter first line of annotation text <Mtext>: (Первая строка текста пояснения <Мтекст>:)
Можно нажать <Enter>, переходя в режим мультитекста, или ввести первую строку однострочного текста, за которой следует запрос:
Enter next line of annotation text: (Следующая строка текста надписи:)
Окончание текста выноски — нажатие клавиши <Enter>. Результат приведен на рис. 2.80.
В последних версиях системы AutoCAD выноска имеет развитый режим настройки, в который можно войти, выбрав вместо первой точки выноски опцию Settings (Параметры) или нажав клавишу <Enter>. В этом случае появляется диалоговое окно Leader Settings (Параметры выноски) (рис. 2.81).

Рис. 2.80. Построение выноски

Рис. 2.81. Диалоговое окно Leader Settings, вкладка Annotation

Окно состоит из трех вкладок. Вкладка Annotation (Пояснение) имеет три области. В области Annotation Type (Тип пояснения) находятся следующие переключатели:

  • MText (МТекст);
  • Copy an Object (Копия объекта);
  • Tolerance (Допуск);
  • Block Reference (Блок);
  • None (Ничего).

Область MText options (Режимы МТекста) содержит три флажка:

  • Prompt for width (Запрос ширины);
  • Always left justify (Выравнивание влево);
  • Frame text (Текст в рамке).

В области Annotation Reuse (Повторное использование) располагаются следующие переключатели, управляющие возможностью повторения текста выносок:

  • None (Нет);
  • Reuse Next (Следующее пояснение);
  • Reuse Current (Текущее пояснение).

Вкладка Leader Line & Arrow (Выноска и стрелка) имеет четыре области (рис. 2.82).

Рис. 2.82. Диалоговое окно Leader Settings, вкладка Leader Line & Arrow

Два переключателя в области Leader Line (Линия-выноска) управляют формой выносной линии:

  • Straight (Ломаная);
  • Spline (Сплайновая).

Область Number of Points (Количество точек) дает возможность управления верхним ограничением на количество точек выноски. Если вы используете количество точек меньше максимального или работаете в режиме No Limit (Не ограничено), то после последней указанной точкой выноски нужно нажать клавишу <Enter>. Параметр Maximum (Максимум) задает максимальное количество точек (используется, если количество точек ограничивается).
Область Arrowhead (Стрелка) управляет формой выносной стрелки. Допустимые варианты собраны в раскрывающийся список (рис. 2.83).

Рис. 2.83. Раскрывающийся список значений поля Arrowhead

С помощью области Angle Constraints (Ограничения углов) при необходимости можно наложить ограничения на углы первого и второго сегментов выносной линии (на рис. 2.84 показан раскрывающийся список допустимых значений параметров First Segment (Первый сегмент) и Second Segment (Второй сегмент)).

Рис. 2.84. Раскрывающийся список значений параметров области Angle Constraints

Параметры третьей вкладки — Attachment (Выравнивание) — управляют положением мультитекста относительно выноски в вариантах левого и правого расположения (рис. 2.85). Для того чтобы текст разместился над полкой, необходимо установить флажок Underline bottom line (Разместить текст над полкой), находящийся внизу вкладки Attachment (Выравнивание).

Рис. 2.85. Диалоговое окно Leader Settings, вкладка Attachment

Команда TOLERANCE (ДОПУСК) формирует обозначение допуска в виде нескольких рядов прямоугольников (от одного до четырех). Команде соответствует кнопка [image] панели Dimension (Размеры) и пункт Tolerance (Допуск) падающего меню Dimension (Размеры).
Команда TOLERANCE (ДОПУСК) открывает диалоговое окно Geometric Tolerance (Допуски формы и расположения) (рис. 2.86).
Обозначение допуска строится с помощью этого диалогового окна, четыре строки которого соответствуют четырем строкам допуска. Если создаваемое обозначение допуска должно иметь меньшее количество строк, то соответствующая строка диалогового окна не заполняется. Каждая строка диалогового окна рассчитана на максимальную длину (до 13 элементов). Поэтому если реальное обозначение допуска будет иметь меньшую длину, то ненужные элементы не заполняются и они не включаются программой в формируемый примитив допуска.

Рис. 2.86. Диалоговое окно Geometric Tolerance

Заполнение полей в диалоговом окне выполняется следующим образом. Черные поля являются полями выбора символов из специальных окон, а белые поля — текстовые, содержимое которых заполняет пользователь. Если щелкнуть левой кнопки мыши по полю первой или второй строки раздела Sym (Симв), то раскроется окно Symbol (Символ) (рис. 2.87), в котором нужно выбрать один из предлагаемых вариантов.

Рис. 2.87. Окно Symbol

Если щелкнуть левой кнопкой мыши по верхнему левому или нижнему левому черному полю, являющемуся первой частью разделов Tolerance 1 (Допуск 1) или Tolerance 2 (Допуск 2), то в квадрате появится символ диаметра. Такой же щелчок удаляет символ диаметра, если это поле ранее уже было заполнено. Верхнее правое или нижнее правое черное поле Tolerance 1 (Допуск 1) либо Tolerance 2 (Допуск 2) может быть заполнено одним из символов зависимого допуска с помощью окна Material Condition (Зависимый допуск) (рис. 2.88).

Рис. 2.88. Окно Material Condition

Аналогично заполняются или пропускаются остальные поля. Пример результата действия команды TOLERANCE (ДОПУСК) приведен на рис. 2.89.

Рис. 2.89. Пример выполнения команды TOLERANCE

Можно в команде QLEADER (БВЫНОСКА) в качестве выносного текста получать обозначение допуска (см. опцию Tolerance (Допуск) вкладки Annotation (Пояснение)).
Команда DIMCENTER (РЗМЦЕНТР) позволяет проставить маркер центра окружности или дуги. Команде соответствуют кнопка [image] панели Dimension (Размеры) и пункт Center Mark (Маркер центра) падающего меню Dimension (Размеры).
В зависимости от настройки стиля (см. разд. 3.6) маркер центра окружности может наноситься одним из способов, изображенных на рис. 2.90.

Рис. 2.90. Маркер центра окружности

Остальные кнопки панели Размеры (Dimension) посвящены операциям редактирования размеров, которые рассмотрены в разд. 3.6.


2.15. Штриховки и заливки

Для штрихования замкнутых областей рисунка служит команда ВНАТСН (КШТРИХ), которая вызывается либо с помощью кнопки [image] панели Draw (Рисование), либо с помощью пункта Hatch (Штриховка) падающего меню Draw (Рисование).
Команда ВНАТСН (КШТРИХ) позволяет создать штриховку или заливку области, ограниченной замкнутой линией (линиями), как путем простого указания точек внутри контура, так и путем выбора объектов. Эта команда автоматически определяет контур и игнорирует примитивы, которые не имеют отношения к контуру. Она вызывает диалоговое окно Boundary Hatch and Fill (Штриховка и заливка по контуру) с тремя вкладками в левой части (рис. 2.91).

Рис. 2.91. Диалоговое окно Boundary Hatch and Fill, вкладка Hatch

Диалоговое окно имеет три сменяющих друг друга вкладки в левой части. Вкладка Hatch (Штриховка) (в предыдущей версии она называлась Quick (Основные)) задает параметры штриховки. Заполняемая штриховкой область задается с помощью параметров в правой части этого окна.
Раскрывающийся список Туре (Тип) предлагает выбрать группу образцов штриховки:

  • Predefined (Стандартный);
  • User defined (Из линий);
  • Custom (Пользовательский).

Система AutoCAD предлагает большой перечень стандартных штриховок. Выбор штриховки осуществляется либо по имени в раскрывающемся списке Pattern (Образец) либо визуально. Визуальный выбор доступен при нажатии на кнопку [image] , после чего открывается окно Hatch Pattern Palette (Палитра образцов штриховки), состоящее из четырех вкладок. Вкладки ANSI (рис. 2.92) и ISO (рис. 2.93) содержат образцы штриховок стандартов ANSI и ISO, поставляемые вместе с данной версией системы.
Вкладка Other Predefined (Другие стандартные) (рис. 2.94) содержит образцы, не вошедшие в первые две вкладки. В четвертой вкладке Custom (Пользовательские) могут находиться образцы, созданные пользователем.

Рис. 2.92. Окно Hatch Pattern Palette, вкладка ANSI

Рис. 2.93. Окно Hatch Pattern Palette, вкладка ISO

Рис. 2.94. Окно Hatch Pattern Palette, вкладка Other Predefined

В перечне других стандартных образцов есть штриховка с именем SOLID, которая является не штриховкой в прямом смысле слова, а заливкой (о заливках речь пойдет далее). Имя образца отображается в поле Swatch (Структура) окна Boundary Hatch and Fill (Штриховка и заливка по контуру).
Если в раскрывающемся списке Туре (Тип) выбрана опция User defined (Из линий), то образец строится с использованием текущего типа линии, угла и расстояния между линиями (поле Spacing (Интервал)).
Выберите мышью пиктограмму с нужным вам образцом штриховки и нажмите ОК. Можете задать также угол наклона и масштаб штриховки относительно эталонного изображения. При увеличении масштаба расстояние между линиями штриховки увеличивается, при уменьшении масштаба — уменьшается.
Если выбирается стандартный образец штриховки из вкладки ISO, то можно задать толщину пера в поле ISO Pen Width (Толщина пера по ISO). Флажок Relative to Paper Space (Относительно пространства листа) доступен только при работе в пространстве листа (см. гл. 10).
С помощью правой части диалогового окна Boundary Hatch and Fill (Штриховка и заливка по контуру) должны быть заданы параметры заполняемого контура. Кнопка [image] (Pick Points (Указание точек)) позволяет в цикле указать внутренние точки областей, контуры которых AutoCAD вычислит (даже если контур будет состоять из частей разных линий) (рис. 2.95). Выйти из цикла указания точек можно, нажав клавишу <Enter>.

Рис. 2.95. Выбор зоны штрихования с помощью кнопки Pick Points

Кнопка [image] (Выбор объектов (Select Objects)) позволяет отметить объекты, пересечение между которыми и даст заполняемую штриховкой область. Все штрихуемые контуры могут быть получены комбинацией методов указания точек и выбора объектов.
Кнопка [image] (Remove Islands (Исключение островков)) дает возможность при выборе большого количества объектов исключить случайно возникшие островки. Кнопка [image] (View Selections (Просмотр набора)) позволяет временно покинуть окно Boundary Hatch and Fill (Штриховка и заливка по контуру) для того, чтобы увидеть еще раз, какие зоны штрихования выбраны. Эти две кнопки недоступны пользователю (погашены), если он еще не указал штрихуемую область.
Кнопка [image] (Inherit Properties (Копирование свойств)) переносит параметры уже выполненной штриховки на новые объекты. В некоторых видах штриховки доступен флажок Double (Крест-накрест), который при штриховании сначала заполняет область обычным образом, а затем повторяет основной образец, но уже под наклоном 90° к исходному варианту.
Большое значение имеет группа из двух переключателей Composition (Связь с контуром). С ее помощью можно задать (Associative (Ассоциативная)) или убрать (Nonassociative (Неассоциативная)) свойство ассоциативности штриховки. Если штриховка ассоциативна, то она привязывается к внешнему контуру. В этом случае при изменении контура штриховка автоматически пересчитывается.
Следующий уровень настройки свойств штриховки выполняется с помощью вкладки Advanced (Дополнительные) (рис. 2.96).

Рис. 2.96. Диалоговое окно Boundary Hatch and Fill, вкладка Advanced

Если при указании зоны штрихования есть вложенные друг в друга объекты, то важно правильно задать стиль штрихования, что определяется включением одного из переключателей группы Island Detection Style (Стиль обнаружения островков). При стиле Normal (Нормальный) возможные зоны штрихования располагаются по порядку их движения от самой внешней зоны внутрь и штрихуются через одну. При стиле Outer (Внешний) заштриховывается только внешняя часть, все внутренние выбрасываются. При стиле Ignore (Игнорирующий) штрихуется все, включая все внутренние зоны. Графические иллюстрации всех вариантов стиля видны на рис. 2.96.
Если штрихуемый контур является не единым объектом, а составляется из частей нескольких примитивов, то с помощью флажка области Object type (Тип объекта) появляется возможность включить режим Retain Boundaries (Сохранение контуров). В этом режиме контур может быть сохранен либо в виде полилинии, либо в виде области (об областях см. разд. 9.9). С помощью группы из двух переключателей области Island detection method (Метод обнаружения островков) можно повлиять на алгоритм обнаружения островков (методы Flood (Поток) и Ray Casting (Падение лучей)).
Если контур выбирался с помощью кнопки Pick Points (Указание точек) и результат, который выдала система AutoCAD, не вполне вас устраивает, вы можете дополнительно указать только те объекты, из которых нужно набирать контур (остальные, ранее выбранные системой, будут проигнорированы). Это делается с помощью кнопки [image] (New (Новый)) раздела Boundary set (Набор контуров).
После формирования контура и задания параметров штриховки желательно просмотреть результат установок с помощью кнопки Preview (Просмотр), доступной на вкладке Hatch (Штриховка) в левом нижнем углу диалогового окна Boundary Hatch and Fill (Штриховка и заливка по контуру). Как правило, трудно сразу подобрать подходящий масштаб для штриховки. Если масштаб слишком мал, то количество линий штриховки будет чрезмерно велико и штриховка будет слишком плотной. Если масштаб слишком велик, то количество линий штриховки может оказаться очень малым (оно может оказаться даже нулевым) — например, как на рис. 2.97.

Рис. 2.97. Штриховка, выполненная со слишком большим значением масштаба (режим Preview)

Если в примере на рис. 2.97 масштаб уменьшить в несколько раз, то получится приемлемый результат (рис. 2.98).

Рис. 2.98. Штриховка, выполненная с правильным масштабом

Штриховка создается как единый примитив, поэтому при выборе штриховки как объекта высвечивается только одна ручка (о ручках подробнее см. разд. 3.1). Если нужно разложить штриховку на составляющие ее отрезки, то это можно сделать командой EXPLODE (РАСЧЛЕНИТЬ). При расчленении штриховка распадается и утрачивает ассоциативность, если она была. Под именем SOLID на вкладке Other Predefined (Другие стандартные) (см. рис. 2.94) фигурирует не штриховка, а запивка. Используемый для заливки .контур должен быть замкнутым и без самопересечений. Если заливается сразу несколько контуров, они не должны пересекаться. Пример заливки приведен на рис. 2.99.

Рис. 2.99. Пример заливки

В рассматриваемой версии системы впервые появилось целое множество заливок — градиентные заливки. Для работы с ними предназначена вкладка Gradient (Градиентные) диалогового окна Boundary Hatch and Fill (Штриховка и заливка по контуру) (рис. 2.100).

Рис. 2.100. Диалоговое окно Boundary Hatch and Fill, вкладка Gradient

В верхней части диалогового окна с помощью двух переключателей нужно выбрать тип заливки: One color (Одноцветная) или Two color (Двухцветная). Для одноцветной заливки необходимо указать основной цвет (его текущее значение отображается в поле [image] , расположенном чуть правее переключателей), а также с помощью кнопки скользящей шкалы выбрать соотношение между светом (Tint) и тенью (Shade). Для изменения основного цвета следует пользоваться кнопкой [image] , щелчок по которой открывает диалоговое окно Select Color (Выбор цвета), имеющее три вкладки. На вкладке Index Color (Цвет по номеру) (рис. 2.101) можно выбрать цвет традиционным для предыдущих версий AutoCAD способом — по номеру (от 1 до 255).
В рассматриваемой версии системы появились еще две вкладки. Внешний вид вкладки True Color (Точный цвет) зависит от выбора в раскрывающемся списке Color model (Цветовая модель) одного из двух значений: HSL или RGB. В первом случае (рис. 2.102) настройка цвета выполняется с помощью шкал Hue (Оттенок), Saturation (Насыщенность) и Luminance (Яркость). Изменять значения в каждой из шкал можно с помощью кнопок настройки [image] Кроме того, для шкалы Luminance (Яркость) можно пользоваться ее аналогом — вертикальной скользящей шкалой в центре. Выбранный цвет иллюстрируется указателем [image] в палитре, расположенной в левой части вкладки. Местоположение указателя можно изменить, щелкнув левой кнопкой мыши внутри палитры. Для выбранного цвета дается также разложение на составляющие в модели RGB (Red (Красный), Green (Зеленый) и Blue (Синий)) (на рис. 2.102 это следующие значения: 64, 189, 191).

Рис. 2.101. Диалоговое окно Select Color, вкладка Index Color

Рис. 2.102. Диалоговое окно Select Color, вкладка True Color (модель HSL)

Если установить в раскрывающемся списке Color model (Цветовая модель) значение RGB, то вкладка примет вид, изображенный на рис. 2.10.З.

Рис. 2.103. Диалоговое окно Select Color, вкладка True Color (модель RGB)

Третья вкладка — Color Books (Цветовые книги) (рис. 2.104) — диалогового окна Select Color (Выбор цвета) позволяет управлять общим стилем цветовых настроек, причем пользователь может подключать собственные цветовые книги (о настройке см. гл. 11).

Рис. 2.104. Диалоговое окно Select Color, вкладка Color Books

На рис. 2.105 показан пример градиентных заливок.

Рис. 2.105. Пример градиентных заливок

Панель Tool Palettes (Палитры инструментов) может быть использована как инструмент быстрого создания наиболее употребительных штриховок и заливок. Эта панель, если она закрыта, может быть вызвана при помощи кнопки [image] панели Standard (Стандартная). На рис. 2.10.6 показана пользовательская вкладка Мои штриховки с образцами штриховок и заливок.

Рис. 2.106. Пример градиентных заливок

Вставка нужной штриховки или заливки выполняется простым перетаскиванием образца внутрь той области, которую необходимо заполнить. О настройке панели TOOL PALETTES (Палитры инструментов) см. разд. 7.1.


2.16. Эллипсы

Эллипс — это геометрическое место точек, сумма расстояний до которых от двух фиксированных точек (фокусов) постоянна. Создание эллипсов и эллиптических дуг выполняется в системе AutoCAD с помощью команды ELLIPSE (ЭЛЛИПС), которая, помимо ввода с клавиатуры, может быть вызвана кнопкой [image] панели Draw (Рисование) или пунктом падающего меню Draw | Ellipse | Axis, End (Рисование | Эллипс Ось, Конец). Первый запрос команды: Specify axis endpoint of ellipse or [Arc/Center]: (Конечная точка оси эллипса или [Дуга/Центр]:)
Если вы указали первую точку оси эллипса, то следующий запрос системы таков:
Specify other endpoint of axis: (Вторая конечная точка оси:)
На этот запрос нужно указать вторую конечную точку оси эллипса. Система AutoCAD по первым точкам вычисляет центр эллипса (середина отрезка между первой и второй точками). Далее последует очередной запрос:
Specify distance to other axis or fRotation]: (Длина другой оси или (Поворот/:)
В этот момент можно ввести число, являющееся длиной второй оси эллипса. Если указать третью точку, то система вычислит расстояние от центра до этой точки, возьмет его в качестве дайны второй полуоси и построит по этим данным эллипс (рис. 2.107).
Если в последнем случае вместо дайны второй оси выбрать опцию Rotation (Поворот), то эллипс будет построен как проекция окружности, повернутой в пространстве относительно плоскости XY (точнее, относительно главной оси) на указанный вами угол. Допустимый диапазон углов: 0—89,4 (если угол равен нулю, то получается обычная окружность). Отношение дайн полуосей вычисляется как абсолютная величина косинуса введенного угла.
Если в ответ на запрос первой точки выбрать опцию Center (Центр) — этому варианту соответствует пункт падающего меню Draw | Ellipse | Center (Рисование | Эллипс | Центр), — то следующее сообщение AutoCAD будет таким:
Specify center of ellipse: (Центр эллипса:)
После указания точки центра эллипса AutoCAD запрашивает:
Specify endpoint of axis: (Конечная точка оси:)

Рис. 2.107. Построение эллипса

После этого выдается заключительный запрос, как и в рассмотренном нами ранее случае (Specify distance to other axis or [Rotation]: (Длина другой оси или [Поворот/:)).
Для построения эллиптической дуги нужно в команде ELLIPSE (ЭЛЛИПС) в ответ на запрос первой точки выбрать опцию Arc (Дуга). Такому же варианту работы команды соответствует кнопка [image] панели Draw (Рисование), а также пункт падающего меню Draw | Ellipse Arc (Рисование | Эллипс Дуга). Следующий запрос системы AutoCAD: Specify axis endpoint of elliptical arc or [Center]: (Конечная точка оси эллиптической дуги или [Центр]:) Далее: Specify other endpoint of axis: (Вторая конечная точка оси:) Следующий запрос:
Specify distance to other axis or [Rotation]: (Д/шна другой оси или [Поворот]:)
Теперь следует запрос на выделение дуги как части эллипса:
Specify start angle or [Parameter]: (Начальный угол или /Параметр]:)
Начальный угол задается числом или с помощью мыши относительно первой оси (отсчет производится против часовой стрелки, начиная с первой точки оси). Далее:
Specify end angle or [Parameter/Included angle]: (Конечный угол или [Параметр/Внутренний угол]:)
Можно задать конечный угол (рис. 2.108) или, выбрав опцию Included angle (Внутренний угол), ввести внутренний (центральный) угол дуги.

Рис. 2.108. Построение эллиптической дуги

Если вы в ответ на этот или иной запрос выбираете опцию Параметр (Parameter), то тогда вы задаете углы с помощью значения параметра в параметрическом векторном уравнении эллипса:
р(u) = с + acos(u) + bsin(u),
где с — это центр эллипса, а а и b — большая и малая оси эллипса (р, с, а и b — двумерные векторы); u — параметр уравнения.
Как начато, так и конец эллиптической дуги могут быть заданы углами или значениями параметра.


2.17. Сплайны

Команда SPLINE (СПЛАЙН) позволяет чертить сплайн — гладкую линию, которая точно проходит через заданные точки или отклоняется от них в рамках допуска и которая может удовлетворять условиям касания в начальной, конечной или обеих точках. Команда, помимо ввода с клавиатуры, может быть вызвана с помощью кнопки [image] панели Draw (Рисование) или пункта Spline (Сплайн) падающего меню Draw (Рисование). Начальный запрос команды: Specify first point or [Object]: (Первая точка или [Объект]:) Если вы указали точку, то выдается запрос: Specify next point: (Следующая точка:)
После ввода второй точки возможно или дальнейшее указание точек, или замыкание линии с помощью опции Close (Замкнуть), или ввод допуска (тогда линия получается более гладкой и может отклоняться от введенных точек на величину заданного допуска):
Specify next point or [Close/Fit tolerance] <start tangent >: (Следующая тонка или [Замкнуть/Допуск] <касательная в начале>:)
Точки могут задаваться и дальше, пока вы не нажмете на клавишу <Enter> и не перейдете тем самым к запросу начального угла касания:
Specify start tangent: (Касательная в начальной точке:)
Если строится замкнутый сплайн (при выборе опции Close (Замкнуть)), то запрос на касание слегка поменяется:
Specify tangent: (Направление касательной:)
Угол может быть задан числом или с помощью мыши (рис. 2.109).
Если нажать на клавишу <Enter>, то в начальной точке граничное условие для построения линии не используется.
Если сплайн не замкнутый (т. е. не использована опция Close (Замкнуть)), то после запроса о начальной касательной выдается запрос на указание направления касания в последней точке (рис. 2.110):
Specify end tangent: (Касательная в конечной точке:)

Рис. 2.109. Задание начальной касательной к сплайну

Рис. 2.110. Задание конечной касательной к сплайну

Примеры построенных сплайнов приведены на рис. 2.111.

Рис. 2.111. Построение сплайнов

Если вместо первой точки сплайна выбрать опцию Object (Объект), то система AutoCAD переходит в режим преобразования ранее построенных и сглаженных с помощью опции Spline (Сплайн) двумерных или трехмерных полилиний (см. разд. 3.3 и 9.3) в сплайны и выдает запрос:
Select objects to convert to splines... Select objects: 'Выберите объекты для преобразования в сплайны... Выберите объекты:)
По окончании выбора объектов (полилиний) они преобразуются из примитива "полилиния" в примитив "сплайн".


2.18. Другие примитивы

К редким примитивам могут быть отнесены полосы и фигуры.
Команда TRACE (ПОЛОСА) вводится только с клавиатуры и предназначена для построения полос — ломаной линии с постоянной шириной. Первый запрос команды:
Specify trace width <1.0000>: (Ширина полосы <1.0000>:)
Задайте ширину вводом числа с клавиатуры или указанием двух точек. Следующий запрос:
Specify start point: (Начальная точка:)
Укажите начальную точку осевой линии полосы. Далее:
Specify next point: (Следующая точка:)
Задайте в цикле очередные точки и завершите построение нажатием клавиши <Enter>. Результат выполненной операции изображен на рис. 2.112. Сегменты полосы не образуют единого объекта.

Рис. 2.112. Построение полосы

Следующая команда — SOLID (ФИГУРА) — строит последовательно расположенные закрашенные четырехугольники или треугольники. Вершины четырехугольника задаются точками:
Specify first point: (Первая точка:)
Затем следует запрос второй точки:
Specify second point: {Вторая тонка:)
Далее:
Specify third point: (Третья точка:)
В качестве третьей точки четырехугольника нужно указать точку, расположенную по диагонали напротив второй (иначе фигура получится перекрученной). Далее следует запрос о четвертой точке. Если вместо ввода четвертой точки нажать клавишу <Enter>, то строится треугольная фигура.
Specify fourth point or <exit>: (Четвертая точка или <выход>:)
Затем снова повторяется запрос третьей точки, поскольку первой и второй точкой очередного четырехугольника становятся первая и вторая точки предыдущего.
В тот момент, когда вы вместо ввода третьей точки нажмете клавишу <Enter>, выполнение команды закончится. Пример выполненного построения приведен на рис. 2.113.

Рис. 2.113. Построение фигур

Фигуры, построенные с помощью одной команды SOLID (ФИГУРА), не образуют единого объекта.


2.19. Получение справок

В процессе работы очень полезными оказываются команды получения справочной информации о создаваемых объектах. На рис. 2.114 показана панель инструментов Inquiry (Справки), содержащие кнопки следующих операций. Перечислим их в порядке их расположения в панели слева направо:

  • Distance (Расстояние);
  • Area (Площадь);
  • Region/Mass Properties (Область/Масса);
  • List (Список);
  • Locate Point (Координаты).

Рис. 2.114. Панель Inquiry

К этим операциям можно также обратиться с помощью подменю Inquiry (Сведения) падающего меню Tools (Сервис). Соответствующие кнопкам панели Inquiry (Сведения) команды имеют следующие наименования:

  • DIST(ДИСТ);
  • AREA (ПЛОЩАДЬ);
  • MASSPROP (МАСС-ХАР);
  • LIST (СПИСОК);
  • ID (КООРД).

Практически все эти команды запрашивают объекты (команда DIST (ДИСТ) — две точки) и выводят свои результаты в текстовое окно.
Особое место среди справочных команд занимает команда LIST (СПИСОК) (соответствующая ей кнопка - [image] ), которая не только выдает координаты и другие данные, использованные при построении объектов, но и такую информацию, как площадь, периметр, цвет, уровень, угол наклона и др. Поэтому эта команда является мощным средством контроля правильности введенных данных.
В справочных командах наименования примитивов выводятся в следующем виде: LINE (отрезок), XLINE (прямая), RAY (луч), CIRCLE (круг), ARC (дуга), POLYLINE (полилиния или сеть), LWPOLYLINE (компактная полилиния), DIMENSION (размер), TOLERANCE (допуск), LEADER (выноска), ELLIPSE (эллипс), SPLINE (сплайн), TRACE (полоса), SOLID (фигура), 3DSOLID (тело), BLOCK REFERENCE (вхождение блока или внешней ссылки), IMAGE (растровое изображение), WIPEOUT (пятно) и т. д.
Система AutoCAD 2004 имеет развитую справочную систему, обратиться к которой можно либо с помощью функциональной клавиши <F1>, либо с помощью пункта Help (Справка) падающего меню Help (Справка), либо щелчком по кнопке [image] панели Standard (Стандартная), либо с помощью команды HELP (СПРАВКА). При вызове справочной системы открывается окно AutoCAD 2004 Help: User Documentation (Справочная система AutoCAD 2004: документация пользователя) (рис. 2.115), которое разделено на две части. В левой части отмечается наименование раздела или темы, а в правой высвечивается содержимое отмеченного раздела. Если пользователь нажимает клавишу <F1> во время выполнения какой-нибудь команды, то в правой части окна отображается контекстно-зависимая справка, т. е. справочная информация по текущей команде.

Рис. 2.115. Окно справочной системы

Левая часть окна, приведенного на рис. 2. 115, имеет пять вкладок (названия некоторых вкладок выводятся на русском языке в русской версии Windows):

  • Содержание (Contents) — показывает список разделов;
  • Предметный указатель (Index) — содержит наиболее употребляемые термины документации, по которым можно найти раздел;
  • Поиск (Find) — осуществляет поиск тем по любым словам;
  • Избранное (Favorites) — отмечает разделы и заносит их наименования в список избранных разделов;
  • Ask Me (Спроси меня) — облегчает поиск раздела, когда пользователю трудно назвать конкретный термин.

Данная структура справочной системы характерна для всех продуктов, интегрированных в Windows.
В данной версии имеется еще один вид помощи — это активная помощь, окно которой может быть вызвано либо командой ASSIST (ПОМОЩНИК), либо пунктом Active Assistance (Помощник) падающего меню Help (Справка). Окно активной помощи приведено на рис. 2.116.

Рис. 2.116. Окно Active Assistance

Окно Active Assistance (Помощник) отличается от предыдущего тем, что его содержимое всегда контекстно-зависимо и меняется при переходе от одной команды к другой. На рис. 2.116 показана активная помощь к команде SPLINE (СПЛАЙН).
При загруженном окне активной помощи в правой части панели задач (в области уведомлений) Windows (в правом нижнем углу экрана) появляется значок [image] . При щелчке правой кнопкой мыши по этому значку открывается контекстное меню Помощника, состоящее из трех пунктов:

  • Show Active Assistance (Показать Помощника) — открывает окно активной помощи;
  • Settings (Параметры) — открывает окно настройки параметров Помощника;
  • Exit (Выход) — удаляет значок Помощника из правой части панели задач Windows.

Окно настройки параметров Помощника (рис. 2.117) имеет один флажок и группу из четырех переключателей в области Activation (Активизация). Если установлен флажок Show on start (Показывать при старте), то окно Помощника открывается сразу же при загрузке файла рисунка.

Рис. 2.117. Окно Active Assistance Settings

В области Activation (Активизация) находятся переключатели, которые управляют режимом активизации Помощника:

  • All commands (Для всех команд);
  • New and enhanced commands (Для новых и усовершенствованных команд);
  • Dialogs only (Только для диалоговых окон);
  • On demand (По запросу).

Включение нужного переключателя позволяет сделать вызов окна активной помощи своевременным и не мешающим работе пользователя.


Глава 3. Редактирование геометрии

    • Редактирование геометрии
    • 3.1. Ручки и выбор объектов
    • 3.2. Команды общего редактирования
    • 3.3. Редактирование полилиний
    • 3.4. Редактирование мультилиний
    • 3.5. Редактирование надписей
    • 3.6. Редактирование размеров
    • 3.7. Редактирование штриховок и заливок
    • 3.8. Редактирование эллипсов
    • 3.9. Редактирование сплайнов


В данной главе рассматриваются операции редактирования геометрии объектов, описанных в предыдущей главе:

  • операции редактирования примитивов с помощью ручек (см. разд. 3.1);
  • команды общего редактирования — копирование, перемещение, удлинение и т. п. (см. разд. 3.2);
  • специальные команды редактирования сложных примитивов (см. разд. 3.3— 3.9).

Операции редактирования свойств (цвета, слоя, типа линии, веса линии и др.) рассмотрены в гл. 4.


3.1. Ручки и выбор объектов

Как уже рассказывалось в разд. 2.5, если в командной строке стоит приглашение Command: (Команда:), то можно отметить на экране видимые объекты и на них появятся ручки — небольшие синие квадраты в характерных точках объектов. Ручки — очень удобный инструмент для быстрого изменения выделенного объекта. Все выбранные в данный момент объекты образуют набор.
Посмотрим, какие ручки высвечиваются у разных примитивов и как можно ими пользоваться для их редактирования. Имена примитивов будут приведены такие, какие выдаются командой LIST (СПИСОК).
Для примитива LINE (отрезок) характерными точками являются конечные и средние точки. Щелкните левой кнопкой мыши по построенному ранее отрезку. Отрезок подсветился (получил пунктирное изображение), а в конечных и средней точках появились ручки (рис. 3.1), которые показывают, что объект выбран для некоторой операции (редактирования или получения справочной информации).

Рис. 3.1. Ручки отрезка

Обычно ручки выбранных примитивов имеют синий цвет. Однако если вы подведете перекрестье курсора, например, к левой ручке, то цвет этой ручки изменится на зеленый. Это означает, что счетчик координат в строке состояния показывает координаты характерной точки объекта. На рис. 3.1 видно, что левая конечная точка отрезка имеет координаты X = 90.4567, Y= 119.9414, Z = 0.
Выберите первую ручку отрезка, установив на нее перекрестье курсора, затем нажмите и отпустите левую кнопку мыши. Выбранная ручка должна сменить синий цвет на красный. Система AutoCAD выдает сообщение:
** STRETCH ** Specify stretch point or [Base point/Copy/Undo/eXit]: (** РАСТЯНУТЬ ** Точка растягивания или [Базовая точка/Копировать/Отменить/выХод]:)
Введите на клавиатуре 90,240 и нажмите клавишу <Enter>. Отрезок сразу изменится: его левый конец переместится в точку с координатами X = 90, Y = 240 (рис. 3.2).

Рис. 3.2. Редактирование отрезка с помощью конечной ручки (указание новой точки вводом координат)

Координаты новой точки можно задать не только вводом их с клавиатуры, но и любым из способов, рассмотренных нами в разд. 2.3. Система AutoCAD при этом выполнит действие, аналогичное работе команды STRETCH (РАСТЯНУТЬ), которая описана в разд. 3.2. На рис. 3.3 отображен процесс редактирования, аналогичный процессу, приведенному на рис. 3.2, но результат получается с применением мыши. Старое положение отрезка показано пунктирной линией, новое — сплошной. Левой кнопкой мыши нужно сначала щелкнуть на ручке изменяемой конечной точки и отпустить нажатую левую кнопку. Затем переместить курсор и снова щелкнуть и отпустить левую кнопку только тогда, когда отрезок достигнет нужного положения.
Остальные опции операции редактирования с помощью ручки аналогичны опциям команды COPY (КОПИРОВАТЬ), которые рассмотрены в разд. 3.2.
Если после выбора ручки вместо выбора ее нового местоположения нажать клавишу <Enter> или <Space> (<Пробел>), то система AutoCAD предлагает аналогичный запрос, но относящийся к команде MOVE (ПЕРЕНЕСТИ). После следующего нажатия на <Enter> запрос меняется и превращается в запрос команды ROTATE (ПОВЕРНУТЬ), затем — команды SCALE (МАСШТАБ), вслед за этим - команды MIRROR (ЗЕРКАЛО), далее снова возвращается запрос команды STRETCH (РАСТЯНУТЬ). Эти операции предлагаются в циклическом порядке, они рассмотрены также в разд. 3.2.

Рис. 3.3. Редактирование отрезка с помощью конечной ручки (указание новой точки мышью)

Если выбрать мышью не конечную ручку, а среднюю, то AutoCAD выдает текст с такими же опциями, как и в предыдущем случае. Укажите мышью новое положение средней точки (рис. 3.4). Отрезок переместится на новое место (перемещение выполняется за среднюю точку).
Аналогичным образом ручки используются и у других примитивов — для указания нового положения выбранной точки объекта или переноса всего объекта на новое место.
У примитива XLINE (прямая) высвечиваются базовая точка и две точки на прямой на небольшом расстоянии от базовой. Если переносить базовую (среднюю) точку, то перемещается вся линия, а если переносить точки других ручек, то базовая точка остается на месте, но изменяется наклон прямой (рис. 3.5).

Рис. 3.4. Редактирование отрезка с помощью средней ручки

Рис. 3.5. Редактирование наклона прямой с помощью ручки

Аналогично использование ручек для редактирования лучей (имя примитива — RAY). У луча высвечиваются две ручки: в базовой точке и в точке, определяющей направление. При перемещении базовой точки перемещается весь луч, при перемещении второй (направляющей) точки изменяется наклон луча.
На окружности (имя примитива — CIRCLE) высвечивается пять ручек: в центре и квадрантах (т. е. крайней верхней, нижней, левой и правой точках). При попытке перемещения центральной ручки окружность перемещается на новое место, а в случае редактирования окружности за любую из остальных ручек окружность растягивается или сжимается, меняя радиус (рис. 3.6).

Рис. 3.6. Редактирование радиуса окружности с помощью ручки

У примитива ARC (дуга) высвечиваются три ручки: на концах и в середине. Перемещение любой из ручек ведет к изменению дуги, с построением новой дуги по трем точкам, из которых одна была новой (рис. 3.7).
Полилиния может быть представлена в информационном окне команды LIST (СПИСОК) с двумя наименованиями: LWPOLYLINE, т. е. компактная полилиния, и POLYLINE, т.е. подробная полилиния (см. разд. 3.3). Компактную полилинию иногда называют легкой (от английского термина lightweight polyline). Ручки высвечиваются на полилинии в концах сегментов и средних точках дуговых сегментов. При перемещении выбранной ручки на новое место прямолинейные сегменты меняются аналогично изменению отрезков при их перемещении за конечные точки, а дуговые сегменты — аналогично изменению дуг (рис. 3.8).

Рис. 3.7. Редактирование дуги с помощью ручки

Примитив MLINE (мультилиния) редактируется с помощью ручек аналогично полилиниям.
Примитивы TEXT (текст) и МТЕХТ (мультитекст) имеют ручки в тех точках, которые характеризуют положение или выравнивание текста. Любая из ручек может использоваться как инструмент для перемещения текста на новое место (рис. 3.9). При некоторых способах выравнивания (Fit (По ширине), Aligned (впИсанный)) перемещение одной ручки может изменять также и наклон текста.
Команды падающего меню Dimension (Размеры) создают примитивы DIMENSION (размер), LEADER (выноска) и TOLERANCE (допуск). Изменения примитивов могут выполняться за любую ручку, что приводит к их перемещению или изменению формы.

Рис. 3.8. Редактирование полилинии с помощью ручки

Рис. 3.9. Редактирование текста с помощью ручки

Однако при редактировании размера с помощью ручек рекомендуется высвечивать ручки не только у размерного примитива, но и у объекта, для которого был проставлен размер. Если вы перемещаете с помощью мыши ручку, к которой была привязана выносная линия размера, то происходит изменение не только основного объекта, но и его размерного примитива (рис. 3.10). Как было сказано в разд. 2.14, размеры обычно являются ассоциативными, поэтому изменение основного примитива вызовет и изменение связанного с ним ассоциативного размера. Об изменении ассоциативности см. разд. 3.6.

Рис. 3.10. Одновременное редактирование объекта и связанного с ним размера с помощью ручки

Примитив DIMENSION имеет ручки не только у базовых точек, но и на концах выносных линий и у размерного текста. Эти ручки позволяют менять положение выносной линии и размерного текста (при этом общее оформление размера как единого целого сохраняется).
Редактирование примитива HATCH (штриховка или заливка) с помощью ручек неэффективно, так как штриховка имеет всего одну ручку в центре тяжести и за эту ручку штриховку можно перенести на новое место (что впрочем, как правило, не имеет смысла). В то же время следует вспомнить свойство ассоциативности штриховки, упомянутое в разд. 2.15. Благодаря этому свойству редактирование контура приведет к изменению штриховки, которая к нему привязана.
Ручки эллипса и эллиптической дуги (и тот и другая являются примитивом ELLIPSE) высвечиваются в различных местах. У полного эллипса их положение аналогично положению ручек окружности. При перемещении центральной ручки перемешается и весь выбранный эллипс. А вот если перемещать центральную ручку эллиптической дуги, то это приведет к изменению дуги (рис. 3.11), т. к. система AutoCAD старается сохранить конечные точки дуги на старом месте.

Рис. 3.11. Редактирование эллипса и эллиптической дуги с помощью ручки

Процесс редактирования примитива SPLINE (сплайн) с помощью ручек похож на процесс редактирования полилинии, но при этом перемещение одной ручки оказывает влияние на форму и соседних участков сплайна (рис. 3.12).
Если с помощью ручек редактировать примитив TRACE (полоса), то она при этом фактически превращается в фигуру (рис. 3.13). Аналогично редактируется и примитив SOLID (фигура).

Рис. 3.12. Редактирование сплайна с помощью ручки

Рис. 3.13. Редактирование полосы с помощью ручки

Редактирование примитивов типа POINT (точка или узловая точка) с помощью ручек очевидно.
Удобным инструментом при редактировании с помощью ручек является контекстное меню. Если вы уже выбрали ручку для редактирования (т. е. на экране она изменила свой цвет на красный) и нажата правую кнопку мыши, то вызывается контекстное меню, изображенное на рис. 3.14.

Рис. 3.14. Контекстное меню при выбранной ручке

В данном меню возможны следующие действия:

  • Enter — имитация нажатия клавиши <Enter> (циклический перебор команд общего редактирования);
  • Move (Перенести) — перенос объектов (команда MOVE (ПЕРЕНЕСТИ));
  • Mirror (Зеркало) — симметрирование объектов (команда MIRROR (ЗЕРКАЛО));
  • Rotate (Повернуть) — поворот объектов (команда ROTATE (ПОВЕРНУТЬ));
  • Scale (Масштаб) — масштабирование объектов относительно базовой точки (команда SCALE (МАСШТАБ));
  • Stretch (Растянуть) — растягивание объектов (команда STRETCH (РАСТЯНУТЬ));
  • Base Point (Базовая точка) — задание другой базовой точки для выполнения команды STRETCH (РАСТЯНУТЬ);
  • Сору (Копировать) — копирование объектов (команда COPY (КОПИРОВАТЬ));
  • Reference (Ссылка) — выбор опции Reference (Опорный угол) для команды ROTATE (ПОВЕРНУТЬ) или Reference (Опорный отрезок) для команды SCALE (МАСШТАБ);
  • Undo (Отменить) — отмена действия последней команды (команда U (О));
  • Properties (Свойства) — управление свойствами объектов (команда PROPERTIES (OKHOCB));
  • Exit (Выход) — выход из режима редактирования с помощью ручек.

Пояснения к этому меню. Команды общего редактирования, как уже было сказано, рассмотрены в разд. 3.2. Об управлении свойствами объектов сказано в гл. 4.
Если вы еще не выбрали конкретную ручку для редактирования (ни одна ручка не изменила свой цвет на красный) и в этот момент нажата на правую кнопку мыши, то вызывается несколько другое контекстное меню, изображенное на рис. 3.15.

Рис. 3.15. Контекстное меню при отсутствии выбранных ручек

Структура этого меню похожа на структуру предыдущего контекстного меню (см. рис. 3.14) тем, что в нем есть группа пунктов, связанных с редактированием (Move (Перенести), Scale (Масштаб) и т. д.), но в нем появился пункт Erase (Стереть), который удаляет выбранные объекты.
Первым в контекстное меню всегда вставляется пункт повтора последней команды. Если выбрать полилинию, то в этом меню дополнительно возникает второй пункт — Polyline Edit (Редактировать полилинию). Его появление в меню связано с типом выделенного объекта, поскольку у сложных объектов есть особые команды редактирования (см. разд. 3.3—3.9).
Пункт Properties (Свойства) соответствует команде PROPERTIES (ОКНОСВ) и вызывает окно изменения свойств, рассмотренное в разд. 4.6.
Пункт Deselect All (Отменить выбор) позволяет отменить показ ручек, т. е. равносилен их сбросу нажатием клавиши <Esc>.
Остальные пункты обычно входят в контекстное меню, выводимое на экран при щелчке правой кнопкой мыши в тот момент, когда нет активных команд.
Пункт Quick Select (Быстрый выбор) соответствует команде QSELECT (БВЫБОР) и вызывает одноименное диалоговое окно Quick Select (Быстрый выбор) (рис. 3.16), позволяющее более тонко (по цвету, типу линии, слою и т. д.) выбрать объекты для включения в новый или текущий набор или удаления из набора выбора. Полученный в результате набор объектов будет участвовать в последующих командах редактирования.

Рис. 3.16. Диалоговое окно Quick Select

Структура диалогового окна Quick Select (Быстрый выбор) позволяет составить уравнение выбора объектов с такими операциями, как = Equals (= Равно), <> Not Equal (<> Не равно), > Greater than (> Больше), < Less than (< Меньше), Select All (Выбрать все). Нужная операция устанавливается в раскрывающемся списке Operator (Оператор). Кроме того, используются следующие поля:

  • Apply to (Применить) — указывает, к чему применять операцию (Entire drawing (К целому рисунку), Current selection (К текущему набору));
  • Object type (Тип объектов) — содержит перечень типов объектов (Line (Отрезок), Polyline (Полилиния) и т. п.) целого рисунка или текущего набора; Multiple (Несколько) означает, что отмечены примитивы разных типов;
  • Properties (Свойства) — содержит перечисление свойств, по которым можно осуществлять операцию выбора (Color (Цвет), Layer (Слой). Linetype (Тип линии), Linetype scale (Масштаб типа линии), Plot style (Стиль печати), Lineweight (Вес линии), Hyperlink (Гиперссылка)); если в текущем наборе уже есть какие-то объекты, то список может дополнительно содержать свойства объектов конкретных типов (Area (Площадь), Closed (Замкнуто), Thickness (Высота), Global width (Глобальная ширина) и т. д.); о свойствах объектов рассказано в следующей главе:
  • Value (Значение) — значение, по которому будут отбираться объекты; список значений зависит от типа выбранного свойства (например, для свойства Color (Цвет) это список цветов).

Область How to apply (Отобранные объекты) с помощью переключателей Include in new selection set (Включить в новый набор) и Exclude from new selection set (Исключить из нового набора) позволяет либо добавить отобранные данным уравнением объекты в новый набор, либо по заданному критерию исключить примитивы из создаваемого набора. Примитивы создаваемого набора присоединяются к текущему набору, если установить флажок Append to current selection set (Добавить к текущему набору).
Следующий пункт Find (Найти) контекстного меню (см. рис. 3.15) соответствует команде FIND (НАЙТИ) и вызывает диалоговое окно Find and Replace (Найти и заменить), которое позволяет найти (и, может быть, заменить) строку в текстовых примитивах, выносках и т. п.
Группа пунктов меню посвящена традиционной работе с буфером операционной системы Windows, в который можно временно помещать объекты, а затем вставлять их в новое место того же рисунка или в другой файл (напомню, что AutoCAD 2004 позволяет открыть одновременно несколько рисунков). Пункт Cut (Вырезать) соответствует команде CUTCLIP (ВБУ-ФЕР) — вырезает (удаляет) объект из чертежа и помещает его в буфер. Пункт Сору (Копировать), соответствующий команде COPYCLIP (КБУ-ФЕР) — копирует объект в буфер, но не удаляет его из рисунка. Пункт Сору with Base Point (Копировать с базовой точкой) тоже соответствует команде COPYCLIP (КБУФЕР), но позволяет еще уточнить и точку вставки (в предыдущем случае она обычно находится в левом нижнем углу изображения). Пункт Paste (Вставить) соответствует команде PASTECLIP (ВСТБУФЕР) для вставки объекта из буфера. Пункт Paste as Block (Вставить как блок) тоже вставляет объект из буфера, но он оформляется как вставка блока. Пункт Paste to Original Coordinates (Вставить с исходными координатами) позволяет перенести объект из буфера в новый файл, но в той же системе координат, что и в файле, из которого он был извлечен (системы координат изучаются в разд. 9.1). Подробно операции вставки файлов и блоков и влияние базовой точки рассмотрены в разд. 7.1.
В падающем меню Tools (Сервис) есть пункт Options (Настройка), используемый для настройки ряда функций системы AutoCAD. Его работа аналогична вызову команды OPTIONS (НАСТРОЙКА) из командной строки или выбору пункта Options (Настройка) из контекстного меню, вызываемого с помощью правой кнопки мыши в момент, когда указатель мыши располагается в зоне командных строк и нет выделенных объектов. Подробнее команда OPTIONS (НАСТРОЙКА) рассмотрена в гл. II, а в данный момент важно то, что она вызывает диалоговое окно Options (Настройка), имеющее целый ряд вкладок и в частности вкладку Selection (Выбор) (рис. 3.17).

Рис. 3.17. Диалоговое окно Options, вкладка Selection

В областях Pickbox Size (Размер прицела) и Grip Size (Размер ручек) можно изменить, соответственно, размер квадратного прицела, который показывает система в режиме выбора объектов, и размер ручек.
Область Grips (Ручки) вкладки посвящена настройке ручек. Во-первых, инструмент ручек можно вообще отключить, если сбросить флажок Enable grips (Включить ручки). Во-вторых, можно установить удобные для вас цвета невыбранных и выбранных ручек с помощью соответствующих раскрывающихся списков: Unselected grip color (Цвет невыбранных ручек), Selected grip color (Цвет выбранных ручек) и Hover grip color (Цвет затронутых ручек). Последний из этих списков — новшество, появившееся только в системе AutoCAD 2004 в связи с тем, что при прохождении курсора над ручкой она меняет свой цвет (по умолчанию на зеленый).
Ручки используются также для предварительного выбора объектов при таких операциях общего редактирования, как стирание, копирование, перенос и т. п. Если объекты предварительно не были выбраны, то тогда команды редактирования будут выдавать запрос на выбор объектов. Выбранные объекты образуют так называемый набор, т. е. подмножество объектов рисунка. Можно пополнять набор другими объектами, а можно исключать из него объекты (например, с помощью диалогового окна Quick Select (Быстрый выбор) (см. рис. 3.16)).
В разд. 2.5 мы уже рассмотрели вопрос выбора объектов тремя способами: непосредственным указанием, обычной рамкой и секущей рамкой. Если помечать объекты в ответ на запрос Command: (Команда:), то на самом деле это будет означать выполнение команды SELECT (ВЫБРАТЬ), формирующей набор объектов, с которыми будут выполнены какие-то действия, определяемые в процессе выполнения следующей команды. Сама команда SELECT (ВЫБРАТЬ) может быть введена также с помощью клавиатуры и будет выдавать повторяющийся запрос (запрос повторяется в цикле, пока не нажата клавиша <Enter>):
Select objects: (Выберите объекты:)
Существует много вариантов выбора. Чтобы получить подсказку с перечислением этих вариантов, необходимо на клавиатуре ввести знак "?" (нажав, разумеется, после него <Enter>). Подсказка выглядит так:
Expects a point or Window/Last/Crossing/BOX/ALL/ Fence/WPolygon/CPolygon/Group/Add/Remove/ Multiple/Previous/Undo/AUto/Single Select objects: (Требуется точка или Рамка/'Последний/Секрамка/БОКС/Все/Линия/ РМн-угол/СМн-угол/Труппа/ Добавить/'Исключить/Несколько/Текущий/ Отменить/Авто/Единственный Выберите объекты:)
Необходимо указать точку с помощью мыши или ввести одну из опций выбора. Если при указании точки с помощью мыши квадратная мишень (прицел) попадает на линию какого-то объекта, то он выбирается и подсвечивается. Если внутри мишени не оказывается линий объектов, то тогда указанная точка становится первой точкой рамки выбора и выдается следующий запрос:
Opposite corner: (Противоположный угол:)
Вторая точка, указываемая вами в этот момент, становится вторым углом рамки, причем рамка является простой (т. е. выбирает только объекты, попавшие внутрь рамки), если вторая точка рамки была указана правее первой, и секущей рамкой (т. е. выбирает и объекты, попавшие внутрь рамки, и объекты, пересеченные рамкой) — если вторая точка указана левее первой. Разберем опции выбора:

  • Window (Рамка) — позволяет две точки, указываемые далее, считать углами обычной рамки, независимо от их расположения;
  • Last (Последний) — выбирает последний построенный объект из видимых на экране;
  • Crossing (Секрамка) — позволяет две точки, указываемые далее, считать углами секущей рамки, независимо от их расположения;
  • BOX (БОКС) — переходит в режим указания рамки, которая становится обычной или секущей в зависимости от расположения углов рамки;
  • ALL (Все) — выбирает все незамороженные объекты рисунка (о замораживании слоев см. разд. 4.3)',
  • Fence (Линия) — позволяет построить разомкнутую (открытую) полилинию и в набор включаются пересеченные ею объекты;
  • WPolygon (РМн-угол) — строит аналог рамки в форме замкнутого многоугольника, и выбираются только те объекты, которые попадают внутрь него;
  • CPolygon (СМн-угол) — является аналогом секущей рамки, но рамка имеет форму многоугольника;
  • Group (Группа) — выбирает группу (набор с именем, сформированный ранее по команде GROUP (ГРУППА));
  • Add (Добавить) — позволяет перейти в режим добавления объектов в набор (завершает режим исключения объектов из набора);
  • Remove (Исключить) — переходит в режим исключения объектов из набора (завершает режим добавления объектов в набор);
  • Multiple (Несколько) — не подсвечивает объекты при их выборе, ускоряя тем самым работу;
  • Previous (Текущий) — позволяет взять в качестве набора набор, сформированный системой AutoCAD в предыдущий раз;
  • Undo (Отменить) — отменяет последнюю операцию добавления объекта в набор или его исключения;
  • AUto (Авто) — переходит в режим автоматического выбора. При этом если в прицел в точке указания попадает объект, происходит его выбор. В противном случае введенная точка становится первым утлом обычной или секущей рамки, т. е. включается режим BOX (БОКС);
  • Single (Единственный) — позволяет перейти в режим выбора единственного объекта, попавшего в мишень устройства указания. После обнаружения первого объекта операция выбора прекращается.

Режимы AUto (Авто) и Add (Добавить) действуют по умолчанию.
Если сформированный в результате операций выбора набор примитивов необходим в дальнейшей работе с рисунком, то такой набор следует оформить в виде группы, которая сохраняется внутри файла рисунка и доступна в следующих сеансах редактирования. Для создания групп используется команда GROUP (ГРУППА), которую следует вводить с клавиатуры.
Команда GROUP (ГРУППА) открывает диалоговое окно Object Grouping (Группы объектов) (рис. 3.18).

Рис. 3.18. Диалоговое окно Object Grouping

В верхней части окна находится список уже существующих в файле чертежа групп (на рис. 3.18 — это группа с именем G1). В списке два столбца: Group Name (Имя группы) и Selectable (Выбираемая). В первом из них располагаются имена групп (до 31 символа длиной, в именах могут использоваться буквы и цифры, а также символы $, - (дефис) и _ (подчеркивание); пробелы не допускаются), а во втором — параметр выбираемое™, который может принимать только два значения: Yes (Да) или No (Нет). В списке групп имена располагаются по алфавиту.
Группа называется выбираемой, если при выборе любого элемента группы система AutoCAD подсвечивает сразу все остальные элементы группы, находящиеся на размороженных и неблокированных слоях.
В первый раз, когда вы открываете окно Object Grouping (Группы объектов), список групп еще пуст. Для того чтобы создать группу, нужно в области Group Identification (Идентификация группы) ввести имя в поле Group Name (Имя группы) и заполнить поле Description (Пояснение). Затем в области Create Group (Создание группы) надо установить или сбросить флажок Selectable (Выбираемая) и щелкнуть по кнопке New (Новая). Система AutoCAD временно закроет окно Object Grouping (Группы объектов) и выдаст запрос на указание объектов, которые будут включены в создаваемую группу. Окончанием выбора объектов будет нажатие клавиши <Enter>.
Как только группа будет создана, ее имя сразу же появится в общем списке групп в верхней части окна.
Можно создавать неименованные группы. Для этого перед щелчком по кнопке New (Новая) необходимо установить флажок Unnamed (Без имени) в области Create Group (Создание группы). Если пользователь создает группы без имени, имена таким группам система присваивает сама (*А1, *А2, *АЗ и т. д.). Для того чтобы в списке Group Name (Имя группы) присутствовали имена неименованных групп, нужно в области Group Identification (Идентификация группы) установить флажок Include Unnamed (Включая неименованные).
В области Group Identification (Идентификация группы) расположены еще две вспомогательные кнопки. Кнопка Find Name (Найти имя) позволяет найти имена всех групп, которым принадлежит примитив. Система временно закрывает диалоговое окно Object Grouping (Группы объектов) и просит указать один объект:
Pick a member of group: (Укажите элемент группы:)
После того как вы указали объект, система открывает окно Group Member List (Список групп для объекта) (рис. 3.19), в котором приводится список всех групп, которым принадлежит выбранный объект.

Рис. 3.19. Окно Group Member List

Кнопка Highlight (Подсветить) диалогового окна Object Grouping (Группы объектов) (см. рис. 3.18) позволяет подсветить все примитивы, входящие в группу, имя которой отмечено в общем списке групп.
Область Change Group (Изменение группы) доступна, если в общем списке отмечено имя какой-либо группы. Кнопки этого раздела позволяют изменить любое свойство группы:

  • Remove (Исключить) — исключение объектов из выбранной группы;
  • Add (Добавить) — добавление объектов в выбранную группу;
  • Rename (Переименовать) — замена имени группы на текущее содержимое поля Group Name (Имя группы) области Group Identification (Идентификация группы);
  • Re-Order (Порядок) — изменение порядка следования объектов внутри группы;
  • Description (Пояснение) — замена пояснения к группе на текущее содержимое поля Description (Пояснение) в области Group Identification (Идентификация группы);
  • Explode (Расчленить) — удаление группы из списка групп (сами объекты, входившие в группу, из рисунка не удаляются);
  • Selectable (Выбираемая) — изменение свойства выбираемое™ группы.

Кнопка Re-Order (Порядок) вызывает диалоговое окно Order Group (Порядок объектов в группе) (рис. 3.20), в котором можно изменить порядковые номера объектов выбранной группы.
По умолчанию номера объектов начинаются с 0 и соответствуют порядку их выбора при включении в группу. При особом использовании групп последовательность объектов внутри группы может иметь значение (например, в случае маршрута движения инструмента).
С помощью кнопок окна, приведенного на рис. 3.20, можно либо изменить порядковые номера отдельных элементов (как по одному, так и для нескольких), либо обратить порядок следования всех элементов.

Рис. 3.20. Окно Order Group

Для того чтобы узнать порядок следования объектов в группе, нужно щелкнуть по кнопке Highlight (Подсветить). Временно закроется окно Order Group (Порядок объектов в группе), и на экране появится окно Object Grouping (Группа объектов). В этот момент на рисунке будет подсвечен только объект с номером 0. Щелчок по кнопке Next (Следующий) погасит объект номер 0 и вызовет подсветку только объекта номер 1. Информация о номере подсвеченного примитива выводится в нижнюю строку окна (рис. 3.21).

Рис. 3.21. Окно Object Grouping

С помощью кнопок Next (Следующий) и Previous (Предыдущий) можно пройти по всем примитивам, входящим в группу, и определить их порядковые номера. Щелчок по кнопке ОК снова вернет вас в окно Order Group (Порядок объектов в группе).
Кнопка Reverse Order (Обратный порядок) окна Order Group (Порядок объектов в группе) изменяет порядок следования объектов на противоположный.
Для того чтобы какой-либо объект переместить на новое место, необходимо указать его номер в поле Remove from position (Взять из позиции), а в поле Enter new position number for the object (Переместить в позицию) — новый номер.
Если в рисунке созданы группы, то на запрос команды SELECT (ВЫБРАТЬ) можно указать объекты сразу всей группы, выбирая опцию Group (Группа) и вводя в ответ на следующий запрос имя этой группы.


3.2. Команды общего редактирования

Кнопки команд общего редактирования объектов (копирование, перенос, удлинение и т. п.) расположены в панели Modify (Редактирование) (рис. 3.22).

Рис. 3.22. Панель Modify

Каждую из этих команд, рассмотренных в данном разделе, можно ввести по имени с клавиатуры, а также вызвать с помощью падающего меню Modify |Редакт). Многие команды данной группы работают либо с набором предварительно выбранных объектов, либо при отсутствии такого набора выдают запрос Select objects (Выберите объекты)- Остальные команды запрашивают редактируемые объекты в соответствующий момент.
Кнопка [image] , соответствующая команде ERASE (СТЕРЕТЬ), стирает с экрана выбранные объекты и удаляет их из рисунка.
Результат действия этой команды, как и любой другой операции системы AutoCAD, может быть отменен либо с помощью кнопки [image] панели Standard (Стандартная), либо с помощью команд U (О) и UNDO (ОТМЕНИТЬ). Щелчок по расположенной рядом кнопке [image] позволяет раскрыть список последних операций и отметить в нем те, которые необходимо отменить. Кнопка [image] панели Standard (Стандартная) оставляет возможность восстановить те действия, которые были отменены, причем у нее тоже можно раскрыть список доступных для восстановления операций. Аналогичную функцию выполняет новая команда MREDO (русский аналог на момент написания не известен).
Кнопка [image] команды COPY (КОПИРОВАТЬ) копирует выбранные объекты параллельно вектору, который задается начальной и конечной точками. Если при запуске команды выбранных объектов нет, то задается вопрос о выборе объектов. После выбора объектов нужно завершить выбор либо нажатием клавиши <Enter>, либо щелчком правой кнопкой мыши.
Первый запрос команды после того, как объекты для операции копирования выбраны:
Specify base point or displacement, or [Multiple]: (Базовая точка или перемещение, или {Несколько!:)
Укажите первую точку. Это может быть любая точка чертежа, но удобнее указать одну из характерных точек копируемого объекта (например, начальную). В целом результат операции копирования зависит не от первой или второй точки, которую нужно будет указать далее, а от взаимного их расположения, ибо результирующий сдвиг копии объекта от оригинала по оси X вычисляется как разность абсцисс между второй и первой точками вектора копирования, а сдвиг по оси Y— как разность ординат. Следующий запрос:
Specify second point of displacement or <use first point as displacement: (Вторая точка перемещения или <считатъ перемещением первую точку>:)
Укажите вторую точку. В результате образуется копия выбранных объектов, которая будет смещена относительно оригинала на заданный вектор (рис. 3.23).

Рис. 3.23. Копирование объектов

Если вместо указания второй точки перемещения нажать клавишу <Enter>, то координаты введенной первой точки становятся координатами перемещения. Этим приемом можно пользоваться для случаев, когда сдвиг объекта заранее известен. Например, если какой-то объект надо скопировать и копия относительно оригинала должна быть смещена на 145 мм по оси X и на —3,75 мм по оси У, то тогда вам в ответ на запрос первой точки надо ввести 145,-3.75. Далее в ответ на запрос второй точки следует нажать клавишу <Enter>.
Опция Multiple (Несколько) предназначена для многократного копирования выбранных объектов. В случае ее использования система AutoCAD один раз запрашивает начальную точку и циклически повторяет запрос о конечной точке вектора перемещения (векторы копирования имеют одну и ту же первую точку, но различные вторые точки). Окончание работы команды — нажатие клавиши <Enter> или щелчок правой кнопкой мыши.
Кнопка [image] команды MIRROR (ЗЕРКАЛО) позволяет зеркально отразить (симметрировать) выбранные объекты относительно оси, которая определяется двумя точками.
После выбора объектов система AutoCAD запрашивает:
Specify first point of mirror line: (Первая точка оси отражения:)
Затем, после вашего ответа, запрашивается вторая точка, а проходящая через обе точки прямая и будет осью отражения (симметрии):
Specify second point of mirror line: (Вторая точка оси отражения:)
Укажите вторую точку (рис. 3.24).
После этого остается только ответить, что сделать с исходными объектами (удалить или нет):
Delete source objects? [Yes/No] <N>: (Удалить исходные объекты?[Да/Нет] <Н>:)
Если вы не хотите удалять объекты-оригиналы, то ответьте N (Н) или нажмите клавишу <Enter>. В противном случае — ответьте Y (Д). Команда MIRROR (ЗЕРКАЛО) будет выполнена.

Замечание Если среди симметрируемых объектов есть тексты, то в некоторых условиях они тоже отражаются относительно оси, что приводит к их нечитаемости. Для того чтобы тексты при отражении не переворачивались, нужно установить для системной переменной MIRRTEXT значение 0 (вместо другого возможного значения 1). Тогда точки привязки текста симметрируются, а сам текст останется повернутым в ту же сторону, что и исходный. О работе с системными переменными см. разд. 11.1.

Рис. 3.24. Симметрирование объектов

Следующая кнопка [image] в панели Draw (Рисование) соответствует команде OFFSET (ПОДОБИЕ). Команду можно также вызвать из падающего меню Modify (Редакт) с помощью пункта Offset (Подобие).
Команда предназначена для рисования подобных (параллельных) линий к линейным объектам (отрезкам, лучам, прямым, полилиниям, дугам, окружностям, эллипсам и сплайнам). Возможны два варианта построения параллельной линии: по расстоянию (смещению) от оригинала и через заданную точку. Первый запрос команды:
Specify offset distance or [Through] <Through>: (Величина смещения или [Точка] < Точка >:)
В угловых скобках стоит значение по умолчанию (от предыдущего выполнения команды OFFSET (ПОДОБИЕ)), которое является либо положительным числом, либо именем опции Through (Точка). Вначате рассмотрим вариант, когда вы задаете величину смещения, что может быть сделано либо вводом числа с клавиатуры, либо указанием двух точек (AutoCAD измерит расстояние между точками и возьмет его в качестве величины смещения). Следующий запрос:
Select object to offset or <exit>: (Выберите объект для создания подобных или <выход>:)
Укажите только один объект, к которому нужно построить параллельную линию. Затем AutoCAD запросит уточнить, в какую сторону от объекта нужно строить параллельную линию (почти всегда к любому объекту существуют две параллельные линии):
Specify point on side to offset: (Укажите точку, определяющую сторону смещения:)
Вам достаточно указать любую точку на экране, которая находится по ту же сторону от объекта, что и будущая параллельная линия (на рис. 3.25 сначала был только нижний объект, затем к нему чуть выше была построена параллельная линия).

Рис. 3.25. Построение подобных объектов

Далее в цикле повторяется запрос о выборе объектов для создания подобных с тем же смещением. По окончании построения всех подобных объектов нужно нажать клавишу <Enter>.
Если в начале работы с командой OFFSET (ПОДОБИЕ) вы в ответ на запрос Specify offset distance or [Through]: (Величина смещения или [Точка]:) выбрали опцию Т (Т), то AutoCAD сначала запрашивает:
Select object to offset or <exit>: (Выберите объект для создания подобных или <выход>:)
И после указания объекта запрашивает точку: Specify through point: (Через точку:)
Вы указываете точку, через которую система проводит линию, параллельную выбранному объекту. Величина получающегося смешения рассчитывается автоматически. Далее снова выдается запрос о выборе объектов для создания подобных. По окончании построений в режиме Through (Точка) нужно нажать на клавишу <Enter>.
Кнопка [image] команды ARRAY (МАССИВ) предназначена для создания группы копий одних и тех же объектов, причем копии располагаются по определенному закону в гнездах прямоугольного или кругового массива. Команду, кроме того, можно также вызвать из падающего меню Modify (Pe-дакт) с помощью пункта Array (Массив). В любом случае команда вызывает диалоговое окно Array (Массив), которое в левой части имеет изменяемую область. Содержимое этой области зависит от состояния двух переключателей Rectangular Array (Прямоугольный массив) и Polar Array (Круговой массив), расположенных в верхней части окна (рис. 3.26).

Рис. 3.26. Диалоговое окно Array с включенным переключателем Rectangular Array

На рис. 3.26 показан вариант диалогового окна Array (Массив) для прямоугольного массива. Слайд в правой части иллюстрирует работу команды ARRAY (МАССИВ) с теми значениями, которые заданы в текущий момент для параметров Rows (Рядов), Columns (Столбцов), Row offset (Между рядами), Column offset (Между колонками) и Angle of array (Угол поворота) и определяют размеры и положение той прямоугольной матрицы, в гнездах которой будут расставлены копии выбранных объектов (матрица может иметь наклон относительно оси X). Если размножаемые объекты еще не выбраны (или выбраны не все), то можно сделать выбор, щелкнув по кнопке [image] расположенной в правой верхней части диалогового окна. Окно при этом временно свернется и появится снова, когда вы завершите выбор объектов.
Расстояние между рядами и столбцами (отстояние). а также угол наклона массива можно задать числами или мышью. Для задания мышью нужно щелкнуть по кнопке [image] , расположенной напротив соответствующего поля, после чего на освободившемся от окна экране указать две точки, которые и зададут значение параметра. Если щелкнуть по большой кнопке [image] , то затем на освободившемся экране указанием двух точек можно задать сразу же отстояния рядов и отстояния столбцов (будут использованы разность между абсциссами точек и разность между ординатами).
Если отстояния положительны, то объекты размножаются вправо по оси X и вверх по оси У. Отрицательные значения меняют направление размножения по соответствующей оси (если оба числа отрицательны, то и по обеим осям).
Кнопка Preview (Просмотр), расположенная в правом нижнем углу диалогового окна, дает возможность оценить правильность задания параметров команды ARRAY (МАССИВ), прежде чем выполнить ее. На рис. 3.27 показано окно Array (Массив) режима просмотра (в качестве объектов размножения выбран прямоугольник и находящиеся внутри него отрезок и заливка). Если вы согласны с результатом, то можете щелкнуть по кнопке Accept (Принять), если не согласны — то по кнопке Modify (Изменить) и вернуться в диалоговое окно, изображенное на рис. 3.26.
Другой вариант команды — размножение объектов по дуге окружности, который работает при включении переключателя Polar Array (Круговой массив). На рис. 3.28 показано диалоговое окно Array (Массив) в режиме кругового массива.

Рис. 3.27. Предварительный просмотр результата работы команды ARRAY в режиме прямоугольного массива

В этом окне нужно задать центр кругового массива (поле Center point (Точка центра)) и в раскрывающемся списке Method (Способ построения) выбрать способ заполнения: Total number of items & Angle to fill (Число элементов и угол заполнения), Total number & Angle between items (Число элементов и угол между элементами) или Angle to fill & Angle between items (Угол заполнения и угол между элементами). В зависимости от выбранного способа, нужно будет заполнить два из трех следующих параметров: Total number of items (Число элементов), Angle to fill (Угол заполнения) и Angle between items (Угол между элементами). Положительные значения углов означают движение против часовой стрелки, отрицательные — по часовой.
В зависимости от состояния флажка Rotate items as copied (Поворачивать элементы массива), размножаемые объекты будут поворачиваться параллельно касательным к дуге или нет. Если в области Object base point (Базовая точка объекта) установлен флажок Set to object's default (Как установлено в объекте), то дуга, относительно которой расставляются новые объекты, будет проходить через некоторую точку последнего выбранного примитива (эта точка определяется системой по своему алгоритму — как правило, это первая или центральная точка). Если данный флажок сбросить, то можно в поле Base point (Базовая точка) задать другую базовую точку.

Рис. 3.28. Диалоговое окно Array с включенным переключателем Polar Array

Если щелкнуть по кнопке Less (Меньше), то размер окна, приведенного на рис. 3.28, уменьшится за счет исчезновения области Object base point (Базовая точка объекта), щелчок по той же кнопке раскроет скрытую область при этом надпись на кнопке будет More (Больше)).
На рис. 3.29 приведен результат работы команды ARRAY (МАССИВ) в режиме кругового массива.
Кнопка [image] соответствует команде MOVE (ПЕРЕНЕСТИ), которая позволяет переместить выбранные объекты параллельно вектору, заданному двумя точками. Команду можно также вызвать из падающего меню Modify (Pe-дакт) с помощью пункта Move (Перенести). Запросы и действия этой команды очень похожи на запросы и действия команды COPY (КОПИРОВАТЬ). Первый запрос после выбора объектов:
Specify base point or displacement: (Базовая точка или перемещение:)
Задайте первую точку. Следующий вопрос:
Specify second point of displacement or <use first point as displacement: (Вторая точка перемещения или < считатъ перемещением первую точку >:)

Рис. 3.29. Копирование объектов с помощью кругового массива

Укажите вторую точку вектора перемещения (рис. 3.30). Если нажать вместо этого на клавишу <Enter>, то координаты первой точки рассматриваются как координаты перемещения.
Кнопка [image] команды ROTATE (ПОВЕРНУТЬ) дает возможность повернуть выбранные объекты относительно базовой точки на заданный угол. Команду можно также вызвать из падающего меню Modify (Редакт) с помощью пункта Rotate (Повернуть).
Сначала команда информирует о режимах измерения углов:
Current positive angle in UCS: ANGDIR=counterclockwise ANGBASE=0
(Текущие установки отсчета углов в ПСК: ANGDIR=против ч/с ANGBASE=0)

Рис. 3.30. Перенос объектов

Первый запрос после выбора объектов:
Specify base point: (Базовая точка:)
Укажите базовую точку, относительно которой будет выполняться поворот. Далее:
Specify rotation angle or [Reference]: (Угол поворота или {Опорный угол]:)
Укажите угол вводом с клавиатуры или с помощью мыши (рис. 3.31).
Вместо ввода угла возможно указание угла поворота с помощью опции Reference (Опорный угол). Например, пусть треугольник с находящимся внутри него отрезком (рис. 3.32) нужно повернуть относительно точки 1 на такой угол, чтобы правая сторона треугольника, отмеченная точками 1 и 2, стала строго горизонтальной.
Задачу можно решить, воспользовавшись вышеупомянутой опцией и не вычисляя начального угла наклона.

Рис. 3.31. Поворот объектов

Вызовите команду ROTATE (ПОВЕРНУТЬ) любым из известных вам способов. На запрос Select objects: (Выберите объекты:) отметьте мышью треугольник и требуемый отрезок и завершите выбор объектов нажатием на клавишу <Enter>. На запрос Base point: (Базовая точка:) с помощью объектной привязки укажите точку 1. Затем в ответ на запрос Specify rotation angle or [Reference]: (Угол поворота или [Опорный угол]:) выберите опцию R (О). Последует запрос:
Specify the reference angle <0>: (Опорный угол <0>:)
Выберем способ ввода угла с помощью двух точек. Укажите точку 1 (с помощью объектной привязки) и в ответ на запрос Specify the second point: (Вторая точка:) укажите точку 2. Начальный угол тем самым определен. Далее AutoCAD запрашивает:
Specify the new angle: (Новый угол:)
В качестве нового угла нужно ввести с клавиатуры 0. Треугольник повернется до горизонтального положения. Поставленная задача решена.

Рис. 3.32. Поворот объектов с помощью опции Reference

Кнопка [image] . соответствующая команде SCALE (МАСШТАБ), позволяет масштабировать (т. е. увеличивать или уменьшать) выбранные объекты относительно базовой точки. Команду можно также вызвать из падающего меню Modify (Редакт) с помощью пункта Scale (Масштаб).
На рис. 3.33 приведен пример, когда прямоугольник и вписанный в него круг масштабируются относительно точки левого нижнего угла прямоугольника.
Команда SCALE (МАСШТАБ) после выбора объектов запрашивает: Specify base point: (Базовая точка:)
Укажите базовую точку (например, точку левого нижнего угла прямоугольника). Далее:
Specify scale factor or [Reference]: (Масштаб или /Опорный отрезок]:)
Для увеличения объектов нужно ввести число больше 1, для уменьшения — положительное число меньше 1. Если масштабирование нужно выполнить в дробное количество раз (например, 3/7), то можно воспользоваться опцией Reference (Опорный отрезок). В ответ на выбор этой опции система AutoCAD выдает запрос:
Specify reference length <1>: (Длина опорного отрезка <!>:)

Рис. 3.33. Масштабирование объектов

Введите число 7. Specify new length: (Новая длина:)
Введите число 3, и система выполнит требуемое преобразование (коэффициент преобразования будет вычислен как частное от деления второй длины на первую). Обе длины можно показывать и с помощью точек (сначала две точки, между которыми будет измерена длина опорного отрезка, а затем указать еще одну точку, до которой будет измерена длина от начала опорного отрезка).
Команда STRETCH (РАСТЯНУТЬ), которой соответствует кнопка [image] панели Modify (Редактирование) предназначена для изменения формы объекта методом растяжения. Команду можно также вызвать из падающего меню Modify (Редакт) с помощью пункта Stretch (Растянуть).
Команда обычно выполняется над полилинией (хотя она может растягивать и дуги, эллиптические дуги, сплайны и другие линейные примитивы), когда надо переместить несколько ее вершин параллельно вектору, задаваемому двумя точками, а остальные вершины полилинии надо оставить на месте и соответствующим образом преобразовать геометрию объекта. Команда STRETCH (РАСТЯНУТЬ) не применяется для набора предварительно выбранных объектов, поскольку в данном случае важно часть полилинии выбрать с помощью секущей рамки или секущего многоугольника, поэтому первый запрос выглядит так:
Select objects to stretch by crossing-window or crossing-polygon... Select objects: (Выберите растягиваемые объекты секущей рамкой или секущим многоугольником...Выберите объекты:)
На рис. 3.34 показана полилиния в форме прямоугольника, у которого нужно переместить две правые вершины.

Рис. 3.34. Выбор растягиваемого объекта секущей рамкой

Выберите секущей рамкой прямоугольник, но таким образом, чтобы внутри рамки оказались только правые вершины полилинии (те из читателей, кто забыл способы выбора объектов, могут вернуться к разд. 3.1). Закончите выбор объектов нажатием клавиши <Enter>. Затем следует запрос о первой точке:
Specify base point or displacement: (Базовая точка или перемещение:)
Укажите первую точку: Specify second point of displacement or <use first point as displacement>: (Вторая точка перемещения или <считать перемещением первую точку >:)
Укажите вторую точку вектора перемещения (рис. 3.35).

Рис. 3.35. Указание вектора перемещения в команде STRETCH

В результате выполнения команды вершины полилинии, не попавшие в рамку, остались на старых местах, а вершины, выбранные секущей рамкой, переместились параллельно заданному вектору.
Команда LENGTHEN (УВЕЛИЧИТЬ), которой соответствует пункт Lengthen (Увеличить) падающего меню Modify (Редакт), увеличивает отрезки, дуги и конечные сегменты полилиний на заданную величину (в единицах длины или угловых единицах).
Первый запрос команды:
Select an object or [DElta/Percent/Total/DYnamic]: (Выберите объект или /ДЕлыпа/проЦент/Всего/ДИнамика]:)
Если в этот момент выбрать объект, то система AutoCAD выдает его текущие параметры, которые можно использовать для увеличения (для отрезка и сегмента полилинии — длину, а для дуги — длину и центральный угол). Опции команды:

  • DElta (ДЕльта) — указывается величина удлинения (числом);
  • Percent (проЦент) — указывается новая длина в процентах от старой длины:
  • Total (Всего) — указывается новая полная длина в линейных или угловых единицах;
  • DYnamic (ДИнамика) — величина удлинения указывается динамически, т. е. заданием одной точки с помощью мыши, а расстояние до следующей указанной точки становится величиной удлинения.

В случае опции DElta (ДЕльта) система AutoCAD запрашивает:
Enter delta length or [Angle] <0.0000>: Приращение длины или [Угол/ <0.0000>:)
На это вы задаете величину приращения в миллиметрах (положительную случае увеличения длины и отрицательную в случае уменьшения длины), система AutoCAD выдает следующий запрос:
Select an object to change or [Undo]: Выберите объект для изменения или [Отменить]:)
Опция U (О) отменяет предварительную установку способа увеличения и возврашает к более раннему запросу. Если вы указываете объект, то он изменяется (увеличивается или уменьшается, в зависимости от знака величины удлинения), причем с того конца, ближе к которому вы указали изменяемый объект. Далее циклически повторяется запрос о выборе объекта для вменения, пока вы не нажмете клавишу <Enter>.
Если вместо приращения длины вы выберете опцию Angle (Угол), то система запросит приращение угла (в угловых скобках при этом может выводить и предыдущее приращение):
Enter delta angle: Введите приращение угла:)
Введите величину приращения (она может быть и отрицательной), и в ответ на следующий запрос выберите изменяемый объект.
Аналогично работают остальные опции команды LENGTHEN (УВЕЛИЧИТЬ). На рис. 3.36 показан пример увеличения дуги с помощью опции DYnamic (ДИнамика). Начало "резиновой нити" показывает конец дуги перед изменением. Конец резиновой нити (с крестом) определяет новый центральный угол. Дуга строится системой AutoCAD с новой величиной, которая закрепляется фиксацией новой точки с помощью левой кнопки мыши.

Рис. 3.36. Увеличение дуги с помощью опции DYnamic команды LENGTHEN

Кнопка [image] соответствует команде TRIM (ОБРЕЗАТЬ), позволяющей обрезать объект (объекты) с помощью пересекающих его (их) других объектов или удлинить его (их) до нужного объекта. Команду можно также вызвать из падающего меню Modify (Редакт) с помощью пункта Trim (Обрезать).
Первый запрос команды:
Current settings: Projection = UCS Edge = None Select cutting edges ... Select objects:
(Текущие установки: Проекция = ПС К Кромки = Без продолжения Выберите режущие кромки ... Выберите объекты:)
В первой строке этого сообщения показаны текущие установки команды, которые при необходимости могут быть изменены. Разберем механизм действия команды на примере рис. 3.37, на котором в левой части экрана показано положение объектов до операции обрезки, а справа — после нее.

Рис. 3.37. Обрезка объектов

Порядок указания объектов в данном случае очень важен. Сначала нужно указать "режущие кромки" — в нашем примере это один отрезок. Окончание выбора режущих объектов — это нажатие клавиши <Enter>. Следующий запрос:
Select object to trim or shift-select to extend or [Project/Edge/Undo]:
(Выберите обрезаемый объект или с клавишей <Shift> выберите удлиняемый объект или [Проекция/Кромка/Отменить]:)
В ответ на этот запрос необходимо выбрать объекты, которые будут обрезаны (в данном примере — упомянутым отрезком), но при этом объекты следует указать именно в той части, которая должна удалиться в результате обрезки. На рис. 3.37 обрезаемые объекты помечаются в точках, которые для наглядности оформлены узловыми точками.
Вместо указания обрезаемых объектов можно изменить установки или отменить предыдущее действие (опция Undo (Отменить)). При выборе опции Project (Проекция) AutoCAD предлагает:
Enter a projection option [None/Ucs/View] <Ucs>: (Задайте опцию проецирования [Нет/Пск/Вид] <Пск>:)
Предлагаемые для выбора опции означают, что обрезка может производиться не только режущими кромками, но и их проекциями, а способ проецирования может быть установлен либо по текущей системе координат (опция Ucs (Пек)), либо по текущему виду (опция View (Вид)). Эти опции будут понятны после разбора операций трехмерных построений. Опция None (Нет) отключает возможность обрезки в проекции (т. е. режущие и обрезаемые объекты должны будут находиться в одной плоскости).
При выборе опции Edge (Кромка) будет выведен запрос:
Enter an implied edge extension mode [Extend/No extend] <No extend >:
(Режим продолжения кромки до воображаемого пересечения [С продолжением/ Без продолжения] <Без продолжения>:)
Здесь определяется, участвуют ли в операции обрезки продолжения режущих кромок. При выборе режима Extend (С продолжением) обрезка выполняется не только выбранными режущими кромками, но и их продолжениями. В случае режима No extend (Без продолжения) обрезка продолжениями режущих кромок не выполняется.
Одни и те же линии при необходимости могут входить как в набор режущих кромок, так и в набор обрезаемых объектов. Например, если два пересекающихся отрезка должны быть взаимно обрезаны, то каждый из них должен быть включен в оба вышеупомянутых набора. Тогда система выполнит взаимную обрезку за одну команду TRIM (ОБРЕЗАТЬ).
При обрезке может происходить преобразование типов примитивов. Например, окружность может стать дугой, луч — отрезком, прямая — лучом или отрезком.
В последних версиях системы команда TRIM (ОБРЕЗАТЬ) фактически объединена с командой EXTEND (УДЛИНИТЬ), рассматриваемой ниже. Это выражается в том, что при ответе на запрос Select object to trim or shift-select to extend or [Project/Edge/Undo]: (Выберите обрезаемый объект или с клавишей <Shift> выберите удлиняемый объект или [Проекция/Кромка/Отменить]:) вместо обычного выбора обрезаемых объектов можно нажать клавишу <Shift> и, не отпуская, отметить мышью объекты. Однако отмеченные таким образом объекты будут не обрезаться, а удлиняться до секущей кромки. В системе AutoCAD 2000 и более ранних версиях этого не было.
Команда EXTEND (УДЛИНИТЬ), которой соответствует кнопка [image] позволяет выбрать набор "граничных кромок", а затем указать объекты, которые удлиняются до этих кромок. Команду можно также вызвать из падающего меню Modify (Редакт) с помощью пункта Extend (Удлинить). Последовательность указания объектов очень важна, так как системе нужно различать граничные и удлиняемые объекты.
Первое сообщение содержит информацию о действующих режимах (режимы общие с командой TRIM (ОБРЕЗАТЬ)) и запрос граничных кромок, до которых нужно выполнить операцию удлинения:
Current settings: Projection = UCS Edge = None Select boundary edges... Select objects:
(Текущие установки: Проекция = ПСК Кромки = Без продолжения Выберите граничные кромки... Выберите объекты:)
Укажите объекты, которые должны образовать набор граничных кромок, и завершите их выбор нажатием клавиши <Enter>. Далее:
Select object to extend or shift-select to trim or [Project/Edge/Undo]:
(Выберите удлиняемый объект или с клавишей <Shift> выберите обрезаемый объект или [Проекция/Кромка/Отменить]:)
Нужно указать объекты, которые будут удлинены до набора граничных кромок, причем точка указания каждого удлиняемого объекта должна быть ближе к тому концу, в сторону которого будет выполнено удлинение. На рис. 3.38 пунктиром показан эллипс, который является граничной кромкой, а левый удлиняемый отрезок указан в верхней своей части.
Если бы отрезок был помечен в левой части, то система AutoCAD выдала бы сообщение:
No edge in that direction. (В данном направлении кромки нет.)
Команда EXTEND (УДЛИНИТЬ) интегрирована с ранее рассмотренной командой TRIM (ОБРЕЗАТЬ), поэтому если при выборе удлиняемых объектов нажата клавиша <Shift>, то объекты, выбранные в команде EXTEND (УДЛИНИТЬ), не удлиняются, а обрезаются.
Команда BREAK (РАЗОРВАТЬ) предназначена для разрыва объекта в двух указываемых точках. Команду можно вызвать из падающего меню Modify (Редакт) с помощью пункта Break (Разорвать). Кроме того, ей в панели инструментов Modify (Редактирование) соответствуют две кнопки. Кнопка [image] вызывает команду BREAK (РАЗОРВАТЬ) в самом общем варианте. Этот вариант мы сначала и рассмотрим.

Рис. 3.38. Удлинение объекта

Первый запрос команды: Select object: (Выберите объект:)
Укажите объект, причем по умолчанию точка указания будет и первой точкой разрыва. Далее:
Specify second break point or [First point]: (Вторая тонка разрыва или {Первая точка]:)
Укажите вторую точку разрыва. Результат операции виден на примере, приведенном на рис. 3.39 (в левой части — до разрыва, в правой — после разрыва; точки демонстрируют последовательность указания).
Возможен случай, когда точка указания объекта не должна быть точкой разрыва (например, если в точке разрыва есть пересечение с другой линией и указание этой точки может привести к неправильному выбору разрываемого объекта). Тогда в ответ на запрос второй точки разрыва следует воспользоваться опцией First point (Первая точка), что позволяет заново указать первую точку разрыва (не меняя выбора объекта):
Specify first break point: (Первая точка разрыва:)

Рис. 3.39. Разрыв объекта

Укажите первую точку. Specify second break point: (Вторая точка разрыва:)
Нужно указать вторую точку, после чего команда будет выполнена. Если вы вместо указания второй точки введете на клавиатуре символ @, то это будет означать, что координаты второй точки разрыва совпадают с координатами первой. Таким образом видимого разрыва на экране не будет, но отмеченный вами объект разделится на два (этот вариант неприменим для целой окружности).
Кнопка [image] Break at Point (Разорвать в точке) панели инструментов Modify (Редактирование) позволяет воспользоваться вариантом команды BREAK (РАЗОРВАТЬ) в том случае, когда первая и вторая точки разрыва совпадают, но точка указания объекта не является точкой разрыва.
Кнопка [image] вызывает команду CHAMFER (ФАСКА), которая выполняет операцию подрезки двух пересекающихся прямолинейных сегментов (отрезков, лучей, прямых) на заданных расстояниях от точки их пересечения (снятие фаски), строя при этом новый отрезок, соединяющий точки подрезки. Команду, кроме того, можно вызвать из падающего меню Modify (Редакт) с помощью пункта Chamfer (Фаска). Команда выполняется как над пересекающимися, так и над непересекающимися, но непараллельными отрезками (при этом отрезки сначала удлиняются до пересечения).
Команда CHAMFER (ФАСКА) сначала сообщает текущее состояние режимов, а затем выдает запрос о выборе объекта:
(TRIMmode) Current chamfer DistJ = 0.0000, Dist2 = 0.0000 Select first line or [Polyline/Distance/Angle/Trim/Method/mUltiple]:
((Режим С ОБРЕЗКОЙ) Параметры фаски: Длина! = 0.0000, Длина2 = 0.0000 Выберите первый отрезок или /полИлиния/Длина/Угол/Обрезка/Метод/ мНого]:)
Если действующие параметры фаски вас устраивают, то вы можете прямо перейти к указанию первого объекта. Но чаще всего сначала надо установить необходимые вам длины фасок. Это делается с помощью опции Distance (Длина), которая выдает свой запрос:
Specify first chamfer distance <0.0000>: (Первая длина фаски <0.0000>:)
Введите первую длину — например, 75 мм. Далее:
Specify second chamfer distance <75.0000>: (Вторая длина фаски <75.0000>:)
Введите вторую длину — например, еще раз 75 мм. Команда на этом не заканчивает работу, как это было в ранних версиях системы AutoCAD, а снова выдает запрос:
Select first line or [Polyline/Distance/Angle/Trim/Method/mUltiple]:
(Выберите первый отрезок или { полИлиния/Длина/Угол/Ойрезка/Метод/ мНого]:)
Нужно отметить первый отрезок. Система AutoCAD тогда запрашивает: Select second line: (Выберите второй отрезок:)
Выберите второй обрезаемый отрезок. На рис. 3.40 приведен пример снятия фаски: в левой части изображены отрезки до операции, и правой части — после операции.
Если в начале команды использовать новую опцию multiple (мНого), то тогда после построения первой фаски команда CHAMFER (ФАСКА) не завершит свою работу, а будет в цикле запрашивать очередную пару редактируемых объектов.

Рис. 3.40. Снятие фаски с отрезков

Опция Trim (Обрезка) выдает запрос:
Enter Trim mode option [Trim/No trim] <Trim>: (Режим обрезки [С обрезкой/Без обрезки] <С обрезкой>:)
В этот момент нужно выбрать один из двух режимов. Обычный режим — Trim (С обрезкой). В случае выбора режима No trim (Без обрезки) дополнительный отрезок, соединяющий точки подрезки, строится, а сами исходные сегменты, к которым применяется операция снятия фаски, остаются неизмененными (как, например, стороны прямоугольника на рис. 3.41). Установка режима распространяется и на следующую команду FILLET (СОПРЯЖЕНИЕ).
Другая опция команды CHAMFER (ФАСКА) — Method (Метод). В этом случае выдается запрос:
Enter trim method [Distance/Angle] <Distance>: (Метод построения [Длина/Угол/ <ДлинаУ:)

Рис. 3.41. Снятие фаски по всей полилинии

Команда может снимать фаску двумя методами. Первый — в случае задания опции Distance (Длина), когда задаются две длины, снимаемые с отрезков. Второй — в случае задания опции Angle (Угол), когда задается одна длина и угол, под которым строится дополнительный отрезок фаски относительно первого сегмента. Установки для обоих методов система AutoCAD хранит в системных переменных CHAMFERA, CHAMFERB (метод Distance (Длина)) и CHAMFERC, CHAMFERD (метод Angle (Угол)). Значения этих переменных выдаются при сообщении текущего состояния установок команды CHAMFER (ФАСКА) (о системных переменных см. разд. 11.1). Задание значений переменных в команде CHAMFER (ФАСКА) выполняется с помощью опций Distance (Длина) и Angle (Угол).
Можно в качестве сегментов для снятия фаски указывать конечные прямолинейные участки двух полилиний или отрезок и конечный прямолинейный сегмент полилинии, а также участки одной полилинии. В последнем варианте либо указываемые сегменты полилинии должны быть соседними, либо они могут быть разделены еще одним сегментом (фаска снимается по обе стороны от точки их пересечения).
Еще одна интересная опция — Polyline (полИлиния). С ее помощью можно снять фаску сразу во всех вершинах одной полилинии. На рис. 3.41 приведен пример такой операции над полилинией в форме прямоугольника (режим No trim (Без обрезки)).
Команда FILLET (СОПРЯЖЕНИЕ) сопрягает объекты (например, отрезки, дуги и окружности) дугой заданного радиуса. Ей соответствует кнопка [image] панели Modify (Редактирование) и пункт Fillet (Сопряжение) падающего меню Modify (Редакт). Команда по своим режимам аналогична команде CHAMFER (ФАСКА).
Первое сообщение, выдаваемое командой, содержит информацию о текущих настройках и запрос первого объекта:
Current settings: Mode = TRIM, Radius = 0.0000 Select first object or [Polyline/Radius/Trim/mUltiple]:
(Текущие настройки: Режим = С ОБРЕЗКОЙ, Радиус сопряжения = 0.0000 Выберите первый объект или [полИлиния/раДиус/Обрезка/мНого]:)
Опция Radius (раДиус) после выдачи соответствующего запроса дает возможность изменить текущее значение радиуса сопряжения:
Specify fillet radius < 0.0000 >: (Радиус сопряжения <0.0000>:)
После установки величины радиуса снова повторяется запрос Select first object or [Polyline/Radius/Trim/mUltiple]: (Выберите первый объект или [полИлиния/раДиус/Обрезка/мНого]:). Если текущие настройки вас удовлетворяют, отметьте первый объект для сопряжения. Далее:
Select second object: (Выберите второй объект:)
Когда вы укажете второй объект, система AutoCAD либо построит требуемую дугу сопряжения, либо сообщит о том, что сопряжение с данным радиусом невозможно. На рис. 3.42 приведен пример сопряжения отрезка и окружности (слева — объекты до сопряжения, справа — после сопряжения). В качестве сопрягаемых объектов могут фигурировать два участка полилинии, которые либо являются соседними участками, либо они разделяются одним сегментом полилинии.
Новая опция multiple (мНого) позволяет в цикле выполнять многократное сопряжение объектов.
Опция Trim (Обрезка) управляет режимом обрезки (он интегрирован с режимом обрезки в команде CHAMFER (ФАСКА)). Если выбран режим No trim (Без обрезки), тогда сопрягающая дуга вычисляется и строится (если построение возможно), а исходные объекты остаются без изменения. Если же действует режим Trim (С обрезкой), то незамкнутые сопрягаемые объекты укорачиваются или удлиняются до точки начала сопрягающей дуги. На рис. 3.42 исходный отрезок, показанный слева, по этой причине стал короче.
Опция Polyline (полИлиния) позволяет скруглить заданным радиусом все вершины одной полилинии.

Рис. 3.42. Сопряжение объектов

В ранних версиях системы AutoCAD команда FILLET (СОПРЯЖЕНИЕ) могла сопрягать только прямолинейные объекты.
Последняя кнопка [image] панели Modify (Редактирование), соответствующая команде EXPLODE (РАСЧЛЕНИТЬ), уже рассматривалась нами ранее. Она расчленяет на более простые объекты полилинии, вхождения блоков, размеры и другие сложные объекты.


3.3. Редактирование полилиний

Специальное редактирование двумерных полилиний выполняется с помощью команды PEDIT (ПОЛРЕД), которой соответствуют кнопка [image] , входящая в панель инструментов Modify II (Редактирование-2) (рис. 3.43), и пункт падающего меню Modify | Object | Polyline (Редакт Объекты | Полилиния). Мы уже рассматривали эту команду в разд. 2.10 для выполнения операции объединения в полилинию отрезков и дуг.

Рис. 3.43. Панель инструментов Modify II

Рассмотрим другие возможности команды PEDIT (ПОЛРЕД). После выбора полилинии в ответ на запрос Select polyline or [Multiple]: (Укажите полилинию или [Несколько]:) система AutoCAD выдает следующий перечень опций:
Enter an option [Close/Join/Width/Edit vertex/Fit/Spline/Decurve/Ltype gen/Undo]:
(Задайте опцию [Замкнуть/Добавить/Ширина/ Вершина/СГладить/СПлайн/ Убрать сглаживание/Типлин/Отменить]:)
Перечислим опции команды с кратким их описанием:

  • Close (Замкнуть) — замыкает разомкнутую (открытую) полилинию; если же была отмечена замкнутая полилиния, то опция изменится на Open (Разомкнуть);
  • Join (Добавить) — добавляет новые сегменты к полилинии;
  • Width (Ширина) — изменяет ширину всех сегментов полилинии на новое постоянное значение;
  • Edit vertex (Вершина) — переходит в режим редактирования вершин полилинии (перемещение вершин, удаление вершин, добавление вершин, изменение ширины отдельных сегментов и т. д.);
  • Fit (СГладить) — сглаживает полилинию с помощью дуговых сегментов;
  • Spline (СПлайн) — проводит сплайн по специальному уравнению, проходящий через начальную и конечную точки полилинии;
  • Decurve (Убрать сглаживание) — убирает сглаживание, выполненное опциями Fit (СГладить) и Spline (СПлайн);
  • Ltype gen (Типлин) — управляет построением типа линии (для сегментов по отдельности или для всей полилинии в целом);
  • Undo (Отменить) — отменяет последнюю операцию, выполненную в данной команде PEDIT (ПОЛРЕД).

Кроме того, нажатие клавиши <Enter> (вместо выбора опции) завершает команду PEDIT (ПОЛРЕД).
Опция Close (Замкнуть) замыкает разомкнутую полилинию, добавляя сегмент, идущий из конечной точки в начальную. Если последний сегмент полилинии был прямолинейным, то замыкание выполняется добавлением прямолинейного участка. Если последний сегмент был дуговым, то для замыкания строится дуговой сегмент, касающийся последнего сегмента. На рис. 3.44 приведены примеры замыкания двух полилиний, отличие которых только в типе последнего сегмента: у первой полилинии он прямолинейный, у второй — дуговой. Точками 1 и 2 отмечены участки, добавляемые системой с помощью опции Close (Замкнуть). Для наглядности эти участки выделены штриховой линией.

Рис. 3.44. Варианты замыкания полилинии

Опция Open (Разомкнуть) действует очевидным образом: удаляет последний участок полилинии.
Опция Join (Добавить) преобразует отрезок или дугу в односегментную полилинию или добавляет к полилинии новые смежные сегменты, которыми могут быть отрезки, дуги и другие двумерные полилинии. Разумеется, при этом не должен нарушаться основной принцип полилинии: начальная точка каждого последующего сегмента должна совпадать с конечной точкой предыдущего.
Опция Width (Ширина) изменяет ширину всех сегментов полилинии на новое постоянное значение, которое запрашивается системой. Значения ширины всех сегментов до операции, даже если они были разными, утрачиваются.
Опция Fit (СГладить) сглаживает полилинию с помощью дуговых сегментов, которые касаются друг друга. На рис. 3.45 приведен пример полилинии до сглаживания (состоит из прямолинейных сегментов) и после сглаживания (состоит из дуговых сегментов). Исходные вершины полилинии остаются на старых местах, но к ним могут быть добавлены промежуточные, которые исчезают после ликвидации сглаживания (см. описание опции Decurve (Убрать сглаживание)).

Рис. 3.45. Сглаживание полилинии с помощью опции Fit

На рис. 3.46 приведена та же полилиния, но сглаженная с помощью опции Spline (СПлайн). Видно, что промежуточные вершины новой полилинии не совпадают с вершинами старой полилинии.
Опция Decurve (Убрать сглаживание) убирает сглаживание, выполненное опциями Fit (СГладить) или Spline (СПлайн). Результирующая полилиния состоит только из прямолинейных сегментов. Для несглаженных полилиний данная опция заменяет дуговые сегменты на прямолинейные, сохраняя вершины на старых местах.
Как было уже сказано в разд. 3.1, полилиния может быть представлена в информационном окне команды LIST (СПИСОК) с двумя наименованиями: LWPOLYLINE — компактная полилиния, и POLYLINE — подробная полилиния. Легкая полилиния превратится в подробную, если к ней применить операцию сглаживания с помощью опций Fit (СГладить) и Spline (СПлайн). Подробная полилиния может иметь дополнительные вершины, вычисленные системой AutoCAD, а компактная — не может. При отключении сглаживания подробные полилинии преобразуются в компактные полилинии.

Рис. 3.46. Сглаживание полилинии с помощью опции

Spline Опция Ltype gen (Типлин) управляет отрисовкой полилинии в случае, когда тип линии выбран отличным от сплошной (в AutoCAD этот тип линии называется CONTINUOUS). Опция выдает следующий запрос:
Enter polyline linetype generation option [ON/OFF] <OFF>: (Генерация типа линии по всей полилинии [Вкл/Откл] <Откл>:)
В этот момент можно включить режим генерации типа линии по всей полилинии (по умолчанию он выключен, что ускоряет расчет). На рис. 3.47 приведен пример полилинии с типом линии DASHED (штриховая) при Ltype gen=OFF (Типлин=Откл), а на рис. 3.48 — при Ltype gen=ON (Типлин=Вкл).
На рис. 3.48 Ltype gen=OFF (Типлин=Откл) и тип линии, состоящий из штрихов и пропусков заданных размеров, применен к каждому сегменту отдельно. Поэтому при недостаточной длине (не хватает длины, чтобы начать второй штрих после пропуска) на сегменте вообще не образуются штрихи, как произошло со вторым, третьим и восьмым сегментами. При Ltype gen=ON (Типлин=Вкл), как на рис. 3.48, длины штрихов откладываются, начиная с самой первой вершины полилинии, по всей полилинии в целом, поэтому штрихи присутствуют на всех сегментах. Недостатком второго режима является то, что пропуск между штрихами может попасть на вершину.

Рис. 3.47. Полилиния при Ltype gen=OFF

Самая сложная опция — Edit vertex (Вершина), которая вызывает режим работы с вершинами полилинии, что дает возможность изменять положение вершин, удалять их, добавлять, а также менять ширину конкретного сегмента и разрывать полилинию на части. После выбора данной опции система AutoCAD выдает запрос:
Enter a vertex editing option [Next/Previous/Break/ lnsert/Move/Regen/Straighten/Tangent/Width/eXit] <N>:
Задайте опцию редактирования вершины
След/Пред/РАзорвать/ВСтавитъ/ПЕренести/ РЕген/ВЫпрямитъ/Касателъная/ Шкрина/выХод] <С>:)
При этом в первой вершине полилинии появляется знак х (рис. 3.49), что означает отметку текущей вершины, к которой будут относиться последующие операции редактирования. Порядок следования вершин идентичен той последовательности, с которой эти вершины создавались при построении полилинии.

Рис. 3.48. Полилиния при Ltype gen=ON

Рис. 3.49. Режим редактирования вершин полилинии

В данном режиме доступны такие опции:

  • Next (След) — перейти на следующую вершину;
  • Previous (Пред) — перейти на предыдущую вершину;
  • Break (РАзорвать) — разорвать полилинию, начиная с текущей вершины;
  • Insert (ВСтавить) — вставить новую вершину после текущей;
  • Move (ПЕренести) — перенести текущую вершину на новое место;
  • Regen (РЕген) — регенерировать (перерисовать) полилинию с текущими установками;
  • Straighten (ВЫпрямить) — выпрямить полилинию на участке, начиная с текущей вершины (удаление соседних вершин);
  • Tangent (Касательная) — задать направление касательной к текущей вершине для будущей операции Fit (СГладить);
  • Width (Ширина) — задать ширину полилинии на участке, начинающемся в текущей вершине;
  • eXit (выХод) — выход из режима редактирования вершин и возврат к запросу: Enter an option [Close/Join/Width/Edil vertex/Fit/Spline/Decurve/Ltype gen/Undo]: (Задайте опцию [Замкнуть/Добавить/Ширина/Вершина/СГладить/СПлайн/ Убрать сглаживание/Типлин/Отменить]:).

Опции Next (След) и Previous (Пред) дают возможность перемещаться между вершинами полилинии, чтобы добраться до той вершины, которую надо редактировать.
Опция Break (РАзорвать) предназначена для разрыва полилинии. Начало разрыва — в текущей вершине, а окончание разрыва нужно указать в ответ на запрос:
Enter an option [Next/Previous/Go/eXit] <N>: (Задайте опцию [След/Пред/Выполнить/выХод] <С>:)
Если разрыв нужно выполнить в текущей вершине (после этого полилиния разделится на две полилинии, имеющие общую точку в месте разрыва), то следует воспользоваться опцией Go (Выполнить). При этом все сегменты исходной полилинии сохраняются, оказываясь в составе одной из двух новых полилиний.
Если разрыв нужно начать в текущей вершине, а закончить в другой, расположенной дальше или ближе текущей (и тем самым в результате разрыва удалить участки между текущей и другой вершиной), то необходимо в режиме Break (Разорвать) сначала с помощью опций Next (След) и Previous (Пред) перейти на ту вершину, в которой разрыв будет закончен, и затем только воспользоваться опцией Go (Выполнить). Если режим редактирования вершин больше не нужен, то выйти из него с помощью опции eXit (выХод).
На рис. 3.50 в левой части изображена полилиния до разрыва, а в правой части — после разрыва, с удалением одного сегмента.

Рис. 3.50. Разрыв полилинии

Для добавления в полилинию новой вершины нужно воспользоваться опцией Insert (ВСтавить). Перед тем как перейти к этой опции, нужно переместиться к вершине, после которой добавляется новая вершина. Затем с помощью клавиатуры ввести опцию Insert (ВСтавить). Система AutoCAD запрашивает:
Specify location for new vertex: (Положение новой вершины:)
Вы указываете положение новой вершины, вставляемой после текущей. На рис. 3.51 слева показан момент указания положения новой вершины, вставляемой между четвертой и пятой вершинами, а справа — результат операции вставки.
Нельзя с помощью этой опции вставить вершину перед первой вершиной полилинии.
Опция Move (ПЕренести) используется, когда текущую вершину нужно перенести на новое место. При использовании опции выдается запрос:
Specify new location for marked vertex: (Новое положение помеченной вершины:)
Вы указываете новое положение текущей вершины (рис. 3.52). Справа на рисунке показан результат переноса вершины на новое место.

Рис. 3.51. Добавление новой вершины в полилинию

Рис. 3.52. Перенос вершины полилинии

Опция Regen (РЕген) позволяет, не выходя из команды PEDIT (ПОЛРЕД), перечертить (регенерировать) полилинию с текущими изменениями.
Если надо удалить какие-то вершины из полилинии, то следует воспользоваться опцией Straighten (ВЫпрямить). Запрос, выдаваемый этой опцией, аналогичен запросу опции Break (РАзорвать): Enter an option [Next/Previous/Go/eXit] <N>: (Задайте опцию [След/Пред/Выполнить/выХод] <С>:). Опция выпрямляет полилинию на участке, начиная с текущей вершины и заканчивая вершиной, в которую можно перейти, перемещаясь по полилинии с помощью опции Next (След) и Previous (Пред). Опция Go (Выполнить) завершает операцию выпрямления. На рис. 3.53 в левой части изображена полилиния до выпрямления, а в правой части — после выпрямления, с удалением четырех вершин.

Рис. 3.53. Выпрямление полилинии

Опция Tangent (Касательная) дает возможность задать направление касательной на вершинах полилинии для будущей операции Fit (СГладить), что позволяет воздействовать на форму линии, получаемой после сглаживания. После выбора опции Tangent (Касательная) следует запрос:
Specify direction of vertex tangent: (Направление касательной в вершине:)
Направление задается углом в градусах или точкой. После задания на текущей вершине появляется стрелка с указанным направлением (см. вершину полилинии в левой части рис. 3.54). Направление будет использовано только тогда, когда вы в дальнейшем выполните операцию сглаживания полилинии с помощью опции Fit (СГладить). В правой нижней части рис. 3.54 показан результат сглаживания, выполненного с учетом направления касательной в указанной ранее вершине. Для сравнения в правой верхней части рисунка приведена аналогичная полилиния, которая была сглажена без задания направления касательной.

Рис. 3.54. Направление касательной в вершине полилинии

Опция Width (Ширина) управляет шириной полилинии на участке, начинающемся в текущей вершине. Первый запрос:
Specify starting width for next segment: (Начальная ширина следующего сегмента:)
Нужно задать начальную ширину (обычно вводом с клавиатуры). Если вы в этот момент мышью укажете точку, то AutoCAD запросит вторую точку, а расстояние между точками возьмет в качестве значения ширины (если указание мышью произошло по недоразумению, то это может привести к непредсказуемому изменению ширины полилинии). Далее:
Specify ending width for next segment <0.0000>: (Конечная ширина следующего сегмента <0.0000>:)
В угловых скобках по умолчанию предлагается значение, выбранное в качестве начальной ширины сегмента (в нашем примере — 0.0000). После ввода второй ширины регенерируется текущий сегмент полилинии с новой шириной.
Опция eXit (выХод) завершает режим редактирования вершин и возвращает запрос Enter an option [Next/'Previous/'Go/'eXitJ <N>: (Задайте опцию [СледУ Пред/'Выполнить/'выХод] <С>:).
Опция Multiple (Несколько), которая появилась еще в системе AutoCAD 20001, доступна пользователю в самом первом запросе о выборе редактируемой полилинии и дает возможность выбрать сразу несколько полилиний для того, чтобы над ними выполнить однотипные операции (например, замкнуть или изменить глобальную ширину). Следует иметь в виду, что при таком выборе полилиний недоступна опция Edit vertex (Вершина).


3.4. Редактирование мультилиний

Мультилиния — сложный объект и для его редактирования имеется специальная команда MLEDIT (МЛРЕД), которой соответствует пункт падающего меню Modify | Object | Multiline (Редакт Объект Мультилиния).
Построение мультилиний с помощью стилей, имеющихся в вашем рисунке, описано в разд. 2.12. Вам всегда доступен стиль STANDARD, создающий мультилинию из двух параллельных линий. О создании других стилей (из трех и большего количества линий, изменение свойств) см. разд. 5.3.
Команда MLEDIT (МЛРЕД) вызывает диалоговое окно Multiline Edit Tools (Редактирование мультилиний) (рис. 3.55). Еще один способ вызова данного окна — двойной щелчок левой кнопкой мыши по мультилиний (при этом в рисунке не должны быть выделены другие объекты).
В этом окне имеются кнопки 12 операций. Если щелкнуть левой кнопкой мыши по выбранной вами пиктограмме, то в нижней части окна появляется подсказка с наименованием операции, выполняемой с помощью данной кнопки диалогового окна. На рис. 3.55 показана подсказка к левой верхней кнопке (Closed Cross (Закрытый крест)). В первом столбце окна расположены кнопки обработки пересечения двух мультилиний, во втором — оформления окончания одной мультилиний около другой, в третьем — обработки углового пересечения двух мультилиний или одной мультилиний (а также операций с вершинами) и в четвертом — операций разрывов. Рассмотрим эти операции в порядке их следования, по столбцам (в каждом столбце — сверху вниз). Для вызова необходимой операции нужно щелкнуть левой кнопкой мыши по соответствующей пиктограмме, а затем нажать кнопку ОК или просто дважды щелкнуть левой кнопкой по выбранной пиктограмме.

Рис. 3.55. Диалоговое окно Multiline Edit Tools

Операция Closed Cross (Закрытый крест) (соответствующая кнопка [image] ) запрашивает: Select first mline: (Выберите первую мультилинию:)
Если на рисунке имеются две пересекающиеся мультилинии, то нужно указать ту из них, которая будет накрыта (разорвана) второй мультилинией мишень мыши при этом должна попасть на одну из линий выбранной мультилинии). По возможности желательно указывать мультилинию ближе ,< точке пересечения. Следующий запрос:
Select second mline: (Выберите вторую мультилинию:)
Укажите вторую мультилинию, которая будет верхней. В результате выполнения операции первая мультилиния будет скрыта под второй в области их пересечения (рис. 3.56).
Далее следует запрос: Select first mline or [Undo]: (Выберите первую мультилинию или /Отменить]:)
Вы можете указать следующую мультилинию в зоне другого пересечения пли нажать клавишу <Enter> для выхода из команды. С помощью опции Undo (Отменить) вы можете отменить только что выполненную операцию над предыдущей парой мультилинии.

Рис. 3.56. Результат операции Closed Cross

Операция Open Cross (Открытый крест) (кнопка [image] ) работает аналогично предыдущей, но в зоне пересечения убирает все внешние кромки и внутренние линии первой указанной мультилинии.
Операция Merged Cross (Сплошной крест) (кнопка [image] ) работает аналогично предшествующей, но убирает только внешние кромки. Операции Closed Tee (Закрытое Т) (кнопка [image] ), Open Tee (Открытое Т) (кнопка [image] ) и Merged Tee (Сплошное Т) (кнопка [image] ) позволяют первую из указываемых мультилинии закончить (обрезать) в области ее пересечения со второй мультилинией. Нюансы работы этих операций хорошо видны на изображениях соответствующих пиктограмм.
Операция Corner Joint (Угловой стык) (кнопка [image] ) оформляет угловое пересечение конечных сегментов двух мультилинии или одной мультилинии, вычисляя все необходимые пересечения.
Операция Add Vertex (Добавить вершину) (кнопка [image] ) позволяет добавить вершину внутри прямолинейного сегмента мультилинии. Для этого в ответ на запрос указания мультилинии нужно отметить на одной из линий, входящих в мультилинию, место стыка (новой вершины). Если в стиле редактируемой мультилинии не было задано вычерчивание внутренних стыков в точках вершин, то появившаяся новая вершина ничем не будет отмечена. Чтобы увидеть все вершины, в том числе и новую, нужно высветить ручки у мультилинии (рис. 3.57).

Рис. 3.57. Добавление вершины в мультилинию

Операция Delete Vertex (Удалить вершину) (кнопка [image] ) позволяет удалить вершину мультилинии, выпрямляя соответствующий сегмент. Для удаления нужно в ответ на запрос выбора мультилинии указать одну из ее линий вблизи ликвидируемой вершины. В результате система AutoCAD перестроит мультилинию без этой вершины.
Операция Cut Single (Обрезать один) (кнопка [image] ) разрывает одну из линий, входящих в мультилинию. Как и в команде BREAK (РАЗОРВАТЬ), точка, в которой указывалась разрываемая мультилиния, является первой точкой разрыва. После указания второй точки система AutoCAD выполнит разрыв.
Операция Cut All (Обрезать все) (кнопка [image] ) разрывает все линии, входящие в мультилинию. Точка, в которой указывалась мультилиния, является первой точкой разрыва, и после указания второй точки AutoCAD разрывает всю мультилинию.
Для ликвидации разрывов мультилинии служит операция Weld All (Соединить все) (кнопка [image] ). Для точности указания аннулируемого разрыва мультилинию нужно помечать вблизи места разрыва.


3.5. Редактирование надписей

Операции редактирования текстов собраны в панели инструментов Text (Текст) (панель приведена на рис. 2.48).
Для редактирования надписей предусмотрены кнопка [image] панели Text (Текст) и пункт падающего меню Modify | Object | Text | Edit (Редакт | Объект Текст | Редактировать). Они вызывают команду DDEDIT (ДИАЛРЕД). Другой, более простой способ вызова этой команды — двойной щелчок по однострочному тексту (при этом в рисунке не должны быть выделены другие объекты).
Команда DDEDIT (ДИАЛРЕД) предназначена не только для редактирования текста, но и размерного текста, допусков и определений атрибутов. О редактировании допусков — в разд. 3.6, об атрибутах — в разд. 7.1.
Команда запрашивает:
Select an annotation object or [Undo]: (Выберите текст или /Отменить]:)
Если указать однострочный текст, то появляется диалоговое окно Edit Text (Редактирование текста) (рис. 3.58).
В выделенном поле Text (Текст) нужно внести необходимые изменения, затем нажать кнопку ОК. Другие параметры текста (высоту, тип выравнивания, точку привязки и т. д.) в данной команде изменить нельзя.
Если в качестве редактируемого объекта в команде DDEDIT (ДИАЛРЕД) был указан мультитекст (многострочный текст), то вызывается окно редактора мультитекста (рис. 3.59), в котором нужно внести изменения, удовлетворяющие обычным правилам оформления мультитекста (см. разд. 2.13).

Рис. 3.58. Диалоговое окно Edit Text

Рис. 3.59. Диалоговое окно редактора мультитекста

Редактирование мультитекста выполняется по тем же правилам, что и создание мультитекста. Кроме того, можно выделить любой участок текста и вызвать правой кнопкой мыши контекстное меню, изображенное на рис. 2.65.
Кнопка [image] панели Text (Текст) вызывает команду FIND (НАЙТИ), которая выполняет операции поиска и замены в текстовых примитивах всего чертежа или выделенного набора объектов.
Кнопка [image] соответствует команде STYLE (СТИЛЬ), создающей стили текста, которые будут рассмотрены в разд. 5.1.
Кнопка [image] вызывает команду SCALETEXT (МАСШТЕКСТ), которая позволяет масштабировать текст. Команду можно также вызвать с помощью пункта падающего меню Modify | Object | Text | Scale (Редакт Объект | Текст Масштаб). Первый запрос команды:
Select an annotation object or [Undo]: (Выберите текстовый объект или [Отменить]:)
Нужно указать однострочный или многострочный текст (возможно также указание атрибутов или определений атрибутов, рассмотренных в разд. 7.1). После этого циклически повторяется запрос о выборе объектов. Окончить выбор можно нажатием клавиши <Enter>. Далее:
Enter a base point option for scaling [Existing/Left/Center/Middle/Right/TL /TC/TR/ML/MC/MR/BL/BC/BR] <Existing>:
(Задайте опцию базовой точки для масштабирования [Существующая/вЛево/Центр/сЕредина/впРаво/ ВЛ/ВЦ/ВП/СЛ/СЦ/СП/НЛ/НЦ/НП] < Существующая >:)
Нужно выбрать опцию, определяющую точку, относительно которой будет масштабироваться текст. Список предлагаемых опций практически повторяет список опций выравнивания текста (см. разд. 2.13 и рис. 2.52). Следует, однако, иметь в виду, что надпись может быть позиционирована одним способом (например, за левую нижнюю точку), а масштабирована другим (например, относительно центральной точки). Опция Existing (Существующая) означает, что масштабирование будет выполнено относительно той же точки, что и точка привязки текстового примитива. Следующий запрос:
Specify new height or [Match object/Scale factor] <15>: (Новая высота или [Образец/Масштаб] < 15>:)
Здесь можно либо указать новую высоту для выбранных надписей, либо выбрать одну из опций. Опция Match object (Образец) позволяет отметить образец (текст), из которого будет взято значение новой высоты:
Select a text object with the desired height: (Укажите текстовый объект с нужной высотой:)
Опция Scale factor (Масштаб) дает возможность ввести множитель для масштабирования высоты:
Specify scale factor or [Reference] <2>: (Масштаб или [Опорный отрезок] <2>:)
В этом случае опция Reference (Опорный отрезок) имеет тот же смысл, что и одноименная опция команды SCALE (МАСШТАБ) (см. разд. 3.2).
Если в команде SCALETEXT (МАСШТЕКСТ) были выбраны сразу несколько объектов, то все они будут изменены по одному алгоритму (хотя базовые точки масштабирования у каждого объекта, естественно, свои).
Команда JUSTIFYTEXT (ВЫРТЕКСТ), которой соответствует кнопка [image] позволяет, не меняя внешнего вида надписи, изменить способ ее выравнивания (например, надпись привязана за нижнюю правую точку, а вы хотите, чтобы надпись была пересоздана с опцией Fit (По ширине)). Команду можно также вызвать с помощью пункта падающего меню Modify | Object | Text | Justify (Редакт | Объекты Текст Выравнивание). Изменение способа выравнивания позволяет в дальнейшем редактировать надпись (даже с помощью ручек), но с сохранением новых свойств.
Начальный запрос команды — обычный для команд редактирования: Select objects: (Выберите объекты:). По окончании выбора следует уже специфический запрос:
Enter a justification option [Left/Align/Fit/Center/Middle/ Right/TL/TC/TR/ML/MC/MR/BL/BC/BR]<Left>:
(Задайте опцию выравнивания [вЛево/впИсанный/Поширине/Центр/сЕредина/ впРаво/ВЛ/ВЦ/ВП/СЛ/СЦ/СП/НЛ/НЦ/НП] <вЛево>:)
Вы выбираете с помощью опций новый способ выравнивания, и команда его тут же реализует. Внешне в вашем рисунке ничего не изменится. Изменения можно увидеть, если включить ручки. На рис. 3.60 показаны два текстовых примитива, однако первый имеет выравнивание за левую точку, а второй — за верхнюю правую.

Рис. 3.60. Изменение способа выравнивания текста

Последняя кнопка [image] панели Text (Текст) соответствует команде SPACETRANS (ЕДПРОСТ), которая предназначена для пересчета длин между пространствами модели и листа. Эта команда будет рассмотрена в гл. 10.
Удобное средство редактирования однострочных текстов, доставшееся от старых версий системы AutoCAD — команда CHANGE (ИЗМЕНИТЬ), вводимая с клавиатуры. Она позволяет изменить любые параметры надписи.
Первый запрос команды — стандартный: Select objects: (Выберите объекты:). Укажите однострочный текст и на повтор запроса о выборе объектов нажмите клавишу <Enter>. Далее:
Specify change point or [Properties]: (Точка изменения или [Свойства]:)
Опция Properties (Свойства) переходит к редактированию свойств (что рассмотрено в гл. 4). Укажите новую характерную точку для того способа выравнивания, которым позиционировался текст при его создании. Надпись переместится согласно вашему указанию. Если вы нажмете клавишу <Enter>, то будет выдан дополнительный запрос:
Specify new text insertion point <no change>: (Новая точка вставки текста <не изменять"?:)
Укажите новую точку или нажмите клавишу <Enter>, если текст перемещать не надо. Далее:
Enter new text style <Standard>: (Новый текстовый спишь <Standard>:)
В угловых скобках выводится имя предыдущего стиля надписи (для примера — Standard). Вопрос о стилях текста итожен в разд. 5.1. Если вы не хотите менять стиль, то снова нажимаете <Enter>. Если в стиле высота букв не была зафиксирована, то выдается следующий запрос (в противном случае запрос пропускается):
Specify new height <33.5000>: (Новая высота <33.5000>:)
В угловых скобках указана действующая высота текста (для примера — 33,5). Введите новую высоту, набрав число на клавиатуре или указав мышью две точки (расстояние между точками будет взято за новую высоту). Если высота не меняется, то нажмите <Enter>. Далее:
Specify new rotation angle <30>: (Новый угол поворота <30>:)
В угловых скобках указан действующий угол поворота нижнего основания надписи (для примера — 30). Укажите угол или нажмите <Enter>. Следующий запрос:
Enter new text <... >: (Новый текст <...>:)
В угловых скобках также будет указано действующее содержимое надписи. Введите новый текст или согласитесь с предложенным по умолчанию, нажав клавишу <Enter>. Система AutoCAD изменит надпись в соответствии с вашими новыми установками.
Команда CHANGE (ИЗМЕНИТЬ) не применяется для корректировки содержимого или положения многострочного текста.
Кроме того, изменение текста и любых его параметров может быть сделано самой универсальной командой редактирования — PROPERTIES (ОК-НОСВ), рассмотренной в разд. 4.6.
Для проверки орфографии служит команда SPELL (ОРФО), которой соответствует пункт Spelling (Орфография) падающего меню Tools (Сервис). Впрочем, в английской версии она настроена на проверку английского языка.


3.6. Редактирование размеров

В панели Dimension (Размеры), которую мы рассмотрели в разд. 2.14, есть еще несколько кнопок с командами, позволяющими редактировать ранее созданные размерные примитивы. Аналогичные операции имеются и в падающем меню Dimension (Размеры).
Команда DIMEDIT (РЗМРЕ7П. которой соответствует кнопка [image] панели Dimension (Размеры), позволяет поменять размерный текст и его местоположение, а также наклонить выносные линии. Этой команде частично (в рамках одной опции) соответствует пункт Oblique (Наклонить) падающего меню Dimension (Размеры).
Первый запрос команды выглядит так:
Enter type of dimension editing [Home/New/Rotate/Oblique] <Home>: (Операция редактирования размеров [Вернуть/Новый/Повернуть/нАклонить] <Вернутъ>:)
Доступны четыре варианта ответа. Опция New (Новый) дает возможность поменять текст с помощью диалогового окна Multiline Text Editor (Редактор многострочного текста) (рис. 3.61). Эта опция по действию аналогична команде DDEDIT (ДИАЛРЕД).

Рис. 3.61. Диалоговое окно замены размерного текста

В данном окне угловые скобки означают старый размерный текст, который можно сохранить, добавив символы перед ним и после него, или полностью заменить, удалив угловые скобки и введя новый текст. После закрытия окна остается лишь указать те размерные примитивы, текст которых нужно заменить (в разных размерах символы < > будут иметь разное значение).
Опция Rotate (Повернуть) поворачивает размерный текст относительно размерной линии. В этом случае выдается запрос:
Enter text angle: (Угол поворота размерного текста:)
После ввода угла выдается повторяющийся запрос Select objects: (Выберите объекты:), в ответ на который нужно указать редактируемый размер (щелкнув левой кнопкой мыши по любому элементу этого размера). Клавиша <Enter> завершает работу команды.
Опция Ноте (Вернуть) ликвидирует изменение, внесенное опцией Rotate (Повернуть).
Опция Oblique (нАклонить) (этой опции соответствует пункт Oblique (Наклонить) падающего меню Dimension (Размеры)) позволяет задать угол наклона выносных линий относительно горизонтальной оси, запрашивая сначала объекты, а затем и угол:
Enter oblique angle (press ENTER for none): (Угол наклона (или ENTER, если без наклона):)
Введите угол наклона. На рис. 3.62 приведен пример наклона выносных линий горизонтального размера до 60°.

Рис. 3.62. Задание угла наклона выносных линий

Команда DIMTEDIT (РЗМРЕДТЕКСТ), которой соответствуют кнопка [image] панели Dimension (Размеры) и пункты подменю Align Text (Размерный текст) падающего меню Dimension (Размеры), позволяет поменять положение размерного текста и размерной линии.
Команда вначале указывает выбрать редактируемый размер, а затем запрашивает его новое положение:
Specify new location for dimension text or [Left/Right/Center/Home/Angle]:
(Новое положение размерного текста или [вЛево/вПраво/Центр/Вернуть/ Угол]:)
Если в этот момент начать двигать по экрану курсор, то вы увидите, как вместе с ним по экрану движутся размерный текст и размерная линия. Размерный текст может быть перенесен в любое место между выносными линиями или помещен вне их. На рис. 3.63 показан возможный результат редактирования положения размерного текста, изображенного на рис. 3.62.

Рис. 3.63. Изменение местоположения размерного текста

Опции Left (вЛево), Right (вПраво), Center (Центр) перемещают размер вдоль существующей размерной линии, между размерными стрелками. Опция Angle (Угол) дает возможность повернуть размерный текст относительно размерной линии. Опция Ноте (Вернуть) ликвидирует сделанные с помощью данной команды перемещения и поворот размерного текста.
Команде DIMSTYLE (РЗМСТИЛЬ) соответствует кнопка [image] которая входит как в панель Dimension (Размеры), так и в новую панель Styles (Стили). Этой же команде соответствуют пункты Style (Стиль) падающего меню Dimension (Размеры) и Dimension Style (Размерные стили) падающего меню Format (Формат). Команда позволяет создавать и редактировать размерные стили. Размерный стиль — это совокупность установок, описывающих форму размерных примитивов. Подробнее о размерных стилях в разд. 5.2.
Однако кнопку [image] удобно использовать еще и для внесения отдельных изменений в оформление размеров, не редактируя размерного стиля и не создавая нового. Рассмотрим диалоговое окно Dimension Style Manager (Диспетчер размерных стилей) (рис. 3.64), открываемое командой DIMSTYLE (РЗМСТИЛЬ), и работу с некоторыми его элементами в самых употребительных случаях.

Рис. 3.64. Диалоговое окно Dimension Style Manager

Все установки оформления размеров записываются в так называемые размерные переменные, которые сохраняются вместе с рисунком. Посмотреть их действующие значения можно, щелкнув мышью по кнопке Compare (Сравнить). На экране появится диалоговое окно Compare Dimension Styles (Сравнение размерных стилей) (рис. 3.65).

Рис. 3.65. Диалоговое окно Compare Dimension Styles

Сравнивать размерные стили мы не будем (стиль по умолчанию в новом рисунке только один, с именем ISO-25). В данный момент важно то, что в центральной части окна виден список с вертикальной линейкой прокрутки, в котором находятся размерные переменные, их описание (смысл) и значения. Пролистаем список и убедимся, что переменная DIMSCALE (в русской версии — РЗММАСШТ) (для нее в столбце Description (Описание) параметр Overall scale (Общий масштаб)) имеет значение 1.0000.
Если вы проставили какой-либо размер и в результате он получился слишком мелким, то все элементы оформления размеров можно легко увеличить пропорционально — например, в два раза. Для этого закроем окно Compare Dimension Styles (Сравнение размерных стилей) и в окне Dimension Style Manager (Диспетчер размерных стилей) нажмем кнопку Override (Переопределить). После этого откроется следующее окно — Override Current Style (Переопределение текущего стиля) (рис. 3.66), имеющее шесть вкладок: Lines and Arrows (Линии и стрелки), Text (Текст), Fit (Размещение). Primary Units (Основные единицы), Alternate Units (Альтернативные единицы) и Tolerances (Допуски).
Все указанные вкладки содержат значения размерных переменных и кнопки (или другие инструменты) для их изменения. С помощью мыши перейдите на вкладку Fit (Размещение) и найдите область Scale for Dimension Features (Масштаб размерных элементов) (рис. 3.67).

Рис. 3.66. Диалоговое окно Override Current Style, вкладка Lines and Arrows

Рис. 3.67. Область Scale for Dimension Features диалогового окна Override Current Style, вкладки Fit

В этой области включен переключатель Use overall scale of (Глобальный масштаб), а справа в счетчике указано его значение (1). Измените это значение на 2 любым из способов: или нажатием на кнопку счетчика со стрелочкой, направленной вверх, или, в данном случае лучше, введя новое значение в текстовое поле, как вы это уже делали для редактируемых текстовых полей. Затем закройте вкладку с помощью кнопки ОК. После этого вы вернетесь в окно Dimension Style Manager (Диспетчер размерных стилей), но в этом окне произошли изменения (см. рис. 3.68).

Рис. 3.68. Диалоговое окно Dimension Style Manager после изменения масштаба

В расположенной слева области Styles (Стили) вниз от имени стиля ISO-25 появилась ветка <style overrides> переопределения стиля>). В средней части в графической иллюстрации высота букв размерного текста стала больше по сравнению с высотой букв на рис. 3.64. В области Description (Описание) появилась отметка о переопределении стиля: ISO-25 + Overall scale = 2.0000.
Нажав кнопку Close (Закрыть), закройте и это окно. Выполненная операция изменила значение размерной переменной DIMSCALE на 2. Теперь, если осуществить установку новых размеров, то все элементы их оформления (цифры, стрелки, отступы и др.) будут в два раза больше, чем у предыдущих размеров.
Можно ли распространить новые установки размерных переменных на ранее созданные размерные примитивы? Можно. Для этого в панели Dimension (Размеры) есть кнопка [image] , а в падающем меню Dimension (Размеры) — пункт Update (Обновить).
При нажатии этой кнопки выдается запрос о выборе объектов. После того как вы отметите необходимые размерные примитивы, они будут перерисованы с новыми установками (в вышеприведенном примере с переменной DIMSCALE оформление размеров укрупнится в два раза).
По умолчанию создаваемые размеры являются ассоциативными. Это означает, что если вы строили размерные примитивы с применением функций объектной привязки, то такие размеры зависят от определяющих их объектов. При изменении основного объекта будет автоматически изменяться и прикрепленный к нему размер.
Команда DIMDISASSOCIATE (РЗМОТКРЕПИТЬ) снимает свойство ассоциативности с тех размерных примитивов, которые будут указаны в ответ на запрос команды.
Для восстановления ассоциативности или изменения (т. е. выбора других точек, от которых будут начинаться выносные линии) следует пользоваться командой DIMREASSOCIATE (РЗМПРИКРЕПИТЬ) или соответствующим ей пунктом Reassociate Dimensions (Прикрепить размеры) падающего меню Dimension (Размеры). Команда запрашивает размерные объекты:
Select dimensions to reassociate Select objects: (Выберите прикрепляемые размеры Выберите объекты:)
После выбора объектов система запрашивает точку, с которой будет ассоциирована точка начала первой выносной линии:
Specify first extension line origin or [Select object] <next>: (Начало первой выносной линии или [Выбрать объект] <далее>:)
При этом действующая определяющая точка начала выносной линии обозначается одним из двух маркеров: — если она обладает свойством ассоциативности (см. рис. 3.69) и [image] — если этим свойством она не обладает. Вы можете либо с помощью объектной привязки указать точку на объекте, с которой будет ассоциативно связано начало выносной линии, либо нажать клавишу <Enter> и перейти к определяющей точке начала второй выносной линии. Размер может быть прикреплен либо полностью, либо частично (т. е. только точка одной выносной линии может быть связана с точкой на объекте).

Рис. 3.69. Признак ассоциативности определяющей точки размера


3.7. Редактирование штриховок и заливок

Для правки штриховок и заливок в панели Modify II (Редактирование-2) (см. рис. 3.43) есть кнопка [image] , которая соответствует команде HATCHEDIT (РЕДШТРИХ). Другой способ вызова команды — пункт падающего меню Modify | Object | Hatch (Редакт | Объект Штриховка).
Команда запрашивает: Select associative hatch object: (Выберите объект — ассоциативную штриховку:)
После того как вы укажете штриховку, раскрывается диалоговое окно Hatch Edit (Редактирование штриховки), в котором будет активна вкладка Hatch (Штриховка) (рис. 3.70). Если вы укажете заливку, то окно откроется на вкладке Gradient (Градиентные) (см. рис. 2.100).

Рис. 3.70. Диалоговое окно Hatch Edit

Это окно практически идентично диалоговому окну Boundary Hatch and Fill (Штриховка и заливка по контуру) (см. рис. 2.91), однако в нем отключены все операции выбора контура. У вас есть возможность поменять образец штриховки, масштаб и угол наклона. После выбора требуемых установок система AutoCAD регенерирует штриховку в новом виде. То же относится и к редактированию параметров заливки.
Диалоговое окно Hatch Edit (Редактирование штриховки) можно также открыть двойным щелчком по штриховке (заливке). При этом в рисунке не должно быть других выделенных объектов. Только один объект может быть выделен и иметь ручки — редактируемая штриховка.


3.8. Редактирование эллипсов

Система AutoCAD не имеет специальной команды для редактирования эллипсов, поэтому для этой цели следует использовать ручки и команды общего редактирования.


3.9. Редактирование сплайнов

Редактирование сплайнов выполняется с помощью команды SPLINEDIT (РЕДСПЛАЙН), которой соответствуют кнопка [image] панели Modify II (Редактирование-2) и пункт падающего меню Modify | Object | Spline (Редакт Объекты Сплайн).
Первый запрос команды: Select spline: (Выберите сплайн:)
Укажите мышью сплайн. Можно выбрать и полилинию, сглаженную с помощью опции Spline (СПлайн) команды PEDIT (ПОЛРЕД). При этом примитив POLYLINE автоматически будет преобразован в примитив SPLINE. Система AutoCAD выдает список опций редактирования:
Enter an option [Fit data/Close/Move vertex/Refine/rEverse/Undo]: (Задайте опцию [Определяющие/Замкнуть/Перенести/
Исправить/ОБратно/ОТменить/выХод]:)
Одновременно с помощью ручек система AutoCAD высвечивает управляющие точки, которые лежат не на самом сплайне, а на каркасной полилинии, которую нужно сгладить, чтобы получить сплайн данной формы (рис. 3.71). Определяющие точки (т. е. точки, которые задал пользователь и через них был проведен сплайн) при этом не высвечиваются.

Рис. 3.71. Управляющие точки сплайна

Сначала дадим краткое описание приведенных опций:

  • Fit data (Определяющие) — редактирует определяющие точки сплайна;
  • Close (Замкнуть) — замыкает сплайн;
  • Move vertex (Перенести) — изменяет положение управляющих точек (и удаляет определяющие);
  • Refine (Исправить) — изменяет гладкость линии сплайна;
  • rEverse (ОБратно) — изменяет направление сплайна (переставляет точки в обратной последовательности);
  • Undo (Отменить) — отменяет последнюю операцию редактирования сплайна.

Кроме того, нажатие на клавишу <Enter> завершает работу команды.
Если сплайн замкнут, то вместо опции Close (Замкнуть) выводится опция Open (Разомкнуть). При выборе опции Fit data (Определяющие) команда высвечивает определяющие точки сплайна (рис. 3.72) и переходит в режим их редактирования.
Выдается запрос:
Enter a fit data option [Add/'Close/'Delete/ 'Move/'Purge/Tangents/toLerance/eXit] <eXit>: (Задайте опцию [Добавить/Замкнуть/Удалить/Перенести/ Очистить/ Касательные/ДОПуск/выХод] <выХод>:)

Рис. 3.72. Определяющие точки сплайна

Опции данного уровня имеют следующее назначение:

  • Add (Добавить) — добавляет новую определяющую точку к сплайну;
  • Close (Замкнуть) — замыкает сплайн;
  • Delete (Удалить) — удаляет некоторые определяющие точки и пересчитывает сплайн по оставшимся определяющим точкам;
  • Move (Перенести) — перемещает определяющие точки;
  • Purge (Очистить) — удаляет информацию об определяющих точках сплайна, после чего они становятся недоступными;
  • Tangents (Касательные) — изменяет начальное и конечное граничные условия сплайна;
  • toLerance (ДОПуск) — изменяет допуск, задающий возможное отклонение сплайна от определяющих точек;
  • eXit (выХод) — выходит из режима редактирования определяющих точек.

Опция Add (Добавить) позволяет добавить определяющую точку к сплайну и выдает запрос:
Specify control point <exit>: (Управляющая точка <выход>:)
Укажите определяющую точку, после которой вы хотите добавить новую точку. Система AutoCAD отмечает ту точку, которую вы укажете, и следующую за ней (рис. 3.73). На экране эти точки будут красного цвета.

Рис. 3.73. Указание участка сплайна, в котором добавляется определяющая точка

Очередной запрос: Specify new point <exit>: (Новая точка <выход>:)
Укажите местоположение добавляемой определяющей точки или нажмите клавишу <Enter> для отказа от добавления. Если вы задали новую точку, то сплайн меняет свою форму с учетом нового состояния определяющих точек (рис. 3.74).

Рис. 3.74. Изменение сплайна при добавлении определяющей точки

Можно сразу же на этом участке сплайна добавить еще точку (или точки), так как запрос о новой точке повторяется. После нажатия клавиши <Enter> режим добавления точек завершается.
Если в качестве точки, после которой добавляется новая, выбрана последняя определяющая точка сплайна, то она помечается только одна (на экране высвечивается красным цветом). Если выбрана первая определяющая точка, то AutoCAD меняет запрос:
Specify new point or [After/Before] <exit>: (Новая точка или [После/До/ <выход>:)
Опция Before (До) дает вам возможность вставить новую определяющую точку перед первой.
Опция Close (Замкнуть) режима редактирования определяющих точек замыкает сплайн и делает доступной опцию Open (Разомкнуть).
Опция Delete (Удалить) предназначена для удаления определяющей точки. В случае применения этой опции выдается запрос:
Specify control point <exit>: (Управляющая точка <выход>:)
Указанная вами определяющая точка будет удалена из сплайна, а сплайн будет пересчитан.
Опция Move (Перенести) дает возможность задать новое положение определяющих точек. Система AutoCAD в этом случае запрашивает:
Specify new location or [Next/Previous/Select Point/'eXit] <N>: (Новое положение или [След/Пред/Выбрать точку/выХод] <С>:)
Система подсвечивает первую определяющую точку. У вас в этот момент есть возможность или указать новое положение данной точки, или переместиться на следующую (предыдущую) точку, или указать другую определяющую точку.
Опция Purge (Очистить) удаляет информацию об определяющих точках сплайна. После этого у вас не будет доступа к определяющим точкам (только к управляющим точкам каркаса).
Опция Tangents (Касательные) изменяет начальное и конечное граничные условия сплайна. Первый запрос системы:
Specify start tangent or [System default}: (Kacamejibnan в начальной точке или [по Умолчанию]:)
Укажите точку, определяющую направление касательной, или нажмите клавишу <Enter> для сохранения старого угла. Далее:
Specify end tangent or [System default]: (Касательная в конечной точке или [по Умолчанию]:)
Задайте направление касательной. Система AutoCAD возвращается к предыдущему выбору опций редактирования определяющих точек. Если сплайн замкнут, то в опции Tangent (Касательная) выдается всего лишь один запрос направления касательной.
Опция toLerance (ДОПуск) — изменяет допуск, задающий возможное отклонение сплайна от определяющих точек. При изменении допуска сплайн пересчитывается. Задание большего значения допуска позволяет построить более плавную кривую. При нулевом допуске сплайн точно проходит через определяющие точки. Запрос системы:
Enter fit tolerance <1.0000E-10>: (Допуск <1.0000Е-10>:)
В скобках приводится предыдущее значение допуска. Введите новое значение или нажмите клавишу <Enter>.
Опция eXit (выХод) завершает режим редактирования определяющих точек.
Теперь продолжим разбор вариантов ответа на запрос Enter an option [Fit Data/Close/Move vertex/Refine/rEverse/Undo]: (Задайте опцию [Определяющие/Замкнутъ/Перенести/Исправить/ ОБратно/ОТменить/выХод]:).
Следующая опция после Fit Data (Определяющие) — Close (Замкнуть). Она замыкает сплайн, одновременно удаляя из него данные определяющих точек.
Опция Move (Перенести) служит для изменения положения управляющих точек каркаса сплайна. При этом следует первый запрос:
Specify new location or [Next/Previous/Select Point/eXit] <N>: (Новое положение или[ След/Пред/Выбрать точку/выХод] <С>:)
Система AutoCAD подсвечивает первую управляющую точку каркаса. Можно в этот момент либо указать новое положение данной точки, либо переместиться на следующую (предыдущую) вершину, либо выбрать другую управляющую точку.
Опция (режим) Refine (Исправить) предназначена для улучшения качества линии сплайна. В этом случае следует такой запрос:
Enter a refine option [Add control point/Elevate order/Weight/eXit] <eXit>: (Задайте опцию [Добавить управляющую точку/Повысить порядок/Вес/выХод] <выХод>:)
Опция Add control point (Добавить управляющую точку) позволяет увеличить количество управляющих точек, не изменяя геометрии линии, что облегчает процесс управления формой сплайна. Затем следует запрос:
Specify a point on the spline <exit>: (Точка на сплайне <выход>:)
После указания ее система AutoCAD добавляет новую управляющую точку вблизи текущей и повторяет запрос о точке на сплайне.
Опция Elevate order (Повысить порядок) изменяет количество управляющих точек сплайна. После чего следует запрос:
Enter new order <4>: (Новое значение порядка <4>:)
Если увеличить порядок, то увеличится количество управляющих точек. Максимальное значение — 26.
Опция Weight (Вес) позволяет изменить вес (т. е. влияние) управляющей точки.
Enter new weight (current = 1.0000) or [Next/Previous/Select point/eXit] <N>:
(Новое значение веса (текущее - 1.0000) или [След/Пред/Выбрать точку/ выХод] <С>:)
Самым важным точкам сплайна рекомендуется давать соответственно и больший вес. В обычной ситуации веса всех точек сплайна равны единице.
Опция eXit (выХод) завершает работу в режиме опции Refine (Исправить).
Опция rEverse (ОБратно) переставляет управляющие точки сплайна в обратной последовательности.
Опция Undo (Отменить) отменяет последнюю операцию команды.


Глава 4. Свойства

    • Свойства
    • 4.1. Цвета
    • 4.2. Типы линий и масштабы
    • 4.3. Слои
    • 4.4. Веса линий
    • 4.5. Гиперссылки
    • 4.6. Редактирование свойств


До сих пор мы рисовали объекты, не особенно заботясь об их оформлении. Однако у каждого примитива могут быть свои цвет, слой, тип линии, масштаб типа линии, стиль печати, вес линии, гиперссылка и высота — все это в данной версии AutoCAD отнесено к свойствам. Следует напомнить, что определить текущие значения свойств объекта можно, например, с помощью команды LIST (СПИСОК).
В предыдущей версии AutoCAD была одна панель Object Properties (Свойства объектов), с помощью которой можно было управлять свойствами. Разработчики системы AutoCAD 2004 разбили эту панель на две.
Основной панелью инструментов, предназначенной для работы со свойствами, теперь является панель Properties (Свойства). Эта панель приведена на рис. 4.1. В повседневной работе рекомендуем держать ее в фиксированном горизонтальном положении выше графического экрана.

Рис. 4.1. Панель Properties

В данной панели расположены четыре раскрывающихся списка (слева направо):

  • Color Control (Цвета);
  • Linetype Control (Типы линий);
  • Lineweight Control (Веса линий);
  • Plot Style Control (Стили печати).

Значения, установленные в списках, определяют текущие установки свойств — именно такие свойства будут присваиваться новым объектам, пока эти значения не будут изменены. Список Plot Style Control (Стили печати) может быть у вас отключен — это означает, что в рисунке не используются именованные стили печати (о стилях печати см. гл. 6).
Еще одна панель, которая будет предметом рассмотрения в данной главе, — Layers (Слои) (рис. 4.2). Ее тоже желательно держать в фиксированном горизонтальном положении выше графического экрана.

Рис. 4.2. Панель Layers

В панели расположены три кнопки:

  • Layers Properties Manager (Диспетчер свойств слоев);
  • Make Object's Layer Current (Сделать слой объекта текущим);
  • Layer Previous (Предыдущий слой).

Кроме того, в панель Layers (Слои) входит раскрывающийся список слоев, который показывает имя и основные характеристики текущего слоя.
Первые четыре пункта падающего меню Format (Формат) (рис. 4.3) также управляют текущими значениями свойств.

Рис. 4.3. Меню Format


4.1. Цвета

Первый (слева направо) раскрывающийся список (см. рис. 4.1) панели Properties (Свойства) называется Color Control (Цвета). Основное его назначение — устанавливать текущее значение цвета. По умолчанию текущим значением является обычно значение ByLayer (Послою), т. е. нужно взять значение цвета от текущего слоя. Текущим слоем на рис. 4.2 является слой с именем 0, и в данный момент у слоя 0 основным цветом является черный. Поэтому создаваемые вами новые объекты рисуются черными линиями на белом или сером фоне (если фон черный, то цвет объектов будет белым). Подробнее об этом рассказано в разд. 4.3. Если вы хотите в качестве текущего установить конкретное значение цвета, не зависящее от слоя, это можно сделать, раскрыв с помощью кнопки [image] список Color (Цвета) (рис. 4.4).

Рис. 4.4. Раскрывающийся список Color

Щелкните с помощью левой кнопки мыши по строке с тем цветом, который вы хотите сделать текущим (например, с красным). Список закроется и покажет новое текущее значение цвета. Попробуйте теперь нарисовать, например, отрезок — он будет иметь красный цвет.
Раскрывающийся список Color Control (Цвета) может также использоваться для изменения цвета существующего объекта. Чтобы изменить цвет только что нарисованного вами красного отрезка на синий, выделите сначала этот отрезок (у него появятся ручки). При наличии в рисунке выделенного объекта список цветов сразу же покажет значение цвета этого объекта. Если в рисунке выделены сразу несколько примитивов, то список покажет их цвет, если цвет у них одинаков, или покажет пустое значение, если цвета не всех отмеченных объектов совпадают.
После выделения отрезка раскройте список цветов и щелкните по строке с цветом Blue (Синий) (рис. 4.5).

Рис. 4.5. Изменение цвета объекта с помощью раскрывающегося списка Color Control

Список закроется и у отрезка будет новый цвет — Blue (Синий). Пока ручки у отрезка подсвечены, список Color Control (Цвета) показывает цвет выделенного объекта. Если с помощью нажатия клавиши <Esc> сбросить выделение ручек, в поле опять восстановится текущее значение цвета для новых объектов.
Если вас интересуют более тонкие оттенки цвета, то вы можете воспользоваться строкой Select Color (Выбор цвета) в раскрывающемся списке Color Control (Цвета). Она вызывает диалоговое окно Select Color (Выбор цвета) (рис. 4.6), в котором приведена полная палитра цветов, доступных в данной версии системы AutoCAD.
Это окно нам уже встречалось в гл. 2 (см. рис. 2.101), но там были заблокированы кнопки со служебными значениями цветов ByLayer (Послою) и ByBlock (Поблоку). Цвет можно выбрать на любой из трех вкладок — Index Color (Цвет по номеру), True Color (Точный цвет) (см. рис. 2.102 и 2.103) и Color Books (Цветовые книги) (см. рис. 2.104). Работа с этими вкладками рассмотрена в разд. 2.15.

Рис. 4.6. Диалоговое окно Select Color, вкладка Index Color

Выбранный вами цвет появится в списке Color Control (Цвета). Наименование цвета зависит от того, на какой вкладке он был выбран, и может быть одного из четырех видов:

  • английское название основного цвета (например, Red (Красный));
  • номер цвета из вкладки Index Color (Цвет по номеру), от 8 до 255;
  • тройка чисел, в соответствии со схемой представления цвета RGB (например, 179,230,127);
  • название из цветовой книги (например, PANTONE Violet 0631 С).

Основными цветами в системе AutoCAD являются первые семь цветов с номерами от 1 до 7:

  • 1 — Red (Красный);
  • 2 — Yellow (Желтый);
  • 3 — Green (Зеленый);
  • 4 — Cyan (Голубой);
  • 5 — Blue (Синий);
  • 6 — Magenta (Фиолетовый);
  • 7 — White (Белый), может быть на самом деле черным или белым, в зависимости от цвета фона графического экрана.

Эти семь цветов всегда присутствуют в списке Color Control (Цвета). Другие будут появляться в списке по мере того, как вы их будете выбирать в диалоговом окне Select Color (Выбор цвета).
Пункт Color (Цвета) падающего меню Format (Формат) (см. рис. 4.3) также вызывает диалоговое окно выбора цвета.
Команда COLOR (ЦВЕТ), вводимая с клавиатуры, является еще одним способом задания текущего цвета. Она опять-таки вызывает диалоговое окно Select Color (Выбор цвета).


4.2. Типы линий и масштабы

Тип линии и масштаб типа линии — еще два важных свойства линейных объектов. Раскрывающийся список Linetype Control (Типы линий) является вторым слева списком в панели Properties (Свойства). Откройте его и посмотрите, какие типы линий содержатся в нем. Окажется, что список почти пуст (рис. 4.7).

Рис. 4.7. Раскрывающийся список Linetype Control

В нем помимо двух служебных значений ByLayer (Послою) и ByBlock (По-блоку), которые рассмотрены далее, есть только тип линии Continuous, используемый в качестве имени для обычной сплошной тонкой линии. Чтобы загрузить другие типы линий, щелкните по строке Other (Другой). Раскроется диалоговое окно Linetype Manager (Диспетчер типов линий) (рис. 4.8).
Это окно позволяет назначить новый текущий тип линии, удалить существующий и загрузить новый тип линии. В центральной части окна в форме списка приводятся имена типов линий, которые уже загружены в файл вашего рисунка. К каждому типу линии имеется соответствующее пояснение и приведен их внешний вид. Чтобы загрузить новые типы линий, нажмите кнопку Load (Загрузить). После этого на экране появится диалоговое окно Load or Reload Linetypes (Загрузка или перезагрузка типов линий) (рис. 4.9).

Рис. 4.8. Диалоговое окно Linetype Manager

Рис. 4.9. Диалоговое окно Load or Reload Linetypes

3 верхней части окна показано имя файла (acadiso.lin), из которого читают--л доступные типы линий. Опытные пользователи могут создавать новые типы линий, сохраняя их в своих файлах с расширением Ни. Кнопка File (Файл) служит для того, чтобы задать имя файла, из которого будет выполнена подгрузка нового типа линии.
С помощью вертикальной линейки прокрутки можно найти и затем отметить левой кнопкой мыши нужный вам тип линии, например, DASHDOT (штрихпунктирная). После этого следует нажать кнопку ОК и выбранный тип линии будет добавлен в список типов линий окна Linetype Manager (Диспетчер типов линий). Однако если вы хотите загрузить сразу все типы линий, то нужно в диалоговом окне Load or Reload Linetypes (Загрузка или перезагрузка типов линий) установить курсор внутри области, в которой перечисляются имена типов линий, и нажать правую кнопку мыши. Появится контекстное меню, в котором имеются всего две строки. В нем нужно выбрать строку Select All (Выбрать все) (рис. 4.10).

Рис. 4.10. Контекстное меню выбора загружаемых типов линий

Система AutoCAD помечает синим цветом все типы линий, а нажатие кнопки ОК загружает их в ваш рисунок. Теперь, после закрытия диалогового окна Linetype Manager (Диспетчер типов линий), в списке типов появилось большое количество новых наименований. Отметьте в раскрывающемся списке Linetype Control (Типы линий) тот тип, который вы хотите сделать текущим, например, ZIGZAG (Зигзаг). Нарисуйте четыре новых отрезка. Они будут созданы с тем цветом и тем типом линии, которые установлены текущими в панели Properties (Свойства) (рис. 4.И).
Если на одном или нескольких примитивах рисунка высветить ручки, тогда раскрывающийся список Linetype Control (Типы линий) может быть использован для изменения типа линий выделенных объектов (аналогично использованию раскрывающегося списка Color Control (Цвета) для изменения цвета объектов).
Вызов диалогового окна Linetype Manager (Диспетчер типов линий) может быть осуществлен также пунктом Linetype (Типы линий) падающего меню Format (Формат) и командой LINETYPE (ТИПЛИН), вводимой с клавиатуры.
Еще одно свойство примитива — масштаб типа линии. Если вы назначили объекту какой-то тип линии и хотели бы изменить размеры составляющих элементов (штрихов, точек, пробелов между штрихами, звеньев зигзагообразной линии и др.), то вы можете изменить масштаб типа линии для этого объекта. По умолчанию масштаб типа линии равен 1 и размеры элементов типа линии совпадают с описанными в эталоне этого типа. На рис. 4.12 показаны два одинаковых отрезка с одинаковыми типами линии, но с разными масштабами.

Рис. 4.11. Установка текущего типа линии

Рис. 4.12. Влияние масштаба типа линии

Значение масштаба типа линии объекта получается как произведение двух масштабов: глобального и собственного. Глобальный масштаб распространяется сразу на все объекты чертежа, а собственный назначается каждому объекту индивидуально.
Получить доступ к действующим значениям обоих масштабов (Global scale factor (Глобальный масштаб) и Current object scale (Текущий собственный масштаб)) можно, воспользовавшись кнопкой Show details (С подробностями) окна Linetype Manager (Диспетчер типов линий), которая добавляет в нижней части окна дополнительную информацию (рис. 4.13).

Рис. 4.13.Глобальный и текущий масштабы типа линии в диалоговом окне Linetype Manager

Изменение глобального масштаба окажет влияние на все элементы рисунка. Так, если предыдущее значение масштаба было равно 1, а новое — 2, то все элементы (штрихи и т. п.) объектов чертежа сразу увеличат свою длину в два раза. Реальная величина масштаба типа линии новых объектов будет произведением глобального и собственного масштабов.
Глобальный масштаб является наследием более ранних версий системы AutoCAD, в которых не было индивидуального (собственного) масштаба. Команда LTSCALE (ЛМАСШТАБ) позволяет с клавиатуры изменить глобальный масштаб типов линий. Его значение хранится в системной переменной LTSCALE (о системных переменных см. разд. 11.1). Значение текущего собственного масштаба заносится в системную переменную CELTSCALE.


4.3. Слои

При создании сложных рисунков возникает необходимость присвоения имен отдельным объектам или группам объектов, чтобы ими можно было удобнее оперировать в дальнейшей работе. Особенно это важно при разработке сложных рисунков и своих собственных приложений, функционирующих в среде AutoCAD. Данной цели служит еще одно свойство примитивов — слой. Более того, слой обладает неоценимой возможностью замораживания (выключения), когда ряд второстепенных в данный момент объектов можно, не удаляя, сделать невидимыми, что позволит успешнее работать с главными объектами.
Основной командой работы со слоями является команда LAYER (СЛОЙ), которой соответствуют кнопка [image] панели Layers (Слои) и пункт Layer (Слои) падающего меню Format (Формат).
Команда LAYER (СЛОЙ) открывает диалоговое окно Layer Properties Manager (Диспетчер свойств слоев) (рис. 4.14).

Рис. 4.14. Диалоговое окно Layer Properties Manager

Область Named layer filters (Именованные фильтры слоев) в левом верхнем углу — это область, в которой можно задать, все ли слои надо выводить в данное диалоговое окно, и если не все, то какой применить фильтр (т. е. критерий выборки). Раскрывающийся список содержит три варианта фильтров:

  • Show all layers (Показать все слои);
  • Show all used layers (Показать все используемые слои);
  • Show all Xref dependent layers (Показать все зависимые от ссылок слои).

К используемым относятся слои, на которых есть какие-то объекты рисунка, блоков или внешних ссылок (о блоках и внешних ссылках см. гл. 7).
С помощью кнопки [image] можно открыть диалоговое окно Named Layer Filters (Именованные фильтры слоев) (рис. 4.15) и создать свой фильтр слоев, присвоив ему имя.

Рис. 4.15. Диалоговое окно Named Layer Filters

В раскрывающемся списке Filter name (Имя фильтра) вы можете ввести имя своего фильтра и сохранить его в рисунке с помощью кнопки Add (Добавить). Установки для фильтра должны быть сделаны с помощью расположенных ниже раскрывающихся списков и полей:

  • On/Off (Вкл/Откл);
  • Freeze/Thaw (Заморожен/Разморожен);
  • Current viewport (Активный ВЭкран);
  • New viewport (Новый ВЭкран);
  • Lock/Unlock (Блокирован/Разблокирован);
  • Plot (Печать);
  • Color (Цвет);
  • Lineweight (Вес линии);
  • Linetype (Тип линии);
  • Plot style (Стиль печати).

Установки, которые нужно сделать в этих полях для своего фильтра, будут понятны после ознакомления с описанными далее свойствами слоев.
Кнопки Delete (Удалить) и Reset (Сброс) предназначены, соответственно, для удаления именованных фильтров и восстановления значений, предлагаемых системой по умолчанию. Новая кнопка Delete All (Удалить все) позволяет удалить из рисунка все фильтры, кроме трех стандартных.
Кнопка Close (Закрыть) закрывает диалоговое окно Named Layer Filters (Именованные фильтры слоев), а кнопка Help (Справка) вызывает соответствующий раздел справочной системы.
Продолжим рассмотрение диалогового окна Layer Properties Manager (Диспетчер свойств слоев) (см. рис. 4.14). Флажки Invert filters (Инвертировать фильтры) и Apply to layers toolbar (Применить к панели слоев) позволяют, соответственно, сменить фильтр на противоположный или применить его к списку слоев панели инструментов Layers (Слои).
Один слой является текущим (активным). Его имя видно в левом верхнем углу ниже области Named layer filters (Именованные фильтры слоев):
Current Layer: 0 (Текущий слой: 0)
Текущий слои — это слой, на котором будут создаваться новые объекты.
В правом верхнем углу расположены следующие кнопки:

  • New (Новый) — создает новый слой:
  • Delete (Удалить) — удаляет из рисунка слой (это возможно только в том случае, если слой является неиспользуемым);
  • Current (Текущий) — устанавливает имя другого слоя в качестве текущего, это имя заносится в системную переменную CLAYER;
  • Show details (С подробностями) — показывает в нижней части окна свойства отмеченного слоя в подробном виде;
  • Save state (Сохранить состояние) — сохраняет текущие установки слоев в файле конфигурации с расширением las для последующего их восстановления;
  • State Manager (Диспетчер конфигураций слоев) — вызывает диалоговое окно, в котором можно выбрать восстановление установок слоев, ранее сохраненных в файле с расширением las.

В центральной части окна находится список слоев рисунка и их характеристик (свойств). В новом чертеже обязательно присутствует слой 0, который по умолчанию является текущим и который нельзя удалить. Каждый слой имеет характеристики, которые выводятся в виде заголовков столбцов. Если они не видны полностью, можно, устанавливая курсор на разделитель между столбцами, двигать его влево или вправо до такого места, чтобы нужные наименования хорошо читались. Другой способ — щелкнуть с помощью правой кнопки мыши по строке заголовков столбцов, после чего откроется контекстное меню с единственным пунктом Maximize column headings (Развернуть заголовки). Щелчок левой кнопкой мыши по появившейся строке разворачивает наименования столбцов полностью, но при этом часть столбцов может уйти вправо за пределы окна.
Характеристики слоев следующие:

  • Name (Имя) — имя слоя, длиной от 1 до 255 символов;
  • On (Вкл) — состояние включения слоя (включен или выключен);
  • Freeze in all VP (Замороженный на всех ВЭ) — состояние замораживания относительно всех видовых экранов одновременно (заморожен или разморожен);
  • Lock (Блокированный) — состояние блокированности (блокирован или разблокирован);
  • Color (Цвет) — текущий цвет для объектов слоя, у которых в качестве цвета задано значение By Layer (Послою);
  • Linetype (Тип линии) — текущий тип линии для объектов слоя, у которых в качестве типа линии задано значение ByLayer (Послою);
  • Lineweight (Вес линии) — текущий вес линии для объектов слоя, у которых в качестве веса задано значение ByLayer (Послою);
  • Plot Style (Стиль печати) — стиль печати, применяемый при выводе к слою;
  • Plot (Печать) — состояние объектов слоя относительно вывода на внешнее устройство (печатать или не печатать).

При работе с видовыми экранами в пространстве листа к перечисленным характеристикам добавятся и другие, которые рассмотрены в гл. 10. Разберем приведенные основные характеристики более подробно.
Имя слоя назначается пользователем и может иметь длину от 1 до 255 символов (символы — латинские и русские буквы, цифры и некоторые знаки). Не допускаются в именах запятые, точки, звездочки и другие. Пробелы в именах допускаются, но могут вызвать трудности в некоторых операциях. Для создания нового слоя нажмите кнопку New (Новый), после чего будет добавлена строка нового слоя с условным именем Layerl (Слой!) (а по мере создания слоев число в конце имени по умолчанию будет увеличиваться). Имя слоя в первый момент выделено и доступно для редактирования (рис. 4.16).

Рис. 4.16. Задание имени нового слоя при его создании

В это время вы можете изменить имя на любое удобное вам, а можете согласиться с предложенным. Следует иметь в виду, что имена слоев в одном рисунке не должны повторяться.
Давайте согласимся с именем Layerl (Слой1) в качестве нового слоя, нажав кнопку ОК. Новый слой будет создан с теми же характеристиками, что и слой 0, имеющий на рис. 4.16 установки, присваиваемые по умолчанию.
Следующая после имени характеристика слоя — On (Вкл). Если у слоя в этом столбце стоит значок [image] (желтая лампочка), то слои считается включенным, если значок [image] (синяя лампочка) — то выключенным.
Объекты, расположенные на слое, который выключается, становятся временно невидимыми (до тех пор, пока слой не будет включен). Любой слой, даже текущий, может быть выключен (для текущего слоя система AutoCAD при выключении выдает предупреждение, поскольку примитивы, создаваемые на этом слое, будут временно исчезать).
Третья характеристика слоя — Freeze in all VP (Замороженный на всех ВЭ). Если у слоя в этом столбце стоит значок [image] (желтое солнце), то слои считается размороженным, если значок [image] (синяя снежинка) — то замороженным.
Объекты, расположенные на слое, который замораживается, становятся временно невидимыми (до тех пор, пока слой не будет разморожен). Любой слой, кроме текущего, может быть заморожен.
Таким образом, объекты на данном слое видны только в том случае, если слой включен и разморожен одновременно.
Следующая характеристика слоя — Lock (Блокированный). Если у слоя в этом столбце стоит значок [image] (открытый замок), то слой считается разблокированным, если значок [image] (закрытый замок) — то блокированным. На блокированном слое вы можете создавать новые объекты, но существующие примитивы редактировать или удалять нельзя.
Характеристика Color (Цвет) говорит о реальном цвете объектов слоя, у которых в качестве цвета задано специальное значение ByLayer (Послою). Если в диалоговом окне Layer Properties Manager (Диспетчер свойств слоев) щелкнуть с помощью левой кнопки мыши по квадратному значку цвета слоя или наименованию цвета, то раскроется диалоговое окно Select Color (Выбор цвета), которое нам уже известно (см. рис. 4.6). При изменении цвета слоя изменится цвет и у тех примитивов, которые лежат на этом слое и имеют в качестве цвета значение ByLayer (Послою) (это значение тоже присутствует в диалоговом окне Select Color (Выбор цвета)).
Следующая характеристика — Linetype (Тип линии). Она задает реальный тип линии, которым будут нарисованы объекты этого слоя, имеющие в качестве типа значение ByLayer (Послою). Если в диалоговом окне Layer Properties Manager (Диспетчер свойств слоев) щелкнуть с помощью левой кнопки мыши по значку типа линии или наименованию типа линии (чаще всего это Continuous), то раскроется диалоговое окно Select Linetype (Выбор типа линии) (рис. 4.17), в котором нужно выбрать нужный вам тип линии.
Если требуемого типа линии в окне нет, можно выполнить его загрузку с помощью кнопки Load (Загрузить).
Очередная характеристика слоя — Lineweight (Вес линии). Она задает реальный вес (толщину) линии, которым будут нарисованы объекты этого слоя, имеющие в качестве веса значение ByLayer (Послою). Если в диалоговом окне Layer Properties Manager (Диспетчер свойств слоев) (см. рис. 4.14) щелкнуть с помощью левой кнопки мыши по значку веса линии, то раскроется диалоговое окно Lineweight (Вес линии) (рис. 4.18), в котором вы можете установить нужный вес. О весах см. разд. 4.4.

Рис. 4.17. Диалоговое окно Select Linetype

Рис. 4.18. Диалоговое окно Lineweight

Характеристика Plot Style (Стиль печати) (см. рис. 4.14) описывает стиль печати, применяемый при выводе слоя. О стилях печати см. разд. 6.3.
Характеристика Plot (Печать) указывает, будут ли выводиться на печать объекты слоя, если даже он включен и разморожен. Значок [image] (неперечеркнутый принтер) показывает, что объекты слоя будут печататься, а значок [image] (зачеркнутый принтер) — не будут. Вспомогательные слои или слои, которые в данный момент не нужны, можно таким образом отсекать от вывода на графопостроитель или принтер. Разумеется, если слой выключить или заморозить, то его объекты тоже не будут распечатываться.
Раскрывающийся список Layer (Слои) панели Layers (Слои) (пример приведен на рис. 4.19) теперь имеет большую ширину, чем он имел в предыдущих версиях системы AutoCAD в панели Object Properties (Свойства объектов). Он содержит имена всех слоев и их свойств и в закрытом виде показывает имя текущего слоя и значки его основных характеристик.

Рис. 4.19. Раскрывающийся список Layer

С помощью этого списка можно назначить новый текущий слой. Для этого надо открыть список слоев и переместить указатель на строку того слоя, который должен стать текущим, а затем щелкнуть левой кнопки мыши по имени слоя. Тот же список дает возможность быстрой корректировки основных характеристик любого существующего слоя: надо открыть список и щелкнуть по тому значку слоя, который должен изменить свой вид на противоположный. Для того чтобы закрыть измененный раскрывшийся список, необходимо щелкнуть левой кнопкой мыши в любой свободной области графического экрана.
Однако раскрывающийся список Layer (Слои) нельзя использовать для создания нового слоя.
Правая кнопка мыши, при нахождении курсора внутри списка слоев диалогового окна Layer Properties Manager (Диспетчер свойств слоев) (см. рис. 4.14), вызывает контекстное меню, приведенное на рис. 4.20.

Рис. 4.20. Контекстное меню операций над слоями

В это меню входят следующие операции над слоями:

  • Make Current (Сделать текущим);
  • New Layer (Новый слой);
  • Select All (Выбрать все);
  • Clear All (Очистить все);
  • Select all but current (Выбрать все, кроме текущего);
  • Invert selection (Инвертировать выбор);
  • Invert layer filter (Инвертировать фильтр слоев);
  • Layer filters (Фильтры слоев);
  • Save layer states (Сохранить состояния слоев).

Кнопка [image] панели Layers (Слои) соответствует команде AI_MOLC, устанавливающей в качестве текущего слой того примитива, который вам нужно будет указать.
Запрос команды:
Select object whose layer will become current: (Выберите объект, слой которого должен стать текущим:)
После указания объекта его слой назначается текущим. Кнопка [image] соответствует команде LAYERP (СЛОЙП), которая позволяет
вернуться к предыдущему состоянию слоев, но со следующими ограничениями:

  • имена переименованных слоев не восстанавливаются;
  • удаленные слои не восстанавливаются;
  • новые слои не удаляются.

Замечание Работой команды LAYERP (СЛОЙП) управляет другая команда — LAYERPMODE (СЛОЙПРЕЖИМ), которая разрешает или запрещает работу LAYERP (СЛОЙП).

Если на одном или нескольких примитивах рисунка высветить ручки, тогда раскрывающийся список Layer (Слои) может быть использован для изменения слоя (т. е. переноса на другой слой) выделенных объектов, аналогично использованию раскрывающегося списка Color Control (Цвета) для изменения цвета объектов.


4.4. Веса линий

Вес линии — интересное свойство примитивов, которое появилось в системе начиная с AutoCAD 2000. Это толщина, с которой объект будет выводиться на устройство печати. Вы можете нарисовать объекты тонкой линией, но задать ненулевой вес и получить при этом жирные линии на листе бумаги.
На графическом экране объекты отображаются без весов, если кнопка режима LWT (ВЕС) выключена, и с весами, если включена. На рис. 4.21 приведены две группы одинаковых объектов, но в левой части экрана они имеют нулевой вес, а в правой — отличающийся от нулевого.
Веса не оказывают влияния на те объекты или их части, у которых есть другие способы назначения толщины: участки полилиний с ненулевой шириной, полосы, фигуры, заливки, надписи со шрифтами типа True Type, растровые изображения (о вставке растровых изображений см. разд. 8.1).
Текущее значение веса, которое присваивается новым объектам, устанавливается с помощью раскрывающегося списка Lineweight Control (Веса) (рис. 4.22), находящегося третьим слева в панели Properties (Свойства) (см. рис. 4.1), сразу после списка Linetype Control (Типы линий).

Рис. 4.21. Объекты с различными весами линий

Текущее значение веса линий может быть также задано с помощью команды LWEIGHT (ВЕСНИН) и соответствующего ей пункта меню Lineweight (Вес линий) падающего меню Format (Формат). Команда LWEIGHT (ВЕС-ЛИН) вызывает диалоговое окно Lineweight Settings (Параметры весов линий) (рис. 4.23).
В данном диалоговом окне можно выбрать новое текущее значение веса линий из списка допустимых значений (от 0 до 2,П мм). Установка флажка Display Lineweight (Отображать линии в соответствии с весами) равносильна включению кнопки режима LWT (ВЕС). Ползунок шкалы Adjust Display Scale (Масштаб экранного отображения) позволяет управлять масштабом весов при отображении их на графическом экране (эта настройка не влияет на величины весов, используемых при печати).
Раскрывающийся список Default (По умолчанию) задает величину веса для особого значения DEFAULT (ОБЫЧНЫЙ).
Вес с наименованием DEFAULT (ОБЫЧНЫЙ) чаше всего принимается равным 0,25 мм (0,01 дюйма). Это значение используется для веса, который применяется для основной массы элементов чертежа.
Если на одном или нескольких примитивах рисунка высветить ручки, тогда список Lineweight (Веса линий) может быть использован для изменения веса линий выделенных объектов (аналогично использованию раскрывающегося списка Color Control (Цвета) панели Properties (Свойства) для изменения цвета объектов — выбрать в списке новое значение и затем отключить ручки).

Рис. 4.22. Раскрывающийся список Lineweight Control

Рис. 4.23. Диалоговое окно Lineweight Settings


4.5. Гиперссылки

Гиперссылка — это свойство графического объекта ссылаться на другой рисунок, документ, электронную таблицу и любой другой файл, а также адрес страницы сети Интернет (URL), адрес электронной почты или вид текущего рисунка.
Вставка и редактирование гиперссылок выполняется с помощью команды HYPERLINK (ГИПЕРССЫЛКА), которой соответствует пункт Hyperlink (Гиперссылка) падающего меню Insert (Вставка).
Команда запрашивает объекты и, если выбрать объекты, не имеющие гиперссылок, вызывает диалоговое окно Insert Hyperlink (Вставка гиперссылки) (рис. 4.24).

Рис. 4.24. Диалоговое окно Insert Hyperlink с нажатой кнопкой Existing File or Web Page

В поле Text to display (Выводимый текст) нужно задать текст, который будет отображаться при прохождении курсора над объектом, имеющим данную гиперссылку. На рис. 4.25 показан значок гиперссылки [image] , появляющийся на экране с выводимым текстом Позиция 16а (гиперссылка привязана к внешней окружности).
Тип объекта, связываемого с примитивом рисунка с помощью гиперссылки, может быть выбран из левой колонки Link to (Связать с) диалогового окна Insert Hyperlink (Вставка гиперссылки) (см. рис. 4.24), в которой находятся наименования трех кнопок:

  • Existing File or Web Page (Имеющийся файл или Web-страница);
  • View of This Drawing (Вид из этого рисунка);
  • E-mail Address (Адрес электронной почты).

Рис. 4.25. Выводимый текст гиперссылки

Внешний вид окна Insert Hyperlink (Вставка гиперссылки) зависит от того, какая из кнопок колонки Link to (Связать с) в данный момент выбрана. На рис. 4.24 окно показано с нажатой кнопкой Existing File or Web Page (Имеющийся файл или Web-страница). В этом режиме основным является поле Type the file or Web page name (Введите имя файла или Web-страницы), в котором можно с помощью клавиатуры набрать имя файла или страницы Интернета. Для облегчения этой операции в правой части диалогового окна предусмотрены кнопки с общим заголовком Browse for (Обзор):

  • File (Файл) — открывает окно Browse for Web — Select Hyperlink (Обзор страниц — выбор гиперссылки), в котором можно указать имя файла или одну из стандартных Web-страниц (рис. 4.26);
  • Web Page (Web-страница) — открывает окно Browse the Web (Обзор в Интернете), в котором можно ввести URL-адрес нужной Web-страницы;
  • Target (Позиция) — в случае выбора для гиперссылки DWG-файла открывает окно Select Place in Document (Выбор позиции в документе) с иерархической структурой, в которой можно указать имя вида или вкладки, открываемых по гиперссылке. На рис. 4.27 показан пример, в котором DWG-файл имеет девять именованных видов во вкладке Model, а также вкладку листа с именем Presentation Plot.

Имена файлов или Web-страниц также можно указать с помощью списка Or select from list (Или выберите из списка) (см. рис. 4.24), в котором отображается один из трех вариантов списков (выбором варианта управляют расположенные слева кнопки):

  • Recent Files (Последние файлы) — список последних использованных файлов;
  • Browsed Pages (Просмотренные Web-страницы) — список последних открытых страниц сайтов Интернета;
  • Inserted Links (Вставленные ссылки) — список последних вставленных гиперссылок.

Рис. 4.26. Диалоговое окно Browse for Web — Select Hyperlink

Рис. 4.27. Диалоговое окно Select Place in Document

Если в качестве имени файла гиперссылки пользователь введет имя файла без полного пути, в поле Path (Путь) будет отображено имя найденного файла с путем. Если установить флажок Use relative path for hyperlink (Использовать относительный путь), то имя файла будет отображено без полного пути (каждый раз при поиске данной гиперссылки система будет брать относительный путь, а не абсолютный).
Диалоговое окно Insert Hyperlink (Вставка гиперссылки) с нажатой кнопкой View of This Drawing (Вид из этого рисунка) (рис. 4.28) предлагает в поле Select a view of this (Выберите вид чертежа) выбрать вид чертежа, который будет открываться по гиперссылке.

Рис. 4.28. Диалоговое окно Insert Hyperlink с нажатой кнопкой View of This Drawing

Диалоговое окно Insert Hyperlink (Вставка гиперссылки) с нажатой кнопкой E-mail Address (Адрес электронной почты) позволяет в качестве гиперссылки выбрать операцию отправки сообщения по электронной почте. Здесь нужно заполнить строки E-mail address (Адрес электронной почты) и Subject (Тема). В качестве помощи при вводе адреса электронной почты предлагается поле Recently used e-mail addresses (Последние использованные адреса электронной почты), из которого можно выбрать ранее применяемый адрес.
Когда пользователю нужно, чтобы гиперссылка, привязанная к какому-нибудь примитиву, сработала (т. е. открыла другой рисунок, файл, вид, страницу в Интернете или подготовила к отправке сообщение по электронной почте), то он должен выделить этот объект, щелкнув по нему, и с помощью правой кнопки мыши вызвать контекстное меню. В этом меню должно появиться подменю Hyperlink (Гиперссылка) (рис. 4.29).

Рис. 4.29. Контекстное меню редактирования объекта, имеющего гиперссылку

Далее щелчок по верхнему пункту контекстного меню Open (Открыть) позволит системе AutoCAD открыть окно, вид или файл, которые прицеплены в качестве гиперссылки (для этого автоматически вызывается программа открытия файла нужного типа, браузер или программа электронной почты).
Если вы в команде HYPERLINK (ГИПЕРССЫЛКА) в ответ на запрос о выборе объектов указываете примитив, у которого уже есть гиперссылка, то открывается окно Edit Hyperlink (Редактирование гиперссылки). Структура этого окна аналогична структуре окна Insert Hyperlink (Вставка гиперссылки), поэтому с ним можно выполнить операции, которые были только что рассмотрены. Дополнительной является кнопка Remove Link (Удалить ссылку), которая расположена в левой нижней части диалогового окна и предназначена для ликвидации существующей гиперссылки.


4.6. Редактирование свойств

Другие свойства примитивов — высота и уровень. Высота — это свойство примитива, применяемое в трехмерных построениях. Оно задает величину выдавливания вдоль оси Z, расположенной перпендикулярно осям X и Y. Например, чтобы круг преобразовать в цилиндр, его нужно выдавить на ненулевую высоту. Уровень — это сдвиг плоскости, в которой создан объект, относительно основной плоскости XY (вдоль оси Z). Подробнее об этом см. в гл. 9.
Основные свойства (слой, цвет, тип линии, вес линии), как было сказано ранее, можно редактировать с помощью ручек и раскрывающихся списков Layer Control (Слой), Color Control (Цвета), Linetype Control (Типы линий), Lineweight Control (Веса линий) панели Properties (Свойства).
Универсальная команда PROPERTIES (OKHOCB) дает возможность редактирования любых свойств объектов, а также элементов геометрии. Команде соответствуют кнопка [image] панели Standard (Стандартная) и пункт Properties (Свойства) падающего меню Tools (Сервис), а также пункт Properties (Свойства) падающего меню Modify (Редакт). Еще один способ вызвать команду — ввести на клавиатуре комбинацию клавиш <CtrI>+<!>. Команда PROPERTIES (OKHOCB) после своего вызова открывает окно PROPERTIES (СВОЙСТВА) (рис. 4.30). По своим внешним признакам это окно является панелью, но чтобы не путать ее с панелью инструментов Properties (Свойства) (см. рис. 4.1), будем называть ее по традиции предыдущих версий системы окном.
Существует возможность быстрого вызова этого окна. Если в рисунке нет выделенных объектов, то двойной щелчок по объекту, являющемуся отрезком, прямой, лучом, полилинией, дугой, окружностью, сплайном, эллипсом, областью тоже выводит на экран окно PROPERTIES (СВОЙСТВА). Если в рисунке был выделен объект (не тот, по которому будет выполнен двойной щелчок) или объекты, то двойной щелчок также откроет окно.
Содержимое окна PROPERTIES (СВОЙСТВА) существенно зависит от того, какие объекты в данный момент выделены в рисунке.

Рис. 4.30. Окно PROPERTIES (в развернутом виде)

Если нет выбранных объектов, то в раскрывающемся списке в верхней части окна написано No selection (Ничего не выбрано) (см. рис. 4.30) и окно показывает текущие установки рисования. Если в графическом экране отметить объект, то содержимое окна PROPERTIES (СВОЙСТВА) изменится и будет показывать свойства выбранного примитива, а раскрывающийся список укажет имя примитива. Когда выбраны сразу несколько объектов, то окно показывает только свойства, присутствующие у всех этих объектов (например, не у всякого примитива есть радиус, площадь).
Если какое-то свойство (например, цвет) у этих объектов имеет разные значения, то в поле свойства выводится значение *VARIES*. Справа от раскрывающегося списка находятся три следующие кнопки:

  • Juck Select (Быстрый выбор) — для быстрого выбора объектов с помощью фильтров в насыщенном рисунке (рассмотрена в разд. 3.1);
  • Select Objects (Выбор объектов) — для выбора объектов заново;
  • Toggle value of PICKADD Sysvar (Изменить значение системной переменной PICKADD) — изменяет значение системной переменной PICKADD с 1 на 0; если значение переменной PICKADD равно 1, то окно PROPERTIES (СВОЙСТВА) отображает свойства, общие для всех выбранных в данный момент объектов, а если 0 — то только последнего из выбранных; если переменной PICKADD установлено значение 0, то рассматриваемая кнопка имеет другое изображение - [image] (щелчок по этой кнопке меняет значение системной переменной PICKADD с 0 на 1).

Можно помечать примитивы, перемещая плавающее окно свойств по экрану и щелкая левой кнопкой мыши по нужному объекту. Открытое окно PROPERTIES (СВОЙСТВА) не препятствует вводу других команд системы AutoCAD.
В рассматриваемой версии системы AutoCAD окно свойств не только изменило свой дизайн, но у него появилась еще возможность сворачивания. Если щелкнуть по значку [image] , расположенному в левом нижнем углу окна, то окно свернется до вертикальной полосы с заголовком (рис. 4.31).

Рис. 4.31. Окно Properties (в свернутом виде)

После этого для временного развертывания окна PROPERTIES (СВОЙСТВА) нужно только подвести курсор к полосе заголовка свернутого окна (при уходе курсора окно снова свернется), а для постоянного развертывания необходимо щелкнуть по значку [image] Щелчок по значку [image] , расположенному в самом низу диалогового окна, приводит к вызову контекстного меню, которое управляет характеристиками самого окна (рис. 4.32). Это же меню появится, если щелкнуть правой кнопкой мыши по синей полосе заголовка, ограничивающей окно слева.

Рис. 4.32. Контекстное меню характеристик диалогового окна PROPERTIES

Контекстное меню имеет такие пункты:

  • Move (Переместить);
  • Size (Размер);
  • Close (Закрыть);
  • Allow Docking (Разрешить закрепление);
  • Auto-hide (Автоматически скрывать);
  • Description (Описание).

Если пункт Auto-hide (Автоматически скрывать) выбран, то это указывает на то, что окно автоматически свернется, если курсор уйдет из зоны окна. Если этот пункт не выбран, то это говорит о том, что окно PROPERTIES (СВОЙСТВА) находится в развернутом виде.
Если выбран пункт Allow Docking (Разрешить закрепление), то окно может быть переведено из плавающего состояния в фиксированное на один из краев графического экрана (точно так же, как это было для панелей инструментов).
Выбор пункта Description (Описание) позволяет нижнюю часть окна использовать для подсказок, описывающих свойство, соответствующее помечаемой клетке при редактировании (например, Specifies the current color (Указывает текущий цвет)). Если пункт не выбран, то подсказки не выводятся.
Центральная часть окна PROPERTIES (СВОЙСТВА) оформлена в виде таблицы, имеющей вкладки. Список вкладок зависит от того, что в данный момент выбрано. Если нет выбранных объектов, то в качестве вкладок выводятся General (Общие), Plot Style (Стиль печати), View (Вид) и Misc (Разное). Если на графическом экране есть выбранные объекты (с ручками), то выводится вкладка General (Общие), к которой в зависимости от типов объектов добавлена Geometry (Геометрия) или другие вкладки (в зависимости от сложности объектов). Справа от наименования вкладки стоит значок [image] или [image] , щелчок по которому позволяет развернуть или свернуть свойства, расположенные в данной вкладке.
Если вы хотите изменить какое-нибудь свойство или геометрическую характеристику объекта, прочитанного в окне PROPERTIES (СВОЙСТВА), щелкните по соответствующей строке. Затем введите новое значение, если это цифровое поле, или откройте раскрывающийся список с перечнем допустимых значений данного свойства (например, Color (Цвет)) и выберите новое значение (рис. 4.33).

Рис, 4.33. Выбор нового значения свойства с помощью раскрывающегося списка

Для перемещения вкладок можно пользоваться вертикальной линейкой прокрутки, расположенной в левой части окна свойств.
После корректировки свойств можно закрыть окно PROPERTIES (СВОЙСТВА) щелчком по значку [image] в левом верхнем углу окна.
Команда CHPROP (СВОЙСТВА) позволяет изменять свойства объекта из командной строки. После запроса на выбор объектов будет выдан следующий запрос:
Enter property to change [Color/LAyer/LType/ltScale/LWeight/Thickness]:
(Укажите изменяемое свойство [Цвет/Слой/Тип линии/Лмасштаб/ вЕс линии/Высота]:)
Опции, используемые для изменения, очевидны. При корректировке цветов пользователю будут доступны обычные цвета AutoCAD с номерами от 1 до 255, а также точные цвета и цвета из цветовых книг (стандартные цветовые книги располагаются в папке Color внутри папки Support программного обеспечения системы AutoCAD).
Команда CHANGE (ИЗМЕНИТЬ) — еще одна команда внесения изменений с помощью командной строки. Она запрашивает объекты, если они не были предварительно выбраны. Выбранные объекты должны быть параллельны плоскости текущей пользовательской системы координат (о системах координат см. разд. 9.1). Это условие не касается отрезков с нулевой высотой. Затем выдается запрос:
Specify change point or [Properties]: (Точка изменения или [Свойства]:)
Если указать точку, то она становится изменяемой точкой выбранного объекта (например, одна из конечных точек отрезка переносится в новую). В случае опции Properties (Свойства) выдается запрос:
Enter property to change [Color/Elev/LAyer/LType/ltScale/L Weight/Thickness]:
(Укажите изменяемое свойство /Цвет/Уровень/Слой/Тип линии/Лмасштаб/ в Ее линии/Высота!:)
По сравнению с опциями команды CHPROP (СВОЙСТВА) здесь есть еще одна — Elev (Уровень). Эта опция позволяет изменить расстояние от объекта до плоскости XY текущей системы координат (уровень по оси Z). Подробнее об уровне сказано в гл. 9.
В системе AutoCAD есть команда, позволяющая перенести свойства одного объекта на другой - команда MATCHPROP (КОПИРОВАТЬСВ). Кнопка [image] , соответствующая команде, находится в панели Standard (Стандартная). Команду можно вызвать также с помощью пункта Match Properties (Копирование свойств) падающего меню Modify (Редакт).
Первый запрос команды: Select source object: (Выберите исходный объект:)
На этот запрос необходимо указать объект, все или некоторые свойства которого будут переноситься на другие объекты. После выбора объекта выводится сообщение о текущих настройках команды КОПИРОВАТЬСВ (MATCHPROP):
Текущие активные настройки: (Current active settings:)
Сообщение продолжается перечислением тех свойств, которые команда собирается перенести на другой объект. Максимальный набор этих свойств показан на рис. 4.34 в виде флажков диалогового окна Property Settings (Настройки свойств): Color (Цвет), Layer (Слой), Linetype (Тип линии), Linetype Scale (Масштаб типа линии), Lineweight (Вес линий), Thickness (Высота), PlotStyle (Стиль печати), Dimension (Размер), Text (Текст), Hatch (Штриховка), а также добавленные в этой версии свойства полилинии Polyline (Полилиния) и свойства видового экрана Viewport (Видовой экран).

Рис. 4.34. Диалоговое окно Property Settings

Далее запрашивается:
Select destination object(s) or [Settings]: (Выберите целевой объект(ы) или [Настройки]:)
При этом курсор принимает форму кисти, по аналогии с такой же операцией в программах Microsoft Office. Можно указать объект или объекты, на которые будут перенесены перечисленные свойства, или выбрать опцию Settings (Настройки). Опция Settings (Настройки) вызывает диалоговое окно Property Settings (Настройки свойств) (см. рис. 4.34).
В этом окне нужно установить флажки тех свойств, которые будут копироваться, и нажать кнопку ОК. Затем вновь повторяется запрос о выборе целевых объектов, после указания которых следует нажать клавишу <Enter>.
Система AutoCAD предоставляет возможность простого создания таких свойств, как слои и типы линий, копируя их в свой рисунок из другого файла чертежа. Этой цели служит специальное окно DesignCenter (Центр управления), рассматриваемое в разд. 5.4.


Глава 5. Стили и стандарты

    • Стили и стандарты
    • 5.1. Текстовые стили
    • 5.2. Размерные стили
    • 5.3. Стили мультилиний
    • 5.4. Центр управления
    • 5.5. Стандарты


В рисунках системы AutoCAD могут присутствовать описания стилей некоторых объектов, что, конечно, облегчает оформление чертежа. К таким стилям относятся: текстовые, размерные и стили мультилиний. Стили печати, используемые для вывода, рассмотрены в гл. 6. Кроме того, система дает возможность создавать свои стандарты оформления, сохранять их и проверять в случае необходимости.
В системе AutoCAD 2004 появилась новая панель — Styles (Стили) (рис. 5.1), которая предоставляет быстрый доступ к текстовым и размерным стилям.

Рис. 5.1. Панель Styles


5.1. Текстовые стили

Текстовые стили являются очень важным инструментом, который употребляется в однострочных текстах и оказывает влияние на многие другие объекты (размерные стили, определения атрибутов и др.). Мы уже встречались с текстовыми стилями при рассмотрении однострочных текстов в разд. 2.13, где говорилось, что имеется текущий текстовый стиль (по умолчанию — Standard), который применяется к создаваемым надписям. Имя текущего текстового стиля отображается в первом раскрывающемся списке панели инструментов Styles (Стили) (см. рис. 5.1).
Текстовые стили хранятся внутри рисунка. С помощью Центра управления AutoCAD (см. разд. 5.4) можно импортировать текстовые стили из других рисунков.
Работа с текстовыми стилями осуществляется с помощью команды STYLE (СТИЛЬ), которой соответствует пункт Text Style (Текстовые стили) падающего меню Format (Формат) и кнопка [image] панелей Text (Текст) и Styles (Стили). Команда STYLE (СТИЛЬ) вызывает диалоговое окно Text Style (Текстовые стили) (рис. 5.2).

Рис. 5.2. Диалоговое окно Text Style

В левом верхнем углу диалогового окна находится раскрывающийся список стилей, имеющихся в данном рисунке. В примере, приведенном на рис. 5.2, имя текущего стиля — Architect. В средней части окна описываются параметры шрифта, использованные в текущем стиле: имя шрифта, начертание (курсив и т. п.) и высота букв. В нижней части окна описываются различные эффекты (переворачивание, растяжение и др.). Если поменять параметры в средней и нижней части диалогового окна, то эти изменения могут быть внесены в действующий стиль с помощью кнопки Apply (Применить), расположенной в верхнем правом углу окна, которая в этом случае будет доступна.
Воспользуемся кнопкой New (Новый) и создадим для примера в рисунке новый стиль. Нажатие на эту кнопку вызывает небольшое диалоговое окно New Text Style (Новый текстовый стиль) (рис. 5.3), в котором нужно ввести имя нового стиля. По умолчанию предлагается имя style 1, а при дальнейшем создании новых стилей его номер будет увеличиваться.

Рис. 5.3. Диалоговое окно New Text Style

Если не менять появившееся имя стиля на свое, то в рисунке будет создан стиль по умолчанию с наименованием style 1. Откорректируйте имя стиля на NewT (или другое, состоящее из букв и цифр, без пробелов) и нажмите клавишу <Enter>. Система AutoCAD создаст стиль с этим именем. Все свои характеристики, кроме имени, созданный стиль первоначально возьмет у текущего стиля. В диалоговом окне вы можете изменить их по своему усмотрению.
В диалоговом окне Text Style (Текстовые стили) (см. рис. 5.2) откройте раскрывающийся список Font Name (Имя шрифта) — список шрифтов, доступных в данной версии AutoCAD (рис. 5.4).

Рис. 5.4. Раскрывающийся список шрифтов

Имена, слева от которых нарисован значок [image] , — это имена традиционных SHX-шрифтов AutoCAD, которые хранятся в папке Fonts программного обеспечения системы AutoCAD, в файлах с расширением shx. Имена, слева от которых нарисован значок [image] — это шрифты типа True Type, установленные в вашей версии Windows. Оба типа шрифтов доступны для использования в текстовом стиле. Стиль Standard, базирующийся на шрифте txt.shx и действующий по умолчанию в новом рисунке, не может быть ни удален с помощью кнопки Delete (Удалить), ни переименован с помощью кнопки Rename (Переименовать) панели Text Style (Текстовые стили) (см. рис. 5.2). Этот стиль может быть лишь изменен (путем изменения параметров стиля или имени файла шрифта). Другие стили можно не только менять, но и удалять, если они не использованы в надписях рисунка, а также и переименовывать.
Изменим, например, характеристики стиля NewT. Откройте список Font Name (Имя шрифта) и установите имя Arial. Сразу после этого вам станет доступным раскрывающийся список Font Style (Начертание), который не был доступным для шрифта txt.shx. Если раскрыть этот список, то в нем будут доступны четыре варианта: Italic (Курсив), Regular (Обычный), Bold (Полужирный) и Bold Italic (Полужирный Курсив). Эти варианты доступны для большинства шрифтов типа True Type. Установите в качестве начертания Bold Italic (Полужирный Курсив).
Поле Height (Высота) служит для того, чтобы всем надписям данного стиля установить одну и ту же высоту шрифта. В случае ненулевой высоты команда TEXT (ТЕКСТ) при использовании такого стиля не будет выдавать запроса о высоте букв, поскольку она уже заранее зафиксирована. На практике же, если нет особой необходимости, рекомендуем высоту сохранять нулевой. Тогда вы можете одним стилем создавать надписи с разной высотой букв. При ненулевой высоте шрифта могут быть проблемы, например, при простановке размеров, когда размерные надписи будут неудобной высоты или будут налезать на размерную линию.
Если в качестве шрифта выбран один из стандартных SHX-шрифтов системы AutoCAD, то тогда становится доступным флажок Use Big Font (Использовать большой шрифт), который при желании можно установить. Флажок меняет наименование списка Font Style (Начертание) на Big Font (Большой шрифт). В этом списке можно выбрать вариант большого шрифта, используемого в афро-азиатских языках. Большие шрифты дают возможность применения алфавитов, имеющих по несколько десятков тысяч символов (например, иероглифов).
Область Effects (Эффекты) содержит несколько возможностей влияния на шрифты или стиль написания. Флажок Upside down (Перевернутый) переворачивает буквы вверх ногами. Флажок Backwards (Справа налево) заставляет писать буквы справа налево (по аналогии с восточными языками). Флажок Vertical (Вертикальный) располагает буквы надписи по вертикали, т. е. столбцом, хотя сами буквы располагаются обычным горизонтальным образом. Такой вариант используется, например, в традиционном японском иероглифическом письме. Флажок Vertical (Вертикальный) для многих шрифтов недоступен.
Параметр Width Factor (Степень растяжения) служит для растяжения или сжатия шрифтов относительно их эталонного написания. Значения больше 1 растягивают символы шрифта по ширине, значения меньше 1 — сжимают. Параметр Oblique Angle (Угол наклона) задает угол наклона букв относительно вертикали (не влияя на наклон всей надписи!). Положительный угол наклоняет буквы в их верхней части вправо, отрицательный — влево. Поэтому для того чтобы, например, задать принятый в конструкторских чертежах наклон букв, равный 15°, нужно ввести 15 в качестве значения параметра Oblique Angle (Угол наклона). Следует только учитывать, что при выборе начертания Italic (Курсив) или Bold Italic (Полужирный Курсив) угол наклона дает дополнительный наклон к тому наклону, который создает курсивное написание. Допустимые значения для угла наклона находятся между -85° и +85°.
В правом нижнем углу диалогового окна Text Style (Текстовые стили) находится область Preview (Образец) с кнопкой Preview (Показать). Слева от кнопки Preview (Показать) находится поле, в котором по умолчанию написаны четыре первых буквы латинского алфавита (в верхнем и нижнем регистрах), отображаемые в поле просмотра, расположенного выше кнопки Preview (Показать). Если вы хотите проверить, как выглядят несколько букв в данном стиле, вы можете ввести эти буквы в боксе и нажать кнопку Preview (Показать), чтобы увидеть их в поле просмотра.
После всех изменений текстового стиля нужно нажать кнопку Apply (Применить), вслед за чем она погаснет, и закрыть диалоговое окно с помощью кнопки Close (Закрыть), которая находится в правом верхнем углу диалогового окна.
Созданный описанной выше последовательностью действий текстовый стиль может быть в дальнейшем использован для новых или редактирования уже имеющихся в рисунке однострочных текстов. На рис. 5.5 показан пример надписи, выполненной вышеупомянутым стилем NewT (шрифт Arial, написание Bold Italic (Полужирный Курсив)).

Рис. 5.5. Пример текста, использующего шрифт Arial, написание Bold Italic


5.2. Размерные стили

Как вы уже знаете из разд. 3.6, установки оформления размерных примитивов составляют размерный стиль. Работа с размерными стилями выполняется с помощью команды DIMSTYLE (РЗМСТИЛЬ), которой соответствуют кнопка [image] панелей Styles (Стили) и Dimension (Размеры), а также пункт Style (Стиль) падающего меню Dimension (Размеры) и пункт Dimension Style (Размерные стили) падающего меню Format (Формат).
Все размерные стили имеют имена. Список стилей, имеющихся в текущем рисунке, содержится в панели Dimension (Размеры) (см. рис. 3.63), а также в правом раскрывающемся списке панели Styles (Стили) (см. рис. 5.1). Если какая-то из этих панелей зафиксирована в вертикальном положении, то список стилей в ней не отображается. В новом рисунке всегда присутствует по крайней мере один стиль — ISO-25.
Если вы создаете новый рисунок с помощью простейшего шаблона (см. разд. 1.3), то в рисунке будет лишь один размерный стиль с именем ISO-25. В разд. ]0.6 рассказано, как при использовании стандартных шаблонов системы AutoCAD можно создавать новые рисунки с уже готовыми размерными стилями Standard (ANSI), DIN, JIS и различными видами стилей ISO. С помощью Центра управления AutoCAD (см. разд. 5.4) можно импортировать размерные стили из других рисунков.
Команда DIMSTYLE (РЗМСТИЛЬ) открывает диалоговое окно Dimension Style Manager (Диспетчер размерных стилей) (рис. 5.6).

Рис. 5.6. Диалоговое окно Dimension Style Manager

Строка Current Dimstyle (Текущий размерный стиль) показывает имя того размерного стиля, который является активным (текущим) — им выполняется оформление новых размеров в рисунке в данный момент. Перечень стилей отображается в левом поле Styles (Стили). Ниже перечня находится раскрывающийся список фильтра стилей List (Вывести в список). В нем можно выбрать опции All styles (Все стили) или Styles in use (Задействованные стили). Флажок Don't list styles in Xrefs (Исключить стили Вн-ссылок) позволяет не включать в перечень стили, порожденные вставкой в рисунок внешних ссылок (о внешних ссылках см. разд. 7.2).
В центральной части диалогового окна поле просмотра Preview of (Образец стиля) показывает внешний вид размеров, создаваемых данным стилем. Ниже, в поле Description (Описание), приводится комментарий к действующему стилю.
В правой части окна находятся следующие кнопки:

  • Set Current (Установить);
  • New (Новый);
  • Modify (Изменить);
  • Override (Переопределить);
  • Compare (Сравнить).

Если вы хотите выбрать новый текущий стиль из числа имеющихся в рисунке, то отметьте его в перечне Styles (Стили) и затем нажмите кнопку Set Current (Установить). Имя текущего слоя изменится на новое.
Чтобы создать новый стиль, следует нажать кнопку New (Новый). В этом случае появится диалоговое окно Create New Dimension Style (Создание нового размерного стиля) (рис. 5.7).

Рис. 5.7. Диалоговое окно Create New Dimension Style

В этом окне в поле New Style Name (Имя нового стиля) нужно ввести имя нового стиля. Если текущим стилем был стиль ISO-25, то в качестве имени по умолчанию предлагается Copy of ISO-25 (Копия ISO-25). Измените имя на свое (например, СтильН). Если вы хотите большую часть установок взять не из текущего стиля, а из другого имеющегося в рисунке, вы должны открыть раскрывающийся список Start With (На основе) и выбрать имя базового стиля.
Новый стиль является самостоятельным и действительно новым только в том случае, если в раскрывающемся списке Use for (Размеры) выбрана опция All dimensions (Все размеры). Если выбрать одну из других опций: Linear dimensions (Линейные размеры), Angular dimensions (Угловые размеры), Radius dimensions (Радиусы), Diameter dimensions (Диаметры), Ordinate dimensions (Ординатные размеры) или Leaders and Tolerances (Выноски и допуски), то это будет означать, что вы не хотите создавать новый стиль, а хотите сделать несколько переопределений текущего стиля в группе параметров, определенных этой выбранной опцией. Тогда поле с именем нового стиля гаснет и становится недоступным.
После задания в диалоговом окне Create New Dimension Style (Создание нового размерного стиля) всех необходимых установок нужно нажать на кнопку Continue (Далее). Вслед за этим появится диалоговое окно New Dimension Style (Новый размерный стиль), имеющее шесть вкладок. Как правило, сразу активизируется вкладка Lines and Arrows (Линии и стрелки) (рис. 5.8).

Рис. 5.8. Диалоговое окно New Dimension Style, вкладка Lines and Arrows

Рассмотрим параметры простановки размеров, собранные в этой вкладке. Область Dimension Lines (Размерные линии) содержит следующие установки построения размерных линий:

  • Color (Цвет);
  • Lineweight (Вес линии);
  • Extend beyond ticks (Удлинение за выносные);
  • Baseline spacing (Шаг в базовых размерах);
  • Suppress Dim Line 1 (2) (Подавить 1-ю (2-ю) размерную).

Назначение параметров соответствует их наименованию. Для цвета и веса размерных линий может быть использовано специальное значение ByBlock (Поблоку), которое при простановке размеров принимает текущее значение цвета и веса линий рисунка.
Область Extension Lines (Выносные линии) содержит похожие установки, но уже для выносных линий:

  • Color (Цвет);
  • Lineweight (Вес линии);
  • Extend beyond dim lines (Удлинение за размерные);
  • Offset from origin (Отступ от объекта);
  • Suppress Ext Line 1 (2) (Подавить 1-ю (2-ю) выносную).

Область Arrowheads (Стрелки) содержит соответствующие раскрывающиеся списки допустимых значений формы стрелок размерных линий и выноски, а также поле, определяющее величину стрелок:

  • 1st (1-я);
  • 2nd (2-я);
  • Leader (Выноска);
  • Arrow size (Величина).

Область Center Marks for Circles (Маркеры центра для кругов) определяет тип маркера центра и осевых линий окружностей и дуг, а также размер маркера и выступа осевых линий за окружность. В этой области два параметра:

  • Туре (Тип) — раскрывающийся список с тремя значениями формы маркера (None (Нет), Mark (Только маркер), Line (С линиями));
  • Size (Размер) — поле счетчика с размером маркера.

Вкладка Text (Текст) (рис. 5.9) диалогового окна New Dimension Style (Новый размерный стиль) описывает установки размерного текста.
Область Text Appearance (Свойства текста) содержит следующие установки:

  • Text style (Текстовый стиль) — имя стиля размерного текста;
  • Text color (Цвет текста) — цвет размерного текста;
  • Text height (Высота текста) — высоту символов;
  • Fraction height scale (Масштаб дробей) — масштаб символов дробей.

Кроме того, установка флажка Draw frame around text (Текст в рамке) задает рамку вокруг размерного текста.

Рис. 5.9. Диалоговое окно New Dimension Style, вкладка Text

Рис. 5.10. Диалоговое окно New Dimension Style, вкладка Fit

Область Text Placement (Выравнивание текста) определяет положение размерного текста относительно размерной линии: Vertical (По вертикали) (допустимые значения — Centered (По центру), Above (Над линией), Outside (Снаружи), JIS (Стандарт JIS)) и Horizontal (По горизонтали) (допустимые значения — Centered (По центру), At Ext Line 1 (У 1-й выносной). At Ext Line 2 (У 2-й выносной), Over Ext Line 1 (Над 1-й выносной), Over Ext Line 2 (Над 2-й выносной)), а также задает для текста отступ от размерной с помощью счетчика Offset from dim line (Отступ от размерной).
Область Text Alignment (Ориентация текста) содержит три переключателя, задающих варианты ориентации размерного текста: Horizontal (Горизонтально), Aligned with dimension line (Вдоль размерной линии) и ISO Standard (Согласно ISO).
Вкладка Fit (Размещение) (рис. 5.10) определяет варианты оформления размеров в случаях, когда текст и стрелки не помещаются между выносными линиями.
Область Fit Options (Опции размещения) содержит текст "If there isn't enough room to place both text and arrows inside extension lines, the first thing to move outside the extension line is:" ("Если текст и стрелки одновременно не могут быть размещены между выносными линиями, размещать их за пределами:") и соответствующие переключатели:

  • Either the text or the arrows, whichever fits best (Либо текст, либо стрелки (оптимальное размещение));
  • Arrows (Стрелки);
  • Text (Текст);
  • Both text and arrows (Текст и стрелки);
  • Always keep text between ext lines (Текст всегда между выносными).

В этой области имеется также флажок Suppress arrows if they don't fit inside the extension lines (Подавить стрелки, если они не помещаются между выносными).
Область Text Placement (Размещение текста) содержит текст "When text is not in the default position, place it" ("При перемещении текста с позиции по умолчанию") и варианты выбора с помощью трех переключателей:

  • Beside the dimension line (Перемещать размерную линию);
  • Over the dimension line, with a leader (Строить выноску);
  • Over the dimension line, without a leader (He строить выноску).

Знакомая нам уже по главе 3 область Scale for Dimension Features (Масштаб размерных элементов) содержит два переключателя: Use overall scale of (Глобальный масштаб), влияющий на все элементы оформления размеров, и соответствующий счетчик, с помощью которого задается этот масштаб,
а в качестве альтернативы — переключатель Scale dimensions to layout (paperspace) (Масштаб относительно листа), который масштабирует размеры относительно пространства листа (о пространстве листа см. гл. 10).
Последняя область вкладки Fit (Размещение) с названием Fine Tuning (Подгонка элементов) содержит два флажка: Place text manually when dimensioning (Размещение размерного текста вручную) и Always draw dim line between extlines (Размерная линия всегда между выносными).
Вкладка Primary Units (Основные единицы) (рис. 5.11) определяет параметры настройки единиц размерных чисел.

Рис. 5.11. Диалоговое окно New Dimension Style, вкладка Primary Units

Область Linear Dimensions (Линейные размеры) включает в себя следующие поля характеристик:

  • Unit format (Формат единиц);
  • Precision (Точность);
  • Fraction format (Формат дробей);
  • Decimal separator (Десятичный разделитель);
  • Round off (Округление);
  • Prefix (Префикс);
  • Suffix (Суффикс).

Кроме того, внутри области Linear Dimensions (Линейные размеры) находятся еще две внутренние области. Первая область Measurement Scale (Масштаб измерений) содержит масштабный множитель Scale factor (Масштаб), на который умножаются все линейные размеры. Этот множитель применяется только к пространству листа, если установлен соответствующий флажок Apply to layout dimensions only (Только для размеров на листе).
Другая внутренняя область Zero Suppression (Подавление нулей) с помощью установки соответствующих флажков позволяет управлять подавлением ведущих или хвостовых нулей, а также выводом нулей в 0 футов и 0 дюймов:

  • Leading (Ведущие);
  • Trailing (Хвостовые);
  • 0 Feet (0 футов);
  • 0 Inches (0 дюймов).

Область Angular Dimensions (Угловые размеры) настраивает формат и точность угловых размеров. Здесь тоже есть возможность подавления ведущих и хвостовых нулей.
Следующая вкладка называется Alternate Units (Альтернативные единицы) (рис. 5.12).

Рис. 5.12. Диалоговое окно New Dimension Style, вкладка Alternate Units

Она содержит установки для того случая, когда размеры проставляются сразу в основных и альтернативных единицах — например, помимо миллиметров нужны еще и дюймы. Элементы этой вкладки доступны только в том случае, если установлен флажок Display alternate units (Разрешить альтернативные единицы).
Область Alternate Units (Альтернативные единицы) управляет форматом и точностью, коэффициентом пересчета, округлением линейных размеров, префиксом и суффиксом альтернативных единиц. Она содержит соответствующие поля настроек:

  • Unit format (Формат единиц);
  • Precision (Точность);
  • Multiplier for alt units (Коэффициент пересчета);
  • Round distances to (Округление);
  • Prefix (Префикс);
  • Suffix (Суффикс).

Область Zero Suppression (Подавление нулей) полностью соответствует аналогичному полю для вкладки Primary Units (Основные единицы) (см. рис. 5.11). Область Placement (Размещение) с помощью двух переключателей позволяет располагать альтернативные размерные единицы в соответствии с названиями переключателей, т. е. After primary value (За основным значением) или Below primary value (Под основным значением).
Вкладка Tolerances (Допуски) (рис. 5.13) определяет форму простановки допусков в размерах.
Область Tolerance Format (Формат допусков) содержит следующие параметры управления допусками:

  • Method (Способ) — определяет способ задания допусков;
  • Precision (Точность) — задает точность (количество десятичных знаков) для допуска;
  • Upper value (Максимальное значение) — определяет предельное значение допуска в большую сторону;
  • Lower value (Минимальное значение) — определяет предельное значение допуска в меньшую сторону;
  • Scaling for height (Масштаб высоты) — устанавливает масштаб высоты текста для отклонений;
  • Vertical position (Выравнивание) — управляет выравниванием текстов отклонений.

Кроме того, внутренняя область Zero Suppression (Подавление нулей) управляет подавлением ведущих и хвостовых нулей.

Рис. 5.13. Диалоговое окно New Dimension Style, вкладка Tolerances

В раскрывающемся списке Method (Способ) можно выбрать такие значения:

  • None (Нет) — без показа допуска;
  • Symmetrical (Симметрично) — допуск с одинаковыми предельными отклонениями в обе стороны (его значение вводится в поле Upper value (Максимальное значение), при выводе содержит символ "±").
  • Deviation (Отклонения) — различные значения отклонений, выводятся отдельно;
  • Limits (Предельные размеры) — вывод двух предельных размеров, больший располагается над меньшим;
  • Basic (Номинальный) — размерный текст принимает форму номинального размера, который заключается в рамку.

После выбора параметра в раскрывающемся списке Method (Способ) система AutoCAD, соответственно, изменяет в окне просмотра иллюстрирующий рисунок, на котором видна устанавливаемая форма размерного примитива.
Если в качестве способа выбран вариант Symmetrically (Симметрично), параметр Lower value (Минимальное значение) не используется.
В раскрывающемся списке Vertical position (Выравнивание) можно выбрать следующие значения:

  • Тор (Вверх) — выравнивание отклонения и номинального размера по верху;
  • Middle (Посредине) — выравнивание по середине размерного текста;
  • Bottom (Вниз) — выравнивание по низу.

Область Alternate Unit Tolerance (Допуски для альтернативных единиц) управляет точностью с помощью раскрывающегося списка Precision (Точность) и подавлением нулей с помощью флажков, расположенных во внутренней области Zero Suppression (Подавление нулей) только в том случае, если используются альтернативные единицы.
После назначения всех установок нового стиля следует закрыть все вкладки нажатием кнопки ОК, а диалоговое окно Dimension Style Manager (Диспетчер размерных стилей) — нажатием кнопки Close (Закрыть).
Кнопка Modify (Изменить) диалогового окна Dimension Style Manager (Диспетчер размерных стилей) (см. рис. 5.6) позволяет внести и сохранить изменения в существующий размерный стиль. Она вызывает диалоговое окно Modify Dimension Style (Изменение размерного стиля), которое полностью аналогично окну New Dimension Style (Новый размерный стиль) и также содержит шесть вкладок. Операции с этим диалоговым окном такие же, как и операции с диалоговым окном New Dimension Style (Новый размерный стиль), только что рассмотренным ранее.
Аналогично кнопке Modify (Изменить) диалогового окна Dimension Style Manager (Диспетчер размерных стилей) (см. рис. 5.6) работает и кнопка Override (Переопределить), которая открывает соответствующее диалоговое окно Override Current Style (Переопределение текущего стиля). Работа этой кнопки рассматривалась в примере разд. 3.6. Все изменения отображаются в перечне стилей диалогового окна Dimension Style Manager (Диспетчер размерных стилей).
Кнопка Compare (Сравнить) диалогового окна Dimension Style Manager (Диспетчер размерных стилей) (см. рис. 5.6) вызывает соответствующее диалоговое окно Compare Dimension Styles (Сравнение размерных стилей) (рис. 5.14).
В это окно выводятся отличающиеся значения размерных переменных, если в раскрывающихся списках Compare (Сравнить) и With (Co стилем) установлены различные имена стилей. Если имена в обоих списках совпадают или в одном из них выбрана опция <попе> (<нет>), то выводится полный перечень переменных и их значений.
Как уже было сказано в разд. 3.6, все установки записываются в размерные переменные рисунка, которым соответствуют системные переменные AutoCAD. В русской версии системы AutoCAD имена размерных переменных отличаются от английских имен системных переменных. В то же время в английской версии нет специальных имен для размерных переменных, поскольку этой цели служат имена системных переменных.

Рис. 5.14. Диалоговое окно Compare Dimension Styles

В русской версии системы имена размерных переменных и их значения выводятся в центральную часть диалогового окна Compare Dimension Styles (Сравнение размерных стилей).
Изменение значения размерной переменной для переопределения текущего стиля может быть выполнено обычным образом — посредством окна диспетчера размерных стилей. Но самый быстрый способ — это изменить соответствующую системную переменную. Например, если вы хотите изменить глобальный масштаб оформления размеров, которому соответствуют русская размерная переменная РЗММАСШТ и системная переменная DIMSCALE, то вы в ответ на подсказку Command: (Команда:) можете ввести в командной строке DIMSCALE, что система AutoCAD воспримет как команду изменения переменной с таким именем и выдаст следующий запрос (при этом в угловых скобках будет указано текущее значение):
Enter new value for DIMSCALE <1.0000>: (Новое значение DIMSCALE <1.0000>:)
С помощью Центра управления AutoCAD (см. разд. 5.4) можно импортировать размерные стили из другого DWG-файла.


5.3. Стили мультилиний

В разд. 2.12 мы рассмотрели построение мультилиний с помощью стиля STANDARD, который создается в новом рисунке автоматически и является действующим стилем по умолчанию. Теперь же рассмотрим процесс формирования других стилей мультилиний.
Создание нового стиля осуществляется с помощью команды MLSTYLE (МЛСТИЛЬ), которой соответствует пункт Multiline Style (Стили мультилиний) падающего меню Format (Формат).
Команда MLSTYLE (МЛСТИЛЬ) вызывает диалоговое окно Multiline Styles (Стили мультилиний) (рис. 5.15).

Рис. 5.15. Диалоговое окно Multiline Styles

Область Multiline Style (Стиль мультилиний) диалогового окна содержит раскрывающийся список и два поля. Раскрывающийся список Current (Текущий) указывает имя текущего стиля. Этот список позволяет посмотреть весь список стилей мультилиний рисунка, а также установить другой текущий стиль, который станет прототипом для нового стиля.
Поле Name (Имя) используется для ввода имени в операциях создания нового стиля или переименования существующего.
Поле Description (Пояснение) позволяет к каждому стилю записать комментарий пользователя, длиной до 255 символов, и который может включать в себя пробелы.
Кроме того, в области Multiline Style (Стиль мультилинии) имеются четыре кнопки:

  • Load (Загрузить);
  • Save (Сохранить);
  • Add (Добавить);
  • Rename (Новое имя).

Кнопка Load (Загрузить) вызывает диалоговое окно Load Multiline Styles (Загрузка стилей мультилинии) (рис. 5.16).

Рис. 5.16. Диалоговое окно Load Multiline Styles

Стили мультилинии можно сохранять в файлах с расширением mln и затем из этих файлов загружать. Стандартным для операций загрузки и сохранения является файл acad.mln, входящий в состав программного обеспечения системы AutoCAD. В случае операции загрузки стиля мультилинии AutoCAD показывает сначала именно этот файл, имя которого видно в верхней части диалогового окна. Если стиль будет загружаться из другого файла, то этот файл может быть найден (указан) с помощью кнопки File (Файл). В центральной части окна виден список стилей, которые имеются в файле стилей. Если вы собираетесь загрузить стиль, то отметьте его в этом списке и нажмите кнопку ОК. После такой операции стиль загружается в рисунок и становится текущим.
При необходимости сохранения созданного вами стиля мультилинии в стандартном файле acad.mln или другом файле с расширением mln вы можете в диалоговом окне Multiline Styles (Стили мультилинии) (см. рис. 5.15) воспользоваться кнопкой Save (Сохранить). Эта кнопка вызывает диалоговое окно Save Multiline Style (Сохранение стиля мультилинии) (рис. 5.17), в котором нужно ввести имя файла с расширением mln и нажать кнопку Save (Сохранить). Текущий стиль будет сохранен в выбранном (созданном) файле.
Если вам необходимо переименовать имя стиля мультилинии, то вам нужно сначала сделать его текущим, затем в поле Name (Имя) (см. рис. 5.15) ввести новое имя и, наконец, нажать кнопку Rename (Новое имя).
Кнопка Add (Добавить) используется для создания в рисунке нового стиля. Далее этот процесс будет рассмотрен.

Рис. 5.17. Диалоговое окно Save Multiline Style

Кнопки Element Properties (Свойства элемента) и Multiline Properties (Свойства мультилинии) используются для изменения характеристик текущего стиля, который еще не задействован ни в каких мультилиниях данного рисунка (например, если этот стиль был только что создан). В центре диалогового окна Multiline Styles (Стили мультилинии) находится отображение свойств текущего стиля, причем оно меняется при изменении свойств стиля.
Теперь создадим в нашем рисунке новый стиль мультилинии. Будем считать, что других стилей в рисунке пока нет, поэтому текущим является стиль STANDARD, состоящий из двух параллельных ломаных линий.
В поле Name (Имя) измените имя STANDARD на то, которое вы хотите присвоить новому стилю — например, Triple (в английской версии рекомендуется пользоваться латинскими буквами).
В поле Description (Пояснение) введите свой комментарий — например, Три линии. При этом в поле Name (Имя) все буквы введенного вами имени Triple уже преобразовались в верхний регистр (TRIPLE). Далее нажмите кнопку Add (Добавить).
После этого в списке стилей мультилинии будут фигурировать два имени (STANDARD и TRIPLE), а имя TRIPLE станет именем текущего стиля (рис. 5.18). Таким образом, в рисунке появился новый стиль, который взял все свои характеристики (количество элементов и их свойства) от предыдущего стиля STANDARD. Образец, отображающий свойства текущего стиля, при этом не изменился, т. к. свойства нового и старого стилей пока идентичны.

Рис. 5.18. Добавление нового стиля мультилиний

Теперь добавим к двум линиям стиля мультилиний еще одну. Нажмите кнопку Element Properties (Свойства элемента). После этого открывается диалоговое окно Element Properties (Свойства элемента) (рис. 5.19).

Рис. 5.19. Диалоговое окно Element Properties

Рассмотрим структуру диалогового окна. В верхней части окна расположен список Elements (Элементы), в котором показаны линии, входящие в текущий стиль, и их свойства. К свойствам относятся: Offset (Смещение), Color (Цвет), Ltype (Тигашнии). В стиле TRIPLE сначала находятся только две линии, которые были в стиле STANDARD. Линии имеют смещение 0.5 и -0.5, т. е. относительно оси мультилинии смещены на полмиллиметра в ту и другую сторону. Изменим смещение первой линии на 2 мм, а второй — на — 1 мм. Для этого с помощью мыши отметим сначала линию, имеющую смещение 0.5, а в поле Offset (Смещение), расположенном ниже списка Elements (Элементы), изменим прежнее значение на 2 (не забудьте щелкнуть левой кнопкой мыши внутри поля Offset (Смещение), чтобы оно стало доступно). Редактирование облегчается, если предварительно стереть старое значение.
Щелкните с помощью левой кнопки мыши в поле Elements (Элементы) по строке второго элемента, имеющего смещение —0,5 мм. При этом в верхней строке смещение сразу изменится на значение 2, которое мы перед этим задали в поле Offset (Смещение). А значение в столбце Offset (Смещение) уже будет показывать смещение второго элемента, то есть -0,5 мм.
Измените содержимое поля Offset (Смещение) на -1. Это значение вступит в силу, как только мы выполним любую другую операцию в диалоговом окне. Зададим теперь новый цвет обоим элементам мультилинии, изменив его со значения BYLAYER (ПОСЛОЮ) на красный. Для этого сначала щелкните по одной из двух строк в списке элементов, нажмите кнопку Color (Цвет) и в открывающемся диалоговом окне установите красный цвет. Затем то же самое проделайте со второй строкой списка.
Добавим к двум элементам мультилинии третий. Для этого нажмите кнопку Add (Добавить). После нажатия в списке элементов появится третий, имеющий значения по умолчанию: нулевое смещение, цвет BYLAYER (ПОСЛОЮ) и тип линии ByLayer (ПОСЛОЮ). У этой линии, если нужно, можно отредактировать величину смещения. Изменим у нее тип линии на другой. Для этого отметьте строку, соответствующую новому элементу, и нажмите кнопку Linetype (Тип линии). Откроется уже знакомое для нас окно выбора типа линии. В нем загрузите новый тип линии (например, Batting (Изоляция)). Закройте окно выбора типа линии. В окне свойства элемента новая линия будет иметь уже требуемый тип линии. Затем измените цвет этой линии на синий и закройте окно нажатием кнопки ОК.
После этих операций вы вернетесь в диалоговое окно Multiline Styles (Стили мультилинии), но в поле, где изображается образец мультилинии, будут нарисованы три прямолинейных элемента (два красных и один синий) (рис. 5.20).
Средний элемент, имеющий сложный тип линии, отображается в этом окне условно сплошной линией.
Отредактируем другие характеристики стиля, нажав кнопку Multiline Properties (Свойства мультилинии). После этого открывается диалоговое окно Multiline Properties (Свойства мультилинии) (рис. 5.21).

Рис. 5.20. Новый стиль мультилиний с измененными свойствами элементов

Рис. 5.21. Диалоговое окно Multiline Properties

В этом окне для мультилиний можно задать следующие параметры:

  • Display joints (Показать стыки);
  • Caps (Торцы);
  • Fill (Заливка).

Если установить флажок Display joints (Показать стыки), то в местах изломов мультилиний отрезками будут показаны стыки.
Область Caps (Торцы) управляет оформлением концов (торцов) мультилиний. В любом из торцов может быть задано соединение внешних кромок отрезками (флажок Line (Отрезок)), а также дугами (флажок Outer arc (Внешняя дуга)). Флажок Inner arcs (Внутренние дуги) соединяет попарно дугой внутренние элементы, если общее количество элементов четыре или больше. Угол, которым срезается торец мультилинии, задается в поле Angle (Угол). Область Fill (Заливка) определяет цвет заливки внутренности мультилинии, а также с помощью флажка On (Вкл) может включать или выключать саму запивку.
В нашем примере установите флажок Display joints (Показать стыки), задайте соединение торцов в начале мультилинии отрезками, а в конце — внешними дугами. Оба угла определите равными 45°. Область Fill (Заливка) трогать не будем, т. к. неудачный выбор цвета заливки может затенить внутреннюю часть мультилинии.
Закройте окно Multiline Properties (Свойства мультилинии), нажав кнопку ОК. Убедитесь, что назначенные новые свойства правильно отобразились в поле образца, а затем закройте диалоговое окно Multiline Styles (Стили мультилинии). Нарисуйте с помощью команды MLINE (МЛИНИЯ) мультилинию новым стилем. Результат будет аналогичен приведенному примеру на рис. 5.22.

Рис. 5.22. Мультилиния, нарисованная новым стилем


5.4. Центр управления

В системе AutoCAD, начиная с AutoCAD 2000, появилось интересное средство — Центр управления. Это специальное окно (рис. 5.23), вызываемое по команде ADCENTER (ЦУВКЛ), которой соответствуют кнопка [image] панели инструментов Standard (Стандартная) и пункт DesignCenter (Центр управления) падающего меню Tools (Сервис). Центр управления можно вызвать также с помощью комбинации клавиш <Ctrl>+<2>.

Рис. 5.23. Окно DESIGNCENTER, вкладка Folders

Закрыть окно DESIGNCENTER (ЦEHTP УПРАВЛЕНИЯ) можно либо повторным щелчком по кнопке [image] , либо командой ADCCLOSE (ЦУОТКЛ), либо щелчком по расположенной в правом верхнем углу окна кнопке [image] .Окно DESIGNCENTER (ЦЕНТР УПРАВЛЕНИЯ) может появиться в фиксированном положении (когда оно закреплено в левой или правой части графического экрана), но буксировкой за заголовок можно перевести окно в плавающее положение. Структура этого окна изменяется в зависимости от того, какая из четырех вкладок активна. Перечислим эти вкладки:

  • Folders (Папки) — показывает диски и папки компьютера, для выбора файла и просмотра его элементов;
  • Open Drawings (Открытые рисунки) — показывает в левой части окна неграфические элементы отмеченного рисунка, а в правой части — имена этих элементов (на рис. 5.24 — имена типов линий);
  • History (Журнал) — показывает журнал последних операций в Центре управления (рис. 5.25);
  • DC Online (ЦУ Online) — доступ в Интернете в прямом режиме к библиотекам стандартных элементов на сайте Autodesk (рис. 5.26); при этом передаются данные об экземпляре системы AutoCAD, с помощью которой выполняется соединение.

Рис. 5.24. Окно DESIGNCENTER, вкладка Open Drawings

Рис. 5.25. Окно DESIGNCENTER, вкладка History

Рис. 5.26. Окно DESIGNCENTER, вкладка DC Online

Над вкладками располагаются кнопки, которые облегчают работу с Центром управления:

  • - Load (Загрузить), загружает отмеченный рисунок (в том числе и со страницы в сети Интернет);
  • — Back (Назад), переходит на предыдущий загруженный элемент (рисунок);
  • — Forward (Вперед), переходит на следующий загруженный элемент (рисунок);
  • — Up (Вверх), переходит в дереве на один уровень вверх;
  • — Search (Поиск), ищет файл по заданным признакам (слоям, блокам и др.);
  • — Favorites (Избранное), показывает содержимое папки Autodesk, которую AutoCAD создает внутри папки Favorites (Избранное);
  • — Home (Домой), показывает содержимое папки DesignCenter, расположенной внутри папки Sample программного обеспечения системы AutoCAD;
  • — Tree View Toggle (Зона структуры), показывает или убирает в левой части окна структуру требуемого типа (тип определяется вкладкой);
  • — Preview (Образцы), добавляет или убирает в правой части окна зону просмотра образцов неграфических элементов (зона особенно удобна для блоков, с которыми в рисунке хранятся образцы для просмотра);
  • — Description (Описания), добавляет или убирает в правой части окна зону просмотра текстовых комментариев для отмеченных элементов (например, блоков);
  • — Views (Вид), устанавливает форму окна для вывода элементов (Large icons (Крупные значки), Small icons (Мелкие значки), List (Список) или Details (Таблица)).

При включении кнопки [image] AutoCAD делит окно DESIGNCENTER (ЦЕНТР УПРАВЛЕНИЯ) на две части по вертикали и показывает в левой части древовидную структуру либо рабочего стола, либо выбранного файла рисунка, либо журнала работы (содержимое зависит от выбранной вкладки).
Правая часть окна DESIGNCENTER (ЦЕНТР УПРАВЛЕНИЯ) может делиться на одну, две либо три части, а также показывать или не показывать образец и описание выбранного элемента, что управляется кнопками [image] и [image] . На вкладке Open Drawings (Открытые рисунки) щелчок в левой части окна DESIGNCENTER (ЦЕНТР УПРАВЛЕНИЯ) по значку с плюсом слева от значка рисунка раскрывает иерархию неграфических элементов этого рисунка, к которым относятся:

  • Blocks (блоки);
  • Dimstyles (размерные стили);
  • Layers (слои);
  • Layouts (листы);
  • Linetypes (типы линий);
  • Textstyles (текстовые стили);
  • Xrefs (внешние ссылки).

Любые элементы, отображаемые в окне DESIGNCENTER (ЦЕНТР УПРАВЛЕНИЯ), могут быть перенесены в текущий рисунок простым перетаскиванием с помощью мыши. Это предоставляет вам возможность простого создания таких элементов чертежа, как текстовые стили, размерные стили, а также слои и типы линий, копируя из файла-прототипа. Копирование можно выполнить также двойным щелчком по выбранному элементу.
Команда ADCNAVIGATE (ЦУПЕРЕЙТИ) позволяет в режиме командной строки перейти в окне Центра управления к нужной папке или файлу. Если в этот момент окно еще не было открыто, то оно открывается автоматически.
Окно DESIGNCENTER (ЦЕНТР УПРАВЛЕНИЯ) обладает таким же свойством свертывания, как и окно Properties (Свойства). Кнопка [image] позволяет свернуть окно до одной вертикальной полосы заголовка. Окно снова раскроется, если вы задержите курсор над полосой заголовка или щелкните по кнопке [image] . Щелчок левой кнопкой мыши по кнопке [image] или щелчок правой кнопкой мыши по полосе заголовка вызывает контекстное меню (рис. 5.27) со следующими пунктами:

Рис. 5.27. Контекстное меню окна DESIGNCENTER

  • Move (Переместить);
  • Size (Размер);
  • Close (Закрыть);
  • Allow Docking (Разрешить закрепление);
  • Auto-hide (Автоматически скрывать).

Контекстное меню позволяет настроить свойства окна DESIGNCENTER (ЦЕНТР УПРАВЛЕНИЯ).


5.5. Стандарты

Группы проектировщиков с достаточно большим опытом работы создают свои правила оформления чертежей, регламентируя имена и свойства слоев, типов линий, текстовых и размерных стилей и прочих элементов. Это позволяет делать чертежи одного или разных проектов максимально понятными и совместимыми. Можно говорить о стандартах структуры чертежных файлов.
Команда SAVEAS (СОХРАНИТЬКАК), рассмотренная в гл. 2, позволяет сохранить проектную информацию из текущего рисунка в DWS-файле — файле формата, появившегося в версии AutoCAD 2002. В качестве элементов проектирования, хранящихся в DWS-файле, который можно назвать файлом стандарта, выступают:

  • слои;
  • типы линий;
  • текстовые стили;
  • размерные стили.

Для работы со стандартами используется панель инструментов CAD Standards (Стандарты оформления) (рис. 5.28).

Рис. 5.28. Панель инструментов CAD Standards

На этой панели расположены три кнопки, соответствующие командам системы AutoCAD:

  • - соответствует команде STANDARDS (СТАНДАРТЫ), которая настраивает стандарты текущего чертежа;
  • — соответствует команде CHECKSTANDARDS (НОРМОКОНТРОЛЬ), которая проверяет текущий чертеж на соответствие выбранным стандартам;
  • — соответствует команде LAYTRANS (СЛОЙТРАНС), которая предназначена для трансляции слоев в соответствии со стандартом.

Разберем работу этих команд на примере специального рисунка MK.MPlan.dwg, поставляемого в папке Sample программного обеспечения системы AutoCAD 2004. Этот файл ассоциирован с другим файлом — MK.MStd.dws, который является файлом стандарта. Если вы откроете последний файл системой AutoCAD, то увидите, что в нем нет никаких примитивов, но в нем присутствуют слои, типы линий, текстовые и размерные стили, составляющие суть данного стандарта.
Откройте файл MKMPlan.dwg, который показывает фрагмент плана здания. В рисунке используются:

  • 36 специальных слоев: S-ANNO-DIMS, S-ANNO-NOTE, S-ANNO-NPLT, S-BEAM, S-BEAMS, S-DEMO, S-DETL-ANNO, S-EXST-WALL, S-JOIS и др.;
  • шесть типов линий: CONTINUOUS, DOT2, HIDDEN, HIDDEN-3, HIDDEN2, PHANTOM2;
  • восемь текстовых стилей: МКМ, МКМ0, МКМ1, МКМ48, МКМ96, ROMAND, STANDARD, ТХТ10;
  • два размерных стиля — МКМ24, МКМ48.

Команда STANDARDS (СТАНДАРТЫ) при своем вызове открывает вкладку Standards (Стандарты) окна Configure Standards (Настройка стандартов) (рис. 5.29).

Рис. 5.29. Диалоговое окно Configure Standards, вкладка Standards

Вкладка Standards (Стандарты) показывает перечень тех стандартов, которые подключены к данному чертежному файлу. Один рисунок может быть ассоциирован сразу с несколькими стандартами. Стандарт, расположенный в списке выше, имеет приоритет по сравнению со стандартом, находящимся ниже. Это правило применяется в тех случаях, когда имя какого-то элемента (слоя, типа, стиля) одного стандарта совпадает с именем элемента (слоя, типа, стиля) другого стандарта. Если слои вашего рисунка удовлетворяют стандарту, свойства слоев (цвет, тип и т. п.) будут точно такими же, как свойства слоев с теми же именами в файле стандарта. Аналогичное правило распространяется и на типы линий, текстовые стили, размерные стили.
В диалоговом окне, показанном на рис. 5.29, вы можете добавить стандарт к списку (кнопка [image] ), удалить стандарт (кнопка [image] ), переместить выше в списке стандартов (кнопка [image] ), опустить ниже в списке (кнопка [image] ).
Когда вы добавляете новый стандарт, то система открывает окно Select standards file (Выбор файла стандартов), в котором вы можете найти и выбрать нужный файл с расширением dws.
На рис. 5.30 показана вкладка Plug-ins (Надстройки) диалогового окна Configure Standards (Настройка стандартов).
На этой вкладке вы видите список типов обнаруженных элементов — Dimension Styles (Размерные стили), Layers (Слои), Linetypes (Типы линий), Text Styles (Текстовые стили). Их можно проверить на соответствие стандартам с помощью кнопки [image] , которая выполняет ту же операцию, что и рассматриваемая ниже команда CHECKS TAN CARDS (HOPMUKOH-ТРОЛЬ).

Рис. 5.30. Диалоговое окно Configure Standards, вкладка Plug-ins

Команда CHECKSTANDARDS (НОРМОКОНТРОЛЬ) предназначена для проверки чертежа на соответствие стандартам. Команда выполняет проверку и результаты выводит в диалоговое окно Check Standards (Нормоконтроль) (рис. 5.31).
Окно содержит три списка:

  • Problem (Проблема);
  • Replace with (Заменить на);
  • Preview of changes (Просмотр изменений).

В соответствии с этой структурой в списке Problem (Нарушение) система сообщает о первой из обнаруженных проблем: Dimstyle 'MKM48' (Размерный стиль МКМ48), Properties are non-standard (Нестандартные свойства) (см. рис. 5.31). Далее в списке Replace with (Заменить на) сообщается о том, что размерный стиль с нестандартными свойствами предлагается заменить на размерный стиль, который выделен (МКМ48, т. е. сам на себя, но с заменой некоторых свойств). В списке Preview of changes (Просмотр изменений) описываются изменения рисунка, которые произойдут в случае принятия предлагаемых модификаций: нестандартный цвет текста Red (Красный), хранящийся в системной переменной DIMCLRT, будет заменен на стандартный (256).

Рис. 5.31. Диалоговое окно Check Standards

Если вы согласны с предлагаемым изменением, вам нужно щелкнуть по кнопке Fix (Принять), а если не согласны — установить флажок Mark this problem as ignored (Игнорировать нарушение в дальнейшем). Для перехода к следующей проблеме необходимо щелкнуть по кнопке Next (Дальше), после чего в окне Check Standards (Нормоконтроль) появится описание очередной проблемы и предлагаемый способ ее устранения. По окончании работы в окне Checking Complete (Проверка завершена) (рис. 5.32) появляется отчет об итоговых результатах проверки:
Problems found: 10 (Обнаружено проблем: 10)
Fixed Automatically: 0 (Фиксировано автоматически: 0)
Fixed Manually: 1 (Фиксировано вручную: 1)
Ignored in current check: 8 (Игнорировано в текущей проверке: 8).
Кнопка Settings (Параметры), расположенная в нижней части окна Check Standards (Нормоконтроль) (см. рис. 5.31), открывает окно CAD Standards Settings (Параметры стандартов) (рис. 5.33).

Рис. 5.32. Окно Checking Complete

Рис. 5.33. Диалоговое окно CAD Standards Settings

Диалоговое окно CAD Standards Settings (Параметры стандартов) разделено на две области. Область Notification settings (Параметры уведомлений) с помощью трех переключателей задает порядок вывода уведомлений, связанных с нарушениями стандартов (настройка сохраняется в новой системной переменной STANDARDSVIOLATION):

  • Disable standards notifications (Отключить стандартные уведомления) — отключает уведомления о нарушении стандартов или отсутствии файлов стандартов;
  • Display alert upon standards violation (Предупреждать о нарушении стандартов) — включает вывод предупреждений о нарушении стандартов, причем пользователю предоставляются варианты исправления нарушений;
  • Display standards status bar icon (Вывести значок стандартов в строку состояния) — выводит в строку состояния значок [image] , когда пользователь открывает файл, связанный со стандартами.

Область Check Standards settings (Параметры нормоконтроля) содержит два флажка и один раскрывающийся список, определяющие действия при обнаружении нарушений стандартов:

  • Automatically fix non-standard properties (Автоматически исправлять нестандартные свойства) — включает или отключает автоматическое исправление нарушений стандартов;
  • Show ignored problems (Показывать проигнорированные нарушения) — включает или отключает показ нарушений, которые были выявлены, но пропущены при проверке;
  • Preferred standards file to use for replacements (Предпочтительно использовать для замены) — устанавливает имя того файла стандарта, который будет использоваться в первую очередь.

В состав программного обеспечения системы AutoCAD входит специальный модуль DwgCheckStandards.exe, который позволяет, не открывая сеанса работы AutoCAD, выполнить проверку группы чертежей на соответствие выбранным стандартам. Для запуска этого модуля следует в меню Programs (Программы), доступ к которому на рабочем столе Windows выполняется через кнопку Start (Пуск), выбрать группу Autodesk > AutoCAD 2004 и в ней — пункт [image] (Пакетная проверка стандартов).
Данный пункт открывает диалоговое окно Batch Standards Checker (Утилита пакетного нормоконтроля), показанное на рис. 5.34.

Рис. 5.34. Диалоговое окно Batch Standards Checker

По результатам выполнения пакетного нормоконтроля формируется специальный отчет, приведенный на рис. 5.35.

Рис. 5.35. Отчет о результатах пакетного нормоконтроля

Команда LAYTRANS (СЛОЙТРАНС), которой соответствует кнопка [image] панели инструментов CAD Standards (Стандарты оформления) (см. рис. 5.28), предназначена для трансляции слоев (смены имен и свойств слоев на требуемые). Диалоговое окно Layer Translator (Транслятор слоев), открываемое командой, приведено на рис. 5.36.
В данном окне в области Translate From (Исходные слои) перечисляются слои текущего рисунка. Используемые слои имеют слева от имени значок [image] неиспользуемые — [image] . Неиспользуемые слои, вероятно, транслировать не нужно. Если вам не требуется список всех слоев, то вы можете с помощью поля Selection Filter (Фильтр) задать фильтр выбора слоев (например, S-*).
В области Translate To (Слои назначения) нужно сформировать список с именами слоев. В начальном состоянии этот список обычно пуст. Добавить в него имена можно либо с помощью кнопки New (Новый), которая вызывает диалоговое окно New Layer (Новый слой), дающее возможность ввести имя слоя и его свойства (тип линии, цвет, вес, стиль печати). Чаще используется кнопка Load (Загрузить), открывающая окно выбора файла- прототипа, из которого будет импортирован список слоев и их характеристик. В качестве такого файла можно взять не только DWG-файл, но и DWT-файл или DWS-файл.

Рис. 5.36. Диалоговое окно Layer Translator

После того как вы выбрали имя слоя в списке Translate From (Исходные слои) и соответствующее ему имя в списке Translate To (Слои назначения), необходимо щелкнуть по кнопке Map (Сопоставить) и в списке области Layer Translation Mappings (Таблица сопоставлений слоев) появится имя старого слоя (Old Layer Name), имя нового слоя (New Layer Name), а также свойства нового слоя (Color (Цвет), Linetype (Тип линии), Lineweight (Вес), Plot style (Стиль печати)). Кнопка Map same (Одноименные) используется для добавления к схеме трансляции слоев, имена которых должны сохраниться (такие имена должны присутствовать в списках Translate From (Исходные слои) и Translate To (Слои назначения)).
Со строками списка в области Layer Translation Mappings (Таблица сопоставления слоев) возможны операции (см. на рис. 5.36 кнопки с соответствующими названиями):

  • Edit (Изменить) — редактирование строки схемы;
  • Remove (Удалить) — удаление строки;
  • Save (Сохранить) — сохранение схемы.

В случае выбора операции Save (Сохранить) система AutoCAD записывает схему трансляции в DWS-файл или DWG-файл и эту схему можно будет за-
грузить при следующем обращении к команде LAYTRANS (СЛОЙТРАНС) с помощью кнопки Load (Загрузить).
После формирования схемы можно с помощью кнопки Settings (Параметры) открыть одноименное диалоговое окно (рис. 5.37), в котором могут быть установлены следующие флажки, определяющие режимы трансляции:

  • Force object color to ByLayer (Установить для объектов цвет ПоСлою);
  • Force object linetype to ByLayer (Установить для объектов тип линии ПоСлою);
  • Translate objects in blocks (Преобразовывать объекты в блоках);
  • Write transaction log (Вести журнал транзакций);
  • Show layer contents when selected (Показывать содержимое выбранного слоя).

Рис. 5.37. Диалоговое окно Settings

По завершении всех настроек трансляции следует в диалоговом окне Layer Translator (Транслятор слоев) (см. рис. 5.36) щелкнуть по кнопке Translate (Преобразовать). Если схема сопоставления слоев не была сохранена, система напомнит вам об этом. Затем выполняется сама трансляция.
В случае установки флажка Write transaction log (Вести журнал транзакций) автоматически образуется текстовый файл журнала, имеющий то же имя, что и рисунок, но с расширением log. В файл журнала заносится протокол трансляции, содержащий список переименованных слоев (Layers Translated) и список непереименованных слоев (Layers Not Translated).


Глава 6. Печать

    • Печать
    • 6.1. Добавление плоттера
    • 6.2. Параметры вывода
    • 6.3. Стили печати


В этой главе рассмотрены вопросы вывода чертежей на внешние устройства. Такие устройства будем называть плоттерами или принтерами, рассматривая эти два термина как синонимы. Такой подход вполне допустим, поскольку на современном уровне развития струйной и лазерной технологии практически стерлась грань между принтером и плоттером в прежнем смысле слова.
В данной главе приводится информация о настройке вывода чертежей. Важным новшеством, появившимся в системе AutoCAD 2004, является возможность вывода тонированных и раскрашенных видов (о тонировании и раскрашивании см. гл. 9). Раньше такие виды приходилось сохранять в растровых файлах и печатать отдельно.


6.1. Добавление плоттера

Любое устройство (локальное или сетевое), к которому вы обращаетесь для вывода чертежа из AutoCAD, должно быть специальным образом конфигурировано (описано) в системе AutoCAD. Операция по установке плоттеров или редактированию их настроек требует специальных знаний. Ее лучше выполнять опытным пользователям или системным администраторам, обслуживающим вычислительные комплексы, на которых функционирует AutoCAD. Поэтому данный раздел содержит лишь самую основную информацию о процессе добавления плоттера. Дополнительную информацию можно найти либо в справочной системе AutoCAD, либо в документации, поставляемой вместе с системой. Автономная настройка (т. е. не зависящая от связи с AutoCAD) самого устройства выполняется с помощью документации, поставляемой вместе с плоттером.
Для того чтобы определить, настроена ли ваша версия AutoCAD, а если настроена, то на плоттеры каких марок, следует воспользоваться командой OPTIONS (НАСТРОЙКА). Эту команду можно вызвать либо с помощью пункта Options (Настройка) падающего меню Tools (Сервис), либо с помощью контекстного меню, появляющегося при нажатии правой кнопки мыши, если курсор расположен в этот момент в зоне командных строк. Команда OPTIONS (НАСТРОЙКА) вызывает диалоговое окно Options (Настройка) (рис. 6.1).

Рис. 6.1. Диалоговое окно Options, вкладка Files

Это окно имеет девять вкладок, управляющих настройкой системы AutoCAD, которые рассмотрены в гл. П. Сейчас же мы рассмотрим только вкладку Plotting (Печать) (рис. 6.2), которая позволяет настраивать плоттеры для последующего вывода чертежей.
Область Default plot settings for new drawings (Параметры печати для новых рисунков по умолчанию) управляет установкой конкретного типа плоттера, который будет использован по умолчанию для вывода чертежей. В этом поле действуют два переключателя: Use as default output device (Устройство вывода по умолчанию) и Use last successful plot settings (Последнее успешно использованное устройство). Первый переключатель сопровождается раскрывающимся списком, содержащим перечень плоттеров, которые уже подключены к данной версии системы AutoCAD (рис. 6.3).
В примере, приведенном на этом рисунке, показаны шесть строк принтеров: HP DeskJet 400 (Monochrome), Symantec Fax Starter Edition, PublishToWeb JPG.pc3, PublishToWeb PNG.pc3, Default Windows System Printer, DWF6 ePlot.pc3. Некоторые из них позволяют не выводить рисунки на особые устройства, а сохранять файлы в некотором формате (не в стандартном формате DWG).

Рис. 6.2. Диалоговое окно Options, вкладка Plotting

Рис. 6.3. Список подключенных плоттеров

Как правило, уже сразу после инсталляции системы AutoCAD выполняется конфигурирование плоттера, установленного в Windows и используемого другими задачами, и добавляются пять указанных выше конфигураций для сохранения графики в форматах DWF, JPG, PNG.
Если в списке нет требуемой конфигурации плоттера, вы можете воспользоваться кнопкой Add or Configure Plotters (Добавление и настройка плоттеров) (см. рис. 6.2). Кнопка открывает системную папку Plotters, которая содержит значки уже созданных конфигураций (рис. 6.4).

Рис. 6.4. Папка Plotters

Работа с этой папкой обсуждается далее, при рассмотрении вопроса об установке нового плоттера.
Область General plot options (Общие параметры печати) диалогового окна Options (Настройка) (см. рис. 6.2) управляет общими параметрами поведения плоттера при печати. В этой области имеется два переключателя When changing the plot device (При смене устройства печати):

  • Keep the layout paper size if possible (Сохранять (если возможно) размеры листа);
  • Use the plot device paper size (Использовать размеры листа из устройства).

Переключатели управляют выбором размера листа при смене плоттера.
Раскрывающийся список System printer spool alert (Предупреждать о буферизации) влияет на выбор способа регистрации ошибок системного принтера, возникших в результате конфликта входного или выходного портов. В раскрывающемся списке поля присутствуют четыре варианта регистрации ошибок. Буферизация — это опция, позволяющая пересылать задания на печать в специальную папку, откуда они затем выводятся в "фоновом режиме". Фоновый режим используется, когда объем печати достаточно велик, что при недостаточной скорости вычерчивания плоттера может препятствовать эффективной работе компьютера, который в основном будет занят ожиданием окончания вывода. Настройка буферизации может быть выполнена в процессе установки нового плоттера при настройке портов (для более детальной информации, необходимой опытным читателям, следует обратиться к справочной системе AutoCAD).
Раскрывающийся список OLE plot quality (Качество печати OLE) и флажок Use OLE application when plotting OLE objects (Печатать OLE-объекты в OLE-приложениях) управляют процессом вывода при наличии в рисунке объектов, созданных другими приложениями (Microsoft Word, Microsoft Excel и др.). О вставке объектов других приложений см. разд. 8.2. Флажок Hide system printers (Скрыть системные принтеры) позволяет скрыть окно свойств системного принтера, конфигурированного в среде Windows.
Область Default plot style behavior for new drawings (Стили печати по умолчанию для новых рисунков) управляет стилями печати, которые будут действовать в новых рисунках. О стилях печати рассказано в разд. 6.2.
После корректировки настройки с помощью вкладки Plotting (Печать) следует щелкнуть кнопку Apply (Применить), которая фиксирует сделанные изменения.
Для работы с наиболее распространенными плоттерами и форматами графических файлов в системе AutoCAD присутствуют специальные программы (драйверы), обеспечивающие передачу данных на соответствующие устройства или в соответствующие форматы. Система AutoCAD в стандартной поставке поддерживает большое количество перьевых и струйных типов плоттеров таких фирм, как Hewlett-Packard, Xerox, Осе и CalComp, а также наиболее распространенные форматы растровых файлов (JPEG, BMP, PNG, TGA и др.) и форматы PostScript, применяемые в лазерных устройствах печати.
При необходимости добавить настройку нового плоттера или отредактировать существующую настройку следует пользоваться специальным инструментом — Autodesk Plotter Manager (Диспетчер плоттеров Autodesk). Обратиться к этому инструменту можно с помощью команды PLOTTERMANAGER (ДИСППЕЧ) или пункта Plotter Manager (Диспетчер плоттеров) падающего меню File (Файл). Команда PLOTTERMANAGER (ДИСППЕЧ), используя Проводник Windows, открывает папку Plotters (см. рис. 6.4), расположенную глубоко внутри папки Documents and Settings. Указанную папку можно открыть также и другим путем: в Windows открыть Control Panel (Панель управления) и щелкнуть по значку [image] Autodesk Plotter Manager (Диспетчер плоттеров Autodesk).
В папке Plotters первоначально обычно находятся пять значков, которые соответствуют файлам конфигураций (с расширением рсЗ), сгенерированным при установке системы AutoCAD на ваш компьютер. Один из значков — [image] Add-A-Plotter Wizard (Мастер установки плоттеров) — вызывает программу (мастер) установки новых плоттеров. Самый короткий путь вызвать программу — это обратиться к пункту падающего меню Tools | Wizards | Add Plotter (Сервис | Мастера | Установки плоттеров). Мастер установки плоттеров начинает свою работу со страницы (окна) Add Plotter — Introduction Page (Установка плоттера — Введение) (рис. 6.5).

Рис. 6.5. Страница Add Plotter — Introduction Page

В данном окне система AutoCAD сообщает о том, что параметры плоттеров хранятся в файлах с расширением рсЗ и эти параметры могут быть импортированы из аналогичных файлов с расширением рср и рс2, созданных в 14-й версии AutoCAD. После нажатия кнопки Далее (Next) переходим к следующей, самой важной странице мастера установки плоттеров — Add Plotter — Begin (Установка плоттера — Начало) (рис. 6.6).
На этой странице нужно включить один из трех переключателей:

  • My Computer (Мой компьютер) — добавление локального плоттера, который не был ранее установлен в Windows;
  • Network Plotter Server (Сетевой сервер печати) — выбор в качестве плоттера сетевого устройства;
  • System Printer (Системный принтер) — выбор в качестве плоттера локального устройства, уже установленного в Windows и используемого другими приложениями.

Самый распространенный вариант — это System Printer (Системный принтер), на котором мы и остановимся. После нажатия кнопки Далее (Next) мы попадаем на страницу Add Plotter — System Printer (Установка плоттера — Системный принтер) (рис. 6.7). На этой странице выберите ваш вариант системного принтера (например, HP DeskJet 400 (Monochrome)) и нажмите кнопку Далее (Next).
Следующая страница носит название Add Plotter — Import Pep or Pc2 (Установка плоттера — Импорт РСР или РС2) (рис. 6.8). Как правило, вам не надо импортировать установки плоттера из предыдущих версий AutoCAD, поэтому нажмите кнопку Далее (Next), и вы попадете на страницу Add Plotter — Plotter Name (Установка плоттера — Имя плоттера) (рис. 6.9).

Рис. 6.6. Страница Add Plotter — Begin

Рис. 6.7. Страница Add Plotter — System Printer

Рис. 6.8. Страница Add Plotter — Import Pep or Pc2

Рис. 6.9. Страница Add Plotter — Plotter Name

Вы можете на ней либо согласиться с именем, предлагаемым по умолчанию (это имя берется из папки Printers (Принтеры) Windows), либо дать свое условное имя, под которым плоттер попадает в список конфигураций плоттеров AutoCAD. Следующая страница — Add Plotter — Finish (Установка плоттера — Конец) (рис. 6.10).

Рис. 6.10. Страница Add Plotter — Finish

Здесь можно нажать на кнопку Готово (Done), завершая сделанные установки. На последней странице есть еще две кнопки: Edit Plotter Configuration (Изменить конфигурацию) и Calibrate Plotter (Калибровка плоттера). Первая кнопка вызывает диалоговое окно Plotter Configuration Editor (Редактор параметров плоттера) (рис. 6.11), позволяющее выполнить более детальную настройку, что, однако, потребует дополнительных знаний.
Кнопка Calibrate Plotter (Калибровка плоттера) страницы Add Plotter —Finish (Установка плоттера— Конец) (см. рис. 6.10) загружает мастер калибровки, который позволяет скорректировать работу плоттера, если выяснилось, что он не выдерживает требуемые размеры линий (т. е. дает постоянную погрешность, вызванную механическими проблемами плоттера). Мастер начинает свою работу со страницы Calibrate Plotter — Begin (Калибровка плоттера— Начало) (рис. 6.12). Идея калибровки заключается в следующем. Вы задаете прямоугольник с максимально возможными размерами, которые позволят вычертить его на исследуемом плоттере на бумаге в масштабе 1:1, затем выводите прямоугольник на плоттер и замеряете получившиеся на листе бумаги размеры прямоугольника. Если они не совпали с требуемыми размерами, то вы сообщаете мастеру калибровки полученные значения, и он в дальнейшем будет пропорционально корректировать вывод на ваш плоттер. Параметры калибровки записываются в файл с расширением ртр. Главная часть имени этого файла обычно совпадает с главной частью имени файла конфигурации плоттера, имеющего расширение рсЗ. Но они могут и отличаться. Тогда увязка должна осуществляться с помощью диалогового окна Plotter Configuration Editor (Редактор параметров плоттера) (см. рис. 6.11).

Рис. 6.11. Диалоговое окно Plotter Configuration Editor

Рис. 6.12. Страница Calibrate Plotter — Begin

Согласно описанной ранее процедуре вы проходите в процессе калибровки по страницам Calibrate Plotter — Rectangle Size (Калибровка плоттера — Прямоугольник), Calibrate Plotter — Measured Plot (Калибровка плоттера — Размеры на листе), Calibrate Plotter — File name (Калибровка плоттера — Имя файла), Calibrate Plotter — Finish (Калибровка плоттера — Конец). После этого вы возвращаетесь на последнюю страницу мастера установки плоттера или проверяете результат калибровки с помощью кнопки Check Calibration (Проверка калибровки) (см. рис. 6.10).


6.2. Параметры вывода

После того как вы убедились, что нужный вам плоттер установлен в системе AutoCAD, можете перейти к настройке непосредственного вывода. Для этого предназначены кнопка [image] панели Standard (Стандартная) и пункт Plot (Печать) падающего меню File (Файл). Они соответствуют команде PLOT (ПЕЧАТЬ).
При вызове команды PLOT (ПЕЧАТЬ) появляется диалоговое окно Plot (Печать) (рис. 6.13).

Рис. 6.13.Диалоговое окно Plot, вкладка Plot Device

Это диалоговое окно предназначено для полного определения всех компонентов вывода: конфигурации плоттера, листа бумаги и части рисунка, которую нужно вывести. Окно разделено на три части по вертикали, причем средняя часть, в свою очередь, имеет две вкладки Plot Device (Устройство печати) и Plot Settings (Параметры печати).
Область Layout name (Имя вкладки), находящаяся в верхней левой части диалогового окна, содержит имя вкладки графического экрана AutoCAD, которое имеет либо одно из стандартных значений: Model (Модель), Layout 1 (Лист!) и Layout2 (Лист2), либо значение, назначенное пользователем (об именах, вкладок листов см. гл. 10). Около имени вкладки можно установить флажок Save changes to layout (Сохранить установленные параметры), позволяющий сохранить устанавливаемые в данном окне параметры для следующего вывода.
Область Page setup name (Набор параметров листа) предоставляет возможность сохранять с именем набор параметров листа и вызывать их затем по имени. Расположенная здесь кнопка Add (Добавить) открывает диалоговое окно User Defined Page Setups (Пользовательские наборы параметров листа) (рис. 6.14).

Рис. 6.14. Диалоговое окно User Defined Page Setups

В этом окне можно задать имя новому набору параметров, введя его в поле New page setup name (Имя нового набора). Кроме того, окно в правой своей части имеет следующие три кнопки:

  • Rename (Переименовать) — переименовывает набор;
  • Delete (Удалить) — удаляет набор;
  • Import (Импорт) — импортирует набор параметров из другого рисунка.

В списке Page setups (Наборы параметров листа) перечисляются наборы параметров листа данного рисунка.
Первая вкладка Plot Device (Устройство печати) диалогового окна Plot (Печать) (см. рис. 6.13) содержит параметры настройки устройства вывода. Область Plotter configuration (Конфигурация плоттера) этой вкладки дает возможность выбрать необходимую конфигурацию из числа имеющихся (например, HP DeskJet 400 (Monochrome)). Кнопка Properties (Свойства) позволяет вызвать окно Plotter Configuration Editor (Редактор параметров плоттера) (см. рис. 6.11), в котором можно редактировать и сохранять файл конфигурации плоттера (с расширением рсЗ). Кнопка Hints (Советы) диалогового окна Plot (Печать) (см. рис. 6.13) выводит окно со справочной информацией, относящейся к системным принтерам.
Область Plot style table (pen assignments) (Таблица стилей печати (присвоения перьев)) дает возможность с помощью раскрывающегося списка Name (Имя) выбрать таблицу стилей печати из перечня существующих (о стилях печати см. следующий раздел). Кнопка Edit (Изменить) позволяет отредактировать таблицу, а кнопка New (Новая) — перейти к созданию новой таблицы.
Интересна область Plot stamp (Штамп чертежа), впервые появившаяся в AutoCAD 2000L При установке флажка On (Вкл) система добавляет в чертеж при выводе штемпель (упрощенный штамп), в виде текстовой строки. Содержимое штемпеля сохраняется в файле с расширением pss. Имя файла с установками штемпеля нужно выбрать с помощью кнопки Settings (Установки). Предварительное формирование элементов штемпеля, их редактирование и сохранение выполняется с помощью команды PLOTSTAMP (ШТЕМПЕЛЬ), рассматриваемой далее в данном разделе. Текущее редактирование элементов штемпеля может быть осуществлено в диалоговом окне, открываемом после нажатия кнопки Settings (Установки) (оно будет разобрано далее при изучении команды PLOTSTAMP (ШТЕМПЕЛЬ)).
Область What to plot (Что печатать) с помощью трех переключателей предоставляет средство выбора вкладок графического экрана, которые будут выводиться:

  • Current tab (Текущая вкладка);
  • Selected tabs (Выбранные вкладки);
  • All layout tabs (Все листы).

К выбранным относятся те вкладки, имена которых система в текущий момент показывает белым цветом (для того чтобы добавить вкладку к выбранным, необходимо нажать клавишу <Shift> и щелкнуть левой кнопкой мыши по имени вкладки).
Счетчик Number of copies (Количество экземпляров) управляет количеством копий выводимого чертежа.
Область Plot to file (Печать в файл) позволяет при установленном одноименном флажке Plot to file (Печать в файл) осуществлять вывод не прямо на плоттер, а в файл с расширением pit, который затем может быть выведен на плоттер уже вне системы AutoCAD (по команде пересылки файла в порт, к которому подсоединен плоттер). Раскрывающийся список File name and path (Имя файла и путь) задает полное имя создаваемого PLT-файла для печати в файл. Кнопка [image] вызывает диалоговое окно Browse for Plot File (Обзор чертежных файлов), помогающее выбрать имя и нужную папку для файла.
Вторая вкладка Plot Settings (Параметры печати) диалогового окна Plot (Печать) содержит параметры листа и чертежа (рис. 6.15).
Область Paper size and paper units (Формат листа и единицы) содержит два параметра, раскрывающийся список и два переключателя. Параметр Plot device (Устройство печати) отображает имя плоттера, выбранного на первой вкладке. В раскрывающемся списке Paper size (Формат листа) необходимо выбрать формат листа из тех форматов, которые доступны для выбранного плоттера. Параметр Printable area (Доступная область) отображает размеры реальной области вывода для данного формата листа. Справа от этого параметра находится группа из двух переключателей, используемых для выбора единиц измерения (inches (дюймы) или mm (мм)).

Рис. 6.15. Диалоговое окно Plot, вкладка Plot Settings

Область Drawing orientation (Ориентация чертежа) управляет положением чертежа на листе бумаги. Здесь пользователю доступны два переключателя ориентации чертежа: Portrait (Книжная) или Landscape (Альбомная). При включении второго переключателя выводимый рисунок на листе бумаги поворачивается на 90° относительно книжной ориентации. Можно повернуть изображение еще на 180°, если установить флажок Plot upside-down (Перевернуть).
Очень важна область Plot area (Печатаемая область), ибо именно ее установки определяют, печатаете ли вы весь чертеж или только его часть, а если часть — то какую. Внешний вид области зависит от того, какая из вкладок, указанная в области Layout name (Имя вкладки), выводится на принтер. На рис. 6.15 вид этой области приведен для вкладки листа (Layoutl), а на рис. 6.16 — для вкладки модели (Model).

Рис. 6.16. Область Plot area для вкладки Model

При печати вкладки Model (Модель) в области Plot area (Печатаемая область) (рис. 6.16) располагаются следующие пять переключателей:

  • Limits (Лимиты) — выводится зона лимитов;
  • Extents (Границы) — выводится зона границ, т. е. наименьшая прямоугольная зона, охватывающая в данном виде все элементы чертежа (самый экономичный вариант получения полного изображения);
  • Display (Экран) — выводится только то, что видно в данный момент на графическом экране;
  • View (Вид) — выводится выбранный именованный вид (о задании видов см. разд. 9.2); положение переключателя View (Вид) и раскрывающийся список справа от него для выбора имени вида доступны только тогда, когда в рисунке созданы именованные виды;
  • Window (Рамка) — выводится прямоугольная зона, которая определяется двумя точками по диагонали.

В случае выбора опции Window (Рамка) нужно щелкнуть по кнопке Window (Рамка) и задать положение левого нижнего и правого верхнего углов рамки. После нажатия на эту кнопку AutoCAD временно покидает диалоговое окно и выдает сообщение:
Specify window for printing Specify first corner: (Укажите окно для вывода на печать Первый угол:)
Здесь нужно указать мышью (или ввести с помощью клавиатуры) первый угол рамки. Далее:
Specify opposite corner: (Противоположный угол:)
На этот запрос нужно указать второй угол рамки. После ответа система AutoCAD возвращает диалоговое окно Plot (Печать).
Область Plot scale (Масштаб печати) (см. рис. 6.15) задает масштаб вывода чертежа на плоттер. Раскрывающийся список этой области позволяет выбрать один из стандартных масштабов: Scaled to Fit (Вписать), 1:1, 1:2, 1:4, 1:8, 1:10, 1:16, 1:20, 1:30, 1:40, 1:50, 1:100, 2:1, 4:1, 8:1, 10:1, 100:1 и др. По умолчанию на вкладке Model (Модель) предлагается масштаб Scaled to Fit (Вписать), а на других вкладках — 1:1. Значение Scaled to Fit (Вписать) означает выбор масштаба программой, исходя из размеров выводимой зоны чертежа и размеров доступной области листа бумаги, причем система AutoCAD пытается максимально занять всю площадь листа. Рассчитанный при этом масштаб отображается в следующем поле, например: 1 mm (мм) = 104.7 units (единиц рисунка). В этом же месте отображается и стандартный масштаб, если вы им воспользовались.
Если вам необходимо обеспечить вывод чертежа в нестандартном масштабе 1:27.5, то вы должны в левом поле задать 1 (mm (мм)), а в правом — 27.5 (units (единиц рисунка)).
Флажок Scale lineweights (Масштабировать веса линий) области Plot scale (Масштаб печати) позволяет при выводе масштабировать не только размеры объектов, но и их веса. Если флажок сброшен, то линия при выводе рисуется с заданным весом (заданной толщиной линии) независимо от масштаба чертежа.
Область Plot offset (Смешение от начала) при сброшенном флажке Center the plot (Центрировать) задает дополнительный сдвиг от левого нижнего угла доступной области печати на листе (значения сдвига в мм нужно записать в поля X и Y). Если флажок Center the plot (Центрировать) установлен, то система AutoCAD сама вычисляет значения для этих параметров таким образом, чтобы чертеж расположился точно по центру листа бумаги. При положительных значениях параметров полей X и Y сдвиг осуществляется внутрь листа бумаги (отрицательные значения также допускаются).
В данной версии системы появилась новая область — Shaded viewport options (Параметры раскрашивания видового экрана). Она отражает возможности печати тонированных и раскрашенных видов. В раскрывающемся списке Shade plot (Раскраска чертежа) доступны следующие опции:

  • As Displayed (Как есть);
  • Wireframe (Каркас);
  • Hidden (Co скрытием невидимых линий);
  • Rendered (Тонированная).

Эти опции позволяют печатать видовой экран независимо от того, в каком состоянии он в данный момент в рисунке находится (обычном, раскрашенном, с удалением невидимых линий или тонированном).
В связи с богатством новых возможностей и расширением количества цветов появился также раскрывающийся список Quality (Качество), управляющий качеством вывода тонированных и раскрашенных видов. В список входят такие элементы:

  • Draft (Черновое) — раскраска и тонирование игнорируются, печать выполняется в каркасном виде;
  • Preview (Предварительное) — разрешение 150 dpi (точек на дюйм);
  • Normal (Обычное) — разрешение 300 dpi (точек на дюйм);
  • Presentation (Высокое) — разрешение 600 dpi (точек на дюйм);
  • Maximum (Максимальное) — максимально возможное разрешение для данного принтера;
  • Custom (Пользовательское) — разрешение задает пользователь.

Для последнего варианта необходимо в поле DPI еще задать разрешение в точках на дюйм.
Область Plot options (Опции печати) имеет следующие флажки:

  • Plot object lineweights (Учитывать веса линий объектов) — позволяет учитывать веса линий; данный флажок доступен только при сбросе флажка Plot with plot styles (Учитывать стили печати);
  • Plot with plot styles (Учитывать стили печати) — использует стили печати;
  • Plot paperspace last (Объекты листа последними) — указывает, что печатать в первую очередь: объекты пространства листа или объекты пространства модели (о пространствах см. гл. 9);
  • Hide paperspace objects (Скрывать объекты) — скрывает невидимые линии при использовании соответствующей установки в параметрах видовых экранов (см. гл. 9).

После того как вы задали все установки вкладок Plot Device (Устройство печати) и Plot Settings (Параметры печати), необходимо просмотреть образ печати с помощью кнопок просмотра, расположенных в нижней части диалогового окна Plot (Печать). Первой обычно используется кнопка Partial Preview (Контурный просмотр), которая в окне Partial Plot Preview (Контурный просмотр чертежа) отображает положение печатаемой области относительно листа бумаги (рис. 6.17).

Рис. 6.17. Окно Partial Plot Preview

В окне просмотра белым фоном помечена зона листа, пунктирной линией — доступная область листа, зачернена печатаемая область. В этом окне видно, каким образом нужно задать смещения от начала, чтобы сдвинуть печатаемую область ближе к нужной части листа бумаги. Для контроля приводятся данные печати:

  • Paper size (Размеры листа);
  • Printable Area (Область печати);
  • Effective Area (Эффективная область);
  • Warnings (Предупреждения).

Под эффективной областью понимается та часть листа бумаги, которая будет занята печатаемой областью.
После отработки чертежа с помощью кнопки Partial Preview (Контурный просмотр) рекомендуется воспользоваться кнопкой Full Preview (Полный просмотр) диалогового окна Plot (Печать) (см. рис. 6.15), которая показывает образ листа бумаги с результатом будущей печати без выбранных вами надписей штампа (рис. 6.18).

Рис. 6.18. Окно полного просмотра результатов вывода

В этом окне вам сразу же будет доступна операция зумирования, что демонстрируется значком лупы со знаками плюс и минус в качестве курсора. Вы можете, нажав левую кнопку мыши, перемещать курсор вверх или вниз, изменяя тем самым масштаб отображения чертежа. Выход из операции — с помощью клавиш <Esc> или <Enter>.
Окно полного просмотра образа печати можно вызвать не только из диалогового окна Plot (Печать), но и с помощью кнопки [image] панели инструментов Standard (Стандартная) или с помощью пункта Plot Preview (Просмотр чертежа) падающего меню File (Файл), а также с помощью команды PREVIEW (ПРЕДВАР).
После того как вы убедились в правильности результатов предстоящего вывода, можно в диалоговом окне Plot (Печать) (см. рис. 6.15) нажать кнопку ОК и отправить чертеж на плоттер. Если же во вкладке Plot Device (Устройство печати) диалогового окна Plot (Печать) вы установили флажок Plot to file (Печать в файл), то вместо вывода на плоттер будет сформирован PLT-файл, позволяющий в дальнейшем вывести его на плоттер.
Предварительное формирование штемпеля, выводимого в чертеж при установке флажка On (Вкл) в области Plot stamp (Штемпель) (см. рис. 6.13), выполняется командой PLOTSTAMP (ШТЕМПЕЛЬ). Эта команда открывает диалоговое окно Plot Stamp (Штемпель), приведенное на рис. 6.19.

Рис. 6.19. Диалоговое окно Plot Stamp

В этом окне область Preview (Просмотр) в условном виде показывает, где будет расположен формируемый штемпель при действующих установках (на рис. 6.19 штемпель размещен вертикально в верхнем правом углу чертежа).
Содержимое штемпеля является текстовой строкой, элементы которой разделяются при выводе запятыми. Таких элементов может быть до девяти. Основные элементы (до семи) задаются установками соответствующих флажков в области Plot stamp fields (Информация для штемпеля):

  • Drawing name (Имя рисунка);
  • Layout name (Имя вкладки);
  • Date and Time (Дата и время);
  • Login name (Пользователь);
  • Device name (Устройство);
  • Paper size (Формат листа);
  • Plot scale (Масштаб чертежа).

Назначение элементов соответствует их наименованиям. В качестве имени чертежа берется полное имя вычерчиваемого файла вместе с путем.
В штемпель можно включить не более двух пользовательских элементов, которые выбираются из раскрывающихся списков, расположенных в области User defined fields (Дополнительная информация). В раскрывающихся списках может быть любое количество элементов, однако только два из них могут быть включены в штемпель при очередной операции печати. Для занесения в эти списки новых элементов или редактирования старых используется кнопка Add/Edit (Добавить/Изменить), которая открывает диалоговое окно User Defined Fields (Дополнительная информация) (рис. 6.20).

Рис, 6.20. Диалоговое окно User Defined Fields

В этом окне задаются те поля пользователя, которые можно добавить при выводе к стандартным полям. Кнопка Add (Добавить) дает возможность внести новый элемент в список, кнопка Edit (Изменить) — отредактировать и кнопка Delete (Удалить) — удалить элемент из списка.
Если вы не хотите к стандартным элементам штемпеля добавлять пользовательские, тогда в обоих списках поля User defined fields (Дополнительная информация) (см. рис. 6.19) вы должны выбрать элементы с именем <попе> (<нет>).
Область Plot stamp parameter file (Файл параметров штемпеля) показывает имя текущего файла с расширением pss, в котором хранятся параметры надписи штемпеля. При необходимости загрузить другой файл следует воспользоваться кнопкой Load (Загрузить), а при необходимости сохранить текущие установки в другом PSS-файле — кнопкой Save As (Сохранить как).
Более тонкие установки штемпеля (положение, шрифт и т. д.) могут быть сделаны с помощью кнопки Advanced (Дополнительно) (см. рис. 6.19), которая вызывает диалоговое окно Advanced Options (Дополнительные опции) (рис. 6.21).

Рис. 6.21. Диалоговое окно Advanced Options

В области Location and offset (Расположение и отступы) с помощью следующих параметров определяется, где и каким образом будет расположена надпись штемпеля:

  • Location (Расположение) — задает угол чертежа, относительно которого будет расположен штамп (в раскрывающемся списке доступны значения Bottom left (Внизу слева), Top left (Вверху слева), Top right (Вверху справа) или Bottom right (Внизу справа));
  • Orientation (Ориентация) — указывает ориентацию: Vertical (Вертикально) или Horizontal (Горизонтально);
  • X offset (Отступ по X) — задает сдвиг по оси X;
  • Y offset (Отступ по У) — задает сдвиг по оси Y.

Установка флажка Stamp upside-down (Перевернутый штемпель) переворачивает надпись на 180°.
В нижней части поля находятся еще два переключателя, определяющие, как должны откладываться сдвиги по осям Х и Y:

  • Offset relative to printable area (Отступ относительно области печати);
  • Offset relative to paper border (Отступ относительно границ листа).

Важное значение имеет область Text properties (Свойства текста). В ней задаются имя шрифта (список Font (Шрифт)) и высота букв (поле Height Высота)). Флажок Single line plot stamp (Однострочный штемпель) задает вывод штемпеля в одну строку (при этом хвост длинного штемпеля будет обрезан). Если флажок не установлен, то штемпель выводится в две строки, причем новая строка начинается с четвертого элемента надписи.
В области Plot stamp units (Единицы измерения штемпеля) с помощью раскрывающегося списка задаются единицы измерения для штемпеля, которыми могут быть:

  • Inches (Дюймы);
  • Millimeters (Миллиметры);
  • Pixels (Пикселы).

И, наконец, в области Log file location (Расположение файла журнала) указывается, нужно ли создавать файл протокола размещения штемпеля (при положительном ответе следует установить флажок Create a log file (Вести журнал в файле)), а также, какое у него будет имя и где он будет расположен.
Установки последнего сохраненного PSS-файла параметров штемпеля становятся установками, действующими по умолчанию в следующей операции печати чертежа.


6.3. Стили печати

Стиль печати — это свойство, отсутствовавшее в версиях системы до AutoCAD 2000, которое позволяет отображать графические объекты при выводе на плоттер специальным образом. В результате примитив рисунка может на экране выглядеть совсем не так, как он будет нарисован плоттером на бумаге. Для печати могут быть изменены цвет, тип, а также вес линии. Можно задать специальное оформление концов и заливки линии. Все такие установки заносятся в таблицы стилей. Система AutoCAD при установке программного обеспечения создает ряд стандартных таблиц стилей печати, которые доступны пользователю.
Стили печати могут быть двух видов: именованные и цветозависимые. Именованный стиль печати может быть назначен любому объекту, а цветозависимый стиль используется в зависимости от цвета примитива.
При входе в новый рисунок устанавливается, какие из двух типов стилей печати будут в нем использоваться. Как уже было сказано в разд. 6.1, для этого в области Default plot style behavior for new drawings (Стили печати для новых рисунков) вкладки Plotting (Печать) диалогового окна Options (Настройка) (см. рис. 6.2) нужно включить один из двух переключателей: Use color dependent plot styles (Цветозависимые стили печати) или Use named plot styles (Именованные стили печати). Сделанное изменение будет распространяться только на следующий новый рисунок и не будет действовать на текущий. По умолчанию устанавливаются цветозависимые стили печати.
Вызов редактора любых стилей печати может быть выполнен с помощью команды STYLESMANAGER (ДИСПСТИЛЬ) или пункта Plot Style Manager (Диспетчер стилей печати) падающего меню File (Файл). Диспетчер открывает папку Plot Styles (рис. 6.22).

Рис. 6.22. Папка Plot Styles

В этой папке имеются значки [image] ранее созданных файлов с таблицами цветозависимых стилей (с расширением ctb) и значки [image] файлов с таблицами именованных стилей (с расширением stb). Кроме того, присутствует значок [image] Add-A-Plot Style Table Wizard (Мастер стилей печати), вызывающий программу-мастер создания таблицы именованных стилей.
В падающем меню Tools (Сервис) в подменю Wizards (Мастера) имеются также пункты Add Plot Style Table (Создание таблиц стилей печати) и Add Color-Dependent Plot Style Table (Создание цветозависимых стилей печати) для создания таблиц стилей обоих видов.
Как вы уже знаете из разд. 6.2, в раскрывающемся списке Name (Имя) области Plot style table (pen assignments) (Таблица стилей печати (присвоения перьев)) вкладки Plot Device (Устройство печати) диалогового окна Plot (Печать) (см. рис. 6.13) можно выбрать текущий стиль печати из перечня существующих (например, acad.ctb), а с помощью кнопки Edit (Изменить) отредактировать выбранный стиль и перейти к созданию нового стиля с помощью кнопки New (Новая).
Цветозависимые стили, которых в каждой таблице 255 (по количеству основных цветов системы AutoCAD), описывают, каким образом нужно выводить на плоттер объекты, имеющие данный цвет. Такие стили удобны для вывода на перьевой плоттер, который имеет ограниченное количество цветов и размеров перьев. По умолчанию, когда имя таблицы действующего цветозависимого стиля не задано, действует стиль, который выводит объекты в том виде, в каком они созданы в рисунке.
В случае применения в рисунке цветов типа True Color (Точный цвет) и цветов из Color Books (Цветовые книги) (см. разд. 4.1) система AutoCAD подбирает в качестве цветозависимого стиля печати стиль одного из основных цветов (с номером из диапазона 1—255), который ближе всего к используемому.
Рассмотрим для примера таблицу цветозависимых стилей acad.ctb, для открытия которой нужно дважды щелкнуть по значку acad.ctb в папке Plot Styles (см. рис. 6.22). После щелчка открывается диалоговое окно Plot Style Table Editor (Редактор таблиц стилей печати), вкладка General (Общие) (рис. 6.23).
Цвета в данной таблице расположены по столбцам (Color 1, Color 2), а свойства стиля — по строкам. К свойствам относятся следующие характеристики:

  • Description (Описание);
  • Color (Цвет);
  • Enable dithering (Разрешить размывание);
  • Convert to grayscale (Печатать оттенками серого);
  • Use assigned pen # (Номер назначенного пера);
  • Virtual pen # (Номер виртуального пера);
  • Screening (Интенсивность);
  • Linetype (Тип линии);
  • Adaptive adjustment (Подстройка масштаба);
  • Lineweight (Вес линии);
  • Line End Style (Стиль окончания линий);
  • Line Join Style (Стиль соединения линий);
  • Fill Style (Стиль заполнения).

Рис. 6.23. Диалоговое окно Plot Style Table Editor, вкладка General

Смысл приведенных параметров достаточно прозрачен. Виртуальное перо может быть сгенерировано у струйных плоттеров для имитации пера. Обычное значение номера виртуального пера — Automatic (Авто).
Для редактирования характеристики стиля, соответствующего цвету, щелкните по нужной клетке таблицы. Система AutoCAD предложит вам список допустимых значений с линейкой прокрутки или шкалой справа. С помощью линейки или шкалы можно установить требуемое значение.
Третья вкладка — Form View (Карточка) — показывает свойства стиля в форме карточки (рис. 6.25).
Работа с этой вкладкой аналогична работе с вкладкой Table View (Таблица). Внесенные изменения всех вкладок закрепляются с помощью кнопки Save & Close (Сохранить).

Рис. 6.24. Диалоговое окно Plot Style Table Editor, вкладка Table View

Рис. 6.25. Диалоговое окно Plot Style Table Editor, вкладка Form View

Если вы задали в рисунке применение именованных стилей, то их использование и редактирование выполняются, как и для цветозависимых стилей, однако каждый стиль имеет свое имя. Нередактируемый стиль Normal (Обычный) обязательно присутствует и выводит на плоттер все свойства объектов в том виде, в каком они присвоены объектам, без изменений.
Если в текущем рисунке задано использование именованных стилей, то вам доступен раскрывающийся список стилей печати, расположенный в панели Properties (Свойства) (см. рис. 4.1 четвертый слева). В случае цветозависимых стилей этот список заблокирован.


Глава 7. Блоки и внешние ссылки

    • Блоки и внешние ссылки
    • 7.1. Блоки
    • 7.1.1. Описание блока
    • 7.1.2. Вставка блока
    • 7.1.3. Панель TOOL PALETTES
    • 7.1.4. Вхождение блока
    • 7.1.5. Экспорт блоков и фрагментов рисунка
    • 7.1.6. Атрибуты
    • 7.1.7. Работа с буфером обмена Windows
    • 7.2. Внешние ссылки
    • 7.2.1. Диспетчер внешних ссылок
    • 7.2.2. Операции над внешними ссылками
    • 7.3. Редактирование блоков и внешних ссылок
    • 7.3.1. Редактирование значений атрибутов
    • 7.3.2. Подрезка вхождений блоков и внешних ссылок
    • 7.3.3. Редактирование вхождений блоков и внешних ссылок


Важным инструментом автоматизации процесса разработки чертежей и моделей является использование блоков и внешних ссылок. Блок — это сложный именованный объект, для которого создается описание, включающее любое количество примитивов текущего рисунка. Блок имеет базовую точку ;; может применяться для вставки в любое место чертежа, причем в процессе вставки возможен его поворот и масштабирование с различными коэффициентами по разным осям. Блок может содержать атрибуты — переменные надписи, задаваемые пользователем. Примитив, который образуется от операции вставки блока, называется вхождением блока. В рисунке может быть любое количество вхождений одного и того же блока.
Внешняя ссыпка — это изображение внешнего файла вместе с элементами текущего рисунка, причем файл, на который вы таким образом ссылаетесь, не переписывается в основной рисунок. В результате текущий рисунок может быть насыщен большим количеством внешних изображений новых объектов, но размер текущего файла от этого практически не увеличится. Примитив, образующийся от операции вставки внешней ссылки, будем называть вхождением внешней ссылки или просто внешней ссылкой.
Оба упомянутых инструмента являются средством автоматизации труда конструктора и чертежника. С помощью блоков можно строить однотипные объекты, описывая полностью только один их них, а остальные получая из него вставкой блока. Внешние ссылки дают возможность пользоваться ранее созданными файлами стандартных графических элементов.
В данной главе также рассмотрены вопросы вставки фрагментов из других рисунков, в том числе с использованием буфера Windows.


7.1. Блоки

Первый шаг к использованию блока — создать его описание. Для этого нужно определиться, из каких примитивов будет состоять блок и где у него будет базовая точка.


7.1.1. Описание блока

Предположим, в нашем рисунке есть полилиния с шириной 1 мм в форме правильного шестиугольника (радиус описанной окружности — 10 мм). Внутри шестиугольника нарисованы два отрезка и касающаяся их окружность радиуса 5 мм. В качестве базовой точки блока возьмем точку центра окружности. Конструируемому блоку дадим имя Element6. На рис. 7.1 показаны примитивы, которые будут участвовать в создании блока.

Рис. 7.1. Примитивы, включаемые в блок Elements

Для того чтобы образовать описание блока, нужно применить команду BLOCK (БЛОК). Команде соответствуют кнопка [image] панели инструментов Draw (Рисование) и пункт падающего меню Draw | Block | Make (Рисование | Блок Создать).
Команда BLOCK (БЛОК) вызывает диалоговое окно Block Definition (Описание блока) (рис. 7.2). Заполним его поля данными для нашего примера.
В поле раскрывающегося списка Name (Имя) нужно ввести имя создаваемого (или переопределяемого) описания блока, в нашем случае — Element6. Имена блоков могут содержать русские и латинские буквы, цифры и отдельные знаки (подчеркивание, минус и некоторые другие). Все буквы в составе имени системой AutoCAD автоматически переводятся в верхний регистр. Не допускаются знак плюс и большая часть других символов, не являющихся буквами и цифрами. Длина имени не должна превышать 255 символов. Если значение системной переменной EXTNAMES равно 0 (а обычное значение — 1), то длина имени блока будет ограничиваться 31 символом, как это было в системе AutoCAD R14 (о системных переменных см. разд. 11.1). Знак пробела допускается в составе имени в системе AutoCAD, но опыт показывает, что без большой нужды его лучше не употреблять. В качестве заменителя пробела лучше использовать символ подчеркивания. Также с осторожностью применяйте русские имена в английской версии AutoCAD.

Рис. 7.2. Диалоговое окно Block Definition

Область Base point (Базовая точка) предназначена для задания базовой точки блока (за эту точку блок будет позиционироваться на поле рисунка при вставке). Координаты точки можно ввести с клавиатуры, заполнив поля X, Y и Z. В нашем примере выберите эту точку мышью, для чего нужно сначала нажать кнопку [image] Pick point (Указать точку), что на некоторое время уберет с экрана диалоговое окно Block Definition (Описание блока). Затем нужно с помощью объектной привязки указать точку центра окружности (эту точку мы предварительно решили выбрать в качестве базовой). После указания точки возвращается диалоговое окно, в котором поля X, Y и Z будут отображать координаты выбранной точки.
Область Objects (Объекты) предназначена для того, чтобы указать объекты, включаемые в описание блока. Нажмите кнопку [image] Select objects (Выбрать объекты) или [image] (Quick select (Быстрый выбор)) и выберите четыре примитива, которые войдут в блок.
Группа переключателей, расположенных под кнопкой Select objects (Выбрать объекты), позволяет задать действие над объектами, включенными в блок, которое будет выполнено после создания описания блока:

  • Retain (Оставить) — сохранить объекты в рисунке в том виде, в каком они были до создания описания блока;
  • Convert to block (Сделать блоком) — заменить указанные объекты на вхождение блока;
  • Delete (Удалить) — удалить объекты из рисунка.

По умолчанию, как правило, предлагается вариант Convert to block (Сделать блоком).
После выбора объектов сообщение No objects selected (Объекты не выбраны) в нижней части области Objects (Объекты) заменяется на сообщение n objects selected (Выбрано объектов), где n — число выбранных объектов. В нашем примере количество выбранных объектов должно равняться четырем.
В области Preview icon (Образец для просмотра) определяется, нужно ли сохранять вместе с блоком растровый образец для операций просмотра. Переключатели этого раздела:

  • Do not include an icon (He включать образец в блок);
  • Create icon from block geometry (Создать образец по объектам блока).

При использовании средств просмотра в Центре управления рядом с именем блока будет показан его графический образец. О Центре управления рассказано в разд. 5.4.
В раскрывающемся списке Drag-and-drop units (Единицы вставки) необходимо выбрать единицы, в которых будет вставляться блок при перемещении в другие рисунки. Обычное значение — Millimeters (Миллиметры).
Поле Description (Пояснение) содержит комментарий к создаваемому описанию блока. Кнопка Hyperlink (Гиперссылка) позволяет связать с блоком гиперссылку.
На рис. 7.3 показан пример заполнения полей диалогового окна Block Definition (Описание блока) в соответствии с условиями рассматриваемого примера.

Рис. 7.3. Пример заполнения полей диалогового окна Block Definition

После нажатия в диалоговом окне кнопки ОК внутри рисунка образуется описание блока с именем Element6. Описание является невидимым компонентом, к которому можно обращаться для операции вставки блока. Если в области Objects (Объекты) выбрать переключатель Convert to block (Сделать блоком), то примитивы, из которых мы составили описание блока, заменились бы на вхождение блока. Вхождение блока (часто его называют просто блоком) в рисунке имеет всего одну ручку, т. к. является единым объектом для операций общего редактирования (стирания, перемещения и т. п.). Блок можно расчленить на примитивы командой EXPLODE (РАСЧЛЕНИТЬ).


7.1.2. Вставка блока

Теперь рассмотрим операцию вставки блока. Для нее используется команда INSERT (ВСТАВИТЬ), которой соответствуют кнопка [image] групповой кнопки [image] панели инструментов Draw (Рисование) и пункт Block (Блок) падающего меню Insert (Вставка). Кроме того, этой команде соответствует аналогичная кнопка [image] панели инструментов Insert (Вставка) (рис. 7.4).

Рис. 7.4. Панель инструментов Insert

На кнопке [image] в правом нижнем углу стоит черный треугольник — это означает, что кнопка групповая и если нажать левой кнопкой мыши на такую кнопку и не отпускать ее, то раскроется ряд кнопок, объединенных в одну группу (все эти кнопки входят также в панель Insert (Вставка)). Первая из кнопок этой группы соответствует команде INSERT (ВСТАВИТЬ).
Отпустите левую кнопку мыши в тот момент, когда указатель будет находиться на кнопке Insert Block (Вставка блока) [image] . В этот момент начнет работать команда INSERT (ВСТАВИТЬ), которая вызывает диалоговое окно Insert (Вставка блока) (рис. 7.5).

Рис. 7.5. Диалоговое окно Insert

Данное окно позволяет вставлять в текущий рисунок описанные в нем блоки (а также файлы из других рисунков). В раскрывающемся списке Name (Имя) нужно выбрать имя вставляемого блока. По умолчанию в данном поле обычно высвечивается имя последнего вставленного блока. В нашем примере (см. рис. 7.5) высвечивается имя Element6, потому что это единственный описанный блок рисунка. Кнопка Browse (Обзор) используется для выбора файла, если данное диалоговое окно было открыто для вставки файла. В этом случае параметр Path (Путь) отобразит полный путь к файлу, который вы выберете для вставки.
В области Insertion point (Точка вставки) нужно задать точку текущего рисунка, в которую будет помещена базовая точка блока. Если установить флажок Specify On-screen (Указать на экране), то после закрытия окна тонча вставки будет отдельно запрошена системой. Если этот флажок сброшен, то для ввода доступны поля X, Y и Z, в которых нужно заполнить координаты точки вставки. Чаще всего используется указание точки на экране. Для двумерных чертежей параметр поля Z задается нулевым.
Область Scale (Масштаб) предназначена для ввода по каждой из трех осей масштабных коэффициентов, с которыми блок будет вставляться на поле рисунка. Если все три масштабных коэффициента (по осям X, Y и Z) равны 1, то блок будет вставлен с теми же размерами, какие были у объектов, использованных в описании блока. Если по какой-то оси масштабный коэффициент меньше 1, то блок при вставке сжимается вдоль по этой оси, если больше 1 — растягивается с данным коэффициентом по этой оси. Масштабные коэффициенты могут быть и отрицательными (тогда изображение блока по этой оси переворачивается). Установленный флажок Specify On-screen (Указать на экране) означает, что вместо масштабных коэффициентов можно будет по закрытии окна указать трехмерную точку, три координаты смещения (в миллиметрах) которой от точки вставки блока станут тремя коэффициентами масштабирования блока. Если установлен флажок Uniform Scale (Равные масштабы), то поля Y и Z становятся недоступными т. е. гасятся), а значение, заданное в поле X, становится значением масштабных коэффициентов по всем трем осям.
В области Rotation (Угол поворота) задается угол поворота блока относительно точки вставки (положительные значения — при повороте против часовой стрелки). Если значение угла поворота будет равно нулю, то блок не поворачивается. Установка флажка Specify On-screen (Указать на экране) означает, что после закрытия диалогового окна угол будет указан мышью. Поле Angle (Угол) используется для задания угла числом с помощью клавиатуры.
Последний флажок — Explode (Расчленить), расположенный в правом нижнем углу диалогового окна Insert (Вставка блока), — предназначен для расчленения блока сразу после его вставки. В этом случае изображение блока вставляется : заданными параметрами масштабных коэффициентов и угла и тут же раскладывается на отдельные примитивы. Изображение вставленного блока при этом уже не будет единым объектом (т. е. не будет вхождением блока).
После задания всех параметров необходимо закрыть диалоговое окно Insert ( Вставка блока) с помощью кнопки ОК. Если вы в области Insertion point (Точка вставки) установили флажок Specify On-screen (Указать на экране), то после закрытия диалогового окна Insert (Вставка блока) система AutoCAD выдает запрос:
Specify insertion point or [Scale/X/Y/Z/Rotate/PScale/PX/PY/PZ/PRotate]: (Точка вставки или | Масштаб/Х/Г/г/ПОворот/ПМасштаб/ПХ/ПУ/П2/ППоворот]:)
Если в этот момент перемещать курсор по графическому экрану, то вместе с перекрестием, указывающим на базовую точку блока, начинает перемещаться изображение блока в натуральную величину (как это показано в правой части графического экрана на рис. 7.6).

Рис. 7.6. Перемещение изображения блока

Вы можете либо указать точку вставки блока (в данную точку будет помещена базовая точка блока и относительно нее будут выполнены масштабирование и поворот), либо выбрать одну из опций. Напомним, что везде, где вам предстоит выбор из нескольких опций, вы можете для облегчения выбора вызвать контекстное меню с помощью щелчка правой кнопки мыши внутри графического экрана. Первые пять опций позволяют задать параметры вставки блока в наиболее удобной для пользователя последовательности:

  • Scale (Масштаб) — ввод единого масштабного коэффициента по всем трем осям;
  • X (X) — ввод масштабного коэффициента по оси X;
  • Y (Y) — ввод масштабного коэффициента по оси Y;
  • Z (Z) — ввод масштабного коэффициента по оси Z;
  • Rotate (ПОворот) — ввод угла поворота блока.

Еще пять опций являются не параметрами вставки блока, а параметрами слежения при перемещении блока вместе с курсором по полю рисунка. Это полезно, когда блок имеет достаточно большие размеры и перемещение его с размерами по умолчанию (т. е. когда масштабные коэффициенты по всем осям равны 1, а угол поворота равен 0) не дает возможности зрительно оценить его будущее положение на чертеже. Опции слежения следующие:

  • PScale (ПМасштаб) — ввод единого масштабного коэффициента перемещения для всех трех осей;
  • РХ (ПХ) — ввод масштабного коэффициента по оси X для перемещения;
  • PY (ГТУ) — ввод масштабного коэффициента по оси Y для перемещения;
  • PZ (П7) — ввод масштабного коэффициента по оси Z для перемещения;
  • PRotate (ППоворот) — ввод угла поворота блока при перемещении.

Если вы начали на экране с указания точки вставки, то следующий запрос системы будет таким (он будет пропущен, если в диалоговом окне уже были определены масштабные коэффициенты вставки):
Enter X scale factor, specify opposite corner, or fCorner/XYZJ <1>:
(Введите масштаб no оси Х, укажите второй угол или [Угол/XYZ] <!>:)
Если ввести ненулевое число, то оно будет воспринято как масштабный коэффициент по оси X.
Если указать точку, то координаты ее смещения в миллиметрах от точки вставки будут взяты в качестве масштабных коэффициентов по всем осям. Например, если вторая точка смещена от точки вставки на 6,2 мм по оси X, на 3,97 мм по оси Y и на 0 мм по оси Z, то в качестве масштабных коэффициентов будет принята следующая тройка чисел: 6.2, 3.97, 1.0. Таким образом, нулевое значение по оси Z заменится на значение ло умолчанию, т. е. на 1.
Опция Corner (Угол) запрашивает вторую точку и работает аналогично предыдущему случаю.
Опция XYZ запрашивает масштабные коэффициенты вставки.
После указания масштабных коэффициентов выдается заключительный запрос на угол поворота блока относительно точки вставки:
Specify rotation angle <0>: (Угол поворота <0>:)
На рис. 7.7 показан блок Elements, вставленный несколько раз с разными углами поворота и различными масштабными коэффициентами.
Если перед именем команды вставки добавить знак минус (-INSERT (-ВСТАВИТЬ)), то команда вставки будет работать в режиме командной строки, т. е. без диалогового окна. Первый запрос, который она выдает, — это запрос имени вставляемого объекта:
Enter block name or [?] <ELEMENT6>: (Имя блока или [?] <ELEMENT6>:)

Рис. 7.7. Примеры вставки блока Elements

В качестве значения по умолчанию в скобках предлагается имя предыдущего вставленного блока. Нужно либо согласиться со значением по умолчанию, нажав клавишу <Enter>, либо ввести имя другого блока, или знак вопроса для просмотра списка имен блоков, описанных в текущем рисунке. После указания имени блока остальные запросы команды вставки совпадают с рассмотренными ранее.
Есть еще одна команда вставки блока, которую можно выполнить из командной строки. Это команда MINSERT (МВСТАВИТЬ). Она вставляет блок в одну точку, а затем копирует его как элементы прямоугольного массива (аналогично команде ARRAY (МАССИВ)). Команда MINSERT (МВСТАВИТЬ) сначала выдает такие же запросы, как и команда INSERT (ВСТАВКА), но затем появляются дополнительные:
Enter number of rows (---) <1>: (Число рядов (---) <]>:)
Нужно задать число рядов (строк) в будущей прямоугольной матрице из вхождений блока.
Enter number of columns (|||) <1>: (Число столбцов (|||) <]>:)
Здесь требуется указать количество столбцов.
Enter distance between rows or specify unit cell (---): (Расстояние между рядами или размер ячейки (---):)
В этом случае, если ввести число, то оно будет воспринято как расстояние между рядами, а если ввести точку, то координаты ее смещения относительно точки вставки блока станут расстоянием между рядами и расстоянием между столбцами. Если задано только одно число (т. е. расстояние между рядами), то выдается следующий запрос:
Specify distance between columns (|||): (Расстояние между столбцами (|||):)
Результат работы команды показан на рис. 7.8. Массив блоков, созданных командой MINSERT (МВСТАВИТЬ), является единым объектом и не расчленяется командой EXPLODE (РАСЧЛЕНИТЬ).

Рис. 7.8. Вставка массива блоков

Команда INSERT (ВСТАВИТЬ) может быть использована и для вставки в текущий рисунок файлов других рисунков с образованием описаний блоков, одноименных вставляемым файлам. Этой цели в диалоговом окне Insert (Вставка блока) служит кнопка Browse (Обзор) (см. рис. 7.5), которая вызывает диалоговое окно выбора файла. В этом окне вы можете указать графический файл (с расширением dwg), который будет импортирован в текущий рисунок. Предположим, вы выбрали для вставки файл с полным именем d:\our\build0\zim.dwg. Тогда система AutoCAD образует в вашем рисунке новое описание блока с именем ZIM, а в поле Path (Путь) диалогового окна Insert (Вставка блока) будет занесено значение d:\our\biuld0. После закрытия диалогового окна с помощью кнопки ОК на поле текущего рисунка окажется вхождение блока с изображением вставленного файла. В качестве базовой точки вставляемого блока берется точка с нулевыми координатами (изменить координаты базовой точки можно с помощью системной переменной INSBASE — см. разд. 11.1 и приложение 2).
Если в диалоговом окне Insert (Вставка блока) установлен флажок Explode (Расчленить), то описание блока не образуется, а новый файл просто копируется в текущей рисунок с параметрами вставки.
Таким образом, мы разобрали операцию вставки файла в текущий рисунок с помощью команды INSERT (ВСТАВИТЬ). Центр управления, рассмотренный в разд. 5.4, позволяет вставлять в текущий чертеж блоки, описанные в файлах других рисунков, простым перетаскиванием с помощью мыши.


7.1.3. Панель TOOL PALETTES

В системе AutoCAD 2004 появился новый инструмент — панель TOOL PALETTES (Палитры инструментов), которую можно использовать для быстрой вставки самых употребительных блоков (из других рисунков), штриховок и заливок.
По умолчанию в панели TOOL PALETTES (ПАЛИТРЫ ИНСТРУМЕНТОВ) (рис. 7.9) имеются три палитры, каждая из которых оформлена как вкладка: ISO Hatches (Штриховки ISO), Sample office project (Примерный офисный проект), Imperial Hatches (Английские штриховки). На рисунке показана панель TOOL PALETTES (ПАЛИТРЫ ИНСТРУМЕНТОВ) с активизированной вкладкой Sample office project (Примерный офисный проект). Активизация нужной вкладки выполняется щелчком левой кнопки мыши по имени палитры.
Внутри палитры может быть расположено любое количество образцов штриховок, заливок и блоков. На рис. 7.9 в видимой части показаны три заливки и четыре блока. Перемещение по палитре выполняется с помощью вертикальной линейки прокрутки, расположенной в правой части.
Если щелкнуть правой кнопкой мыши по элементу палитры, появится контекстное меню (рис. 7.10), имеющее пять следующих пунктов:

  • Cut (Вырезать) — копирование элемента в буфер обмена Windows с удалением из палитры;
  • Сору (Копировать) — копирование элемента в буфер обмена Windows без удаления из палитры;
  • Delete Tool (Удалить) — удаление элемента;
  • Rename (Переименовать) — переименование элемента;
  • Properties (Свойства) — вызов окна свойств элемента.

Рис. 7.9. Панель TOOL PALETTES с активной вкладкой Sample office project

Рис. 7.10. Контекстное меню элемента палитры

На рис. 7.11 показано окно Tool Properties (Свойства инструмента) свойств заливки с названием Office trim carpet. Структура этого окна для штриховок и заливок одинакова. В группе параметров Pattern (Образец) показаны специфические свойства, а в General (Общие) — стандартные свойства (цвет, слой и т. п.).

Рис. 7.11. Окно Tool Properties свойств заливки Office trim carpet

Свойства штриховок и заливок знакомы нам по разд. 2.15. Для изменения доступны только те свойства элемента палитры, которые приведены на белом фоне (если фон серый, то это свойство отключено или недоступно). Для корректировки значения свойства щелкните по его строке и выберите из списка или задайте новое значение. На рис. 7.12 показано окно свойств с заменой заливки SOLID на штриховку BOX. В поле просмотра Image (Образец) отображается образец новой формы элемента палитры. После редактирования свойства необходимо закрыть окно щелчком по кнопке ОК.
На рис. 7.13 приведено окно Tool Properties (Свойства инструмента) свойств блока с именем Desk — 30 х 60 in. Для блоков структура этого окна немного отличается от структуры окна, показанного на рис. 7.11 для заливки (штриховки). В списке вместо группы параметров Pattern (Образец) в окне присутствует Insert (Вставка).
Перечислим основные свойства блока, находящиеся в группе параметров Insert (Вставка):

  • Name (Имя) — имя блока;
  • Source (Источник) — полное имя файла, содержащего описание блока;
  • Scale (Масштаб) — масштабный коэффициент, который будет применен при вставке блока (масштаб один по всем трем осям);
  • Rotation (Поворот) — угол поворота блока при вставке;
  • Explode (Расчленение) — признак расчленения блока при вставке (Yes (Да) или No (Нет)).

Рис. 7.12. Изменение свойств заливки (штриховки)

Рис. 7.13. Окно Tool Properties свойств блока Desk - 30 х 60 in

Для вставки блока необходимо мышью перетащить изображение блока в рисунок. Блок будет вставлен с теми значениями коэффициентов и угла, которые в данный момент указаны в окне свойств вставляемого элемента. Поэтому рекомендуется перед вставкой проверить текущие значения свойств и отредактировать их.
Другой вариант вставки — щелкнуть левой кнопкой мыши по нужному элементу, после чего система выдаст запрос:
Specify insertion point: (Точка вставки:)
Остается задать точку вставки любым известным нам способом. Способы вставки блока аналогичны способам вставки блоков из окна Центра управления.
Для вставки штриховки или заливки из панели TOOL PALETTES (Палитры инструментов) (см. рис. 7.9) необходимо мышью перетащить элемент палитры внутрь штрихуемой замкнутой зоны рисунка. Можно также щелкнуть по элементу и система выдаст запрос о точке вставки.
Добавление блока к палитре выполняется перетаскиванием выбранного элемента из Центра управления. Удаление блока выполняется с помощью пункта Delete Tool (Удалить) контекстного меню элемента палитры (см. рис. 7.10).
Если щелкнуть правой кнопкой мыши внутри панели TOOL PALETTES (Палитры инструментов), но не на элементе палитры, то откроется контекстное меню редактирования свойств и структуры панели (рис. 7.14).

Рис. 7.14. Контекстное меню панели TOOL PALETTES

Контекстное меню имеет следующие пункты:

  • Allow Docking (Разрешить закрепление) — разрешает или запрещает закрепление палитры по краям графического экрана;
  • Auto-hide (Автоматически скрывать) — разрешает или запрещает автоматическое сворачивание, если курсор оказывается вне панели;
  • Transparency (Прозрачность) — вызывает окно настройки прозрачности панели; в прозрачном режиме под панелью видны элементы рисунка;
  • View Options (Настройки отображения) — вызывает окно настройки параметров отображения элементов палитры (размера значков и пояснительного текста);
  • Paste (Вставить) — вставляет новый элемент из буфера обмена Windows;
  • New Tool Palette (Новая палитра) — создает новую палитру в панели;
  • Delete Tool Palette (Удалить палитру) — удаляет активную палитру из панели;
  • Rename Tool Palette (Переименовать палитру) — переименовывает активную палитру;
  • Customize (Адаптация) — вызывает окно, позволяющее внести изменения в панель (добавить, удалить, переименовать, переставить вкладки).

Вкладки (палитры) панели TOOL PALETTES (Палитры инструментов) тоже имеют контекстное меню, вызываемое с помощью правой кнопки мыши (рис. 7.15).

Рис. 7.15. Контекстное меню вкладок панели TOOL PALETTES

Два первых пункта предназначены для перестановки вкладок:

  • Move Up (Вверх) — перемещает выбранную палитру вверх по списку;
  • Move Down (Вниз) — перемещает выбранную палитру вниз по списку.

Остальные пять пунктов повторяют пункты контекстного меню, приведенного на рис. 7.14.


7.1.4. Вхождение блока

Вернемся теперь непосредственно к блокам. При выборе мышью объекта вхождения блока на нем высвечивается одна ручка, которая располагается в точке вставки. К этой точке можно привязаться с помощью функции Snap to Insert (Привязка к вставке блока), которой соответствует кнопка [image] панели инструментов Object Snap (Объектная привязка).
Объекты, включенные в блок при его описании, сохраняют свои основные свойства (слой, цвет, тип линии, вес) и во вставленном блоке. Исключением является специальное значение BYBLOCK (ПОБЛОКУ), которое может быть дано цвету, типу линии и весу. Использование значения BYBLOCK (ПОБЛОКУ) рассмотрено в разд. 7.3. В описание блока могут включаться вхождения других блоков.
Вхождение блока тоже имеет такие свойства, как цвет, слой и др. Они внешне обычно никак не проявляются. Однако если выключить или заморозить слой, на котором находится вхождение блока, то весь вставленный блок станет невидимым (независимо от того, на каких слоях были составляющие его элементы). Если примитивы, из которых образован блок, имели разные слои, то они во вхождении блока становятся невидимыми, при выключении или замораживании их слоя.


7.1.5. Экспорт блоков и фрагментов рисунка

Любой фрагмент рисунка (например, описание блока) может быть с помощью команды WBLOCK (ПБЛОК) выведен в отдельный файл. Эта команда вызывает диалоговое окно Write Block (Запись блока на диск) (рис. 7.16).

Рис. 7.16. Диалоговое окно Write Block

В области Source (Источник данных) диалогового окна с помощью группы переключателей задается тот фрагмент рисунка, который нужно сохранить в виде нового файла рисунка. Возможен один из трех вариантов:

  • Block (Блок) — позволяет ввести или выбрать с помощью раскрывающегося списка имя блока, описание которого будет взято в качестве выводимого фрагмента;
  • Entire drawing (Весь рисунок) — дает возможность в качестве фрагмента взять весь рисунок в его текущем состоянии (аналогично операции сохранения рисунка под другим именем, но при этом не выводятся такие неиспользованные элементы, как слои, типы линий и т. п.);
  • Objects (Объекты) — позволяет с помощью мыши отметить те объекты, которые будут выведены в новый файл.

Если выбран переключатель Objects (Объекты), то становятся доступными области Base point (Базовая точка) и Objects (Объекты), назначение которых аналогично назначению таких же полей диалогового окна Block Definition (Описание блока) (см. рис. 7.2), рассмотренного ранее. В области Base point (Базовая точка) (рис. 7.16) задается базовая точка для выводимого файла или создаваемого описания блока. Кнопки области Objects (Объекты) позволяют выбрать выводимые примитивы, а также указать, что сделать с выбранными объектами после завершения команды WBLOCK (ПБЛОК):

  • Retain (Оставить) — сохранить в текущем рисунке выбранные объекты в том виде, в каком они были ранее;
  • Convert to block (Сделать блоком) — создать в текущем рисунке описание блока (в качестве имени блока взять имя файла из области Destination (Размещение)), а выбранные объекты заменить на вхождение этого блока;
  • Delete from drawing (Удалить из рисунка) — удалить выбранные примитивы из текущего рисунка.

Нижняя часть области Objects (Объекты) показывает, какое количество объектов выбрано для вывода.
В области Destination (Размещение) определяется имя и местоположение создаваемого файла, в который выводится фрагмент текущего рисунка:

  • File name and path (Имя файла и путь) — позволяет ввести имя и папку создаваемого файла (по умолчанию — new block.dwg); это же имя (без расширения) становится именем образуемого описания блока, если в области Objects (Объекты) выбран переключатель Convert to block (Сделать блоком); путь можно выбрать с помощью кнопки [image] ;
  • Insert units (Единицы) — дает возможность выбора единиц измерения, если создаваемый файл в дальнейшем будет использоваться для вставки в качестве блока.

После закрытия диалогового окна Write Block (Запись блока на диск) с помощью кнопки ОК система AutoCAD образует требуемый файл.
Таким образом, любые части рисунков могут сохраняться в виде отдельных файлов, а любые созданные файлы могут вставляться в текущий рисунок с образованием (или без образования) блоков.


7.1.6. Атрибуты

Часто возникает необходимость вместе с блоком держать и надписи, которые могли бы менять свои значения после вставки блока. Например, если вы рисуете схему с использованием заранее подготовленных блоков условных элементов, тогда номера или наименования вставленных графических элементов вам нужно будет оформить в виде текстовых надписей. Однако в системе AutoCAD есть специальный примитив, называемый ATTRIBUTE DEFINITION (ОПИСАНИЕ АТРИБУТА), который может быть включен в описание блока, а при операции вставки этого блока будет запрошено его значение и создан атрибут (текстовая строка), входящий в состав блока.
Для создания атрибутов применяется команда ATTDEF (АТОПР), которой соответствует пункт падающего меню Draw | Block | Define Attributes (Рисование | Блок | Задание атрибутов). Команда ATTDEF (АТОПР) вызывает диалоговое окно Attribute Definition (Описание атрибута) (рис. 7.17).

Рис. 7.17. Диалоговое окно Attribute Definition

Рассмотрим параметры этого окна на следующем примере. Предположим, нам нужно нарисовать схему размещения компьютеров в служебном помещении. В качестве условного изображения компьютера будем использовать блок, состоящий из двух прямоугольников (например, внешний прямоугольник с размерами 40 мм на 30 мм, а внутренний образован параллельной линией с величиной смещения 5 мм от первой линии). Под каждым изображением прямоугольников нужно будет нанести две надписи из атрибутов. Одна надпись будет описывать тип процессора, а вторая — величину оперативной памяти.
Нарисуйте в новом рисунке прямоугольники с теми характеристиками, которые были названы, и вызовите диалоговое окно Attribute Definition (Описание атрибута) с помощью команды ATTDEF (АТОПР). Разберем параметры этого окна.
Область Mode (Режим) с помощью четырех флажков задает режимы атрибута:

  • Invisible (Скрытый) — атрибут невидим (для его отображения нужно использовать специальную команду ATTDISP (АТЭКР) — см. далее);
  • Constant (Постоянный) — атрибут имеет постоянное (неизменяемое) значение, которое не запрашивается при вставке блока;
  • Verify (Контролируемый) — для контроля при вставке блока значение атрибута запрашивается дважды;
  • Preset (Установленный) — атрибут вставляется с установленным значением (значение не запрашивается), может быть изменен командой редактирования атрибута EATTEDIT (АТРЕДАКТ) - см. разд. 7.3.

В области Attribute (Атрибут) можно задать три следующих параметра:

  • Tag (Имя) — имя атрибута (не должно содержать пробелы и специальные знаки);
  • Prompt (Подсказка) — подсказка, которая выдается в качестве запроса значения атрибута (выводится системой AutoCAD при вставке блока с данным атрибутом, после запроса автоматически добавляется двоеточие);
  • Value (Значение) — значение атрибута по умолчанию.

В области Insertion Point (Точка вставки) для каждого атрибута должна быть задана точка вставки, а в области Text Options (Параметры текста) должны быть заданы такие же параметры, как и для однострочного текста. При этом очень важно правильно выбрать значение параметра Justification (Выравнивание), чтобы значение атрибута красиво расположилось около блока.
В нашем примере определим два атрибута с именами PROCESSOR и RAM. Для обоих атрибутов не будем устанавливать ни одного флажка в области Mode (Режим), что соответствует самому употребительному варианту. В качестве подсказок зададим соответственно Процессор и Оперативная память. Значения по умолчанию возьмем Р-3 800 МГц и 256 Мб. Выберем точку вставки первого атрибута под внешним прямоугольником блока и посередине, а в качестве значения параметра Justification (Выравнивание) — Center (Середина). Высоту букв зададим равной 5 мм.
Для второго атрибута установим флажок Align below previous attribute definition (Выровнять по предыдущему атрибуту). Тогда параметры текста автоматически будут взяты из предыдущего описания атрибута, а точка вставки будет определена так, чтобы второй атрибут расположился под первым. Примерный вид примитивов, которые будут включены в блок, а также двух описаний атрибутов, которые тоже войдут в блок, приведены на рис. 7.18.

Рис. 7.18. Описания атрибутов

Теперь с помощью команды BLOCK (БЛОК) создадим описание блока с именем Computer, включив в него оба прямоугольника и два описания атрибутов. Исходные объекты, вошедшие в описание блока, удалим.
По команде INSERT (ВСТАВИТЬ) можно вставить созданный блок, имеющий атрибуты, на поле текущего рисунка. После указания обычных параметров операции вставки блока система AutoCAD сначала выдаст запрос на ввод значения первого атрибута:
Процессор <Р-3 800 МГц>:
Затем последует запрос на ввод значения второго атрибута: Оперативная память <256 Мб>:
Ответив на запросы, мы сформировали блок (точнее, вхождение блока) с двумя атрибутами, задав при этом их значения, и вставили его в рисунок. На рис. 7.19 приведен пример вставки четырех блоков Computer на поле текущего рисунка.
Возможно редактирование значений атрибутов для вставленных блоков. Для этого используется команда EATTEDIT САТРЕЛАКТ) или соответствующая ей кнопка [image] панели инструментов Modify II (Редактирование 2). Команда EATTEDIT (АТРЕДАКТ) делает запрос о выборе вхождения блока: Select a block: (Выберите блок:)

Рис. 7.19. Вставка блока с атрибутами

После указания блока открывается диалоговое окно Enhanced Attribute Editor (Редактор атрибутов) (рис. 7.20).

Рис. 7.20. Диалоговое окно Enhanced Attribute Editor, вкладка Attribute

Это диалоговое окно имеет три вкладки. На вкладку Attribute (Атрибут) выводятся имя блока, имена атрибутов, подсказки и значения. После редактирования значений атрибутов с помощью столбца Value (Значение) и закрытия окна с помощью кнопок Apply (Применить) и ОК атрибуты выбранного блока изменят свои значения на новые.
Вкладка Text Options (Текстовые настройки) позволяет задать настройки атрибута как текста (высоту, выравнивание и т. п.), а вкладка Properties (Свойства) — изменить такие характеристики, как слой, вес, цвет и др.
Можно редактировать и описания атрибутов. Для этого подходит универсальная команда PROPERTIES (OKHOCB), рассмотренная в разд. 4.6. Команда DDEDIT (ДИАЛРЕД), описанная в разд. 3.5, может редактировать не только текст, но также и описание атрибута. Для этого на запрос
Select an annotation object or [Undo]: (Выберите текст или [Отменить]:)
нужно отметить описание атрибута. Далее появляется диалоговое окно Edit Attribute Definition (Редактирование описания атрибута) (рис. 7.21).

Рис. 7.21. Диалоговое окно Edit Attribute Definition

В данном окне вы можете задать новые значения в полях Tag (Имя), Prompt (Подсказка), Default (По умолчанию).
Двойной щелчок по описанию атрибута — еще один способ перейти к его редактированию.
В области Mode (Режим) диалогового окна Attribute Definition (Описание атрибута) (см. рис. 7.17) задается состояние видимости определяемого атрибута. Поэтому часть атрибутов текущего рисунка могут быть видимыми, а часть — невидимыми. Команда ATTDISP (АТЭКР) позволяет включить или отключить видимость всех атрибутов или вернуть их видимость к тому состоянию, которое было им назначено при создании определений атрибутов. При выполнении данной команды из командной строки системой выдается следующий запрос:
Enter attribute visibility setting [Normal/ON/Off] <Normal>: (Состояние видимости атрибута [Нормальное/Вкл/Откл] <Нормальное >:)
Ответ ON (Вкл) включает видимость всех атрибутов, OFF (Откл) — отключает, a Normal (Нормальное) — делает видимыми только те атрибуты, которые в описании были заданы как видимые. Аналогичную операцию выполняет пункт падающего меню View | Display | Attribute Display (Вид | Отображение | Атрибуты). Он имеет те же опции, что и команда ATTDISP (АТЭКР).
Другим инструментом, управляющим состоянием видимости атрибутов блоков, является команда BATTMAN (ДИСПАТБЛК), которая вызывается с помощью кнопки [image] панели Modify II (Редактирование 2) или с помощью пункта падающего меню Modify | Object | Attribute | Block Attribute Manager (Редакт | Объект | Атрибут | Диспетчер атрибутов блоков). Команда BATTMAN (ДИСПАТБЛК) открывает диалоговое окно Block Attribute Manager (Диспетчер атрибутов блоков) (рис. 7.22).

Рис. 7.22. Диалоговое окно Block Attribute Manager

По умолчанию в окне отображается состояние атрибутов первого блока (на рис. 7.22 — Computer). Блок можно выбрать либо по имени с помощью раскрывающегося списка Block (Блок), либо щелчком по кнопке [image] .
Для выбранного блока в центральной части окна отображаются заданные характеристики (Tag (Имя), Prompt (Подсказка) и т. д.). Перечень отображаемых характеристик устанавливается в диалоговом окне, вызываемом с помощью кнопки Settings (Установки). Атрибуты можно переставлять в списке (кнопки Move Up (Вверх), Move Down (Вниз)), изменять (кнопка Edit (Редактировать)), удалять (кнопка Remove (Удалить)). Кнопка Sync (Сихронизация) предназначена для синхронизации атрибутов всех вхождений блока (при этом атрибуты всех вхождений получат одинаковые характеристики). Операцию синхронизации можно выполнить также с помощью команды ATTSYNC (АТРОБНОВИТЪ) (кнопка [image] панели инструментов Modify II (Редактирование 2)).
Атрибуты блоков содержат текстовую информацию, которая дополняет графические примитивы рисунка. Извлечение значений атрибутов может быть сделано с помощью специальной команды ЕАТТЕХТ (АТРИЗВЛЕЧЬ), вызываемой с помощью кнопки [image] панели Modify II (Редактирование 2) и позволяющей выполнить экспорт атрибутов в электронную таблицу или базу данных. Эта операция полезна в системах автоматизированного проектирования на базе AutoCAD.


7.1.7. Работа с буфером обмена Windows

Несколько команд системы AutoCAD работают с буфером Windows, который используется для копирования и вставки фрагментов чертежа.
Команда CUTCLIP (ВБУФЕР), которой соответствуют кнопка [image] панели инструментов Standard (Стандартная) и пункт Cut (Вырезать) падающего меню Edit (Правка), вырезает (удаляет) объекты из текущего рисунка и помещает их в буфер, оформляя как блок. В качестве базовой точки у этого блока берется точка левого нижнего угла наименьшей прямоугольной рамки, охватывающей выбранные для копирования объекты.
Для того чтобы объекты из буфера вставить в текущий или любой другой открытый рисунок, следует воспользоваться командой PASTECLIP (ВСТБУФЕР), которой соответствуют кнопка [image] и пункт Paste (Вставить) падающего меню Edit (Правка). При вставке блок, находящийся в буфере, не масштабируется и не поворачивается. Кроме того, блок расчленяется, поэтому описание нового блока в текущем рисунке не образуется.
Аналогичную операцию выполняет команда PASTEBLOCK (ВСТБЛОК), которой соответствует пункт Paste as Block (Вставить как блок) падающего меню Edit (Правка), но она при вставке образует в рисунке блок с именем, назначаемым системой AutoCAD.
Команда COPYCLIP (КБУФЕР) копирует выбранные объекты в буфер, не удаляя их из текущего рисунка. Базовая точка при этом выбирается так же, как и в команде CUTCLIP (ВБУФЕР). Команде COPYCLIP (КБУФЕР) соответствуют кнопка [image] панели инструментов Standard (Стандартная) и пункт Сору (Копировать) падающего меню Edit (Правка).
Если вы хотите сами назначить базовую точку при копировании объектов в буфер, то воспользуйтесь командой COPYBASE (БТКОПИРОВАТЬ), которой соответствует пункт Copy with Base Point (Копировать с базовой точкой) падающего меню Edit (Правка).
Команда PASTEORIG (ВСТИСХОД) дает возможность при вставке объектов из буфера расположить их с теми же координатами, какие они имели в файле-источнике. Команда работает только в том случае, когда в буфере
находятся объекты из "чужого" рисунка (т. е. не из текущего). Данной команде соответствует пункт Paste to Original Coordinates (Вставить с исходными координатами) падающего меню Edit (Правка).


7.2. Внешние ссылки

Вставка с помощью команды INSERT (ВСТАВИТЬ) одного файла рисунка в другой рисунок, который является текущим, увеличивает его объем, т. к. в него переносятся примитивы вставляемого файла. Но есть еще один способ добавить к текущему рисунку изображение другого рисунка — вставить файл с помощью внешней ссылки. При этом примитивы файла, на который добавляется ссылка, в текущий рисунок непосредственно не переносятся, а запоминается только имя файла ссылки (обычно вместе с путем). В дальнейшем если система AutoCAD открывает рисунок, имеющий внешнюю ссылку, то загружается сначала открываемый файл, а затем — содержимое дополнительного файла-ссылки. Таким образом, файл-ссылка не хранится вместе с основным рисунком. Разумеется, при таком варианте основной файл имеет меньший размер по сравнению с вариантом вставки файла с помощью команды INSERT (ВСТАВИТЬ), но он попадает в зависимость от дополнительного файла, т. к. тот должен всегда обнаруживаться на своем привычном месте и не менять своего имени и пути.
Возможны вложенные ссылки, когда ссылка выполняется на файл, который сам содержит внешнюю ссылку на другой файл.


7.2.1. Диспетчер внешних ссылок

Команда XREF (ССЫЛКА) управляет в текущем рисунке внешними ссылками на другие файлы. Команда может быть либо введена с клавиатуры, либо вызвана с помощью кнопки [image] панели Insert (Вставка) (см. рис. 7.4) или с помощью идентичной кнопки панели Reference (Ссылки) (рис. 7.23), либо вызвана с помощью пункта Xref Manager (Диспетчер внешних ссылок) падающего меню Insert (Вставка). Кроме того, такую же кнопку можно найти в панели Draw (Рисование) в группе, образуемой кнопкой [image] .

Рис. 7.23. Панель инструментов Reference

Рассмотрим внешние ссылки на примере файла 8th floor.dwg, расположенного в папке Sample с примерами данной версии системы AutoCAD. Команда XREF (ССЫЛКА) открывает диалоговое окно Xref Manager (Диспетчер внешних ссылок) (рис. 7.24).

Рис. 7.24. Диалоговое окно Xref Manager (табличная форма)

Данное диалоговое окно позволяет выполнять операции над внешними ссылками (вставка, удаление, обновление и т. п.). В центральной части располагается перечень внешних ссылок, содержащихся в текущем рисунке. Перечень может отображаться в виде таблицы (см. рис. 7.24) или в виде дерева (рис. 7.25).

Рис. 7.25. Диалоговое окно Xref Manager (форма дерева)

Переключение между табличной формой и формой дерева осуществляется либо с помощью функциональных клавиш <F3> и <F4>, либо с помощью расположенных в верхней части диалогового окна кнопок [image] (List View (F3) (Таблица)) и [image] (Tree View (F4) (Дерево)). Табличная форма перечня ссылок (см. рис. 7.24) имеет следующие колонки (если наименование колонки высвечивается не полностью, вы можете мышью передвинуть разделитель между колонками):

  • Reference Name (Имя);
  • Status (Статус);
  • Size (Размер);
  • Туре (Тип);
  • Date (Дата);
  • Saved Path (Сохраненный путь).

Назначение колонок соответствует их наименованию. Поясним два из перечисленных параметров.
Параметр Status (Статус) может принимать такие значения:

  • Loaded (Загружена) — внешняя ссылка найдена и загружена в рисунок;
  • Unloaded (Выгружена) — внешняя ссылка выгружена из рисунка;
  • Unreferenced (He используется) — внешняя ссылка была вставлена, но затем удалена;
  • Not Found (He найдена) — внешняя ссылка не найдена ни по одному из заданных путей;
  • Unresolved (He обработана) — внешняя ссылка найдена, но не может быть прочитана;
  • Orphaned (Разорвана) — внешняя ссылка вложена в другую внешнюю ссылку, которая не обнаружена, не обработана или разорвана.

Параметр Туре (Тип) указывает тип внешней ссылки: Attach (Вставленная) или Overlay (Наложенная). Вставленной называется внешняя ссылка, которая отображает все имеющиеся в ней самой внешние ссылки. Наложенной называется ссылка, которая не отображает те ссылки, которые имеются внутри нее.
Поле области Xref Found At (Ссылка найдена в) показывает путь, по которому найдена ссылка, помеченная в перечне внешних ссылок. Кнопка Browse (Найти) позволяет вызвать окно поиска файла для загрузки помеченной в перечне ссылки. Если файл найден, то можно сохранить его полный путь с помощью кнопки Save Path (Сохранить путь).


7.2.2. Операции над внешними ссылками

В правой части диалогового окна Xref Manager (Диспетчер внешних ссылок) (см. рис. 7.24 и 7.25) собраны кнопки операций над внешними ссылками:

  • Attach (Вставить);
  • Detach (Удалить);
  • Reload (Обновить);
  • Unload (Выгрузить);
  • Bind (Внедрить);
  • Open (Открыть).

Рассмотрим действия этих кнопок подробнее. Кнопка Attach (Вставить) либо вставляет в рисунок внешнюю ссылку на новый файл, либо добавляет в другом месте чертежа ссылку, которая уже была использована в текущем рисунке.
Откройте новый рисунок и вызовите в нем диалоговое окно Xref Manager (Диспетчер внешних ссылок). Добавьте в рисунок внешнюю ссылку. Для этого нажмите кнопку Attach (Вставить), которая вызывает диалоговое окно Select Reference File (Выбор файла внешней ссылки), являющееся обычным окном поиска файлов. Выберите, например, в знакомой нам папке Sample файл SPCA Site Plan.dwg и нажмите кнопку Open (Открыть). Появится следующее диалоговое окно, которое называется External Reference (Внешняя ссылка) (рис. 7.26).

Рис. 7.26. Диалоговое окно External Reference

Раскрывающийся список Name (Имя) показывает имя выбранной вами внешней ссылки. Можно заменить ее с помощью кнопки Browse (Обзор). Параметр Saved path (Сохраненный путь) показывает путь, с которым была сохранена ссылка. Поле Found in (Найдена в) показывает путь, по которому ссылка была на самом деле найдена.
В области Reference Type (Тип ссылки) с помощью переключателей задается один из двух возможных типов ссылки: Attachment (Вставленная) или Overlay (Наложенная). Если вы не хотите, чтобы вставляемая внешняя ссылка потянула за собой ссылки, имеющиеся в ней самой, выберите переключатель Overlay (Наложенная). В противном случае (а это более распространенный вариант) включите переключатель Attachment (Вставленная).
В раскрывающемся списке области Path type (Тип пути) следует задать тип пути, сохраняемого вместе с именем внешней ссылки: Full path (Полный путь), Relative path (Относительный путь) или No path (Без пути). По этой установке система AutoCAD будет выбирать путь, по которому ищется файл внешней ссылки при следующем открытии основного рисунка.
Области Insertion point (Точка вставки), Scale (Масштаб) и Rotation (Поворот) аналогичны соответствующим областям диалогового окна вставки блока (см. рис. 7.5). Внешняя ссылка тоже может быть повернута и масштабирована при вставке. Задайте для внешней ссылки SPCA Site Plan нулевой угол поворота, масштаб 0.05 по всем осям, а точку вставки — около нижнего левого угла графического экрана. Вставленная ссылка должна поместиться на экране, если вы выбирали при входе в новый рисунок зону черчения формата A3.
Диалоговое окно External Reference (Внешняя ссылка), используемое для вставки внешней ссылки, может быть вызвано также командой ХАТТАСН (ССВСТАВИТЬ), или кнопкой [image] панели Reference (Ссылки), или пунктом External Reference (Внешняя ссылка) падающего меню Insert (Вставка).
Внешняя ссылка, вставленная в рисунок, является единым объектом для операций общего редактирования (стирание, перенос и т. п.). У нее высвечивается только одна ручка (в точке вставки). Если посмотреть справочную информацию о внешней ссылке с помощью команды LIST (СПИСОК), то мы увидим, что примитив внешней ссылки тоже называется BLOCK REFERENCE (вхождение блока). Это связано с тем, что внутри файла рисунка имена блоков и внешних ссылок содержатся в одной таблице. Этим же объясняется существование ограничения на имена блоков и внешних ссылок внутри одного рисунка — имя внешней ссылки не должно повторять имя блока и наоборот.
Продолжим рассмотрение кнопок операций над внешними ссылками. Кнопка Detach (Удалить) (см. рис. 7.24 и 7.25) удаляет из рисунка все вхождения внешней ссылки, отмеченной в данный момент в перечне внешних ссылок диалогового окна Xref Manager (Диспетчер внешних ссылок).
Кнопка Reload (Обновить) повторно загружает отмеченную в перечне внешнюю ссылку (это полезно, если в процессе параллельной работы файл, на который была внешняя ссылка, изменился, или вы изменили путь к файлу ссылки). Кнопка Unload (Выгрузить) позволяет отключить видимость отмеченной в перечне внешней ссылки, не удаляя ее из текущего рисунка.
Особая роль в диалоговом окне Xref Manager (Диспетчер внешних ссылок) отводится кнопке Bind (Внедрить), которая внедряет внешнюю ссылку, т. е. преобразует ссылку в блок текущего рисунка. До внедрения внешней ссылки имена таких элементов, как слои, типы линий, описания блоков, текстовые стили и размерные стили, содержали в текущем рисунке в качестве префикса имя файла, на который сделана ссылка. Например, после вставки внешней ссылки SPCA Site Plan в текущем рисунке образовались слой SPCA Site Plan|A-PILLARS и тип линии SPCA Site Plan|BDY2, поскольку в файле-источнике был слой A-PILLARS и тип линии BDY2. Преобразование ссылки в блок может быть выполнено двумя способами: внедрением (со сложными именами внедряемых элементов, содержащими имя файла-источника в качестве префикса) и слиянием (имена не сохраняют обозначения файла-источника).
Кнопка Bind (Внедрить) вызывает диалоговое окно Bind Xrefs (Внедрение ссылок) (рис. 7.27), в котором с помощью переключателя нужно выбрать способ преобразования внешней ссылки.

Рис. 7.27. Диалоговое окно Bind Xrefs

В случае выбора положения Insert (Слияние) имена элементов (слоев, типов линий, описаний блоков, текстовых стилей и размерных стилей) переносятся в таком же виде, в каком они были в файле-источнике. Этот вариант дает результат, аналогичный результату действия команды INSERT (ВСТАВИТЬ) при вставке файла в текущий рисунок.
В случае выбора положения Bind (Внедрение) имена внедряемых символов преобразуются по схеме: из blockname(symbolname в blockname$n$symbolname, причем обычно $n$ заменяется на $0$ (если возникают повторения имен, то AutoCAD последовательно пытается заменить n на 1, 2 и т. д.). Если вернуться к примеру с внешней ссылкой SPCA Site Plan, то слой SPCA Site Plan|A-PILLARS после внедрения преобразуется в SPCA Site Plan$0$A-PILLARS, a тип линии SPCA Site Plan|BDY2 - в SPCA Site Plan$0$BDY2.
Команда XBIND (ВНЕДРИТЬ) выполняет аналогичную операцию переноса символов (текстовых и размерных стилей, блоков и т. п.), вызывая диалоговое окно Xbind (Внедрение символов) (рис. 7.28). Команда XBIND (ВНЕДРИТЬ) может быть вызвана с помощью кнопки [image] панели Reference (Ссылки) или пункта падающего меню Modify | Object | External Reference |Bind (Редакт | Объекты | Внешние ссылки | Внедрить).
Рассмотрим действие команды на примере с внешней ссылкой SPCA Site Plan. В расположенном слева списке области Xrefs (Внешние ссылки) диалогового окна Xbind (Внедрение символов) щелкните левой кнопкой мыши по знаку [image] слева от ссылки SPCA Site Plan. После этого раскроется перечень символов, которые можно перенести из внешней ссылки в текущий рисунок.

Рис. 7.28. Диалоговое окно Xbind

Если, например, щелкнуть по знаку плюс слева от наименования Textstyle (Текстовый стиль), то раскроется ветвь дерева, содержащая имена текстовых стилей. Если пометить нужное нам имя стиля и нажать на кнопку Add (Добавить), то помеченный символ появится в расположенном справа списке области Definitions to Bind (Внедряемые описания) диалогового окна. Таким образом, можно выбрать все внедряемые символы (лишние можно убрать с помощью кнопки Remove (Удалить)), которые будут перенесены в текущий рисунок. Теперь если стереть внешнюю ссылку и сохранить текущий рисунок, то в нем удаленной внешней ссылки не будет, но останутся внедренные символы.
Внешние ссылки могут копироваться из одного рисунка в другой с помощью Центра управления (о Центре управления см. разд. 5.4).
Новая кнопка Open (Открыть), появившаяся в системе AutoCAD 2004 в диалоговом окне Xref Manager (Диспетчер внешних ссылок), вызывает команду XOPEN (русское наименование команды в момент написания книги не известно), которая позволяет открыть файл-ссылку.


7.3. Редактирование блоков и внешних ссылок

Команды общего редактирования (перенос, копирование, стирание и т. п.) применимы к вхождениям блоков и внешним ссылкам. В системе AutoCAD предусмотрены также специальные средства редактирования блоков, атрибутов и ссылок, рассмотренные в данном разделе.
Попробуйте изменить такие свойства вхождения блока (а вхождение блока — это единый примитив), как цвет, тип или вес линий. Почти наверняка с первого раза у вас это не получится (можно, конечно, расчленить блок с помощью команды EXPLODE (РАСЧЛЕНИТЬ), но при этом он перестанет быть блоком). Однако для возможности таких изменений есть особые значения для цвета, типа и веса линий — ByBlock (ПОБЛОКУ).
Если какие-то объекты в описании блока в качестве цвета имели значение ByBlock (ПОБЛОКУ), то тогда при изменении цвета вхождения блока (с помощью команд PROPERTIES (OKHOCB) или CHPROP (СВОЙСТВА)) эти объекты блока (и только они) примут то же самое значение цвета, которое вы дали вхождению блока. Аналогично влияет установка значения цвета. Если в рисунке текущим цветом был красный, то после вставки блока все входящие в блок объекты, имеющие в качестве цвета значение ByBlock (ПОБЛОКУ), станут красными.
Все сказанное ранее для цвета относится и к использованию значения ByBlock (ПОБЛОКУ) для типа и веса линий.
Особое влияние на свойства элементов вставленного блока оказывает слой с именем 0. Если в описании блока использованы примитивы, которые расположены на служебном слое 0 и имеют цвет, тип или вес линий со значениями ByLayer (ПОСЛОЮ), то цвет, тип и все линий таких объектов при отображении на экране будут не текущими, а повторяющими значения того слоя, на котором размещено вхождение данного блока.


7.3.1. Редактирование значений атрибутов

Специальный вопрос — редактирование атрибутов уже вставленных блоков. Если в блоке заданы атрибуты, то высвечиваются ручки не только у точки вставки блока, но и у точек вставки атрибутов. Поэтому за собственные ручки атрибуты могут переноситься в новое место. В то же время перемещение блока за ручку точки вставки блока осуществляется вместе с его атрибутами.
Для того чтобы скорректировать значение атрибута, необходимо воспользоваться командой EATTEDIT (АТРЕДАКТ) или командой BATTMAN (ДИСПАТБЛК), рассмотренной в разд. 7.1.6.
Команду EATTEDIT (АТРЕДАКТ) можно либо ввести с клавиатуры, либо вызвать, нажав кнопку [image] панели инструментов Modify II (Редактирование-2) или выбрав пункт падающего меню Modify | Object | Attribute | Single (Редакт | Объект | Атрибуты | По одному).
Команда EATTEDIT (АТРЕДАКТ) открывает диалоговое окно Enhanced Attribute Editor (Редактор атрибутов). На рис. 7.29 приведено это окно (открыта вкладка Attribute (Атрибут)) для редактирования использованного в качестве примера на рис. 7.18 в разд. 7.1 блока Computer с двумя атрибутами с именами PROCESSOR и RAM. В диалоговое окно выводятся имя блока, имена атрибутов, подсказки (Процессор и Оперативная память) и значения. После редактирования значений атрибутов с помощью поля Value (Значение) и закрытия окна с помощью кнопок Apply (Применить) и ОК атрибуты выбранного блока изменят свои значения на новые.

Рис. 7.29. Диалоговое окно Enhanced Attribute Editor, вкладка Attribute

Вкладка Text Options (Текстовые настройки) диалогового окна Enhanced Attribute Editor (Редактор атрибутов) позволяет задать настройки атрибута как текста (высоту, выравнивание и т. п.), а вкладка Properties (Свойства) — изменить такие характеристики, как слой, вес, цвет и др.
Команда ATTEDIT (АТРЕД) является более простым вариантом рассмотренной ранее команды EATTEDIT (АТРЕДАКТ). Команда ATTEDIT (АТРЕД) запрашивает блок и после указания открывает диалоговое окно Edit Attributes (Редактирование атрибутов) (рис. 7.30). В этом окне можно изменить действующие значения атрибутов блока.
Если ввести команду ATTEDIT (АТРЕД) в командной строке со знаком минус, т. е. -ATTEDIT (-АТРЕД), или если выбрать пункт падающего меню Modify | Object | Attribute | Global (Редакт Объект Атрибуты | Глобально), то команда начинает работать без диалогового окна, но зато предоставляет пользователю возможность одновременно редактировать сразу несколько атрибутов (например, когда нужно одно и то же значение одного атрибута нескольких блоков заменить на другое), а также позволяет поменять некоторые свойства атрибутов (положение, текстовый стиль и т. п.)- Первый запрос команды:
Edit attributes one at a time? [Yes/No] <Y>: (Редактировать атрибуты по одному?[Да/Нет] <Д>:)

Рис. 7.30. Диалоговое окно Edit Attributes

Ответ Yes (Да) ведет к редактированию атрибутов по одному, a No (Нет) — к глобальному редактированию. При ответе Yes (Да) следующий запрос:
Enter block name specification < *>: (Шаблон имени блока < *>:)
Нужно задать имя блока, можно с использованием групповых символов "*" и "?".
Enter attribute tag specification < *>: (Шаблон имени атрибута < *>:)
Введите имя атрибута или шаблон (например, символ "*").
Enter attribute value specification < *>: (Шаблон значения атрибута < *>:)
Нужно выбрать шаблон значения атрибута или нажать клавишу <Enter>. Select Attributes: (Выберите атрибуты:)
Выберите атрибуты (можно рамкой), из них система AutoCAD оставит только те, которые удовлетворяют шаблонам имени блока, имени атрибута, а также значения атрибута. Окончание выбора— нажатие клавиши <Enter>. Далее подсвечивается первый из выбранных для редактирования атрибутов и запрашивается, какие изменения в нем требуется выполнить:
Enter an option [Value/Position/Height/Angle/Style/Layer/Color/Next] <N>: (Задайте опцию [Значение/Положение/Высота/Угол/с Тиль/сЛой/Цвет/ Следующий] <С>:)
Перечислим опции и их назначение:

  • Value (Значение) — изменяет значение атрибута (см. далее);
  • Position (Положение) — изменяет точку привязки;
  • Height (Высота) — задает новую высоту текста атрибута;
  • Angle (Угол) — изменяет угол наклона;
  • Style (сТиль) — изменяет имя текстового стиля атрибута;
  • Layer (сЛой) — изменяет имя слоя;
  • Color (Цвет) — задает другой цвет;
  • Next (Следующий) — переходит к редактированию следующего атрибута.

При выборе опции Value (Значение) система AutoCAD запрашивает:
Enter type of value modification [Change/Replace] <R >: (Способ модификации значения [Изменить/Заменить] <R>:)
Опция Change (Изменить) позволяет изменить группу символов в значении атрибута:
Enter string to change: (Старая строка:)
Введите последовательность символов, которую нужно изменить.
Enter new string: (Новая строка:)
На этот запрос вводится текст замены. Если же нажать клавишу <Enter>, то символы, выбранные в качестве "старой строки", будут просто удалены из текста атрибута. В данном случае нельзя использовать символы "?" и "*" в качестве групповых.
Опция Replace (Заменить) (при выборе ранее опции Value (Значение)) заменяет полный текст атрибута. Далее следует запрос:
Enter new attribute value: (Новое значение атрибута:)
Введите новый текст атрибута. Нажатие клавиши <Enter> вместо текста задает пустую строку.
Если в ответ на запрос Edit attributes one at a time? (Редактировать атрибуты пo одному?) вы отвечаете No (Нет), то переходите в режим глобального редактирования. Система AutoCAD выводит сообщение:
Performing global editing of attribute values. Edit only attributes visible on screen? [Yes/No] < Y>:)
(Выполняется глобальное редактирование значений атрибутов. Редактировать только видимые на экране атрибуты?[Да/Нет] <Д>:)
В зависимости от вашего ответа будут редактироваться все атрибуты или только те, которые находятся в видимой части экрана. После этого выдаются такие же запросы о шаблонах имени блока, имени атрибута и значении атрибута, как и при редактировании атрибутов по одному. Затем появляются запросы Enter string to change: (Старая строка:) и Enter new string: (Новая строка:), после ответа на которые выполняется глобальная замена значений атрибутов.


7.3.2. Подрезка вхождений блоков и внешних ссылок

Для блоков и внешних ссылок есть особая операция редактирования — подрезка, т. е. такая операция, когда задается контур, вне которого блок или внешняя ссылка будут невидимы. Для ее выполнения есть команда XCLIP (ССПОДРЕЗАТЬ), которой соответствуют кнопка [image] панели Reference (Ссылки) и пункт падающего меню Modify | Clip | Xref (Редакт | Подрезка | Ссылка).
Команда начинает выполнение с запроса о выборе объекта. Нужно отметить вхождение блока или внешней ссылки, которое будет подрезаться некоторым контуром. Окончание выбора — нажатие клавиши <Enter>. Следующий запрос:
Enter clipping option [ON/0FF/Clipdepth/Delete/generate Polyline/New boundary] <New>:
(Задайте опцию подрезки [Вкл/Откл/Плоскости/Удалить/полиЛиния/Новый контур] < Новый >:)
Перечислим опции:

  • ON (Вкл) — включает подрезку, которая перед этим была выключена (контур подрезки уже задан);
  • OFF (Откл) — отключает подрезку, хотя контур подрезки задан;
  • Clipdepth (Плоскости) — позволяет задать подрезку не только контуром в плоскости XY, но и двумя плоскостями (передней и задней), параллельными плоскости XY, т. е. задает с двух сторон подрезку трехмерного объекта по оси Z;
  • Delete (Удалить) — удаляет контур подрезки;
  • generate Polyline (полиЛиния) — преобразует контур подрезки в двумерную полилинию;
  • New boundary (Новый контур) — создает контур подрезки или заменяет старый контур на новый.

Рассмотрим опцию New boundary (Новый контур), которая создает новый замкнутый контур, подрезающий блок или внешнюю ссылку. Если выбранный объект уже имеет контур подрезки, то следует запрос:
Delete old boundary(s)? [Yes/No] <Yes>: (Удалить прежние контуры ? [Да/Нет] <Да >:)
Продолжить задание нового контура можно только при выборе ответа Yes (Да). Далее:
Specify clipping boundary: [Select polyline/Polygonal/Rectangular] <Rectangular >:
(Укажите контур подрезки: [Выбрать полилинию/Многоугольный/Прямоугольный] <Прямоугольный>:)
Опция Rectangular (Прямоугольный) запрашивает два противоположных угла для построения прямоугольника, который становится контуром подрезки. Опция Polygonal (Многоугольный) запрашивает точки, образующие по окончании их ввода замкнутый многоугольный контур, который не должен иметь самопересечений. В случае опции Select polyline (Выбрать полилинию) нужно указать полилинию, состоящую только из прямолинейных сегментов и не имеющую самопересечений. Если полилиния не замкнута, то AutoCAD добавит к контуру замыкающий сегмент.
Пример результата подрезки блоков приведен на рис. 7.31. Для удобства контур подрезки сделан видимым, хотя по умолчанию он невидим.
Управление видимостью контура подрезки осуществляется с помощью кнопки [image] панели Reference (Ссылки). При нажатии на эту кнопку система AutoCAD изменяет текущее значение системной переменной XCLIPFRAME на противоположное (0 на 1 или 1 на 0). При 1 контуры подрезки блоков и внешних ссылок становятся видимыми, при 0 — невидимыми. О системных переменных см. разд. 11.1.

Рис. 7.31. Подрезка вхождения блока


7.3.3. Редактирование вхождений блоков и внешних ссылок

Изучаемая версия системы AutoCAD предлагает еще один инструмент работы с блоками и внешними ссылками — редактирование внешних ссылок и описаний блоков через их вхождения в текущий рисунок. Такая операция затрагивает сложные связи внутри рисунка (для блоков) и связи с другими рисунками (для внешних ссылок), поэтому объем подобного редактирования не должен быть велик. В случае большого объема изменений лучше действовать обычными средствами: переопределить блок, который требует изменений, с помощью команды BLOCK (БЛОК), а вместо редактирования вхождения внешней ссылки открыть файл-источник ссылки, изменить его, а затем обновить ссылки на этот файл в основном рисунке. Операция редактирования применима и к массивам блоков, созданным командой MINSERT (МВСТАВИТЬ), но выполняется над первым объектом из массива, а затем автоматически распространяется на остальные.
Для редактирования вхождения блока или ссылки используется команда REFEDIT (ССЫЛРЕД), которой соответствуют кнопка [image] , расположенная первой в панели инструментов Refedit (Редактирование вхождений) (рис. 7.32), а также пункт падающего меню Modify | Xref and Block Editing | Edit Reference In-Plасе (Редакт | Блоки и внешние ссылки | Редактирование вхождений).

Рис. 7.32. Панель инструментов Refedit

Опробуем редактирование вхождения на примере файла, изображенного на рис. 7.31, где блок Computer был вставлен четыре раза, причем у двух вхождений выполнена подрезка.
Щелкните по кнопке [image] , расположенной в панели инструментов Refedit (Редактирование вхождений), вызывая тем самым на выполнение команду REFEDIT (ССЫЛРЕД). Появится запрос:
Select reference: (Выберите вхождение:)
Выберите верхнее вхождение блока Computer (выбранные вами для редактирования вхождения заносятся в специальный рабочий набор). После этого откроется диалоговое окно Reference Edit (Редактирование вхождений), в котором в левой части вкладки Identify Reference (Выбрать вхождение) высвечивается дерево вхождений для выбранного объекта (в нашем случае это блок Computer) (рис. 7.33).

Рис. 7.33. Диалоговое окно Reference Edit, вкладка Identify Reference

В правой части окна в области просмотра Preview (Образец) виден растровый образец отмеченного блока. В нижней части расположена группа переключателей Path (Путь):

  • Automatically select all nested objects (Автоматически показывать все вложенные объекты) — показывает и внутренние вхождения в отмеченный блок или внешнюю ссылку, с возможностью их выбора для редактирования;
  • Prompt to select nested objects (Запрашивать выбор вложенных объектов) — внутренние вхождения показывает по запросу.

На вкладке Settings (Настройки) диалогового окна Reference Edit (Редактирование вхождений) (рис. 7.34) расположены три флажка, задающие дополнительные настройки процесса редактирования вхождений:

  • Create unique layer, style, and block names (Создавать уникальные имена слоев, стилей и блоков);
  • Display attribute definitions for editing (Вывести описания атрибутов для редактирования);
  • Lock objects not in working set (Закрыть объекты, не входящие в рабочий набор).

Рис. 7.34. Диалоговое окно Reference Edit, вкладка Settings

Первый флажок позволяет включать префиксы в имена слоев и символов (см. ранее операцию внедрения внешних ссылок, где появляются префиксы). Второй флажок позволит отредактировать определения атрибутов выбранного блока. Третий флажок при включении блокирует отображение объектов, не попавших в редактируемый набор, чтобы их нельзя было случайно изменить.
После нажатия в диалоговом окне Reference Edit (Редактирование вхождений) кнопки ОК система сообщает:
Use REfCLOSE or the Refedit toolbar to end reference editing session.
(Для завершения сеанса редактирования вхождения воспользуйтесь командой ССЫЛЗАКР или соответствующей панелью инструментов.)
Теперь в панели Refedit (Редактирование вхождений) в списке вхождений должно появиться имя Computer (как на рис. 7.32). Этот список показывает вам имена тех вхождений блоков и внешних ссылок, которые вы внесли в рабочий набор для дальнейшего редактирования. Установленное в этом списке текущее значение (его вы могли бы поменять, если бы выбрали несколько вхождений) показывает имя вхождения, которое вы сейчас начнете редактировать.
Следующий шаг — с помощью кнопки [image] необходимо выбрать объекты вхождения блока, которые должны быть отредактированы. Система выдаст следующий запрос:
Transfer objects between the RefEdit working set and host drawing... Enter an option [Add/Remove] <Add>: _add
(Перемещение объектов из основного рисунка в рабочий набор для ССЫЛРЕД и обратно... Задайте опцию [Добавить/Исключить] <Добавить>: _add)
Отметьте оба входящих в блок Computer прямоугольника (по очереди или секущей рамкой). Далее система AutoCAD сообщит:
2 Added to working set: (Добавлено к рабочему набору элементов: 2)
С помощью кнопки [image] вы можете добавить к рабочему набору другие дополнительные объекты, а с помощью кнопки [image] — убрать из набора лишние.
Теперь воспользуйтесь командой PROPERTIES (OKHOCB) и сделайте во внешнем прямоугольнике изменение цвета и ширины (например, на 2 мм), а во внутреннем прямоугольнике измените тип линии (например, на тип Dashed (Штриховая)). После этого левое вхождение блока Computer примет новую форму, а остальные вхождения не будут видны (рис. 7.35). Для того чтобы занести сделанные изменения в описание блока Computer, щелкните по кнопке [image] панели Refedit (Редактирование вхождений). Данная кнопка вызывает команду REFCLOSE (ССЫЛЗАКР) в режиме сохранения изменений.
Прежде чем внести результаты редактирования, система AutoCAD выдает предупреждение (рис. 7.36).
При согласии с внесением изменений нажмите кнопку ОК. После этого результат редактирования отразится на всех вхождениях блока Computer (рис. 7.37), а панель Refedit (Редактирование вхождений) исчезнет.
Возможно редактирование и вложенных вхождений (например, когда внешняя ссылка внутри себя содержит другую внешнюю ссылку).

Рис. 7.35. Редактирование вхождения блока Computer

Рис. 7.36. Предупреждающее сообщение команды REFCLOSE

Кнопка [image] панели Refedit (Редактирование вхождений) предназначена для отказа от внесения изменений во все вхождения блока или внешней ссылки.

Рис. 7.37. Результаты редактирования описания блока через вхождение


Глава 8. Операции над объектами других форматов

    • Операции над объектами других форматов
    • 8.1. Вставка и редактирование растровых изображений
    • 8.2. Примитив WIPEOUT
    • 8.3. Импорт из других форматов
    • 8.4. Экспорт в другие форматы


В предыдущей главе был рассмотрен вопрос вставки ранее созданных системой AutoCAD рисунков в текущий рисунок. Однако AutoCAD может читать ряд других графических форматов и вставлять растровые изображения и объекты, созданные другими приложениями (например, Microsoft Office).
В данной главе описан также новый объект AutoCAD — WIPEOUT (пятно, см. разд. 8.2).


8.1. Вставка и редактирование растровых изображений

Растровое изображение — это изображение, состоящее из точек (растров), которые благодаря цветам формируют рисунок. AutoCAD может прочитать файл с растровой картинкой и вставить его в текущий рисунок в виде цветного прямоугольника (аналогично внешней ссылке). Редактировать вставленное изображение на точечном уровне AutoCAD не может, но может выполнять подрезку, масштабирование, перенос и другие простые операции редактирования. При наложении одного растрового изображения на другое можно управлять порядком их следования (переносить на передний план или убирать на задний).
Для операций с растровыми изображениями используется команда IMAGE (ИЗОБ), которой соответствует кнопка [image] панелей Reference (Ссылки) и Insert (Вставка), а также пункт Image Manager (Диспетчер изображений) падающего меню Insert (Вставка).
Команда IMAGE (ИЗОБ) вызывает диалоговое окно Image Manager (Диспетчер растровых изображений) (рис. 8.1).
Основную часть окна занимает перечень растровых изображений, вставленных в текущий рисунок. Диалоговое окно может выводиться не только в табличной форме, как это показано на рис. 8.1, но и в форме дерева (рис. 8.2).

Рис. 8.1. Диалоговое окно Image Manager (табличная форма)

Рис. 8.2. Диалоговое окно Image Manager (форма дерева)

Управление формой диалогового окна выполняется с помощью расположенных в верхней части окна кнопок [image] (List View (F3) (Таблица)) и [image] (Tree View (F4) (Дерево)), а также клавиш <F3> и <F4>. Табличная форма перечня (см. рис. 8.1) имеет следующие колонки:

  • Image Name (Имя);
  • Status (Статус);
  • Size (Размер);
  • Туре (Тип);
  • Date (Дата);
  • Saved Path (Сохраненный путь).

Поясним два из перечисленных параметров (смысл же остальных колонок очевиден).
Параметр Status (Статус) может принимать следующие значения:

  • Loaded (Загружено) — изображение найдено и загружено в рисунок;
  • Unload (Выгружено) — растровое изображение выгружено из рисунка;
  • Reload (Перегружено) — изображение загружено повторно;
  • Not Found (He найдено) — изображение не найдено ни по сохраненному пути, ни по одному из стандартных путей поиска.

Параметр Туре (Тип) указывает формат изображения. AutoCAD читает следующие форматы растровых файлов: BMP (расширения файлов — bmp, rle, dib), CALS1 (rst, gp4, mil, cal, cg4), FLIC (flc, fli), GEOSPOT (bil), IG4 (ig4), IGS (igs), JFIF (jpg), PCX (pcx), PICT (pet), PNG (png), RLC (rlc), TGA (tga), TIFF (tif, tiff).
Область Image found at (Изображение найдено в) показывает путь, по которому найдено изображение, помеченное в перечне. Кнопка Browse (Найти) позволяет вызвать окно поиска файла для загрузки помеченного изображения. Если файл найден, то можно сохранить его полный путь с помощью кнопки Save Path (Coxp. путь).
В правой части диалогового окна Image Manager (Диспетчер растровых изображений) собраны кнопки операций над изображениями:

  • Attach (Вставить);
  • Detach (Удалить);
  • Reload (Обновить);
  • Unload (Выгрузить);
  • Details (Подробнее).

Для вставленного и отмеченного в перечне изображения можно с помощью кнопки Details (Подробнее) вызвать диалоговое окно Image File Details (Подробные сведения об изображении) (рис. 8.3), которое сообщает детальную информацию об изображении (имя, путь, размер, разрешение и др.).
Остальные четыре кнопки позволяют выполнить соответствующие им операции над изображениями. Кнопка Attach (Вставить) вызывает окно Image (Растровое изображение) (рис. 8.4), в котором можно задать имя вставляемого в текущий рисунок изображения.

Рис. 8.3. Диалоговое окно Image File Details

Рис. 8.4. Диалоговое окно Image

В этом окне раскрывающийся список Name (Имя) показывает имя вставляемого изображения. Если растровое изображение уже было вставлено в текущий рисунок, то его можно выбрать из самого раскрывающегося списка. Если оно еще не вставлялось, то необходимо с помощью кнопки Browse (Обзор) открыть окно поиска растрового файла и выбрать необходимый вам файл. После закрытия окна поиска имя выбранного вами файла отобразится в списке Name (Имя) диалогового окна Image (Растровое изображение), а путь к этому файлу укажет параметр Path (Путь). Области Insertion point (Точка вставки), Scale (Масштаб) и Rotation (Угол поворота) аналогичны одноименным разделам диалоговых окон вставки блоков и внешних ссылок (см. гл. 7). Кнопка Details (Подробнее) позволяет расширить вниз диалоговое окно Image (Растровое изображение) за счет подробной информации о выбранном изображении.
После задания параметров и закрытия диалогового окна Image (Растровое изображение) с помощью кнопки ОК система AutoCAD запрашивает у пользователя параметры только тех разделов, в которых был установлен флажок Specify on-screen (Указать на экране), и затем вставляет изображение. Рекомендуется масштаб указывать на экране, поскольку при движении мыши вправо AutoCAD прямоугольной рамкой показывает, как расположится внешний контур растрового изображения (рис. 8.5).

Рис. 8.5. Задание масштаба растрового изображения

В качестве масштаба при этом берется расстояние, в миллиметрах, от точки вставки до точки, в которой находится указатель мыши. На рис. 8.6 показан результат вставки двух растровых изображений (второе повернуто при вставке на 30°). Последнее вставленное изображение закрывает предыдущее.
Кнопка Detach (Удалить) диалогового окна Image Manager (Диспетчер растровых изображений) (см. рис. 8.1 и 8.2) удаляет из рисунка отмеченные растровые изображения (если при отметке держать нажатыми клавиши <Ctrl> или <Shift>, то можно в перечне пометить мышью сразу несколько имен).

Рис. 8.6. Вставка растровых изображений

Кнопка Reload (Обновить) обновляет растровое изображение (это полезно, например, когда изображение было выгружено). Кнопка Unload (Выгрузить) временно выгружает отмеченное изображение, оставляя только его внешний контур. При выгруженных изображениях рисунок на экране регенерируется быстрее.
Для вставки растровых изображений, минуя диалоговое окно Image Manager (Диспетчер растровых изображений), можно использовать команду IMAGEATTACH (ИЗОБВСТАВИТЬ), которая вызывается с помощью кнопки [image] панели Reference (Ссылки) или пункта Raster Image (Растровое изображение) падающего меню Insert (Вставка).
Имя примитива, который образуется от вставки растрового изображения, — IMAGE (это имя английское даже в русской версии системы AutoCAD). Информацию о свойствах этого примитива можно получить с помощью команд LIST (СПИСОК) или PROPERTIES (OKHOCB).
К растровым изображениям фактически следует отнести заливки (см. разд. 2.15). Если несколько растровых изображений вставлено с наложением, то каждое последующее ложится на экране поверх предыдущих. Однако при необходимости можно с помощью команды DRAWORDER (ПОРЯДОК), которой соответствует кнопка [image] панели инструментов Modify II (Редактирование-2), управлять порядком вывода растровых изображений. Предположим, нужно поменять порядок следования растровых изображений, показанных на рис. 8.6. Вызовем команду DRAWORDER (ПОРЯДОК), которая сначала запросит выбрать объекты. Укажите нижнее изображение, щелкнув левой кнопкой мыши по его прямоугольному контуру, и нажмите клавишу <Enter> для окончания выбора. Далее следует запрос:
Enter object ordering option [Above object/Under object/Front/Back] <Back>: (Задайте опцию перестановки [Перед объектом/За объектом/пЕредний план/зЛдний план] <зАдний>:)
Выберите опцию Front (пЕредний план). Система AutoCAD перерисует рисунок, но горизонтально расположенное изображение выйдет на передний план и окажется нарисованным на переднем плане, поверх всех остальных объектов (рис. 8.7).

Рис. 8.7. Управление порядком следования изображений

Другие опции команды:

  • Above object (Перед объектом) — помещает изображение перед другим объектом, который далее нужно будет указать;
  • Under object (За объектом) — помещает изображение под другой объект, который далее нужно будет указать;
  • Back (зАдний план) — переносит изображение на задний план (под все другие объекты).

В системе AutoCAD 2004 появилась специальная панель Draw Order (Порядок вывода) (рис. 8.8), четыре кнопки которой соответствуют четырем опциям команды DRAWORDER (ПОРЯДОК).

Рис. 8.8. Панель инструментов Draw Order

Команда DRAWORDER (ПОРЯДОК) может управлять порядком взаимного расположения не только растровых изображений, но и любых других примитивов.
Есть еще несколько команд, выполняющих операции с растровыми изображениями. Команда IMAGECLIP (ИЗОБРЕЗ), которой соответствуют кнопка [image] панели Reference (Ссылки) и пункт падающего меню Modify | Clip | Image (Редакт | Подрезка | Изображение). Эта команда позволяет подрезать изображение с помощью прямоугольного или многоугольного контура.
Команда IMAGECLIP (ИЗОБРЕЗ) запрашивает:
Select image to clip: (Выберите изображение для подрезки:)
Щелкните левой кнопкой мыши по границе изображения, которое нужно подрезать (если же мишень указателя мыши окажется внутри изображения, то программа его не обнаружит). Далее следующий запрос:
Enter image clipping option [ON/OFF/Delete/New boundary] <New>:
(Задайте опцию подрезки [Вкл/Откл/Удалить/Новый контур] <Новый>:)
Возможны следующие опции:

  • ON (Вкл) — включает подрезку изображения, если контур подрезки уже был задан и отключен;
  • OFF (Откл) — отключает подрезку, хотя контур подрезки задан;
  • Delete (Удалить) — удаляет контур подрезки;
  • New boundary (Новый контур) — задает новый прямоугольный или многоугольный контур подрезки.

Рассмотрим опцию New boundary (Новый контур). При выборе этой опции AutoCAD запрашивает:
Enter clipping type [Polygonal/Rectangular] <Rectangular>:
(Тип контура подрезки [Многоугольный/Прямоугольный] <Прямоугольный>:)
Контур подрезки может быть прямоугольным или многоугольным. Для прямоугольного контура нужно задать два противоположных угла прямоугольной рамки, а для многоугольного — указать несколько точек, образующих замкнутый контур, но без самопересечений. В обоих случаях вводимые точки корректируются системой AutoCAD, если точки указаны за пределами изображения. Пример результата подрезки растрового изображения многоугольным контуром приведен на рис. 8.9.

Рис. 8.9. Подрезка растрового изображения

Контур изображения может быть погашен и снова включен с помощью команды IMAGEFRAME (ИЗОБКОНТУР), которой соответствуют кнопка [image] панели Reference (Ссылки) и пункт падающего меню Modify | Object | Image | Frame (Редакт | Объекты | Изображения | Контур).
Команда запрашивает:
Enter image frame setting [ON/OFF]: (Контур подрезки изображения [Вкл/Откл]:)
В скобках в качестве значения по умолчанию при этом запросе выдается текущее состояние контура.
Изображение с отключенным контуром недоступно для любых операций редактирования.
Команда IMAGEADJUST (ИЗОБРЕГУЛ), которой соответствуют кнопка [image] панели Reference (Ссылки) и пункт падающего меню Modify | Object | Image |Adjust (Редакт | Объекты | Изображения | Регулировка), позволяет менять такие характеристики, как яркость, контрастность и слияние с фоном.
Команда выдает запрос на указание изображения и затем вызывает диалоговое окно Image Adjust (Регулировка изображения) (рис. 8.10).

Рис. 8.10. Диалоговое окно Image Adjust

Пользователь может менять характеристики изображения, корректируя значения параметров трех областей: Brightness (Яркость), Contrast (Контрастность) и Fade (Слияние с фоном) в диапазоне от 0 до 100. Любое изменение отражается в образце или иначе области просмотра, расположенном в правой части диалогового окна. Если параметр Fade (Слияние с фоном) установить равным 100, то изображение полностью сольется с фоном. Кнопка Reset (Сброс) восстанавливает стандартные значения (50, 50 и 0).
Команда IMAGEQUALITY (ИЗОБКАЧЕСТВО) управляет качеством вывода изображения на экран. Команде соответствуют кнопка [image] панели Reference (Ссылки) и пункт падающего меню Modify | Object Image | Quality (Редакт | Объекты | Изображения | Качество).
Команда IMAGEQUALITY (ИЗОБКАЧЕСТВО) запрашивает:
Enter image quality setting [High/Draft]: (Качество изображения [Высокое/Черновое]:)
В случае выбора опции Draft (Черновое) при регенерации или открытии рисунка растровые изображения выводятся быстрее, но с худшим качеством. Рекомендуется опция High (Высокое).
Некоторые типы растровых изображений обладают свойством прозрачности, при включении которого на экране становятся видимыми нарисованные под ними объекты. Команда TRANSPARENCY (ПРОЗРАЧНОСТЬ) управляет этим свойством. Этой команде соответствуют кнопка [image] панели Reference (Ссылки) и пункт падающего меню Modify | Object | Image | Transparency (Редакт | Объекты | Изображения | Прозрачность).
Команда вначале запрашивает выбрать изображение, а затем выдает следующий запрос:
Enter transparency mode [ON/OFF]: (Состояние прозрачности [Вкл/Откл]:)
В случае ответа ON (Вкл) прозрачность изображения включается, в случае OFF (Откл) — выключается. В первый момент сразу после вставки изображения его прозрачность отключается.
Команды работы с изображениями доступны и через контекстное меню, вызываемое с помощью правой кнопки мыши при высвеченных ручках какого-нибудь из растровых изображений.
Система AutoCAD может сохранять образ графического экрана (или активного видового экрана, если графический экран разделен на несколько видовых — см. разд. 9.2) в растровом формате. Это может быть выполнено с помощью команды SAVEIMG (СОХРИЗОБ) или соответствующего ей пункта падающего меню Tools | Display Image | Save (Сервис | Изображения | Сохранить). Эта команда вызывает диалоговое окно Save Image (Сохранение изображения) (рис. 8.11).

Рис. 8.11. Диалоговое окно Save Image

Прежде всего, в области Format (Формат) с помощью соответствующего переключателя необходимо выбрать один из трех растровых форматов (BMP, TGA, TIFF), в которых может быть сохранен образ графического экрана (в образ не включаются плавающие панели и перекрестие устройства указания). При выборе форматов TGA и TIFF пользователю становится доступной кнопка Options (Параметры), расположенная в нижней части области Format (Формат). Эта кнопка вызывает диалоговые окна TGA Options (Параметры TGA) или TIFF Options (Параметры TIFF), в которых можно с помощью переключателя указать, использовать сжатие форматов или нет (в сжатом виде растровые файлы занимают на диске меньше места, но дольше обрабатываются).
В области Portion (Часть) нужно задать, какая часть графического экрана подлежит сохранению. В правом верхнем углу поля параметр Size (Размер) указывает размер полного экрана в точках (пикселах) по горизонтали и вертикали. Два поля Offset (Смещение) задают смещение, в пикселах, левого нижнего угла сохраняемой части экрана от левого нижнего угла графического экрана, который имеет координаты X = 0, Y = 0. Правый верхний угол сохраняемой части экрана задается с помощью полей Size (Размер). Его значения по осям X и Y должны быть заданы так, чтобы сохраняемая часть не вышла за пределы полного графического экрана. Заданные пользователем значения отображаются в графическом поле просмотра Active viewport (Активный видовой экран), которое показывает границы полного экрана и границы сохраняемой части (см. рис. 8.11).
Кнопка Reset (Сброс) позволяет вернуть установки границ к значениям по умолчанию, которые соответствуют полному графическому экрану.
После нажатия кнопки ОК система AutoCAD вызывает диалоговое окно Image File (Файл изображения), в котором расширение (bmp, tga или tif) будущего файла определено заданным растровым форматом (BMP, TGA или TIFF), а имя файла должен задать пользователь. По умолчанию предлагается имя, идентичное имени текущего рисунка.


8.2. Примитив WIPEOUT

Иногда требуется в созданном рисунке просто закрыть цветом фона какие-то линии или их части. Для этого в системе введен новый тип растровых изображений — пятно, создаваемый командой WIPEOUT (наименование команды в русскоязычной версии на момент написания книги не известно). Фактически это растровое изображение многоугольной формы, заполненное точками цвета фона рисунка.
Для построения примитива WIPEOUT можно заранее нарисовать в виде полилинии замкнутый контур, который должен закрыть какие-то объекты рисунка. Для примера возьмем полилинию, созданную командой RECTANG (ПРЯМОУГ). Теперь введем с клавиатуры команду WIPEOUT или выберем пункт Wipeout (Пятно) из падающего меню Draw (Рисование).
Команда WIPEOUT начинает с запроса:
Specify first point or [Frames/Polyline]<Polyline>: (Первая точка или [Границы/Полилиния] <Полилиния>:)
Теперь в случае указания точки система будет в цикле спрашивать следующие точки создаваемого многоугольного замкнутого контура, который станет границей пятна (окончание ввода точек — нажатие клавиши <Enter>). Выберем опцию Polyline (Полилиния).
Последует запрос: Select a closed polyline; (Выберите замкнутую полилинию:)
Укажите предварительно построенный прямоугольник.
Еще один запрос:
Erase polyline [Yes/No] <No>: Стереть полилинию [Да/Нет] <Нет >:
В случае ответа Yes (Да) полилиния будет удалена, в случае ответа No (Нет) — сохранится в рисунке. Выберите опцию Yes (Да). Результат операции приведен на рис. 8.12.

Рис. 8.12. Вставка пятна

На рисунке видно, что хотя полилиния была удалена, но контур пятна остался видимым. Для отключения контуров всех объектов WIPEOUT следует воспользоваться опцией Frames (Контуры) команды WIPEOUT и в ответ на запрос
Enter mode [ON/OFF] <ON>: (Введите режим [Вкл/Откл] <Вкл >:)
Ответ OFF (Откл) отключает контуры всех пятен.
С помощью пятна можно "заклеить" лишние части вашего рисунка, не прибегая к операциям редактирования (стирания, обрезки и т. п.). Пятно имеет те же свойства, что и растровое изображение, поэтому к нему можно применять команду DRAWORDER (ПОРЯДОК), которую можно вызвать с помощью кнопки [image] панели Modify II (Редактирование-2).


8.3. Импорт из других форматов

В падающем меню Insert (Вставка) имеется шесть пунктов, которые позволяют импортировать в рисунок системы AutoCAD файлы еще некоторых форматов.
Перечислим эти пункты:

  • 3D Studio (Файл 3D Studio) — выполняет импорт файлов системы 3ds max (команда 3DSIN (ИМПОРТЗДС)), с передачей геометрии и данных о тонировании, сетях, материалах, источниках света и камерах;
  • ACIS File (Файл ACIS) — задает импорт файлов в формате ACIS, предназначенном для хранения геометрии пространственных твердотельных объектов (команда ACISIN (ИМПОРТТЕЛ));
  • Drawing Exchange Binary (Файл DXB) — выполняет импорт файлов в двоичном обменном формате DXB (команда DXBIN (ИМПОРТД));
  • Windows Metafile (Метафайл Windows) — задает импорт графических метафайлов Windows (команда WMFIN (ИМПОРТМТФ));
  • OLE Object (Объект OLE) — выполняет вставку связанного или внедренного объекта из программы, поддерживающей технологию OLE, например, Microsoft Word или Microsoft Excel (команда INSERTOBJ (ВСТОБЪЕКТ));
  • Markup (Пометка) — задает вставку пометок к текущему чертежному файлу, сохраненных в файле формата RML с помощью модуля Volo View Express фирмы Autodesk (команда RMLIN (ПОМЕТКА)).

Импорт файлов четырех первых форматов (соответствующие расширения файлов — 3ds, sat, dxb, wmf) выполняется одинаково, поэтому рассмотрим его на примере вставки файла формата WMF (метафайла Windows, в котором геометрия объектов сохраняется не в точечном, а в векторном виде). Команда WMFIN (ИМПОРТМТФ) начинает работу с открытия диалогового окна Import WMF (Импорт WMF), которое имеет стандартную форму окна выбора файлов с заданным расширением wmf.
Выберем для примера файл J01572763.wmf из числа файлов, поставляемых вместе с Windows XP Professional. После указания имени вставляемого файла AutoCAD выдает запрос:
Specify insertion point or [Scale/X/Y/Z/Rotate/PScale/PX/PY/PZ/PRotate]:
(Точка вставки или [Масштаб/Х/У/2/ ПОворот/ПМасштаб/ПХ/ПУ/П2/ ППоворот]:)
Такой же запрос выдает и команда INSERT (ВСТАВИТЬ) при вставке блока. Дальнейшие действия по вставке метафайла аналогичны действиям при вставке блока. При задании параметров вставки изображение метафайла перемещается вместе с курсором (рис. 8.13).

Рис. 8.13. Импорт файла формата WMF

В результате операции импорта новый объект оформляется как вхождение блока с именем, содержащим префикс WMF.
Команда IMPORT (ИМПОРТ), которой соответствует кнопка [image] панели инструментов Insert (Вставка), позволяет вставлять файлы трех из перечисленных форматов (WMF, ACIS, 3D Studio). Команда открывает диалоговое окно Import File (Импорт файла) (рис. 8.14), в котором в раскрывающемся списке Files of type (Тип файлов) доступны только расширения, соответствующие трем упомянутым форматам.

Рис. 8.14. Диалоговое окно Import File

Специальная команда — INSERTOBJ (ВСТОБЪЕКТ) — позволяет вставлять в рисунок документы, созданные Windows-приложениями. Этой команде соответствуют кнопка [image] панели Insert (Вставка) и пункт OLE Object (Объект OLE) падающего меню Insert (Вставка).
Команда INSERTOBJ (ВСТОБЪЕКТ) вызывает диалоговое окно Вставка объекта (Insert Object) (рис. 8.15), которое в русской версии Windows выводится на русском языке.
В центральной части диалогового окна в списке Тип объекта (Object Type) располагается список документов всех приложений Windows, установленных на вашем компьютере и поддерживающих OLE-технологию (технологию связывания и внедрения). Данная технология предусматривает два варианта вставки одного документа в другой: связывание и внедрение. При связывании создается ссылка на другой файл документа, который можно редактировать, не выходя из основного документа. При внедрении либо создается новый документ другого типа, который помещается внутрь основного документа, либо в основной документ вставляется содержимое другого документа, но связь с файлом-источником утрачивается. В обоих случаях на время создания или редактирования вставленного документа в отдельное окно загружается его собственное приложение. Вариант связывания аналогичен вставке внешней ссылки, а вариант внедрения — вставке файла как блока.

Рис. 8.15. Диалоговое окно Вставка объекта (режим Создать новый)

Для примера рассмотрим операцию вставки в рисунок системы AutoCAD текстового документа, созданного в Microsoft Word. В левой части открытого диалогового окна Вставка объекта (Insert Object) (см. рис. 8.15) нужно выбрать либо переключатель Создать новый (Create New), либо Создать из файла (Create from File). Первый вариант означает, что мы создадим совершенно новый текстовый документ, который будет внедрен внутрь рисунка AutoCAD и не будет существовать в виде отдельного файла Microsoft Word. Выбор переключателя Создать из файла (Create from File) означает, что нужно будет указать файл с вставляемым текстовым документом. В этом случае диалоговое окно Вставка объекта (Insert Object) изменит свой начальный вид на вид, приведенный на рис. 8.16.

Рис. 8.16. Диалоговое окно Вставка объекта (режим Создать из файла)

В данном диалоговом окне нужно будет определить имя вставляемого файла, для чего необходимо либо в поле Файл (File) ввести полное имя вставляемого файла, либо выбрать файл с помощью кнопки Обзор (Browse), которая откроет диалоговое окно поиска файла. Установленный флажок Связь (Link) будет означать, что документ вставляется со связыванием, а сброшенный — что документ внедряется. Дальнейшие действия пользователя в этом окне аналогичны действиям в режиме Создать новый (Create New), к которому мы и возвращаемся.
В режиме Создать новый (Create New) в списке Тип объекта (Object Type) диалогового окна Вставка объекта (Insert Object) (см. рис. 8.15) отметим строку Документ Microsoft Word (Microsoft Word Document). Флажок В виде значка (Display as Icon) устанавливать не будем (при установке флажка документ вставится в рисунок не в естественном виде, а в виде условного значка Word Pad с подписью Документ.
Далее нажмем кнопку ОК. После этого в оперативную память подгружается необходимое программное обеспечение и открывается окно Word Pad. Введите в этом окне ваш текст и отформатируйте его средствами Word (рис. 8.17).

Рис. 8.17. Окно Документ в Drawing 1 — Word Pad

В названии окна у вас вместо Drawing 1 может быть другое имя (т. е. имя вашего текущего рисунка). Дальше в падающем меню Файл Word Pad выберите Закрыть и вернуться Документ в Drawing!. Окно Word Pad закроется, и ваш документ окажется вставленным в верхний левый угол графического экрана (зона документа имеет белый фон), поверх которого появится диалоговое окно OLE Properties (Свойства OLE) (рис. 8.18).

Рис. 8.18. Диалоговое окно OLE Properties

В этом окне есть возможность подкорректировать параметры вставляемого документа с помощью параметров следующих областей:

  • Size (Размер) — задает, в миллиметрах, высоту и ширину зоны документа в рисунке с помощью полей Height (Высота) и Width (Ширина); кнопка Reset (Сбросить) устанавливает размер зоны документа по умолчанию;
  • Scale (Масштаб) — устанавливает масштаб вставки документа в процентах от исходного размера, с помощью счетчиков Height (Высота) и Width (Ширина); если установить флажок Lock Aspect Ratio (He изменять пропорции), то изменение одного параметра (высоты или ширины) будет автоматически менять значение второго параметра;
  • Text size (Размер текста) — меняет имя шрифта (левый параметр, выбираемый из раскрывающегося списка) и устанавливает соответствие между размером шрифта в пикселах (средний параметр) и единицах рисунка (правый параметр).

В раскрывающемся списке OLE plot quality (Качество печати OLE) можно установить качество печати вставленного документа, выбираемое из четырех допустимых значений.
Установка флажка Display dialog when pasting new OLE object (Выводить это окно при вставке новых объектов) заставляет автоматически вызывать диалоговое окно OLE Properties (Свойства OLE) при вставке очередного OLE-объекта.
Закройте диалоговое окно OLE Properties (Свойства OLE). Документ окажется вставленным в рисунок (рис. 8.19).

Рис. 8.19. Вставка OLE-объекта

Такой документ можно перемещать. Для этого нужно щелкнуть левой кнопкой мыши по белому полю вставленного документа. У него появятся 8 ручек (по углам и средним точкам кромок). Документ можно передвигать по рисунку с помощью обычной буксировки: нажать и, не отпуская левую кнопку мыши, переместить курсор вместе с документом в новое место и только после этого отпустить.
Вставленный документ можно масштабировать, если установить указатель мыши на одну из угловых ручек и после появления двойной наклонной стрелки изменить размер зоны документа (аналогично изменению размеров окон Windows). He рекомендуется растягивать зону документа только по одному направлению, т. к. это приведет к искажению пропорций текста. Для редактирования текста с помощью левой кнопки мыши дважды щелкните по зоне документа, после чего откроется окно Microsoft Word с вашим текстом.
Для редактирования вставленного документа можно использовать контекстное меню (рис. 8.20), вызываемое щелчком правой кнопкой мыши по зоне документа.

Рис. 8.20. Контекстное меню редактирования вставленного документа

Возможна вставка отмеченного участка документа в рисунок AutoCAD методом перетаскивания, если одновременно открыть окно с документом Microsoft Word и окно с рисунком системы AutoCAD. Если же при этом нажать и не отпускать клавишу <Ctrl>, то выделенный участок текста после вставки сохраняется в файле-источнике (т. е. выполняется операция копирования), в противном случае — выделенный участок из исходного файла удаляется (выполняется операция перемещения).
Система AutoCAD поддерживает буфер обмена Windows для копирования и вставки OLE-объектов. Этой цели служат пункты падающего меню Edit (Правка):

  • Copy Link (Копировать вид) — копирует текущий вид в буфер обмена для связывания с другими OLE-приложениями (соответствующая команда — COPYLINK (КСВЯЗЬ), о видах см. гл. 9);
  • Paste Special (Специальная вставка) — вставляет данные из буфера обмена с возможностью управления их форматом (соответствующая команда - PASTESPEC (ВСТСПЕЦ));
  • OLE Links (Связи) — обновляет, изменяет и разрывает имеющиеся OLE-связи (соответствующая команда — OLELINKS (ВНЕДРСВЯЗИ)).

Пункт OLE Links (Связи) доступен, только если в рисунке присутствуют связи с объектами других приложений. Соответствующая ему команда OLELINKS (ВНЕДРСВЯЗИ) вызывает диалоговое окно Связи (Links) (рис. 8.21).
В данном окне перечисляются связи, имеющиеся в рисунке, и для каждой из них указывается имя файла-источника (колонка Связи (Links)), тип объекта (колонка Тип (Туре)) и способ обновления (колонка Обновление (Update)). Для помеченной в диалоговом окне связи в нижнюю часть окна выводится та же информация, но в более подробном виде. В качестве типа объекта приводится имя создавшего его приложения, а для способа обновления есть два переключателя: Автоматическое (Automatic) и Вручную (Manual).

Рис. 8.21. Диалоговое окно Связи

Кнопка Обновить сейчас (Update Now) выполняет немедленное обновление выбранной в списке связи. Кнопка Открыть источник (Open Source) открывает файл-источник и подсвечивает ту часть, которая связана с текущим рисунком AutoCAD. С помощью кнопки Сменить источник (Change Source) можно сменить файл, являющийся источником для связи. Кнопка Разорвать связь (Break Link) разрывает связь, преобразуя ее во внедрение файла-источника в рисунок.
Для работы с внедренными объектами служит диалоговое окно Преобразование (Convert) (рис. 8.22), которое вызывается, если щелкнуть правой кнопкой по внедренному объекту и в контекстном меню (см. рис. 8.20) выбрать пункт Преобразовать (Convert).

Рис. 8.22. Диалоговое окно Преобразование

Данное диалоговое окно (см. рис. 8.22) позволяет сменить приложение-источник для выбранного внедренного объекта. Параметр Текущий тип (Current Type) показывает действующий тип выбранного объекта. Список Тип объекта (Object Type) отображает список только тех типов, которые могут быть выбраны для преобразования.
Два переключателя в левой части диалогового окна Преобразование (Convert) выполняют следующие действия:

  • Преобразовать в (Convert to) — задает преобразование объекта в новый тип, который сохраняется и после закрытия диалогового окна;
  • Активировать как (Activate as) — после редактирования объект возвращается к своему старому типу.

Установленный флажок В виде значка (Display as Icon) позволяет показывать внедренный объект в рисунке AutoCAD в виде значка создавшего его приложения, а не в естественном виде документа. При установке этого флажка появится еще опция Изменить значок (Change Icon).
Область Результат (Result) содержит комментарий к результату применения выбранных опций в диалоговом окне Преобразование (Convert).


8.4. Экспорт в другие форматы

Помимо рассмотренных возможностей импорта, AutoCAD располагает аналогичными возможностями экспорта. Для этого предназначена команда EXPORT (ЭКСПОРТ) и соответствующий ей пункт Export (Экспорт) падающего меню File (Файл). Команда EXPORT (ЭКСПОРТ) вызывает диалоговое окно Export Data (Экспорт данных), в котором, используя раскрывающийся список Files of type (Тип файлов), можно выбрать расширение одного из допустимых типов файлов экспорта (рис. 8.23).
К допустимым типам форматов экспорта относятся:

  • Metafile (Метафайл) — расширение wmf;
  • ACIS (ACIS) — расширение sat;
  • Lithography (Литография) — расширение stl;
  • Encapsulated PS (Encapsulated PS) — расширение eps;
  • DXX Extract (Файлы вывода DXX) — расширение dxx;
  • Bitmap (Растровые файлы) — расширение bmp;
  • 3D Studio (Файлы 3D Studio) — расширение 3ds;
  • Block (Блок) — расширение dwg.

Рис. 8.23. Диалоговое окно Export Data

К каждому из перечисленных вариантов экспорта можно также обратиться с помощью индивидуальных команд:

  • WMFOUT (ЭКСПОРТМТФ);
  • ACISOUT (ЭКСПОРТТЕЛ);
  • STLOUT (ЭКСПОРТСТЛ);
  • PSOUT (ЭКСПОРТПС);
  • АТТЕХТ (АТЭКСП);
  • BMPOUT (ЭКСПОРТНЫЙ);
  • 3DSOUT (ЭКСПОРТЗДС);
  • WBLOCK (ПБЛОК).


Глава 9. Трехмерные построения

    • Трехмерные построения
    • 9.1. Плоскости построения и системы координат
    • 9.1.1. Управление знаком ПСК
    • 9.1.2. Координаты в трехмерном пространстве
    • 9.1.3. Уровень и высота
    • 9.1.4. Системы координат
    • 9.2. Виды и видовые экраны
    • 9.2.1. Общий вид
    • 9.2.2. Конфигурации видовых экранов
    • 9.2.3. Виды
    • 9.2.4. Настройка вида
    • 9.3. Трехмерные полилинии
    • 9.4. Тонирование
    • 9.4.1. Типы тонирования
    • 9.4.2. Источники
    • 9.4.3. Сцены
    • 9.4.4. Материалы
    • 9.4.5. Фон и туман
    • 9.4.6. Элементы ландшафта
    • 9.4.7. Настройки и статистика
    • 9.5. Грани и сети
    • 9.6. Области
    • 9.7. Тела
    • 9.7.1. Построение тел
    • 9.7.2. Разрезы и сечения
    • 9.7.3. Редактирование тел


Система AutoCAD может строить рассмотренные в предыдущих главах примитивы не только в плоскости XY, которая до сих пор была единственной плоскостью построений, но и в любой плоскости трехмерного пространства. Кроме того, в системе AutoCAD существует большой набор пространственных примитивов (сетей, тел и др.), которые позволяют выполнять построения трехмерных моделей зданий, сооружений и машиностроительных изделий.
Далее мы не только будем строить трехмерные объекты, но и рассматривать их в разных видах и проекциях, используя новые системы координат (все эти понятия будут определены далее). Затем познакомимся с такими возможностями AutoCAD, как скрытие невидимых линий, тонирование и назначение объектам тех или иных материалов. Все построенные модели можно оформлять красиво и удобно в виде чертежей с помощью пространства листа, рассмотренного в гл. 10.


9.1. Плоскости построения и системы координат

Плоскость XY основной системы координат, с которой мы до сих пор работали и которая называется мировой системой координат (МСК), совпадает с плоскостью графического экрана. Третья ось (ось Z) МСК расположена перпендикулярно экрану и направлена от экрана к нам. В качестве признака мировой системы координат пиктограмма осей имеет прямоугольник в точке начала координат (рис. 9.1).

Рис. 9.1. Пиктограмма мировой системы координат (стиль 3D)

Все остальные системы координат называются пользовательскими системами координат (ПСК).


9.1.1. Управление знаком ПСК

Другая форма пиктограммы, которая привычна пользователям, работавшим с предыдущими версиями системы AutoCAD, может быть установлена в диалоговом окне UCS Icon (Знак ПСК) (рис. 9.2), вызываемом либо с помощью пункта падающего меню View | Display | UCS Icon | Properties (Вид | Отображение | Знак ПСК | Свойства), либо с помощью опции Properties (Свойства) команды UCSICON (ЗНАКПСК).

Рис. 9.2. Диалоговое окно UCS Icon

Данное диалоговое окно имеет четыре области. В области UCS icon style (Стиль пиктограммы ПСК) можно с помощью соответствующих переключателей 2D и 3D выбрать стиль отображения пиктограммы системы координат. Стиль 3D показан на рис. 9.1, стиль 2D — на рис. 9.3.

Рис. 9.3. Пиктограмма мировой системы координат (стиль 2D)

При использовании стиля 2D буква W (в русской версии AutoCAD — М) обозначает МСК.
В случае стиля 3D установка в диалоговом окне (см. рис. 9.2) флажка Cone (Конус) выводит на конце осей замкнутую стрелку (конус), а при сбросе флажка — незамкнутую стрелку. Параметр Line width (Ширина линии) управляет шириной линий осей (может принимать значения от 1 до 3 пикселов).
В области UCS icon size (Размер знака ПСК) устанавливается величина знака в процентах от размера экрана (допустимые значения — от 5 до 95). В области UCS icon color (Цвет знака ПСК) можно изменить цвет пиктограммы ПСК (параметры выбираются из раскрывающихся списков Model space icon color (Цвет знака в пространстве модели) и Layout tab icon color (Цвет знака на листах)).


9.1.2. Координаты в трехмерном пространстве

Многие рассмотренные нами команды допускают ввод трехмерных координат точек. Например, для команды LINE (ОТРЕЗОК) на запрос From point: (От точки:) можно ввести: 114,47,200 — это означает, что начальная точка строящегося отрезка имеет соответствующие координаты по осям: Х= 114, Y= 47 и Z= 200 (напомним, что в системе AutoCAD запятая является разделителем между координатами, а точка отделяет целую часть числа от дробной). Если же на следующий запрос команды LINE (ОТРЕЗОК) То point: (К точке:) вы ответите: 62.81,—39.4,—4.55, то будет построен отрезок, у которого конечной точкой является точка с координатами: Х= 62.81, Y= -39.4 и 2= -4.55.
Вариант относительного ввода точек в декартовых координатах тоже допускает использование трех координат, например: @28,0,44 — строящаяся точка смещена относительно предыдущей по оси X на 28 мм, по оси У— на О мм, а по оси Z — на 44 мм.
К записи относительного ввода точки в полярных координатах тоже может добавляться третья координата, например: @12.6<19.4,20.79. Эта запись означает, что проекция отрезка на плоскость XY, построенного из предыдущей точки в указанную нами вторую точку, образует в плоскости XY с положительным направлением оси X угол 19,4° и имеет в этой же плоскости длину 12,6 мм, а координата Z конечной точки отрезка смещена от начальной по оси Z на 20,79 мм. Этот вариант ввода координат можно назвать относительным вводом точек в цилиндрических координатах (ось цилиндра направлена по оси Z).
Возможен ввод координат записью следующего типа: @73<35<57 — его можно назвать относительным вводом точек в сферических координатах. Понимать эту запись следует так: отрезок сначала строится в плоскости XY, образуя угол 35 градусов относительно положительного направления оси X, затем отрезок наклоняется относительно плоскости XY на 57° и, на определившемся таким образом луче, конечная точка отрезка смещается относительно начальной на 73 мм.
Для указания точек в пространстве может использоваться и объектная привязка к характерным точкам объектов. Следует отметить, что роль объектной привязки в трехмерном пространстве даже выше.
Плоскость, в которой строятся двумерные объекты, называется плоскостью построений. Ее положение определяется действующей системой координат и уровнем, т. е. смещением плоскости построений вдоль оси Z относительно плоскости XY системы координат. Мы имели дело пока только с одной системой координат — мировой, но даже в ней можно менять уровень плоскости объекта.
Удобно анализировать трехмерные построения в изометрических видах, которые вполне могут заменить известную нам аксонометрию. Главное, что в любом изометрическом виде хорошо заметны модификации примитивов по всем трем осям. Установим стандартный вид, называемый юго-западной изометрией. Воспользуйтесь для этого пунктом падающего меню View | 3D Views | SW Isometric (Вид | ЗМ виды ЮЗ изометрия). Щелкните с помощью левой кнопки мыши по указанному пункту меню. После этого изменяется внешний вид графического экрана: пиктограмма осей МСК смещается в центр и разворачивается так, что в проекции угол между осями будет уже не прямым, а 120°. Кроме того, внутри пиктограммы появляется знак плюс, означающий, что в данном виде пиктограмма располагается в начале действующей системы координат, т. е. в начале МСК. Форма перекрестия устройства указания также изменяется аналогично знаку осей координат.


9.1.3. Уровень и высота

Рассмотрим работу в изометрии на примере построения окружности. Нарисуйте окружность (с помощью команды CIRCLE (КРУГ)) с центром в точке X = 0, Y = 0 и радиусом 100 мм. В результате получим вид, изображенный на рис. 9.4.

Рис. 9.4. Окружность, построенная в юго-западной изометрии

В изометрическом виде окружность изображается эллипсом. Ось Z при этом идет вертикально вверх от точки начала координат. Изменим уровень окружности (для этого нужно изменить координату Z центра окружности). Щелкните по окружности — у нее появятся ручки. С помощью кнопки [image] панели Standard (Стандартная) вызовите окно PROPERTIES (СВОЙСТВА).
В этом окне отражены все характеристики окружности, которые при желании могут быть изменены. Щелкните дважды левой кнопкой мыши в правой колонке, напротив характеристики Center Z (Центр Z). В ячейке появится вертикальный текстовый курсор и значок устройства указания (его можно использовать, если вы хотите указать новое значение Z для центра с помощью мыши). Исправьте с помощью клавиатуры старое значение 0 на 250 (рис. 9.5) и закройте окно PROPERTIES (СВОЙСТВА).

Рис. 9.5. Изменение уровня с помощью окна PROPERTIES

В результате этого изменения окружность переместилась вверх на 250 мм (рис. 9.6). Если бы было нужно опустить окружность на 250 мм вниз, то мы бы задали Z = —250.
Таким образом, в нашем примере плоскостью построений сначала была основная плоскость XY с уровнем Z= 0, а затем объект был перенесен в новую плоскость (на 250 мм выше по оси Z).
Теперь попробуем изменить еще одну характеристику нашего круга — высоту. Под высотой в системе AutoCAD понимается толщина объекта по оси Z. В нашем случае это будет означать, что окружность превратится в цилиндр с осью, направленной вдоль оси Z MCK. Откройте еще раз окно PROPERTIES (СВОЙСТВА) и измените значение параметра Thickness (Высота) с 0 на 100. При этом двумерный круг превратится в трехмерный цилиндр (рис. 9.7).

Рис. 9.6. Результат изменения уровня объекта

Рис. 9.7. Результат изменения высоты объекта

На криволинейной части цилиндра AutoCAD для наглядности выводит некоторое количество образующих. Кроме того, в рабочем режиме все стенки цилиндра доступны для редактирования и прозрачны, чтобы видеть объект полностью.
Операция изменения высоты называется еще выдавливанием двумерного объекта (в данном случае выдавливание круга идет вдоль положительного направления оси Z). Образовавшийся объект уже является трехмерным полым объектом. Теперь воспользуйтесь пунктом Hide (Скрыть) падающего меню View (Вид) для того, чтобы скрыть невидимые части цилиндра и убедиться, что стенка цилиндра и оба дна (основания) является непрозрачными. Этому пункту соответствует команда HIDE (СКРЫТЬ). Результат скрытия невидимых линий приведен на рис. 9.8.

Рис. 9.8. Скрытие невидимых линий цилиндра командой HIDE

Замечание В режиме трехмерного каркаса команда HIDE (СКРЫТЬ) считает оба дна (основания) цилиндра прозрачными, аналогично действию операций раскрашивания и тонирования, рассматриваемых в разд. 9.2 и 9.4.

Если выдавить другой двумерный объект — например, прямоугольник (т. е. замкнутую полилинию в форме прямоугольника), — то у него боковые стенки будут тоже непрозрачными.
Изображение, образовавшееся в графическом экране в результате скрытия невидимых линий, является нерабочим — для продолжения редактирования рекомендуется выполнить пункт Regen (Регенерировать) или Regen All (Регенерировать все) падающего меню View (Вид). Пункт Regen All (Регенерировать все) отличается от пункта Regen (Регенерировать) тем, что если графический экран разделен на видовые экраны (о видовых экранах см. разд. 9.2), то регенерируются все экраны, а не только активный.
Система AutoCAD хранит текущее значение уровня, на котором выполняются построения, в системной переменной ELEVATION (о системных переменных см. гл. 11). Команда ELEV (УРОВЕНЬ) изменяет текущие установки для уровня и высоты объектов, которые будут строиться далее. Команда запрашивает (в скобках указывается текущее значение):
Specify new default elevation <0.0000>: (Новый уровень по умолчанию <0.0000>:)
Введите 250, что соответствует уровню нижнего основания цилиндра. Таким образом, плоскость построений переносится на уровень 250 мм. Следующий запрос (в скобках — текущее значение):
Specify new default thickness <0.0000>: (Новая высота по умолчанию <0.0000>:)
Введите —100, чтобы строящиеся объекты выдавливались на 100 мм вдоль отрицательного направления оси Z
Теперь постройте окружность с центром в точке с координатами 0,0 и радиусом 200 мм. Если у точки центра координата Z отсутствует, то значение Z берется равным текущему уровню (т. е. 250 мм). В результате, во-первых, построится не окружность, а еще один цилиндр, поскольку задана ненулевая высота, а во-вторых, одно основание цилиндра попадет в плоскость нижнего основания первого цилиндра, а второе основание будет лежать в плоскости с уровнем 150 мм (т. к. к текущему уровню 250 прибавляется высота выдавливания, т. е. —100). Можно немного упростить себе задачу построения цилиндра, если при задании центра окружности воспользоваться функцией объектной привязки Center (Центр) к центру нижнего основания существующего цилиндра. В этом случае точка центра вычислилась бы сразу как трехмерная.
Теперь скройте невидимые линии. Результат выполненных операций представлен на рис. 9.9.

Рис. 9.9. Скрытие невидимых линий двух цилиндров

Перемещение примитивов можно было бы выполнить не только изменяя уровень объекта (для окружности это координата Z ее центра), но и с помощью обычной команды MOVE (ПЕРЕНЕСТИ) (см. разд. 3.2), используя для этого при ответе на запросы команды две трехмерные точки, расположенные друг от друга в пространстве с заданным сдвигом вдоль оси Z.


9.1.4. Системы координат

Для задания любых других плоскостей построений, которые не параллельны плоскости XY МСК, используется команда UCS (ПСК). Аббревиатура команды образована от слов "user coordinate system" ("пользовательская система координат"). Все системы координат, отличные от мировой, называются пользовательскими. Пользовательские системы координат могут именоваться. Команда UCS (ПСК) позволяет задать начало новой системы координат и положение новых осей Xii Y, а положение новой оси Z зависит от положения соответствующих осей Х и У и поэтому определяется автоматически.
Этой команде соответствуют две панели инструментов: UCS (ПСК) и UCS II (ПСК-2) (рис. 9.10 и 9.11).

Рис. 9.10. Панель инструментов UCS

Рис. 9.11. Панель инструментов UCS II

Рассмотрим работу команды UCS (ПСК) на примере, в котором следующей плоскостью построений сделаем плоскость XZ МСК.
Наберите команду UCS (ПСК) на клавиатуре или щелкните по кнопке [image] панели UCS (ПСК).
Система сообщает:
Current ucs name: *WORLD* (Имя текущей системы координат: *МИРОВАЯ*)
Далее следует запрос:
Enter an option [New/Move/orthoGraphic/Prev/Restore/Save/Del/Apply/?/World] <World>:
(Задайте опцию [Hoвaя/Пepeнecmli/OPтогональнaя/пpeДыдyщaя/Boccтaнoвить/ Сохранитъ/Удалить/прИменить/?/Мир] <Мир >:)
Возможен выбор следующих опций:

  • New (Новая) — переход в режим создания новой ПСК;
  • Move (Перенести) — перенос начала текущей ПСК в новую точку;
  • orthoGraphic (ОРтогональная) — выбор одной из шести стандартных ортогональных систем координат;
  • Prev (предыдущая) — возврат к предыдущей ПСК;
  • Restore (Восстановить) — восстановление ПСК по ее имени;
  • Save (Сохранить) — сохранение текущей ПСК с новым именем;
  • Del (Удалить) — удаление именованной ПСК;
  • Apply (применить) — применение ПСК текущего видового экрана к другому экрану или сразу ко всем видовым экранам (о видовых экранах см. разд. 9.2);
  • ? (?) — вывод списка именованных ПСК с их характеристиками;
  • World (Мир) — восстановление МСК.

Для построения новой ПСК выберите опцию New (Новая). Далее система AutoCAD выдает запрос:
Specify origin of new UCS or [ZAxis/3point/OBject/Face/View/X/Y/Z] <0,0,0>:
(Укажите начало новой ПСК или [20съ/Зточки/Объект/Гранъ/Вид/Х/¥/2] <0,0,0>:)
В этом случае возможны следующие опции создания новой системы координат:

  • origin of new UCS (начало новой ПСК) — перенос начала ПСК в новую точку с сохранением направления осей X и У\
  • ZAxis (ZOcb) — указание нового начала координат и точки, лежащей на положительном направлении новой оси Z\
  • 3point (Зточки) — указание нового начала координат и точек, определяющих положительные направления новых осей X и У;
  • OBject (Объект) — установка ПСК по плоскости двумерного объекта;
  • Face (Грань) — установка ПСК по плоскости грани трехмерного тела;
  • View (Вид) — установка ПСК перпендикулярно направлению взгляда (в плоскости вида), с сохранением начала координат;
  • X — поворот текущей ПСК вокруг текущей оси X; П Y — поворот текущей ПСК вокруг текущей оси У;
  • Z — поворот текущей ПСК вокруг текущей оси Z.

Самым общей является опция 3point (Зточки). Построим с ее помощью новую ПСК. После выбора опции следует запрос:
Specify new origin point <0,0,0>: (Новое начало координат <0,0,0>:)
Нажмите клавишу <Enter>, подтверждая сохранение начала координат на прежнем месте. Следующий запрос:
Specify point on positive portion of X-axis <1.0000,0.0000,0.0000>:
(Точка на положительном луче оси X <1.0000,0.0000,0.0000>:)
Поскольку оси X и Y новой ПСК должны лежать в плоскости XZ МСК, то новая ось обязана пройти по старой. Поэтому нажмите клавишу <Enter> (предлагаемая точка 1,0,0 лежит на положительном направлении оси X МСК). Далее:
Specify point on positive-Y portion of the UCS XY plane <0.0000,1.0000,0.0000>:
(Точка на положительном луче оси Ye плоскости XY ПСК <0.0000,1.0000,0.0000>:)
Новую ось К направим по оси Z МСК, поэтому ответьте 0,0,1, и новая ось ординат (Y) пойдет по старой оси Z (точка 0,0,1 лежит на положительном направлении оси Z).
Выполненная операция определила новую текущую систему координат, поэтому пиктограмма ПСК изменит свое положение (рис. 9.12).

Рис. 9.12. Новое направление осей системы координат

Кроме того, в панели UCS II (ПСК-2) поле списка, показывающее имя текущей ПСК и имевшее значение World (Мировая СК), изменило свое значение на Unnamed (Без имени). Если ПСК нужна для неоднократных построений, сохраните ее с новым именем (например, nviXZ), для чего нужно повторить команду UCS (ПСК) и выбрать опцию Save (Сохранить). В ответ на запрос имени введите имя, выбранное вами для новой ПСК.
Теперь все вводимые координаты будут браться относительно текущей ПСК, которая отлична от МСК. Если вы, находясь в ПСК, хотите все-таки задать координаты точки в мировой системе координат, то добавляйте перед координатами символ звездочки, например: *150,320
Вспомним, что текущее значение уровня было 250 мм. Введение новой системы координат не изменит его (оно сохраняется в системной переменной ELEVATION — см. разд. 11.1}. Однако это означает, что текущей плоскостью построений будет не плоскость XY действующей ПСК, а плоскость, которая параллельна ей (напомню, что эта плоскость совпадает с плоскостью XZ МСК) и отстоит от нее вдоль направления новой оси аппликат (Z) на 250 мм. Попробуйте с помощью команды PLINE (ПЛИНИЯ) построить замкнутую полилинию в новой системе координат с вершинами в точках (0,0), (200,0), (200,120) и (0,120). Получится параллелепипед, а не прямоугольная полилиния, т. к. текущее значение высоты равно —100. Основание нового параллелепипеда будет параллельно новой плоскости построений (рис. 9.13, со скрытием невидимых линий с помощью команды HIDE (СКРЫТЬ)).

Рис. 9.13. Построение параллелепипеда в новой ПСК

Поскольку вы не указали третьей координаты для первой вершины полилинии, то AutoCAD взял ее значение из текущего значения уровня, т. е. 250 мм. Если бы были заданы все три координаты первой точки, то плоскость основания параллелепипеда была бы выбрана независимо от текущего уровня. Обратите внимание, что основания построенного параллелепипеда, в отличие от основания цилиндра, для команды HIDE (СКРЫТЬ) не являются сплошными двумерными объектами (имеют только внешний контур без внутренности) и поэтому прозрачны.
Новую систему координат, поскольку она является одной из стандартных, проще было бы задать с помощью опции orthoGraphic (ОРтогональная) команды UCS (ПСК). При выборе этой опции команда UCS (ПСК) запрашивает имя для системы координат:
Enter an option [Top/Bottom/Front/Back/Left/Right] <Top>:
(Задайте опцию [Верхняя/Нижняя/Передняя/Задняя/Левая/пРавая] <Верхняя >:)
Имя нашей системы координат — Front (Передняя), поскольку выбор плоскости XZ для построений соответствует выбору переднего вида. ПСК Back (Задняя) отличается от Front (Передняя) тем, что у нее ось X направлена в противоположную сторону. Мировая система координат идентична с Тор (Верхняя). Соответственно, если вы хотите выбрать ПСК для правого вида, укажите Right (пРавая).
Для выбора стандартной ПСК можно также воспользоваться раскрывающимся списком систем координат панели UCS II (ПСК-2), в котором нужно выбрать пункт Front (Спереди) (рис. 9.14).

Рис. 9.14. Раскрывающийся список систем координат панели UCS II

В панели инструментов UCS (ПСК) (см. рис. 9.10) собраны кнопки, которые соответствуют различным вариантам (комбинациям опций) команды UCS (ПСК). Поэтому щелчок по любой кнопке этой панели инструментов почти всегда означает, что вызывается команда UCS (ПСК) с некоторой опцией или опциями. Перечислим кнопки панели инструментов UCS (ПСК) по порядку слева направо:

  • - вызывает выполнение команды UCS (ПСК) без автоматического выбора опций (далее их задает пользователь);
  • - вызывает диалоговое окно UCS (ПСК) для управления именованными системами координат;
  • — восстанавливает предыдущую ПСК;
  • — восстанавливает МСК;
  • — устанавливает ПСК по объекту;
  • — совмещает ПСК с выбранной гранью трехмерного тела;
  • — устанавливает новую систему координат с плоскостью XY, параллельной экрану (виду);
  • - устанавливает новую ПСК путем переноса начала системы координат;
  • — устанавливает ПСК путем указания точки на положительном участке новой оси Z;
  • — устанавливает новую ПСК с помощью трех точек (начала координат и направлений осей Х\\ К);
  • — выполняет поворот текущей ПСК вокруг оси Х\
  • — выполняет поворот текущей ПСК вокруг оси Y;
  • — выполняет поворот текущей ПСК вокруг оси Z;
  • — применяет текущую ПСК к выбранному видовому экрану.

Панель UCS II (ПСК-2) (см. рис. 9.11), помимо раскрывающегося списка именованных систем координат, содержит две кнопки, первая из которых вошла в панель UCS (ПСК), а вторая ( [image] ) позволяет перенести начало текущей ПСК в другую точку, не меняя направления осей координат. Кнопка [image] связана не с командой UCS (ПСК), а с командой UCSMAN (ДИСПСК), которая открывает диалоговое окно UCS (ПСК) (рис. 9.15).

Рис. 9.15. Диалоговое окно DCS, вкладка Named UCSs

Диалоговое окно имеет три вкладки: Named UCSs (Именованные ПСК), Orthographic UCSs (Ортогональные ПСК) и Settings (Режимы). Вкладка Named UCSs (Именованные ПСК) позволяет видеть список именованных ПСК и устанавливать любую из них с помощью кнопки Set Current (Установить). Кнопка Details (Подробности) открывает диалоговое окно UCS Details (Подробности о ПСК) с характеристиками отмеченной ПСК (рис. 9.16).
Вкладка Orthographic UCSs (Ортогональные ПСК) (рис. 9.17) предназначена для работы с основными ортогональными ПСК. Задание параметра Depth (Глубина) позволяет дополнительно переместить плоскость текущей ортогональной ПСК вдоль оси Z Для того чтобы изменить параметр глубины, нужно либо дважды щелкнуть по колонке Depth (Глубина), либо вызвать правой кнопкой контекстное меню, в котором выбрать пункт Depth (Глубина), после чего появится диалоговое окно Orthographic UCS depth (Глубина ортогональной ПСК) (рис. 9.18), в котором можно задать новую глубину.

Рис. 9.16. Диалоговое окно UCS Details

Рис. 9.17.Диалоговое окно DCS, вкладка Orthographic UCSs

Рис. 9.18. Диалоговое окно Orthographic UCS depth

Вкладка Settings (Режимы) диалогового окна UCS (ПСК) (рис. 9.19) имеет две области.
В области UCS Icon settings (Режимы пиктограммы ПСК) находятся три флажка:

  • On (Вкл) — включает пиктограмму ПСК;
  • Display at UCS origin point (В начале ПСК) — переносит пиктограмму из левого нижнего угла графического экрана в точку начала координат (если точка 0,0,0 видна в этом экране);
  • Apply to all active viewports (Для всех активных ВЭкранов) — распространяет установки режимов пиктограммы ПСК на все видовые экраны.

Рис. 9.19. Диалоговое окно UCS, вкладка Settings

Область UCS settings (Режимы ПСК) содержит два флажка:

  • Save UCS with viewport (Сохранять ПСК с ВЭкраном) — сохраняет индивидуальную ПСК для каждого видового экрана;
  • Update view to Plan when UCS is changed (Вид в плане при смене ПСК) — автоматически устанавливает вид перпендикулярно плоскости XY текущей ПСК.

О делении графического экрана на видовые экраны см. разд. 9.2.


9.2. Виды и видовые экраны

Работая с моделью трехмерного объекта, можно задавать и менять виды, делить графический экран на части, в каждой из которых можно устанавливать свою точку зрения или проекцию.


9.2.1. Общий вид

Для удобства отображения сложного чертежа или модели полезно вывести на экран окно, называемое Aerial View (Общий вид). Тогда на основном экране может устанавливаться один вид, а в дополнительном окне — другой (например, вид всего рисунка). На рис. 9.20 показано окно Aerial View (Общий вид), в котором установлено окно по границам всего рисунка, а внутри него рамкой показаны границы того вида, который находится в основном графическом экране.

Рис. 9.20. Окно Aerial View

Вызов этого окна может быть выполнен с помощью команды DSVIEWER (ГЛАЗ) или пункта Aerial View (Общий вид) падающего меню View (Вид). Возможно также выполнять зумирование большого окна через маленькое. Для этого нужно щелкнуть мышью внутри окна Aerial View (Общий вид), которое переходит в режим динамического зумирования (см. опцию Dynamic (Динамика) команды ZOOM (ПОКАЗАТЬ), описанную в разд. 2.4). Выполняемое зумирование отражается на основном графическом экране.
Закрыть окно Aerial View (Общий вид) можно либо с помощью стандартной кнопки [image] закрытия окон Windows, либо с помощью того же пункта Aerial View (Общий вид) падающего меню Вид (View).


9.2.2. Конфигурации видовых экранов

Система AutoCAD позволяет в пространстве модели создавать конфигурации из любого количества частей (неперекрывающихся видовых экранов) и каждой такой конфигурации присваивать имя, по которому такая конфигурация может быть в любое время восстановлена. Команда VPORTS (ВЭ-КРАН), которой соответствуют также кнопка [image] панели Viewports (Видовые экраны) (рис. 9.21) и пункт падающего меню View | Viewports | New Viewports (Вид | Видовые экраны | Новые ВЭ), создает конфигурации видовых экранов.

Рис. 9.21. Панель инструментов Viewports

Команда VPORTS (ВЭКРАН) открывает диалоговое окно Viewports (Видовые экраны) (рис. 9.22).

Рис. 9.22. Диалоговое окно Viewports, вкладка New Viewports

Поле New name (Новое имя) этого окна предназначено для задания имени создаваемой конфигурации видовых экранов. Вводимое имя удовлетворяет обычным ограничениям, налагаемым на имена таких символов AutoCAD, как слои, описания блоков, типы линий и др. Если имя не задать, то новая конфигурация экранов создается (графический экран делится на необходимые части), но не сохраняется (т. е. после перехода к следующей конфигурации данная конфигурация не может быть восстановлена, т. к. она не имеет имени).
В области Preview (Образец) отображается внешний вид той конфигурации (варианта деления на части), которая отмечена в списке Standard viewports (Стандартные конфигурации). В раскрывающемся списке Apply to (Применить) можно выбрать одно из двух значений, указывающих, к какой части графического экрана будет применяться операция деления на части:

  • Display (Ко всему экрану);
  • Current Viewport (К текущему ВЭкрану).

В раскрывающемся списке Setup (Режим) пользователю доступны только два значения:

  • 2D — текущий вид (т. е. вид, установленный в активном видовом экране, который делится на части) распространяется на все новые видовые экраны;
  • 3D — текущий вид устанавливается в одном из создаваемых видовых экранов, а в остальных система AutoCAD выбирает соответствующие ортогональные виды.

В раскрывающемся списке Change view to (Сменить вид на) задается вид, который необходимо установить в видовом экране, отмеченном в области Preview (Образец) (доступны стандартные имена ортогональных и изометрических видов и имя *Current* (Текущий*)). Отметка нужного экрана выполняется щелчком мыши.
Выберите в списке Standard viewports (Стандартные конфигурации) конфигурацию Three: Above (Три: выше), в раскрывающемся списке Setup (Режим) установите 3D, а в раскрывающемся списке Change view to (Сменить вид на) — SE Isometric (ЮВ изометрию). В качестве имени введите, например, КонфЗ и закройте диалоговое окно кнопкой ОК. Графический экран разделится на три части (рис. 9.23).
Из трех образовавшихся видовых экранов только один является активным — это тот экран, в котором указатель мыши имеет вид перекрестия, а не стрелки (активный экран имеет еще и чуть более жирную рамку). В нашем случае активным стал верхний видовой экран. Если вам нужно активизировать другой экран, просто щелкните по нему с помощью левой кнопки мыши.

Рис. 9.23. Задание конфигурации неперекрывающихся видовых экранов

Если вы захотите вернуться к одноэкранной конфигурации, то активизируйте тот видовой экран, вид из которого вы хотите оставить, и командой VPORTS (ВЭКРАН) откройте диалоговое окно Viewports (Видовые экраны). Во вкладке New Viewports (Новые ВЭкраны) (см. рис. 9.22) в списке Standard viewports (Стандартные конфигурации) выберите конфигурацию Single (Один), а в раскрывающемся списке Apply to (Применить) установите Display (Ко всему экрану). Другая возможность перейти к одному экрану — щелкнуть по кнопке [image] панели инструментов Viewports (Видовые экраны) (см. рис. 9.21).
Вкладка Named Viewports (Именованные ВЭкраны) (рис. 9.24) диалогового окна Viewports (Видовые экраны) позволяет вам выбрать конфигурацию видовых экранов из тех, которые ранее в вашем рисунке были сохранены с теми или иными именами.
Каждый из созданных видовых экранов можно разделить на 1, 2, 3 или 4 части. Для этого используются вкладка New Viewports (Новые ВЭкраны) диалогового окна Viewports (Видовые экраны) или пункты падающего меню View | Viewports | 1 Viewport—4 Viewports (Вид Видовые экраны 1 ВЭкран— 4 ВЭкрана).

Рис. 9.24. Диалоговое окно Viewports, вкладка Named Viewports

Смежные видовые экраны можно соединять в один. Например, в нижней части рис. 9.23 можно объединить левый и правый видовые экраны, причем в зависимости от выбора пользователя в объединенном видовом экране будет установлен вид из левого или из правого экранов. Для этого следует воспользоваться пунктом падающего меню View | Viewports | Join (Вид | Видовые экраны | Соединить).


9.2.3. Виды

В видовом экране (или во всем графическом экране, если он не разделен) можно устанавливать вид, задавая в этом экране направление взгляда и масштаб отображения. Виды, как и видовые экраны, могут именоваться и затем восстанавливаться по этим именам. Основными путями для осуществления этого являются команда VIEW (ВИД), а также панель инструментов View (Вид) (рис. 9.25).

Рис. 9.25. Панель инструментов View

На панели инструментов View (Вид) расположены следующие кнопки:

  • — вызывает диалоговое окно View (Вид);
  • 6 кнопок установки стандартных ортогональных видов — [image] (вид сверху), [image] (вид снизу), [image] (вид слева), [image] (вид справа), [image] (вид спереди) и [image] (вид сзади);
  • 4 кнопки установки стандартных изометрических видов — [image] (юго-западная (ЮЗ) изометрия), [image] (юго-восточная (ЮВ) изометрия), [image] (северо-восточная (СВ) изометрия) и [image] (северо-западная (СЗ) изометрия);
  • — задает направление взгляда с помощью точки камеры и точки направления взгляда.

Рассмотрим диалоговое окно View (Вид) (рис. 9.26), открываемое командой VIEW (ВИД) или соответствующей ей кнопкой [image] панели View (Вид).

Рис. 9.26. Диалоговое окно View, вкладка Named Views

Список видов, занимающий большую часть диалогового окна, имеет четыре колонки с параметрами видов текущего рисунка:

  • Name (Имя) — содержит наименование вида;
  • Location (Вкладка) — указывает имя вкладки, к которой привязан вид (у нас пока это только Model (Модель), другие появятся в пространстве листа — см. гл. 10);
  • UCS (ПСК) — содержит имя системы координат, если она сохранена с видом;
  • Perspective (Перспектива) — указывает признак установки обычного или перспективного вида.

Над всеми видами можно выполнять операции удаления, переименования и установки вида текущим. Доступ к этим операциям осуществляется посредством контекстного меню, вызываемого щелчком правой кнопки мыши внутри списка видов. Один из видов в списке обязательно называется Current (Текущий).
Для того чтобы создать новый вид, нужно щелкнуть по кнопке New (Новый), после чего открывается диалоговое окно New View (Новый вид) (рис. 9.27).

Рис. 9.27. Диалоговое окно New View

В этом окне задается имя вида (в поле View name (Имя вида) — например, My_view), определяются размеры вида (весь экран в случае выбора переключателя Current display (Текущий экран) или указываемая рамкой часть экрана в случае выбора переключателя Define window (Задать рамкой)). В области UCS Settings (Режимы ПСК) с помощью раскрывающегося списка UCS name (Имя ПСК) можно выбрать имя ПСК, устанавливаемой вместе с видом (эта возможность доступна, если установить флажок Save UCS with view (Сохранить ПСК с видом)). Следует отметить, что установка точки зрения (т. е. направления взгляда) для сохраняемого вида должна быть сделапа в текущем видовом экране до открытия диалоговых окон New View (Новый вид) и View (Вид).
Кнопка Details (Подробности) диалогового окна View (Вид) (см. рис. 9.26) выводит подробные характеристики вида в диалоговое окно View Details
(Подробности о виде) (рис. 9.28).

Рис. 9.28. Диалоговое окно View Details

Области в верхней части диалогового окна View Details (Подробности о виде) определяют размеры и наклон вида, а также направление взгляда. Области средней части описывают параметры перспективы и параметры передней и задней секущих плоскостей. Секущие плоскости позволяют показывать в виде только ту часть модели, которая находится между передней и задней плоскостями.


9.2.4. Настройка вида

Установка перспективы и секущих плоскостей выполняются командой DVIEW (ДВИД). Первый запрос команды:
Select objects or <use DVIEWBLOCK>: (Выберите объекты или Использовать DVIEWBLOCK>:)
В ответ на запрос нужно указать объекты (несколько из тех. что присутствуют в модели), положение которых в достаточной мере продемонстрирует установку направления взгляда. При нажатии клавиши <Enter> по умолчанию демонстрация выполняется на стандартном блоке в форме домика. Далее:
Enter option [CAmera/TArget/Distance/POints/ PAn/Zoom/TWist/CLip/Hide/Off/ Undo]:
(Задайте опцию [Камера/Цель/Расстояние/Точки/ПАн/ПОказатъ/ ВРащать/ СЕчение/СКрыть/ОТКл/ОТМенить/:)
Опции команды:

  • САrаеrа (Камера) — динамическое указание начальной точки для вектора камера-цель, определяющего направление взгляда;
  • TArget (Цель) — динамическое указание конечной точки для вектора камера-цель, определяющего направление взгляда;
  • Distance (Расстояние) — ввод нового расстояния между камерой и целью, с одновременным включением перспективной проекции (рис. 9.29); шкала от Ох до 1бх в верхней части экрана позволяет увеличивать расстояние до 16 раз от текущего;
  • POints (Точки) — задание точек цели и камеры в координатах;
  • РАn (ПАн) — перемещение вида без увеличения, с помощью двух точек вектора перемещения;
  • Zoom (ПОказать) — задание коэффициента увеличения от 0х до 16х, а также фокусного расстояния при включенной перспективе;
  • TWist (ВРащать) — вращение и наклон вида относительно направления взгляда;
  • CLip (СЕчение) — установка или отключение на виде секущих плоскостей;
  • Hide (СКрыть) — подавление скрытых линий для выбранных объектов;
  • Off (ОТКл) — отключает перспективную проекцию; для ее включения следует снова воспользоваться опцией Distance (Расстояние);
  • Undo (ОТМенить) — отмена действия последней операции команды DVIEW (ДВИД).

Указание точки вместо выбора опций работает как указание точки для опции TArget (Цель).
В перспективной проекции пиктограмма ПСК отображается пунктиром (см. рис. 9.29).
Секущие плоскости могут устанавливаться как для обычной, параллельной проекции, так и для перспективной (задание плоскостей может быть выполнено с помощью команды DVIEW (ДВИД) или рассматриваемой далее команды 3DORBIT (3-ОРБИТА)). На рис. 9.30 показан пример вида с установленными секущими плоскостями (скрыты часть линий шпангоутов конструктивной модели судна, изображенной на рис. 9.29; перспективная проекция заменена на обычную — параллельную).
Еще одна интересная возможность управления видом — команда 3DORBIT (3-ОРБИТА), которой соответствуют кнопка [image] панели инструментов 3D Orbit (3M орбита) (рис. 9.31) и пункт 3D Orbit (3M орбита) падающего меню View (Вид).

Рис. 9.29. Перспективная проекция

Рис. 9.30. Установка секущих плоскостей вида

Рис. 9.31. Панель инструментов 3D Orbit

Команда позволяет динамически изменять вид трехмерных объектов с помощью устройства указания. Если в момент вызова команды в рисунке были выбраны какие-то объекты, то в дальнейших манипуляциях установки вида участвуют только они. При отсутствии выбранных объектов динамическое изменение показывает новое положение всех видимых объектов рисунка (хотя при большом объеме рисунка это может происходить медленно).
На период работы команды 3DORBIT (3-ОРБИТА) знак ПСК изменяется на цветной знак трехмерных осей, а на виде появляется орбитальное кольцо (рис. 9.32).

Рис. 9.32. Орбитальное кольцо

Центр орбитального кольца совпадает с центром вида, вокруг которого пользователь может перемешать свою камеру. При движении устройства указания курсор (перекрестие) может принимать разные формы, что влияет на механизм вращения вида.
Если устройство указания находится внутри орбитального кольца, то курсор принимает форму сферы с двумя внешними окружностями-орбитами ( [image] ).
В этом случае нажатие левой кнопки мыши и перемещение курсора внутри кольца вращает вид вокруг точки цели. Вращение возможно во всех направлениях.
Если курсор находится вне орбитального кольца, он выглядит как сфера с внешней окружностью-стрелкой ( [image] ). В этом случае нажатие левой кнопки мыши и перемещение курсора вне кольца вращает вид вокруг оси, проходящей через центр орбитального кольца перпендикулярно экрану.
Если курсор находится на левом или правом малом кругах, расположенных в точках левого и правого квадрантов орбитального кольца, то он принимает форму сферы с горизонтальным эллипсом-стрелкой ( [image] ). Нажатие левой кнопки мыши и перемещение курсора из этих точек вызывает вращение вида относительно вертикальной оси, расположенной в плоскости орбитального кольца и проходящей через его центр.
Если курсор находится на верхнем или нижнем малом кругах (квадрантах) орбитального кольца, он имеет форму маленькой сферы с вертикальным эллипсом-стрелкой ( [image] ). Нажатие левой кнопки мыши и перемещение курсора из этих точек вызывает вращение вида относительно горизонтальной оси, расположенной в плоскости кольца и проходящей через его центр.
Выход из команды 3DORBIT (3-ОРБИТА) — нажатие клавиш <Esc> или <Enter>. Во время работы команды можно воспользоваться контекстным меню, вызываемым нажатием правой кнопкой мыши (рис. 9.33).

Рис. 9.33. Контекстное меню команды 3DORBIT

Перечислим пункты этого меню:

  • Pan (Панорамирование) — перемещение вида с сохранением расстояния до рассматриваемых объектов;
  • Zoom (Зумирование) — изменение фокусного расстояния при рассмотрении объектов, что приближает их к наблюдателю или отдаляет от него;
  • Orbit (Орбита) — возврат в стандартный режим трехмерной орбиты после зумирования, панорамирования или вращения вида;
  • More (Другие опции) — возможны опции: Adjust Distance (Регулировка расстояния), Swivel Camera (Повернуть камеру), Continuous Orbit (Вращение по орбите), Zoom Window (Показать рамкой), Zoom Extents (Показать в границах). Orbit Maintains Z (Орбита с сохранением Z), Orbit uses Auto Target (Орбита с автоприцелом), Adjust Clipping Planes (Регулировка секущих плоскостей), Front Clipping On (Передняя плоскость Вкл) и Back Clipping On (Задняя плоскость Вкл):
  • Projection (Проекция) — выбор режима проецирования: Parallel (Параллельная) или Perspective (Перспективная);
  • Shading Modes (Раскрашивание) — установка режима раскрашивания объектов: Wireframe (Каркас), Hidden (Скрытие линий), Flat Shaded (Плоское), Gouraud Shaded (По Гуро), Flat Shaded, Edges On (Плоское, с кромками) и Gouraud Shaded. Edges On (По Гуро. с кромками):
  • Visual Aids (Средства визуализации) — возможны следующие опции: Compass (Компас), Grid (Сетка) и UCS Icon (Пиктограмма ПСК);
  • Reset View (Восстановить вид) — восстановление на экране вида, предшествовавшего орбитальному режиму;
  • Preset Views (Стандартные виды) — установка одного из шести стандартных ортогональных или четырех изометрических видов модели;
  • Saved Views (Сохраненные виды) — выбор именованного вида (этот пункт появляется только при наличии в рисунке сохраненных именованных видов).

Большая часть этих опций соответствует операциям, выполняемым другими командами (например, командой DVIEW (ДВИД)) и рассмотренным выше. Остановимся на новых моментах.
Опция Continuous Orbit (Вращение по орбите) пункта More (Другие опции) контекстного меню позволяет перевести рисунок в режим постоянного вращения (для этого движением мыши с нажатой левой кнопкой надо указать направление вращения и отпустить кнопку). Щелчок левой кнопкой останавливает постоянное вращение.
Опции пункта Visual Aids (Средства визуализации) контекстного меню команды 3DORBIT (3-ОРБИТА) предназначены для вывода средств, облегчающих рассмотрение вида и ориентацию расположенных в нем объектов. Опция Compass (Компас) изображает точками на экране три окружности, имитирующие три основные плоскости (AY, YZи XZ). Установка опции Grid (Сетка) выводит клетчатую сетку, соответствующую сетке в зоне лимитов плоскости AT текущей ПСК. Опция UCS Icon (Пиктограмма ПСК) изображает цветную трехмерную пиктограмму системы координат: ось X имеет красный цвет, ось Y— зеленый, ocbZ— синий (или голубой). На рис. 9.34 отображены все средства визуализации одновременно.

Рис. 9.34. Средства визуализации орбитального режима

Пункт меню Shading Modes (Раскрашивание) с помощью шести опций задает вариант раскраски объектов рисунка в процессе их вращения:

  • Wireframe (Каркас) — объекты изображаются в виде совокупности отрезков и линий (кромок граней и тел), раскрашивание отсутствует;
  • Hidden (Скрытие линий) — то же, что и Wireframe (Каркас), но линии невидимых задних граней не отображаются;
  • Flat Shaded (Плоское) — грани раскрашиваются цветом, но с низкой плавностью раскраски;
  • Gouraud Shaded (По Гуро) — грани раскрашиваются цветом; переходы граней сглаживаются с помощью оттенков; плавность раскраски в этом случае выше, чем в предыдущей опции;
  • Flat Shaded, Edges On (Плоское, с кромками) — комбинируются опции Wireframe (Каркас) и Flat Shaded (Плоское) (при раскрашивании линии каркасов просвечивают);
  • Gouraud Shaded, Edges On (По Гуро, с кромками) — комбинируются опции Wireframe (Каркас) и Gouraud Shaded (По Гуро).

На рис. 9.35 приведен пример орбитального режима с раскраской.

Рис. 9.35. Раскрашивание в орбитальном режиме

Кнопки, аналогичные большей части пунктов контекстного меню команды 3DORBIT (3-ОРБИТА), собраны в панели инструментов 3D Orbit (ЗМ орбита) (см. рис. 9.31). Перечислим кнопки этой панели и соответствующие им команды:

  • — 3DPAN (3-ПАН), панорамирование в пространстве;
  • — 3DZOOM (3-ПОКАЗАТЬ), зумирование в пространстве;
  • — 3DORBIT (3-ОРБИТА), возврат в режим орбиты после панорамирования или зумирования;
  • — 3DCORBIT (3-ПОРБИТА), переход к постоянному вращению;
  • — 3DSWIVEL (3-ШАРНИР), поворот вида;
  • — 3DDISTANCE (3-РАССТ), изменение фокусного расстояния;
  • — 3DCLIP (3-СЕКПЛ), регулировка положения секущих плоскостей;
  • — включение или выключение режима действия передней секущей плоскости;
  • — включение или выключение режима действия задней секущей плоскости.

Последние две кнопки являются частным случаем команды DV1EW (ДВИД) (опция Clip (СЕчение)). Раскрывающийся список в правой части панели инструментов 3D Orbit (ЗМ орбита) (см. рис. 9.31) позволяет устанавливать именованные виды.
Команда 3DCLIP (3-СЕКПЛ) вызывает окно Adjust Clipping Planes (Регулировка секущих плоскостей) (рис. 9.36) и позволяет задать положение передней и задней секущих плоскостей.

Рис. 9.36. Окно Adjust Clipping Planes

В данном окне отображается вид сверху (относительно текущего вида) и текущее положение секущих плоскостей указывается двумя горизонтальными линиями (черная линия, на рисунке она нижняя, соответствует передней плоскости, зеленая, на рисунке она верхняя, — задней). Линии положения плоскостей можно перемещать, "захватывая" их с помощью левой кнопки мыши. В верхней части окна расположены следующие кнопки:

  • — переход в режим регулировки передней секущей плоскости (в этом режиме можно менять положение только передней плоскости);
  • — переход в режим регулировки задней плоскости (в этом режиме можно менять положение только задней плоскости);
  • — переход в режим одновременного изменения положения обеих плоскостей (при фиксированном расстоянии между ними);
  • — включение передней плоскости;
  • — включение задней плоскости.

После задания положения обеих секущих плоскостей их действие проявляется только при включении двух последних кнопок. На рис. 9.36 видно, как плоскости отсекают части объектов рисунка. При изменении или вращении вида секущие плоскости остаются всегда параллельными плоскости экрана, поэтому при задании непрерывного вращения (с помощью команд 3DCORBIT (3-ПОРБИТА) или 3DORBIT (3-ОРБИТА)) возникает эффект постепенного исчезновения или появления объектов.
Команда PLAN (ПЛАН) дает возможность установить вид по нужной ПСК:
Enter an option [Current ucs/Ucs/World] <Current>: (Задайте опцию /Текущая/Пек/Мир j <Текущая>:)
Три опции данной команды позволяют соответственно устанавливать вид по текущей ПСК, именованной ПСК или МСК. Текущая ПСК при этом остается прежней.
Еще одна возможность установить нестандартный вид (направление взгляда) — команда VPOINT (ТЗРЕНИЯ). Эта команда выдает запрос:
*** Switching to the WCS *** Current view direction: VIEWDIR= ...
Specify a view point or [Rotate] <display compass and tripod>:
(*** Переключение в МСК *** Текущее направление взгляда: VIEWDIR— ...
Задайте точку зрения или [Повернуть] <компас и тройка осей>:)
Если в ответ на запрос указать точку, то она аналогично точке положения камеры в команде DVIEW (ДВИД) задаст направление взгляда. Если выбрать опцию Rotate (Повернуть), то будут запрошены углы установки направления взгляда: сначала угол в плоскости XY относительно оси X, а затем угол относительно плоскости XY.
Опция, предлагаемая по умолчанию, вызывает условную схему с компасом и тройкой осей (рис. 9.37).
В правом верхнем углу высвечивается двумерное изображение глобуса, причем центр глобуса соответствует северному полюсу, внутренняя окружность — экватору, а внешняя окружность — южному полюсу. При движении маленького перекрестия по глобусу тройка осей отражает соответствующую текущему положению перекрестия точку зрения (направление взгляда).

Рис. 9.37. Задание точки зрения с помощью компаса и тройки осей


9.3. Трехмерные полилинии

Особым трехмерным объектом является трехмерная полилиния, которая состоит из связанных прямолинейных сегментов, но вершины сегментов могут иметь любые координаты трехмерного пространства. Трехмерная полилиния, в отличие от двумерной, не лежит, как правило, в единой плоскости трехмерного пространства и строится с помощью команды 3DPOLY (3-ПЛИНИЯ). Первый запрос этой команды:
Specify start point of polyline: (Начальная точка полилинии:)
Нужно указать трехмерную точку, которая станет начальной точкой полилинии. Далее выдается повторяющийся запрос:
Specify endpoint of line or [Undo]: (Конечная точка сегмента или [Отменить/:)
После указания третьей точки форма запроса немного меняется, т. к. добавляется опция замыкания:
Specify endpoint of line or [Close/Undo]: (Конечная точка сегмента win {Замкнуть/Отменить]:)
Завершается ввод точек либо нажатием клавиши <Enter>, либо опцией Close (Замкнуть).
Для редактирования трехмерных полилиний используется та же команда PEDIT (ПОЛРЕД), что и для двумерных полилиний. Но запрос опций редактирования для трехмерной линии несколько беднее:
Enter an option [Close/Edit vertex/Spline curve/Decurve/Undo/eXit]:
(Задайте опцию [Замкнуть/Вершина/СПлайн/Убратъ сглаживание/Отменить]:)
Перечисленные опции похожи на опции редактирования двумерных полилиний, которые рассмотрены в разд. 3.3. На рис. 9.38 и 9.39 приведен пример трехмерной полилинии до и после сглаживания трехмерным сплайном.

Рис. 9.38. Трехмерная полилиния

Рис. 9.39. Сглаживание трехмерной полилинии сплайном

Рассмотренная в гл. 2 команда SPLINE (СПЛАЙН) допускает использование трехмерных точек. В результате строится трехмерный сплайн.


9.4. Тонирование

Для реалистического представления трехмерных моделей в системе AutoCAD предусмотрено несколько операций. В разд. 9.1 мы уже познакомились с командой HIDE (СКРЫТЬ). В команде DVIEW (ДВИД) тоже предусмотрена опция для скрытия невидимых линий.
Команда 3DORBIT (3-ОРБИТА), приведенная в предыдущем разделе, позволяла пользоваться раскрашиванием объектов. Аналогичные возможности предоставляет пункт Shade (Раскрашивание) падающего меню View (Вид). Все виды раскрашивания собраны также как кнопки в панели инструментов Shade (Раскрашивание) (рис. 9.40). Эти кнопки являются опциями команды SHADEMODE (РЕЖИМРАСКР).

Рис. 9.40. Панель инструментов Shade

Более интересной возможностью получения реалистических изображений трехмерных объектов является операция тонирования. Тонирование дает возможность помимо обычного удаленного источника освещения, лучи которого направлены перпендикулярно экрану, использовать и другие — точечные и прожекторы. Поверхностям объектов можно назначать свойства материалов. В качестве специальных эффектов возможны туман и фон (в том числе из готового растрового изображения). Операции тонирования появились в системе после интеграции AutoCAD с существовавшим ранее пакетом Auto Vision.
Важно отметить, что в рассматриваемой версии системы AutoCAD раскрашенные и тонированные виды могут выводиться на печать (в AutoCAD 2002 и более ранних версиях это было невозможно).
Все команды тонирования собраны в пункте Render (Тонирование) падающего меню View (Вид), а также в одноименной панели инструментов Render (Тонирование) (рис. 9.41).

Рис. 9.41. Панель инструментов Render

Эта панель имеет следующие кнопки (здесь же приведем имена соответствующих команд системы AutoCAD):

  • — изображение трехмерной модели с подавлением скрытых линий (команда HIDE (СКРЫТЬ));
  • — выполнение реалистичного тонированного изображения трехмерной модели (команда RENDER (ТОНИРОВАТЬ));
  • — управление сценами (сцена — совокупность вида и источников освещения) в пространстве модели (команда SCENE (СЦЕНА));
  • — управление источниками освещения (команда СВЕТ (LIGHT));
  • — управление материалами (команда RMAT (МАТЕРИАЛ));
  • — импорт и экспорт материалов (команда MATLIB (БИБМАТ));
  • — наложение текстур (привязка материалов к поверхности, команда SETUV (НАЛТЕК));
  • — задание фона (команда BACKGROUND (ФОН));
  • — управление туманом (команда FOG (ТУМАН));
  • — вставка элементов ландшафта (изображений кустов, деревьев, людей и т. п., команда LSNEW (ЛАНДНОВЫЙ));
  • — редактирование элементов ландшафта (команда LSEDIT (ЛАНД-РЕД));
  • — выполнение работы с библиотекой элементов ландшафта (команда LSLIB (ЛАНДБИБ));
  • — задание режимов тонирования (команда RPREF (РЕЖИМТОН));
  • — вывод статистических данных о тонировании (команда STATS (СТАТ)).

Команда HIDE (СКРЫТЬ), соответствующая первой кнопке панели Render (Тонирование), уже рассмотрена ранее.
Команда RENDER (ТОНИРОВАТЬ), соответствующая второй кнопке, выполняет тонирование, для установок параметров которого открывает диалоговое окно Render (Тонирование) (рис. 9.42).
Расположенная в нижней части окна кнопка Render (Тонирование) закрывает окно и выполняет непосредственное тонирование с текущими настройками.

Рис. 9.42. Диалоговое окно Render


9.4.1. Типы тонирования

В раскрывающемся списке Rendering Type (Тип тонирования) диалогового окна Render (Тонирование) (см. рис. 9.42) следует выбрать алгоритм выполнения — один из трех вариантов: Render (Упрощенное), Photo Real (Фотореалистичное) и Photo Raytrace (Трассировка луча). На рис. 9.43 показан вариант Render (Упрощенное), а на рис. 9.44 и 9.45 соответственно варианты Photo Real (Фотореалистичное) и Photo Raytrace (Трассировка луча). Часто разница между ними трудно определима.

Рис. 9.43. Упрощенное тонирование

Рис. 9.44. Фотореалистичное тонирование

Рис. 9.45. Тонирование методом трассировки луча

В списке Scene to Render (Сцена для тонирования) диалогового окна Render (Тонирование) (см. рис, 9.42) можно осуществить выбор сцены по имени (если имена были заданы) или выбор текущей сцены (о сценах см. разд. 9.4.2). В области Rendering Procedure (Процедура тонирования) расположены три флажка, установка которых определяет процедуру выполнения тонирования:

  • Query for Selections (Выбирать объекты) — задается прямое указание тонируемых объектов;
  • Crop Window (Задать область тонирования) — выполняется задание области тонирования (флажок доступен только в том случае, если в области Destination (Вывод) из раскрывающегося списка выбран пункт Viewport (Видовой экран)) — см. рис, 9.46;
  • Skip Render Dialog (Без диалога) — задается тонирование всего видового экрана, без диалога.

Рис. 9.46. Задание области тонирования

Поле Light Icon Scale (Масштаб символа источника) диалогового окна Render (Тонирование) (см. рис. 9.42) задает масштаб блока, используемого для обозначения источника света, а поле Smoothing Angle (Угол сглаживания) — максимальное значение угла между гранями, при котором система AutoCAD сглаживает их края (по умолчанию — 45°).
В области Rendering Options (Параметры тонирования) расположены четыре флажка:

  • Smooth Shade (Плавное) — определяет плавный переход между гранями многогранной поверхности (путем смешивания цветов граней);
  • Apply Materials (С материалами) — осуществляет использование присвоенных материалов; при сброшенном же флажке применяется стандартный материал *GLOBAL* ("ГЛОБАЛЬНЫЙ*);
  • Shadows (С тенями) — задает генерацию теней для двух типов тонирования: Photo Real (Фотореалистичное) и Photo Raytrace (Трассировка луча);
  • Render Cache (Кэширование) — указывает на использование кэш-файла для тонирования, что ускоряет повторное выполнение операции тонирования.

В этой же области находится кнопка More Options (Дополнительно), которая, в зависимости от типа, выбранного в списке Rendering Type (Тип тонирования), вызывает окно дополнительных настроек: Render Options (Параметры упрощенного тонирования), Photo Real Render Options (Параметры фотореалистического тонирования) или Photo Raytrace Render Options (Параметры тонирования методом трассировки лучей). Это окно позволяет более точно настроить режимы тонирования, повлиять на плавность тонирования граней, управлять уровнем устранения зазубрин и т. д.
В области Destination (Вывод) с помощью раскрывающегося списка задается одно из трех возможных направлений вывода тонированного изображения:

  • Viewport (Видовой экран) — вывод в видовой экран;
  • Render Window (Окно) — вывод результата в специальное окно Render;
  • File (Файл) — запись в файл.

Кнопка More Options (Дополнительно) этой же области открывает диалоговое окно указания параметров файла, но только в том случае, если в списке опций задан вывод именно в файл.
Область Sub Sampling (Проба) с помощью раскрывающегося списка определяет пробу тонирования на ускоренном варианте: от 1:1 (Best) (лучше качество, но медленнее) до 8:1 (Fastest) (быстрее, но качество хуже). Кнопка Background (Фон) выполняет открытие окна задания фона, а кнопка Fog/Depth Cue (Туман/Затемнение) — диалогового окна задания затемняющих эффектов.
Другие опции будут понятны после рассмотрения оставшихся кнопок панели инструментов Render (Тонирование) (см. рис. 9.41) и соответствующих им команд AutoCAD.


9.4.2. Источники

Команда LIGHT (СВЕТ) и кнопка [image] панели инструментов Render (Тонирование) (см. рис. 9.41) позволяют добавлять к рисунку новые источники освещения, которые могут быть четырех типов: рассеянный свет, удаленный источник, точечный источник и прожектор. Рассеянный свет — это аналог фонового освещения, которое можно либо выключить, либо изменять его интенсивность. Слишком сильный рассеянный свет может совсем размыть контуры тонируемых объектов.
Удаленный источник прямолинейно распространяет свет в одном направлении, и интенсивность света не меняется с расстоянием. Удаленный источник может использоваться, например, для имитации солнечного света.
Точечный источник испускает свет во всех направлениях, и его интенсивность падает с удалением от источника. С помощью точечных источников хорошо имитируются электрические лампы (например, при создании моделей помещений).
Лучи света от прожектора идут в заданном направлении, образуя конус, что создает на освещаемых объектах яркие световые пятна и зоны спада освещенности вокруг световых пятен. Угол конуса, соответствующего световому пятну, должен быть меньше угла полного светового конуса, включающего в себя конус светового пятна и зону спада освещенности. Оба угла (угол полного светового конуса и угол конуса, соответствующего яркому пятну) должны находиться между 0 и 160 градусами.
Все источники света (кроме рассеянного света) отмечаются в рисунке изображениями блоков (рис. 9.47).

Рис. 9.47. Изображения блоков, соответствующих точечному источнику, удаленному источнику и прожектору

Команда LIGHT (СВЕТ) вызывает диалоговое окно Lights (Источники света) (рис. 9.48).

Рис. 9.48. Диалоговое окно Lights

Правая область Ambient Light (Рассеянный свет) этого диалогового окна позволяет настроить интенсивность (шкала Intensity (Интенсивность)) и цвет (область Color (Цвет)) общего рассеянного света.
Слева расположен список Lights (Источники), содержащий список всех именованных источников света данного рисунка. Справа от него находятся кнопки Modify (Изменить), Delete (Удалить) и Select (Выбор), которые позволяют соответственно изменять, удалять и выбирать мышью источник света.
Кнопка New (Новый) служит для создания нового источника света. Но перед тем как на нее нажать, нужно в раскрывающемся списке справа от нее выбрать тип источника: Point Light (Точечный), Distant Light (Удаленный) или Spotlight (Прожектор). Для точечного источника кнопка New (Новый) открывает диалоговое окно New Point Light (Новый точечный источник света) (рис. 9.49).

Рис. 9.49. Диалоговое окно New Point Light

В этом окне в поле Light Name (Имя источника) нужно ввести имя источника света (до 8 символов длиной). Шкала Intensity (Интенсивность) позволяет указать интенсивность нового источника. Размешенная в области Position (Положение) кнопка Show (Показать) выводит на экран координаты создаваемого источника света по умолчанию. Задать реальные координаты точки установки источника можно с помощью кнопки Modify (Изменить), которая временно закрывает диалоговое окно New Point Light (Новый точечный источник света) для того, чтобы пользователь задал положение точки с источником света.
В области Color (Цвет) задается цвет для источника. Цвет можно указать либо комбинацией значений насыщенности трех основных цветов (красного, зеленого и синего) или выбрать его из палитры (кнопка Select Color (Выбрать из палитры)), либо выбрать из стандартного окна индекса цветов AutoCAD (кнопка Select Indexed (Выбор из ИЦА)).
Группа переключателей Attenuation (Спад) определяет, как будет уменьшаться интенсивность с увеличением расстояния. Возможны три варианта:

  • None (Нет) — спада интенсивности нет, т. е. источник одинаково освещает и ближние, и дальние объекты:
  • Inverse Linear (Линейная инверсия) — уменьшение интенсивности происходит пропорционатьно расстоянию от источника;
  • Inverse Square (Квадратичная инверсия) — спад интенсивности пропорционален квадрату расстояния.

В области Shadows (Тени) можно установить флажок Shadow On (Включить), после чего при тонировании добавляются тени от объектов. Характеристики теней управляются с помощью кнопки Shadow Options (Параметры теней), открывающей одноименное диалоговое окно Shadow Options (Параметры теней) (рис. 9.50).

Рис. 9.50. Диалоговое окно Shadow Options

Установленный флажок Shadow Volumes/Ray Traced Shadows (Объемные тени/Тени трассировки луча) этого диалогового окна указывает системе, что для фотореалистичного тонирования нужно генерировать объемные тени, а для тонирования методом трассировки луча — лучевые тени. Остальные параметры при этом пользователю недоступны.
При сбросе флажка Shadow Volumes/Ray Traced Shadows (Объемные тени/Тени трассировки луча) становятся доступными следующие два поля:

  • Shadow Map Size (Размер карты теней) — задает размер стороны карты теней (в пикселах, допустимые значения — от 64 до 4096); чем больше размер, тем точнее получаются тени, но тем дольше они рассчитываются;
  • Shadow Softness (Мягкость теней) — задает коэффициент мягкости теневых переходов, принимает значения от 1 до 10, но лучшие результаты достигаются в диапазоне от 2 до 4.

Помимо этих двух полей становится доступной кнопка Shadow Bounding Objects (Тени от ограничивающего объект параллелепипеда), которая предлагает выбрать объекты, ограничивающий параллелепипед которых используется для подрезки карт теней.
На рис. 9.51 показан результат тонирования цилиндрического объекта при двух точечных источниках, установленных внутри прямоугольных ящиков.
После закрытия диалогового окна New Point Light (Новый точечный источник света) возвращаемся в диалоговое окно Lights (Источники света) (см. рис. 9.48). В качестве нового источника в раскрывающимся списке можно выбрать Distant Light (Удаленный). Тогда при нажатии кнопки New (Новый) открывается диалоговое окно New Distant Light (Новый удаленный источник света) (рис. 9.52).

Рис. 9.51. Тонирование в условиях двух точечных источников

Рис. 9.52. Диалоговое окно New Distant Light

Поля Light Name (Имя источника). Intensity (Интенсивность) и области Color (Цвет) и Shadows (Тени) идентичны одноименным полям и областям уже рассмотренного диалогового окна New Point Light (Новый точечный источник света). Кнопка Sun Angle Calculator (Положение солнца) вызывает открытие диалогового окна Sun Angle Calculator (Положение солнца) (рис. 9.53), в котором можно выяснить положение солнца в определенное время конкретного географического места.

Рис. 9.53. Диалоговое окно Sun Angle Calculator

В этом окне кнопка Geographic Location (Географическое положение) позволит в свою очередь открыть диалоговое окно Geographic Location (Географическое положение) (рис. 9.54) для определения широты и долготы нужной местности с использованием карты и списка городов. Вычисленные значения автоматически передаются в предыдущее окно.

Рис. 9.54. Диалоговое окно Geographic Location

Поля Azimuth (Азимут) и Altitude (Возвышение) диалогового окна New Distant Light (Новый удаленный источник света) (см. рис. 9-52) задают положение удаленного источника в географических координатах. Область Light Source Vector (Направление луча) позволяет отобразить или ввести координаты вектора источника света.
Если в диалоговом окне Lights (Источники света) (см. рис. 9.48) в качестве нового источника в раскрывающемся списке выбрать Spotlight (Прожектор), то при нажатии кнопки New (Новый) открывается диалоговое окно New Spotlight (Новый прожектор) (рис. 9.55).

Рис. 9.55. Диалоговое окно New Spotlight

Данное окно в большей своей части нам уже знакомо по аналогичным окнам для точечного и удаленного источников света (см. рис. 9.49 и 9.52). Новыми являются поля Hotspot (Яркое пятно) и Falloff (Полный конус). Как уже было сказано выше, яркое пятно является основной частью полного конуса, образуемого лучом прожектора. Поэтому величина, указываемая для яркого пятна в градусах, не должна превышать величины, заданной для полного конуса. По умолчанию величина яркого пятна равна 44°, а полного конуса — 45°. В любом случае обе величины должны лежать в диапазоне от 0° до 160°.
В диалоговом окне Lights (Источники света) (см. рис. 9.48) осталась нерассмотренной лишь одна кнопка North Location (Направление на север). Эта кнопка позволяет определить направление на север для любой именованной ПСК, используемой вами. При нажатии кнопки открывается одноименное диалоговое окно North Location (Направление на север) (рис. 9.56), в котором можно задать угол требуемого направления.

Рис. 9.56. Диалоговое окно North Location


9.4.3. Сцены

Команда SCENE (СЦЕНА) и кнопка [image] панели инструментов Render (Тонирование) открывают диалоговое окно Scenes (Сцены) (рис. 9.57), которое управляет именованными сценами текущего рисунка.

Рис. 9.57. Диалоговое окно Scenes

Понятие сцены включает в себя вид и источники света. В левой части окна Scenes (Сцены) находится перечень именованных сцен. Если сцены не задавались, то список Scenes (Сцены) содержит только строку *NONE* (*HET*), которая соответствует текущей сцене, состоящей из текущего вида и всех источников света.
Кнопки Modify (Изменить) и Delete (Удалить) позволяют соответственно изменить или удалить выбранную сцену рисунка. Кнопка New (Новый) вызывает диалоговое окно New Scene (Новая сцена) (рис. 9.58), предназначенное для формирования новой сцены.

Рис. 9.58. Диалоговое окно New Scene

Для создания новой сцены нужно в этом диалоговом окне в списке Views (Виды) отметить имя одного нужного вам вида, а в списке Lights (Источники) — имена всех необходимых источников света (об источниках освещения речь пойдет далее). Держите нажатой клавишу <Ctrl>, если хотите к уже выбранным источникам добавить еще и другие. В поле Scene Name (Имя сцены) вводится имя, присваиваемое новой сцене.


9.4.4. Материалы

Следующей командой задания настроек тонирования, которая соответствует кнопке [image] панели инструментов Render (Тонирование), является команда RMAT (МАТЕРИАЛ), назначающая материалы построенным объектам. Команда вызывает диалоговое окно Materials (Материалы) (рис. 9.59).

Рис. 9.59. Диалоговое окно Materials

В левой части окна в списке Materials (Материалы) приводится перечень материалов, загруженных в текущий рисунок. Один материал, который называется *GLOBAL* ("ГЛОБАЛЬНЫЙ*), обязательно присутствует в рисунке и присваивается всем объектам, имеющим поверхности, по умолчанию. Все остальные материалы надо импортировать с помощью команды MATLIB (БИБМАТ) или с помощью кнопки [image] панели инструментов Render (Тонирование), которые вызывают диалоговое окно Materials Library (Библиотека материалов) (рис. 9.60).

Рис. 9.60. Диалоговое окно Materials Library

В левой части этого окна в области Current Drawing (Текущий рисунок) также приводится перечень материалов, уже импортированных в текущий рисунок. Этот перечень можно очистить с помощью кнопки Purge (Очистить) или сохранить в виде отдельного файла библиотеки материалов с расширением mli (с помощью кнопки Save As (Сохранить как) области Current Drawing (Текущий рисунок)). В правом верхнем углу в раскрывающемся списке области Current Library (Текущая библиотека) находится имя текущей библиотеки, а под ним выводится список ее материалов. По умолчанию используется стандартная библиотека AutoCAD с именем render.mli (расширение mli обязательно). Если нужно открыть другую библиотеку, то для этого следует воспользоваться кнопкой Open (Открыть).
Если в перечне материалов текущей библиотеки отметить материал и нажать кнопку Preview (Просмотр) в центре диалогового окна, то в поле просмотра вы увидите, как указанный материал будет выглядеть на поверхности объекта. В качестве такого условного объекта могут быть выбраны Sphere (Сфера) или Cube (Куб), которые выбираются из раскрывающегося списка, расположенного под кнопкой Preview (Просмотр). На рис. 9.60 показан просмотр материала 3D CEL ТЕХТМАР на кубе.
Импорт материалов выполняется по следующей схеме. Нужный вам материал отмечается в списке материалов текущей библиотеки материалов и затем с помощью кнопки Import (Импорт) передается в список материалов текущего рисунка. Если вы хотите какой-то из материалов текущего рисунка перенести в текущую библиотеку (когда такого материала в ней нет), то для этого воспользуйтесь кнопкой Export (Экспорт). После экспорта в библиотеку необходимого материала ее можно сохранить с помощью кнопки Save (Сохранить).
Кнопка Delete (Удалить) дает возможность удалить материал из перечня материалов, загруженных в рисунок.
По окончании импорта всех выбранных вами материалов нужно закрыть окно Materials Library (Библиотека материалов) с помощью кнопки ОК. После этого система AutoCAD вновь открывает диалоговое окно Materials (Материалы) (см. рис. 9.59).
В окне Materials (Материалы) также имеется возможность просмотра материала на поверхности сферы или куба с помощью кнопки Preview (Просмотр). Кнопка Modify (Изменить) позволяет для отмеченного материала вызвать диалоговое окно Modify Standard Material (Изменение стандартного материала) (рис. 9.61) и поменять для него те или иные характеристики.

Рис. 9.61. Диалоговое окно Modify Standard Material

Рассмотрим наиболее важные параметры этого окна. В области Attributes (Параметры) расположены семь переключателей:

  • Color/Pattern (Цвет/Текстура) — осуществляется настройка основного цвета материала (диффузное отражение); управляется полем Value (Значение) и областью Color (Цвет);
  • Ambient (Рассеяние) — выполняется настройка цвета, отражаемого поверхностью при освещении ее рассеянным светом; управляется полем Value (Значение) и областью Color (Цвет);
  • Reflection (Отражение) — осуществляется настройка цвета бликов на отражающей поверхности; управляется полем Value (Значение) и областью Color (Цвет);
  • Roughness (Шероховатость) — выполняется настройка степени шероховатости (блики меньше на более гладкой поверхности);
  • Transparency (Прозрачность) — выполняется настройка прозрачности; управляется полем Value (Значение); в поле File Name (Имя файла) можно задать имя файла текстуры;
  • Refraction (Преломление) — осуществляется настройка степени преломления лучей при отражении (только при тонировании методом трассировки лучей); управляется полем Value (Значение);
  • Bump Map (Выдавливание) — выполняется имитация эффекта выдавливания; имя файла текстуры задается в поле File Name (Имя файла).

Кнопка Duplicate (Копировать) диалогового окна Materials (Материалы) (см. рис. 9.59) копирует отмеченный материал для создания на его основе нового материала. Кнопка New (Новый) вызывает специальное окно для описания характеристик нового материала.
Каждый материал может иметь один из четырех типов, который устанавливается в раскрывающемся списке под кнопкой New (Новый): Standard (Стандартный), Granite (Гранит), Marble (Мрамор), Wood (Дерево). В отличие от стандартного, каждый из оставшихся трех типов привносит свои оттенки (гранита, мрамора или дерева). В случае установки типа, не являющегося стандартным, диалоговое окно Modify Standard Material (Изменение стандартного материала) (см. рис. 9.61) меняет свое название (например, для типа Granite (Гранит) окно будет называться Modify Granite Material (Изменение материала Гранит)).
Кнопка Select (Выбор) диалогового окна Materials (Материалы) (см. рис. 9.59) позволяет определять материал, присвоенный ранее объекту рисунка. После нажатия на эту кнопку AutoCAD временно закрывает диалоговое окно Materials (Материалы) и предлагает указать в рисунке объект. Затем снова открывается окно Materials (Материалы), но с отмеченным в списке именем материала того объекта, который вы только что указали.
Для присвоения материала нужно его сначала отметить в списке, а затем нажать кнопку Attach (Присвоить). Система AutoCAD закроет окно Materials (Материалы) и запросит объекты. После указания объектов и нажатия клавиши <Enter> выбранные материалы будут присвоены и AutoCAD снова откроет окно Materials (Материалы) для продолжения работы.
Если необходимо снять присвоенный объекту материал и вернуть значение по умолчанию, то нужно воспользоваться кнопкой Detach (Снять).
Есть еще две возможности присвоения материала: по цвету и по слою. Кнопка By ACI (По ИЦА) связывает номер цвета в индексе цветов AutoCAD (ИЦА) с материалом, а кнопка By Layer (По слою) связывает с материалом слой.
На рис. 9.62 приведен пример тонирования с использованием материала LITEWOOD SHINGLS. Некоторые материалы могут имитировать эффект прозрачности стекла.

Рис. 9.62. Тонирование с применением материалов

Команда SETUV (НАЛТЕК) и соответствующая ей кнопка [image] панели инструментов Render (Тонирование) позволяют накладывать текстуры с достижением эффектов специального проектирования (цилиндрического, сферического и др.) растровых изображений на поверхность объекта.


9.4.5. Фон и туман

Команда BACKGROUND (ФОН) и кнопка [image] панели инструментов Render (ТОнирование) служат для создания фона при тонировании и при своем выполнении открывают диалоговое окно Background (Фон) (рис. 9.63).
В этом окне нужно выбрать тип фона, установив переключатель в одно из четырех положений:

  • Solid (Сплошной) — задает одноцветный фон (может быть и фоном AutoCAD);
  • Gradient (Переход) — определяет переливающийся фон из двух или трех цветов;
  • Image (Изображение) — задает фон из растрового файла;
  • Merge (Слияние) — определяет в качестве фона содержимое видового экрана (возможно только, если в диалоговом окне Render (Тонирование) (см. рис. 9.42) в раскрывающемся списке раздела Destination (Вывод) выбран пункт Viewport (Видовой экран)); в этом случае видны и те объекты, которые при обычном тонировании исчезают.

Рис. 9.63. Диалоговое окно Background

На рис. 9.64 приведен пример тонирования с использованием в качестве фона файла растрового изображения.

Рис. 9.64. Тонирование с фоном

Команда FOG (ТУМАН) и соответствующая ей кнопка [image] панели инструментов Render (Тонирование) позволяют достигать эффектов тумана. Команда вызывает диалоговое окно Fog/Depth Cue (Туман/Затемнение) (рис. 9.65).

Рис. 9.65. Диалоговое окно Fog/Depth Cue

В этом окне, если вам необходимо тонировать с туманом, нужно установить флажок Enable Fog (Включить туман), иначе остальные поля вам будут не доступны. Настройка цвета и интенсивности тумана выполняется соответствующими кнопками диалогового окна.


9.4.6. Элементы ландшафта

Команда LSNEW (ЛАНДНОВЫЙ) и соответствующая ей кнопка [image] панели инструментов Render (Тонирование) дают возможность при тонировании добавлять элементы ландшафта (стандартных изображений кустов, деревьев, людей, знаков). Команда вызывает диалоговое окно Landscape New (Новый ландшафт) (рис. 9.66).
В данном диалоговом окне из списка нужно выбрать имя элемента ландшафта. Кнопка Preview (Просмотр) позволяет просмотреть выбранный элемент. Перед вставкой задаются параметры изображения (область Geometry (Геометрия)) и размеры (поле Height (Высота)).

Рис. 9.66. Диалоговое окно Landscape New

С помощью кнопки Position (Положение) элемент ландшафта располагается на поле рисунка. Вне тонирования вставленные элементы имеют форму треугольника с именем. При тонировании элементы включаются в фон для оживления изображения. На рис. 9.67 показан пример тонирования с элементом ландшафта (кактусом).

Рис. 9.67. Тонирование с элементами ландшафта

Команда LSEDIT (ЛАНДРЕД) дает пользователю возможность изменять параметры вставленного элемента ландшафта, а команда LSLIB (ЛАНД-БИБ) — просматривать, изменять и добавлять элементы, которые сохраняются в библиотеке ландшафтов.


9.4.7. Настройки и статистика

Команда RPREF (РЕЖИМТОН) и кнопка [image] панели инструментов Render (Тонирование) позволяют устанавливать режимы тонирования в диалоговом окне, которое отличаются от диалогового окна Render (Тонирование) (см. рис. 9.42) только тем, что не имеет кнопки Render (Тонирование).
Команда STATS (CTAT) и соответствующая ей кнопка [image] панели инструментов Render (Тонирование) выводят в диалоговое окно Statistics (Статистика) (рис. 9.68) статистические данные о последнем тонировании.

Рис. 9.68. Диалоговое окно Statistics


9.5. Грани и сети

Для того чтобы при тонировании поверхности объектов были непрозрачными, они должны быть созданы специальным образом. Мы уже знаем, что у цилиндра (выдавленного круга) все поверхности в режиме двумерного каркаса являются непрозрачными при скрытии невидимых линий, а вот у выдавленной полилинии в форме прямоугольника непрозрачны только боковые стенки. Сам прямоугольник не является сплошным плоским объектом и фактически имеет только контур, без внутренности.
Для непрозрачных треугольников и четырехугольников в AutoCAD есть специальный объект — грань. Непрерывно расположенные грани могут объединяться в "сеть". Поверхности очень многих трехмерных объектов могут быть представлены в виде сетей. Сеть хотя и является приближенным представлением объекта, но дает достаточно много информации о его форме и размерах. Для примера выберем пункт в падающем меню Draw | Surfaces | 3D Surfaces (Рисование | Поверхности ЗМ поверхности). На экране появится диалоговое окно 3D Objects (ЗМ объекты) (рис. 9.69).

Рис. 9.69. Диалоговое окно 3D Objects

В этом окне доступны 9 объектов (Box3d (ЗМ ящик). Pyramid (Пирамида), Wedge (Клин), Dome (Купол), Sphere (Сфера), Cone (Конус), Torus (Top), Dish (Чаша) и Mesh (Сеть)), которые после задания параметров будут построены в текущем рисунке поверхностями в виде сетей с четырехугольными и треугольными ячейками. Все клетки (ячейки) таких поверхностей непрозрачны для операций скрытия невидимых линий, раскрашивания и тонирования.
В панели инструментов Surfaces (Поверхности) (рис. 9.70) собраны кнопки всех основных операций с гранями и сетями.

Рис. 9.70. Панель инструментов Surfaces

Рассмотрим кнопки этой панели. Первая кнопка [image] вызывает команду рисования плоских четырехугольников SOLID (ФИГУРА), описанную в разд. 2.18.
Команда строит примитивы, называемые SOLID (ФИГУРА). Фигуры обладают дополнительным свойством — они являются непрозрачными, благодаря чему их кнопка включена в панель Surfaces (Поверхности). Фигура является плоским (двумерным) объектом и располагается в плоскости, параллельной плоскости XY текущей системы координат.
Команда 3DFACE (3-ГРАНЬ), которой соответствуют кнопка [image] панели инструментов Surfaces (Поверхности) и пункт падающего меню Draw | Surfaces | 3D Face (Рисование | Поверхность ЗМ грань), строит также четырехугольные примитивы, но они являются уже трехмерными объектами, вершины которых могут не лежать в одной плоскости.
Первый запрос команды 3DFACE (3-ГРАНЬ) выглядит так: Specify first point or [Invisible]: (Первая точка или (Невидимая):)
Если выбрать опцию Invisible (Невидимая), то кромка грани, идущая из первой точки во вторую, будет невидимой (это полезно в трехмерных моделях). После выбора этой опции AutoCAD повторит запрос первой точки. Если задана первая точка, то выводится следующий запрос:
Specify second point or [Invisible]: (Вторая точка или [Невидимая]:)
Здесь выбор опции Invisible (Невидимая) будет означать, что кромка между второй и третьей точками будет невидимой. После ввода второй точки:
Specify third point or [Invisible] <exit>: (Третья точка или [Невидимая] <выход>:)
Если в этот момент нажать клавишу <Enter>, то команда закончит свою работу. Далее после ввода третьей точки:
Specify fourth point or [Invisible] <create three-sided face>: (Четвертая точка или [Невидимая! <создать треугольную грань>:)
В этот момент нажатие клавиши <Enter> создает треугольную грань (т. е. четвертая и третья вершины совпали). А после указания четвертой точки снова выдается запрос о третьей точке (в качестве первой и второй точек следующей грани будут взяты третья и четвертая точки предыдущей). Если неправильно задан обход вершин грани, то грань может получиться перекрученной. В этом случае нужно поменять местами третью и четвертую точки. На рис. 9.71 приведен пример построения граней.
Для наглядности на рисунке еще построен цилиндр и выполнено скрытие невидимых линий. На рисунке видно, что грани являются непрозрачными.
Грани можно редактировать с помощью ручек. Возможны грани, все кромки которых невидимы, однако при скрытии невидимых линий такие грани будут закрывать расположенные под ними объекты.

Рис. 9.71. Пример построения граней

Команда EDGE (КРОМКА), которой соответствует кнопка [image] панели инструментов Surfaces (Поверхности), дает возможность менять видимость кромок граней и сетей. Удобным средством изменения видимости кромок является окно Properties (Свойства).
Восемь кнопок (с 3-й по 10-ю) панели инструментов Surface (Поверхности) (см. рис. 9.70) позволяют строить сети стандартной формы (ящик, клин, пирамида, конус, сфера, купол, чаша, тор) — такие же, что и с помощью диалогового окна 3D Objects (ЗМ объекты) (см. рис. 9.69). Сети — это более сложные объекты, чем грани. Если сеть расчленить с помощью команды EXPLODE (РАСЧЛЕНИТЬ), то она распадется на грани, причем из одной ячейки сети получится одна грань (каждая грань будет иметь одну кромку с соседней гранью).
Все сети стандартной формы строятся относительно текущей плоскости построений, поэтому перед тем как приступить к созданию подобного объекта, не забудьте перейти в необходимую ПСК. Построение восьми стандартных поверхностей может быть выполнено не только с помощью вышеупомянутых восьми кнопок панели инструментов Surfaces (Поверхности), но и при помощи команды 3D (ЗМ), которая строит все эти объекты.
Рассмотрим построение стандартной поверхности на примере прямоугольного параллелепипеда — ящика (построение остальных поверхностей выполняется аналогично). После вызова команды 3D (ЗМ) появляется первый запрос:
Select option [Box/Cone/DIsh/DOme/Mesh/ Pyramid/Sphere/Torus/Wedge]:
(Задайте опцию [Ящик/КОнус/ЧАша/КУпол/СЕть/Пирамида/СФера/Тор/КЛин]:)
Выберите опцию Box (Ящик). Следующий запрос:
Specify comer point of box; (Угловая точка ящика:)
Укажите точку первого угла. Далее:
Specify length of box: (Длина ящика:)
Укажите длину вводом числа или точки. Затем: Specify width of box or [Cube]: (Ширина ящика или {Куб/:)
Нужно ввести ширину числом или точкой либо выбрать опцию Cube (Куб). Если ширина задана, т. е. строящийся ящик не является кубом, то следует дополнительный запрос:
Specify height of box: (Высота ящика:)
Теперь все размеры определены, но можно еще повернуть ящик вокруг оси Z. Следующий запрос:
Specify rotation angle of box about the Z axis or [Reference]: (Угол поворота ящика вокруг оси Z или /Опорный угол]:)
После задания угла строится замкнутая сеть в форме ящика. На рис. 9.72 приведен пример ящика, повернутого на —25° вокруг оси Z (также выполнено скрытие невидимых линий).

Рис. 9.72. Построение стандартной сети в форме ящика

В общем случае сеть — это объект, у которого вдоль одного направления имеется определенное количество точек (М), а вдоль другого направления — другое заданное количество точек (N). Эти направления так и принято называть — М-направление и N-направление. Соответственно общее количество ячеек есть произведение (М - 1) на (N - 1). Сети могут быть незамкнутыми и замкнутыми, причем замыкание может быть по одному или двум направлениям. Сеть, не замкнутая по какому-то направлению, может быть замкнута с помощью команды PEDIT (ПОЛРЕД), т. к. эта команда редактирует не только полилинии, но и сети (которые во внутреннем представлении в системе AutoCAD являются примитивами POLYLINE).
Команда 3DMESH (3-СЕТЬ), которой соответствует кнопка [image] панели инструментов Surfaces (Поверхности), позволяет построить произвольную незамкнутую сеть по координатам точек вершин этой сети.
Первый запрос команды: Mesh M size: (Размер сети в направлении М:)
Введите число от 2 до 256, определяющее размер сети по направлению М (например, 3). Далее:
Mesh N size: (Размер сети в направлении N:)
Введите число от 2 до 256, определяющее размер сети по направлению N (например, 4). Затем выдаются запросы по каждой из 12 вершин сети. Точки по каждому направлению нумеруются от 0 до М — 1 и от 0 до N — 1, соответственно. Система AutoCAD запросит первую вершину:
Vertex (0, 0): (Положение вершины (0, 0):)
Далее по очереди запрашиваются все остальные вершины с номерами (О, 1), (О, 2), (0, 3), (1, 0), (1, 1), (1, 2), (1. 3), (2, 0), (2, 1), (2, 2), (2, 3).
Пример такой сети приведен на рис. 9.73.

Рис. 9.73. Построение сети размером 3x4

На этом рисунке направление Л/ближе к горизонтальной границе экрана, а направление N — к вертикальной.
Четыре последних кнопки панели инструментов Surfaces (Поверхности) представляют собой случаи построения более сложных сетей. Кнопка [image] которой соответствует команда REVSURF (П-ВРАЩ). Команда позволяет получить поверхность, образующуюся в пространстве при вращении линии вокруг отрезка. На рис. 9.74 показан пример сети, полученной как поверхность вращения полилинии вокруг оси МСК (невидимые линии скрыты).
При построении поверхностей вращения размер сети определяется значениями системных переменных SURFTAB1 и SURFTAB2 (о системных переменных см. разд. 11.1). Они определяют количество прямолинейных сегментов, которыми аппроксимируются в обоих направлениях криволинейные участки используемых в построении сетей линий. Стандартные значения этих переменных равны 6. Пример на рис. 9.74 был построен со значениями SURFTAB1 = 12 и SURFTAB2 = 12.

Рис. 9.74. Построение поверхности вращения

Для изменения значения системной переменной используйте команду SETVAR (УСТПЕРЕМ).
Остальные три кнопки панели инструментов Surfaces (Поверхности) выполняют следующие операции:

  • — создает поверхность сдвига, получаемую от движения одной кривой вдоль другой (команда TABSURF (П-СДВИГ));
  • — создает поверхность соединения, возникающую при плавном переходе от одной линии к другой (команда RULESURF (П-СОЕД));
  • — создает поверхность Кунса между четырьмя кромками, образующими замкнутый криволинейный четырехугольник (команда EDGESURF (П-КРОМКА)).

В этих командах также имеют большое значение системные переменные SURFTAB1 и SURFTAB2.


9.6. Области

Область — это двумерный объект, который ограничен замкнутым контуром и имеет внутренность. В области могут присутствовать отверстия. Области можно вычитать и складывать. Они непрозрачны (кроме участков, которые являются отверстиями). Аналогом области является тонкая листовая деталь, в которой могут иметься вырезы. Но самое главное — области могут использоваться для построения тел сложной формы (с помощью выдавливания и вращения), что нам понадобится в следующем разделе.
Любой плоский замкнутый контур (окружность, замкнутую полилинию, отрезки в форме замкнутой ломаной и другие подобные им объекты) можно сделать областью. Для этого используется команда REGION (ОБЛАСТЬ), которой соответствуют кнопка [image] панели инструментов Draw (Рисование) и пункт Region (Область) падающего меню Draw (Рисование).
Команда REGION (ОБЛАСТЬ) запрашивает объекты и по окончании их выбора сообщает о количестве созданных областей. Одной командой может быть создано несколько областей, если указанные пользователем объекты удовлетворяют необходимым требованиям. На рис. 9.75 показаны примеры трех контуров, которые могут быть преобразованы в области. В то же время четыре отрезка в правой части графического экрана не могут быть превращены в область, т. к. не образуют единого замкнутого контура (их нужно предварительно обрезать).

Рис. 9.75. Пример трех областей

Над областями возможны операции объединения, вычитания и пересечения. Кнопки этих операций являются первыми тремя кнопками в панели инструментов Solids Editing (Редактирование тел) (рис. 9.76), поскольку такие же операции разрешаются над телами (см. разд. 9.7).

Рис. 9.76. Панель инструментов Solids Editing

На рис. 9.77 показан пример объединения трех областей в одну (слева — объекты до объединения, справа — новая область). Соответствующие средства системы AutoCAD для объединения областей — это команда UNION (ОБЪЕДИНЕНИЕ) и кнопка [image] панели инструментов Solids Editing (Редактирование тел).

Рис. 9.77. Объединение областей

Из рисунка видно, что области объединяются как плоские множества. Треугольник внутри области справа является отверстием. Область является единым объектом (даже если имеет вырезы или если объединяются непересекающиеся объекты).
На рис. 9.78 приведен пример вычитания областей.

Рис. 9.78. Вычитание областей

Слева показаны три области до вычитания. Справа — результат вычитания (из многоугольной области вычитаются две круговых). Новая область имеет один круглый вырез. Соответствующие средства системы AutoCAD —SUBTRACT (ВЫЧИТАНИЕ) и кнопка [image] панели инструментов Solids Editing (Редактирование тел).
На рис. 9.79 приведен пример пересечения трех областей. Для операции пересечения используется команда INTERSECT (ПЕРЕСЕЧЕНИЕ) и соответствующая ей кнопка [image] панели инструментов Solids Editing (Редактирование тел).

Рис. 9.79. Пересечение областей

Если объединить непересекающиеся области, то образуется область, имеющая многосвязный внешний контур (она подобна блоку при операциях перемещения, копирования и т. п.). Команда EXPLODE (РАСЧЛЕНИТЬ) раскладывает область на простые примитивы (отрезки, дуги, окружности, эллипсы, сплайны).


9.7. Тела

Трехмерные сети, рассмотренные в разд. 9.5, даже если они были замкнутыми по двум направлениям, были объектами без внутренности. Также не имеют внутренности и выдавленные двумерные объекты (например, цилиндр).
Новые объекты, которые рассмотрены в данном разделе, называются телами. Эти объекты имеют внутренность и объем, их можно объединять, вычитать и пересекать как трехмерные множества.
Тела получаются в результате использования команд построения стандартных тел (ящиков, конусов, шаров и т. п.), а также как результат вращения, выдавливания областей. Тела можно разрезать на части и получать сечения плоскостями. Над телами возможны операции специального редактирования.
Для создания в системе AutoCAD твердотельной модели изделия в начале необходимо мысленно разложить его на простые стандартные составляющие. Затем путем логических операций (объединения, вычитания и пересечения), а также операций редактирования создать объект нужной формы.


9.7.1. Построение тел

В панели инструментов Solids (Тела) (рис. 9.80) собраны кнопки операций построения тел. Эти операции изучаются в данном разделе (кроме трех последних кнопок, которые связаны с работой в пространстве листа и рассмотрены в гл. 10).

Рис. 9.80.Панель инструментов Solids

Первые шесть кнопок этой панели предназначены для построения твердотельных объектов стандартной формы. Этим кнопкам соответствуют следующие команды системы AutoCAD: BOX (ЯЩИК), SPHERE (ШАР), CYLINDER (ЦИЛИНДР), CONE (КОНУС), WEDGE (КЛИН) и TORUS (TOP).
С помощью команды BOX (ЯЩИК) построим в МСК твердотельный параллелепипед. Для удобства в предварительно очищенном графическом экране рекомендуется установить в качестве вида юго-западную изометрию.
Первый запрос команды BOX (ЯЩИК):
Specify corner of box or [CEnter]<0,0,0>: (Угол ящика или /Центр/ <0,0,0>:)
Нажмите клавишу <Enter> — это означает, что точка первого угла ящика будет выбрана по умолчанию, т. е. примет текущее значение в начале МСК. Можно ввести и любые другие координаты трехмерной точки. Выбор опции CEnter (Центр) ведет к варианту построения ящика с фиксацией положения не первого угла, а центра параллелепипеда. Следующий запрос:
Specify corner or [Cube/Length]: (Угол или [Куб/Длина]:)
Здесь можно задать точку другого угла ящика. Опция Cube (Куб) ведет к построению куба (параллелепипеда с одинаковыми значениями длины, ширины и высоты). Выберите опцию Length (Длина). Далее система запрашивает длину ребра:
Specify length: (Длина:)
Задайте длину 400. Затем следующий запрос:
Specify width (Ширина:)
Введите ширину 350. И, наконец, последний запрос высоты:
Specify height: (Высота:)
Задайте высоту 200.
Результат построения твердотельного паратлелепипеда (ящика) приведен на рис. 9.81.

Рис. 9.81. Построение твердотельного ящика

Теперь на верхней поверхности ящика построим цилиндр с радиусом 100 мм и высотой 150 мм. Команда CYLINDER (ЦИЛИНДР) запрашивает:
Current wire frame density: ISOLINES=4 Specify center point for base of cylinder or fEllipticalJ <0,0,0>:
(Текущая плотность каркаса: ISOLINES=4 Центральная точка основания цилиндра или [Эллиптический] <0,0,0>:)
Задайте точку 200,175,200. Далее:
Specify radius for base of cylinder or [Diameter]: (Радиус основания цилиндра или [Диаметр]:)
Введите радиус 100.
Specify height of cylinder or [Center of other end]: (Высота цилиндра или [Центр другого основания]:)
Задайте высоту цилиндра 150.
В результате чего на верхней грани ящика будет построен твердотельный цилиндр (рис. 9.82).

Рис. 9.82. Построение твердотельного цилиндра

Обратите внимание на то, что для наглядности система AutoCAD рисует образующие цилиндра, количество которых (четыре) равно текущему значению системной переменной ISOLINES (см. первое сообщение команды CYLINDER (ЦИЛИНДР)). На первый взгляд, количество образующих на рис. 9.82 равно двум, однако это не так, поскольку в данном виде произошло совмещение передних и задних образующих.
Увеличим количество образующих до 28. Для этого необходимо изменить значение системной переменной ISOLINES на 28. Это можно сделать с помощью команды SETVAR (УСТПЕРЕМ), но проще прямо ввести название переменной в командной строке: ISOLINES и нажать клавишу <Enter>. Система AutoCAD выдаст запрос:
New value for ISOLINES <4>: (Новое значение ISOLINES <4>:)
Введите 28 и выполните регенерацию экрана с помощью пункта Regen (Регенерировать) падающего меню View (Вид) или с помощью команды REGEN (РЕГЕН). На рис. 9.83 видно, что количество образующих увеличилось, и мы имеем более точное представление о форме объекта.

Рис. 9.83. Изменение количества образующих для отображения твердотельных объектов

Теперь на ближней к нам правой боковой стенке ящика построим другой ящик, который станет затем углублением. Для начала установим НОВУЮ ПСК по правой боковой грани. Для этого воспользуйтесь кнопкой [image] панели инструментов UCS (ПСК). Система AutoCAD выдаст первый запрос: Select face of solid object: (Выберите грань твердотельного объекта:)
Щелкните мышью по нижнему ребру правой передней стенки ящика. Правая грань подсветится и появится запрос:
Enter an option [Next/Xflip/Yflip] <accept>: (Задайте опцию 1Сменить/обратитьХ/обратитьУ] <принять>:)
Если у вас пиктограмма новой системы координат высветилась в том же виде, как на рис. 9.84, то нажмите клавишу <Enter> в знак согласия с выбранной ПСК.

Рис. 9.84. Установка ПСК по грани тела

Постройте теперь с помощью команды BOX (ЯЩИК) ящик, задав у него первый угол (100,0,0), второй угол — (300,—170,0), а высоту — —250 мм. Внутри основного ящика появится второй (рис. 9.85).

Рис. 9.85. Построение ящика в ПСК, установленной по грани

Теперь с помощью уже известных нам кнопок [image] и [image] , соответствующих командам UNION (ОБЪЕДИНЕНИЕ) и SUBTRACT (ВЫЧИТАНИЕ), объедините большой ящик с цилиндром, а из образовавшегося составного тела вычтите малый ящик. Результат представлен на рис. 9.86 (для наглядности итоговому телу присвоен цвет с номером 255 и выполнено раскрашивание по Гуро).

Рис. 9.86. Объединение и вычитание тел

Рассмотренные в гл. 3 команды CHAMFER (ФАСКА) и FILLET (СОПРЯЖЕНИЕ) применимы и к телам, для снятия фаски между соседними гранями и сопряжения двух граней. На рис. 9.87 приведен результат снятия фаски 40 х 40 у верхней цилиндрической части и сопряжения двух пар боковых граней в левой части тела с радиусом 75 (для удобства текущий вид несколько изменен).

Рис. 9.87. Построение фаски и сопряжения граней тела

Тела можно строить методом выдавливания или вращения областей. Эти операции выполняются с помощью кнопок [image] и [image] панели инструментов Тела (Solids) (см. рис. 9.80). Данные кнопки соответствуют командам EXTRUDE (ВЫДАВИТЬ) и REVOLVE (ВРАЩАТЬ).
В качестве примера рассмотрим построение участка твердотельной трубы с помощью команды EXTRUDE (ВЫДАВИТЬ).
Установим на пустом экране в качестве вида юго-западную изометрию. Построим два круга с центрами в начале координат и радиусами 100 и 80.
Преобразуем их в области. Из большой области вычтем малую и получим область в форме кольца (рис. 9.88).

Рис. 9.88. Построение области в форме кольца

На рисунке показана также будущая траектория выдавливания. Для ее построения с помощью кнопки [image] панели инструментов UCS (ПСК) повернем оси на У1Г (до вертикального положения). В новой системе координат построим полилинию из трех сегментов: первый из них является прямолинейным с вершинами в точках с координатами (0,0) и (0,500), второй сегмент — дуговой, касающийся первого и заканчивающийся в точке (100,600), а третий сегмент — снова прямолинейный, касающийся дугового и заканчивающийся в точке (1000,600) (у всех точек координата (равна нулю). Вызовем команду EXTRUDE (ВЫДАВИТЬ). На запрос о выборе объектов укажите область в форме кольца. Следующий запрос:
Specify height of extrusion or [Path]: (Глубина выдавливания или [Траектория]:)
Выберите опцию Path (Траектория). Далее система выдаст запрос:
Select extrusion path: (Траектория выдавливания:)
Укажите полилинию в качестве траектории выдавливания. Результат (при выполненном раскрашивании по Гуро) приведен на рис. 9.89.
Команда INTERFERE (ВЗАИМОД) позволяет создать тело, занимающее общий объем двух или более тел. Команде соответствует кнопка [image] панели инструментов Solids (Тела).

Рис. 9.89. Построение трубы с помощью выдавливания


9.7.2. Разрезы и сечения

Команда SLICE (РАЗРЕЗ), которой соответствует кнопка [image] панели инструментов Тела (Solids), позволяет разрезать тело плоскостью на два тела и, при необходимости, одно из них удалить.
Рассмотрим эту команду на примере построенной нами трубы (см. рис. 9.89). С помощью команды UCS (ПСК) перейдите в МСК. Щелкните мышью по кнопке [image] и на запрос об объектах выберите трубу. Следующий запрос:
Specify first point on slicing plane by [Object/Zaxis/View/XY/YZ/ZX/3points] <3points>:
(Первая тонка на режущей плоскости [Объект/2ось/Вид/Х¥/¥2/7Х/Зточки] <3точки >:)
Нажмите клавишу <Enter>, подтверждая выбор плоскости разреза тремя точками. Далее последовательно следуя запросам, введите следующие точки: (100,-50,100), (-100,80,100) и (300,0,600). Системе теперь необходимо сообщить, какие тела оставить:
Specify a point on the desired side of the plane or [keep Both sides]:
(Укажите точку с нужной стороны от плоскости [Обе стороны]:)
Выберите опцию keep Both sides (Обе стороны). Труба разделится на два тела, причем в одном теле будут две непересекающихся части. Отодвиньте (например, за ручки) одно тело влево. Результат проделанных операций приведен на рис. 9.90. Для наглядности выполнено раскрашивание по Гуро.

Рис. 9.90. Разрезание тела плоскостью

Правое тело в случае необходимости можно разбить на два отдельных тела с помощью кнопки [image] панели Solids Editing (Редактирование тел).
Команда SECTION (СЕЧЕНИЕ), которой соответствует кнопка [image] панели инструментов Solids (Тела), строит сечение тела, образуя в результате область с линиями сечения, которую можно затем вынести и использовать в чертеже.


9.7.3. Редактирование тел

Над телами можно выполнять операции общего редактирования (удаление, перемещение, копирование и т. п.). В падающее меню Modify (Редакт) входит подменю 3D Operation (3M операции), в котором собраны следующие полезные пункты:

  • 3D Array (3M массив) — создание трехмерного массива (команда 3DARRAY (3-МАССИВ));
  • Mirror 3D (ЗМ зеркало) — создание зеркальной копии объектов относительно заданной плоскости (команда MIRROR3D (3-ЗЕРКАЛО));
  • Rotate 3D (ЗМ поворот) — поворот объектов вокруг произвольной оси в пространстве (команда ROTATE3D (3-ПОВЕРНУТЬ));
  • Align (Выровнять) — выравнивание объектов с другими точками или объектами в двумерном и трехмерном пространствах (команда ALIGN (ВЫРОВНЯТЬ)).

Операции построения фасок и сопряжения граней тел с помощью команд CHAMFER (ФАСКА) и FILLET (СОПРЯЖЕНИЕ) были рассмотрены в предыдущем разделе.
В связи с особой организацией твердотельных объектов (примитивов типа 3DSOLID) их ручки нельзя использовать для таких действий, как растягивание, модификация граней и ребер и т. п. Для этих целей предусмотрена панель инструментов Solids Editing (Редактирование тел) (рис. 9.91).

Рис. 9.91. Панель инструментов Solids Editing

Первые три кнопки панели соответствуют операциям объединения, вычитания и пересечения тел, аналогичным одноименным операциям над областями, рассмотренным в разд. 9.6. Другие кнопки соответствуют опциям команды SOLIDEDIT (РЕДТЕЛ):

  • — выдавливание граней тела на заданную глубину или вдоль траектории;
  • — перенос граней тела на заданное расстояние;
  • — равномерное смещение граней на заданное расстояние или до указанной точки;
  • — удаление граней тела вместе с сопряжениями и фасками;
  • — поворот граней вокруг заданной оси;
  • — сведение граней на конус под заданным углом;
  • — создание копий граней тела в виде областей или твердотельных оболочек;
  • — изменение цвета отдельных граней;
  • — создание копий ребер тела в виде отрезков, дуг, окружностей, эллипсов или сплайнов;
  • — изменение цвета ребер;
  • — создание клейма (нового ребра, являющегося отпечатком другого объекта) на грани;
  • — удаление лишних ребер и вершин;
  • — разделение многосвязных тел (занимающих несколько замкнутых объемов в пространстве) на отдельные тела (см. пример на рис. 9.90);
  • — создание полой тонкостенной оболочки заданной толщины;
  • — проверка, является ли объект допустимым телом.

Все эти операции могут быть выполнены также через подменю Solids Editing (Редактирование тел) падающего меню Modify (Редакт).
Команда SOLIDEDIT (РЕДТЕЛ), выполняющая все перечисленные операции редактирования твердотельных объектов, начинает свою работу с сообщения:
Solids editing automatic checking: SOLIDCHECK=1 Enter a solids editing option [Face/Edge/Body/Undo/eXit] <eXit>:
(Автоматическая проверка тел при редактировании: SOLIDCHECK=1 Задайте опцию редактирования тела {Грань/Ребро/Тело ACIS/Отменить/ выХод] <выХод>:)
Системная переменная SOLIDCHECK, значение которой показывается в первой строке, управляет режимом проверки корректности тел, создаваемых в операциях редактирования. Если значение переменной равно 1, то автоматическая проверка выполняется, если 0 — то не выполняется (тогда проверку надо осуществлять с помощью специального средства команды SOLIDEDIT (РЕДТЕЛ)).
В первом запросе команда SOLIDEDIT (РЕДТЕЛ) предлагает четыре опции:

  • Face (Грань) — режим редактирования граней;
  • Edge (Ребро) — режим редактирования ребер;
  • Body (Тело ACIS) — специальный режим работы с телом (проверка, клеймение и т. п.);
  • Undo (Отменить) — отмена последней операции редактирования тела;
  • eXit (выХод) — завершение работы команды.

В случае выбора опции Face (Грань) система AutoCAD предлагает операции редактирования граней:
Enter a face editing option [Extrude/Move/Rotate/ Offset/Taper/Delete/Copy/coLor/Undo/eXit] <eXit>:
(Задайте опцию редактирования грани [Выдавить/пеРенести/Повернуть/ Сместить/коНус/Удалитъ/Копировать/Цвет/ Отменитъ/выХод] <выХод >:)
В данном списке опций первые восемь соответствуют операциям, связанным с кнопками редактирования граней панели Solids Editing (Редактирование тел), уже рассмотренными ранее. Последние две опции позволяют отменить предыдущую операцию редактирования или выйти из режима редактирования граней.
Если в ответ на первый запрос команды SOLIDEDIT (РЕДТЕЛ) вы выберите опцию Edge (Ребро), то перейдете в режим редактирования ребер:
Enter an edge editing option [Copy/coLor/Undo/eXit] <eXit>:
(Задайте опцию редактирования ребра [Копировать/Цвет/Отменить/выХод] <выХод>:)
В этот момент вам доступны опции копирования ребра (в качестве нового отрезка, дуги, окружности, эллипса или сплайна) или изменения цвета ребра.
Если в начале работы команды SOLIDEDIT (РЕДТЕЛ) выбрать опцию Body (Тело ACIS), то система запрашивает:
Enter a body editing option [Imprint/seParate solids/Shell/cLean/Check/ Undo/eXit] <eXit>:
(Задайте опцию редактирования тела [Клеймить/Разделить/о Волочка/ У простить/Проверить/Отменить/выХод] <выХод >:)
Здесь первые пять опций соответствуют операциям над телами, описанных, в целом, при перечислении последних пяти кнопок панели Solids Editing (Редактирование тел).
На рис. 9.92—9.95 проиллюстрированы результаты выполнения нескольких операций. Слева на каждом рисунке показано тело до операции, справа — после редактирования.
На рис. 9.92 правая боковая (более темная) грань повернута на 15° относительно нижнего ребра этой грани. Другие грани продлены.

Рис. 9.92. Поворот грани тела

На рис. 9.93 продемонстрировано смещение грани (построение параллельной поверхности). Правая боковая цилиндрическая грань смещена по нормали. Другие грани продлены до пересечения с изменившейся гранью.
На рис. 9.94 в плоскости верхнего основания куба расположен прямоугольник. После операции клеймения три отрезка (части контура прямоугольника) добавлены в ребра, расположенные на верхней грани тела.

Рис. 9.93. Параллельное смещение грани тела

Рис. 9.94. Клеймение грани тела

На рис. 9.95 проиллюстрирована операцию построения тонкой оболочки к стенкам куба (правая боковая грань из операции исключена).

Рис. 9.95. Построение тонкой оболочки тела


Перечень команд AutoCAD

В табл. П1.1 приведен алфавитный перечень документированных команд англоязычной версии AutoCAD 2004. В эту таблицу не включены дополнительные команды комплекса Express Tools 2004 и команды работы в режиме связи с базами данных.

В табл. П1.2 и П1.3 перечислены, соответственно, новые и удаленные команды.

Таблица П1.1. Команды системы AutoCAD 2004

Команда | Описание
#
3D | Построение сети в форме стандартной поверхности
3DARRAY | Копирование объектов с расположением в виде трехмерного массива
3DCLIP | Регулировка секущих плоскостей
3DCONFIG | Настройка параметров трехмерной графики
3DCORBIT | Установка режима постоянного вращения вида
3DDISTANCE | Установка режима просмотра, приближение к объектам и удаление от них
3DFACE | Построение трехмерной грани
3DMESH | Построение сети
3DORBIT | Просмотр объектов в орбитальном режиме
3DORBITCTR | Просмотр объектов в орбитальном режиме, с заданием точки центра вращения
3DPAN | Трехмерное панорамирование
3DPOLY | Построение трехмерной полилинии из линейных сегментов
3DSIN | Импорт файла 3D Studio
3DSOUT | Экспорт в файл 3D Studio
3DSWIVEL | Имитация эффекта поворота камеры
3DZOOM | Трехмерное зумирование
А
ABOUT | Вывод на экран информации об экземпляре версии системы AutoCAD
ACISIN | Импорт ACIS-файла
ACISOUT | Экспорт твердотельных объектов AutoCAD в файл формата ACIS
ADCCLOSE | Закрытие Центра управления
ADCENTER | Вызов Центра управления AutoCAD
ADCNAVIGATE | Перемещение в зоне структуры Центра управления AutoCAD на конкретный файл, папку или сетевой ресурс
AIJ/IOLC | Установка слоя объекта текущим
ALIGN | Выравнивание объектов относительно других объектов
AMECONVERT | Конвертирование моделей АМЕ (AutoCAD R 12) в твердотельные объекты AutoCAD 2000
APERTURE | Изменение размера прицела объектной привязки
APPLOAD | Загрузка и выгрузка приложений
ARC | Построение дуг
AREA | Вычисление площадей и периметров объектов
ARRAY | Создание массивов объектов
ARX | Загрузка, выгрузка и получение информации об ARX-приложениях
ASSIST | Управление окном активной помощи
ATTACHURL | Добавление гиперссылки
ATTDEF | Создание описания атрибута
ATTDISP | Глобальное управление видимостью атрибутов
ATTEDIT | Изменение значений атрибутов
ATTEXT | Извлечение значений атрибутов
ATTREDEF | Переопределение блока и обновление связанных с ним атрибутов
ATTSYNC | Синхронизация атрибутов
AUDIT | Проверка целостности рисунка
В
BACKGROUND | Задание фона для операции тонирования
BASE | Задание базовой точки вставки для текущего рисунка
BATTMAN | Диспетчер атрибутов блоков
BHATCH | Нанесение ассоциативной штриховки внутри замкнутого контура
BLIPMODE | Управление простановкой маркеров при рисовании
BLOCK | Создание описания блока
BLOCKICON | Формирование растрового образца для просмотра блока, созданного в предыдущих версиях AutoCAD
BMAKE | Создание описания блока
BMPOUT | Сохранение в файле формата BMP
BOUNDARY | Создание области или полилинии из замкнутого контура
BOX | Построение твердотельного параллелепипеда (ящика)
BREAK | Построение разрыва линии между точками
BROWSER | Вызов браузера Web-страниц
С
CAL | Вычисление математических и геометрических выражений (калькулятор)
CAMERA | Установка положения камеры и цели
CHAMFER | Построение фаски
CHANGE | Изменение свойств объектов
CHECKSTANDARDS | Проверка чертежа на соответствие стандартам
CHPROP | Изменение свойств объектов
CIRCLE | Построение окружностей (кругов)
CLEANSCREENOFF | Отказ от расширения графического экрана
CLEANSCREENON | Расширение графического экрана за счет отказа от панелей и заголовка
CLOSE | Закрытие текущего рисунка
CLOSEALL | Закрытие всех открытых рисунков
COLOR | Установка цвета для вновь создаваемых объектов
COMPILE | Компиляция файлов форм и файлов шрифтов PostScript
CONE | Построение твердотельного конуса
CONVERT | Преобразование двумерных полилиний и ассоциативных штриховок, созданных в AutoCAD R13 или более ранних версиях
CONVERTCTB | Преобразование таблиц цветозависимых стилей печати в таблицы именованных стилей
CONVERTPOLY | Преобразование подробных полилиний в компактные и наоборот
CONVERTPSTYLES | Перенастройка рисунка с цветозависимых стилей печати на именованные или наоборот
COPY | Копирование объектов
COPYBASE | Копирование объектов в буфер обмена с указанием базовой точки
COPYCLIP | Копирование объектов в буфер обмена
COPYHIST | Копирование строк из текстового окна в буфер обмена
COPYLINK | Копирование текущего вида в буфер обмена для вставки его в другой рисунок или документ другого приложения
CUSTOMIZE | Адаптация панелей, палитр инструментов и горячих клавишей
CUTCLIP | Копирование объектов в буфер обмена с удалением их из рисунка
CYLINDER | Построение твердотельного цилиндра
D |
DBCCLOSE | Закрытие диспетчера связи с базами данных
DBCONNECT | Интерфейс между AutoCAD и таблицами внешних баз данных
DBLCLKEDIT | Управление вызовом окна редактирования по двойному щелчку
DBLIST | Вывод на экран информации обо всех объектах рисунка
DDEDIT | Редактирование текстов, размерных текстов и описаний атрибутов
DDPTYPE | Задание режима отображения и величины объектов-точек
DDVPOINT | Задание направления взгляда в трехмерном пространстве
DELAY | Задание паузы при выполнении пакета команд
DETACHURL | Удаление гиперссылки
DIM | Переход в режим нанесения размеров
DIM1 | Переход в режим нанесения одного размера
DIMALIGNED | Простановка параллельного линейного размера
DIMANGULAR | Простановка углового размера
DIMBASELINE | Простановка базового размера
DIMCENTER | Простановка маркера центра и нанесение центровой линии
DIMCONTINUE | Простановка размерной цепи
DIMDIAMETER | Простановка диаметра
DIMDISASSOCIATE | Преобразование ассоциативных размеров в неассоциативные
DIMEDIT | Редактирование размера
DIMLINEAR | Простановка линейного размера
DIMORDINATE | Простановка ординатного размера
DIMOVERRIDE | Переопределение установок размерных переменных
DIMRADIUS | Простановка радиуса
DIMREASSOCIATE | Преобразование размеров в ассоциативные
DIMREGEN | Дополнительная регенерация ассоциативных размеров
DIMSTYLE | Создание и модификация размерных стилей
DIMTEDIT | Перемещение и поворот размерных текстов
DIST | Измерение расстояния между точками
DIVIDE | Равномерная расстановка точек или блоков вдоль объекта
DONUT | Построение закрашенных колец
DRAGMODE | Управление отображением объектов при буксировке
DRAWORDER | Изменение порядка вывода растровых изображений и других объектов на экран
DSETTINGS | Задание параметров шаговой привязки, сетки, полярного и объектного отслеживания
DSVIEWER | Вызов окна Aerial View
DTEXT | Создание однострочных текстовых надписей в динамическом режиме
DVIEW | Установка параллельных проекций и видов в перспективе
DWGPROPS | Задание и просмотр свойств текущего рисунка
DXBIN | Импорт двоичных файлов в специальной кодировке
E
EATTEDIT | Редактирование атрибутов блоков
EATTEXT | Извлечение атрибутов
EDGE | Изменение видимости кромок трехмерной грани
EDGESURF | Построение сети (поверхности Кунса)
ELEV | Задание уровня и высоты выдавливания вновь создаваемых объектов
ELLIPSE | Построение эллипса или эллиптической дуги
ERASE | Удаление объектов из рисунка
ETRANSMIT | Создание массива чертежных файлов, шрифтов для передачи
EXPLODE | Расчленение составного объекта
EXPORT | Экспорт объектов в файлы различных форматов
EXPRESSMENU | Загрузка меню Express
EXPRESSTOOLS | Загрузка Express Tools
EXTEND | Продление объектов до пересечения с другими объектами
EXTRUDE | Создание тела путем выдавливания двумерного объекта
F
FILEOPEN | Открытие рисунка без диалогового окна
FILL | Управление закрашиванием
FILLET | Скругление углов и сопряжение объектов
FILTER | Создание фильтров многократного использования для выбора объектов на основе их свойств
FIND | Поиск, замена, выбор и показ текста на рисунке
FOG | Управление туманом и затемнением объектов
G
GOTOURL | Загрузка браузера и открытие страницы (файла) по гиперссылке
GRAPHSCR | Переключение из текстового окна в графический экран
GRID | Включение и отключение сетки на текущем видовом экране
GROUP | Управление группами (именованными наборами объектов)
H
HATCH | Заполнение указанного контура штриховкой по выбранному образцу
HATCHEDIT | Редактирование нанесенной штриховки
HELP | Вызов справочной системы
HIDE | Регенерация трехмерной модели с подавлением скрытых линий
HLSETTINGS | Настройка параметров отображения скрытых линий
HYPERLINK | Создание и редактирование гиперссылки
HYPERLINKOPTIONS | Управление видимостью курсора и выводом подсказок для гиперссылок
I
ID | Определение координат точки
IMAGE | Управление растровыми изображениями
IMAGEADJUST | Регулировка яркости, контрастности и степени слияния изображений с фоном
IMAGEATTACH | Вставка растрового изображения
IMAGECLIP | Создание контуров подрезки растровых изображений
IMAGEFRAME | Управление видимостью границ контуров подрезки изображения
IMAGEQUALITY | Управление качеством вывода изображений на экран
IMPORT | Импорт в AutoCAD файлов различных форматов
INSERT | Вставка в текущий рисунок блока или другого рисунка
INSERTOBJ | Вставка связанного или внедренного объекта
INTERFERE | Создание сложного тела, занимающего общий объем двух или более тел
INTERSECT | Пересечение областей или тел
ISOPLANE | Выбор текущей изометрической плоскости
J
JPGOUT | Экспорт в файл формата JPEG
JUSTIFYTEXT | Изменение способа привязки и выравнивания текста
L
LAYER | Управление слоями и их свойствами
LAYERP | Возврат к предыдущему состоянию слоев
LAYERPMODE | Управление изменениями слоев при возврате к предыдущему состоянию слоев
LAYOUT | Операции с листами
LAYOUTWIZARD | Вызов Мастера компоновки нового листа
LAYTRANS | Трансляция слоев
LEADER | Построение линий, соединяющих пояснительные надписи с поясняемыми элементами
LENGTHEN | Увеличение длин объектов
LIGHT | Управление источниками света
LIMITS | Установка и контроль лимитов рисунка
LINE | Построение отрезков
LINETYPE | Создание, загрузка и установка типов линий
LIST | Получение информации о выбранных объектах
LOAD | Подготовка форм к использованию
LOGFILEOFF | Выключение режима записи в файл журнала
LOGFILEON | Включение режима записи в файл журнала
LSEDIT | Редактирование объектов ландшафта
LSLIB | Управление библиотеками объектов ландшафта
LSNEW | Вставка в рисунок элемента ландшафта
LTSCALE | Задание глобального масштаба типов линий
LWEIGHT | Задание текущего веса линий
M
MASSPROP | Вычисление масс-инерционных характеристик
MATCHPROP | Копирование свойств объекта в другие объекты
MATLIB | Работа с библиотекой материалов
MEASURE | Расстановка точек или блоков вдоль объекта с заданными интервалами
MENU | Загрузка файла меню
MENULOAD | Загрузка фрагментного меню
MENUUNLOAD | Выгрузка фрагментного меню
MINSERT | Вставка нескольких вхождений блоков с расположением их в виде прямоугольного массива
MIRROR | Зеркальное отображение объектов
MIRROR3D | Симметрирование объектов относительно плоскости
MLEDIT | Редактирование мультилинии
MLINE | Построение мультилинии
MLSTYLE | Создание и редактирование стилей мультилинии
MODEL | Переключение с вкладки пространства листа на вкладку Model
MOVE | Перемещение объектов
MREDO | Отмена действия группы последних операций
MSLIDE | Создание файла слайда
MSPACE | Переключение из поля листа в видовой экран пространства листа
MTEXT | Создание многострочного текста
MULTIPLE | Многократное повторение следующей команды
MVIEW | Создание и включение плавающих видовых экранов
MVSETUP | Задание параметров и оформление листа
N
NEW | Создание нового файла рисунка
О
OFFSET | Построение подобных (параллельных) объектов
OLELINKS | Обновление, изменение и разрыв имеющихся OLE-связей
OLESCALE | Вызов диалогового окна свойств OLE-объектов
OOPS | Восстановление стертых объектов
OPEN | Открытие существующего файла рисунка
OPTIONS | Настройка параметров рабочей среды AutoCAD
ORTHO | Включение (отключение) режима ортогональности
OSNAP | Задание текущих режимов объектной привязки
P
PAGESETUP | Задание устройства печати, формата бумаги и других параметров для листов файла рисунка
PAN | Панорамирование (перемещение изображения)
PARTIALOAD | Дополнительная загрузка геометрии в частично открытый рисунок
PARTIALOPEN | Загрузка в текущий рисунок геометрии с выбранного вида или слоев
PASTEBLOCK | Вставка содержимого буфера обмена Windows с преобразованием в блок
PASTECLIP | Вставка содержимого буфера обмена Windows
PASTEORIG | Вставка объектов, скопированных в буфер обмена, в другой рисунок с теми же координатами, которые они имели в исходном рисунке
PASTESPEC | Вставка данных из буфера обмена Windows с возможностью управления их форматом
PCINWIZARD | Вызов Мастера импорта параметров печати из РСР-и РС2-файлов для вкладки Model или текущего листа
PEDIT | Редактирование полилиний, полигональных и многогранных сетей
PFACE | Создание многогранной сети
PLAN | Установка вида в плане заданной ПСК
PLINE | Построение двумерной полилинии
PLOT | Вывод рисунка на принтер или в файл
PLOTSTAMP | Вывод в чертеж дополнительных служебных надписей
PLOTSTYLE | Установка стиля печати для новых или выбранных объектов
PLOTTERMANAGER | Вызов диспетчера плоттеров
PNGOUT | Экспорт в файл формата PNG
POINT | Создание объектов-точек
POLYGON | Построение полилинии в форме правильного многоугольника
PREVIEW | Просмотр внешнего вида чертежа, который будет получен в процессе печати
PROPERTIES | Окно управления свойствами объектов
PROPERTIESCLOSE | Закрытие окна свойств
PSETUPIN | Импорт набора параметров листа из другого файла рисунка во вновь создаваемый лист
PSFILL | Заполнение контура двумерной полилинии образцом заполнения PostScript
PSOUT | Экспорт в EPS-файл
PSPACE | Переключение из видового экрана пространства листа в поле листа
PUBLISH | Экспорт в файл формата DWF
PUBLISHTOWEB | Создание страниц в формате HTML
PURGE | Очистка рисунка от неиспользуемых именованных объектов (блоков, слоев и т. п.)
Q
QDIM | Быстрое нанесение размеров
QLEADER | Построение выноски
QNEW | Быстрое создание нового рисунка
QSAVE | Быстрое сохранение текущего рисунка
QSELECT | Быстрое создание наборов объектов
QTEXT | Управление показом и выводом на принтер текста и атрибутов
QUIT | Завершение сеанса работы с AutoCAD
R
RAY | Построение луча
RECOVER | Восстановление поврежденного рисунка
RECTANG | Построение полилинии в форме прямоугольника
REDEFINE | Восстановление переопределенной команды AutoCAD в первоначальном виде
REDO | Отмена действия последней команды UNDO или U
REDRAW | Перерисовка содержимого текущего видового экрана
REDRAWALL | Перерисовка содержимого всех видовых экранов
REFCLOSE | Сохранение или отказ от изменений, произведенных в ходе редактирования вхождений блоков и ссылок
REFEDIT | Выбор вхождения блока или внешней ссылки для редактирования
REFSET | Добавление и исключение объектов из рабочего набора при редактировании вхождений блоков и внешних ссылок
REGEN | Регенерация рисунка и перерисовка содержимого текущего видового экрана
REGENALL | Регенерация рисунка и перерисовка всех видовых экранов
REGENAUTO | Управление автоматической регенерацией рисунка
REGION | Создание области
REINIT | Повторная инициализация портов ввода-вывода, дигитайзера, монитора и файла параметров для AutoCAD
RENAME | Изменение имен объектов (слоев, блоков, текстовых стилей и т. п.)
RENDER | Тонирование
RENDSCR | Повторный вывод на экран последнего изображения, созданного командой RENDER
REPLAY | Просмотр изображений в форматах BMP, TGA и TIFF
RESUME | Продолжение прерванного пакета
REVCLOUD | Создание линии облака (полилинии из дуг окружностей)
REVOLVE | Создание тела вращения
REVSURF | Создание поверхности вращения
RMAT | Управление материалами для тонирования
RMLIN | Вставка пометок
ROTATE | Поворот объектов вокруг заданной точки
ROTATE3D | Поворот объектов вокруг оси в пространстве
RPREF | Настройка режимов тонирования
RSCRIPT | Создание бесконечно повторяющегося пакета (сценария)
RULESURF | Создание поверхности соединения
S
SAVE | Сохранение рисунка под текущим или заданным именем
SAVEAS | Сохранение рисунков, не имевших имени, или сохранение текущего рисунка с переименованием
SAVEIMG | Сохранение тонированных изображений в файлах
SCALE | Масштабирование объектов
SCENE | Управление сценами в пространстве модели
SCRIPT | Выполнение последовательности команд из пакетного (командного) файла
SECTION | Создание области путем пересечения тел плоскостью
SECURITYOPTIONS | Управление паролем и цифровой подписью
SELECT | Занесение выбранных объектов в текущий набор
SELECTURL | Выбор всех объектов с гиперссылками
SETIDROPHANDLER | Задание параметров загрузки в рисунок файлов из Интернета
SETUV | Наложение текстур на поверхности объектов
SETVAR | Получение списка системных переменных, изменение их значений
SHADEMODE | Раскрашивание объектов на текущем видовом экране
SHAPE | Вставка формы
SHELL | Доступ к командам операционной системы
SHOWMAT | Получение списка типов материалов и методов их присвоения выбранным объектам
SIGVAL1DATE | Проверка электронной цифровой подписи
SKETCH | Рисование коротких смежных сегментов от руки
SLICE | Разрезание набора тел плоскостью
SNAP | Ограничение перемещения курсора определенными интервалами
SOLDRAW | Построение профилей и сечений на видовых экранах, созданных командой SOLVIEW
SOLID | Создание фигур (закрашенных многоугольников)
SOLIDEDIT | Редактирование граней и ребер твердотельных объектов
SOLPROF | Создание профилей трехмерных тел
SOLVIEW | Создание связанных плавающих видовых экранов для размещения видов и сечений твердотельных объектов
SPACETRANS | Пересчет длин между пространствами модели и листа
SPELL | Орфографическая проверка надписей
SPHERE | Построение трехмерного твердотельного шара
SPLINE | Построение сплайна
SPLINEDIT | Редактирование сплайнового объекта
STANDARDS | Работа со стандартами
STATS | Показ статистики тонирования
STATUS | Вывод на экран статистической информации о рисунке, режимах и границах
STLOUT | Сохранение тел в двоичном или ASCII-файле формата STL
STRETCH | Растягивание объектов
STYLE | Создание и редактирование текстовых стилей
STYLESMANAGER | Вызов диспетчера стилей печати
SUBTRACT | Вычитание областей или тел
SYSWINDOWS | Управление окнами документов
Т
TABLET | Настройка и калибровка планшета
TABSURF | Создание поверхности сдвига по определяющей кривой и вектору направления
TEXT | Создание однострочных текстовых надписей в динамическом режиме
TEXTSCR | Открытие текстового окна AutoCAD
TIFOUT | Экспорт в файл формата TIFF
TIME | Получение сведений о дате и времени
TOLERANCE | Простановка допуска формы и расположения
TOOLBAR | Загрузка, удаление и адаптация панелей
TOOLPALETTES | Загрузка панели Tool Palettes
TOOLPALETTES-CLOSE | Выгрузка панели Tool Palettes
TORUS | Построение твердотельного тора
TRACE | Построение полос
TRANSPARENCY | Управление прозрачностью растровых изображений
TRAYSETTINGS | Управление значками в области уведомлений Windows
TREESTAT | Получение информации о пространственных индексах рисунка
TRIM | Обрезка объекта по кромке, заданной другими объектами
U
U | Отмена действия последней команды
UCS | Управление пользовательскими системами координат
UCSICON | Управление формой, видимостью и расположением пиктограммы пек
UCSMAN | Управление пользовательскими системами координат
UNDEFINE | Переопределение внутренней команды AutoCAD одноименной командой приложения
UNDO | Отмена действия одной или нескольких команд
UNION | Объединение областей или тел
UNITS | Управление форматом и точностью линейных и угловых единиц
V
VBAIDE | Вызов редактора Visual Basic
VBALOAD | Глобальная загрузка проекта VBA в текущий сеанс AutoCAD
VBAMAN | Работа с проектами VBA
VBARUN | Запуск VBA-макроса
VBASTMT | Выполнение VBA-выражения в командной строке AutoCAD
VBAUNLOAD | Глобальная выгрузка проекта VBA
VIEW | Управление видами
VIEWRES | Задание точности аппроксимации объектов на текущем видовом экране
VLIDE | Вызов интегрированной среды разработки приложений Visual LISP
VLISP | Вызов интегрированной среды разработки приложений Visual LISP
VPCLIP | Подрезка видовых экранов в пространстве листа
VPLAYER | Управление видимостью слоев для отдельных видовых экранов
VPOINT | Задание направления взгляда для трехмерного вида
VPORTS | Создание неперекрывающихся или плавающих видовых экранов
VSLIDE | Просмотр файла слайда
W
WBLOCK | Запись объектов или блока в отдельный файл рисунка
WEDGE | Построение твердотельного клина
WHOHAS | Выдача информации о том, кем открыт файл рисунка
WIPEOUT | Создание пятна
WMFIN | Импорт метафайла Windows
WMFOPTS | Задание опций для команды WMFIN
WMFOUT | Экспорт объектов в метафайл Windows
X
XATTACH | Вставка внешних ссылок в текущий рисунок
XBIND | Внедрение неграфических объектов (символов) внешней ссылки в рисунок
XCLIP | Задание контура подрезки для внешней ссылки или блока и установка передней и задней плоскостей обрезки
XLINE | Построение бесконечных прямых
XOPEN | Открытие файла рисунка внешней ссылки
XPLODE | Разбиение составного объекта на составляющие объекты с возможностью назначения цветов, слоев и типов линий образующимся объектам
XREF | Управление внешними ссылками
Z
ZOOM | Увеличение или уменьшение видимого размера объектов на текущем видовом экране (зумирование)

Названия команд, появившихся в системе AutoCAD 2004:

3DCONFIG | JPGOUT | SECURITYOPTIONS | TRAYSETTINGS
3DORBITCTR | MREDO | SETIDROPHANDLER | WIPEOUT
ATTACHURL | PNGOUT | SIGVALIDATE | XOPEN
CLEANSCREENOFF | PUBLISH | TIFOUT |
CLEANSCREENON | QNEW | TOOLPALETTES |
HLSETTINGS | REVCLOUD | TOOLPALETTESCLOSE |

Названия команд: которые присутствовали в системе AutoCAD 2002, но исключены из веосии AutoCAD 2004:

DWFOUT
ENDTODAY
MEETNOW
TODAY


Перечень системных переменных

В табл. П2.1 приводится список документированных системных переменных AutoCAD, в алфавитном порядке, с кратким описанием. Более подробное описание системных переменных и их значений.
В табл. П2.2 и П2.3 перечислены, соответственно, новые и удаленные системные переменные.

Таблица П2.1. Системные переменные AutoCAD 2004

Системная переменная | Описание
А
ACADLSPASDOC | Управление режимом загрузки файла acad.lsp
ACADPREFIX | Пути поиска файлов поддержки и драйверов
ACADVER | Номер версии AutoCAD
ACISOUTVER | Код версии ACIS-файлов, создаваемых командой ACISOUT
ADCSTATE | Признак наличия на экране Центра управления
AFLAGS | Сумма установленных битовых флагов для команды ATTDEF
ANGBASE | Направление нулевого угла в текущей ПСК
ANGDIR | Код направления отсчета углов в текущей ПСК
АРВОХ | Состояние прицела автопривязки
APERTURE | Размер прицела перекрестия курсора
AREA | Последнее вычисленное значение площади
ATTDIA | Режим команды INSERT при вводе значений атрибутов (с диалоговым окном или без него)
ATTMODE | Режим видимости атрибутов
ATTREQ | Режим использования командой INSERT атрибутов по умолчанию
AUDITCTL | Режим создания файла протокола проверки (с расширением adt) при выполнении команды AUDIT
AUNITS | Угловые единицы измерения
AUPREC | Точность в угловых размерах
AUTOSNAP | Управление маркером, подсказкой и магнитом автопривязки
В
BACKZ | Смещение задней секущей плоскости от плоскости цели для текущего видового экрана в условных единицах
BINDTYPE | Форма имен зависимых символов при внедрении внешних ссылок и при редактировании вхождений
BLIPMODE | Режим видимости маркеров
С
CDATE | Текущая дата и время суток
CECOLOR | Текущий цвет
CELTSCALE | Текущий масштаб типа линий
CELTYPE | Текущий тип линии
CELWEIGHT | Текущий вес линий
CHAMFERA | Первая длина фаски
CHAMFERB | Вторая длина фаски
CHAMFERC | Длина фаски
CHAMFERD | Угол фаски
CHAMMODE | Текущий метод создания фасок в команде CHAMFER
CIRCLE-PAD | Радиус, предлагаемый по умолчанию в команде CIRCLE
CLAYER | Текущий слой
CLEARSCREENSTATE | Состояние очистки экрана
CMDACTIVE | Битовый код, указывающий, активны ли в данный момент обычная команда, прозрачная команда, пакет команд и (или) диалоговое окно
CMDECHO | Режим эхо-вывода (отображения подсказок AutoCAD) при выполнении функций command и vl-cmdf языка AutoLISP
CMDNAMES | Английское имя текущей команды
CMLJUST | Текущий тип расположения мультилиний
CMLSCALE | Текущий масштаб построения мультилиний
CMLSTYLE | Текущий стиль мультилиний
COMPASS | Режим показа трехмерного компаса на текущем видовом экране
COORDS | Режим обновления координат в статусной строке
CPLOTSTYLE | Текущий стиль печати
CPROFILE | Имя текущего профиля
СТАВ | Название текущей вкладки в рисунке (Model или один из листов)
CURSORSIZE | Размер перекрестия в процентном отношении к размеру экрана
CVPORT | Номер активного видового экрана
D
DATE | Текущая дата и время суток
DBMOD | Битовый код, определяющий состояние изменений в рисунке с момента последнего сохранения
DCTCUST | Путь и имя файла текущего вспомогательного словаря проверки орфографии
DCTMAIN | Имя файла текущего основного орфографического словаря
DEFLPLSTYLE | Стиль печати по умолчанию для новых слоев
DEFPLSTYLE | Стиль печати по умолчанию для новых объектов
DELOBJ | Режим сохранения или удаления примитивов, используемых для создания других объектов
DEMANDLOAD | Реакция AutoCAD при обнаружении в рисунке объектов, созданных другими приложениями
DIASTAT | Режим выхода из последнего диалогового окна
DIMADEC | Точность угловых размеров
DIMALT | Режим альтернативных единиц в размерах
DIMALTD | Точность для альтернативных единиц измерения
DIMALTF | Коэффициент пересчета для альтернативных единиц в размерах
DIMALTRND | Точность округления альтернативных единиц
DIMALTTD | Точность в альтернативном допуске
DIMALTTZ | Режим подавления нулей в допусках
DIMALTU | Формат единиц для всех видов альтернативных размеров, за исключением угловых
DIMALTZ | Режим подавления нулей в альтернативных размерных единицах
DIMAPOST | Строка, присоединяемая в конец любых размеров в альтернативных единицах измерения, за исключением угловых
DIMASO | Режим ассоциативности размерных объектов, как блоков (устаревшая переменная)
DIMASSOC | Режим ассоциативной связи размеров и измеряемых объектов рисунка
DIMASZ | Величина стрелок на концах размерной линии и выноски
DIMATFIT | Режим размещения размерного текста и стрелок, если для того и другого одновременно недостаточно места между выносными линиями
DIMAUNIT | Формат единиц измерения для угловых размеров
DIMAZIN | Режим подавления нулей в угловых размерах
DIMBLK | Блок, используемый для стрелок на концах размерных линий и выносок
DIMBLK1 | Стрелка на первом конце размерной линии (при включенной переменной DIMSAH)
DIMBLK2 | Стрелка на втором конце размерной линии (при включенной переменной DIMSAH)
DIMCEN | Режим нанесения маркеров центра и центровых линий кругов и дуг в командах DIMCENTER, DIMDIAMETER и DIMRADIUS
DIMCLRD | Цвет размерных линий, стрелок и выносных линий
DIMCLRE | Цвет выносных линий размеров
DIMCLRT | Цвет размерного текста
DIMDEC | Точность в основных единицах
DIMDLE | Величина выступа размерной линии за выносную линию при использовании засечек
DIMDLI | Величина отступа размерной линии в базовых размерах
DIMDSEP | Символ десятичного разделителя при десятичном формате вывода чисел
DIMEXE | Величина выступа выносной линии за размерную линию
DIMEXO | Величина смещения выносных линий относительно заданных начальных точек
DIMFIT | Устаревшая переменная (заменена на DIMATFIT и DIMTMOVE)
DIMFRAC | Формат дробей в случаях, когда DIMLUNIT имеет значение 4 (архитектурные) или 5 (дробные)
DIMGAP | Расстояние, оставляемое пустым при изображении размерного текста в разрыве размерной линии
DIMJUST | Режим положения размерного текста по горизонтали
DIMLDRBLK | Тип стрелки на конце выноски
DIMLFAC | Масштабный коэффициент для линейных размеров
DIMLIM | Генерация размерного текста в формате "пределы"
DIMLUNIT | Формат единиц для всех видов размеров, кроме угловых
DIMLWD | Вес для размерных линий
DIMLWE | Вес для выносных линий
DIMPOST | Определяемое пользователем окончание размерного текста
DIMRND | Точность округления всех линейных размеров
DIMSAH | Управление использованием блоков размерных стрелок
DIMSCALE | Глобальный масштабный коэффициент, применяемый ко всем размерным переменным, за исключением допусков, измеренных длин, координат и углов
DIMSD1 | Режим подавления первой размерной линии
DIMSD2 | Режим подавления второй размерной линии
DIMSE1 | Режим подавления первой выносной линии
DIMSE2 | Режим подавления второй выносной линии
DIMSHO | Режим изменения размерных объектов при отслеживании
DIMSOXD | Подавление изображения размерной линии за пределами соответствующих выносных линий
DIMSTYLE | Текущий размерный стиль
DIMTAD | Режим вертикальности текста относительно размерной линии
DIMTDEC | Количество десятичных знаков для значений допусков в основных единицах
DIMTFAC | Масштабный коэффициент для расчета высоты текста дробных частей размеров и допусков
DIMTIH | Режим ориентации размерного текста для линейных размеров, радиусов и диаметров, если текст вписывается между выносными линиями
DIMTIX | Режим принудительного размещения размерного текста между выносными линиями
DIMTM | Нижнее предельное отклонение или наименьший предельный размер, если системные переменные DIMTOL или DIMLIM включены
DIMTMOVE | Правила перемещения размерного текста при редактировании
DIMTOFL | Режим рисования размерной линии между выносными линиями, если стрелки размещаются вне выносных линий
DIMTOH | Режим ориентации размерного текста вне выносных линий
DIMTOL | Код простановки допусков в основных размерах
DIMTOLJ | Выравнивание допусков относительно размерного текста по вертикали
DIMTP | Верхнее предельное отклонение или наибольший предельный размер, если системные переменные DIMTOL или DIMLIM включены
DIMTSZ | Величина засечки, изображаемой вместо стрелки в линейных размерах, радиусах и диаметрах
DIMTVP | Регулировка вертикального положения размерного текста над или под размерной линией
DIMTXSTY | Текстовый стиль для размера
DIMTXT | Высота размерного текста, если используемый текстовый стиль не имеет фиксированную высоту
DIMTZIN | Режим подавления нулей в допусках
DIMUNIT | Устаревшая переменная (заменена на DIMLUNIT и DIMFRAC)
DIMUPT | Режим действия курсора при пользовательском расположении текста
DIMZIN | Режим подавления нулей в основных единицах измерения
DISPSILH | Режим показа кромок силуэта твердотельных объектов в каркасном режиме
DISTANCE | Последнее расстояние, вычисленное командой DIST
DONUTID | Последний внутренний диаметр кольца
DONUTOD | Последний внешний диаметр кольца
DRAGMODE | Режим отображения объектов при буксировке
DRAGP1 | Частота регенерации объекта при отслеживании
DRAGP2 | Частота регенерации объекта при быстром отслеживании
DWGCHECK | Код необходимости проверки, редактировался ли рисунок в последний раз программой, отличной от AutoCAD
DWGCODEPAGE | Хранит то же значение, что и SYSCODEPAGE (для целей совместимости)
DWGNAME | Имя текущего рисунка
DWGPREFIX | Путь к текущему рисунку
DWGTITLED | Код, определяющий, присвоено ли текущему рисунку имя
E
EDGEMODE | Режим удлинения объектов, выбранных в качестве режущих и граничных кромок в командах TRIM и EXTEND
ELEVATION | Действующий уровень (смещение по текущей оси Z) построения объектов в текущем видовом экране
ENTEXTS | Код точности вычисления границ примитивов
EXPERT | Режим сложности выводимых подсказок
EXPLMODE | Режим возможности расчленения командой EXPLODE блоков с разными масштабными коэффициентами
EXTMAX | Правая верхняя точка, в МСК, границ рисунка в текущем пространстве
EXTMIN | Левая нижняя точка, в МСК, границ рисунка в текущем пространстве
EXTNAMES | Код ограничений имен элементов символьных таблиц (типов линий, слоев и др.)
F
FACETRATIO | Режим плотности сетевого представления лекальных граней тел
FACETRES | Регулировка гладкости раскрашенных и тонированных объектов, а также объектов с подавленными скрытыми линиями
FILEDIA | Режим использования диалоговых окон выбора файлов
FILLETRAD | Текущий радиус сопряжения
FILLMODE | Режим закраски мультилиний, полос, фигур, всех штриховок (в том числе сплошных) и полилиний ненулевой ширины
FONTALT | Имя файла альтернативного шрифта
FONTMAP | Имя файла подстановки шрифтов
FRONTZ | Смещение передней секущей плоскости для текущего видового экрана
FULLOPEN | Индикатор полного или частичного открытия текущего рисунка
G
GFANG | Угол градиентной заливки
GFCLR1 | Первый цвет градиентной заливки
GFCLR2 | Второй цвет градиентной заливки
GFCLRLUM | Соотношение между светом и тенью в градиентной заливке
GFCLRSTATE | Признак использования одного или двух цветов в градиентной заливке
GFNAME | Номер образца градиентной заливки
GFSHIFT | Признак смещения центра заливки
GRIDMODE | Код состояния режима GRID
GRIDUNIT | Размер ячейки сетки на текущем видовом экране по осям X и Y
GRIPBLOCK | Режим показа ручек внутри блоков
GRIPCOLOR | Цвет невыбранных ручек
GRIPHOT | Цвет выбранных ручек
GRIPHOVER | Цвет невыбранной ручки при положении над ней курсора
GRIPOBJLIMIT | Максимальное количество одновременно показываемых ручек
GRIPS | Режим показа ручек выбранных объектов
GRIPSIZE | Размер ручки (в пикселах)
GRIPTIPS | Режим вывода подсказок при положении курсора над невыбранной ручкой
Н
HALOGAP | Допуск на размеры видимых объектов для команды HIDE
HANDLES | Режим присвоения меток объектам
HIDEPRECISION | Режим точности скрытия невидимых линий и раскрашивания
HIDETEXT | Режим обработки текстов командой HIDE
HIGHLIGHT | Режим подсветки объектов при выборе
HPANG | Угол наклона образца штриховки по умолчанию
HPASSOC | Режим ассоциативности штриховок и заливок
HPBOUND | Код типа объекта, создаваемого командами ВНАТСН и BOUNDARY
HPDOUBLE | Режим двойного штрихования (крест-накрест)
HPNAME | Имя образца штриховки по умолчанию
HPSCALE | Масштаб штриховки по умолчанию
HPSPACE | Расстояние между штриховыми линиями по умолчанию для пользовательских штриховок
HYPERLINKBASE | Путь, используемый для относительных гиперссылок
I
IMAGEHLT | Режим подсветки растровых изображений при выборе
INDEXCTL | Режим создания слоевого и пространственного индексов
INETLOCATION | Начальный URL-адрес браузера
INSBASE | Базовая точка вставки, устанавливаемая командой BASE
INSNAME | Имя блока по умолчанию для команды INSERT
INSUNITS | Единицы измерения для блоков и растровых изображений, вставляемых из Центра управления
INSUNITSDEFSOURCE | Единицы измерения в файле-источнике
INSUNITSDEFTARGET | Единицы измерения в целевом рисунке
INTERSECTIONCOLOR | Цвет линий пересечения сетей
INTERSECTIONDISPLAY | Признак отображения линий пересечения сетей при раскрашивании и скрытии невидимых линий
ISAVEBAK | Режим создания резервной копии рисунка (с расширением Ьак)
ISAVEPERCENT | Размер неиспользуемого пространства внутри рисунка, при превышении которого выполняется полное сохранение
ISOLINES | Число образующих на криволинейных участках поверхности объекта
L
LASTANGLE | Конечный угол последней построенной дуги
LASTPOINT | Последняя указанная точка в текущей ПСК
LASTPROMPT | Последний текст, выведенный в командную строку
LAYOUTREGENCTL | Режимы регенерации изображения на вкладках листов
LENSLENGTH | Фокусное расстояние (в миллиметрах) при построении перспективной проекции в текущем видовом экране
LIMCHECK | Режим проверки выхода за лимиты рисунка
LIMMAX | Правый верхний угол зоны лимитов рисунка, в МСК
LIMMIN | Левый нижний угол зоны лимитов рисунка, в МСК
LISPINIT | Режим сохранения в памяти функций и переменных (LISP-символов) при открытии нового рисунка (в одно-документном режиме)
LOCALE | Код ISO языка текущей версии AutoCAD
LOCALROOTPREFIX | Путь к папке, используемой для хранения настроек пользователя
LOGFILEMODE | Режим записи содержимого текстового окна в файл журнала (с расширением log)
LOGFILENAME | Имя файла журнала (вместе с путем) для текущего рисунка
LOGFILEPATH | Путь к файлам журналов всех рисунков сеанса
LOGINNAME | Системное имя пользователя
LTSCALE | Глобальный масштаб типов линии
LUNITS | Система измерения линейных единиц
LUPREC | Точность отображения линейных величин
LWDEFAULT | Значение, соответствующее весу линии DEFAULT
LWDISPLAY | Режим отображения весов линий на экране
LWUNITS | Единицы измерения для весов линий (дюймы или миллиметры)
M
MAXACTVP | Максимальное количество видовых экранов, которые могут быть активны одновременно
MAXSORT | Максимальное количество строк, которое можно отсортировать в диалоговых окнах при выводе списков (слоев и т. п.)
MBUTTONPAN | Режим действия третьей кнопки или колесика устройства указания (например, мыши)
MEASUREINIT | Система единиц (британские или метрические) для новых рисунков
MEASUREMENT | Система единиц (британские или метрические) для текущего рисунка
MENUCTL | Режим смены страниц экранного меню
MENUECHO | Сумма битовых флагов управления эхо-выводом и запросами меню
MENUNAME | Имя файла базового меню (включая путь)
MIRRTEXT | Режим симметрирования текста в команде MIRROR
MODEMACRO | Дополнительный текст, отображаемый в начале строки состояния
MTEXTED | Имя редактора (встроенного или внешнего), используемого командой МТЕХТ
MTEXTFIXED | Управление местоположением окна редактора мультитекста
MTJIGSTRING | Текст, "привязываемый" к курсору при входе в окно мультитекста
MYDOCUMENTSPREFIX | Путь к папке Мои документы текущего пользователя
N
NOMUTT | Режим полного подавления сообщений в командной строке при работе пакетов и функций AutoLISP
О
OBSCUREDCOLOR | Цвет, устанавливаемый для невидимых линий
OBSCUREDLTYPE | Тип линии, устанавливаемый для невидимых линий
OFFSETDIST | Текущее смещение в команде OFFSET
OFFSETGAPTYPE | Метод обработки соединений соседних сегментов командой OFFSET
OLEHIDE | Режим показа и печати OLE-объектов
OLEQUALITY | Режим качества и печати внедренных OLE-объектов
OLESTARTUP | Режим загрузки родительских приложений для OLE-объектов при печати
ORTHOMODE | Текущее состояние режима ортогональности
OSMODE | Сумма битовых флагов текущих режимов объектной привязки
OSNAPCOORD | Режим подавления вводимыми координатами текущих режимов привязки
P
PALETTEOPAQUE | Управление прозрачностью окон и палитр
PAPERUPDATE | Режим вывода предупреждения при несоответствии размеров листа формату печати
PDMODE | Текущий режим отображения точек
PDSIZE | Размер символа, отображающего точку
PEDITACCEPT | Автоматическое преобразование выбранного объекта в полилинию в команде PEDIT
PELLIPSE | Режим рисования эллипсов (точных или аппроксимированных)
PERIMETER | Последнее вычисленное значение периметра
PFACEVMAX | Максимальное число вершин на одну грань в команде PFACE
PICKADD | Режим добавления объектов к уже выбранным
PICKAUTO | Режим автоматического создания рамки выбора при щелчке мышью по свободному месту
PICKBOX | Высота прицела выбора объектов в пикселах
PICKDRAG | Способ создания рамки выбора
PICKFIRST | Режим предварительного выбора объектов, для их использования в следующей команде
PICKSTYLE | Режим выбора объектов с помощью групп и с помощью ассоциативной штриховки
PLATFORM | Тип платформы (операционной системы)
PLINEGEN | Режим генерации типа линии в вершинах двумерных полилиний
PLINETYPE | Управление типом создаваемых двумерных полилиний (компактных или подробных)
PLINEWID | Ширина двумерной полилинии по умолчанию
PLOTROTMODE | Ориентация чертежа
PLQUIET | Управление выводом необязательных диалоговых окон и сообщений о некритических ошибках при пакетной печати и выполнении пакетных файлов
POLARADDANG | Дополнительные углы полярного отслеживания
POLARANG | Основной угол при полярном отслеживании
POLARDIST | Шаг полярной привязки
POLARMODE | Управление режимами полярного и объектного отслеживания
POLYSIDES | Число сторон многоугольника, предлагаемое по умолчанию командой POLYGON
POPUPS | Код состояния видеомонитора
PRODUCT | Название программного продукта
PROGRAM | Имя основного файла программы
PROJECTNAME | Имя проекта, в котором ищутся внешние ссылки и растровые изображения
PROJMODE | Режим проецирования для операций обрезки и удлинения
PROXYGRAPHICS | Режим сохранения объектов-заместителей в рисунке
PROXYNOTICE | Режим вывода сообщения при создании объекта-заместителя
PROXYSHOW | Режим показа объектов-заместителей в рисунке
PROXYWEBSEARCH | Режим поиска программы Object Enabler для обработки объектов-заместителей
PSLTSCALE | Режим масштабирования типов линий в пространстве листа
PSPROLOG | Имя раздела файла acad.psf, который нужно прочитать команде PSOUT
PSQUALITY | Управление качеством отображения изображений формата PostScript
PSTYLEMODE | Тип стилей печати (цветозависимые или именованные) в текущем рисунке
PSTYLEPOLICY | Режим связи цвета объекта с его стилем печати
PSVPSCALE | Масштаб для вновь создаваемых видовых экранов
PUCSBASE | Имя ПСК, на которой базируются ортогональные системы координат (только для пространства листа)
Q
QTEXTMODE | Режим быстрого (контурного) отображения текста
R
RASTERPREVIEW | Режим сохранения вместе с рисунком растрового образца для предварительного просмотра
REFEDITNAME | Имя внешней ссылки или блока, редактируемого в данный момент командой REFEDIT
REGENMODE | Режим автоматической регенерации рисунка
RE-INIT | Сумма битовых флагов переинициализации дигитайзера, его порта и перезагрузки файла acad.pgp
REMEMBERFOLDERS | Режим запоминания путей к файлам рисунков
REPORTERROR | Управление выводом сообщения о возможности отправки уведомления об ошибке в фирму Autodesk
ROAMABLEROOTPREFIX | Путь к папке, позволяющей поддерживать поиск файлов в сети
RTDISPLAY | Управление показом растровых изображений при панорамировании и зумировании в реальном времени (команды ZOOM и PAN)
S
SAVEFILE | Имя файла автоматического сохранения
SAVEFILEPATH | Путь к папке, в которую осуществляется автоматическое сохранение файлов сеанса AutoCAD
SAVENAME | Имя файла, под которым сохранен текущий рисунок (вместе с путем)
SAVETIME | Интервал автоматического сохранения рисунка в минутах
SCREENBOXES | Количество строк в зоне экранного меню графического экрана
SCREENMODE | Битовый код, указывающий состояние экрана AutoCAD (графический, текстовый)
SCREENSIZE | Размер текущего видового экрана в пикселах (по осям ХиУ)
SDI | Режим AutoCAD (одно- или многодокументный)
SHADEDGE | Режим показа ребер и граней при тонировании
SHADEDIF | Код отношения рассеянной освещенности к освещенности диффузного отражения
SHORTCUTMENU | Режим доступа к контекстным меню
SHPNAME | Имя формы по умолчанию
SIGWARN | Код вывода окна с информацией об электронной цифровой подписи
SKETCHING | Длина сегментов в команде SKETCH
SKPOLY | Режим генерации отрезков или полилиний в команде SKETCH
SNAPANG | Угол поворота сетки шаговой привязки (в текущей ПСК) для текущего видового экрана
SNAPBASE | Начальная точка сетки шаговой привязки для текущего видового экрана (в текущей ПСК)
SNAPISOPAIR | Код текущей плоскости изометрии для текущего видового экрана
SNAPMODE | Текущее состояние режима SNAP
SNAPSTYL | Стиль шаговой привязки на текущем видовом экране
SNAPTYPE | Тип шаговой привязки
SNAPUNIT | Параметры сетки шаговой привязки в текущем видовом экране
SOLIDCHECK | Режим проверки целостности тел
SORTENTS | Режим сортировки объектов
SPLFRAME | Режим отображения каркасов сплайнов, сглаженных сплайнами полилиний и сглаженных сетей
SPLINESEGS | Код управления аппроксимацией полилинии при сглаживании ее сплайном
SPLINETYPE | Тип сглаживающей кривой в опции Spline команды PEDIT
STANDARDSVIOLATION | Режим вывода уведомлений о нарушении стандартов при нормоконтроле
STARTUP | Управление типом окна при создании новых рисунков
SURFTAB1 | Плотность в направлении М для команд построения сетей
SURFTAB2 | Плотность в направлении N для команд построения сетей
SURFTYPE | Тип поверхности сглаживания, которая используется опцией Smooth команды PEDIT
SURFU | Плотность сети в направлении М для опции Smooth команды PEDIT
SURFV | Плотность сети в направлении N для опции Smooth команды PEDIT
SYSCODEPAGE | Системная кодовая таблица, заданная в файле acad.xmx
Т
TABMODE | Управление использованием режима Tablet
TARGET | Положение цели в координатах ПСК на текущем видовом экране
TDCREATE | Дата и время (местное) создания текущего рисунка
TDINDWG | Общее время редактирования
TDUCREATE | Дата и время (всемирное) создания текущего рисунка
TDUPDATE | Дата и время (местное) последнего сохранения рисунка
TDUSRTIMER | Таймер пользователя
TDUUPDATE | Дата и время (всемирное) последнего сохранения рисунка
TEMPPREFIX | Имена папок для хранения временных файлов
TEXTEVAL | Режим обработки LISP-выражений при запросе текста
TEXTFILL | Режим заливки текста, выполненного шрифтами True Туре, при печати, экспорте командой PSOUT и тонировании
TEXTQLTY | Качество начертания шрифтов True Type при выводе текстов на печать, экспорте командой PSOUT и тонировании
TEXTSIZE | Высота букв, предлагаемая по умолчанию для нового однострочного текста
TEXTSTYLE | Текущий текстовый стиль
THICKNESS | Текущая трехмерная высота
TILEMODE | Режим пространства листа или модели
TOOLTIPS | Управление выводом всплывающих подсказок
TPSTATE | Код видимости панели Tool Palettes
TRACEWID | Ширина полосы по умолчанию
TRACKPATH | Управление показом пунктирных линий при полярном и объектном отслеживании
TRAYICONS | Управление показом значков уведомлений
TRAYNOTIFY | Управление выводом уведомлений
TRAYTIMEOUT | Длительность показа уведомлений
TREEDEPTH | Максимальная глубина ветвления пространственного индекса
TREEMAX | Максимальное количество узлов в пространственном индексе
TRIMMODE | Режим изменения выбранных объектов в командах CHAMFER и FILLET
TSPACEFAC | Отношение межстрочного интервала к высоте многострочного текста
TSPACETYPE | Стиль межстрочного интервала в многострочном тексте
TSTACKALIGN | Выравнивание двухэтажного элемента мультитекста по вертикали
TSTACKSIZE | Отношение высоты дробной части двухэтажного текста к высоте обычного текста (в процентах)
U
UCSAXISANG | Значение угла по умолчанию при повороте ПСК вокруг одной из ее осей с помощью опций X, Y или Z команды UCS
UCSBASE | Имя ПСК, на которой базируются ортогональные системы координат
UCSFOLLOW | Установка вида в плане при переходе от одной ПСК к другой
UCSICON | Включение видимости пиктограммы ПСК на текущем видовом экране
UCSNAME | Имя текущей системы координат для текущего видового экрана в текущем пространстве
UCSORG | Начало текущей системы координат для текущего видового экрана в текущем пространстве
UCSORTHO | Режим восстановления ортогональной ПСК в момент установки соответствующего ортогонального вида
UCSVIEW | Режим сохранения текущей ПСК вместе с именованным видом
UCSVP | Режим изменения ПСК на видовых экранах вслед за системой координат, установленной на текущем видовом экране
UCSXDIR | Направление оси X текущей ПСК на текущем видовом экране в текущем пространстве
UCSYDIR | Направление оси Y текущей ПСК на текущем видовом экране в текущем пространстве
UNDOCTL | Сумма битовых флагов, указывающих состояние Auto и Control команды UNDO
UNDOMARKS | Количество меток, заданных в опции Mark команды UNDO для управления отменой
UNITMODE | Режим отображения чисел с дробной частью, в футах и дюймах и в топографических единицах
USERI1 (2-5) | Используются для хранения целых чисел, заданных пользователем
USERR1 (2-5) | Используются для хранения вещественных чисел, заданных пользователем
USERS1 (2-5) | Используются для хранения текстовых данных пользователя
V
VIEWCTR | Центр текущего видового экрана в координатах ПСК
VIEWDIR | Направление взгляда на текущем видовом экране, вМСК
VIEWMODE | Битовый код режима вида на текущем видовом экране
VIEWSIZE | Высота изображения на текущем видовом экране
VIEWTWIST | Угол поворота вида для текущего видового экрана
VISRETAIN | Управление видимостью, цветом, типом линии, весом линии и стилями печати (если PSTYLEPOLICY равна 0) зависимых от внешних ссылок слоев, а также сохранением путей доступа для вложенных ссылок
VSMAX | Правый верхний угол виртуального экрана текущего видового экрана, выраженный в координатах ПСК
VSMIN | Левый нижний угол виртуального экрана текущего видового экрана, выраженный в координатах ПСК
W
WHIPARC | Режим гладкости кругов и дуг на экране
WHIPTHREAD | Режим проверки наличия дополнительных процессоров
WMFBKGND | Режим фона рисунка при экспорте в метафайл Windows
WMFFOREGND | Режим назначения цвета при экспорте в метафайл
WORLDUCS | Индикатор совпадения текущей ПСК с МСК
WORLDVIEW | Код ПСК, используемой в командах установки видов
WRITESTAT | Указывает, открыт ли текущий файл рисунка только для чтения
X
XCLIPFRAME | Видимость контуров подрезки внешних ссылок и блоков
XEDIT | Индикатор, может ли текущий рисунок участвовать в операции редактирования вхождений, будучи вставленным в другой рисунок как внешняя ссылка
XFADECTL | Управление снижением интенсивности отображения объектов при редактировании вхождений
XLOADCTL | Управление загрузкой файлов внешних ссылок и их копий
XLOADPATH | Путь для хранения временных копий файлов подгруженных внешних ссылок
XREFCTL | Определяет, создаются ли файлы журналов внешних ссылок
XREFNOTIFY | Режим уведомления о неразрешенных внешних ссылках
Z
ZOOMFACTOR | Управление скоростью перемещения курсора

Названия системных переменных, появившихся в системе AutoCAD 2004:

CLEARSCREENSTATE | INTERSECTIONCOLOR | STARTUP
GFANG | INTERSECTIONDISPLAY | TPSTATE
GFCLR1 | LOCALROOTPREFIX | TRAYICONS
GFCLR2 | MTEXTFIXED | TRAYNOTIFY
GFCLRLUM | MTJIGSTRING | TRAYTIMEOUT
GFCLRSTATE | MYDOCUMENTSPREFIX | TSPACETYPE
GFNAME | PALETTEOPAQUE | XREFNOTIFY
GFSHIFT | PEDITACCEPT |
GRIPHOVER | REPORTERROR |
GRIPOBJLIMIT | ROAMABLEROOTPREFIX |
GRIPTIPS | SIGWARN |
HPASSOC | STANDARDSVIOLATION |

Названия системных переменных, которые присутствовали в системе AutoCAD 2002, но исключены из версии AutoCAD 2004:

PLOTID
PLOTTER
STARTUPTODAY


Приложение 3. Операции с сетью Интернет

    • Операции с сетью Интернет
    • Публикация в Интернете
    • Настройка уведомлений


Система AutoCAD 2004 обеспечивает работу с сетью Интернет. Необходимо, чтобы на вашем компьютере был установлен браузер (Microsoft Internet Explorer версии не ниже 6.0). Можно читать файлы со страниц в Интернете (Web-страниц), сохранять файлы на страницах Интернета (в специальном формате DWF), формировать Web-страницы и вставлять гиперссылки на URL-адреса. Регистрация системы AutoCAD после установки выполняется через Интернет.
Операции обычного доступа к Интернету обеспечивает панель инструментов Web (рис. П3.1).

Рис. П3.1. Панель инструментов Web

В этой панели расположены четыре кнопки для обеспечения работы с сетью Интернет:

  • — возврат к предыдущему документу (странице) по гиперссылке;
  • — переход к следующему документу (странице) по гиперссылке;
  • — прекращение навигации по страницам;
  • — вызов установленной на компьютере программы-браузера для навигации в Интернете (Microsoft Internet Explorer).

Кнопка [image] соответствует команде BROWSER (БРАУЗЕР). При первом щелчке по этой кнопке AutoCAD вызывает ваш браузер и пытается загрузить страницу с адресом по умолчанию (www.autodesk.com). При успешном соединении с сетью Интернет появляется Web-страница фирмы Autodesk.
Если ввести в командной строке команду BROWSER (БРАУЗЕР), то система AutoCAD выдаст запрос:
Enter Web location (URL): (Введите Web-адрес (URL):)
Здесь тоже нужно ввести требуемый адрес, после чего система пытается с ним соединиться.
В примитивах рисунка в качестве гиперссылок (см. разд. 4.5) можно использовать ссылки на Web-страницы. Команда GOTOURL, вводимая из командной строки, позволяет перейти по адресу, который указан в качестве гиперссылки.
Для удобства хранения на Web-сервере файлов рисунков был создан специальный формат DWF, сохранение рисунков в котором обеспечивается командой PUBLISH (см. разд. 11.4.5).


Публикация в Интернете

Другим средством публикации файлов рисунков в сети Интернет и генерации страниц в формате HTML является команда PUBLISHTOWEB (ОПУБЛИКОВАТЬ), которой соответствует пункт Publish to Web (Публикация в Интернете) падающего меню File (Файл).
Команда вызывает первую страницу (Begin (Начало)) окна программы-мастера работы с Web-страницами (рис. П3.2).

Рис. П3.2. Страница Begin окна Publish to Web

На этой странице нужно установить переключатель в одно из положений:

  • Create New Web Page (Создание новой Web-страницы);
  • Edit Existing Web Page (Редактирование существующей Web-страницы).

В первом случае вы получаете возможность создания файлов новой Web-страницы, во втором — редактирования ранее сформированной страницы.
Если выбран режим создания новой Web-страницы, то щелчок по кнопке Далее (Next) переводит вас на следующую страницу — Create Web Page (Создание Web-страницы) (рис. ПЗ.З). Если же выбрать режим редактирования существующей Web-страницы, то вы попадете сначала на страницу Edit Existing Web Page (Редактирование существующей Web-страницы), затем на страницу Describe Web Page (Описание Web-страницы). На этих страницах вам будет предоставлена возможность сначала выбрать ранее созданную Web-страницу, а затем — внести в нее изменения.

Рис. ПЗ.З. Страница Create Web Page окна Publish to Web

На странице Create Web Page (Создание Web-страницы) нужно заполнить три поля. В верхнем вводится имя вашей Web-страницы (например, Steel). В втором поле необходимо указать путь к папке, в которой будут сохранены файлы Web-страницы. По умолчанию AutoCAD предлагает путь к папке, в которой сохраняются настройки текущего пользователя (c:\Documents and Settings\...). С помощью щелчка по кнопке [image] можно открыть окно поиска и в этом окне выбрать другую существующую на компьютере папку (например, d:\Temp), к которой система добавит имя папки, совпадающее с именем страницы (d:\Temp\Steel). В нижнем поле рекомендуется задать описание к создаваемой Web-странице.
Следующее окно Мастера — Select Image Type (Выбор типа изображения) (рис. П3.4) — предназначено для указания формата графических файлов.

Рис. П3.4. Страница Select Image Type окна Publish to Web

В первом из раскрывающихся списков необходимо выбрать формат, в котором вы хотите разместить свой рисунок: DWF, JPEG или PNG (формат PNG используется для формирования растровых образцов рисунков AutoCAD). Для двух последних форматов (JPEG и PNG) становится доступным и второй список — Image size (Размер изображения), в котором следует выбрать строку, управляющую размером (и, значит, степенью сжатия): Small (Маленький), Medium (Средний), Large (Большой), Extra Large (Сверхбольшой).
Очередное окно — Select Template (Выбор шаблона) (рис. П3.5) задает форму Web-страницы.
Пользователю предлагаются четыре варианта шаблона:

  • Array of Thumbnails (Массив образцов);
  • Array plus Summary (Массив образцов с пояснениями);
  • List of Drawings (Список рисунков);
  • List plus Summary (Список рисунков с пояснениями).

Внешний вид всех вариантов шаблона приведен на рис. П3.6.
После указания варианта шаблона пользователь попадает в окно выбора темы (рис. П3.7).

Рис. П3.5. Страница Select Template окна Publish to Web

Рис. П3.6. Шаблоны Web-страницы

Рис. П3.7. Страница Apply Theme окна Publish to Web

Под темой (theme) в данном окне подразумевается цветовое и шрифтовое оформление. Пользователю доступны следующие темы:

  • Autumn Field (Осеннее поле);
  • Classic (Классика);
  • Cloudy Sky (Облачное небо);
  • Dusky Maize (Темная кукуруза);
  • Ocean Waves (Океанские волны);
  • Rainy Day (Дождливый день);
  • Supper Club (Вечерний клуб).

Далее идет страница Enable i-drop (Разрешить загрузку) (рис. П3.8).

Рис. П3.8. Страница Enable i-drop окна Publish to Web

Если вы установите в этом окне флажок Enable i-drop (Разрешить загрузку), то на вашу Web-страницу вместе с растровыми образцами будут помешены DWG-файлы, которые любой посетитель сайта сможет загрузить в свой сеанс работы AutoCAD простым перетаскиванием.
Страница Select Drawings (Выбор рисунков) (рис. П3.9) имеет область Image settings (Параметры рисунков), которая позволяет выбрать файл (раскрывающийся список Drawing (Рисунок)), указать имя нужной вкладки (раскрывающийся список Layout (Вкладка)), задать метку изображения (поле Label (Метка)) и комментарий (поле Description (Описание)). Метки выбранных рисунков помещаются в результирующий список (область Image list (Список изображений)) с помощью кнопки Add (Добавить). Для редактирования списка могут применяться кнопки Update (Изменить), Remove (Удалить), Move Up (Вверх), Move Down (Вниз).

Рис. П3.9. Страница Select Drawings окна Publish to Web

Следующая страница — Generate Images (Генерация изображений) (рис. П3.10) — управляет процессом генерации изображений.

Рис. П3.10. Страница Generate Images окна Publish to Web

На этой странице нужно выбрать одно из двух положений переключателя:

  • Regenerate images for drawings that have changed (Регенерировать изображения для изменившихся рисунков);
  • Regenerate all images (Регенерировать все изображения).

В зависимости от выбора пользователя графические изображения будут пересчитаны либо частично (только для изменившихся рисунков), либо полностью.

Рис. П3.11. Страница Preview and Post окна Publish to Web

Последняя страница программы-мастера — Preview and Post (Просмотр и размещение) (рис. П3.11) — сообщает о формировании файлов Web-страницы. Пользователю доступны кнопки:

  • Preview (Просмотр) — позволяет просмотреть созданную Web-страницу (рис. П3.12);
  • Post Now (Разместить) — позволяет выгрузить свою страницу на сервер сети Интернет;
  • Send Email (Послать сообщение по электронной почте) — формирует письмо электронной почты со ссылкой на адрес своей страницы.

Щелчок по кнопке Готово (Done) завершает работу с мастером создания Web-страницы. Результаты сохраняются в виде группы файлов, в которой основным является файл acwebpublish.htm (в примере на рис. П3.12 он открыт с помощью браузера).
Режим редактирования существующей Web-страницы работает аналогично.

Рис. П3.12. Пример Web-страницы, созданной командой PUBLISHTOWEB


Настройка уведомлений

Из сети Интернет можно получать уведомления об обновлениях продуктов фирмы Autodesk. Для этого в строке состояния должен присутствовать значок [image] .
Тогда система AutoCAD с заданным интервалом пытается соединиться с сайтом фирмы Autodesk и получить информацию об обновлениях. Если значка [image] нет, то следует выполнить команду TRAYSETTINGS (русское наименование команды в момент написания книги не известно) или вызвать контекстное меню настройки строки состояния (см. рис. 2.16) и в нем выбрать пункт Tray Settings (Настройки лотка). Откроется диалоговое окно Tray Settings (Настройки лотка) (рис. П3.13).
В этом окне только установка флажка Display icons from services (Показывать значки служб) разрешает размещение в области уведомлений панели задач значков различных служб. Если при этом установить еще и флажок Display notifications from services (Показывать уведомления служб), то появится значок [image] .

Рис. П3.13. Диалоговое окно Tray Settings

В нижней части диалогового окна Tray Settings (Настройки лотка) расположены два переключателя, управляющие временем, на которое задерживаются на экране уведомления служб:

  • Display time (Показ в течение установленного времени) — задает конкретное время, на которое выводится окно уведомления; само время необходимо установить в раскрывающемся списке справа (от одной до десяти секунд);
  • Display until closed (Показ до закрытия) — задает неограниченное время показа уведомления (до тех пор пока пользователь сам не закроет окно уведомления).

Щелчок по значку [image] позволяет вызвать диалоговое окно Communication Center (Центр связи) (рис. П3.14), управляемое мастером Welcome (Добро пожаловать).

Рис. П3.14. Диалоговое окно Communication Center

В этом окне расположены три флажка, порядок которых соответствует последовательности шагов настройки:

  • Specify your country and preferred update frequency (Указать страну и частоту обновления) — вызывает диалоговое окно Configuration Settings (Параметры конфигурации) (рис. П3.15), рассматриваемое далее;
  • Connect to the Internet and download available information (Соединиться с Интернетом и получить доступную информацию) — выполняет соединение с Интернетом и выводит соответствующее окно уведомления:
  • Specify which information channels you wish to view (Указать каналы, которые вы хотите просматривать) — позволяет задать каналы, информацию которых нужно получать.

Рис. П3.15. Диалоговое окно Configuration Settings

В диалоговом окне Configuration Settings (Параметры конфигурации) (см. рис. ПЗ. 15) расположены три области, отвечающие за настройку уведомлений:

  • Country (Страна) — задается страна, по которой ищется информация для уведомлений;
  • Check for New Content (Проверить новое содержание) — выполняется повторная проверка информации;
  • Balloon Notification (Уведомление в форме воздушного шара) — уведомления генерируются над панелью задач в виде окон, имеющих желтый фон и форму, похожую на форму воздушного шарика.

Кнопки Refresh Content (Обновить содержание) и Settings (Настройки) диалогового окна Communication Center (Центр связи) (см. рис. П3.14) позволяют, соответственно, освежить содержание окон уведомлений и вызвать окно Configuration Settings (Параметры конфигурации) (см. рис. П3.15). Кроме того, через свой сайт www.autodesk.com фирма Autodesk оказывает различные услуги пользователям системы AutoCAD (доступ к библиотекам символов, ответы на вопросы и т. п.).


Приложение 4. Сопутствующие программные продукты

    • Сопутствующие программные продукты
    • AutoCAD LT и аналогичные продукты
    • Машиностроительные приложения
    • Архитектурно-строительные приложения
    • Геоинформационные системы
    • Программы обработки сканированных изображений
    • Системы документооборота


Система AutoCAD стала средой для разработки большого количества специализированных программных комплексов для многих отраслей. В числе разработчиков таких пакетов, использующих различные версии системы AutoCAD, в том числе и AutoCAD как графическую среду, можно назвать саму фирму Autodesk (США), а также фирмы: Consistent Software (Норвегия), Интермех (Белоруссия), АПИО-Центр (Москва), ANSYS (США) и др.
В данном приложении перечислены некоторые из наиболее распространенных программных продуктов, которые успешно работают в среде AutoCAD или совместно с AutoCAD. Дополнительную информацию можно найти на сайтах фирмы Autodesk (www.autodesk.com) и ее партнеров (www.autocad.ru, www.esg.spb.ru и т. д.). Фирма Consistent Software издает специализированный журнал CADmaster, информация о котором находится на сайте www.cadmaster.ru.
Много полезного можно найти также на сайте пользователей CAD-систем республик бывшего СССР (www.cad.dp.ua).


AutoCAD LT и аналогичные продукты

Система AutoCAD LT (разработчик — фирма Autodesk) является облегченной версией AutoCAD, которая сохраняет все возможности двумерной работы и часть трехмерных операций, но в то же время значительно дешевле, чем основная система AutoCAD. Обычно выпускается на английском языке и локализуется частично.
Для каждой версии AutoCAD разработана соответствующая версия AutoCAD LT. Система AutoCAD LT 2004 может читать все файлы рисунков, созданные в AutoCAD 2004.
К недорогим продуктам аналогичного назначения можно отнести также AutoSketch и Actrix Technical (Autodesk).


Машиностроительные приложения

Фирма Autodesk создала мощный пакет для машиностроительного проектирования — Autodesk Mechanical Desktop, предназначенный для сложного трехмерного моделирования. Пакет обладает следующими возможностями, ускоряющими цикл разработки машиностроительных изделий и выпуска необходимой документации: трехмерное параметрическое моделирование твердых тел и сложных поверхностей, формирование деталей, узлов и конструкций, выпуск спецификаций и машиностроительных чертежей. Специальные функции этого пакета позволяют проектировать валы и пружины. Имеется библиотека стандартных деталей различных типов и стандартов, в том числе стандартов ГОСТ.
Пакет AutoCAD Mechanical (Autodesk) ориентирован на оформление машиностроительных чертежей. Он продается отдельно, но входит в состав Autodesk Mechanical Desktop Power Pack.
Фирмой Autodesk создан также машиностроительный пакет Autodesk Inventor, который превосходит по своим возможностям Autodesk Mechanical Desktop.
Фирма Consistent Software поставляет на российский рынок специализированные пакеты Mechanics, ElectriCS, HydrauliCS, Technologies.
Фирмой Интермех разработаны машиностроительные приложения, которые в большей степени ориентированы на рынок России и СНГ: Cadmech Desktop, Cadmech, AVS, Rotation, Gear, Spring, Search, Techcard, которые позволяют выполнять двумерное и трехмерное проектирование машиностроительных изделий, формирование баз данных, выпуск документации и ведение технических архивов.
Для проектирования деталей из листовых материалов предназначена система Copra Sheet Metal Bender Desktop (Data-M Software GmbH).
Моделирование динамики работы механизмов может выполняться в системе Dynamic Designer (Mechanical Dynamics).


Архитектурно-строительные приложения

В числе известных архитектурных и строительных приложений можно отметить системы АРКО (АПИО-Центр), СПДС GraphiCS (Consistent Software), ArchiCAD (Graphisoft), Autodesk Architectural Desktop (Autodesk), Autodesk Architectural Studio (Autodesk), Autodesk Building Systems (Autodesk), МАЭСТРО (Maestro Group), SCAD (SCAD Group).
Для проектирования промышленных объектов может использоваться система PLANT-4D (СЕА Technology).


Геоинформационные системы

Ряд геоинформационных и геодезических систем соседствуют с AutoCAD: AutoCAD MAP (Autodesk), Autodesk OnSite Enterprise (Autodesk), Autodesk MapGuide (Autodesk), Maplnfo (Maplnfo), AutoCAD Land Development Desktop (Autodesk), Autodesk Survey (Autodesk), Autodesk Civil Design (Autodesk), GeomatiCS (Consistent Software), PLATEIA (CGS Software).


Программы обработки сканированных изображений

Для обработки файлов со сканированными документами могут применяться такие системы: Spotlight (Consistent Software), Vectory (Consistent Software), RasterDesk (Consistent Software), Autodesk CAD Overlay (Autodesk).


Системы документооборота

Для ведения документооборота и создания электронных архивов в числе недорогих предлагаются такие системы, как Search (Интермех), Interbase (Интермех), Show (Интермех), OutdoCS (Consistent Software).


Предисловие

Представленная в настоящей книге новая версия широко распространенного графического пакета AutoCAD с номером 2004 (внутренний номер версии — 16) фирмы Autodesk (США) продолжает традиции, заложенные в предыдущих версиях, и ориентирована на специалистов разной квалификации — конструкторов, архитекторов, строителей, инженеров, техников, чертежников. Система AutoCAD применяется для оформления практически всей графической документации, выпускаемой в нашей стране в электронном виде. Формат DWG, используемый в системе, стал фактически всемирным стандартом. Кроме того, заказчики стали требовать от исполнителей создания трехмерной модели проектируемого изделия или сооружения. Все это объясняет непрерывно растущее значение системы AutoCAD. Данная книга использует те же принципы изложения материала, которые были предложены одним из авторов в самоучителях для предыдущих версий системы (AutoCAD 2000 и AutoCAD 2002). Книга предлагает читателям авторскую методику освоения системы, причем эта методика опирается на курс лекций, читаемых им.
В книге проводится сравнение AutoCAD 2004 с другими версиями системы, поэтому книга будет полезна и для тех, кто еще работает в более ранних версиях.
Перечислим основные отличия новой версии от AutoCAD 2002:

  • Выполнена внешняя и внутренняя интеграция системы AutoCAD с операционной системой Windows XP (Professional Edition и Home Edition).
  • Для работы с системой AutoCAD в операционных системах Windows 2000 и Windows XP больше не требуется наличие прав Power User, поскольку данные пользовательских профилей сохраняются теперь в папке Documents and Settings конкретного пользователя.
  • Введен новый, более компактный DWG-формат, который позволяет просматривать растровые образцы DWG-файлов в проводнике Windows, а также защищать паролем и цифровой подписью файлы рисунков.
  • Аннулировано окно AutoCAD Today (Проектный центр).
  • Появился новый элемент интерфейса — Tool Palettes (Палитры инструментов), который дает возможность быстрого доступа к часто используемым элементам пользователя (блокам, штриховкам и заливкам).
  • Появилась немодальная форма окон Properties (Свойства), Design Center (Центр управления), которые сворачиваются и легко раскрываются.
  • Добавлена возможность расширения графического экрана.
  • Введены новые панели Styles (Стили) и Draw Order (Порядок следования).
  • Список Layers (Слои) и кнопки операций над слоями выделены из панели инструментов Properties (Свойства) и стали самостоятельной панелью.
  • Количество используемых цветов увеличилось с 256 до 16 миллионов.
  • Появилась возможность печати раскрашенных и тонированных видовых экранов.
  • Введена возможность настройки строки режимов (убирать ненужные кнопки и восстанавливать нужные).
  • Значительно улучшены средства создания и редактирования многострочных текстов (в частности, введены позиции табуляции).
  • Появились градиентные заливки.
  • Улучшился механизм работы с файлами внешних ссылок.
  • Появилась возможность более тонкой настройки функций правой кнопки мыши, в зависимости от продолжительности щелчка.
  • Заметно упростилась процедура установки системы на компьютере.
  • Для инсталляции AutoCAD 2004 не требуется удалять с компьютера предыдущую версию AutoCAD (2002 или более раннюю).
  • Система AutoCAD 2004 не может быть установлена в среде операционной системы Windows 95.
  • AutoCAD 2004 работает в операционной системе Windows 98 с предварительно установленным Internet Explorer 6.0 и, видимо, в Windows Me, хотя официально не рассчитан на них. Дилеры Autodesk не принимают по ним вопросов. Начиная с AutoCAD 2004 фирма Autodesk полностью прекращает поддерживать в своих продуктах платформу Windows 98, 98SE, Me.

Книга имеет одиннадцать глав и четыре приложения. Первая глава дает общие сведения о назначении системы, требованиях, предъявляемых к компьютеру, на котором может быть установлена система AutoCAD. Описываются элементы пользовательского интерфейса. Во второй главе рассматриваются
основные объекты (примитивы), с которыми работает система, и создающие их команды. Третья и четвертая главы отражают способы редактирования геометрии и свойств (цветов, типов линий, весов, слоев, гиперссылок и т. п.).
Главы с пятой по восьмую посвящены вопросам работы с такими элементами, созданными пользователем, как стили, блоки, внешние ссылки, а также вопросам вывода рисунков на внешние устройства. Рассмотрены проблемы взаимосвязи с другими приложениями под Windows (Microsoft Word, Microsoft Excel и др.).
В девятой главе пользователь знакомится с методами построения трехмерных объектов и визуализации объемных моделей. Десятая глава анализирует проблемы пространства модели и пространства листа, а также средства получения чертежа по трехмерной модели. В одиннадцатой главе рассмотрены вопросы адаптации системы AutoCAD.
Приложения дополняют основной материал книги и содержат следующую справочную информацию: команды, системные переменные, особенности работы с использованием Интернета, описание дополнительного меню Express, сопутствующие программные продукты.
В качестве базовой версии для изложения материала в книге принята англоязычная версия системы AutoCAD. Везде в скобках приводятся русские аналоги терминов. Имена команд и системных переменных даются в книге заглавными буквами (LINE, CIRCLE, ARRAY, TILEMODE, CLAYER и т.д.). В наименованиях диалоговых окон, кнопок инструментов, пунктов меню использован полужирный шрифт. Английские сообщения системы даются полужирным курсивом, русские аналоги — в скобках, курсивом без полужирного начертания.